Guía de Configuración de Multiprotocol Label Switching de Cisco IOS, Release 12.2SR
¿VRF CLI del MPLS VPN para el IPv4 y el IPv6 VPN
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 262 KB | Inglés (6 Septiembre 2011) | Comentarios

Contenidos

MPLS VPN — VRF CLI for IPv4 and IPv6 VPNs

Encontrar la información de la característica

Contenido

Prerrequisitos de MPLS VPN - VRF CLI for IPv4 and IPv6 VPNs

Restricciones de MPLS VPN — VRF CLI for IPv4 and IPv6 VPNs

Información sobre MPLS VPN — VRF CLI for IPv4 and IPv6 VPNs

Conceptos VRF Similares para VPNs MPLS IPv4 e IPv6

Migración de un Solo Protocolo VRF a Multiprotocolo VRF

Características y Ejemplos de Configuraciones de VRF Multiprotocolo

Configuración de VRF Multiprotocolo: Ejemplo de Protocolo Único con Políticas no Comunes

Configuración de VRF Multiprotocolo: Ejemplo de Multiprotocolo con Políticas no Comunes

Configuración de VRF Multiprotocolo: Ejemplo de Multiprotocolo con Políticas Comunes

Configuración de VRF Multiprotocolo: Multiprotocolo con Políticas Comunes y no Comunes

Cómo Configurar MPLS VPN — VRF CLI para VPNs IPv4 e IPv6

Configuración de un VRF para VPNs de MPLS IPv4 e IPv6

Asociación de un VRF Multiprotocolo a una Interfaz

Verificación de la Configuración de MPLS VPN — VRF CLI for IPv4 and IPv6 VPNs

Migración de una Configuración VRF solamente IPv4 de un Protocolo a otra VRF Multiprotocolo

Ejemplos de configuración para MPLS VPN — VRF CLI for IPv4 and IPv6 VPNs

Configuración de un VRF para VPNs IPv4 e IPv6: Ejemplo:

Asociación de un VRF Multiprotocolo a una Interfaz: Ejemplo:

Migración de una Configuración VRF solamente IPv4 de un Protocolo a otra VRF Multiprotocolo: Ejemplo:

Referencias adicionales

Documentos Relacionados

Estándares

MIB

RFC

Asistencia Técnica

Referencia de Comandos

Información sobre la Función MPLS VPN - VRF CLI for IPv4 and IPv6 VPNs

Glosario


MPLS VPN — VRF CLI for IPv4 and IPv6 VPNs


Primera publicación: De febrero el 19 de 2007
Última actualización: 7 de noviembre de 2008

Este documento describe cómo configurar un Red privada virtual (VPN) que rutea y que remite el caso (VRF) para el IPv4 y el IPv6 VPN y describe cómo actualizar su solo-protocolo existente IPv4-only VRF a una configuración de VRF multiprotocol.

El MPLS VPN — El VRF CLI para la característica del IPv4 y del IPv6 VPN introduce los comandos del comando line interface(cli) del Cisco IOS que permiten que usted habilite un IPv4 y el IPv6 VPN en el mismo caso VRF y que simplifique la migración de una configuración de VRF del solo-protocolo a una configuración de VRF multiprotocol.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea “información de la característica para el MPLS VPN — VRF CLI para la sección del IPv4 y del IPv6 VPN”.

Utilice Cisco Feature Navigator para buscar información sobre el soporte de plataformas y el soporte de imágenes del software Cisco IOS y Catalyst OS. Para acceder a Cisco Feature Navigator, vaya a http://www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Contenido

Prerrequisitos de MPLS VPN - VRF CLI for IPv4 and IPv6 VPNs

Restricciones de MPLS VPN — VRF CLI for IPv4 and IPv6 VPNs

Información sobre MPLS VPN — VRF CLI for IPv4 and IPv6 VPNs

Cómo Configurar MPLS VPN — VRF CLI para VPNs IPv4 e IPv6

Ejemplos de configuración para MPLS VPN — VRF CLI for IPv4 and IPv6 VPNs

Referencias adicionales

Referencia de Comandos

Información sobre la Función MPLS VPN - VRF CLI for IPv4 and IPv6 VPNs

Glosario

Prerrequisitos de MPLS VPN - VRF CLI for IPv4 and IPv6 VPNs

El MPLS VPN — El VRF CLI para la característica del IPv4 y del IPv6 VPN tiene los requisitos previos siguientes:

Para la migración — Un Multiprotocol Label Switching (MPLS) VPN VRF del IPv4 debe existir.

Para una nueva configuración de VRF — El Cisco Express Forwarding y un método de distribución de etiqueta MPLS, Protocolo de distribución de etiquetas (LDP) o la Ingeniería de tráfico MPLS (TE), se deben habilitar en todo el Routers en la base, incluyendo el Routers del borde del proveedor (PE).

Restricciones de MPLS VPN — VRF CLI for IPv4 and IPv6 VPNs

El MPLS VPN — El VRF CLI para la característica del IPv4 y del IPv6 VPN tiene las restricciones siguientes:

Una vez que usted ha convertido a un VRF multiprotocol, usted no puede convertir el VRF de nuevo a un solo-protocolo VRF IPv4-only.

Usted puede asociar una interfaz con solamente un VRF. Usted no puede configurar un VRF para el IPv4 y un diverso VRF para el IPv6 en lo mismo interconecta.

Usted puede configurar las familias del direccionamiento solamente del IPv4 y del IPv6 en un VRF multiprotocol. Otros protocolos (IPX, APPLETALK, y similares) no se soportan.

Información sobre MPLS VPN — VRF CLI for IPv4 and IPv6 VPNs

Antes de que usted utilice el MPLS VPN — VRF CLI para que la característica del IPv4 y del IPv6 VPN emigre de un solo-protocolo VRF a un VRF multiprotocol, usted debe entender los conceptos siguientes:

Conceptos VRF Similares para VPNs MPLS IPv4 e IPv6

Migración de un Solo Protocolo VRF a Multiprotocolo VRF

Características y Ejemplos de Configuraciones de VRF Multiprotocolo

Conceptos VRF Similares para VPNs MPLS IPv4 e IPv6

Los VPN para el IPv6 utilizan los mismos conceptos VRF que el uso del MPLS VPNs del IPv4, tal como familias del direccionamiento, los Route Distinguisher, ruta apunta, y los identificadores VRF. Los clientes que utilizan el IPv4 y el IPv6 VPN pudieron querer compartir las directivas VRF entre las familias del direccionamiento. Puede ser que quieran una manera de definir las directivas aplicables VRF para todas las familias del direccionamiento, en vez de definir las directivas VRF para una familia del direccionamiento individualmente como hacen para o un solo-protocolo IPv4-only VRF.

Antes del Cisco IOS Release 12.2(33)SRB, un VRF se aplicó solamente a una familia del direccionamiento del IPv4. Relación uno a uno existido entre el nombre VRF y un identificador de la encaminamiento y de tabla de reenvío, entre un nombre VRF y un Route Distinguisher (RD), y entre un nombre VRF y un VPN ID. Esta configuración se llama un solo-protocolo VRF.

El Cisco IOS Release 12.2(33)SRB introduce el soporte para una estructura múltiple de la direccionamiento-familia (multi-AF) VRF. El multi-AF VRF permite que usted defina a las familias con varias direcciones bajo el mismo VRF. Un VRF dado, identificado por su nombre y un conjunto de políticas, puede aplicarse a una VPN IPv4 e IPv6 a la vez. Este VRF se puede activar en una interfaz dada, aunque las tablas de reenvío y ruteo son diferentes para los protocolos IPv4 e IPv6. Esta configuración se llama un VRF multiprotocol.

Migración de un Solo Protocolo VRF a Multiprotocolo VRF

Antes del Cisco IOS Release 12.2(33)SRB, usted podría crear un solo-protocolo IPv4-only VRF. Usted creó un solo-protocolo VRF ingresando ip vrf el comando. Para activar el solo-protocolo VRF en una interfaz, usted ingresó ip vrf forwarding el comando (de la configuración de la interfaz).

Después de la introducción del MPLS VPN — VRF CLI para la característica del IPv4 y del IPv6 VPN en el Cisco IOS Release 12.2(33)SRB, usted crea un VRF multiprotocol ingresando vrf definition el comando. Para activar el VRF multiprotocol en una interfaz, usted ingresa vrf forwarding el comando.

El MPLS VPN — El VRF CLI para la característica del IPv4 y del IPv6 VPN introduce vrf upgrade-cli multi-af-mode {common-policies | non-common-policies} el comandovrf vrf-namedel []ese fuerza la migración de la configuración de VRF de un modelo del solo-protocolo VRF a un modelo multiprotocol VRF:

Si las directivas de la ruta-blanco se aplican a todas las familias del direccionamiento configuradas en el multi-AF VRF, seleccione common-policies la palabra clave.

Si las directivas de la ruta-blanco se aplican solamente a la familia del direccionamiento del IPv4 que usted está emigrando, seleccione non-common-policies la palabra clave.

Después de que usted ingrese vrf upgrade-cli el comando y salve la configuración al NVRAM, la configuración de VRF del solo-protocolo se guarda como configuración de VRF multiprotocol. En el proceso de actualización, ip vrf el comando se convierte vrf definition al comando (comandos global configuration) y ip vrf forwarding el comando se convierte vrf forwarding al comando (comando interface configuration). vrf upgrade-cli El comando tiene un efecto inmediato de una sola vez.

Usted puede ser que tenga IPv4-only VRF y VRF multiprotocol en su router. Una vez que usted crea un VRF, usted puede editarlo usando solamente los comandos en el modo en el cual fue creado. Por ejemplo, usted creó un vrf2 nombrado VRF con los comandos vrf multiprotocol siguientes:

Router# configure terminal
Enter configuration command, one per line. End with CNTL/Z
Router(config)# vrf definition vrf2
Router(config-vrf)# rd 2:2
Router(config-vrf)# route-target import 2:2
Router(config-vrf)# route-target export 2:2
Router(config-vrf)# end

Si usted intenta editar VRF vrf2 con los comandos vrf IPv4-only, usted recibe el siguiente mensaje:

Router# configure terminal
Enter configuration command, one per line. End with CNTL/Z
Router(config)# ip vrf vrf2
% Use `vrf definition vrf2' command 

Si usted intenta editar un IPv4-only VRF con los comandos vrf multiprotocol, usted recibiría este mensaje, donde está el nombre el <vrf-name> del IPv4-only VRF:

% Use `ip vrf <vrf-name>' command

ip vrf El nombre y ip vrf forwarding los comandos name (de la configuración de la interfaz) estarán disponibles por un período de tiempo antes de que se quiten. Utilice vrf upgrade el comando de emigrar su IPv4-only más viejo VRF a la nueva configuración de VRF multiprotocol. Cuando usted necesita crear un nuevo VRF — si el VRF está para un IPv4 VPN, o el IPv6 VPN, o ambos — utilice el VRF multiprotocol vrf definition y vrf forwarding ordena que soporten una configuración multi-AF.

Características y Ejemplos de Configuraciones de VRF Multiprotocolo

En un VRF multiprotocol, usted puede configurar el IPv4 VRF y el IPv6 VRF bajo la misma familia del direccionamiento o configurar los VRF separados para familia de cada direccionamiento del IPv4 o del IPv6. La configuración de VRF multiprotocol tiene las siguientes características:

El nombre VRF identifica un VRF, que pudo tener las familias de direccionamiento del IPv4 y del IPv6. En la misma interfaz, usted no puede tener las familias de direccionamiento del IPv4 y del IPv6 usando diversos nombres VRF.

El RD, el VPN ID, y el contexto del Simple Network Management Protocol (SNMP) son compartidos por las familias de ambo direccionamiento del IPv4 y del IPv6 para un VRF dado.

Las directivas (blanco de la ruta, por ejemplo) especificadas en el modo multi-AF VRF, fuera de la configuración de la direccionamiento-familia, son valores por defecto que se aplicarán a cada familia del direccionamiento. Las blancos de la ruta son las únicas características VRF dentro de las cuales puede ser definido y fuera de una familia del direccionamiento.

Lo que sigue es también verdad cuando usted asocia un VRF multiprotocol a una interfaz:

Atar una interfaz a un VRF (vrf forwarding vrf-name comando) quita todos los direccionamientos del IPv4 y del IPv6 configurados en esa interfaz.

Una vez que usted asocia un VRF a una interfaz dada, todas las familias activas del direccionamiento pertenecen a ese VRF. La excepción es cuando no se configura ningún direccionamiento del tipo de la direccionamiento-familia, en este caso se inhabilita el protocolo.

Configurar un direccionamiento en una interfaz que esté limitada a un VRF requiere que la familia del direccionamiento correspondiente al tipo de dirección es activa para ese VRF. Si no, un mensaje de error es el exponer publicado que la familia del direccionamiento debe ser activada primero en el VRF.

La compatibilidad descendente con el solo-protocolo VRF CLI se soporta en el Cisco IOS Release 12.2(33)SRB. Esto significa que usted puede ser que tenga el solo-protocolo y CLI multiprotocol en el mismo router, pero no en la misma configuración de VRF.

El solo-protocolo CLI continúa permitiendo que usted defina un direccionamiento del IPv4 dentro de un VRF y un direccionamiento del IPv6 en la tabla de Global Routing en lo mismo interfaz.

Las secciones siguientes tienen ejemplos multiprotocol de la configuración de VRF:

Configuración de VRF Multiprotocolo: Ejemplo de Protocolo Único con Políticas no Comunes

Configuración de VRF Multiprotocolo: Ejemplo de Multiprotocolo con Políticas no Comunes

Configuración de VRF Multiprotocolo: Ejemplo de Multiprotocolo con Políticas Comunes

Configuración de VRF Multiprotocolo: Multiprotocolo con Políticas Comunes y no Comunes

Configuración de VRF Multiprotocolo: Ejemplo de Protocolo Único con Políticas no Comunes

Lo que sigue es un ejemplo de una configuración de VRF multiprotocol para un solo protocolo (IPv4) con las directivas de la ruta-blanco en la configuración de la direccionamiento-familia:

vrf definition vrf2
 rd 2:2
 !
 address-family ipv4
 route-target export 2:2
 route-target import 2:2
 exit-address-family

El RD (2:2) se aplica a todas las familias del direccionamiento definidas para VRF vrf2.

Configuración de VRF Multiprotocolo: Ejemplo de Multiprotocolo con Políticas no Comunes

Lo que sigue es un ejemplo de una configuración de VRF multiprotocol para el IPv4 y el IPv6 VPN en los cuales las directivas de la ruta-blanco se definen en las configuraciones separadas de la direccionamiento-familia:

vrf definition vrf2
 rd 2:2
 !
 address-family ipv4
 route-target export 2:2
 route-target import 2:2
 exit-address-family
 !
 address-family ipv6
 route-target export 3:3
 route-target import 3:3
 exit-address-family

Configuración de VRF Multiprotocolo: Ejemplo de Multiprotocolo con Políticas Comunes

Lo que sigue es un ejemplo de una configuración de VRF multiprotocol para el IPv4 y del IPv6 VPN con las directivas de la ruta-blanco definidas en la parte de global el VRF:

vrf definition vrf2
 rd 2:2
 route-target export 2:2
 route-target import 2:2
  !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family

Las directivas de la ruta-blanco se definen fuera de las configuraciones de la direccionamiento-familia. Por lo tanto, las directivas se aplican a todas las familias del direccionamiento definidas en VRF vrf2.

Configuración de VRF Multiprotocolo: Multiprotocolo con Políticas Comunes y no Comunes

Lo que sigue es un ejemplo de un VRF multiprotocol con las directivas de la ruta-blanco definidas en las áreas globales y de la direccionamiento-familia:

Para el IPv6, las definiciones de la ruta-blanco se definen bajo la familia del direccionamiento. Se utilizan estas definiciones y las definiciones de la ruta-blanco en el área global se ignoran. Por lo tanto, el IPv6 VPN ignora la importación 100:2.

Para el IPv4, no se define ningunas directivas de la ruta-blanco bajo la familia del direccionamiento, por lo tanto, se utilizan las definiciones globales.

vrf definition vfr1
 route-target export 100:1
 route-target import 100:1
 route-target import 100:2
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 route-target export 100:1
 route-target import 100:1
 route-target import 100:3
 exit-address-family

Cómo Configurar MPLS VPN — VRF CLI para VPNs IPv4 e IPv6

Esta característica proporciona los comandos del Cisco IOS CLI que permiten que usted configure un VRF multiprotocol (el IPv4 y el IPv6 VPN en el mismo VRF) y que emigre una configuración de VRF del solo-protocolo (IPv4-only VRF) a una configuración de VRF multiprotocol.

Un VRF multiprotocol permite que usted comparta las directivas de las blancos de la ruta (importación y exportación) entre el IPv4 y el IPv6 o que configure las directivas separadas de la ruta-blanco para el IPv4 y el IPv6 VPN.

Realice las tareas en las secciones siguientes de configurar o de emigrar al MPLS VPN — VRF CLI para la característica del IPv4 y del IPv6 VPN:

Configurando un VRF para el IPv4 y el MPLS VPNs del IPv6 (requerido)

Asociando un VRF Multiprotocol a una interfaz (requerida)

Verificando el MPLS VPN — VRF CLI para el IPv4 y la configuración del IPv6 VPN (opcional)

Realice la tarea siguiente de emigrar de un solo-protocolo VRF a una configuración de VRF multiprotocol:

Migración de un Solo-protocolo IPv4-Only VRF a una configuración de VRF Multiprotocol (opcional)

Configuración de un VRF para VPNs de MPLS IPv4 e IPv6

Realice la tarea siguiente de configurar un VRF para el IPv4 y el MPLS VPNs del IPv6. Cuando usted configura un VRF para el IPv4 y el IPv6 VPN (un VRF multiprotocol), usted puede elegir configurar las directivas de la ruta-blanco que se aplican a todas las familias del direccionamiento en el VRF o usted puede configurar las directivas de la ruta-blanco que se aplican a las familias individuales del direccionamiento en el VRF.

La tarea siguiente muestra cómo configurar un VRF que tenga eso tenga directivas de la ruta-blanco definidas para el IPv4 y el IPv6 VPN en el VRF separado se dirige a las familias.

PASOS SUMARIOS

1.permiso

2.configure terminal

3. vrf definition vrf-name

4. rd route-distinguisher

5.address-family {ipv4 | ipv6}

6.route-target {import | export | both} route-target-ext-community

7. exit-address-family

8.address-family {ipv4 | ipv6}

9.route-target {import | export | both} route-target-ext-community

10. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

vrf definition vrf-name

Example:

Router(config)# vrf definition vrf1

Configura una tabla de ruteo VRF y entra en el modo de configuración de VRF.

vrf-name El argumento es el nombre del VRF.

Paso 4 

rd route-distinguisher

Example:

Router(config-vrf)# rd 100:1

Crea las tablas de ruteo y reenvío para un VRF.

route-distinguisher El argumento especifica para agregar un valor 8-byte a un prefijo del IPv4 para crear un prefijo del IPv4 VPN. Puede ingresar un discriminador de rutas con cualquiera de estos formatos:

– número del sistema autónomo de 16 bits (ASN): su número de 32 bits
Por ejemplo, 101:3.

– dirección IP de 32 bits: su número de 16 bits
Por ejemplo, 192.168.122.15:1.

Paso 5 

address-family {ipv4 | ipv6}

Example:

Router(config-vrf) address-family ipv4

Ingresa en el modo de configuración de la familia de direcciones VRF para especificar una familia de direcciones para un VRF.

ipv4 La palabra clave especifica a una familia del direccionamiento del IPv4 para un VRF.

ipv6 La palabra clave especifica a una familia del direccionamiento del IPv6 para un VRF.

Paso 6 

route-target {import | export | both} route-target-ext-community

Example:

Router(config-vrf-af)# route-target both 100:2

Crea a una comunidad ampliada de comando route-target para un VRF.

import La palabra clave especifica para importar la información de ruteo de la comunidad ampliada de la blanco VPN.

export La palabra clave especifica para exportar la información de ruteo a la comunidad ampliada de la blanco VPN.

both La palabra clave especifica para importar la importación y la información de ruteo de la exportación a la comunidad ampliada de la blanco VPN.

route-target-ext-community El argumento agrega los atributos de la comunidad ampliada de la ruta-blanco a la lista VRF de importación, de exportación, o de ambas (importación y exportación) las comunidades ampliadas de la ruta-blanco.

Paso 7 

exit-address-family

Example:

Router(config-vrf-af)# exit-address-family

Salidas del modo de configuración de familia de direcciones VRF.

Paso 8 

address-family {ipv4 | ipv6}

Example:

Router(config-vrf) address-family ipv6

Ingresa en el modo de configuración de la familia de direcciones VRF para especificar una familia de direcciones para un VRF.

ipv4 La palabra clave especifica a una familia del direccionamiento del IPv4 para un VRF.

ipv6 La palabra clave especifica a una familia del direccionamiento del IPv6 para un VRF.

Paso 9 

route-target {import | export | both} route-target-ext-community

Example:

Router(config-vrf-af)# route-target both 100:3

Crea a una comunidad ampliada de comando route-target para un VRF.

import La palabra clave especifica para importar la información de ruteo de la comunidad ampliada de la blanco VPN.

export La palabra clave especifica para exportar la información de ruteo a la comunidad ampliada de la blanco VPN.

both La palabra clave especifica para importar la importación y la información de ruteo de la exportación a la comunidad ampliada de la blanco VPN.

route-target-ext-community El argumento agrega los atributos de la comunidad ampliada de la ruta-blanco a la lista VRF de importación, de exportación, o de ambas (importación y exportación) las comunidades ampliadas de la ruta-blanco.

Ingrese route-target el comando una vez para cada comunidad de la blanco.

Paso 10 

end

Example:

Router(config-vrf-af)# end

Sale al modo EXEC privilegiado.

Asociación de un VRF Multiprotocolo a una Interfaz

Realice la tarea siguiente de asociar un VRF multiprotocol a una interfaz. La asociación del VRF a una interfaz activa el VRF.

PASOS SUMARIOS

1. enable

2. configure terminal

3. interface type number

4. vrf forwarding vrf-name

5.ip address ip-address mask []secondary

6.ipv6 address {ipv6-address/prefix-length | prefix-name sub-bits/prefix-length}

7. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

interface type number

Example:

Router(config)# interface Ethernet 0/1

Configura un tipo de interfaz e ingresa en el modo de configuración de la interfaz.

type El argumento identifica el tipo de interfaz que se configurará.

number El argumento identifica el puerto, el conector, o el número de placa de interfaz.

Paso 4 

vrf forwarding vrf-name

Example:

Router(config-if)# vrf forwarding vrf1

Asocia un VRF a una interfaz o subinterfaz.

vrf-name El argumento es el nombre del VRF.

Paso 5 

ip address ip-address mask [secondary]

Example:

Router(config-if)# ip address 10.24.24.24 255.255.255.255

Fija una dirección IP primaria o secundaria para una interfaz.

ip-address El argumento es la dirección IP.

mask El argumento es la máscara de la subred IP asociada.

secondary La palabra clave especifica que la dirección configurada es una driección IP secundaria. Si se omite esta palabra clave, la dirección configurada es la dirección IP primaria.

Paso 6 

ipv6 address {ipv6-address/prefix-length | prefix-name sub-bits/prefix-length}

Example:

Router(config-if)# ipv6 address 2001:0DB8:0300:0201::/64

Configura un direccionamiento del IPv6 basado en un prefijo general del IPv6 y habilita el IPv6 que procesa en una interfaz.

ipv6-address El argumento es el direccionamiento del IPv6 que se utilizará.

prefix-lengthEl argumento es la longitud del prefijo del IPv6, que es un valor decimal que indica cuántos de los bits contiguos de alto nivel del direccionamiento comprenden el prefijo (la porción de la red del direccionamiento). Una marca de la raya vertical debe preceder el valor decimal.

prefix-name El argumento es un prefijo general que especifica los bits principales de la red que se configurará en la interfaz.

sub-bits El argumento es los bits del subprefix y bits del host del direccionamiento que se concatenará con los prefijos proporcionados por el prefijo general especificado el argumento del prefijo-nombre.

El argumento de los sub-bits debe estar en la forma documentada en el RFC 2373 donde el direccionamiento se especifica en el hexadecimal usando los valores de 16 bits entre los dos puntos.

Paso 7 

end

Example:

Router(config-if) end

Sale al modo EXEC privilegiado.

Verificación de la Configuración de MPLS VPN — VRF CLI for IPv4 and IPv6 VPNs

Realice la tarea siguiente de verificar el MPLS VPN — VRF CLI para configuración de la característica del IPv4 y del IPv6 VPN, es decir, para mostrar que la configuración de VRF esté actualizada a un multi-AF VRF multiprotocol.

PASOS SUMARIOS

1. enable

2.show running-config vrf []vrf-name

3. show vrf

4.show vrf detail []vrf-name

5. exit

PASOS DETALLADOS


Paso 1 enable

Utilice este comando para habilitar el modo EXEC privilegiado. Ingrese su contraseña, si se le pide que lo haga. Por ejemplo:

Router> enable
Router#

[]del pasoshow running-config vrf 2vrf-name

Utilice este comando para verificar que el upgrade a una configuración de VRF multiprotocolo multi-AF fue correcta. Lo que sigue es salida del comando de ejemplo antes de la actualización a un multi-AF VRF multiprotocol:

Router# show running-config vrf vpn2
Building configuration...
Current configuration : 604 bytes
ip vrf vpn2
 rd 1:1
 route-target both 1:1
!
!
interface Loopback1
 ip vrf forwarding vpn2
 ip address 10.43.43.43 255.255.255.255
!

Lo que sigue es salida del comando de ejemplo después de que usted actualice a un multi-AF VRF multiprotocol con las directivas comunes para todas las familias del direccionamiento:

Router# show running-config vrf vpn1
Building configuration...
Current configuration : 604 bytes
vrf definition vpn1
 rd 1:1
 route-target both 1:1
!
 address-family 1pv4
 exit-address-family
!
!
interface Loopback1
 ip vrf forwarding vpn1
 ip address 10.43.43.43 255.255.255.255
!

Esta configuración contiene vrf definition el comando. vrf definition El comando substituye ip vrf el comando en la configuración de VRF multiprotocol multi-AF.

Paso 3 show vrf

Utilice este comando para verificar que el upgrade a una configuración de VRF multiprotocolo multi-AF fue correcta. show vrf El comando substituye show ip vrf el comando cuando una configuración de VRF se pone al día a una configuración de VRF multiprotocol multi-AF. show vrf El comando visualiza los protocolos definidos para un VRF. El siguiente comando muestra la salida de muestra después de que usted actualice una configuración de VRF del solo-protocolo a una configuración de VRF multiprotocol multi-AF:

Router# show vrf vpn1
  Name                           Default RD     Protocols         Interfaces
  vpn1                           1:1            ipv4              Lo1/0

Lo que sigue es salida de muestra show ip vrf vp1 del comando. Compare esto a la salida show vrf vpn1 del comando. Los protocolos bajo el VRF no se visualizan.

Router# show ip vrf vrf1
  Name      Default RD   Interface
  vpn1      1:1          Loopback1

Lo que sigue es salida de muestra show vrf del comando para los VRF multiprotocol, uno de los cuales contiene los protocolos del IPv4 y del IPv6:

Router# show vrf
  Name                           Default RD     Protocols         Interfaces
  vpn1                           1:1            ipv4              Lo1/0
  vpn2                           100:3          ipv4              Lo23  AT3/0/0.1
  vpn4                           100:2          ipv4,ipv6 

[]del pasoshow vrf detail 4vrf-name

Utilice este comando de visualizar todas las características del VRF definido para verificar que es la configuración como usted esperó. Por ejemplo, si es su configuración de VRF para el vpn1 VRF como sigue:

vrf definition vpn1
 route-target both 100:1
 route-target import 100:2
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 route-target both 100:1
 route-target import 100:3
 exit-address-family

Este comando visualizaría el siguiente:

Router# show vrf detail vpn1
VRF vpn1 (VRF Id = 3); default RD <not set>; default VPNID <not set>
  No interfaces
Address family ipv4 (Table ID = 3 (0x3)):
  Connected addresses are not in global routing table
  Export VPN route-target communities
    RT:100:1                
  Import VPN route-target communities
    RT:100:1                 RT:100:2             
  No import route-map
  No export route-map
  VRF label distribution protocol: not configured
  VRF label allocation mode: per-prefix
Address family ipv6 (Table ID = 503316483 (0x1E000003)):
  Connected addresses are not in global routing table
  Export VPN route-target communities
    RT:100:1                
  Import VPN route-target communities
    RT:100:1                 RT:100:3                
  No import route-map
  No export route-map
  VRF label distribution protocol: not configured
  VRF label allocation mode: per-prefix

Paso 5 exit

Utilice este comando para salir al modo EXEC de usuario. Por ejemplo:

Router# exit
Router>

Migración de una Configuración VRF solamente IPv4 de un Protocolo a otra VRF Multiprotocolo

Realice la tarea siguiente de forzar la migración de un solo-protocolo IPv4-only VRF a una configuración de VRF multiprotocol.

La configuración de VRF multiprotocol permite que usted defina a las familias con varias direcciones bajo el mismo VRF. Un VRF dado, identificado por su nombre y un conjunto de políticas, puede aplicarse a una VPN IPv4 e IPv6 a la vez. Este VRF se puede activar en una interfaz dada, aunque las tablas de reenvío y ruteo son diferentes para los protocolos IPv4 e IPv6.

PASOS SUMARIOS

1. enable

2. configure terminal

3.vrf upgrade-cli multi-af-mode {common-policies | non-common-policies} []vrf vrf-name

4. exit

5. show running-config vrf vrf-name

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

vrf upgrade-cli multi-af-mode {common-policies | non-common-policies} [vrf vrf-name]

Example:

Router(config)# vrf upgrade-cli multi-af-mode common-policies vrf vpn4

Actualiza un caso VRF o todos los VRF configurados en el router para soportar a las familias con varias direcciones bajo el mismo VRF.

multi-af-mode La palabra clave especifica una actualización de un solo-protocolo VRF o todos los VRF a un VRF multiprotocol que soporte la configuración multi-AF.

common-policies La palabra clave especifica para copiar las directivas de la ruta-blanco a la parte de común la configuración de VRF de modo que las directivas se apliquen a todas las familias del direccionamiento configuraran en el multi-AF VRF.

non-common-policies La palabra clave especifica para copiar las directivas de la ruta-blanco a la parte de la familia del direccionamiento del IPv4 la configuración de VRF de modo que las directivas se apliquen solamente al IPv4.

vrf La palabra clave especifica un VRF para la actualización a una configuración de VRF multi-AF.

vrf-name El argumento es el nombre del solo-protocolo VRF a actualizar a una configuración de VRF multi-AF.

Paso 4 

exit

Example:

Router(config)# exit

Sale al modo EXEC privilegiado.

Paso 5 

show running-config vrf [vrf-name]

Example:

Router# show running-config vrf vpn4

Visualiza el subconjunto de la configuración corriente de un router que se conecte a un caso específico VRF o a todos los VRF configurados en el router.

vrf-name El argumento es el nombre del VRF cuyo usted quiere visualizar la configuración.

Observela imagen del Cisco IOS que apoya los comandos vrf multiprotocol no pudo soportar show running-config vrfel comando. Usted puede utilizar show running-config el comando en lugar de otro.

Ejemplos de configuración para MPLS VPN — VRF CLI for IPv4 and IPv6 VPNs

Los siguientes ejemplos muestran cómo utilizar el VRF CLI proporcionado por el MPLS VPN — VRF CLI para que la característica del IPv4 y del IPv6 VPN emigre de un solo-protocolo VRF a una configuración de VRF multiprotocol:

Configuración de un VRF para VPNs IPv4 e IPv6: Ejemplo:

Asociación de un VRF Multiprotocolo a una Interfaz: Ejemplo:

Migración de una Configuración VRF solamente IPv4 de un Protocolo a otra VRF Multiprotocolo: Ejemplo:

Configuración de un VRF para VPNs IPv4 e IPv6: Ejemplo:

Las demostraciones del siguiente ejemplo cómo configurar un VRF para el IPv4 y el IPv6 VPN:

configure terminal
!
vrf definition vrf1
 rd 100:1
!
 address-family ipv4
 route-target both 100:2
 exit-address-family
!
 address-family ipv6
 route-target both 100:3
 exit-address-family 

En este ejemplo, las directivas del noncommon se definen en la configuración de la direccionamiento-familia.

Lo que sigue es un ejemplo de un VRF para el IPv4 y el IPv6 que tenga directivas comunes definidas en la parte de global la configuración de VRF:

configure terminal
!
vrf definition vrf2
 rd 200:1
 route-target both 200:2
!
 address-family ipv4
 exit-address-family
!
 address-family ipv6
 exit-address-family
 end

Asociación de un VRF Multiprotocolo a una Interfaz: Ejemplo:

Las demostraciones del siguiente ejemplo cómo asociar un VRF multiprotocol a una interfaz:

configure terminal
!
interface Ethernet 0/1
 vrf forwarding vrf1
 ip address 10.24.24.24 255.255.255.255
 ipv6 address 2001:0DB8:0300:0201::/64 
 end

Migración de una Configuración VRF solamente IPv4 de un Protocolo a otra VRF Multiprotocolo: Ejemplo:

Esta sección contiene los ejemplos que muestran cómo emigrar de un solo-protocolo IPv4-only VRF a una configuración de VRF multiprotocol.

Este ejemplo muestra un solo-protocolo IPv4-only VRF antes de que el Cisco IOS VRF CLI para el IPv4 y el IPv6 se ingrese en el router:

ip vrf vrf1
 rd 1:1
 route-target both 1:1
interface Loopback1
 ip vrf forwarding V1
 ip address 10.3.3.3 255.255.255.255

Este ejemplo muestra cómo forzar la migración del solo-protocolo VRF vrf1 a una configuración de VRF multiprotocol:

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
!
Router(config)# vrf upgrade-cli multi-af-mode common-policies vrf vrf1
You are about to upgrade to the multi-AF VRF syntax commands. 
You will lose any IPv6 address configured on interfaces 
belonging to upgraded VRFs. 
Are you sure ? [yes]: yes
Number of VRFs upgraded: 1
Router(config)# exit

Este ejemplo muestra la configuración de VRF multiprotocol después de la migración forzada:

vrf definition vrf1
 rd 1:1
 route-target both 1:1
 !
 address-family ipv4
 exit-address-family
!
interface Loopback1
 vrf forwarding V1
 ip address 10.3.3.3 255.255.255.255

Lo que sigue es otro ejemplo de una configuración de VRF multiprotocol multi-AF:

vrf definition vrf2
 rd 100:1 
 address family ipv6
 route-target both 200:1 
 exit-address-family
!
ip vrf vrf1
 rd 200:1 
 route-target both 200:1 
!
interface Ethernet0/0
 vrf forwarding vrf2
 ip address 10.50.1.2 255.255.255.0
 ipv6 address 2001:0DB8:0:1::/64 
!
interface Ethernet0/1
 ip vrf forwarding vrf1
 ip address 10.60.1.2 255.255.255.0
 ipv6 address 2001:0DB8:1 :1::/64 

En este ejemplo, todo dirige (IPv4 y IPv6) definido para el Ethernet0/0 de la interfaz está en VRF vrf2. Para la interfaz Ethernet0/1, el direccionamiento del IPv4 se define en VRF vrf1 pero el direccionamiento del IPv6 está en la tabla de ruteo global del IPv6.

Referencias adicionales

Las secciones siguientes proporcionan las referencias relacionadas con el MPLS VPN — VRF CLI para la característica del IPv4 y del IPv6 VPN.

Documentos Relacionados

Tema relacionado
Título del documento

MPLS

Literatura del producto MPLS

Comandos para configurar el MPLS y el MPLS VPNs

Referencia de Comandos de Multiprotocol Label Switching de Cisco IOS

Tareas de configuración para el MPLS y el MPLS VPNs

Guía de Configuración de Multiprotocol Label Switching de Cisco IOS


Estándares

Estándar
Título

Esta función no soporta estándares nuevos o modificados, y el soporte de los estándares existentes no ha sido modificado por ella.


MIB

MIB
Link del MIB

Esta función no soporta MIBs nuevas o modificadas, y el soporte para las MIBs existentes no ha sido modificado por esta función.

Para localizar y descargar MIB de plataformas, versiones de Cisco IOS y conjuntos de funciones seleccionados, utilice Cisco MIB Locator, que se encuentra en la siguiente URL:

http://www.cisco.com/cisco/web/LA/support/index.html


RFC

RFC
Título

RFC 1771

Un Border Gateway Protocol 4 (BGP-4)

RFC 4364

Redes privadas virtuales (VPN) BGP MPLS/IP


Asistencia Técnica

Descripción
Link

El sitio Web de soporte técnico de Cisco proporciona los recursos en línea extensos, incluyendo la documentación y las herramientas para localizar averías y resolver los problemas técnicos con los Productos Cisco y las Tecnologías.

Para recibir la Seguridad y la información técnica sobre sus Productos, usted puede inscribir a los diversos servicios, tales como la herramienta de alerta del producto (accedida de los Field Notice), el hoja informativa de los servicios técnicos de Cisco, y alimentaciones realmente simples de la sindicación (RSS).

El acceso a la mayoría de las herramientas en el sitio Web de soporte técnico de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html


Referencia de Comandos

Los siguientes comandos se introducen o se modifican en la característica o las características documentadas en este módulo. Para obtener información sobre estos comandos, vea la Referencia de Comandos de Multiprotocol Label Switching de Cisco IOS en http://www.cisco.com/en/US/docs/ios/mpls/command/reference/mp_book.html. Para obtener información sobre todos los comandos de Cisco IOS, vaya al sitio de la Herramienta de Búsqueda de Comandos en http://tools.cisco.com/Support/CLILookup o la Lista de Comandos Principal de Cisco IOS, Todas las Versiones, que se encuentra en http://www.cisco.com/en/US/docs/ios/mcl/allreleasemcl/all_book.html.

show vrf

vrf definition

vrf forwarding

vrf upgrade-cli

Información sobre la Función MPLS VPN - VRF CLI for IPv4 and IPv6 VPNs

La Tabla 1 muestra el historial de versiones de esta función.

Puede que no estén disponibles todos los comandos en su versión de software de Cisco IOS. Para la información de versión sobre un comando específico, vea la documentación de referencia de comandos.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software. Cisco Feature Navigator le permite determinar qué imágenes de Cisco IOS y Catalyst OS Software soportan una versión de software, un conjunto de funciones o una plataforma específica. Para acceder a Cisco Feature Navigator, vaya a http://www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.


Observelas listas del cuadro 1 solamente la versión de Cisco IOS Software que introdujo el soporte para una característica dada en un tren de versión del Cisco IOS Software dado. A menos que se indique lo contrario, las versiones posteriores de dicha serie de versiones de software de Cisco IOS también soportan esa función.


Información de la característica del cuadro 1 para el MPLS VPN — VRF CLI para el IPv4 y el IPv6 VPN 

Nombre de la función
Versiones
Información sobre la Función

MPLS VPN — VRF CLI for IPv4 and IPv6 VPNs

12.2(33)SRB
12.2(33)SXI

Este documento describe cómo configurar un Red privada virtual (VPN) multiprotocol que rutea y que remite el caso (VRF) para el IPv4 y el IPv6 VPN y describe cómo actualizar su solo-protocolo existente IPv4-only VRF a una configuración de VRF multiprotocol.

El MPLS VPN — El VRF CLI para la característica del IPv4 y del IPv6 VPN introduce los comandos del comando line interface(cli) del Cisco IOS que permiten que usted habilite un IPv4 y el IPv6 VPN en el mismo caso del Multiprotocol Label Switching (MPLS) VRF y que simplifique la migración de una configuración de VRF del solo-protocolo a una configuración de VRF multiprotocol.

En 12.2(33)SRB se insertó esta función en el Cisco 7600 Series Router.

En 12.2(33)SXI, esta característica era integrada en una versión del Cisco IOS 12.2SXI.

Las secciones siguientes proporcionan información acerca de esta función:

Conceptos VRF Similares para VPNs MPLS IPv4 e IPv6

Migración de un Solo Protocolo VRF a Multiprotocolo VRF

Características y Ejemplos de Configuraciones de VRF Multiprotocolo

Configuración de un VRF para VPNs de MPLS IPv4 e IPv6

Asociación de un VRF Multiprotocolo a una Interfaz

   

Verificación de la Configuración de MPLS VPN — VRF CLI for IPv4 and IPv6 VPNs

Migración de una Configuración VRF solamente IPv4 de un Protocolo a otra VRF Multiprotocolo

Se han insertado o modificado los siguientes comandos: show vrf vrf definition vrf forwarding vrf upgrade-cli.


Glosario

6PE — Router de borde del proveedor del IPv6 o un router de borde del Label Switch Router del Multiprotocol Label Switching (MPLS) (LSR) usando el IPv6.

6VPE — Router de borde del proveedor del Red privada virtual (VPN) del IPv6.

AF — familia del direccionamiento. Conjunto de los protocolos de comunicación relacionados en los cuales todos los miembros utilizan un mecanismo de dirección común para identificar los puntos finales. Familia de protocolos también llamada.

AFI — Identificador de la familia del direccionamiento. Lleva la identidad del protocolo de capa de red que se asocia a la dirección de red.

BGP — Protocolo Protocolo de la puerta de enlace marginal (BGP). Un Routing Protocol usado entre los sistemas autónomos. Es el Routing Protocol que hace el trabajo de Internet. El BGP es un Distance Vector Routing Protocol que lleva la información de la Conectividad y un conjunto adicional de atributos BGP. Estos atributos permiten un conjunto de las directivas para decidir a la mejor ruta para utilizar para alcanzar un destino determinado. El BGP es definido por el RFC 1771.

CE — Router borde del cliente. Un router del proveedor de servicio que conecta con el Red privada virtual (VPN) los sitios del cliente.

BOLA — Bases de información de reenvío. Base de datos que salva la información sobre la transferencia de los paquetes de datos. UNA BOLA se basa en la información en el Routing Information Base (RIB). Es el conjunto óptimo de las rutas seleccionadas que están instaladas en el linecards para remitir.

HA — alta disponibilidad. La Alta disponibilidad se define como la operación continua de los sistemas. Para que un sistema esté disponible, todos los componentes — incluyendo la aplicación y los servidores de bases de datos, los dispositivos de almacenamiento, y la red de extremo a extremo — necesitan proporcionar el servicio continuo.

IP — Protocolo de Internet. Protocolo de capa de red en la pila de TCP/IP que ofrece un servicio entre redes sin conexión. IP proporciona funciones de direccionamiento, especificación de tipo de servicio, fragmentación y reensamblado, y seguridad.

IPv4 — Versión IP 4. capas de red para el Conjunto de protocolos TCP/IP. El IPv4 está un sin conexión, protocolo de conmutación de conjunto de bits del mejor esfuerzo.

IPv6 — Versión IP reemplazo 6. para el IPv4. El IPv6 es una última generación protocolo IP. El IPv6 es compatible con versiones anteriores con y diseñado reparar los defectos del IPv4, tal como seguridad de datos y direccionamientos de la cantidad máxima de usuario. El IPv6 aumenta el espacio de la dirección a partir del 32 a los bits 128, previendo un número sin límite de redes y de sistemas. También soporta los parámetros de Calidad de Servicio (QoS) para el audio en tiempo real y el vídeo.

MFI: Infraestructura de Reenvío MPLS. En el subsistema de Cisco MPLS, la estructura de datos para almacenar la información sobre etiquetas de entrada y de salida y paquetes equivalentes asociados adecuados para su etiquetado.

MPLS — Multiprotocol Label Switching. El MPLS es un método para reenviar los paquetes (tramas) a través de una red. Permite a los routers del borde de una red aplicar las etiquetas a los paquetes (tramas). Los switches ATM o los routers presentes en el núcleo de la red pueden conmutar paquetes en función de las etiquetas con un incremento mínimo de las operaciones de búsqueda.

PE — router de borde del proveedor. Un router que es parte de a la red de proveedor de servicio y que está conectado con un router de la frontera del cliente (CE). La función del router PE es una combinación de una función del router switch de borde de etiqueta MLS (LSR) con algunas funciones adicionales para soportar el Redes privadas virtuales (VPN).

RD (IPv4) — Route Distinguisher. Un valor 8 bytes que se concatena con un prefijo de IPv4 para crear un prefijo único de VPN IPv4 (VPNv4).

RD (IPv6) — Route Distinguisher. Un valor 64-bit que prepended a un prefijo del IPv6 para crear a global - direccionamiento único del VPN-IPv6.

RIB — Routing Information Base. El conjunto de todas las rutas disponibles de las cuales para elegir la Base de información de reenvío (FIB). El RIB esencialmente contiene todas las rutas disponibles para la selección. Es la suma de todas las rutas aprendidas por los Dynamic Routing Protocol, todos directamente las redes conectadas (esas las ser-redes a las cuales un router dado tienen interfaces conectadas), y cualquier ruta configurada adicional, tal como Static rutas.

RT: Destino de ruta. El atributo de la comunidad ampliada usado para identificar el Red privada virtual (VPN) que rutea y que remite la tabla de ruteo (VRF) en la cual un prefijo debe ser importado.

VPN — Red privada virtual. Permite que el tráfico IP se transfiera con seguridad a través de una red TCP/IP pública mediante el cifrado de todo el tráfico de una red a otra. Una VPN utiliza una arquitectura de "tunelización" para encriptar toda la información en el nivel de IP.

VRF — El rutear y caso de reenvío del Red privada virtual (VPN). Un VRF consta de una tabla de IP Routing, una tabla de reenvío derivada, un conjunto de interfaces que utiliza la tabla de reenvío y un conjunto de reglas y protocolos de ruteo que determina qué incluye la tabla de reenvío. En general, un VRF incluye la información de ruteo que define un sitio de cliente VPN conectado a un router PE.

Tabla VRF — Una encaminamiento y una tabla de reenvío se asociaron a un Red privada virtual (VPN) que ruteaba y que remitía el caso (VRF). Esto es una tabla específica del cliente, habilitando al router del borde del proveedor (PE) para mantener al estado de ruteo independiente para cada cliente.