Guía de Configuración de Multiprotocol Label Switching de Cisco IOS, Release 12.2SR
Configuración de VPNs de Capa 3 MPLS
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 373 KB | Inglés (12 Febrero 2008) | Comentarios

Contenidos

Configuración de VPNs de Capa 3 MPLS

Encontrar la información de la característica

Contenido

Prerrequisitos de VPNs MPLS de Capa 3

Restricciones de las VPNs de Capa 3 MPLS

Información sobre VPNs MPLS de Capa 3

Definición de MPLS VPN

Cómo Funciona una VPN MPLS

Cómo el ruteo virtual/las tablas de reenvío trabaja en un MPLS VPN

Cómo la información de VPN Routing se distribuye en un MPLS VPN

Distribución BGP de la información de VPN Routing

Expedición MPLS

Principales Componentes de MPLS VPNs

Ventajas de una MPLS VPN

Cómo Configurar las VPNs de Capa 3 MPLS

Configurar la red del núcleo

Evaluar las necesidades de los clientes del MPLS VPN

Configurar los Routing Protocol en la base

Configurar el MPLS en la base

El determinar si el CEF se habilita en la base

Configurar el Multiprotocol BGP en el Routers y los reflectores de ruta PE

Conexión de los clientes del MPLS VPN

Definición de los VRF en el Routers PE para habilitar la Conectividad del cliente

Configurar las interfaces VRF en el Routers PE para cada cliente VPN

Configurar los Routing Protocol entre el Routers PE y CE

Verificar la configuración VPN

Verificar la Conectividad entre los sitios del MPLS VPN

Verificación de la Conectividad IP del Router CE al Router CE a través de la Base MPLS

Verificación que los Routers CE Locales y Remotos estén en la Tabla de Ruteo

Ejemplos de Configuración de MPLS VPNs

Configuración de una MPLS VPN Usando BGP: Ejemplo:

Configuración de una VPN MPLS mediante RIP: Ejemplo:

Configuración de una MPLS VPN Usando Rutas Estáticas: Ejemplo:

Configuración de una VPN MPLS mediante OSPF: Ejemplo:

Configuración de una MPLS VPN Usando EIGRP: Ejemplo:

Referencias adicionales

Documentos Relacionados

Estándares

MIB

RFC

Asistencia Técnica

Información de la Función para MPLS Layer 3 VPNs


Configuración de VPNs de Capa 3 MPLS


Primera publicación: 2 de mayo de 2005
Última actualización: De agosto el 26 de 2008

Un Red privada virtual (VPN) del Multiprotocol Label Switching (MPLS) consiste en un conjunto de los sitios que se interconectan mediante una red del núcleo del proveedor MPLS. En cada sitio del cliente, uno o varios routers de borde del cliente (CE) se conectan a uno o varios routers de borde del proveedor (PE). Este módulo explica cómo crear un MPLS VPN.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea “información de la característica para MPLS la sección de la capa 3 VPN”.

Utilice Cisco Feature Navigator para buscar información sobre el soporte de plataformas y el soporte de imágenes del software Cisco IOS y Catalyst OS. Para acceder a Cisco Feature Navigator, vaya a http://www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Contenido

Prerrequisitos de VPNs MPLS de Capa 3

Restricciones de las VPNs de Capa 3 MPLS

Información sobre VPNs MPLS de Capa 3

Cómo Configurar las VPNs de Capa 3 MPLS

Ejemplos de Configuración de MPLS VPNs

Referencias adicionales

Información de la Función para MPLS Layer 3 VPNs

Prerrequisitos de VPNs MPLS de Capa 3

Antes de configurar la capa 3 VPN MPLS, usted debe tener el MPLS, el Protocolo de distribución de etiquetas (LDP), y Cisco Express Forwarding (CEF) instalado en su red. Todo el Routers en la base, incluyendo el Routers PE, debe poder soportar la expedición CEF y MPLS. Vea “evaluando las necesidades la sección de los clientes del MPLS VPN” de más información.

Restricciones de las VPNs de Capa 3 MPLS

Al configurar las Static rutas en un entorno MPLS o del MPLS VPN, algunas variaciones del ip route y ip route vrf los comandos no se soportan. Estas variaciones de los comandos no se soportan en las versiones del Cisco IOS que soportan el (TFIB) de los Tag Forwarding Information Bases, específicamente los Cisco IOS Release 12.xT, 12.xM, y 12.0S. La TFIB no puede resolver los prefijos si la ruta recurrente sobre la que viajan los prefijos desaparece y después reaparece. Sin embargo, las variaciones del comando se soportan en las versiones del Cisco IOS que soportan la infraestructura de la expedición MPLS (MFI), específicamente Cisco IOS Release 12.2(25)S y Posterior. Utilice las siguientes pautas al configurar rutas estáticas.

Rutas Estáticas Soportadas en un Entorno MPLS

Se soporta ip route el siguiente comando cuando usted configura las Static rutas en el entorno MPLS:

ip route destination-prefix mask interface next-hop-address

Se soportan ip route los siguientes comandos cuando usted configura las Static rutas en un entorno MPLS y configura la carga a compartir con las rutas no recurrentes estáticas y una interfaz de salida específica:

ip route destination-prefix mask interface1 next-hop1
ip route destination-prefix mask interface2 next-hop2

Static rutas sin apoyo en un entorno MPLS que utiliza el TFIB

El siguiente comando ip route no se soporta cuando usted configura las Static rutas en un entorno MPLS:

ip route destination-prefix mask next-hop-address

El siguiente comando ip route no se soporta cuando usted configura las Static rutas en un entorno MPLS y habilita la carga a compartir donde el salto siguiente se puede alcanzar a través de dos trayectorias:

ip route destination-prefix mask next-hop-address

El siguiente comando ip route no se soporta cuando usted configura las Static rutas en un entorno MPLS y habilita la carga a compartir donde el destino se puede alcanzar a través de dos saltos siguientes:

ip route máscara next-hop1 del prefijo de destino
ip route destination-prefix mask next-hop2

Utilice interface next-hop los argumentos al especificar las Static rutas.

Rutas Estáticas Soportadas en un Entorno VPN MPLS

Se soportan ip route vrf los siguientes comandos cuando usted configura las Static rutas en un entorno del MPLS VPN, y el salto siguiente y la interfaz están en el mismo VRF:

ip route vrfnext-hop-address de la máscara del prefijo de destino del vrf-name

ip route vrfnext-hop-address de la interfaz de la máscara del prefijo de destino del vrf-name

ip route vrfmáscara del prefijo de destino del vrf-name interface1 next-hop1
ip route vrf vrf-name destination-prefix mask interface2 next-hop2

Se soportan ip route vrf los siguientes comandos cuando usted configura las Static rutas en un entorno del MPLS VPN, y el salto siguiente está en la tabla global en la nube MPLS en la tabla de Global Routing. Por ejemplo, se soportan estos comandos cuando el salto siguiente está señalando al gateway de Internet.

ip route vrfnext-hop-address de la máscara del prefijo de destino del vrf-name global

ip route vrfnext-hop-address de la interfaz de la máscara del prefijo de destino del vrf-name
(Se soporta este comando cuando el salto siguiente y la interfaz están en la base.)

Se soportan ip route los siguientes comandos cuando usted configura las Static rutas en un entorno del MPLS VPN y habilita la carga a compartir con las rutas no recurrentes estáticas y las interfaces de salida específicas:

ip route destination-prefix mask interface1 next-hop1
ip route destination-prefix mask interface2 next-hop2

Static rutas sin apoyo en un entorno del MPLS VPN que utiliza el TFIB

El siguiente comando ip route no se soporta cuando usted configura las Static rutas en un entorno del MPLS VPN, el salto siguiente está en la tabla global en la nube MPLS dentro de la base, y usted habilita la carga a compartir donde el salto siguiente se puede alcanzar a través de dos trayectorias:

ip route vrf destination-prefix mask next-hop-address global

Los siguientes comandos ip route no se soportan cuando usted configura las Static rutas en un entorno del MPLS VPN, el salto siguiente están en la tabla global en la nube MPLS dentro de la base, y usted habilita la carga a compartir donde el destino se puede alcanzar a través de dos saltos siguientes:

ip route vrf destination-prefix mask next-hop1 global
ip route vrf destination-prefix mask next-hop2 global

Los siguientes comandos ip route vrf no se soportan cuando usted configura las Static rutas en un entorno del MPLS VPN, y el salto siguiente y la interfaz están en el mismo VRF:

ip route vrf máscara del prefijo de destino del vrf-namenext-hop1
ip route vrf
de la máscara del prefijo de destino del vrf-name
next-hop2

Rutas Estáticas Soportadas en un Entorno de MPLS VPN donde el Siguiente Salto Reside en la Tabla Global del Router CE

Se soporta ip route vrf el siguiente comando cuando usted configura las Static rutas en un entorno del MPLS VPN, y el salto siguiente está en la tabla global en el lado CE. Por ejemplo, el siguiente comando se soporta cuando el prefijo de destino es la dirección de loopback del router CE, como en los casos del eBGP multisalto.

ip route vrf vrf-name destination-prefix mask interface next-hop-address

Se soportan ip route los siguientes comandos cuando usted configura las Static rutas en un entorno del MPLS VPN, el salto siguiente están en la tabla global en el lado CE, y usted habilita la carga a compartir con las rutas no recurrentes estáticas y las interfaces de salida específicas:

ip route máscara interface1 nexthop1 del prefijo de destino
máscara interface2 nexthop2 del prefijo de destino de la ruta de IP

Información sobre VPNs MPLS de Capa 3

Antes de configurar la capa 3 VPN MPLS, usted debe undertand los conceptos siguientes:

Definición de MPLS VPN

Cómo Funciona una VPN MPLS

Principales Componentes de MPLS VPNs

Ventajas de una MPLS VPN

Definición de MPLS VPN

Antes de definir un MPLS VPN, usted necesita definir un VPN en general. Un VPN es:

Servicios red basada en IP de una red privada de entrega sobre una infraestructura pública

Un conjunto de los sitios que se permiten comunicar con uno a privado sobre Internet u otro público o redes privadas

Los VPN convencionales son creados configurando una interconexión total de los túneles o de los circuitos virtuales permanentes (PVC) a todos los sitios en un VPN. Este tipo de VPN no es fácil de mantener o de ampliarse, porque agregar un nuevo sitio requiere el cambio de cada dispositivo de borde en el VPN.

Los VPN basado en MPLS se crean en la capa 3 y se basan en el modelo del par. El modelo del par permite al proveedor de servicio y al cliente para intercambiar la información de ruteo de la capa 3. El proveedor de servicio retransmite los datos entre los sitios del cliente sin la implicación del cliente.

El MPLS VPNs es más fácil de manejar y de ampliarse que los VPN convencionales. Cuando un nuevo sitio se agrega a un MPLS VPN, sólo el router de borde del proveedor de servicio que proporciona los servicios al sitio del cliente necesita ser puesto al día.

Se describen las diversas partes del MPLS VPN como sigue:

Router del proveedor (p) — Router en la base de la Red proveedora. La transferencia del funcionamiento MPLS del Routers P, y no sujeta las escrituras de la etiqueta VPN (escritura de la etiqueta MPLS en cada ruta asignada por el router PE) a los paquetes ruteados. Las escrituras de la etiqueta VPN se utilizan para dirigir los paquetes de datos al router Egress correcto.

Router PE — El router que sujeta la escritura de la etiqueta VPN a los paquetes entrantes basó en la interfaz o la subinterfaz en las cuales se reciben. Un router PE asocia directamente a un router CE.

Router del cliente (c) — Router en el ISP o la red para empresas.

Router borde del cliente — Router de borde en la red del ISP que conecta con el router PE en la red. Un router CE debe interconectar con un router PE.

El cuadro 1 muestra un MPLS VPN básico.

Cuadro 1 terminología básica del MPLS VPN

Cómo Funciona una VPN MPLS

Las funciones del MPLS VPN se habilitan en el borde de una red MPLS. El router PE realiza el siguiente:

Intercambia las actualizaciones de ruteo por el router CE

Traduce la información de ruteo CE a las rutas del VPNv4

Rutas del VPNv4 de los intercambios con el otro Routers PE con el protocolo Protocolo de la puerta de enlace marginal (BGP) Multiprotocol (MP-BGP)

Cómo el ruteo virtual/las tablas de reenvío trabaja en un MPLS VPN

Cada VPN se asocia a uno o más los casos del ruteo virtual y de la expedición (VRF). Un VRF define las pertenencias a VPN de un sitio del cliente asociado a un router PE. Un VRF consiste en los componentes siguientes:

Una tabla de IP Routing

Una tabla CEF derivada

Un conjunto de las interfaces que utilizan la tabla de reenvío

Un conjunto de reglas y parámetros del Routing Protocol que controlan la información que se incluye en la tabla de ruteo

No existe necesariamente una relación de uno a uno entre los sitios del cliente y las VPNs. Un sitio puede ser un miembro de los VPN múltiples. Sin embargo, un sitio se puede asociar a un solo VRF. El VRF de un sitio contiene todas las rutas disponibles para el sitio de los VPN cuyo es un miembro.

La información del reenvío de paquete se salva en la tabla de IP Routing y la tabla CEF para cada VRF. Un conjunto aparte de la encaminamiento y de las tablas CEF se mantiene para cada VRF. Estas tablas evitan que la información sea remitida fuera de un VPN, y también previenen los paquetes que están fuera de un VPN del envío a un router dentro del VPN.

Cómo la información de VPN Routing se distribuye en un MPLS VPN

La distribución de la información de ruteo VPN se controla con el uso de las comunidades de destino de ruta VPN, implementado por las comunidades ampliadas BGP. Se distribuye la información de VPN Routing como sigue:

Cuando una ruta VPN que es docta de un router CE se inyecta en el BGP, una lista de atributos de la comunidad ampliada de la blanco de la ruta VPN se asocia a ella. La lista de valores ampliados comunidad de destino de Route se fija típicamente de una lista de exportación de blancos de la ruta asociadas al VRF del cual la ruta era docta.

Se asocia una lista de comunidades ampliadas de destino de ruta con cada VRF. La lista de importación define los atributos de la comunidad ampliada de la blanco de la ruta que una ruta debe tener para que la ruta sea importada en el VRF. Por ejemplo, si la lista de importación para un VRF determinado incluye a las comunidades ampliadas A, B, y C de la blanco de la ruta, después cualquier ruta VPN que lleve a ningunas de esas comunidades ampliadas de la blanco de la ruta — A, B, o C — se importa en el VRF.

Distribución BGP de la información de VPN Routing

Un router PE puede aprender un prefijo IP de las fuentes siguientes:

Un router CE por la configuración estática

Una sesión de BGP con el router CE

Un intercambio del Routing Information Protocol (RIP) con el router CE

El prefijo IP es un miembro de la familia del direccionamiento del IPv4. Después de que el router PE aprenda el prefijo IP, el PE lo convierte en un prefijo del VPN-IPv4 combinándolo con un Route Distinguisher 8-byte (RD). El prefijo generado es un miembro de la familia del direccionamiento del VPN-IPv4. Identifica únicamente el direccionamiento del cliente, incluso si el sitio del cliente está utilizando los IP Addresses global nonunique (privado desregistrada). El Route Distinguisher usado para generar el prefijo del VPN-IPv4 es especificado por un comando configuration asociado al VRF en el router PE.

El BGP distribuye la información de alcance para los prefijos del VPN-IPv4 para cada VPN. La comunicación BGP ocurre en dos niveles:

Dentro de los dominios IP, conocidos como sistema autónomo ([IBGP] interior BGP)

Entre los sistemas autónomos ([EBGP] del BGP externo)

Las sesiones PE-PE o PE-RR (reflector de ruta) son sesiones del IBGP, y las sesiones PE-CE son sesiones eBGP. En un entorno del EIGRP PE-CE, cuando una ruta interno del EIGRP es redistribuida en el BGP por un PE, después nuevamente dentro del EIGRP por otro PE, la router-identificación que origina para la ruta se fija a la router-identificación del segundo PE, substituyendo la router-identificación interna original.

El BGP propaga la información de alcance para los prefijos del VPN-IPv4 entre el Routers PE mediante las Extensiones multiprotocol BGP (refiera al RFC 2283, a las Extensiones Multiprotocol para BGP-4), que definen el soporte para las familias del direccionamiento con excepción del IPv4. El uso de las extensiones garantiza que las rutas de una VPN dada solamente resultan conocidas para otros miembros de esa VPN, lo que permite a los miembros de la VPN comunicarse entre ellos.

Expedición MPLS

De acuerdo con la información de ruteo salvada en la tabla de IP Routing VRF y la tabla CEF VRF, los paquetes se remiten a su destino usando el MPLS.

Un router PE ata una escritura de la etiqueta a cada prefijo del cliente aprendido de un router CE e incluye la escritura de la etiqueta en la información sobre el alcance de la red para el prefijo de que hace publicidad al otro Routers PE. Cuando un router PE adelante un paquete recibido de un router CE a través de la Red proveedora, él etiqueta el paquete con la escritura de la etiqueta aprendida del router del destino PE. Cuando el router del destino PE recibe el paquete etiquetado, hace estallar la escritura de la etiqueta y la utiliza para dirigir el paquete al router CE correcto. La expedición de la escritura de la etiqueta a través de la estructura básica del proveedor se basa en el Label sSwitching dinámico o las trayectorias dirigidas tráfico. Un paquete de datos del cliente lleva dos niveles de escrituras de la etiqueta al atravesar la estructura básica:

La escritura de la etiqueta superior dirige el paquete al router correcto PE.

La segunda escritura de la etiqueta indica cómo ese router PE debe remitir el paquete al router CE.

Principales Componentes de MPLS VPNs

Una red VPN basado en MPLS tiene tres componentes importantes:

Comunidades de destino de Route VPN — Una comunidad de destino de Route VPN es una lista de todos los miembros de una comunidad VPN. Las blancos de la ruta VPN necesitan ser configuradas para cada miembro de la comunidad VPN.

Mirada del Multiprotocol BGP (MP-BGP) del Routers de la comunidad VPN PE — el MP-BGP propaga la información de alcance VRF a todos los miembros de una comunidad VPN. El peering MP-BGP necesita ser configurado en todo el Routers PE dentro de una comunidad VPN.

Expedición MPLS — El MPLS transporta todo el tráfico entre todos los miembros de la comunidad VPN a través de una red del proveedor de servicios VPN.

No existe necesariamente una relación de uno a uno entre los sitios del cliente y las VPNs. Un sitio dado puede ser un miembro de los VPN múltiples. Sin embargo, un sitio se puede asociar a un solo VRF. Un sitio del cliente VRF contiene todas las rutas disponibles para el sitio de los VPN cuyo es un miembro.

Ventajas de una MPLS VPN

El MPLS VPNs permite que los proveedores de servicio desplieguen los VPN scalable y que construyan la fundación para entregar los servicios de valor agregado, incluyendo:

Servicio sin conexión — Una ventaja técnica significativa del MPLS VPNs es que están sin conexión. Internet debe su éxito a su tecnología básica, TCP/IP. El TCP/IP se emplea el paquete basado, paradigma de la red sin conexión. Esto significa que no hay acción anterior necesaria establecer la comunicación entre los hosts, haciéndola fácil para que dos partidos comuniquen. Para establecer la aislamiento en un entorno sin conexión IP, las soluciones de VPN actuales imponen un recubrimiento orientado a la conexión, de punto a punto ante la red. Incluso si funciona con encima una red sin conexión, un VPN no puede aprovecharse de la facilidad de la Conectividad y de los servicios múltiples disponibles en las redes sin conexión. Cuando usted crea un VPN sin conexión, usted no necesita los túneles y el cifrado para la aislamiento de la red, así eliminando la complejidad significativa.

Servicio centralizado — La construcción de los VPN en la capa 3 permite la salida de los servicios apuntados a un grupo de usuarios representados por un VPN. Un VPN debe dar los proveedores de servicio más que un mecanismo para los usuarios privado de conexión a los servicios del intranet. Debe también proporcionar una manera de entregar fexiblemente los servicios de valor agregado a los clientes apuntados. El scalability es crítico, porque los clientes quieren utilizar los servicios privado en sus intranets y extranets. Porque el MPLS VPNs se considera como intranets privados, usted puede utilizar los nuevos Servicios IP por ejemplo:

Multicast (multidifusión)

Calidad de Servicio (QoS)

Soporte de la telefonía dentro de un VPN

Servicios centralizados incluyendo el contenido y hosting de Web a un VPN

Usted puede personalizar varias combinaciones de servicios especializados para los clientes individuales. Por ejemplo, un servicio que combina el Multicast IP con una clase de servicio de la latencia baja habilita la videoconferencia dentro de un intranet.

Scalability — Si usted crea un VPN usando los recubrimientos, el Frame Relay, o las conexiones virtuales orientado a la conexión, de punto a punto atmósfera (VCs), la deficiencia de la clave VPN es scalability. Específicamente, los VPN orientados a la conexión sin las conexiones completamente enredadas entre los sitios del cliente no son óptimos. Los VPN basado en MPLS en lugar de otro utilizan el modelo del par y acodan la arquitectura sin conexión 3 para leverage una solución de VPN altamente scalable. El modelo del par requiere un sitio del cliente mirar con solamente un router PE en comparación con el resto del Routers de la frontera del cliente (CE) que sea miembros del VPN. La arquitectura sin conexión permite la creación de los VPN en la capa 3, eliminando la necesidad de los túneles o de VCs.

Otros problemas de ampliación del MPLS VPNs son debido a la división de las rutas VPN entre el Routers PE y la división posterior de las rutas VPN y IGP entre el Routers PE y el Routers del proveedor (p) en una red del núcleo.

El Routers PE debe mantener las rutas VPN para esos VPN que sean miembros.

El Routers P no mantiene ninguna rutas VPN.

Esto aumenta el scalability de la base del proveedor y se asegura de que nadie dispositivo es un embotellamiento del scalability.

Seguridad — Oferta del MPLS VPNs el mismo nivel de seguridad que los VPN orientados a la conexión. Los paquetes a partir de un VPN no van inadvertidamente a otro VPN.

La Seguridad se proporciona en las áreas siguientes:

En el borde de una Red proveedora, asegurando los paquetes recibidos de un cliente se colocan en el VPN correcto.

En la estructura básica, el tráfico VPN se mantiene separado. El spoofing malévolo (una tentativa de acceder a un router PE) es casi imposible porque los paquetes recibidos de los clientes son paquetes IP. Estos paquetes IP se deben recibir en una interfaz particular o una subinterfaz que se identificarán únicamente con una escritura de la etiqueta VPN.

Fácil crear — Para aprovechar completo de los VPN, los clientes deben poder crear fácilmente los nuevos VPN y a las comunidades del usuario. Porque el MPLS VPNs está sin conexión, no se requiere ningunas correspondencias o topologías de la conexión Point-to-Point del específico. Usted puede agregar los sitios a los intranets y a las extranets y crear a los grupos de usuario cerrado. El manejo de los VPN de este modo habilita la calidad de miembro de cualquier sitio dado en los VPN múltiples, maximizando la flexibilidad en los intranets y las extranets del edificio.

Dirección flexible — Para hacer un servicio VPN más accesible, los clientes de un proveedor de servicio pueden diseñar su propio plan de direccionamiento, independiente de los planes de direccionamiento para los clientes proveedor del otro servicio. Muchos clientes utilizan los espacios de dirección privada, según lo definido en el RFC 1918, y no quieren invertir la época y el costo de convertir a los IP Address públicos para habilitar la Conectividad del intranet. El MPLS VPNs permite que los clientes continúen utilizando sus actuales espacios de la dirección sin el Network Address Translation (NAT) proporcionando a un público y a una vista privada del direccionamiento. Se requiere Un NAT solamente si dos VPN con los espacios de dirección superpuesta quieren comunicar. Esto permite a los clientes para utilizar a sus propias direcciones privadas desregistradas, y comunica libremente a través de una red IP pública.

Soporte integrado del Calidad de Servicio (QoS) — QoS es un requisito importante para muchos clientes VPN IP. Proporciona la capacidad de dirigir dos requisitos fundamentales VPN:

Rendimiento predecible y implementación de directivas

Soporte para los niveles múltiples de servicio en un MPLS VPN

El tráfico de la red se clasifica y se etiqueta en el borde de la red antes de que el tráfico se agregue según las directivas definidas por los suscriptores y implementadas por el proveedor y transportadas a través de la base del proveedor. El tráfico en el borde y la base de la red se puede entonces distinguir en diversas clases por la probabilidad de caída o el retardo.

Migración directa — Para que los proveedores de servicio desplieguen rápidamente los servicios VPN, utilice un trayecto de migración directo. El MPLS VPNs es único porque usted puede construirlos sobre las arquitecturas de Red múltiple, incluyendo el IP, la atmósfera, el Frame Relay, y las redes híbridas.

La migración para el cliente final se simplifica porque no hay requisito de soportar el MPLS en el router CE y no se requiere ningunas modificaciones al intranet de un cliente.

Cómo Configurar las VPNs de Capa 3 MPLS

Para configurar y verificar los VPN, realice las tareas descritas en las secciones siguientes:

Configurando la red del núcleo (requerida)

Conectando a los clientes del MPLS VPN (requeridos)

Verificando la Conectividad entre los sitios del MPLS VPN (opcionales)

Configurar la red del núcleo

Configurar la red del núcleo incluye las tareas siguientes:

Evaluando las necesidades de los clientes del MPLS VPN (requeridos)

Configurando los Routing Protocol en la base (requerida)

Configurando el MPLS en la base (requerida)

El determinar si el CEF se habilita en la base (requerida)

Configurando el Multiprotocol BGP en el Routers y los reflectores de ruta PE (requeridos)

Evaluar las necesidades de los clientes del MPLS VPN

Antes de que usted configure un MPLS VPN, usted necesita identificar la topología de red del núcleo de modo que pueda los mejores clientes del MPLS VPN del servicio. Realice esta tarea de identificar la topología de red del núcleo.

PASOS SUMARIOS

1.Identifique los tamaños de la red.

2.Identifique los Routing Protocol.

3.Determine si usted necesita el soporte de gran disponibilidad MPLS.

4.Determine si usted necesita la carga a compartir y los trayectos redundantes BGP.

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

Identifique los tamaños de la red.

Identifique el siguiente para determinar el número de Routers y le vira hacia el lado de babor necesidad:

¿Cuántos clientes usted necesita apoyar?

¿Cuántos VPN son necesarios por el cliente?

¿Cuánto el ruteo virtual y los casos de reenvío son allí para cada VPN?

Paso 2 

Identifique los Routing Protocol en la base.

Determine que los Routing Protocol usted necesitan en la red del núcleo.

Paso 3 

Determine si usted necesita el soporte de gran disponibilidad del MPLS VPN.

La expedición y el graceful restart directos del MPLS VPN se soportan en el Routers y las versiones selectos del Cisco IOS. Entre en contacto el soporte de Cisco para los requisitos y el soporte del hardware exactos.

Paso 4 

Determine si usted necesita la carga a compartir y los trayectos redundantes BGP en la base del MPLS VPN.

Vea el tráfico del MPLS VPN de la carga a compartir para los pasos para la configuración.


Configurar los Routing Protocol en la base

Para configurar un Routing Protocol, tal como BGP, el OSPF, el IS-IS, el EIGRP, y los parásitos atmosféricos, ven el documento siguiente:

Configuración de BGP

Configurar el OSPF

Configurar el IS-IS

Configurar ERGRP

Configurar las Static rutas

Configurar el MPLS en la base

Para habilitar el MPLS en todo el Routers en la base, usted debe configurar un Label Distribution Protocol. Usted puede utilizar cualquiera del siguiente como Label Distribution Protocol:

Protocolo de distribución de etiquetas (LDP) MPLS. Para la información de la configuración, vea el Protocolo de distribución de etiquetas (LDP) MPLS.

Resource Reservation Protocol (RSVP) de la Ingeniería de tráfico MPLS. Para la información de la configuración, vea la Ingeniería de tráfico MPLS y las mejoras.

El determinar si el CEF se habilita en la base

El Cisco Express Forwarding (CEF) se debe habilitar todo el Routers en la base, incluyendo el Routers PE. Para la información sobre cómo determinar si se habilita el CEF, vea configurar el Cisco Express Forwarding básico.

Configurar el Multiprotocol BGP en el Routers y los reflectores de ruta PE

Realice esta tarea de configurar la Conectividad del Multiprotocol BGP (MP-BGP) en el Routers y los reflectores de ruta PE.

PASOS SUMARIOS

1. enable

2. configure terminal

3. router bgp as-number

4. no bgp default ipv4-unicast

5.neighbor {ip-address | peer-group-name} remote-as as-number

6.neighbor {ip-address | peer-group-name} activate

7.address-family vpnv4 []unicast

8.neighbor {ip-address | peer-group-name} send-community extended

9.neighbor {ip-address | peer-group-name} activate

10. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

router bgp as-number

Example:

Router(config)# router bgp 100

Configura un proceso de ruteo BGP e ingresa en el modo de configuración del router.

as-number El argumento indica el número de un sistema autónomo que identifique al router a otros routeres BGP y marque la información de ruteo con etiqueta pasajera adelante. Los números válidos son del 0 al 65535. Los números privados del sistema autónomo que se pueden utilizar en redes internas van del 64512 al 65535.

Paso 4 

no bgp default ipv4-unicast

Example:

Router(config-router)# no bgp default ipv4-unicast

(Opcional) Inhabilita la familia de direcciones unicast IPv4 en todos los vecinos.

Utilice no la forma bgp default ipv4-unicast del comando si usted está utilizando a este vecino para las rutas MPLS solamente.

Paso 5 

neighbor {ip-address | peer-group-name} remote-as as-number

Example:

Router(config-router)# neighbor pp.0.0.1 remote-as 100

Añade una entrada al BGP o a la tabla de vecinos BGP multiprotocolo.

ip-address El argumento especifica la dirección IP del vecino.

peer-group-name El argumento especifica el nombre de un grupo de peer de BGP.

as-number El argumento especifica el sistema autónomo al cual el vecino pertenece.

Paso 6 

neighbor {ip-address | peer-group-name} activate

Example:

Router(config-router)# neighbor pp.0.0.1 activate

Habilita el intercambio de información con un router BGP vecino.

ip-address El argumento especifica la dirección IP del vecino.

peer-group-name El argumento especifica el nombre de un grupo de peer de BGP.

Paso 7 

address-family vpnv4 [unicast]

Example:

Router(config-router)# address-family vpnv4

Ingresa en el modo de configuración de familia de direcciones para configurar sesiones de ruteo, como el BGP, que usa prefijos de dirección VPNv4 estándar.

La palabra clave optativa unicast especifica los prefijos de la dirección de Unicast del VPNv4.

Paso 8 

neighbor {ip-address | peer-group-name} send-community extended

Example:

Router(config-router-af)# neighbor pp.0.0.1 send-community extended

Especifica que se debe enviar un atributo de comunidades a un vecino BGP.

ip-address El argumento especifica la dirección IP del vecino de BGP-discurso.

peer-group-name El argumento especifica el nombre de un grupo de peer de BGP.

Paso 9 

neighbor {ip-address | peer-group-name} activate

Example:

Router(config-router-af)# neighbor pp.0.0.1 activate

Habilita el intercambio de información con un router BGP vecino.

ip-address El argumento especifica la dirección IP del vecino.

peer-group-name El argumento especifica el nombre de un grupo de peer de BGP.

Paso 10 

end

Example:

Router(config-router-af)# end

(Opcional) Sale al modo EXEC privilegiado.


Consejos de Troubleshooting

Usted puede ingresar show ip bgp neighbor un comando de verificar que los vecinos son en servicio. Si este comando no es acertado, ingrese debug ip bgp x.x.x.x events un comando, donde está el IP address x.x.x.x del vecino.

Conexión de los clientes del MPLS VPN

Para conectar a los clientes del MPLS VPN con el VPN, realice las tareas siguientes:

Definiendo los VRF en el Routers PE para habilitar la Conectividad del cliente (requerida)

Configurando las interfaces VRF en el Routers PE para cada cliente VPN (requerido)

Configurando los Routing Protocol entre el Routers PE y CE (requerido)

Definición de los VRF en el Routers PE para habilitar la Conectividad del cliente

Para definir los casos del VPN Routing and Forwarding (VRF), realice esta tarea.

PASOS SUMARIOS

1. enable

2. configure terminal

3. ip vrf vrf-name

4. rd route-distinguisher

5.route-target {import | export | both} route-target-ext-community

6. import map route-map

7. exit

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

ip vrf vrf-name

Example:

Router(config)# ip vrf vpn1

Define la instancia de ruteo de VPN mediante la asignación de un nombre de VRF e ingresa en el modo de configuración de VRF.

vrf-name El argumento es el nombre asignado a un VRF.

Paso 4 

rd route-distinguisher

Example:
Router(config-vrf)# rd 100:1

Crea tablas de reenvío y ruteo.

route-distinguisher El argumento agrega un valor 8-byte a un prefijo del IPv4 para crear un prefijo del IPv4 VPN. Puede ingresar un RD en cualquiera de estos formatos:

– Número AS de 16 bits: su número de 32 bits, por ejemplo, 101:3

– dirección IP de 32 bits: su número de 16 bits, por ejemplo, 192.168.122.15:1

Paso 5 

route-target {import |export | both} route-target-ext-community

Example:

Router(config-vrf)# route-target import 100:1

Crea a una comunidad ampliada de comando route-target para un VRF.

import La palabra clave importa la información de ruteo de la comunidad ampliada de la blanco VPN.

export La palabra clave exporta la información de ruteo a la comunidad ampliada de la blanco VPN.

both La palabra clave importa la información de ruteo de y exporta la información de ruteo a la comunidad ampliada de la blanco VPN.

route-target-ext-community El argumento agrega los atributos de la comunidad ampliada de la ruta-blanco a la lista VRF de importación, de exportación, o de ambas (importación y exportación) las comunidades ampliadas de la ruta-blanco.

Paso 6 

import map route-map

Example:

Router(config-vrf)# import map vpn1-route-map

(Opcional) Configura un route map de importación para un VRF.

route-map El argumento especifica el Route Map que se utilizará como Route Map de la importación para el VRF.

Paso 7 

exit

Example:

Router(config-vrf)# exit

(Opcional) Sale al modo de configuración global.


Configurar las interfaces VRF en el Routers PE para cada cliente VPN

Para asociar un VRF a una interfaz o a una subinterfaz en el Routers PE, realice esta tarea.

PASOS SUMARIOS

1. enable

2. configure terminal

3. interface type number

4. ip vrf forwarding vrf-name

5. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

interface type number

Example:

Router(config)# interface Ethernet 5/0

Especifica la interfaz para configurar e ingresa en el modo de configuración de la interfaz.

type El argumento especifica el tipo de interfaz que se configurará.

number El argumento especifica el puerto, el conector, o el número de placa de interfaz.

Paso 4 

ip vrf forwarding vrf-name

Example:

Router(config-if)# ip vrf forwarding vpn1

Asocia un VRF a la interfaz o subinterfaz especificada.

vrf-name El argumento es el nombre asignado a un VRF.

Paso 5 

end

Router(config-if)# end

(Opcional) Sale al modo EXEC privilegiado.


Configurar los Routing Protocol entre el Routers PE y CE

Configure al router PE con el mismo Routing Protocol que el router CE utiliza. Usted puede configurar los Routing Protocol siguientes:

Configurar el BGP como el Routing Protocol entre el Routers PE y CE

Configurar el RIPv2 como el Routing Protocol entre el Routers PE y CE

Configurar las Static rutas entre el Routers PE y CE

Configurar el OSPF como el Routing Protocol entre el Routers PE y CE

Configuración de EIGRP como Protocolo de Ruteo entre los routers PE y CE

Configuración de la Redistribución de EIGRP en MPLS VPN

Configurar el BGP como el Routing Protocol entre el Routers PE y CE

Para configurar las sesiones de la encaminamiento PE-a-CE usando el BGP, realice esta tarea.

PASOS SUMARIOS

1. enable

2. configure terminal

3. router bgp as-number

4.address-family ipv4 [multicast | unicast | vrf vrf-name]

5.neighbor {ip-address | peer-group-name} remote-as as-number

6.neighbor {ip-address | peer-group-name} activate

7. exit-address-family

8. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

router bgp as-number

Example:

Router(config)# router bgp 100

Configura un proceso de ruteo BGP e ingresa en el modo de configuración del router.

as-number El argumento indica el número de un sistema autónomo que identifique al router a otros routeres BGP y marque la información de ruteo con etiqueta pasajera adelante. Los números válidos son del 0 al 65535. Los números privados del sistema autónomo que se pueden utilizar en redes internas van del 64512 al 65535.

Paso 4 

address-family ipv4 [multicast | unicast | vrf vrf-name]

Example:

Router(config-router)# address-family ipv4 vrf vpn1

Especifica el tipo de la familia de direcciones IPv4 e ingresa en el modo de configuración de familia de direcciones.

multicast La palabra clave especifica los prefijos de la dirección Multicast del IPv4.

unicast La palabra clave especifica los prefijos de la dirección de Unicast del IPv4.

vrf vrf-name La palabra clave y el argumento especifican el nombre del VRF para asociarse a los comandos configuration mode subsiguientes de la familia del direccionamiento del IPv4.

Paso 5 

neighbor {ip-address | peer-group-name} remote-as as-number

Example:

Router(config-router-af)# neighbor pp.0.0.1 remote-as 200

Añade una entrada al BGP o a la tabla de vecinos BGP multiprotocolo.

ip-address El argumento especifica la dirección IP del vecino.

peer-group-name El argumento especifica el nombre de un grupo de peer de BGP.

as-number El argumento especifica el sistema autónomo al cual el vecino pertenece.

Paso 6 

neighbor {ip-address | peer-group-name} activate

Example:

Router(config-router-af)# neighbor pp.0.0.1 activate

Habilita el intercambio de información con un router BGP vecino.

ip-address El argumento especifica la dirección IP del vecino.

peer-group-name El argumento especifica el nombre de un grupo de peer de BGP.

Paso 7 

exit-address-family

Example:

Router(config-router-af)# exit-address-family

Sale del modo de configuración de familia de direcciones.

Paso 8 

end

Example:

Router(config-router)# end

(Opcional) Sale al modo EXEC privilegiado.

Configurar el RIPv2 como el Routing Protocol entre el Routers PE y CE

Para configurar las sesiones de la encaminamiento PE-a-CE usando el RIPv2, realice esta tarea.

PASOS SUMARIOS

1. enable

2. configure terminal

3. router rip

4.version {1 | 2}

5.direccionamiento-familia ipv4 [Multicast | unicast | vrf-name del vrf]

6.IP Address de red

7.redistribute[process-id] del protocolo {level-1 | level-1-2 | level-2} [type-value] del [metric-value]metric del [as-number]metric-type [match {internal | externo 1 | []externo del [map-tag]tag del [tag-value]route-map 2}]subnets

8. exit-address-family

9. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

router rip

Example:

Router(config)# router rip

RIP de los permisos.

Paso 4 

version {1 | 2}

Example:

Router(config-router)# version 2

Especifica una versión del Routing Information Protocol (RIP) usada global por el router.

Paso 5 

address-family ipv4 [multicast | unicast | vrf vrf-name]

Example:

Router(config-router)# address-family ipv4 vrf vpn1

Especifica el tipo de la familia de direcciones IPv4 e ingresa en el modo de configuración de familia de direcciones.

multicast La palabra clave especifica los prefijos de la dirección Multicast del IPv4.

unicast La palabra clave especifica los prefijos de la dirección de Unicast del IPv4.

vrf vrf-name La palabra clave y el argumento especifica el nombre del VRF para asociarse a los comandos configuration mode subsiguientes de la familia del direccionamiento del IPv4.

Paso 6 

network ip-address

Example:

Router(config-router-af)# network 192.168.7.0

Los permisos RASGAN en el link PE-a-CE.

Paso 7 

redistribute protocol [process-id] {level-1 | level-1-2 | level-2} [as-number] [metric metric-value] [metric-type type-value] [match {internal | external 1 | external 2}] [tag tag-value] [route-map map-tag] [subnets]

Example:

Router(config-router-af)# redistribute bgp 200

Redistribuye las rutas desde un dominio de ruteo a otro dominio de ruteo.

Para el Routing Protocol del RIPv2, utilice redistribute bgp el comando del como-número.

Vea el comando redistribute para la información sobre otros argumentos y palabras claves.

Paso 8 

exit-address-family

Example:

Router(config-router-af)# exit-address-family

Sale del modo de configuración de familia de direcciones.

Paso 9 

end

Example:

Router(config-router)# end

(Opcional) Sale al modo EXEC privilegiado.

Configurar las Static rutas entre el Routers PE y CE

Para configurar las sesiones de la encaminamiento PE-a-CE que utilizan las Static rutas, realice esta tarea.

PASOS SUMARIOS

1. enable

2. configure terminal

3.ip route vrf vrf-name

4.address-family ipv4 [multicast | unicast | vrf vrf-name]

5.redistribute[process-id] del protocolo {level-1 | level-1-2 | level-2} [type-value] del [metric-value]metric del [as-number]metric-type [match {internal | externo 1 | []externo del [map-tag]tag del [tag-value]route-map 2}]subnets

6.redistribute[process-id] del protocolo {level-1 | level-1-2 | level-2} [type-value] del [metric-value]metric del [as-number]metric-type [match {internal | externo 1 | []externo del [map-tag]tag del [tag-value]route-map 2}]subnets

7. exit-address-family

8. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

ip route vrf vrf-name

Example:

Router(config)# ip route vrf 200

Define los parámetros de la Static ruta para cada sesión PE-a-CE.

Paso 4 

address-family ipv4 [multicast | unicast | vrf vrf-name]

Example:

Router(config-router)# address-family ipv4 vrf vpn1

Especifica el tipo de la familia de direcciones IPv4 e ingresa en el modo de configuración de familia de direcciones.

multicast La palabra clave especifica los prefijos de la dirección Multicast del IPv4.

unicast La palabra clave especifica los prefijos de la dirección de Unicast del IPv4.

vrf vrf-name La palabra clave y el argumento especifica el nombre del VRF para asociarse a los comandos configuration mode subsiguientes de la familia del direccionamiento del IPv4.

Paso 5 

redistribute protocol [process-id] {level-1 | level-1-2 | level-2} [as-number] [metric metric-value] [metric-type type-value] [match {internal | external 1 | external 2}] [tag tag-value] [route-map map-tag] [subnets]

Example:

Router(config-router-af)# redistribute static

Redistribuye las rutas desde un dominio de ruteo a otro dominio de ruteo.

Para redistribuir las Static rutas VRF en la tabla BGP VRF, utilice redistribute static el comando.

Vea el comando para la información sobre otros argumentos y palabras claves.

Paso 6 

redistribute protocol [process-id] {level-1 | level-1-2 | level-2} [as-number] [metric metric-value] [metric-type type-value] [match {internal | external 1 | external 2}] [tag tag-value] [route-map map-tag] [subnets]

Example:

Router(config-router-af)# redistribute connected

Redistribuye las rutas desde un dominio de ruteo a otro dominio de ruteo.

Para redistribuir directamente las redes conectadas en la tabla BGP VRF, utilice redistribute connected el comando.

Vea redistribute el comando para la información sobre otros argumentos y palabras claves.

Paso 7 

exit-address-family

Example:

Router(config-router-af)# exit-address-family

Sale del modo de configuración de familia de direcciones.

Paso 8 

end

Example:

Router(config-router)# end

(Opcional) Sale al modo EXEC privilegiado.

Configurar el OSPF como el Routing Protocol entre el Routers PE y CE

Para configurar las sesiones de la encaminamiento PE-a-CE que utilizan el OSPF, realice esta tarea.

PASOS SUMARIOS

1. enable

2. configure terminal

3.router ospf [vpn-name] proceso-identificaciónvrf

4.network ID de área basado en wildcardarea del IP address

5.address-family ipv4 [multicast | unicast | vrf vrf-name]

6.redistribute[process-id] del protocolo {level-1 | level-1-2 | level-2} [type-value] del [metric-value]metric del [as-number]metric-type [match {internal | externo 1 | external 2}] []tag del [map-tag]route-map del [tag-value]subnets

7. exit-address-family

8. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

router ospf process-id [vrf vpn-name]

Example:

Router(config)# router ospf 1 vrf grc

Habilita el ruteo OSPF e ingresa al modo de configuración de router.

process-id El argumento identifica el proceso OSPF.

vrf La palabra clave y vpn-name el argumento identifican un VPN. Cree un proceso OSPF separado para cada VRF que reciba las rutas VPN.

Paso 4 

network ip-address wildcard-mask area area-id

Example:

Router(config-router)# network 192.168.129.16 0.0.0.3 area 20

Define las interfaces en las cuales los funcionamientos OSPF y definen el ID de área para esas interfaces.

El argumento de IP Address identifica la dirección IP.

El argumento basado en wildcard identifica la máscara del IP-direccionamiento-tipo que incluye los bits del sin importancia.

El argumento del ID de área identifica el área que debe ser asociada al intervalo de direcciones OSPF. Puede ser especificado como valor decimal o como dirección IP. Para asociar las áreas a las subredes IP, especifique a una dirección de subred como el valor del argumento del ID de área.

Paso 5 

address-family ipv4 [multicast | unicast | vrf vrf-name]

Example:

Router(config-router)# address-family ipv4 vrf vpn1

Especifica el tipo de la familia de direcciones IPv4 e ingresa en el modo de configuración de familia de direcciones.

multicast La palabra clave especifica los prefijos de la dirección Multicast del IPv4.

unicast La palabra clave especifica los prefijos de la dirección de Unicast del IPv4.

vrf vrf-name La palabra clave y el argumento especifican el nombre del VRF para asociarse a los comandos configuration mode subsiguientes de la familia del direccionamiento del IPv4.

Paso 6 

redistribute protocol [process-id] {level-1 | level-1-2 | level-2} [as-number] [metric metric-value] [metric-type type-value] [match {internal | external 1 | external 2}] [tag tag-value] [route-map map-tag] [subnets]

Example:
Router(config-router-af)#  redistribute rip metric 1 
subnets

Redistribuye las rutas desde un dominio de ruteo a otro dominio de ruteo.

Usted puede necesitar incluir varios protocolos para asegurarse de que todas las rutas del IBGP están distribuidas en el VRF.

Vea el comando redistribute para la información sobre otros argumentos y palabras claves.

Paso 7 

exit-address-family

Example:

Router(config-router-af)# exit-address-family

Sale del modo de configuración de familia de direcciones.

Paso 8 

end

Example:

Router(config-router)# end

(Opcional) Sale al modo EXEC privilegiado.

Configuración de EIGRP como Protocolo de Ruteo entre los routers PE y CE

Usando el Enhanced Interior Gateway Routing Protocol (EIGRP) entre el Routers PE y CE permite que usted transparente conecte las redes del cliente del EIGRP a través de una red del núcleo habilitado para MPLS BGP para redistribuir las rutas EIGRP con el VPN a través de la red de BGP como rutas del Internal BGP (iBGP).

Para configurar las sesiones de la encaminamiento PE-a-CE que utilizan el EIGRP, realice esta tarea.

Prerrequisitos

El BGP se debe configurar en el núcleo de la red.

PASOS SUMARIOS

1. enable

2. configure terminal

3. router bgp as-number

4. no synchronization

5. neighbor ip-address remote-as as-number

6.neighbor ip-address update-source loopback interface-number

7. address-family vpnv4

8. neighbor ip-address activate

9. neighbor ip-address send-community extended

10. exit-address-family

11. address-family ipv4 vrf vrf-name

12. redistribute eigrp as-number []metric metric-valuedel []route-map map-name

13. no synchronization

14. exit-address-family

15. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

router bgp as-number

Example:

Router(config)# router bgp 10

Ingresa en el modo de configuración de router y crea un proceso de ruteo BGP.

Paso 4 

no synchronization

Example:

Router(config-router)# no synchronization

Configura BGP para que envíe anuncios sin esperar a sincronizar con el IGP.

Paso 5 

neighbor ip-address remote-as as-number

Example:

Router(config-router)# neighbor 10.0.0.1 remote-as 10

Establece el peering con el vecino o el grupo de peers especificado.

En este paso, usted está estableciendo una sesión del iBGP con el router PE que está conectado con el router CE en el otro sitio CE.

Paso 6 

neighbor ip-address update-source loopback interface-number

Example:

Router(config-router)# neighbor 10.0.0.1 update-source loopback 0

Configuraciones BGP para utilizar cualquier interfaz operativa para las conexiones TCP.

Este paso para la configuración no se requiere. Sin embargo, el proceso de ruteo BGP será menos susceptible a las influencias de la interfaz o del link inestable.

Paso 7 

address-family vpnv4

Example:

Router(config-router)# address-family vpnv4

Ingresa al modo de configuración de la familia del direccionamiento para configurar las sesiones de la encaminamiento que utilizan los prefijos de dirección estándar del IPv4, tales como BGP, RIP, y las sesiones del Static Routing.

Paso 8 

neighbor ip-address activate

Example:

Router(config-router-af)# neighbor 10.0.0.1 activate

Establece el peering con el vecino o el grupo de peers especificado.

En este paso, usted está activando el intercambio de la información de ruteo del VPNv4 entre el Routers PE.

Paso 9 

neighbor ip-address send-community extended

Example:

Router(config-router-af)# neighbor 10.0.0.1 send-community extended

Configura el router local para enviar la información de atributo de la comunidad ampliada al vecino especificado.

Este paso se requiere para el intercambio de los atributos de la comunidad ampliada del EIGRP.

Paso 10 

exit-address-family

Example:

Router(config-router-af)# exit-address-family

Sale del modo de configuración de la familia de direcciones y entra en el modo de configuración de routers.

Paso 11 

address-family ipv4 vrf vrf-name

Example:

Router(config-router)# address-family ipv4 vrf RED

Configura a una direccionamiento-familia del IPv4 para el EIGRP VRF y ingresa al modo de configuración de la familia del direccionamiento.

Una direccionamiento-familia el VRF necesita ser configurada para cada EIGRP VRF que se ejecuta entre el Routers PE y CE.

Paso 12 

redistribute eigrp as-number [metric metric-value][route-map map-name]

Example:

Router(config-router-af)# redistribute eigrp 101

Redistribuye el EIGRP VRF en el BGP.

El número del sistema autónomo de la red CE se configura en este paso.

Paso 13 

no synchronization

Example:

Router(config-router-af)# no synchronization

Configura BGP para que envíe anuncios sin esperar a sincronizar con el IGP.

Paso 14 

exit-address-family

Example:

Router(config-router-af)# exit-address-family

Sale del modo de configuración de la familia de direcciones y entra en el modo de configuración de routers.

Paso 15 

end

Example:

Router(config-router)# end

Sale del modo de configuración del router e ingresa en el modo EXEC privilegiado.

Configuración de la Redistribución de EIGRP en MPLS VPN

Realice esta tarea a cada router PE que proporcione los servicios VPN para habilitar la redistribución de EIGRP en el MPLS VPN.

Prerrequisitos

El métrico se debe configurar para las rutas de los sistemas autónomos del EIGRP externo y de las redes del NON-EIGRP antes de que estas rutas se puedan redistribuir en un router CE del EIGRP. El métrico se puede configurar en la declaración de la redistribución usando el comando redistribute (ip) o configurar con el comando del (EIGRP) del Default-metric. Si una ruta externo se recibe de otro sistema autónomo EIGRP o de una red del NON-EIGRP sin una medición configurado, la ruta no será hecha publicidad al router CE.

Restricciones

La redistribución entre el EIGRP nativo VRF no se soporta. Éste es comportamiento diseñado.

PASOS SUMARIOS

1. enable

2. configure terminal

3. router eigrp as-number

4.address-family ipv4 [multicast | unicast | vrf vrf-name]

5. network ip-address wildcard-mask

6.redistribute bgp {as-number} []metric bandwidth delay reliability load mtudel []route-map map-name

7. autonomous-system as-number

8. exit-address-family

9. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

router eigrp as-number

Example:

Router(config)# router eigrp 1

Ingresa en el modo de configuración del router y crea un proceso de ruteo EIGRP.

El proceso de EIGRP Routing para el router PE se crea en este paso.

Paso 4 

address-family ipv4 [multicast | unicast | vrf vrf-name]

Example:

Router(config-router)# address-family ipv4 vrf RED

Ingresa al modo de configuración de la direccionamiento-familia y crea un VRF.

El nombre VRF debe hacer juego el nombre VRF que fue creado en la sección anterior.

Paso 5 

network ip-address wildcard-mask

Example:

Router(config-router-af)# network 172.16.0.0 0.0.255.255

Especifica la red para el VRF.

La declaración de la red se utiliza para identificar que interconecta para incluir en el EIGRP. El VRF se debe configurar con los direccionamientos que bajan dentro del rango basado en wildcard de la declaración de la red.

Paso 6 

redistribute bgp {as-number} [metric bandwidth delay reliability load mtu] [route-map map-name]

Example:

Router(config-router-af)# redistribute bgp 10 metric 10000 100 255 1 1500

Redistribuye el BGP en el EIGRP.

El número del sistema autónomo y el métrico de la red de BGP se configura en este paso. El BGP se debe redistribuir en el EIGRP para que el sitio CE valide las rutas BGP que llevan la información EIGRP. Una necesidad métrica también se especifique para la red de BGP y se configura en este paso.

Paso 7 

autonomous-system as-number

Example:

Router(config-router-af)# autonomous-system 101

Especifica el número del sistema autónomo de la red EIGRP para el sitio del cliente.

Paso 8 

exit-address-family

Example:

Router(config-router-af)# exit-address-family

Sale del modo de configuración de la familia de direcciones y entra en el modo de configuración de routers.

Paso 9 

end

Example:

Router(config-router)# end

Sale del modo de configuración del router e ingresa en el modo EXEC privilegiado.

Verificar la configuración VPN

Un Route Distinguisher se debe configurar para el VRF, y el MPLS se debe configurar en las interfaces que llevan el VRF. Utilice show ip vrf el comando de verificar el Route Distinguisher (RD) y de interconectar que se configura para el VRF.

PASOS SUMARIOS

1. show ip vrf

PASOS DETALLADOS


Paso 1 show ip vrf

Utilice este comando de visualizar el conjunto de los casos definidos VRF y de las interfaces asociadas. La salida también asocia los casos VRF al Route Distinguisher configurado.


Verificar la Conectividad entre los sitios del MPLS VPN

Para verificar que el Routers local y remoto CE pueda comunicar a través de la base MPLS, realice las tareas siguientes:

Verificación de la Conectividad IP del Router CE al Router CE a través de la Base MPLS

Verificación que los Routers CE Locales y Remotos estén en la Tabla de Ruteo

Verificación de la Conectividad IP del Router CE al Router CE a través de la Base MPLS

Realice esta tarea de verificar la conectividad del IP del router CE al router CE a través del MPLS VPN.

PASOS SUMARIOS

1. enable

2.ping []protocol{host-name | system-address}

3.trace []protocoldel []destination

4.show ip route []ip-address maskdel [[]longer-prefixes] | [[]protocol process-id] | [list access-list-number | access-list-name]

5. disable

PASOS DETALLADOS


Paso 1 enable

Utilice este comando para habilitar el modo EXEC privilegiado.

[]del pasoping 2protocol {host-name | system-address}

Utilice este comando a la conectividad de red básica de las diagnosis en el APPLETALK, el CLNS, el IP, el Novell, Apolo, el VINES, el DECNet, o las redes XNS. Utilice ping el comando de verificar la Conectividad a partir de un router CE a otro.

[]del []trace del pasoprotocol 3destination

Utilice este comando de descubrir las rutas que los paquetes toman al viajar a su destino. Utilice trace el comando de verificar la trayectoria que un paquete vaya a través antes de alcanzar el destino final. trace El comando puede ayudar a aislar un lugar problemático si dos Routers no puede comunicar.

[]del [ip-address [mask]show ip route del paso 4longer-prefixes] | [[]protocolprocess-id] | [list access-list-number | access-list-name]

Utilice este comando de visualizar al estado actual de la tabla de ruteo. Utilice ip-address el argumento para verificar que el CE1 tiene una ruta al CE2. Verifique las rutas aprendidas por el CE1. Asegúrese de que se incluye la ruta de CE2.


Verificación que los Routers CE Locales y Remotos estén en la Tabla de Ruteo

Realice esta tarea de marcar que el Routers local y remoto CE está en la tabla de ruteo del Routers PE.

PASOS SUMARIOS

1. enable

2.show ip route vrf vrf-name []prefix

3.show ip cef vrf vrf-name []ip-prefix

4. exit


Paso 1 enable

Utilice este comando para habilitar el modo EXEC privilegiado.

[]del pasoshow ip route vrf vrf-name 2prefix

Utilice este comando de visualizar la tabla de IP Routing asociada a un VRF. Marque que los Loopback Address del Routers local y remoto CE están en la tabla de ruteo del Routers PE.

[]del pasoshow ip cef vrf vrf-name 3ip-prefix

Utilice este comando de visualizar la tabla de reenvío CEF asociada a un VRF. Marque que el prefijo del router CE remoto está en la tabla CEF.

Paso 4 exit


Ejemplos de Configuración de MPLS VPNs

Configuración de una MPLS VPN Usando BGP: Ejemplo:

Configuración de una VPN MPLS mediante RIP: Ejemplo:

Configuración de una MPLS VPN Usando Rutas Estáticas: Ejemplo:

Configuración de una VPN MPLS mediante OSPF: Ejemplo:

Configuración de una MPLS VPN Usando EIGRP: Ejemplo:

Configuración de una MPLS VPN Usando BGP: Ejemplo:

Este ejemplo muestra un MPLS VPN que se configura usando el BGP.

Configuración de PE
Configuración CE

ip vrf vpn1

 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
ip cef
mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
interface Ethernet0/0
 ip vrf forwarding vpn1
 ip address 34.0.0.2 255.0.0.0
 no cdp enable
!
interface Ethernet 1/1
ip address 30.0.0.1 255.0.0.0
mpls label protocol ldp
mpls ip
!
router ospf 100
network 10.0.0. 0.0.0.0 area 100
network 30.0.0.0 0.255.255.255 area 100
!
router bgp 100
 no synchronization
 bgp log-neighbor changes
 neighbor 10.0.0.3 remote-as 100
 neighbor 10.0.0.3 update-source Loopback0
no auto-summary
 !        
address-family vpnv4
 neighbor 10.0.0.3 activate
 neighbor 10.0.0.3 send-community extended
 bgp scan-time import 5
 exit-address-family
 !        
address-family ipv4 vrf vpn1
 redistribute connected
 neighbor 34.0.0.1 remote-as 200
 neighbor 34.0.0.1 activate
 neighbor 34.0.0.1 as-override
 neighbor 34.0.0.1 advertisement-interval 5
 no auto-summary
 no synchronization
 exit-address-family

ip cef

mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
 ip address 10.0.0.9 255.255.255.255
!
interface Ethernet0/0
 ip address 34.0.0.1 255.0.0.0
 no cdp enable
!
router bgp 200
 bgp log-neighbor-changes
 neighbor 34.0.0.2 remote-as 100
 !        
address-family ipv4
 redistribute connected
 neighbor 34.0.0.2 activate
 neighbor 34.0.0.2 advertisement-interval 5
 no auto-summary
 no synchronization
 exit-address-family

Configuración de una VPN MPLS mediante RIP: Ejemplo:

Este ejemplo muestra un MPLS VPN que se configura usando el RIP.

Configuración de PE
Configuración CE

ip vrf vpn1

 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
ip cef
mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
interface Ethernet0/0
 ip vrf forwarding vpn1
 ip address 34.0.0.2 255.0.0.0
 no cdp enable
interface Ethernet 1/1
ip address 30.0.0.1 255.0.0.0
mpls label protocol ldp
mpls ip 
!
router rip
version 2
timers basic 30 60 60 120 
!
address-family ipv4 vrf vpn1
version 2
redistribute bgp 100 metric transparent
network 34.0.0.0
distribute-list 20 in
no auto-summary
exit-address-family 
!
router bgp 100
no synchronization
bgp log-neighbor changes
neighbor 10.0.0.3 remote-as 100
neighbor 10.0.0.3 update-source Loopback0
no auto-summary
!        
address-family vpnv4
 neighbor 10.0.0.3 activate
 neighbor 10.0.0.3 send-community extended
 bgp scan-time import 5
 exit-address-family
!        
address-family ipv4 vrf vpn1
 redistribute connected
 redistribute rip
 no auto-summary
 no synchronization
 exit-address-family

ip cef

mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
 ip address 10.0.0.9 255.255.255.255
!
interface Ethernet0/0
 ip address 34.0.0.1 255.0.0.0
 no cdp enable
router rip
 version 2
 timers basic 30 60 60 120
 redistribute connected
 network 10.0.0.0
 network 34.0.0.0
 no auto-summary

Configuración de una MPLS VPN Usando Rutas Estáticas: Ejemplo:

Este ejemplo muestra un MPLS VPN que se configura usando las Static rutas.

Configuración de PE
Configuración CE

ip vrf vpn1

 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
ip cef
mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
interface Ethernet0/0
 ip vrf forwarding vpn1
 ip address 34.0.0.2 255.0.0.0
 no cdp enable
!
interface Ethernet 1/1
ip address 30.0.0.1 255.0.0.0
mpls label protocol ldp
mpls ip
!
router ospf 100
network 10.0.0. 0.0.0.0 area 100
network 30.0.0.0 0.255.255.255 area 100
!
router bgp 100
 no synchronization
 bgp log-neighbor changes
 neighbor 10.0.0.3 remote-as 100
 neighbor 10.0.0.3 update-source Loopback0
no auto-summary
 !        
address-family vpnv4
 neighbor 10.0.0.3 activate
 neighbor 10.0.0.3 send-community extended
 bgp scan-time import 5
 exit-address-family
 !        
address-family ipv4 vrf vpn1
 redistribute connected
 redistribute static
 no auto-summary
 no synchronization
 exit-address-family
!         
ip route vrf vpn1 10.0.0.9 255.255.255.255 
34.0.0.1
ip route vrf vpn1 34.0.0.0 255.0.0.0 34.0.0.1

ip cef

!
interface Loopback0
 ip address 10.0.0.9 255.255.255.255
!
interface Ethernet0/0
 ip address 34.0.0.1 255.0.0.0
 no cdp enable
!
ip route 10.0.0.9 255.255.255.255 34.0.0.2 3
ip route 31.0.0.0 255.0.0.0 34.0.0.2 3

Configuración de una VPN MPLS mediante OSPF: Ejemplo:

Este ejemplo muestra un MPLS VPN que se configura usando el OSPF.

Configuración de PE
Configuración CE

ip vrf vpn1

 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
ip cef
mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
interface Ethernet0/0
 ip vrf forwarding vpn1
 ip address 34.0.0.2 255.0.0.0
 no cdp enable
!
router ospf 1000 vrf vpn1
 log-adjacency-changes
 redistribute bgp 100 metric-type 1 subnets
 network 10.0.0.13 0.0.0.0 area 10000
 network 34.0.0.0 0.255.255.255 area 10000
! 
router bgp 100
no synchronization
bgp log-neighbor changes
neighbor 10.0.0.3 remote-as 100
neighbor 10.0.0.3 update-source Loopback0
no auto-summary
 !        
address-family vpnv4
 neighbor 10.0.0.3 activate
 neighbor 10.0.0.3 send-community extended
 bgp scan-time import 5
 exit-address-family
 !        
address-family ipv4 vrf vpn1
redistribute connected
redistribute ospf 1000 match internal 
external 1 external 2
no auto-summary
no synchronization
exit-address-family

ip cef

mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
 ip address 10.0.0.9 255.255.255.255
!
interface Ethernet0/0
 ip address 34.0.0.1 255.0.0.0
 no cdp enable
!
router ospf 1000
log-adjacency-changes
auto-cost reference-bandwidth 1000
redistribute connected subnets
network 34.0.0.0 0.255.255.255 area 1000
network 10.0.0.0 0.0.0.0 area 1000

Configuración de una MPLS VPN Usando EIGRP: Ejemplo:

Este ejemplo muestra un MPLS VPN que se configura usando el EIGRP.

Configuración de PE
Configuración CE

ip vrf vpn1

 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
ip cef
mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
interface Ethernet0/0
 ip vrf forwarding vpn1
 ip address 34.0.0.2 255.0.0.0
 no cdp enable
interface Ethernet 1/1
ip address 30.0.0.1 255.0.0.0
mpls label protocol ldp
mpls ip
router eigrp 1000
 auto-summary   
!
address-family ipv4 vrf vpn1
 redistribute bgp 100 metric 10000 100 255 
1 1500
 network 34.0.0.0
 distribute-list 20 in
 no auto-summary
 autonomous-system 1000
 exit-address-family
!
router bgp 100
no synchronization
bgp log-neighbor changes
neighbor 10.0.0.3 remote-as 100
neighbor 10.0.0.3 update-source Loopback0
no auto-summary
 !        
address-family vpnv4
 neighbor 10.0.0.3 activate
 neighbor 10.0.0.3 send-community extended
 bgp scan-time import 5
 exit-address-family
 !        
address-family ipv4 vrf vpn1
 redistribute connected
 redistribute eigrp
 no auto-summary
 no synchronization
 exit-address-family

ip cef

mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
 ip address 10.0.0.9 255.255.255.255
!
interface Ethernet0/0
 ip address 34.0.0.1 255.0.0.0
 no cdp enable
!
router eigrp 1000
 network 34.0.0.0
 auto-summary

Referencias adicionales

Las secciones siguientes proporcionan referencias relacionadas con MPLS VPNs.

Documentos Relacionados


Estándares

Estándar
Título

Esta función no soporta estándares nuevos o modificados, y el soporte de los estándares existentes no ha sido modificado por ella.


MIB

MIB
Link del MIB

Esta función no soporta MIBs nuevas o modificadas, y el soporte para las MIBs existentes no ha sido modificado por esta función.

Para localizar y descargar MIB de plataformas, versiones de Cisco IOS y conjuntos de funciones seleccionados, utilice Cisco MIB Locator, que se encuentra en la siguiente URL:

http://www.cisco.com/cisco/web/LA/support/index.html


RFC

RFC
Título

RFC 2547

BGP/MPLS VPN


Asistencia Técnica

Descripción
Link

El sitio Web de soporte técnico de Cisco proporciona los recursos en línea extensos, incluyendo la documentación y las herramientas para localizar averías y resolver los problemas técnicos con los Productos Cisco y las Tecnologías.

Para recibir la Seguridad y la información técnica sobre sus Productos, usted puede inscribir a los diversos servicios, tales como la herramienta de alerta del producto (accedida de los Field Notice), el hoja informativa de los servicios técnicos de Cisco, y alimentaciones realmente simples de la sindicación (RSS).

El acceso a la mayoría de las herramientas en el sitio Web de soporte técnico de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html


Información de la Función para MPLS Layer 3 VPNs

La Tabla 1 muestra el historial de versiones de esta función.

Puede que no estén disponibles todos los comandos en su versión de software de Cisco IOS. Para la información de versión sobre un comando específico, vea la documentación de referencia de comandos.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software. Cisco Feature Navigator le permite determinar qué imágenes de Cisco IOS y Catalyst OS Software soportan una versión de software, un conjunto de funciones o una plataforma específica. Para acceder a Cisco Feature Navigator, vaya a http://www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.


Observelas listas del cuadro 1 solamente la versión de Cisco IOS Software que introdujo el soporte para una característica dada en un tren de versión del Cisco IOS Software dado. A menos que se indique lo contrario, las versiones posteriores de dicha serie de versiones de software de Cisco IOS también soportan esa función.


Información de la característica del cuadro 1 para la capa 3 VPN MPLS

Nombre de la función
Versiones
Información de la Configuración de la Función

Redes privadas virtuales MPLS

12.0(5)T

12.0(21)ST

12.0(22)S

12.0(23)S

12.2(13)T

12.2(14)S

12.0(26)S

Esta característica permite un conjunto de los sitios que ser interconectado mediante una red del núcleo del proveedor MPLS. En cada sitio del cliente, uno o varios routers de borde del cliente (CE) se conectan a uno o varios routers de borde del proveedor (PE).

Las secciones siguientes proporcionan información acerca de esta función:

Definición de MPLS VPN

Cómo Funciona una VPN MPLS

Principales Componentes de MPLS VPNs

Ventajas de una MPLS VPN

Cómo Configurar las VPNs de Capa 3 MPLS

Soporte del MPLS VPN para el EIGRP entre el borde del proveedor y la frontera del cliente

12.0(22)S

12.2(15)T

12.2(18)S

12.0(27)S

Esta característica permite que usted conecte a los clientes que ejecutan el EIGRP con un MPLS VPN.

Las secciones siguientes proporcionan información acerca de esta función:

Configuración de EIGRP como Protocolo de Ruteo entre los routers PE y CE

Configuración de la Redistribución de EIGRP en MPLS VPN