Fundamentales guía de configuración de la configuración del Cisco IOS, versión 12.2SR
División de la configuración
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 218 KB | Inglés (17 Marzo 2008) | Comentarios

Contenidos

División de la configuración

Contenido

Información sobre Configuration Partitioning

Configuraciones en Ejecución en el Sistema

Recuperación de la Configuración en Ejecución para las Operaciones de Visualización o Copia

Ventajas de la Creación de Particiones de la Configuración en Ejecución

Cómo Utilizar la Función Configuration Partitioning

Visualizar las divisiones de la configuración

Inhabilitar la configuración que divide la característica

Pasos Siguientes

Ejemplos de Configuración para Configuration Partitioning

Visualización de las Particiones de la Configuración: Ejemplo:

Referencias adicionales

Documentos Relacionados

Estándares

MIB

RFC

Asistencia Técnica

Referencia de Comandos

Información sobre la Función Configuration Partitioning


División de la configuración


Primera publicación: De febrero el 26 de 2007
Última actualización: De octubre el 17 de 2008

La función de partición de configuración proporciona modularización (“partición”) del estado de configuración en funcionamiento para proporcionar acceso granular a la configuración en funcionamiento de Cisco IOS Software.

Esta función está habilitada de forma predeterminada en las imágenes de Cisco IOS Software que incluyen esta función.

El estado de la configuración de un dispositivo se extrae dinámicamente siempre que un usuario publique show running-config el comando. Cuando la configuración que divide la característica se habilita, los Grupos del sistema el estado de la configuración del dispositivo en las piezas (llamadas las “divisiones”) para solamente extraer el estado de la configuración los deseos del usuario a revisar al generar una lista visualizada de comandos en la configuración corriente. Esta función mejora el rendimiento de los sistemas más avanzados con configuraciones complejas porque solamente se procesa una parte del estado de la configuración en ejecución al generar la lista de comandos de configuración en ejecución, en contraposición con el método existente de procesar el estado de la configuración del sistema completo.

Las particiones de configuración predeterminadas se proporcionan mediante la introducción de esta función; otras Características del Software Cisco IOS pueden definir sus propias divisiones del comando en versiones posteriores.

Cómo Encontrar Información sobre Funciones en Este Módulo

Esta característica fue introducida en las imágenes del software para las Cisco 7600 Series en la versión 12.2(33)SRB. Las actualizaciones adicionales de la integración de la versión serán agregadas a la “información de la característica para la configuración que divide” la sección como están disponibles.

Búsqueda de Información de Soporte de Plataformas e Imágenes de Software de Cisco IOS y Catalyst OS

Utilice Cisco Feature Navigator para buscar información sobre el soporte de plataformas y el soporte de imágenes del software Cisco IOS y Catalyst OS. Para acceder a Cisco Feature Navigator, vaya a http://www.cisco.com/go/cfn. Una cuenta en Cisco.com no se requiere.

Contenido

Información sobre Configuration Partitioning

Cómo Utilizar la Función Configuration Partitioning

Ejemplos de Configuración para Configuration Partitioning

Referencias adicionales

Referencia de Comandos

Información sobre la Función Configuration Partitioning

Información sobre Configuration Partitioning

Para utilizar la configuración que divide la característica, usted debe entender los conceptos siguientes:

Configuraciones en Ejecución en el Sistema

Recuperación de la Configuración en Ejecución para las Operaciones de Visualización o Copia

Ventajas de la Creación de Particiones de la Configuración en Ejecución

Configuraciones en Ejecución en el Sistema

El manejo de la configuración de cualquier dispositivo basado en software del Cisco IOS implica el manejar de la configuración de inicio (lanzamiento-config), que es un archivo salvado en la memoria no volátil, y de la configuración corriente (ejecutar-config), que es el conjunto de toda la opción de configuración actualmente en efecto en el sistema. Típicamente, el archivo de configuración de inicio se carga cuando los arranques del sistema, y cambia a la configuración corriente del sistema, aplicada usando el comando line interface(cli), es guardado copiando la configuración corriente a un archivo de configuración (o localmente o en la red), que se puede entonces utilizar para configurar el dispositivo en el lanzamiento, o utilizado para configurar los otros dispositivos.

Recuperación de la Configuración en Ejecución para las Operaciones de Visualización o Copia

En el modelo de configuración de Cisco IOS Software, el estado de configuración se mantiene de una manera distribuida, almacenando cada componente su propio estado de configuración. Para extraer la información de configuración global, el software debe sondear cada componente para recoger la información distribuida. Esta operación de la extracción del estado de la configuración es realizada por un proceso conocido como generación permanente (NVGEN), y es invocada por los comandos por ejemplo show running-config, que se utiliza para visualizar el estado de la configuración actual, y copy system:running-configuration, que es utilizada para salvar la configuración corriente copiándola a un archivo. Cuando está invocada, el NVGEN de proceso pregunta cada componente del sistema, cada caso de la interfaz, y el resto de los objetos componentes configurados en una secuencia estándar. Se construye un archivo de configuración corriente como NVGEN atraviesa el sistema que realiza estas interrogaciones, y es este “archivo virtual” se visualiza o se copia que.

Ventajas de la Creación de Particiones de la Configuración en Ejecución

La configuración que divide la característica es la más última en una serie de las características de la mejora en el rendimiento de la generación de la configuración para el Cisco IOS Software. (Véase que “relacionó la sección de los documentos” para las características relacionadas.) Esta característica mejora el tiempo de respuesta del sistema proporcionando a un método para preguntar solamente el componente del sistema que usted desea revisar al publicar show running-config el comando.

Cuando la configuración que divide la característica se habilita, los Grupos del sistema el estado de la configuración del dispositivo en las partes (llamadas las “divisiones”) con el fin de generar el archivo de configuración corriente virtual (la lista de comandos configuration). Un comando new show running-config partition, permite que usted visualice solamente la parte de la configuración corriente que usted quiere examinar, bastante que teniendo que visualizar la configuración corriente entera inmediatamente, o visualizando solamente las líneas que hacen juego cierta cadena.

El beneficio fundamental de esta característica es que aumenta el rendimiento del sistema permitiendo que el sistema ejecute el NVGEN de proceso para solamente la colección de componentes del sistema (tales como interfaces específicas) esos usted necesidad de visualizar. Esto está en contraste con otras Extensiones existentes show running-config al comando, que filtran solamente los componentes del sistema generados de la lista después de todo se han procesado.

El proceso selectivo del estado de la configuración de sistema con el fin de generar una configuración corriente parcial se llama “división de la configuración.”

Un acceso más granular a la información de la configuración ofrece a los beneficios de rendimiento importantes para las plataformas de ruteo de gama alta con los archivos de configuración muy grandes, mientras que también aumenta la administración de la configuración permitiendo que las características de configuración avanzada sean implementadas en un nivel más granular. La opción de configuración avanzada incluye el soporte del Cisco IOS Software para disposición de los servicios al cliente, de la restauración no actualizada de los Config, de los Config que bloquean, y del control de acceso de la configuración.

Cómo Utilizar la Función Configuration Partitioning

Esta sección contiene las siguientes tareas:

Visualizando las divisiones de la configuración (opcionales)

Inhabilitando la configuración que divide la característica (opcional)

Visualizar las divisiones de la configuración

El método principal de aprovecharse esta característica está usando show running-config partition part el comando en el modo EXEC del priveledge, que es una extensión especializada al comando show running-config.


Observe partition part la extensión del comando no está disponible para more:system running-config el comando.


Porque esta característica ofrece el rendimiento mejorado para los comandos existentes, esta característica se habilita por abandono en las imágenes del Cisco IOS Software que soportan esta característica. Para determinar rápidamente si esta característica es soportada y que se ejecuta en su sistema, publique show running-config partition ? el comando en el modo EXEC privilegiado.

PASOS SUMARIOS

1. show running-config partition ?

2. show runningconfig partition part

PASOS DETALLADOS


Paso 1 show running-config partition ?

La publicación de este comando le mostrará la lista de piezas corrientes de la configuración disponibles para la visualización en su sistema.

Si la configuración que divide la característica se soporta en su sistema y se habilita, usted verá que la cadena “división de los config es VERDAD” pues la primera línea de salida de la ayuda.

Si usted recibe un mensaje de error al ingresar la sintaxis de los comandos mostrada aquí, esta característica no se soporta en su sistema. Vea la documentación del comando para el comando show running-config para las Extensiones existentes de ese comando en otras versiones que permitan que usted muestre solamente a parte de la configuración corriente.


Observela lista de piezas disponibles de la configuración puede variar por la imagen del software y es dependiente en qué ofrece se configura actualmente.


Router# show running-config partition ?
 config partition is TRUE 
  access-list       All access-list configurations
  boot              All boot configurations
  class-map         All class-map configurations
  common            All remaining unregistered configurations
  global-cdp        All global cdp configurations
  interface         All Interface specific Configurations
  ip-as-path        All IP as-path configurations
  ip-community      All IP community list configurations
  ip-domain-list    All ip domain list configurations
  ip-prefix-list    All ip prefix-list configurations
  ip-static-routes  All IP static configurations
  line              All line mode configurations
  policy-map        All policy-map configurations
  route-map         All route-map configurations
  router            All routing configurations
  snmp              All SNMP configurations
  tacacs            All TACACS configurations

Elija la parte de la configuración corriente que usted quiere visualizar, y utilice la palabra clave asociada como part el argumento en el paso 2.

Paso 2 show running-config partition part

Como ejemplo, hacer que el sistema realice el NVGEN de proceso en solamente los componentes asociados a las partes de la lista de acceso el estado corriente de la configuración, y visualizar solamente las configuraciones relacionadas de la lista de acceso, usted ingresaría show running-config partition access-list el comando:

Router# show running-config partition access-list
        Building configuration...
Current configuration : 127 bytes
!
Configuration of Partition access-list 
!
!
!
access-list 90 permit 0.0.0.0 1.2.3.5
access-list 100 permit 10 any any
!
end

Observeeste comando también permite que usted ejecute el NVGEN de proceso y que visualice la salida resultante para las interfaces específicas. Ésta es una capacidad dominante de esta característica, como fue diseñada para los sistemas con las interfaces activas numerosas.


En el siguiente ejemplo, la división de la configuración principal es la configuración de la interfaz, y la parte de específica la configuración que se generará es la configuración para la interfaz Fast Ethernet 0/0.

Router# show running-config partition interface fastethernet0/0
Building configuration... 
Current configuration : 213 bytes
!
Configuration of Partition interface FastEthernet0/0
!
!
interface FastEthernet0/0
 ip address 10.4.2.39 255.255.255.0
 no ip route-cache cef
 no ip route-cache
 duplex half
 ipv6 enable
 no cdp enable
!
!
end

Inhabilitar la configuración que divide la característica

Porque esta característica ofrece el rendimiento mejorado para los comandos existentes, esta característica se habilita por abandono para las imágenes del Cisco IOS Software que soportan esta característica. Sin embargo, usted puede querer inhabilitar esta característica si usted determina que no es necesaria, pues esta característica utiliza a los muy poco de los recursos del sistema (memoria y utilización de la CPU). Para inhabilitar la configuración que divide, realice la tarea siguiente, que asume que usted está comenzando en el modo EXEC de usuario.

PASOS SUMARIOS

1. enable

2. configure terminal

3. no parser config partition

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

no parser config partition

Example:

Router(config)# no parser config partition

Disabling config partitioning

Router(config)#

Inhabilita la configuración que divide la característica.

Pasos Siguientes

Para volver a permitir la característica después de que se haya inhabilitado, utilice parser config partition el comando en el modo de configuración global.


Observecomo esta característica se habilita por abandono, sólo no la forma aparecerá en el archivo de configuración corriente, o será escrita al archivo de configuración de inicio cuando usted publica copy running-config startup-config el comando.


Ejemplos de Configuración para Configuration Partitioning

Esta sección proporciona los ejemplos de visualizar las divisiones de la configuración con show running-config partition el comando:

Visualización de las Particiones de la Configuración: Ejemplo:

Visualización de las Particiones de la Configuración: Ejemplo:

En este ejemplo, show running-config partition el comando se utiliza con los Comandos relacionados en una serie de camina un administrador pudo tomar para marcar el estatus de una interfaz específica y la configuración actual de algunos de otros componentes del sistema. La salida filtrada comparable del comando estándar show running-config (por ejemplo, show running-config | include access-list) se incluye como demostración.


Observe part el argumento puede consistir en las palabras claves múltiples del nombre de la división, como en el eigrp 1. del router de la pieza de los ejecutar-config de la demostración.


gt3-7200-3# show running-config partition ?
  access-list       All access-list configurations
  boot              All boot configurations
  class-map         All class-map configurations
  global-cdp        All global cdp configurations
  interface         All Interface specific Configurations
  ip-as-path        All IP as-path configurations
  ip-community      All IP community list configurations
  ip-domain-list    All ip domain list configurations
  ip-static-routes  All IP static configurations
  line              All line mode configurations
  policy-map        All policy-map configurations
  route-map         All route-map configurations
  router            All routing configurations
  service           All service configurations
  snmp              All SNMP configurations
gt3-7200-3# show running-config partition access-list 
Building configuration...
Current configuration : 87 bytes
!
!
!
!
access-list 90 permit 0.0.0.0 1.2.3.5
access-list 100 permit 10 any any
!
end
gt3-7200-3# show running-config | include access-list 
access-list 90 permit 0.0.0.0 1.2.3.5
access-list 100 permit 10 any any
gt3-7200-3#
gt3-7200-3# show running-config partition boot 
Building configuration...
Current configuration : 51 bytes
!
boot network tftp:/service_config.txt
!
!
!
end
gt3-7200-3# show running-config partition class-map 
Building configuration...
Current configuration : 78 bytes
!
!
!
class-map match-all abc
  match any 
class-map match-all xyz
!
!
!
end
gt3-7200-3# show running-config | begin class-map 
class-map match-all abc
  match any 
class-map match-all xyz
!
!
gt3-7200-3# show running-config partition global-cdp 
Building configuration...
Current configuration : 43 bytes
!
!
!
cdp timer 20
cdp holdtime 100
!
end
gt3-7200-3# show running-config | include global-cdp 
cdp timer 20
cdp holdtime 100
gt3-7200-3#
gt3-7200-3# show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES NVRAM  administratively down down    
Ethernet2/0                10.4.2.32       YES NVRAM  up                    up      
Ethernet2/1                unassigned      YES NVRAM  administratively down down    
Ethernet2/2                unassigned      YES NVRAM  administratively down down    
Ethernet2/3                unassigned      YES NVRAM  administratively down down    
Serial3/0                  unassigned      YES NVRAM  administratively down down    
Serial3/1                  unassigned      YES NVRAM  administratively down down    
Serial3/2                  unassigned      YES NVRAM  administratively down down    
Serial3/3                  unassigned      YES NVRAM  administratively down down    
Loopback0                  unassigned      YES NVRAM  administratively down down    
Loopback234                unassigned      YES NVRAM  administratively down down    
gt3-7200-3# show running-config partition interface fastethernet0/0
Building configuration...
Current configuration : 98 bytes
!
!
!
interface FastEthernet0/0
 no ip address
 no ip route-cache
 shutdown
 duplex half
!
!
end
gt3-7200-3# show running-config partition interface ethernet2/0   
Building configuration...
Current configuration : 122 bytes
!
!
!
interface Ethernet2/0
 ip address 10.4.2.32 255.255.255.0
 no ip proxy-arp
 no ip route-cache
 duplex half
!
!
end
gt3-7200-3# show running-config partition interface ethernet2/1
Building configuration...
Current configuration : 94 bytes
!
!
!
interface Ethernet2/1
 no ip address
 no ip route-cache
 shutdown
 duplex half
!
!
end
gt3-7200-3# show running-config partition interface ethernet2/2 
Building configuration...
Current configuration : 94 bytes
!
!
!
interface Ethernet2/2
 no ip address
 no ip route-cache
 shutdown
 duplex half
!
!
end
gt3-7200-3# show running-config partition interface ethernet2/3
Building configuration...
Current configuration : 94 bytes
!
!
!
interface Ethernet2/3
 no ip address
 no ip route-cache
 shutdown
 duplex half
!
!
end
gt3-7200-3# show running-config partition interface serial3/0
Building configuration...
Current configuration : 103 bytes
!
!
!
interface Serial3/0
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
!
end
gt3-7200-3# show running-config partition interface serial3/1
Building configuration...
Current configuration : 103 bytes
!
!
!
interface Serial3/1
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
!
end
gt3-7200-3# show running-config partition interface serial3/2
Building configuration...
Current configuration : 103 bytes
!
!
!
interface Serial3/2
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
!
end
gt3-7200-3# show running-config partition interface serial3/3
Building configuration...
Current configuration : 103 bytes
!
!
!
interface Serial3/3
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
!
end
gt3-7200-3# show running-config partition interface loopback0
Building configuration...
Current configuration : 79 bytes
!
!
!
interface Loopback0
 no ip address
 no ip route-cache
 shutdown
!
!
end
gt3-7200-3# show running-config partition interface loopback1
                                                      ^
% Invalid input detected at '^' marker.
gt3-7200-3# show running-config partition interface loopback234
Building configuration...
Current configuration : 81 bytes
!
!
!
interface Loopback234
 no ip address
 no ip route-cache
 shutdown
!
!
end
gt3-7200-3# configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
gt3-7200-3(config)# interface ethernet 2/0.1
gt3-7200-3(config-subif)# exit
gt3-7200-3(config)# exit
gt3-7200-3#
00:13:05: %SYS-5-CONFIG_I: Configured from console by console
gt3-7200-3# show running-config partition interface ethernet2/0.1
Building configuration...
Current configuration : 58 bytes
!
!
!
interface Ethernet2/0.1
 no ip route-cache
!
!
end
gt3-7200-3# show run partition ip?
ip-as-path  ip-community  ip-domain-list  ip-static-routes  
gt3-7200-3#sh run part ip-as
gt3-7200-3#sh run part ip-as-path 
Building configuration...
Current configuration : 125 bytes
!
!
!
ip as-path access-list 2 permit $ABC
ip as-path access-list 2 permit $xyz*
ip as-path access-list 2 permit qwe*
!
end
gt3-7200-3# show running-config partition ip-community 
Building configuration...
Current configuration : 92 bytes
!
!
!
ip community-list standard asd permit
ip community-list expanded qwe deny uio*
!
end
gt3-7200-3# show running-config | include ip community
ip community-list standard asd permit
ip community-list expanded qwe deny uio*
gt3-7200-3#
gt3-7200-3# show running-config partition ip-domain-list 
Building configuration...
Current configuration : 70 bytes
!
ip domain-list iop
ip domain-list tyu
ip domain-list jkl
!
!
!
end
gt3-7200-3# show running-config partition ip-static-routes 
Building configuration...
Current configuration : 98 bytes
!
!
!
ip route 0.0.0.0 0.0.0.0 Ethernet2/0
ip route 171.69.1.129 255.255.255.255 10.4.29.1
!
end
gt3-7200-3# show running-config partition line
Building configuration...
Current configuration : 489 bytes
!
!
!
!
line con 0
 exec-timeout 0 0
 transport output lat pad v120 mop telnet rlogin udptn nasi
 stopbits 1
line aux 0
 transport output lat pad v120 mop telnet rlogin udptn nasi
 stopbits 1
line vty 0
 password lab
 login
 transport input lat pad v120 mop telnet rlogin udptn nasi
 transport output lat pad v120 mop telnet rlogin udptn nasi
line vty 1 4
 login
 transport input lat pad v120 mop telnet rlogin udptn nasi
 transport output lat pad v120 mop telnet rlogin udptn nasi
!
end       
gt3-7200-3# show running-config partition policy-map
Building configuration...
Current configuration : 162 bytes
!
!
!
policy-map qwer
 description policy-map qwer.
  class xyz
    shape peak 8000 32 32
policy-map p1
policy-map sdf
  class abc
   set precedence 4
!
!
!
end
gt3-7200-3# show running-config partition route-map
Building configuration...
Current configuration : 65 bytes
!
!
!
route-map iop permit 10
!
route-map rty permit 10
!
!
end
gt3-7200-3#sh run part router bgp 1
Building configuration...
Current configuration : 111 bytes
!
!
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 distance bgp 2 2 2
 no auto-summary
!
!
end
gt3-7200-3#sh run part router egp ?
<0-65535>  Remote autonomous system number
gt3-7200-3#sh run part router egp 1
Building configuration...
Current configuration : 46 bytes
!
!
!
router egp 1
 timers egp 20 20
!
!
end
gt3-7200-3# show running-config partition router ?
  bgp       Border Gateway Protocol (BGP)
  egp       Exterior Gateway Protocol (EGP)
  eigrp     Enhanced Interior Gateway Routing Protocol (EIGRP)
  isis      ISO IS-IS
  iso-igrp  IGRP for OSI networks
  mobile    Mobile routes
  odr       On Demand stub Routes
  ospf      Open Shortest Path First (OSPF)
  rip       Routing Information Protocol (RIP)
gt3-7200-3# show running-config partition router eigrp ?
<1-65535>  Autonomous system number
gt3-7200-3# show running-config partition router eigrp 1
Building configuration...
Current configuration : 13 bytes
!
!
!
!
end
gt3-7200-3#
gt3-7200-3# sh run part router eigrp 2 
Building configuration...
Current configuration : 57 bytes
!
!
!
router eigrp 2
 variance 10
 auto-summary
!
!
end
gt3-7200-3# show running-config partition router ?
  bgp       Border Gateway Protocol (BGP)
  egp       Exterior Gateway Protocol (EGP)
  eigrp     Enhanced Interior Gateway Routing Protocol (EIGRP)
  isis      ISO IS-IS
  iso-igrp  IGRP for OSI networks
  mobile    Mobile routes
  odr       On Demand stub Routes
  ospf      Open Shortest Path First (OSPF)
  rip       Routing Information Protocol (RIP)
gt3-7200-3# show running-config partition router isis ?
  WORD  ISO routing area tag
  |     Output modifiers
  <cr>
gt3-7200-3# show running-config partition router isis qwe
Building configuration...
Current configuration : 86 bytes
!
!
!
router isis qwe
 set-attached-bit route-map qwer
 use external-metrics
!
!
end
gt3-7200-3# show running-config partition router isis ?
  WORD  ISO routing area tag
  |     Output modifiers
  <cr>
gt3-7200-3# show running-config partition router iso
gt3-7200-3# show running-config partition router iso-igrp ?
  WORD  ISO routing area tag
  |     Output modifiers
  <cr>
gt3-7200-3# show running-config partition router iso-igrp 
Building configuration...
Current configuration : 31 bytes
!
!
!
router iso-igrp
!
!
end
gt3-7200-3# show running-config | begin iso
router iso-igrp
!
router isis qwe
 set-attached-bit route-map qwer
 use external-metrics
!
router egp 1
 timers egp 20 20
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 distance bgp 2 2 2
 no auto-summary
!
gt3-7200-3# show running-config partition router ?
  bgp       Border Gateway Protocol (BGP)
  egp       Exterior Gateway Protocol (EGP)
  eigrp     Enhanced Interior Gateway Routing Protocol (EIGRP)
  isis      ISO IS-IS
  iso-igrp  IGRP for OSI networks
  mobile    Mobile routes
  odr       On Demand stub Routes
  ospf      Open Shortest Path First (OSPF)
  rip       Routing Information Protocol (RIP)
gt3-7200-3# show running-config partition router mobile ?
  |  Output modifiers
  <cr>
gt3-7200-3# show running-config partition router mobile 
Building configuration...
Current configuration : 42 bytes
!
!
!
router mobile
 distance 20
!
!
end
gt3-7200-3# sh run | include router 
router mobile
router odr
router eigrp 2
router ospf 4
router iso-igrp
router isis qwe
router egp 1
router bgp 1
gt3-7200-3# show running-config partition router ?
  bgp       Border Gateway Protocol (BGP)
  egp       Exterior Gateway Protocol (EGP)
  eigrp     Enhanced Interior Gateway Routing Protocol (EIGRP)
  isis      ISO IS-IS
  iso-igrp  IGRP for OSI networks
  mobile    Mobile routes
  odr       On Demand stub Routes
  ospf      Open Shortest Path First (OSPF)
  rip       Routing Information Protocol (RIP)
gt3-7200-3# show running-config partition router ospf ?
  <1-65535>  Process ID
gt3-7200-3# show running-config partition router ospf 4
Building configuration...
Current configuration : 64 bytes
!
!
!
router ospf 4
 log-adjacency-changes
 distance 4
!
!
end
gt3-7200-3# sh run part service 
Building configuration...
Current configuration : 190 bytes
!
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service internal
service udp-small-servers
service tcp-small-servers
!
!
!
end
gt3-7200-3# sh run part snmp 
Building configuration...
Current configuration : 84 bytes
!
!
!
snmp-server community user101 RW
snmp mib target list qwe host 0.0.0.0
!
end

Referencias adicionales

Las secciones siguientes proporcionan las referencias relacionadas con la configuración que divide la característica.

Documentos Relacionados

Tema relacionado
Título del documento

Mejora en el rendimiento corriente de la configuraciónparser config cache — para las interfaces.

Mejora en el rendimiento de la generación de la configuración

Aprovisionamiento de los servicios al cliente, de la restauración no actualizada de los Config, de los Config que bloquean, y del control de acceso de la configuración

Utilidad del contexto del diff de la configuración

Administración de la configuración — Registro del cambio de configuración.

Configuration Change Notification and Logging

Administración de la configuración — Rápido-salvaguardia para el cambio de configuración que registra1.

Persistencia del maderero de la configuración

El bloquear del control de acceso de la configuración del Cisco IOS Software y de la sesión de los config (“bloqueo de los Config”).

Exclusive Configuration Change Access and Access Session Locking

1 que “la característica de la persistencia del maderero de la configuración” permite el guardar apenas de los comandos entered puesto que el archivo más reciente de los lanzamiento-config fue generado, bastante que guardando la configuración de inicio entera.


Estándares

Estándar
Título

No se asocia ningunos estándares a esta característica.


MIB

MIB
Link del MIB

Esta función no soporta MIBs nuevas o modificadas, y el soporte para las MIBs existentes no ha sido modificado por esta función.


RFC

RFC
Título

Esta función no soporta RFCs nuevos o modificados, y el soporte de los RFCs existentes no ha sido modificado por ella.


Asistencia Técnica

Descripción
Link

El sitio Web de soporte técnico de Cisco proporciona los recursos en línea extensos, incluyendo la documentación y las herramientas para localizar averías y resolver los problemas técnicos con los Productos Cisco y las Tecnologías.

Para recibir la Seguridad y la información técnica sobre sus Productos, usted puede inscribir a los diversos servicios, tales como la herramienta de alerta del producto (accedida de los Field Notice), el hoja informativa de los servicios técnicos de Cisco, y alimentaciones realmente simples de la sindicación (RSS).

El acceso a la mayoría de las herramientas en el sitio Web de soporte técnico de Cisco requiere un ID de usuario y una contraseña de Cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html


Referencia de Comandos

Los siguientes comandos se introducen o se modifican en la característica o las características documentadas en este módulo. Para obtener información sobre estos comandos, vea la Referencia de Comandos de los Aspectos Fundamentales de la Configuración de Cisco IOS en http://www.cisco.com/en/US/docs/ios/fundamentals/command/reference/cf_book.html. Para obtener información sobre todos los comandos de Cisco IOS, vaya a la Command Lookup Tool disponible en http://tools.cisco.com/Support/CLILookup o a la Lista de Comandos Principal de Cisco IOS.

división de los config del analizador de sintaxis

muestre la división de los ejecutar-config

Información sobre la Función Configuration Partitioning

La Tabla 1 muestra el historial de versiones de esta función.

Puede que no estén disponibles todos los comandos en su versión de software de Cisco IOS. Para la información de versión sobre un comando específico, vea la documentación de referencia de comandos.


Observelas listas del cuadro 1 solamente la versión de Cisco IOS Software que introdujo el soporte para una característica dada en un tren de versión del Cisco IOS Software dado. A menos que se indique lo contrario, las versiones posteriores de dicha serie de versiones de software de Cisco IOS también soportan esa función.


Información de la característica del cuadro 1 para la división de la configuración

Nombre de la función
Versiones
Información sobre la Función

División de la configuración

12.2(33)SRB
12.2(33)SB
12.2(33)SXI

La función de partición de configuración proporciona modularización (“partición”) del estado de configuración en funcionamiento para proporcionar acceso granular a la configuración en funcionamiento de Cisco IOS Software. Esta función está habilitada de forma predeterminada en las imágenes de Cisco IOS Software que incluyen esta función.

En 12.2(33)SB, esta función fue implementada en Cisco 10000 Series.

Las secciones siguientes proporcionan información acerca de esta función:

Información sobre Configuration Partitioning

Cómo Utilizar la Función Configuration Partitioning