Routers : Routers de servicios integrados de Cisco de la serie 3800

Cliente de AnyConnect VPN (SSL) en el router IOS con el ejemplo de configuración CCP

31 Julio 2013 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (28 Agosto 2009) | Comentarios


Contenido


Introducción

Este documento describe cómo configurar a un router del ® del Cisco IOS para realizar SSL VPN en un palillo con el Cliente Cisco AnyConnect VPN que usa al Cisco Configuration Professional (CCP). Esta configuración se aplica a un caso específico donde el Router no permite tunelización dividida, y los usuarios se conectan directamente con el Router antes de que se les permita utilizar Internet.

La SSL VPN o la tecnología WebVPN es soportada en estas plataformas del router IOS:

  • 870, 1811, 1841, 2801, 2811, 2821, 2851

  • 3725, 3745, 3825, 3845, 7200 y 7301

El CCP es una herramienta de administración de dispositivos basada en GUI que le permite configurar los routers de acceso basados en IOS de Cisco, incluidos los Cisco integrated services routers, los Cisco 7200 series routers y el Cisco 7301 router. El CCP está instalado en un equipo y simplifica el router, la seguridad, las comunicaciones unificadas, la red inalámbrica, la WAN, y la configuración básica LAN a través de los asistentes basados en GUI, fáciles de utilizar.

Los routers que se piden con CCP se envían con Cisco Configuration Professional Express (CCP Express) instalado en la memoria flash del router. El CCP Express es una versión ligera del CCP. Puede utilizar CCP Express para configurar las funciones de seguridad básicas en las interfaces LAN y WAN del router. CCP Express está disponible en la memoria flash del router.

Prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • Microsoft Windows 2000 o XP

  • Navegador Web con SUN JRE 1.4 o una versión posterior o un navegador controlado ActiveX

  • Privilegios administrativos locales en el cliente

  • Cisco IOS Router con Advanced Security image -12.4(20)T o una versión posterior

  • Cisco Configuration Professional 1.3

    Si Cisco Configuration Professional no está cargado en su equipo, puede obtener una copia gratuita del software e instalar el archivo .exe (cisco-config-pro-k9-pkg-1_3-en.zip) de la Descarga del Software. Para obtener información detallada sobre la instalación y la configuración del CCP, consulte la Guía de Inicio Rápido de Cisco Configuration Professional.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco IOS Series 1841 Router con versión de software 12.4(24)T

  • Cisco Configuration Professional (CCP) 1.3

  • Cisco AnyConnect SSL VPN Client, versión para Windows 2.3.2016

Nota: La información de este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

ssl-ios-01.gif

Tareas de Preconfiguración

  1. Debe configurar el router para el CCP.

    Los routers con la licencia adecuada del conjunto de seguridad ya tienen la aplicación CCP cargada en la memoria flash. Consulte la Guía de Inicio Rápido de Cisco Configuration Professional para obtener y para configurar el software.

  2. Descargue una copia del archivo .pkg de Anyconnect VPN en su equipo de administración.

Configure Anyconnect VPN en el IOS

En esta sección, se presentan los pasos necesarios para configurar las funciones descritas en este documento. Este ejemplo de configuración utiliza el Asistente CCP para habilitar la operación de Anyconnect VPN en el router IOS.

Siga estos pasos para configurar Anyconnect VPN en el Cisco IOS router:

  1. Instale y habilite Anyconnect VPN Software en el Cisco IOS Router

  2. Configure un Contexto SSL VPN y un Gateway VPN SSL con el Asistente CCP

  3. Configure la Base de Datos de Usuarios para los Usuarios VPN de Anyconnect

  4. Configure los Recursos para Mostrar a los Usuarios

Paso 1. Instale y habilite el Anyconnect VPN Software en el Router IOS

Para instalar y habilitar el Anyconnect VPN software en el router IOS, siga estos pasos:

  1. Abra la aplicación CCP, diríjase a Configure > Security, y luego haga clic en VPN.

  2. Amplíe SSLVPN y elija Packages.

    /image/gif/paws/110608/ssl-ios-02.gif

  3. En el software de cliente Cisco SSLVPN, haga clic en Browse.

    Aparece el cuadro de diálogo Install SSL VPN Client Package.

    /image/gif/paws/110608/ssl-ios-03.gif

  4. Especifique la ubicación de la imagen de Cisco AnyConnect VPN Client.

    • Si la imagen de Cisco AnyConnect VPN Client está en la memoria flash del router, haga clic en el cuadro de diálogo del botón de opción Router File System y haga clic en Browse.

    • Si la imagen de Cisco AnyConnect VPN Client no está en la memoria flash del router, haga clic en el cuadro de diálogo del botón de opción My Computer y haga clic en Browse.

    Aparece el cuadro de diálogo File Selection.

    ssl-ios-04.gif

  5. Seleccione la imagen de cliente que desee instalar y haga clic en OK.

    ssl-ios-05.gif

  6. Una vez que especifique la ubicación de la imagen del cliente, haga clic en Install.

  7. Haga clic en Yes y luego en OK.

  8. Una vez que la imagen del cliente esté instalada correctamente, recibe este mensaje:

    /image/gif/paws/110608/ssl-ios-06.gif

  9. Para continuar, haga clic en OK (Aceptar).

Paso 2. Configure un Contexto SSLVPN y un Gateway SSLVPN con el Asistente CCP

Siga estos pasos para configurar un contexto SSL VPN y un gateway VPN SSL:

  1. Diríjase a Configure > Security > VPN, y luego haga clic en SSL VPN.

  2. Haga clic en SSL VPNManager, y haga clic la pestaña Create SSL VPN.

    /image/gif/paws/110608/ssl-ios-07.gif

  3. Active el botón de opción Create a New SSL VPN y luego haga clic en Launch the selected task.

    Aparece el cuadro de diálogo SSL VPN Wizard .

    /image/gif/paws/110608/ssl-ios-08.gif

  4. Haga clic en Next (Siguiente).

    /image/gif/paws/110608/ssl-ios-09.gif

  5. Ingrese la Dirección IP del nuevo gateway VPN SSL e ingrese un nombre único para este contexto SSL VPN.

    Puede crear diferentes contextos SSL VPN para la misma Dirección IP (gateway VPN SSL), pero cada nombre debe ser único. Este ejemplo utiliza esta Dirección IP: https://172.16.1.1/

  6. Haga clic en Next y continúe con el Paso 3.

Paso 3. Configure las Bases de Datos de Usuarios para los Usuarios VPN de Anyconnect

Para la autenticación, puede utilizar un Servidor AAA, los usuarios locales, o ambos. Este ejemplo de configuración utiliza los usuarios creados localmente para la autenticación.

Siga estos pasos para configurar las bases de datos de usuarios para los usuarios VPN de Anyconnect:

  1. Una vez que complete el Paso 2, haga clic en el botón de opción Locally on this router situado en el cuadro de diálogo SSL VPN Wizard User Authentication.

    /image/gif/paws/110608/ssl-ios-10.gif

    Este cuadro de diálogo le permite agregar usuarios a las bases de datos locales.

  2. Haga clic en Add e ingrese la información de usuario.

    /image/gif/paws/110608/ssl-ios-11.gif

  3. Haga clic en OK y agregue usuarios adicionales, de ser necesario.

  4. Una vez que agregue la cantidad necesaria de usuarios, haga clic en Next y continúe con el Paso 4.

Paso 4. Configure el Túnel Completo de Anyconnect

Siga estos pasos para configurar el túnel completo de Anyconnect y el conjunto de direcciones IP para los usuarios:

  1. Como Anyconnect otorga acceso directo a los recursos de la intranet corporativa, no es necesario configurar la lista URL. Haga clic en el botón Next situado en el cuadro de diálogo Intranet Websites.

    /image/gif/paws/110608/ssl-ios-12.gif

  2. Verifique que la casilla de verificación Enable Full Tunnel esté activada.

    ssl-ios-17.gif

  3. Cree un conjunto de direcciones IP que los clientes de este contexto SSL VPN puedan utilizar.

    El conjunto de direcciones debe corresponder a las direcciones disponibles y ruteables en su Intranet.

  4. Haga clic las elipses () al lado de la dirección IP reúna el campo, y elija crean una nueva agrupación IP.

  5. En el cuadro de diálogo Add IP Local Pool, ingrese un nombre para el conjunto (por ejemplo, nuevo), y haga clic en Add.

    /image/gif/paws/110608/ssl-ios-18.gif

  6. En el cuadro de diálogo Add IP address range, ingrese el rango del conjunto de direcciones para los clientes VPN de Anyconnect, y haga clic en OK.

    Nota: Antes de 12.4(20)T, el conjunto de direcciones IP debe estar dentro del rango de una interfaz conectada directamente con el router. Si desea utilizar un rango de conjunto diferente, puede crear una dirección loopback asociada a su nuevo conjunto para satisfacer este requisito.

  7. Haga clic en OK.

  8. Asegúrese de activar la casilla de verificación Install Full Tunnel Client.

    ssl-ios-19.gif

  9. Configure las opciones de túnel avanzadas, como tunelización dividida, DNS dividido, configuraciones proxy del navegador y servidores DNS y WNS.

    Nota: Cisco le recomienda configurar al menos servidores DNS y WINS.

      Para configurar opciones avanzadas de túnel, siga estos pasos:

    1. Haga clic en el botón Advanced Tunnel Options.

    2. Haga clic en la pestaña DNS and WINS Servers e ingrese las direcciones IP principales para los servidores DNS y WINS.

      ssl-ios-19a.gif

    3. Para configurar la tunelización dividida, haga clic en la pestaña Split Tunneling.

      ssl-ios-19b.gif

      La capacidad de transmitir tráfico seguro y no seguro en la misma interfaz se conoce como tunelización dividida. La tunelización dividida requiere que especifique exactamente qué tráfico es seguro y cuál es el destino de ese tráfico, de modo que solamente el tráfico especificado ingresa en el túnel mientras que el resto se transmite no encriptado a través de la red pública (Internet).

      Por ejemplo, consulte ASA 8.x: Habilite la Tunelización Dividida para AnyConnect VPN Client en el Ejemplo de Configuración ASA que ofrece instrucciones paso a paso sobre cómo permitir el acceso de Cisco AnyConnect VPN Client a Internet mientras que son tunelados en un Cisco Adaptive Security Appliance (ASA) 8.0.2.

  10. Después de que configure la opción necesaria, haga clic en Next.

  11. Personalice la Página del Portal SSL VPN o seleccione los valores predeterminados.

    Con la Página del Portal Personalizar SSL VPN puede personalizar la presentación de la Página del Portal SSL VPN para sus clientes.

    /image/gif/paws/110608/ssl-ios-20.gif

  12. Después de que personalice la página del portal SSL VPN, haga clic en Next.

  13. Haga clic en Finish (Finalizar).

    ssl-ios-21.gif

  14. Haga clic en Deliver para guardar su configuración y luego haga clic en OK.

    El Asistente VPN SSL envía los comandos tour router.

    ssl-ios-22.gif

    Nota: Si recibe un mensaje de error, la licencia SSL VPN puede ser incorrecta.

    Para corregir un problema de licencia, siga estos pasos:

    1. Diríjase a Configure > Security > VPN, y luego haga clic en SSL VPN.

    2. Haga clic en SSL VPN Manager y luego haga clic en la pestaña Edit SSL VPN en la parte derecha.

      /image/gif/paws/110608/ssl-ios-23.gif

    3. Resalte su contexto creado recientemente, y haga clic en el botón Edit.

      /image/gif/paws/110608/ssl-ios-24.gif

    4. En el campo Maximum Number of users, ingrese el número correcto de usuarios para su licencia.

    5. Haga clic en OK y luego en Deliver.

      Sus comandos se escriben en el archivo de configuración.

Configuración de CLI

El CCP crea estas configuraciones de la línea de comandos:

Router
Router#show run
Building configuration...

Current configuration : 4110 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
no logging buffered
enable password cisco
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication login ciscocp_vpn_xauth_ml_1 local
aaa authorization exec default local
!
!
aaa session-id common
!
crypto pki trustpoint TP-self-signed-1951692551
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1951692551
 revocation-check none
 rsakeypair TP-self-signed-1951692551
!
!
crypto pki certificate chain TP-self-signed-1951692551
 certificate self-signed 02
  3082023E 308201A7 A0030201 02020102 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31393531 36393235 3531301E 170D3039 30383037 31303538
  33345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 39353136
  39323535 3130819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100CD40 156E21C4 4F84401A F5674319 CC05B708 72A79C69 90997D30 6F556A37
  75FC53DA AB0B43AF 70E7DBC2 C9416C4B 009C3695 67C20847 4F0BC7B0 715F0518
  5E558DFC 13A20167 5D169C47 3BC083C9 A2B66790 79B83814 5008EBF6 169FA897
  6D955F46 2BDADBB0 5275F07E C124CCF3 64DD9CE1 1B6F5744 282E4EA5 A0840385
  5FD90203 010001A3 66306430 0F060355 1D130101 FF040530 030101FF 30110603
  551D1104 0A300882 06526F75 74657230 1F060355 1D230418 30168014 05F279A9
  C556AF46 C5F7A1F0 2ADD2D22 F75BF7B7 301D0603 551D0E04 16041405 F279A9C5
  56AF46C5 F7A1F02A DD2D22F7 5BF7B730 0D06092A 864886F7 0D010104 05000381
  81004886 D666121E 42862509 CA7FDACC 9C57C8BE EB6745FC 533A8C08 FEF2C007
  274374EE 803823FB 79CFD135 2B116544 88B5CFB1 B7BB03E2 F3D65A62 B0EE050A
  924D3168 98357A5B E1F15449 5C9C22D0 577FB036 A3D8BB08 5507C574 18F2F48F
  0694F21C 0983F254 6620FCD7 8E460D29 B09B87E8 ADC3D589 F4D74659 A5CEA30F 1A9C
        quit
dot11 syslog
ip source-route
!
!
!
!
ip cef
!
multilink bundle-name authenticated
!
!
!
username test privilege 15 password 0 test
username tsweb privilege 15 password 0 tsweb
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.77.241.111 255.255.255.192
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description $ES_LAN$
 ip address 172.16.1.1 255.255.255.0
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
!
interface FastEthernet0/1/1
!
interface FastEthernet0/1/2
!
interface FastEthernet0/1/3
!
interface ATM0/0/0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface Vlan1
 no ip address
!
ip local pool new 192.168.10.1 192.168.10.10
ip forward-protocol nd
ip route 10.20.10.0 255.255.255.0 172.16.1.2
ip route 10.77.233.0 255.255.255.0 10.77.241.65
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 transport input telnet ssh
 transport output telnet
!
scheduler allocate 20000 1000
!
webvpn gateway gateway_1
 ip address 172.16.1.1 port 443
 http-redirect port 80
 ssl trustpoint TP-self-signed-1951692551
 inservice
 !
webvpn install svc flash:/webvpn/svc_1.pkg sequence 1
 !
webvpn context sales
 secondary-color white
 title-color #CCCC66
 text-color black
 ssl authenticate verify all

 !
 !
 policy group policy_1
   
   functions svc-enabled
   
   svc address-pool "new"
   svc dns-server primary 10.1.1.1
   svc wins-server primary 10.1.1.2
 default-group-policy policy_1
 aaa authentication list ciscocp_vpn_xauth_ml_1
 gateway gateway_1
 max-users 10
 inservice
!
end

Establezca la Conexión de Cliente VPN de AnyConnect

Siga estos pasos para establecer una Conexión VPN de AnyConnect con el Router.

Nota: Agregue un router a la lista de sitios confiables en Internet Explorer. Para más información, consulte Agregar un Dispositivo de Seguridad/Router a la lista de Sitios Confiables (IE).

  1. Ingrese la URL o la Dirección IP de la interfaz del WebVPN del router en su navegador Web en el formato que se muestra.

    https://<url>

    O

    https://<IP address of the Router WebVPN interface>

    ssl-ios-25.gif

  2. Ingrese su nombre de usuario y contraseña.

    ssl-ios-26.gif

  3. Haga clic en el botón inicio para iniciar la Conexión del Túnel VPN de Anyconnect.

    ssl-ios-27.gif

  4. Esta ventana aparece antes de que se establezca la conexión VPN SSL.

    ssl-ios-28.gif

    Nota: El software ActiveX se debe instalar en su equipo antes de que descargue Anyconnect VPN.

    Aparece el mensaje Connection Established (Conexión Establecida) una vez que el cliente se conecta correctamente.

    ssl-ios-29.gif

  5. Una vez que la conexión se establece correctamente, haga clic en la pestaña Statistics.

    La pestaña Statistics muestra la información sobre la conexión SSL.

    ssl-ios-30.gif

  6. Haga clic en Details.

    Aparece el cuadro de diálogo de Cisco AnyConnect VPN Client: Statistics Detail.

    ssl-ios-31.gif

    El cuadro de diálogo Statistics Details muestra información estadística de la conexión detallada, incluido el estado de túnel y el modo, la duración de la conexión, la cantidad de bytes y las tramas enviadas y recibidas, información de dirección, información del transporte y el estado de la evaluación de la postura de Cisco Secure Desktop. El botón Reset en esta pestaña restablece las estadísticas de la transmisión. El botón Export le permite exportar las estadísticas actuales, la interfaz, y la tabla de ruteo a un archivo de texto. El cliente de AnyConnect le solicita que designe un nombre y una ubicación al archivo de texto. El nombre predeterminado es AnyConnect-ExportedStats.txt, y la ubicación predeterminada es el escritorio.

  7. En el cuadro de diálogo Cisco AnyConnect VPN Client, haga clic en la pestaña About.

    Esta pestaña muestra la información de la Versión de Cisco AnyConnect VPN Client.

    ssl-ios-32.gif

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

Comandos

Varios comandos show se asocian a WebVPN. Puede ejecutar estos comandos en command-line interface (CLI) para mostrar las estadísticas y otra información. Para obtener información detallada sobre los comandos show, consulte Verificar la Configuración WebVPN.

Nota: La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

  • Router#show webvpn session context all
    WebVPN context name: sales
    Client_Login_Name  Client_IP_Address  No_of_Connections  Created  Last_Used
    test               10.20.10.2                 3         00:03:10  00:02:56
  • Router#show webvpn session user test context sales
    WebVPN user name = test ; IP address = 10.20.10.2 ; context = sales
        No of connections: 0
        Created 00:26:05, Last-used 00:25:24
        User Policy Parameters
          Group name = policy_1
        Group Policy Parameters
          url list name = "webserver"
          idle timeout = 2100 sec
          session timeout = Disabled
          functions =
                    mask-urls
                    svc-enabled
    
          citrix disabled
          address pool name = "new"
          dpd client timeout = 300 sec
          dpd gateway timeout = 300 sec
          keepalive interval = 30 sec
          SSLVPN Full Tunnel mtu size = 1406 bytes
          keep sslvpn client installed = enabled
          rekey interval = 3600 sec
          rekey method =
          lease duration = 43200 sec
  • Router#show webvpn stats
    User session statistics:
        Active user sessions     : 1          AAA pending reqs         : 0
        Peak user sessions       : 2          Peak time                : 00:00:52
        Active user TCP conns    : 0          Terminated user sessions : 2
        Session alloc failures   : 0          Authentication failures  : 1
        VPN session timeout      : 0          VPN idle timeout         : 0
        User cleared VPN sessions: 0          Exceeded ctx user limit  : 0
        Exceeded total user limit: 0
        Client process rcvd pkts : 108        Server process rcvd pkts : 0
        Client process sent pkts : 589        Server process sent pkts : 0
        Client CEF received pkts : 76         Server CEF received pkts : 0
        Client CEF rcv punt pkts : 0          Server CEF rcv punt pkts : 0
        Client CEF sent pkts     : 0          Server CEF sent pkts     : 0
        Client CEF sent punt pkts: 0          Server CEF sent punt pkts: 0
    
        SSLVPN appl bufs inuse   : 0          SSLVPN eng  bufs inuse   : 0
        Active server TCP conns  : 0
    
    Mangling statistics:
        Relative urls            : 0          Absolute urls            : 0
        Non-http(s) absolute urls: 0          Non-standard path urls   : 0
        Interesting tags         : 0          Uninteresting tags       : 0
        Interesting attributes   : 0          Uninteresting attributes : 0
        Embedded script statement: 0          Embedded style statement : 0
        Inline scripts           : 0          Inline styles            : 0
        HTML comments            : 0          HTTP/1.0 requests        : 0
        HTTP/1.1 requests        : 9          Unknown HTTP version     : 0
        GET requests             : 9          POST requests            : 0
        CONNECT requests         : 0          Other request methods    : 0
        Through requests         : 0          Gateway requests         : 9
        Pipelined requests       : 0          Req with header size >1K : 0
        Processed req hdr bytes  : 2475       Processed req body bytes : 0
        HTTP/1.0 responses       : 0          HTTP/1.1 responses       : 0
        HTML responses           : 0          CSS responses            : 0
        XML responses            : 0          JS responses             : 0
        Other content type resp  : 0          Chunked encoding resp    : 0
        Resp with encoded content: 0          Resp with content length : 0
        Close after response     : 0          Resp with header size >1K: 0
        Processed resp hdr size  : 0          Processed resp body bytes: 0
        Backend https response   : 0          Chunked encoding requests: 0
    
    HTTP Authentication stats :
        Successful NTLM Auth     : 0          Failed NTLM Auth         : 0
        Successful Basic Auth    : 0          Failed Basic Auth        : 0
        Unsupported Auth         : 0          Unsup Basic HTTP Method  : 0
        NTLM srv kp alive disabld: 0          NTLM Negotiation Error   : 0
        Oversize NTLM Type3 cred : 0          Internal Error           : 0
        Num 401 responses        : 0          Num non-401 responses    : 0
        Num Basic forms served   : 0          Num NTLM forms served    : 0
        Num Basic Auth sent      : 0          Num NTLM Auth sent       : 0
    
    CIFS statistics:
      SMB related Per Context:
        TCP VC's                 : 0          UDP VC's                 : 0
        Active VC's              : 0          Active Contexts          : 0
        Aborted Conns            : 0
      NetBIOS related Per Context:
        Name Queries             : 0          Name Replies             : 0
        NB DGM Requests          : 0          NB DGM Replies           : 0
        NB TCP Connect Fails     : 0          NB Name Resolution Fails : 0
      SMB related Global:
        Sessions in use          : 0          Mbufs in use             : 0
        Mbuf Chains in use       : 0          Active VC's              : 0
        Active Contexts          : 0          Browse Errors            : 0
        Empty Browser List       : 0          NetServEnum Errors       : 0
        Empty Server List        : 0          NBNS Config Errors       : 0
        NetShareEnum Errors      : 0
      HTTP related Per Context:
        Requests                 : 0          Request Bytes RX         : 0
        Request Packets RX       : 0          Response Bytes TX        : 26286
        Response Packets TX      : 33         Active Connections       : 0
        Active CIFS context      : 0          Requests Dropped         : 0
      HTTP related Global:
        Server User data         : 0          CIFS User data           : 0
        Net Handles              : 0          Active CIFS context      : 0
        Authentication Fails     : 0          Operations Aborted       : 0
        Timers Expired           : 0          Pending Close            : 0
        Net Handles Pending SMB  : 0          File Open Fails          : 0
        Browse Network Ops       : 0          Browse Network Fails     : 0
        Browse Domain Ops        : 0          Browse Domain Fails      : 0
        Browse Server Ops        : 0          Browse Server Fails      : 0
        Browse Share Ops         : 0          Browse Share Fails       : 0
        Browse Dir Ops           : 0          Browse Network Fails     : 0
        File Read Ops            : 0          File Read Fails          : 0
        File Write Ops           : 0          File Write Fails         : 0
        Folder Create Ops        : 0          Folder Create Fails      : 0
        File Delete Ops          : 0          File Delete Fails        : 0
        File Rename Ops          : 0          File Rename Fails        : 0
        URL List Access OK       : 0          URL List Access Fails    : 0
    
    Socket statistics:
        Sockets in use           : 1          Sock Usr Blocks in use   : 1
        Sock Data Buffers in use : 0          Sock Buf desc in use     : 0
        Select timers in use     : 1          Sock Select Timeouts     : 0
        Sock Tx Blocked          : 0          Sock Tx Unblocked        : 0
        Sock Rx Blocked          : 0          Sock Rx Unblocked        : 0
        Sock UDP Connects        : 0          Sock UDP Disconnects     : 0
        Sock Premature Close     : 0          Sock Pipe Errors         : 12
        Sock Select Timeout Errs : 0
    
    Port Forward statistics:
      Client                                Server
        proc pkts                : 0          proc pkts                 : 0
        proc bytes               : 0          proc bytes                : 0
        cef pkts                 : 0          cef pkts                  : 0
        cef bytes                : 0          cef bytes                 : 0
    
    WEBVPN Citrix statistics:
    
                   Server                   Client
      Packets in  : 0                        0
      Packets out : 0                        0
      Bytes in    : 0                        0
      Bytes out   : 0                        0
    
    ACL statistics:
        Permit web request       : 0          Deny web request         : 0
        Permit cifs request      : 0          Deny cifs request        : 0
        Permit without ACL       : 0          Deny without match ACL   : 0
        Permit with match ACL    : 0          Deny with match ACL      : 0
    
    Single Sign On statistics:
        Auth Requests            : 0          Pending Auth Requests    : 0
        Successful Requests      : 0          Failed Requests          : 0
        Retranmissions           : 0          DNS Errors               : 0
        Connection Errors        : 0          Request Timeouts         : 0
        Unknown Responses        : 0
    
    URL-rewrite splitter statistics:
        Direct access request    : 0          Redirect request         : 0
        Internal request         : 0
    
    Tunnel Statistics:
        Active connections       : 0
        Peak connections         : 1          Peak time                : 00:34:51
        Connect succeed          : 3          Connect failed           : 0
        Reconnect succeed        : 0          Reconnect failed         : 0
        DPD timeout              : 0
      Client                                Server
        in  CSTP frames          : 32         out IP pkts              : 5
        in  CSTP data            : 5
        in  CSTP control         : 27
        in  CSTP bytes           : 1176       out IP bytes             : 805
        out CSTP frames          : 4          in  IP pkts              : 0
        out CSTP data            : 0
        out CSTP control         : 4
        out CSTP bytes           : 32         in  IP bytes             : 0
        cef in CSTP data frames  : 0          cef out forwarded pkts   : 0
        cef in CSTP data bytes   : 0          cef out forwarded bytes  : 0
        cef out CSTP data frames : 0          cef in forwarded pkts    : 0
        cef out CSTP data bytes  : 0          cef in forwarded bytes   : 0
  • En el CCP, elija Monitoring > Security > VPN Status > SSL VPN > Users para ver las listas actuales de usuarios SSL VPN en el router.

    ssl-ios-33.gif

  • Elija Monitoring > Security > VPN Status > SSL VPN > Sales para ver la información actual de la sesión SSL VPN en el router.

    ssl-ios-34.gif

Troubleshooting

Use esta sección para resolver problemas de configuración.

Problema de Conectividad SSL

Problema: Los clientes VPN SSL no pueden conectarse con el router.

Solución: El número insuficiente de direcciones IP en el conjunto de direcciones IP puede causar este problema. Aumente el número de direcciones IP en el conjunto de direcciones IP en el router para resolver este problema.

Para más información sobre Troubleshooting AnyConnect VPN Client, consulte Preguntas Frecuentes sobre AnyConnect VPN Client.

Error: SSLVPN Package SSL-VPN-Client: Error en la instalación: Disco

Problema: Recibe este error cuando instala el paquete SVC en un router: SSLVPN Package SSL-VPN-Client: Error en la instalación: Disco.

Solución: Este error puede resolverse al cambiar el formato de la memoria flash.

Comandos para resolución de problemas

Varios comandos clear se asocian a WebVPN. Para obtener información detallada sobre estos comandos, consulte Uso de los Comandos Clear de WebVPN.

Varios comandos debug se asocian a WebVPN. Para obtener información detallada sobre estos comandos, consulte Uso de los Comandos Debug de WebVPN.

Nota: El uso de los comandos debug puede afectar negativamente su dispositivo de Cisco. Antes de que utilice los comandos debug, consulte Información Importante sobre los Comandos Debug.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 110608