Routers : Routers de servicios integrados de Cisco de la serie 3800

Cliente de AnyConnect VPN (SSL) en el router IOS con el ejemplo de configuración CCP

19 Marzo 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (29 Febrero 2016) | Comentarios

Introducción

Este documento describe cómo configurar a un router del ® del Cisco IOS para realizar Secure Sockets Layer (SSL) VPN en un palillo con el Cliente Cisco AnyConnect VPN que usa al Cisco Configuration Professional (CCP). Esta configuración se aplica a un caso específico donde AnyConnect en el router se configura con el Túnel dividido, y permite el acceso seguro de cliente a los recursos corporativos y también proporciona el acceso sin garantía a Internet.

El SSL VPN o la tecnología del WebVPN se soporta en la mayoría de las plataformas del router tales como la generación 1 del router de los Servicios integrados (ISR), la generación 2 (refiera los Productos ISR para la lista de Productos ISR). Aconsejan los clientes referir la guía del navegador de la característica para obtener una lista completa de plataformas de Cisco IOS que soporten el cliente de AnyConnect VPN (SSL) (o cualquier otra tecnología de la característica de hecho). Esta información está disponible en el navegador de la característica.

El CCP es una herramienta de Administración de dispositivos GUI basada que permite que usted configure los routeres de acceso basados en IOS de Cisco. El CCP está instalado en un PC y simplifica el router, la Seguridad, las Comunicaciones unificadas, la Tecnología inalámbrica, WAN, y las configuraciones básicas LAN a través de los Asisitente GUI basados, fáciles de usar.

Contribuido por Bratin Saha y Rahul Govindan, ingenieros de Cisco TAC.

Prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • Sistema operativo conveniente del cliente. Refiera los Release Note de AnyConnect para los sistemas operativos admitidos.

  • El buscador Web con la versión JRE 1.4 del SOL o más adelante o un ActiveX controló al navegador

  • Privilegios administrativos locales en el cliente

  • Cisco IOS Router con Advanced Security image -12.4(20)T o una versión posterior

  • Versión 1.3 o posterior del Cisco Configuration Professional

Si no cargan al Cisco Configuration Professional ya en su ordenador, usted puede obtener una copia libre del software y instalar el archivo del .exe (cisco-config-pro-k9-pkg-2_8-en.zip) de la descarga del software. Para obtener información detallada sobre la instalación y la configuración del CCP, consulte la Guía de Inicio Rápido de Cisco Configuration Professional.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Router de la serie CISCO2811 del Cisco IOS con la versión de software 15.1(4)M8

  • Versión 2.8 CCP

  • Versión del cliente VPN de Cisco AnyConnect SSL para Windows 3.1.05160

La información de este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Configurar

Diagrama de la red

En este documento, se utiliza esta configuración de red:

Tareas de Preconfiguración

  1. Configure al router para el CCP.

    El Routers con la licencia apropiada del conjunto de la Seguridad tiene ya la aplicación CCP cargada en el Flash. Refiera a la guía de inicio rápido del Cisco Configuration Professional para obtener y configurar el software.

  2. Descargue una copia del archivo .pkg de Anyconnect VPN en su equipo de administración.

Configuraciones

En esta sección, le presentan con los pasos necesarios para configurar las características descritas en este documento. Este ejemplo de configuración utiliza al Asisitente CCP para habilitar la operación del Anyconnect VPN en el router IOS.

Siga estos pasos para configurar Anyconnect VPN en el Cisco IOS router:

  1. Configure el CCP y descubra al router del Cisco IOS.

  2. Instale y habilite el software VPN de Anyconnect en el router del Cisco IOS.

  3. Configure un contexto SSL VPN y el gateway de VPN SSL con el Asisitente CCP.

  4. Configure la base de datos de usuarios para los usuarios de VPN de Anyconnect.

  5. Configure el túnel lleno de AnyConnect.

Cada uno de estos pasos se describe más detalladamente en las siguientes secciones de este documento.

Paso 1: Configure el CCP y descubra al router del Cisco IOS

  1. Haga clic el estatus del router en la ventana CCP para ver la información del dispositivo de router.



  2. Haga clic la configuración para comenzar la configuración.



Paso 2: Instale y habilite el software VPN de Anyconnect en el router IOS

Complete estos pasos para instalar y habilitar el software VPN de Anyconnect en el router IOS:

  1. Abra la aplicación CCP, navegue para configurar el > Security (Seguridad), y después haga clic el VPN.

  2. Amplíe SSLVPN y elija Packages.



    Asegúrele que la licencia de función SSL VPN está instalada en el dispositivo, si no pudo conseguir la advertencia mostrada en la imagen anterior. Refiera el link de la licencia de función para ver la sección de información de pedidos.

  3. En el software de cliente Cisco SSLVPN, haga clic en Browse.

    El cuadro de diálogo selecto de la ubicación de SVC aparece.



  4. Especifique la ubicación de la imagen del Cliente Cisco AnyConnect VPN (elija cualquiera de las dos opciones disponibles).

    • Si la imagen del Cliente Cisco AnyConnect VPN está en memoria Flash del router, haga clic el cuadro de diálogo del botón de radio del sistema de archivos del router, y el tecleo hojea.





    • Si la imagen del Cliente Cisco AnyConnect VPN no está en memoria Flash del router, haga clic el cuadro de diálogo de la radio del mi PC, y el tecleo hojea.


  5. Seleccione la imagen del cliente que usted quiere para instalar y para hacer clic la AUTORIZACIÓN.

  6. Una vez que especifique la ubicación de la imagen del cliente, haga clic en Install.

  7. El tecleo  y entonces hace clic la AUTORIZACIÓN.

  8. Una vez que la imagen del cliente está instalada con éxito, usted recibe el Mensaje de éxito. Haga Click en OK para continuar.

  9. Una vez que está instalado, vea los detalles del paquete instalado bajo la Seguridad > el VPN > el SSL VPN > los paquetes.

Paso 3: Configure un contexto SSLVPN y el gateway SSLVPN con el Asisitente CCP

Complete estos pasos para configurar un contexto SSL VPN y el gateway de VPN SSL:

  1. Diríjase a Configure > Security > VPN, y luego haga clic en SSL VPN.

  2. Haga clic al administrador SSL VPN y después haga clic la lengueta del crear SSL VPN.



  3. Siga los prompts para habilitar el Authentication, Authorization, and Accounting (AAA) si no se habilita ya.









  4. Marque el crear un nuevo botón de radio SSL VPN y después haga clic el lanzamiento la tarea seleccionada.

    Aparece el cuadro de diálogo SSL VPN Wizard .



  5. Haga clic en Next (Siguiente).



    Nota: Si el SSL VPN se configura bajo interfaz a través de la cual se invoca Cisco CP, puede ser que cause Cisco CP al disconnet del router. Como mejor práctica, usted puede acceder al router del Cisco IOS vía el CCP de la interfaz interna (en este ejemplo, 10.106.44.141) o de cualquier otra interfaz, mientras que el SSL VPN se configura bajo el FastEthernet0/0 de la interfaz externa (en este ejemplo, 10.105.130.149).





  6. Ingrese el IP Address del nuevo gateway de VPN SSL y ingrese un nombre único para este contexto SSL VPN.

    Puede crear diferentes contextos SSL VPN para la misma Dirección IP (gateway VPN SSL), pero cada nombre debe ser único. Este ejemplo utiliza esta Dirección IP: https://10.105.130.149/

  7. Haga clic después, y continúe a la siguiente sección.

Paso 4: Configure la Base de Datos de Usuarios para los Usuarios VPN de Anyconnect

Para la autenticación, puede utilizar un Servidor AAA, los usuarios locales, o ambos. Este ejemplo de configuración utiliza a los usuarios para la autenticación local-creados.

Siga estos pasos para configurar las bases de datos de usuarios para los usuarios VPN de Anyconnect:

  1. Después de que usted complete el paso 3, haga clic localmente encendido el este botón de radio del router situado en el cuadro de diálogo de la autenticación de usuario del Asistente VPN SSL.



    Este cuadro de diálogo le permite agregar usuarios a las bases de datos locales.

  2. Haga clic agregan y ingresan la información del usuario.



  3. El Haga Click en OK y agrega a los usuarios adicionales cuanto sea necesario.

  4. Después de que usted agregue a los usuarios necesarios, haga clic después, y continúe a la siguiente sección.

Paso 5. Configure el túnel de Anyconnect

Complete estos pasos para configurar el túnel de Anyconnect y el pool de los IP Addresses para los usuarios:

  1. Porque Anyconnect proporciona el acceso directo a los recursos de la intranet corporativa, la lista url no es necesaria para configurar. Haga clic en el botón Next situado en el cuadro de diálogo Intranet Websites.



  2. Verifique que la casilla de verificación Enable Full Tunnel esté activada.



  3. Cree un conjunto de direcciones IP que los clientes de este contexto SSL VPN puedan utilizar.

    La agrupación de direcciones debe corresponder a los direccionamientos disponibles y al routable en su intranet.

  4. Haga clic las elipses () al lado de la dirección IP reúna el campo, y elija crean a una nueva agrupación IP.

  5. En el cuadro de diálogo Add IP Local Pool, ingrese un nombre para el conjunto (por ejemplo, nuevo), y haga clic en Add.



  6. En el cuadro de diálogo del alcance del IP Address del agregar, ingrese el rango de la agrupación de direcciones para los clientes VPN de Anyconnect y haga clic la AUTORIZACIÓN.

    Nota: Antes de la versión 12.4(20)T, el pool de la dirección IP debe estar en un rango de una interfaz conectada directamente con el router. Si usted quiere utilizar un diverso rango del pool, usted puede crear un Loopback Address asociado a su nuevo pool para satisfacer este requisito.



  7. Haga clic en OK.

  8. Configure las opciones avanzadas del túnel, tales como Túnel dividido, DNS dividido, configuraciones de representación del navegador, y servidores del Domain Name System (DNS) y del Windows Internet Name Service (TRIUNFOS).

    Nota: Cisco recomienda que usted configura por lo menos el DNS y GANA los servidores.



    Complete estos pasos para configurar las opciones avanzadas del túnel, tales como Túnel dividido:

    1. Haga clic en el botón Advanced Tunnel Options.

    2. Haga clic el DNS y GANA la lengueta de los servidores y ingresa los IP Address principales para el DNS y GANA los servidores.



    3. Haga clic la lengueta del Túnel dividido para configurar el Túnel dividido.



      La capacidad de transmitir tráfico seguro y no seguro en la misma interfaz se conoce como tunelización dividida. La tunelización dividida requiere que especifique exactamente qué tráfico es seguro y cuál es el destino de ese tráfico, de modo que solamente el tráfico especificado ingresa en el túnel mientras que el resto se transmite no encriptado a través de la red pública (Internet).

      En el ejemplo, el túnel dividido se configura para incluir el tráfico.


  9. Después de que configure la opción necesaria, haga clic en Next. Elija la opción de interfaz del túnel apropiada SSL VPN y haga clic después.



  10. Personalice la Página del Portal SSL VPN o seleccione los valores predeterminados.

    Con la Página del Portal Personalizar SSL VPN puede personalizar la presentación de la Página del Portal SSL VPN para sus clientes.



  11. Después de que personalice la página del portal SSL VPN, haga clic en Next.

  12. Haga clic en Finish (Finalizar).



  13. El tecleo entrega para salvar su configuración y después hacer clic la AUTORIZACIÓN.

    El Asistente VPN SSL somete sus comandos al router.





Éstos son básicamente los comandos que se entregan del CCP al router:

AAA commands:

aaa new-model
aaa authorization exec default local
aaa authentication login default local
line vty 0 4
login authentication default
authorization exec default
exit

Remaining commands:

aaa authentication login ciscocp_vpn_xauth_ml_1 local
ip local pool IP_Pool 192.168.1.10 192.168.1.15
interface Virtual-Template1
exit
default interface Virtual-Template1
interface Virtual-Template1
no shutdown
ip unnumbered FastEthernet0/0
exit
webvpn gateway gateway_1
ip address 10.105.130.149 port 443
http-redirect port 80
inservice
ssl trustpoint TP-self-signed-1878971148
exit
webvpn context Test
aaa authentication list ciscocp_vpn_xauth_ml_1
gateway gateway_1
virtual-template 1
max-users 1000
inservice
secondary-color white
title-color #FF9900
text-color black
policy group policy_1
svc split include 10.106.44.0 255.255.255.0
svc keep-client-installed
functions svc-enabled
svc address-pool IP_Pool netmask 255.255.255.255
svc default-domain cisco.com
svc dns-server primary 10.106.44.10
svc wins-server primary 10.106.44.12
exit
default-group-policy policy_1
exit
! IP address / user account command
username user1 privilege 1 secret 0 *********

Nota: Si usted recibe un mensaje de error, la licencia SSL VPN pudo ser incorrecta.

Complete estos pasos para corregir un problema de la licencia:

  1. Diríjase a Configure > Security > VPN, y luego haga clic en SSL VPN.

  2. Haga clic al administrador SSL VPN y después haga clic la lengueta del editar SSL VPN en el Lado derecho.



  3. Resalte su contexto creado recientemente y haga clic el botón Edit.



  4. En el campo Maximum Number of users, ingrese el número correcto de usuarios para su licencia.

  5. Haga clic en OK y luego en Deliver.

    Los comandos se escriben al archivo de configuración.

Configuración de CLI

El CCP crea estas configuraciones de la línea de comandos:

Router#show running-config
Building configuration...

Current configuration : 3590 bytes
!
! Last configuration change at 06:30:34 UTC Sat Nov 29 2014
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication login ciscocp_vpn_xauth_ml_1 local
aaa authorization exec default local
!
!
!
!
!
aaa session-id common
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
!
!
multilink bundle-name authenticated
!
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-1878971148
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1878971148
 revocation-check none
 rsakeypair TP-self-signed-1878971148
!
!
crypto pki certificate chain TP-self-signed-1878971148
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31383738 39373131 3438301E 170D3134 31313239 30353537
  32355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 38373839
  37313134 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C77D F135BBCA 8A84DE7D A3330085 3694EC3B 9BAE2F94 AF19CAEC 89A4AA6A
  DC098301 AC996CA7 BE1C6AB2 BF4745F4 911E9812 97BC1A1F 15D1AFD0 384878C6
  8781D8A7 3BFCFCFF 5626EF1A BCF73C78 B07E4587 710B6F18 B4E0017F 807606EA
  03E398B0 A2DE06B6 2D39B122 32D82E1B 7AE55554 63D8BDD6 222CF884 C9D5570D
  74BD0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 1455F1A2 00753895 04EB04BE 13273EEF D48D86C6 84301D06
  03551D0E 04160414 55F1A200 75389504 EB04BE13 273EEFD4 8D86C684 300D0609
  2A864886 F70D0101 05050003 81810013 B72A05AE E7816FB7 377FC3B3 8EE7D2AC
  9211B78D 8B6A604A DA7D571F 6E083B78 279F0EB1 95B5ADC8 79572616 53B52B90
  1BF1A39B 46F8C88C 3335F498 E2CF5ABC 5D942A23 7DE35239 04D509EF 88E60201
  8B111BD6 FE82E159 67E05A62 03BFBCA6 E99EA1CE DA52F66A 8CE502C1 B9FAA488
  8A5B022A 3003F718 E8E1C6CC 2EB03C
        quit
!
!
license udi pid CISCO2811 sn FHK1404F3X2
username username privilege 15 secret 5 $1$hPnV$zwQ6MMwLA7HUC/NJRCMyt1
username user1 secret 5 $1$X3Vu$h5/xHipon7Fym16G2SCrz1
!
redundancy
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address dhcp
 duplex auto
 speed auto
!
interface Virtual-Template1
 ip unnumbered FastEthernet0/0
!
ip local pool IP_Pool 192.168.1.10 192.168.1.15
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
 transport input all
!
scheduler allocate 20000 1000
!
webvpn gateway gateway_1
 ip address 10.105.130.149 port 443
 http-redirect port 80
 ssl trustpoint TP-self-signed-1878971148
 inservice
 !
webvpn install svc flash:/webvpn/anyconnect-win-3.1.05160-k9.pkg sequence 1
 !
webvpn context Test
 secondary-color white
 title-color #FF9900
 text-color black
 ssl authenticate verify all
 !
 !
 policy group policy_1
   functions svc-enabled
   svc address-pool "IP_Pool" netmask 255.255.255.255
   svc default-domain "cisco.com"
   svc keep-client-installed
   svc split include 10.106.44.0 255.255.255.0
   svc dns-server primary 10.106.44.10
   svc wins-server primary 10.106.44.12
 virtual-template 1
 default-group-policy policy_1
 aaa authentication list ciscocp_vpn_xauth_ml_1
 gateway gateway_1
 inservice
!
end

Router#sh run int Virtual-Access2
Building configuration...

Current configuration : 104 bytes
!
interface Virtual-Access2
 description ***Internally created by SSLVPN context Test***
 mtu 1406
end

Establezca la Conexión de Cliente VPN de AnyConnect

Complete estos pasos para establecer una conexión VPN de AnyConnect con el router.

Nota: Agregue a un router a la lista de sitios confiables en el Internet Explorer. Para más información, consulte Agregar un Dispositivo de Seguridad/Router a la lista de Sitios Confiables (IE).

  1. Ingrese el URL o el IP Address de la interfaz del WebVPN del router en su buscador Web en el formato como se muestra.

    https://<url>


    O

    https://<IP address of the Router WebVPN interface>


  2. Ingrese su nombre de usuario y contraseña.



  3. Haga clic el comienzo para iniciar la conexión del túnel de Anyconnect VPN.



    Esta ventana aparece antes de que se establezca la conexión VPN SSL.



    Nota: El software de ActiveX se debe instalar en su ordenador antes de que usted descargue el Anyconnect VPN.





  4. Una vez que la conexión se establece correctamente, haga clic en la pestaña Statistics.

    La pestaña Statistics muestra la información sobre la conexión SSL.



    Las estadísticas detallan la información estadística detallada las visualizaciones de la conexión del cuadro de diálogo, que incluye el estado de túnel y el modo, la duración de la conexión, la cantidad de bytes y la enmarcan enviado y recibido, información de dirección, información del transporte, y el estatus de la evaluación de la postura del Cisco Secure Desktop. El botón Reset en esta pestaña restablece las estadísticas de la transmisión. El botón Stats de la exportación permite que usted exporte las estadísticas actuales, la interfaz, y la tabla de ruteo a un archivo de texto. El cliente de AnyConnect le solicita que designe un nombre y una ubicación al archivo de texto. El nombre predeterminado es A nyConnect-ExportedStats.txt y la ubicación predeterminada está en el escritorio.

  5. Marque los detalles de la ruta (basados en la configuración del túnel dividido) bajo lengueta de los detalles de la ruta.



  6. En el cuadro de diálogo del Cliente Cisco AnyConnect VPN, haga clic alrededor la lengueta para visualizar la información de la versión del Cliente Cisco AnyConnect VPN.



Verificación

Utilize esta sección para confirmar que su configuración funcione correctamente.

Comandos

Nota: La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Varios comandos show se asocian a WebVPN. Usted puede ejecutar estos comandos en el CLI para mostrar las estadísticas y la otra información. Para obtener información detallada sobre los comandos show, consulte Verificar la Configuración WebVPN.

muestre el contexto todo de la sesión del webvnp

Router#show webvpn session context all
WebVPN context name: Test
Client_Login_Name  Client_IP_Address  No_of_Connections  Created  Last_Used
user1              10.106.42.10                1         00:01:22  00:00:01

muestre la prueba del contexto del user1 del usuario de sesión del webvpn

Router#show webvpn session user user1 context Test detail
Session Type      : Full Tunnel
Client User-Agent : AnyConnect Windows 3.1.05160

Username          : user1                Num Connection : 1
Public IP         : 10.106.42.10         VRF Name       : None
Context           : Test                 Policy Group   : policy_1
Last-Used         : 00:00:00             Created        : *06:33:24.505 UTC Sat
Nov 29 2014
Session Timeout   : Disabled             Idle Timeout   : 2100
DNS primary serve : 10.106.44.10         WINS primary s : 10.106.44.12
DPD GW Timeout    : 300                  DPD CL Timeout : 300
Address Pool      : IP_Pool              MTU Size       : 1199
Rekey Time        : 3600                 Rekey Method   :
Lease Duration    : 43200
Tunnel IP         : 192.168.1.10         Netmask        : 255.255.255.255
Rx IP Packets     : 0                    Tx IP Packets  : 617
CSTP Started      : 00:01:22             Last-Received  : 00:00:00
CSTP DPD-Req sent : 0                    Virtual Access : 2
Msie-ProxyServer  : None                 Msie-PxyPolicy : Disabled
Msie-Exception    :
Split Include     : 10.106.44.0 255.255.255.0
Client Ports      : 60304

Detail Session Statistics for User:: user1
----------------------------------

CSTP Statistics::
Rx CSTP Frames    : 618                Tx CSTP Frames   : 0
Rx CSTP Bytes     : 46113              Tx CSTP Bytes    : 0
Rx CSTP Data Fr   : 617                Tx CSTP Data Fr  : 0
Rx CSTP CNTL Fr   : 1                  Tx CSTP CNTL Fr  : 0
Rx CSTP DPD Req   : 0                  Tx CSTP DPD Req  : 0
Rx CSTP DPD Res   : 0                  Tx CSTP DPD Res  : 0
Rx Addr Renew Req : 0                  Tx Address Renew : 0
Rx CDTP Frames    : 0                  Tx CDTP Frames   : 0
Rx CDTP Bytes     : 0                  Tx CDTP Bytes    : 0
Rx CDTP Data Fr   : 0                  Tx CDTP Data Fr  : 0
Rx CDTP CNTL Fr   : 0                  Tx CDTP CNTL Fr  : 0
Rx CDTP DPD Req   : 0                  Tx CSTP DPD Req  : 0
Rx CDTP DPD Res   : 0                  Tx CDTP DPD Res  : 0
Rx IP Packets     : 0                  Tx IP Packets    : 617
Rx IP Bytes       : 0                  Tx IP Bytes      : 41122

CEF Statistics::
Rx CSTP Data Fr   : 0                  Tx CSTP Data Fr  : 0
Rx CSTP Bytes     : 0                  Tx CSTP Bytes    : 0

muestre el stats del webvpn

Router#show webvpn stats
User session statistics:
    Active user sessions     : 1          AAA pending reqs         : 0
    Peak user sessions       : 1          Peak time                : 00:02:29
    Active user TCP conns    : 1          Terminated user sessions : 0
    Session alloc failures   : 0          Authentication failures  : 0
    VPN session timeout      : 0          VPN idle timeout         : 0
    User cleared VPN sessions: 0          Exceeded ctx user limit  : 0
    Exceeded total user limit: 0
    Client process rcvd pkts : 57         Server process rcvd pkts : 0
    Client process sent pkts : 8134       Server process sent pkts : 0
    Client CEF received pkts : 664        Server CEF received pkts : 0
    Client CEF rcv punt pkts : 29         Server CEF rcv punt pkts : 0
    Client CEF sent pkts     : 0          Server CEF sent pkts     : 0
    Client CEF sent punt pkts: 0          Server CEF sent punt pkts: 0

    SSLVPN appl bufs inuse   : 0          SSLVPN eng  bufs inuse   : 0
    Active server TCP conns  : 0

Mangling statistics:
    Relative urls            : 0          Absolute urls            : 0
    Non-http(s) absolute urls: 0          Non-standard path urls   : 0
    Interesting tags         : 0          Uninteresting tags       : 0
    Interesting attributes   : 0          Uninteresting attributes : 0
    Embedded script statement: 0          Embedded style statement : 0
    Inline scripts           : 0          Inline styles            : 0
    HTML comments            : 0          HTTP/1.0 requests        : 0
    HTTP/1.1 requests        : 3          Unknown HTTP version     : 0
    GET requests             : 3          POST requests            : 0
    CONNECT requests         : 0          Other request methods    : 0
    Through requests         : 0          Gateway requests         : 3
    Pipelined requests       : 0          Req with header size >1K : 0
    Processed req hdr bytes  : 844        Processed req body bytes : 0
    HTTP/1.0 responses       : 0          HTTP/1.1 responses       : 0
    HTML responses           : 0          CSS responses            : 0
    XML responses            : 0          JS responses             : 0
    Other content type resp  : 0          Chunked encoding resp    : 0
    Resp with encoded content: 0          Resp with content length : 0
    Close after response     : 0          Resp with header size >1K: 0
    Processed resp hdr size  : 0          Processed resp body bytes: 0
    Backend https response   : 0          Chunked encoding requests: 0

HTTP Authentication stats :
    Successful NTLM Auth     : 0          Failed NTLM Auth         : 0
    Successful Basic Auth    : 0          Failed Basic Auth        : 0
    Unsupported Auth         : 0          Unsup Basic HTTP Method  : 0
    NTLM srv kp alive disabld: 0          NTLM Negotiation Error   : 0
    Oversize NTLM Type3 cred : 0          Internal Error           : 0
    Num 401 responses        : 0          Num non-401 responses    : 0
    Num Basic forms served   : 0          Num NTLM forms served    : 0
    Num Basic Auth sent      : 0          Num NTLM Auth sent       : 0

CIFS statistics:
  SMB related Per Context:
    TCP VC's                 : 0          UDP VC's                 : 0
    Active VC's              : 0          Active Contexts          : 0
    Aborted Conns            : 0
  NetBIOS related Per Context:
    Name Queries             : 0          Name Replies             : 0
    NB DGM Requests          : 0          NB DGM Replies           : 0
    NB TCP Connect Fails     : 0          NB Name Resolution Fails : 0
  SMB related Global:
    Sessions in use          : 0          Mbufs in use             : 0
    Mbuf Chains in use       : 0          Active VC's              : 0
    Active Contexts          : 0          Browse Errors            : 0
    Empty Browser List       : 0          NetServEnum Errors       : 0
    Empty Server List        : 0          NBNS Config Errors       : 0
    NetShareEnum Errors      : 0
  HTTP related Per Context:
    Requests                 : 0          Request Bytes RX         : 0
    Request Packets RX       : 0          Response Bytes TX        : 0
    Response Packets TX      : 0          Active Connections       : 0
    Active CIFS context      : 0          Requests Dropped         : 0
  HTTP related Global:
    Server User data         : 0          CIFS User data           : 0
    Net Handles              : 0          Active CIFS context      : 0
    Authentication Fails     : 0          Operations Aborted       : 0
    Timers Expired           : 0          Pending Close            : 0
    Net Handles Pending SMB  : 0          File Open Fails          : 0
    Browse Network Ops       : 0          Browse Network Fails     : 0
    Browse Domain Ops        : 0          Browse Domain Fails      : 0
    Browse Server Ops        : 0          Browse Server Fails      : 0
    Browse Share Ops         : 0          Browse Share Fails       : 0
    Browse Dir Ops           : 0          Browse Network Fails     : 0
    File Read Ops            : 0          File Read Fails          : 0
    File Write Ops           : 0          File Write Fails         : 0
    Folder Create Ops        : 0          Folder Create Fails      : 0
    File Delete Ops          : 0          File Delete Fails        : 0
    File Rename Ops          : 0          File Rename Fails        : 0
    URL List Access OK       : 0          URL List Access Fails    : 0

Socket statistics:
    Sockets in use           : 1          Sock Usr Blocks in use   : 1
    Sock Data Buffers in use : 0          Sock Buf desc in use     : 0
    Select timers in use     : 1          Sock Select Timeouts     : 0
    Sock Tx Blocked          : 150        Sock Tx Unblocked        : 150
    Sock Rx Blocked          : 0          Sock Rx Unblocked        : 0
    Sock UDP Connects        : 0          Sock UDP Disconnects     : 0
    Sock Premature Close     : 0          Sock Pipe Errors         : 13
    Sock Select Timeout Errs : 0

Smart Tunnel statistics:
  Client                                Server
    proc pkts                : 0          proc pkts                 : 0
    proc bytes               : 0          proc bytes                : 0
    cef  pkts                : 0          cef  pkts                 : 0
    cef  bytes               : 0          cef  bytes                : 0

Port Forward statistics:
  Client                                Server
    proc pkts                : 0          proc pkts                 : 0
    proc bytes               : 0          proc bytes                : 0
    cef pkts                 : 0          cef pkts                  : 0
    cef bytes                : 0          cef bytes                 : 0

WEBVPN Citrix statistics:

               Server                   Client
  Packets in  : 0                        0
  Packets out : 0                        0
  Bytes in    : 0                        0
  Bytes out   : 0                        0

ACL statistics:
    Permit web request       : 0          Deny web request         : 0
    Permit cifs request      : 0          Deny cifs request        : 0
    Permit without ACL       : 0          Deny without match ACL   : 0
    Permit with match ACL    : 0          Deny with match ACL      : 0

Single Sign On statistics:
    Auth Requests            : 0          Pending Auth Requests    : 0
    Successful Requests      : 0          Failed Requests          : 0
    Retranmissions           : 0          DNS Errors               : 0
    Connection Errors        : 0          Request Timeouts         : 0
    Unknown Responses        : 0

URL-rewrite splitter statistics:
    Direct access request    : 0          Redirect request         : 0
    Internal request         : 0

Tunnel Statistics:
    Active connections       : 1
    Peak connections         : 1          Peak time                : 00:01:44
    Connect succeed          : 2          Connect failed           : 0
    Reconnect succeed        : 1          Reconnect failed         : 0
    DPD timeout              : 0
  Client
    in  CSTP frames          : 671        in  CSTP control         : 1
    in  CSTP data            : 670        in  CSTP bytes           : 50002
    out CSTP frames          : 0          out CSTP control         : 0
    out CSTP data            : 0          out CSTP bytes           : 0
    in  CDTP frames          : 0          in  CDTP control         : 0
    in  CDTP data            : 0          in  CDTP bytes           : 0
    out CDTP frames          : 0          out CDTP control         : 0
    out CDTP data            : 0          out CDTP bytes           : 0
    cef in  CSTP data frames : 0          cef in  CSTP data bytes  : 0
    cef out CSTP data frames : 0          cef out CSTP data bytes  : 0
    cef in  CDTP data frames : 0          cef in  CDTP data bytes  : 0
    cef out CDTP data frames : 0          cef out CDTP data bytes  : 0
  Server
    In  IP pkts              : 0          In  IP bytes             : 0
    Out IP pkts              : 670        Out IP bytes             : 44587

En el CCP, elija el > Security (Seguridad) > el estado del VPN > SSL VPN (todos los contextos) de la supervisión para ver las listas de usuario de VPN actuales SSL en el router.

Troubleshooting

Esta sección proporciona la información que usted puede utilizar para resolver problemas su configuración.

Comandos para resolución de problemas

Varios comandos clear se asocian a WebVPN. Para obtener información detallada sobre estos comandos, consulte Uso de los Comandos Clear de WebVPN.

Varios comandos debug se asocian a WebVPN. Para obtener información detallada sobre estos comandos, consulte Uso de los Comandos Debug de WebVPN.

Nota: El uso de los comandos debug puede afectar negativamente su dispositivo de Cisco. Antes de que utilice los comandos debug, consulte Información Importante sobre los Comandos Debug.

Información Relacionada


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 110608