Switches : Sistema de switching virtual 1440 Cisco Catalyst 6500

Emigre el Cisco Catalyst 6500 Switch independiente al sistema de transferencia virtual del Cisco Catalyst 6500

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona la información sobre el procedimiento para emigrar un Cisco Catalyst 6500 Series Switch independiente a un sistema de transferencia virtual del Cisco Catalyst 6500.

Nota: Este documento proporciona los pasos comunes que se requieren para la migración. Los pasos exactos se basan en la configuración del switch actual y pueden variar levemente del procedimiento mencionado.

prerrequisitos

Requisitos

Cisco recomienda que tenga conocimiento sobre estos temas:

Componentes Utilizados

La información en este documento se basa en los Cisco Catalyst 6500 Series Switch con el supervisor VS-S720-10G-3C/XL que funciona con el Software Release 12.2(33)SXH1 o Posterior del½ del¿Â del Cisco IOSïÂ.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Antecedentes

El sistema de transferencia virtual (VSS) es una nueva e innovadora característica en los Cisco Catalyst 6500 Series Switch que permite con eficacia agrupar de dos chasis físicos junto en una sola entidad lógica. Tal tecnología permite las nuevas mejoras en todas las áreas del despliegue de la oficina central de la empresa y del centro de datos, que incluye la Alta disponibilidad, scalability/funcionamiento, Administración y mantenimiento.

La implementación actual del VSS permite que usted combine dos Cisco Catalyst 6500 Series Switch físicos juntos en una sola entidad lógico-manejada. Esta figura proporciona una representación gráfica de este concepto donde dos 6509 chasis se pueden manejar como solo 18-slot chasis VSS se habilitan una vez:

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration1.gif

Proceso de migración

Soporte del hardware y software

El VSS es una función del software disponible solamente con los Cisco Catalyst 6500 Series Switch. Para habilitar y configurar esta característica, se requiere esto:

Hardware VS-S720-10G-3C/XL

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration2.gif

Software Cisco IOS Software Release 12.2(33)SXH1 o Posterior

Chasis soportado por el sistema de transferencia virtual de Cisco

Número de modelo Descripción
WS-C6503-E Chasis del E-series 3-slot
WS-C6504-E Chasis del E-series 4-slot
WS-C6506 chasis 6-slot
WS-C6506-E Chasis del E-series 6-slot
WS-C6509 chasis 9-slot
WS-C6509-E Chasis del E-series 9-slot
WS-C6509-NEB-A chasis vertical de los estándares de edificio del equipo de red 9-slot (NEBS)
WS-C6509-V-E Chasis de la vertical del E-series 9-slot
WS-C6513 chasis 13-slot

Esta tabla da una lista completa del chasis soportado con la versión inicial del sistema de transferencia virtual de Cisco. Para más información, refiera al sistema de transferencia virtual de las Cisco Catalyst 6500 Series (VSS) 1440.

Trayectos de migración

La tabla enumera algunos de los trayectos de migración posibles al VSS. Esta lista es solamente sugestiva y no completa.

Configuración inicial Actualización requerida Configuración final
Dos Cisco Catalyst 6500 Series Switch con WS-SUP720-3B los supervisores.

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration3.gif

Actualización de hardware - Actualización del software de los supervisores VS-S720-10G-3C/XL - Cisco IOS 12.2(33)SXH1 o más adelante VSS

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration4.gif

Dos Cisco Catalyst 6500 Series Switch con los supervisores VS-S720-10G-3C/XL.

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration5.gif

Actualización del software - Cisco IOS 12.2(33)SXH1 o más adelante VSS

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration4.gif

Descripción de la migración

Configuración común en el entorno independiente

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration6.gif

Características o protocolos que se ejecutan entre la base de la capa 3 (L3) y la distribución L2/L3:

  • IP Routing Protocol

  • Característica de trayectoria múltiple de los Canales de puerto L3 o de EqualCost del Routing IP

Características o protocolos que se ejecutan entre la distribución L2/L3 y la capa de acceso:

  • Spanning Tree Protocol

  • Primeros protocolos del Hop Routing (FHRP)

  • Directivas: QoS, ACL

  • Links troncales L2, VLA N, Canales de puerto

Migración al VSS

Esto es un proceso de varias fases, y cada paso se explica en esta sección.

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration7.gif

Pasos de la migración entre la base y la capa de distribución:

  • Configurando el EtherChannel del Multichassis (MEC)

  • Comandos de modificación de la configuración de IP Routing y de la eliminación, que son requeridos

Pasos de la migración entre la distribución y la capa de acceso:

  • Configurar MEC

  • Manteniendo el Spanning Tree Protocol habilitado

  • Comandos de modificación FHRP

  • Directivas de mudanza de QoS y ACL a MEC (si procede)

  • Configuración de mudanza de los links troncales L2 a MEC

Proceso de migración gradual

Complete estos pasos:

  1. En la configuración independiente inicial, el tráfico es comúnmente carga balanceada entre los switches de distribución usando la distribución y la configuración HSRP de carga de VLAN.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration8.gif

  2. Modifique el HSRP y la configuración de STP de modo que Distribution-1 sea activo para todos los flujos, y los dispositivos de vecindad detectan este cambio y envían todo el tráfico a Distribution-1.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration9.gif

  3. Apague las interfaces físicas de Distribution-2, para aislarlo de la red.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration10.gif

    .

    Una vez que el Distribution-2 se quita totalmente de la red, puede ser convertido al modo VSS sin el tráfico de producción de interrupción.

  4. Si no instalado previamente, instale al nuevo supervisor (VS-SUP720-10G) y verifique el estatus.

    Distribution-2#show module
    Mod Ports Card Type                              Model              Serial No.
    --- ----- -------------------------------------- ------------------ -----------
      5    5  Supervisor Engine 720 10GE (Active)    VS-S720-10G        SAD104707BB
      9   48  CEF 720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX     SAL1020NGY3
  5. Copie el Cisco IOS Software compatible VSS al disco de arranque sup:

    Distribution-2#copy ftp: sup-bootdisk:
    Address or name of remote host []? 172.16.85.150
    Source filename []? s72033-ipservices_wan_vz.122-33.SXH1.bin
    Destination filename [s72033-ipservices_wan_vz.122-33.SXH1.bin]?
    Accessing ftp://172.16.85.150/s72033-ipservices_wan_vz.122-33.SXH1.bin...
  6. Ponga al día el bootvar para cargar el Cisco IOS Software copiado al disco de arranque sup:

    Distribution-2(config)#boot system flash sup-bootdisk:s72033-ipservices_wan_vz.122-33.SXH1.bin
    
    
  7. Para que el Switch Distribution-2 se ejecute en el modo VSS, se requiere un link del switch virtual (VSL). El link actual del Canal de puerto entre Distribution-1 y Distribution-2 se puede utilizar para formar el VSL.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration11.gif

  8. Configure los atributos del switch virtual:

    1. Número de dominio del switch virtual (único dentro de la red)

    2. Número del switch virtual (único dentro del dominio)

    3. Link del switch virtual (VSL)

    Distribution-2(config)#hostname VSS
    
    VSS(config)#switch virtual domain 100
    
    VSS(config-vs-domain)#switch 1
    
    
    !--- After conversion Distribution-2 will be noted 
    !--- as Switch 1 in VSS mode.
    
    VSS(config-vs-domain)# exit
    VSS(config)#interface port-channel 1
    VSS(config-if)#switch virtual link 1
    
    VSS(config-if)#interface TenG 5/4
    VSS(config-if)#channel-group 1 mode on
    VSS(config-if)#interface TenG 5/5
    VSS(config-if)#channel-group 1 mode on
    VSS(config-if)# ^Z
    VSS#
  9. Convierta el Switch Distribution-2 al modo VSS.

    Nota: Publique este comando vía la consola del Switch:

    VSS#switch convert mode virtual
    
    This command will convert all interface
    names to naming convention "interface-type
    switch-number/slot/port",
    save the running config to startup-config and
    reload the switch.
    Do you want to proceed? [yes/no]: yes
    Converting interface names
    Building configuration...
    
    
    !--- At this point the switch will reboot
    
    
    
    !--- snippet of the console output
    
    System detected Virtual Switch configuration...
     Interface TenGigabitEthernet 1/5/4 is member of
    PortChannel 1
     Interface TenGigabitEthernet 1/5/5 is member of
    PortChannel 1
    
    !--- snippet of the console output
    
    00:00:23: %PFREDUN-6-ACTIVE: Initializing as ACTIVE
    processor for this switch
    
    !--- snippet of the console output
    
    00:00:28: %VSL_BRINGUP-6-MODULE_UP: VSL module in slot 5
    switch 1 brought up
    Initializing as Virtual Switch Active
    
  10. Verifique la conversión del Switch Distribution-2 al modo VSS.

    VSS#show switch virtual role
    
    Switch  Switch Status  Preempt    Priority   Role     Session ID
            Number         Oper(Conf) Oper(Conf)          Local  Remote
    -------------------------------------------------------------------
    LOCAL    1     UP      FALSE(N)    110(110)  ACTIVE    0      0
    
    In dual-active recovery mode: No

    El Switch Distribution-2 se convierte y está actuando con éxito en el modo VSS. los pasos de la PRE-configuración pueden también ser realizados después de convertir el Switch Distribution-1. Sin embargo, la PRE-configuración ayuda a reducir la cantidad de pérdida del paquete durante la migración.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration12.gif

  11. Complete estos pasos para preconfigurar el Switch1 VSS:

    1. Configure MEC usando las interfaces locales Switch-1. Las interfaces del switch-2 (actualmente Distribution-1) se pueden agregar a MEC después de convertirlo al modo VSS.

      • Configuración MEC.

      • Mueva la configuración de la interfaz a MEC.

      • Mueva QoS y las directivas ACL a MEC.

      Configuración inicial
      interface TenGigabitEthernet1/2/1
       ip address 192.168.4.2 255.255.255.0
      
      interface GigabitEthernet1/1/2
       switchport
       switchport trunk encapsulation dot1q
       switchport trunk allowed vlan 10,20
      Cambios de configuración
      
      !--- MEC to Core layer
      
      VSS(config)# int ten 1/2/1
      VSS(config-if)# no ip address
      VSS(config-if)# interface po20
      VSS(config-if)# ip address 192.168.4.2 255.255.255.0
      VSS(config-if)# no shut
      VSS(config-if)# interface ten1/2/1
      VSS(config-if)# channel-group 20 mode desirable
      
      
      !--- MEC to Access layer
      
      VSS(config-if)# interface po10
      VSS(config-if)# switchport
      VSS(config-if)# switchport trunk encapsulation dot1q
      VSS(config-if)# switchport trunk allowed vlan 10,20
      VSS(config-if)# no shut
      VSS(config-if)# interface gig1/1/2
      VSS(config-if)# switchport
      VSS(config-if)# channel-group 10 mode desirable
      Dispositivos de vecindad de la configuración para acomodar el Canal de puerto

      La conexión entre el Switch-1 VSS y sus dispositivos de vecindad está abajo en este momento. Por lo tanto, un Canal de puerto se configura sin el tráfico de interferencia atraviesa Distribution-1.

      
      !--- In Core layer devices
      
      Core(config)# int gig 1/1
      Core(config-if)# no ip address
      Core(config-if)# int po20
      Core(config-if)# ip address 192.168.4.1 255.255.255.0
      Core(config-if)# no shut
      Core(config-if)# int gig 1/1
      Core(config-if)# channel-group 20 mode desirable
      
      !--- In Access layer devices
      
      Access(config)# int po10
      Access(config-if)# switchport
      Access(config-if)# switchport trunk encapsulation dot1q
      Access(config-if)# switchport trunk
      Access(config-if)# no shut
      Access(config-if)# int gig 1/1
      Access(config-if)# channel-group 10 mode desirable
    2. En el chasis activo y espera VSS, utilice los chasis activos quemar-en la dirección MAC y la dirección IP del VLA N. El HSRP se requiere no más.

      • Mueva los IP Addresses virtuales del HSRP a las interfaces VLAN.

      • Quite la configuración HSRP de las interfaces VLAN.

      Configuración inicial
      interface Vlan10
       ip address 10.1.1.2 255.255.255.0
       standby 10 ip 10.1.1.1
       standby 10 priority 110
      !
      interface Vlan20
       ip address 20.1.1.2 255.255.255.0
       standby 20 ip 20.1.1.1
       standby 20 priority 110
      !
      Cambios de configuración
      VSS(config)# interface Vlan10
      VSS(config-if)# no standby 10 ip 10.1.1.1
      VSS(config-if)# no standby 10 priority 110
      VSS(config-if)# ip address 10.1.1.1 255.255.255.0
      VSS(config-if)# interface Vlan20
      VSS(config-if)# no standby 20 ip 20.1.1.1
      VSS(config-if)# no standby 20 priority 110
      VSS(config-if)# ip address 20.1.1.1 255.255.255.0

      Nota: Los dispositivos extremos todavía estarían señalando sus entradas ARP para rubricar la dirección MAC del HSRP. Hasta que estas entradas midan el tiempo hacia fuera u otro ARP se envía para poner al día su caché, hay una cierta Pérdida de conectividad.

    3. Habilite la característica NSF-SSO para los IP Routing Protocol usados. El VSS simplifica la configuración de ruteo, así que algunas de las declaraciones de la red se requieren no más. Por lo tanto, pueden ser quitadas.

      Switch-1 VSS
      VSS#show running-config | begin ospf
      router ospf 1
       log-adjacency-changes
       network 10.1.1.0 0.0.0.255 area 0
       network 20.1.1.0 0.0.0.255 area 0
       network 192.168.4.0 0.0.0.255 area 0
       network 192.168.5.0 0.0.0.255 area 0
      
      !--- rest of output elided
      
      
      
      !--- Previous L3 interfaces are merged as MEC, hence some
      routing statements are no longer required.
      
      
      VSS(config)# router ospf 1
      VSS(config-router)# nsf
      VSS(config-router)# no network 192.168.5.0 0.0.0.255 area 0
      Núcleo
      Core#show running-config | begin ospf
      router ospf 1
       log-adjacency-changes
       network 192.168.4.0 0.0.0.255 area 0
       network 192.168.5.0 0.0.0.255 area 0
      
      !--- rest of output elided
      
      
      
      !--- Previous L3 interfaces are merged as MEC, hence some
      routing statements are no longer required.
      
      
      Core(config)# router ospf 1
      Core(config-router)# nsf
      Core(config-router)# no network 192.168.5.0 0.0.0.255 area 0
    4. Modifique la configuración de STP de modo que el Switch-1 VSS se convierta en la raíz para todos los VLA N.

  12. Verifique la configuración y la Conectividad del Switch-1 VSS.

    • Habilite las interfaces del Switch-1 VSS.

    • Verifique la Conectividad L2 a los dispositivos de la capa de acceso.

    • Verifique la Conectividad L3 a los dispositivos de la capa del núcleo.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration13.gif

  13. Después de que se verifique la Conectividad del Switch-1 VSS, apague las interfaces de Distribution-1 para cambiar el tráfico al VSS.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration14.gif

  14. Relance los pasos de la conversión en el Switch Distribution-1 para traer eso en el modo de reserva preferido VSS.

    Distribution-1(config)#hostname VSS
    
    VSS(config)#switch virtual domain 100
    
    VSS(config-vs-domain)#switch 2
    
    
    !--- After conversion Distribution-1 will be noted 
    !--- as Switch 2 in VSS mode.
    
    VSS(config-vs-domain)# exit
    VSS(config)#interface port-channel 2
    VSS(config-if)#switch virtual link 2
    
    VSS(config-if)#interface TenG 5/4
    VSS(config-if)#channel-group 2 mode on
    VSS(config-if)#interface TenG 5/5
    VSS(config-if)#channel-group 2 mode on
    VSS(config-if)# ^Z
    VSS#
    
    VSS#switch convert mode virtual
    
    This command will convert all interface
    names to naming convention "interface-type
    switch-number/slot/port",
    save the running config to startup-config and
    reload the switch.
    Do you want to proceed? [yes/no]: yes
    Converting interface names
    Building configuration...
    
    
    !--- At this point the switch will reboot
    
    
    
    !--- snippet of the console output
    
    System detected Virtual Switch configuration...
     Interface TenGigabitEthernet 2/5/4 is member of
    PortChannel 2
     Interface TenGigabitEthernet 2/5/5 is member of
    PortChannel 2
    
    !--- snippet of the console output
    
    00:00:23: %PFREDUN-6-ACTIVE: Initializing as ACTIVE
    processor for this switch
    
    !--- snippet of the console output
    
    00:00:28: %VSL_BRINGUP-6-MODULE_UP: VSL module in slot 5
    switch 2 brought up
    Initializing as Virtual Switch Standby
    
  15. Después de que el Switch espera VSS arranque, la configuración activa VSS se sincroniza automáticamente al recurso seguro VSS. En el arrancar, las interfaces del recurso seguro VSS (switch-2) están en el estado de cierre normal.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration15.gif

  16. Concluya la configuración del switch virtual.

    Nota: Este final, Paso crítico es aplicable solamente para una conversión por primera vez. Si el Switch se ha convertido o se ha convertido parcialmente ya, usted no puede utilizar este comando. Se genera un mensaje de error si se convierte o se convierte parcialmente el Switch:

    11:27:30: %PM-SP-4-ERR_DISABLE: channel-misconfig error detected
    on Po110, putting Gi9/2 in err-disable state
    

    Usted puede publicar este comando de configurar automáticamente la configuración espera del switch virtual en el switch virtual activo:

    VSS#switch accept mode virtual
    
    This command will bring in all VSL configurations from the standby 
    switch and populate it into the running configuration.
    In addition the startup configurations will be updated with the 
    new merged configurations.
    Do you want proceed? [yes/no]: yes
    Merging the standby VSL configuration. . .
    Building configuration...

    Nota: Sea consciente que el Switch valida el comando virtual del modo está necesitado no más en el Cisco IOS Software Release 12.2 SXI mientras que las configuraciones se combinan automáticamente.

  17. Agregue las interfaces del switch-2 a MEC.

    • VSS
      
      !--- To Core layer
      
      VSS(config)# interface range tengig 1/2/1, tengig2/2/1
      VSS(config-if-range)# channel-group 20 mode desirable
      VSS(config-if-range)# no shut
      
      
      !--- To Access layer
      
      VSS(config)# interface range gig 1/1/2, gig 2/1/2
      VSS(config-if-range)# switchport
      VSS(config-if-range)# channel-group 10 mode desirable
      VSS(config-if-range)# no shut
      
    • Vecino VSS - Base
      Core(config)# interface range gig 1/1, gig 1/2
      Core(config-if-range)# channel-group 20 mode desirable
      Core(config-if-range)# no shut
    • Vecino VSS - Acceso
      Access(config)# interface range gig 1/1, gig 1/2
      Access(config-if-range)# channel-group 10 mode desirable
      Access(config-if-range)# no shut

    La migración al VSS es completa. En este momento, ambo Switches del VSS se está ejecutando y el tráfico es carga balanceada en todas las interfaces de link ascendente.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration16.gif


Información Relacionada


Document ID: 109573