Ethernet de largo alcance (LRE) y Línea de suscriptor digital (xDSL) : Línea de suscriptor digital asimétrica (ADSL)

Guía de Configuración y Troubleshooting del Cisco DSL Router - PPPoA del router DLS de Cisco con un IP Address estático

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Su Proveedor de Servicios de Internet (ISP) ha asignado una dirección IP pública dinámica a su Cisco Digital Subscriber Line (DSL) Router.

Consejo: Si usted no es familiar con cómo configurar los dispositivos de Cisco y quisiera seguir una configuración gradual, refiera a la configuración gradual del PPPoA con un IP Address estático.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Tareas de realizarse

  • Diseñe un esquema de IP Addressing para su LAN privado.

  • Configure una dirección IP y a una máscara de subred en la interfaz de Ethernet del router DLS de Cisco.

  • Configure la interfaz ATM interfaz (del Asynchronous Digital Subscriber Line (ADSL)) del router DLS de Cisco con un circuito virtual permanente (PVC) y la encapsulación atmósfera.

  • Cree y configure la interfaz del dialer del router DLS de Cisco para el protocolo Point-to-Point sobre la atmósfera (PPPoA) con un IP Address estático.

  • Para el NAT: Configure el NAT en el router DLS de Cisco para permitir la distribución del IP Address público estático de la interfaz del dialer.

    • Opcional: Agrupamiento NAT, si los IP Addresses adicionales han sido proporcionados por su ISP.

    • Opcional: NAT estático, si los usuarios de Internet requieren el acceso a los servidores internos.

  • Configure cada host PC con una dirección IP, una máscara de subred, un default gateway, y un servidor del Domain Name System (DNS).

    Alternativamente, si usted quisiera que el router DLS de Cisco asignara los IP Address dinámicos de sus PC cliente, configure cada PC para obtener una dirección IP y los servidores DNS automáticamente vía el DHCP.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Configuración

Consejo: Si usted no es familiar con cómo configurar los dispositivos de Cisco y quisiera seguir una configuración gradual, refiera a la configuración gradual del PPPoA con un IP Address estático.

Router DLS de Cisco con un IP Address estático

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
ip subnet-zero
!

!--- For DHCP:

ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server>
!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>

!--- For NAT:

 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 pvc <vpi/vci>
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

!
interface dialer1
 ip address <ip address> subnet mask <subnet mask> 
 no ip directed-broadcast

!--- For NAT:

 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp chap hostname <username> 
 ppp chap password <password> 
 ppp pap sent-username <username> password <password> 
!

!--- For NAT:

ip nat inside source list 1 interface dialer1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface dialer1 overload

 
 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!---  netmask <subnet mask>




!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!--- <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless 
ip route 0.0.0.0 0.0.0.0 dialer1 

!--- For NAT:

access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, configure 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 in order to allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Refiera al PPPoA del troubleshooting si su servicio ADSL no trabaja correctamente.


Información Relacionada


Document ID: 71110