Ethernet de largo alcance (LRE) y Línea de suscriptor digital (xDSL) : Línea de suscriptor digital asimétrica (ADSL)

Guía de Configuración y Troubleshooting del Cisco DSL Router - Configuración gradual del PPPoA con un IP Address dinámico

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Su Proveedor de Servicios de Internet (ISP) ha asignado una dirección IP pública dinámica a su Cisco Digital Subscriber Line (DSL) Router.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

Conecte el router DLS de Cisco y su PC

Una conexión de consola se hace con un cable enrollado y conecta el puerto de la consola del router del Digital Subscriber Line (DSL) de Cisco con un puerto COM en un PC. El cable de la consola que se incluye con el router DLS de Cisco es un cable azul claro plano. Para más información sobre las configuraciones del cable de un cable enrollado, o las configuraciones del cable de un RJ-45 al convertidor DB9, refiera a la guía del cableado para la consola y los puertos auxiliares.

  1. Conecte el conector RJ-45 en un extremo de un cable de la consola de Cisco con el puerto de la consola del router DLS de Cisco.

  2. Conecte el conector RJ-45 en el otro extremo del cable de la consola con un RJ-45 con el convertidor DB9.

  3. Conecte el conector DB9 con un puerto COM abierto en su PC.

Comience y configure el hyperterminal

Complete estos pasos:

  1. Comience el programa del hyperterminal sobre el PC.

  2. Configure a su sesión HyperTerminal.

    1. Asigne un nombre a su sesión, y haga clic la AUTORIZACIÓN.

    2. De la conexión con la ventana, haga clic la cancelación.

    3. Del menú de archivos, haga clic las propiedades.

    4. De la ventana de pPropiedades, en la conexión usando la lista, seleccione el puerto COM en donde usted conecta el extremo DB9 del cable de la consola.

    5. Del tecleo de la ventana de pPropiedades configure y complete estos valores:

      • Bits por segundo: 9600

      • Bits de datos: 8

      • Paridad: Ninguno

      • Bits de parada: 1

      • Control de Flujo: Ninguno

    6. Haga clic en OK.

    7. Del Call Menu, desconexión del tecleo.

    8. Del Call Menu, llamada del tecleo.

    9. Presione ENTER hasta que usted vea un prompt de router en su pantalla del hyperterminal.

Borre las configuraciones existentes en el router DLS de Cisco

Complete estos pasos:

  1. Teclee enable en el prompt de router para ingresar al modo privilegiado.

    Router>enable
    Router#
    
    !--- The # symbol indicates that you are in privileged mode.
    
    
  2. Borre las configuraciones existentes en el router.

    Router#write erase
    
  3. Recargue al router así que inicia con una configuración de inicio en blanco.

    Router#reload
    System configuration has been modified. Save? [yes/no]:no
    Proceed with reload? [confirm]yes
    
    !--- Reloading the router can take a few minutes.
    
    
  4. Después de que el router haya recargado, ingrese el enable mode otra vez.

    Router>enable
    Router#

Configure el router DLS de Cisco

Complete estos pasos:

  1. Configure la indicación de fecha y hora de servicio para registrar y para visualizar correctamente la salida de los debugs en la sección de Troubleshooting.

    Router#configure terminal
    Router(config)#service timestamps debug datetime msec
    Router(config)#service timestamps log datetime msec
    Router(config)#end
    
  2. Inhabilite la consola de registro en su router DLS de Cisco para suprimir los mensajes de la consola que pueden ser accionados mientras que usted está configurando al router.

    Router#configure terminal
    Router(config)#no logging console
    Router(config)#end
    
  3. Configure el Routing IP, la subred cero del IP, y el IP sin clase para proporcionar la flexibilidad en las opciones de configuración de ruteo.

    Router#configure terminal
    Router(config)#ip routing
    Router(config)#ip subnet-zero
    Router(config)#ip classless
    Router(config)#end
    
  4. Configure una dirección IP y una máscara de subred en la interfaz de Ethernet del router DLS de Cisco.

    Para el NAT: Permiso (opcional) NAT dentro en la interfaz de Ethernet.

    Router#configure terminal
    Router(config)#interface ethernet 0
    Router(config-if)#ip address <ip address> <subnet mask>
    
    
    !--- For NAT:
    
    Router(config-if)#ip nat inside
    
    
    Router(config-if)#no shut
    Router(config-if)#end
    
  5. Configure la interfaz ATM de su router DLS de Cisco con un circuito virtual permanente (PVC), el tipo de encapsulación, y los recursos compartidos de dialers atmósfera.

    Router#configure terminal
    Router(config)#interface atm 0
    Router(config-if)#pvc <vpi/vci>
    Router(config-if-atm-vc)#encapsulation aal5mux ppp dialer
    Router(config-if-atm-vc)#dialer pool-member 1
    Router(config-if-atm-vc)#no shut
    Router(config-if-atm-vc)#end
    
  6. Configure la interfaz del dialer de su router DLS de Cisco para el protocolo Point-to-Point sobre la atmósfera (PPPoA) para habilitar un IP Address dinámico que se asignará.

    Para el NAT: (Opcional) habilite el NAT afuera en la interfaz del dialer.

    Router#configure terminal
    Router(config)#interface dialer 1
    Router(config-if)#ip address negotiated
    Router(config-if)#no ip directed-broadcast
    
    !--- For NAT:
     
    Router(config-if)#ip nat outside
    
    
    Router(config-if)#encapsulation ppp
    Router(config-if)#dialer pool 1  
    Router(config-if)#ppp chap hostname <username>
    Router(config-if)#ppp chap password <password>
    Router(config-if)#ppp pap sent-username <username> password <password>
    Router(config-if)#end
    
  7. Configure una ruta predeterminado usando el Dialer1 como la interfaz de salida.

    Router#configure terminal
    Router(config)#ip route 0.0.0.0 0.0.0.0 dialer1
    Router(config)#end
    
  8. Este paso está para el NAT: Configure los comandos nat globales en el router DLS de Cisco de permitir la distribución de la dirección IP de las públicas dinámicas de la interfaz del dialer.

    Router#configure terminal
    Router(config)#ip nat inside source list 1 interface dialer1 overload
    Router(config)#access-list 1 permit <ip network address of ethernet0> 
     <wildcard mask>
    Router(config)#end
    

    Configuraciones optativas

    Agrupamiento NAT, si los IP Addresses adicionales han sido proporcionados por su ISP.

    Router(config)#ip nat inside source list 1 interface dialer1 overload 
    Router(config)#ip nat pool <nat pool name> <first ip address> 
     <last ip address> netmask <subnet mask>
    Router(config)#end
    

    NAT estático, si los usuarios de Internet requieren el acceso a los servidores internos.

    Router(config)#ip nat inside source static tcp <inside ip address of server> 
     {80 or 25} <outside well-known ip address of server> {80 or 25} extendable
    Router(config)#end
    
  9. Para el DHCP: (Opcional) configure el router DLS de Cisco como servidor DHCP con un pool de los IP Addresses para asignar a los hosts conectados con la interfaz de Ethernet del router DLS de Cisco. El servidor DHCP asigna dinámicamente una dirección IP, el Domain Name Server (DNS), y el default gateway IP Address a sus hosts.

    Router#configure terminal
    Router(config)#ip dhcp excluded-address <ip address of ethernet0>
    Router(config)#ip dhcp pool <dhcp pool name>
    Router(dhcp-config)#network <ip network address of ethernet0> <subnet mask>  
    Router(dhcp-config)#default-router <ip address of ethernet0> 
    Router(dhcp-config)#dns-server <ip address of primary dns server> 
     <ip address of secondary dns server>
    Router(dhcp-config)#end
    
  10. Habilite la consola de registro en el router DLS de Cisco, y escriba todos los cambios a la memoria.

    Router#configure terminal
    Router(config)#logging console
    Router(config)#end
    *Jan 1 00:00:00.100: %SYS-5-CONFIG_I: Configured from console by console
    Router#write memory
    Building configuration... [OK]
    Router#

Configuración

Ésta es la configuración que resulta después de que usted complete los procedimientos en este documento.

Router DLS de Cisco con un IP Address dinámico

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
ip subnet-zero
!

!--- For DHCP:

ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server>
!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>
 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 pvc <vpi/vci>
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

!
interface dialer1
 ip address negotiated 
 no ip directed-broadcast

!--- For NAT:

 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp chap hostname <username> 
 ppp chap password <password> 
 ppp pap sent-username <username> password <password> 
!

!--- For NAT:

ip nat inside source list 1 interface dialer1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface dialer1 overload 


 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!---  netmask <subnet mask>



!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!---  <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless 
ip route 0.0.0.0 0.0.0.0 dialer1 

!--- For NAT:

access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network was 10.10.10.0, configuring 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 would allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

Verificación

Su router DLS de Cisco debe ahora ser operativo para el Digital Subscriber Line del Asymetric (ADSL) servicio. Usted puede publicar un comando show run para ver la configuración.

Router#show run
Building configuration...

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Troubleshooting

Si su servicio ADSL no trabaja correctamente, refiera al PPPoA del troubleshooting.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 71108