Ethernet de largo alcance (LRE) y Línea de suscriptor digital (xDSL) : Línea de suscriptor digital asimétrica (ADSL)

Guía de Configuración y Troubleshooting del Cisco DSL Router - Configuración gradual del IRB con un IP Address dinámico

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Su Proveedor de servicios de Internet (ISP) ha asignado una dirección IP de las públicas dinámicas a su router del Digital Subscriber Line (DSL) de Cisco.

Nota: Este ejemplo resalta dos tipos de configuraciones:

  • Servidor del Protocolo de configuración dinámica de host (DHCP)

  • Network Address Translation (NAT).

Importante: Antes de que usted comience, cierre todos los programas sobre el PC que pudo monitorear su puerto COM. Los dispositivos tales como PDA y cámaras digitales ponen a menudo los programas en la bandeja del sistema que hacen su puerto COM inutilizable para la configuración de su router DLS de Cisco.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Procedimientos de configuración

Conecte el router DLS de Cisco y su PC

Una conexión de consola se hace con un cable enrollado y conecta el puerto de la consola del router DLS de Cisco con un puerto COM en un PC. El cable de la consola que se incluye con el router DLS de Cisco es un cable azul claro plano. Para más información sobre las configuraciones del cable de un cable enrollado, o las configuraciones del cable de un RJ-45 al convertidor DB9, refiera al guía del cableado para la consola y los puertos auxiliares.

  1. Conecte el conector RJ-45 en un extremo de un cable de la consola de Cisco con el puerto de la consola del router DLS de Cisco.

  2. Conecte el conector RJ-45 en el otro extremo del cable de la consola con un RJ-45 con el convertidor DB9.

  3. Conecte el conector DB9 con un puerto COM abierto en su PC.

Comience y configure el hyperterminal

Complete estos pasos:

  1. Comience el programa del hyperterminal sobre el PC.

  2. Configure a su sesión HyperTerminal.

    1. Asigne un nombre a su sesión y haga clic la AUTORIZACIÓN.

    2. En la conexión con la ventana, haga clic la cancelación.

    3. Elija el File (Archivo) > Properties (Propiedades).

    4. De la ventana de pPropiedades, vaya a la conexión usando la lista y seleccione el puerto COM en donde usted conecta el extremo DB9 del cable de la consola.

    5. Del tecleo de la ventana de pPropiedades configure y complete estos valores:

      • Bits por segundo: 9600

      • Bits de datos: 8

      • Paridad: Ninguno

      • Bits de parada: 1

      • Control de Flujo: Ninguno

    6. Haga clic en OK.

    7. Del Call Menu, desconexión del tecleo.

    8. Del Call Menu, llamada del tecleo.

    9. Presione ENTER hasta que usted vea un prompt de router en su ventana HyperTerminal.

Borre las configuraciones existentes en el router DLS de Cisco

Complete estos pasos:

  1. Teclee enable en el prompt de router para ingresar al modo privilegiado.

    Router>enable
    Router#
    
    !--- The # symbol indicates that you are in privileged mode.
    
    
  2. Borre las configuraciones existentes en el router.

    Router#write erase
    
  3. Recargue al router de modo que inicie con una configuración de inicio en blanco.

    Router#reload
    System configuration has been modified. Save? [yes/no]:no
    Proceed with reload? [confirm]yes
    
    !--- The router reload can take a few minutes.
    
    
  4. Después de que el router haya recargado, ingrese el enable mode otra vez.

    Router>enable
    Router#

Configure al router DLS de Cisco

Complete estos pasos:

  1. Configure la indicación de fecha y hora de servicio para registrar y para visualizar correctamente la salida de los debugs en la sección de Troubleshooting.

    Router#configure terminal
    Router(config)#service timestamps debug datetime msec
    Router(config)#service timestamps log datetime msec
    Router(config)#end
    
  2. Inhabilite la consola de registro en su router DLS de Cisco para suprimir los mensajes de la consola que pudieron ser accionados mientras que usted configura al router.

    Router#configure terminal
    Router(config)#no logging console
    Router(config)#end
    
  3. Configure el Routing IP, la subred cero del IP, y el IP sin clase para proporcionar la flexibilidad en las opciones de configuración de ruteo.

    Router#configure terminal
    Router(config)#ip routing
    Router(config)#ip subnet-zero
    Router(config)#ip classless
    Router(config)#end
    
  4. Configure los Parámetros globales del Integrated Routing and Bridging (IRB).

    Router#configure terminal
    Router(config)#bridge irb
    Router(config)#bridge 1 protocol ieee
    Router(config)#bridge 1 route ip
    Router(config)#end
    
  5. Configure una dirección IP y a una máscara de subred en la interfaz de Ethernet del router DLS de Cisco.

    Para el NAT: Permiso (opcional) NAT dentro en la interfaz de Ethernet.

    Router#configure terminal
    Router(config)#interface ethernet 0
    Router(config-if)#ip address <ip address> <subnet mask>
    
    
    !--- For NAT:
    
    
    Router(config-if)#ip nat inside
    
    Router(config-if)#no shut
    Router(config-if)#end
    
  6. Configure la interfaz ATM de su router DLS de Cisco con un circuito virtual permanente (PVC), el tipo de encapsulación, y el Grupo de Bridge atmósfera.

    Router#configure terminal
    Router(config)#interface atm 0
    Router(config-if)#bridge-group 1
    Router(config-if)#pvc <vpi/vci>
    Router(config-if-atm-vc)#encapsulation aal5snap
    Router(config-if-atm-vc)#no shut
    Router(config-if-atm-vc)#end
    
  7. Cree y configure un (BVI) de la Interfaz Virtual Interconectada para habilitar un IP Address dinámico que se asignará a su router DLS de Cisco.

    Para el NAT: (Opcional) habilite el NAT afuera en la interfaz BVI.

    Router#configure terminal
    Router(config)#interface bvi 1
    Router(config-if)#mac address <address from line 2 of show interface bvi1>
    
    Router(config-if)#ip address dhcp client-id ethernet0
    Router(config-if)#no ip directed-broadcast
     
    
    !--- For NAT:
    
    
    Router(config-if)#ip nat outside
    
    Router(config-if)#end
    
  8. Configure una ruta predeterminado usando el default gateway ISP como el salto siguiente.

    Router#configure terminal
    Router(config)#ip route 0.0.0.0 0.0.0.0 <default gateway to isp>
    
    Router(config)#end
    
  9. Este paso está para el NAT — Configure los comandos nat globales en el router DLS de Cisco para permitir la distribución del IP Address público estático de la interfaz del dialer.

    Router#configure terminal
    Router(config)#ip nat inside source list 1 interface bvi1 overload
    Router(config)#access-list 1 permit <ip network address of ethernet0> 
    
     
    <wildcard mask>
    
    Router(config)#end
    

    Configuraciones optativas

    Agrupamiento NAT, si los IP Addresses adicionales han sido proporcionados por su ISP.

    Router(config)#ip nat inside source list 1 interface bvi1 overload 
    Router(config)#ip nat pool <nat pool name> <first ip address> 
     <last ip address> netmask <subnet mask>
    
    Router(config)#end
    

    NAT estático, si los usuarios de Internet requieren el acceso a los servidores internos.

    Router(config)#ip nat inside source static tcp <inside ip address of server> 
     {80 or 25} <outside well-known ip address of server> {80 or 25} extendable
    Router(config)#end
    
  10. Este paso está para el servidor DHCP — (opcional) configure al router DLS de Cisco como servidor DHCP con un pool de los IP Addresses para asignar a los host conectados con la interfaz de Ethernet del router DLS de Cisco. El servidor DHCP asigna dinámicamente una dirección IP, el Domain Name Server (DNS), y el default gateway IP Address a sus host.

    Router#configure terminal
    Router(config)#ip dhcp excluded-address <ip address of ethernet0>
    
    Router(config)#ip dhcp pool <dhcp pool name>
    
    Router(dhcp-config)#network <ip network address of ethernet0> <subnet mask>
      
    Router(dhcp-config)#default-router <ip address of ethernet0> 
    
    Router(dhcp-config)#dns-server <ip address of primary dns server> 
     <ip address of secondary dns server>
    
    Router(dhcp-config)#end
    
  11. Habilite la consola de registro en el router DLS de Cisco, y escriba todos los cambios a la memoria.

    Router#configure terminal
    Router(config)#logging console
    Router(config)#end
    *Jan 1 00:00:00.100: %SYS-5-CONFIG_I: Configured from console by console
    Router#write memory
    Building configuration... [OK]
    Router#

Configuración

Ésta es la configuración se construye que después de que usted haya completado los procedimientos en la sección de los Procedimientos de configuración de este documento.

Router DLS de Cisco con un IP Address dinámico

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
!
bridge irb
!
ip subnet-zero
!

!--- For the DHCP Server:


ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server>
!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>

!--- For NAT:


 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc <vpi/vci>
  encapsulation aal5snap
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
 bridge-group 1
!
interface bvi1
 mac-address <address from line 2 of show interface bvi1>
 ip address dhcp client-id ethernet0

!--- For NAT:


 ip nat outside
 no ip directed-broadcast
!

!--- For NAT:


ip nat inside source list 1 interface bvi1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface bvi1 overload 

 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!--- netmask <subnet mask>



!--- If Internet users require access to an internal server, you can 
!--- add these static NAT configuration statements:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!--- <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless 
ip route 0.0.0.0 0.0.0.0 <default gateway to isp>

!--- For NAT:


access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, the configuration of  
!--- access-list 1 permit 10.10.10.0 0.0.0.255 allows NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
bridge 1 protocol ieee
 bridge 1 route ip
!
end   

Verificación

Su router DLS de Cisco es operativo ahora para el servicio del Asymmetric Digital Subscriber Line (ADSL). Usted puede publicar un comando show run para ver la configuración.

Router#show run
Building configuration...

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Troubleshooting

Refiera al RFC1483 del troubleshooting que interliga con el IRB si su servicio ADSL no trabaja correctamente.

Vuelva a la página previa de este guía de Configuración y Troubleshooting - IRB con un IP Address dinámico.

Vuelva a la página principal de la guía de Configuración y Troubleshooting del Cisco DSL Router.


Información Relacionada


Document ID: 71101