Ethernet de largo alcance (LRE) y Línea de suscriptor digital (xDSL) : Línea de suscriptor digital asimétrica (ADSL)

Guía de Configuración y Troubleshooting del Cisco DSL Router - IRB con un IP Address dinámico

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Su Proveedor de servicios de Internet (ISP) ha asignado una dirección IP de las públicas dinámicas a su router del Digital Subscriber Line (DSL) de Cisco.

Consejo: Si usted no es familiar con cómo configurar los dispositivos de Cisco y quisiera seguir una configuración gradual, refiera a la configuración gradual del IRB con un IP Address dinámico.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Tareas de realizarse

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Nota: Este ejemplo resalta dos tipos de configuraciones:

  • Servidor del Protocolo de configuración dinámica de host (DHCP)

  • Network Address Translation (NAT).

Tareas:

  • Diseñe un esquema de IP Addressing para su LAN privado.

  • Configure una dirección IP y una máscara de subred en la interfaz de Ethernet del router DLS de Cisco.

  • Configure la interfaz ATM (Digital Subscriber Line del Asymetric (ADSL) interfaz) del router DLS de Cisco con un circuito virtual permanente (PVC) y la encapsulación atmósfera.

  • Habilite el Integrated Routing and Bridging (IRB).

  • Cree y configure la interfaz del (BVI) del Interfaz Virtual de Bridge Group del router DLS de Cisco para el IRB con una dirección IP negociada.

  • (Para el NAT) — Configure el NAT en el router DLS de Cisco para permitir la distribución de la dirección IP de las públicas dinámicas de la interfaz BVI.

    • Opcional: Agrupamiento NAT, si los IP Addresses adicionales han sido proporcionados por su ISP.

    • Opcional: NAT estático, si los usuarios de Internet requieren el acceso a los servidores internos.

  • Configure cada host PC con una dirección IP, una máscara de subred, un default gateway, y un servidor del Domain Name System (DNS).

    (Para el servidor DHCP) — Alternativamente, si usted quisiera que el router DLS de Cisco asignara los IP Address dinámicos de sus clientes PC, configure cada PC para obtener una dirección IP y los servidores DNS automáticamente vía el DHCP.

Configuración

Consejo: Si usted no es familiar con cómo configurar los dispositivos de Cisco y quisiera seguir una configuración gradual, refiera a la configuración gradual del IRB con un IP Address dinámico.

Router DLS de Cisco con un IP Address dinámico

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
!
bridge irb
!
ip subnet-zero
!

!--- For the DHCP Server:


ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server>
!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>

!--- For NAT:


 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc <vpi/vci>
  encapsulation aal5snap
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
 bridge-group 1
!
interface bvi1
 mac-address <address from line 2 of show interface bvi1>
 ip address dhcp client-id ethernet0

!--- For NAT:


 ip nat outside
 no ip directed-broadcast
!

!--- For NAT:


ip nat inside source list 1 interface bvi1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface bvi1 overload 

 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!---  netmask <subnet mask>



!--- If Internet users require access to an internal server, you can 
!--- add these static NAT configuration statements:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!--- <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless 
ip route 0.0.0.0 0.0.0.0 <default gateway to isp>

!--- For NAT:


access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, the configuration of  
!--- access-list 1 permit 10.10.10.0 0.0.0.255 allows NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
bridge 1 protocol ieee
 bridge 1 route ip
!
end  

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Refiera al RFC1483 del troubleshooting que interliga con el IRB si su servicio ADSL no trabaja correctamente.

Vuelva a las páginas previas de esta guía de Configuración y Troubleshooting - RFC1483 que interliga con la opción de implementación IRB.

Vuelva a las páginas principales de la guía de Configuración y Troubleshooting del Cisco DSL Router.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 71100