Tecnología inalámbrica / Movilidad : LAN inalámbrica (WLAN)

Ejemplos de configuración del módulo del regulador del Wireless LAN (WLCM)

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (20 Diciembre 2015) | Comentarios


Contenido


Introducción

El módulo Cisco WLAN Controller (WLC) (WLCM) permite a los Cisco ISR y routers Cisco 3700 Series administrar hasta seis puntos de acceso (AP) de LAN inalámbricos (WLAN) y simplificar la implementación y gestión de las WLAN. Es equivalente a un Cisco WLC 2006 en un factor de forma NM. La única diferencia es que el NM-WLC (módulo WLCM) tiene solamente un puerto Fast Ethernet conectado internamente al router del host y el puerto Fast Ethernet externo de la placa frontal NM está inhabilitado e inutilizable. Este documento explica cómo configurar el WLCM para diversos escenarios.

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • Conocimientos básicos de Lightweight Access Point Protocol (LWAPP)

  • Conocimiento básico del WLC y de los AP ligeros (revestimientos)

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configuración Básica

Piense en el NM-WLC como WLC externo (2006) con solamente una interfaz del Fast Ethernet (FE) (conocida como puerto 1) conectado internamente con la interfaz Fast Ethernet de un router nombró la interfaz del controlador de WLAN. Este diagrama muestra un ejemplo.

Nota: El puerto FastEthernet externo en la placa frontal del módulo del WLC de Cisco no se soporta.

/image/gif/paws/70530/nm-wlc-config-guide-1.gif

La manera habitual de conectar con el módulo está internamente dentro del router con el comando session del módulo de servicio.

  1. Inserte el módulo NM-WLC sobre el router y el inicio encima del router con una imagen válida.

    Cualquier imagen (del ipbase a adventerprisek9) puede soportar el módulo NM-WLC. Esta característica fue introducida con el Cisco IOS Software Release 12.4(2)XA1 (software del router). La versión mínima del firmware del controlador debe ser 3.2.78.0 (software del regulador).

  2. Configure una dirección IP en el WLAN-regulador 1/0 de la interfaz; si se asume que el módulo está conectado en el slot1 del router. Realice un ningún cerrado si está en el estado de cierre normal.

    c2811#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    c2811(config)#
    c2811(config)#interface wlan-controller 1/0
    c2811(config-if)#ip address 192.168.99.254 255.255.255.0
    c2811(config-if)#no shut
    c2811(config-if)#end
    c2811#
  3. Del prompt exec privilegiado, abra una sesión en el regulador que usa el comando session del módulo de servicio.

    c2811#service-module wlan-controller 1/0 session 
    Trying 192.168.99.254, 2066 ... Open

    Nota: Los comandos cisco ios para el módulo del theWLCM varían en el router que ejecuta el Software Cisco IOS versión 12.4(15)T o más adelante. Refiera a configurar Cisco WLCM en el router para más información.

Si el regulador se trae para arriba por primera vez sin la configuración anterior, ingresa automáticamente en un Asisitente CLI que le pida una serie de información de la configuración. Este Asisitente no puede ser desviado y usted debe ingresar toda la información que pide. Entendiendo de antemano cómo usted quisiera que sus configuraciones miraran cuando las ayudas completadas contestan a las preguntas. Algo de la información que pide no es relevante y utilizada inmediatamente pero usted todavía necesita suministrarlo porque no valida la entrada inválida y usted también no puede desviar. La salida aparece similar a la salida en esta tabla:

Regulador de Cisco
Welcome to the Cisco Wizard Configuration Tool
Use the '-' character to backup
System Name [Cisco_ff:f6:a0]: NMWLC
Enter Administrative User Name (24 characters max): admin
Enter Administrative Password (24 characters max): *****
 
Management Interface IP Address: 192.168.99.24
Management Interface Netmask: 255.255.255.0
Management Interface Default Router: 192.168.99.254 
Management Interface VLAN Identifier (0 = untagged): 0
Management Interface Port Num [1]: 1
Management Interface DHCP Server IP Address: 192.168.99.24
 
AP Manager Interface IP Address: 192.168.99.25
 
AP-Manager is on Management subnet, using same values
AP Manager Interface DHCP Server (192.168.99.24): 192.168.99.24
 
Virtual Gateway IP Address: 1.1.1.1
 
Mobility/RF Group Name: mg1
 
Network Name (SSID): wl15
Allow Static IP Addresses [YES][no]: no
 
Configure a RADIUS Server now? [YES][no]: no
Warning! The default WLAN security policy requires a RADIUS server.
Please see documentation for more details.
 
Enter Country Code (enter 'help' for a list of countries) [US]: US
 
Enable 802.11b Network [YES][no]: YES
Enable 802.11a Network [YES][no]: YES
Enable 802.11g Network [YES][no]: YES
Enable Auto-RF [YES][no]: no
Configuration saved!
Resetting system with new configuration...

Una vez que la configuración es completa, reinicia automáticamente con la nueva configuración y para en el usuario: indique donde usted suministra un nombre de usuario y contraseña. (Regulador de Cisco) > el prompt entonces aparece.

User:admin
Password:*****
(Cisco Controller) >

Una vez que usted está en el prompt del regulador, usted puede hacer configuraciones o modificaciones más futuras de lo que usted hizo a través del Asisitente CLI. ¿Utilice? para obtener ayuda.

Para volver al router, presione ctrl+shift+6, libere, y después presione el X. Esto le lleva al prompt de router. Sigue habiendo la sesión intacto, así que si usted Presione ENTER, él le toma de nuevo al regulador. Si usted quiere totalmente claro la sesión, ingrese la desconexión en el prompt de router.

Aunque el regulador tiene solamente un puerto físico (designado el puerto 1), usted puede crear cualquier número de interfaces lógicas en él, estático o dinámico, y esas interfaces pueden ser VLA N-marcadas con etiqueta o untagged. Por abandono, el regulador tiene dos estáticos y interfaces untagged:

  • Interfaz de administración

  • Interfaz del AP manager

La interfaz de administración se utiliza para los fines de administración. Si usted elige utilizar una interfaz GUI basada en web para manejar el WLCM, usted necesita configurar la dirección IP en la interfaz de administración y hacer eso accesible del puesto de trabajo que usted planea manejarlo de.

Nota: Por abandono, inhabilitan al servidor HTTP en el regulador pero se habilita el HTTP seguro. Por lo tanto, el URL al IP Address de administración del regulador debe ser https://mgt-ip-address.

La interfaz del AP manager es utilizada por el regulador para hablar con los revestimientos. Puesto que la Administración y las interfaces del AP manager son untagged, deben estar en la misma subred IP que el WLC de la interfaz en el router.

(Cisco Controller) >config
(Cisco Controller) config>interface address management 
                           192.168.99.24 255.255.255.0 192.168.99.254
(Cisco Controller) config>interface address ap-manager 
                           192.168.99.25 255.255.255.0 192.168.99.254

Usted puede configurar el CLI de dos maneras. Uno es del prompt normal precediendo el CLI con los config. El otro método es ir al prompt de los config con el comando config y después publicar los CLI sin los config de la palabra. Por ejemplo:

 (Cisco Controller) >config
(Cisco Controller) config>interface address management 
                           192.168.99.24 255.255.255.0 192.168.99.254

o

(Cisco Controller)>config interface address management 
                        192.168.99.24 255.255.255.0 192.168.99.254

Este ejemplo configura la interfaz de administración con la dirección IP 192.168.99.24/24 y define el default gateway como 192.168.99.254.

Nota: El default gateway en la Administración y la Administración AP debe señalar a la dirección IP del acceso de Ethernet WLCM.

Nota: Una vez que usted configura estos IP Addresses vía el Asisitente entonces usted no necesita estos comandos. Éste es apenas mostrarle que estos IP Addresses pertenecen a la misma subred y esto se puede también configurar vía la línea de comando.

En ambos casos, la dirección IP más reciente (192.168.99.254) es el default gateway IP Address. Puesto que la única salida del regulador está vía el router del host, el default gateway debe ser la dirección IP de la interfaz wlan-controller1/0 en el router. Con esta mucha configuración, usted puede hacer ping del router a la dirección IP de la interfaz de administración del regulador.

c2811#ping 192.168.99.24
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.99.24, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
c2811# 

Ejemplo 1 - La configuración básica con un AP conectó con un router a bordo de los fast ethernet/de Gigabit Ethernet

Cuando un REVESTIMIENTO conectado con la interfaz de Ethernet Gigabite a bordo (g0/0) de un router se acciona encendido, envía un pedido de DHCP para una dirección IP. En este ejemplo, configuran al router como servidor DHCP con el pool de la dirección IP de la red 192.168.100.0/24. Así pues, el REVESTIMIENTO consigue una dirección IP de 192.168.100.101. La oferta de DHCP también dice el REVESTIMIENTO (vía la opción 43) que la dirección IP del regulador es 192.168.99.24 (el IP Address de administración del regulador). El REVESTIMIENTO ahora envía un regulador el unicast del mensaje de detección a 192.168.99.24. El regulador ofrece el registro y como consecuencia, el REVESTIMIENTO se registra con el regulador.

Utilice el comando show ap summary para ver el REVESTIMIENTO que se registra con el WLCM.

(Cisco Controller) >show ap summary

AP Name             Slots  AP Type    MAC Addr           Location          Port
------------------  -----  ---------  -----------------  ---------------- 	----
AP11                 2     Cisco      00:0b:85:01:03:30                   	1

En este ejemplo, el regulador se configura con dos WLAN (wl15 y wl16) según lo descrito más adelante en el documento.

El c1 del cliente envía una petición de la asociación con SSID wl15. Asocia y consigue una dirección IP de 192.168.15.101 y un default gateway de 192.168.15.1 del servidor DHCP configurado en el router.

El cliente C2 también envía una petición de la asociación con SSID wl16. Asocia y consigue una dirección IP de 192.168.16.101 y un default gateway de 192.168.16.1. Ahora hay dos clientes en dos diversas subredes. La comunicación entre ellas es posible mediante un router que realice la encaminamiento entre sus dos subinterfaces (wlc1/0.15 y wlc1/0.16) como este diagrama muestra:

La configuración requerida en los dispositivos para esta configuración se discute en la sección de configuración de controlador de este documento.

/image/gif/paws/70530/nm-wlc-config-guide-2.gif

Configuración de controlador

Esta sección discute la configuración requerida en el módulo del regulador.

  1. Cree dos interfaces dinámicas nombradas vl15 en el VLAN15 y vl16 en el VLA N 16.

    (Cisco Controller) >config interface create vl15 15
    (Cisco Controller) >config interface create vl16 16
    
  2. Asigne la dirección IP, el netmask, y el default gateway para estas interfaces VLAN.

    (Cisco Controller) >config interface address vl15 
                                  192.168.15.254 255.255.255.0 192.168.15.1
    
    (Cisco Controller) >config interface address vl16 
                                  192.168.16.254 255.255.255.0 192.168.16.1
    

    Nota: El default gateway para las interfaces dinámicas debe ser la dirección IP de la sub-interfaz en el router para el VLAN correspondiente.

  3. Cree dos WLAN 15 y 16 con SSID correspondientes wl15 y wl16.

    (Cisco Controller) >wlan create 15 wl15
    (Cisco Controller) >wlan create 16 wl16
    
  4. Ate estos WLAN con las interfaces VLAN correspondientes que usted creó (en la cara tela).

    (Cisco Controller) >wlan interface 15 vl15
    (Cisco Controller) >wlan interface 16 vl16
    
  5. Configure las interfaces dinámicas que usted creó con un IP Address del servidor DHCP para remitir los pedidos de DHCP del cliente a.

    Puesto que configuran al servidor DHCP en el router, debe señalar a los IP Addresses correspondientes de la sub-interfaz del router. Si usted tiene un servidor DHCP externo, después debe señalar a esa dirección IP.

    (Cisco Controller) >interface dhcp vl15 192.168.15.1
    (Cisco Controller) >interface dhcp vl16 192.168.16.1
    
  6. Por abandono, el método de autentificación es dot1x y se habilita. Para trabajar con la autenticación abierta, inhabilitela con este comando para ambos WLAN:

    (Cisco Controller) >wlan security 802.1X disable 15
    (Cisco Controller) >wlan security 802.1X disable 16
    

Esta configuración se puede ampliar basó en sus necesidades tales como más VLA N/WLAN, autenticación ([LEAP] del protocolo lightweight extensible authentication, EAP), QoS, y así sucesivamente.

Nota: Con WLCM, es difícil que un REVESTIMIENTO descubra el WLCM con el broadcast de la subred IP. Esto está debido a la manera que el WLCM integra en el backplane y el REVESTIMIENTO y la interfaz Gigabit del 2800 Router que está conectado directamente con el REVESTIMIENTO necesita ser la misma subred. Si usted quiere realizar la detección del broadcast de la subred IP con el éxito, utilice los comandos UDP 12223 del delantero-protocolo del IP helper-address/ip. El propósito de estos comandos es generalmente remitir/retransmisión potencialmente cualquier trama del broadcast IP. Simplemente la retransmisión y la dirección de él a la interfaz de administración del WLC deben ser adecuadas conseguir el WLC para responder de nuevo al REVESTIMIENTO.

Nota: Todas las configuraciones de controlador en esta sección se pueden hacer fácilmente con el acceso a GUI vía un buscador Web una vez que la interfaz de administración se configura con una dirección IP, el netmask, y la información del gateway. También, cualquier encaminamiento requerida en la red para que sus estaciones del navegador puedan alcanzar el regulador se hace. El URL para abrir la página GUI es https://192.168.99.24.

Configuración del router

Complete estos pasos para configurar al router para puesto esta sección describe.

  1. Configure la interfaz G0/0 en el router que está conectada con el REVESTIMIENTO.

  2. Configure el WLAN-regulador 1/0 de la interfaz con una dirección IP de las 192.168.99.0/24 redes y los subinterfaces w1/0.15 en el VLAN15 y w1/0.16 en el VLA N 16 con los IP Addresses de las redes 192.168.15.0/24 y 192.168.16.0/24.

  3. Configure a un servidor DHCP en el router con varios pools definidos.

    • El pool lwapp-ap asigna una dirección IP al AP de la red 192.168.100.0/24 que también incluye la opción DHCP 43 que informa al AP la dirección IP del regulador para entrar en contacto.

    • El pool client-15 asigna una dirección IP a los clientes (atados con alambre/Tecnología inalámbrica) en el VLAN15 de la red 192.168.15.0/24.

    • El pool client-16 asigna una dirección IP a los clientes (atados con alambre/Tecnología inalámbrica) en el VLA N 16 de la red 192.168.16.0/24.

Esta salida muestra la configuración en el router:

Router
!		
interface GigabitEthernet0/0								
Description: Connected to AP							
 ip address 192.168.100.1 255.255.255.0						
 load-interval 30									
 duplex auto									
 speed auto
									
!										
ip dhcp excluded-address 192.168.100.1 192.168.100.100
!
ip dhcp pool lwapp-ap

!--- Creates a DHCP pool for the LAP.

network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15

!--- Creates a DHCP pool for users that connect to WLAN wl15.

network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16

!--- Creates a DHCP pool for users that connect to WLAN wl16.

network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!										
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15

!--- Creates a sub-interface for VLAN 15.
						
encapsulation Dot1q 15								
ip address 192.168.15.1 255.255.255.0							
!										
interface wlan-controller 1/0.16

!--- Creates a sub-interface for VLAN 16.
					
encapsulation Dot1q 16								
ip address 192.168.16.1 255.255.255.0							
!

Ejemplo 2 - Configuraciones de VLAN con los AP conectados con un switch externo

El WLCM conectado en el router se puede lógicamente considerar equivalente a un WLC externo conectado con el router vía una interfaz de Ethernet mientras que este diagrama muestra. Con la suposición que el módulo de red está conectado en el slot1 del router, la Conectividad típica consiste en:

  • Un WLCM conectado con el router a través del WLAN-regulador 1/0 de la interfaz.

  • Un 2 Switch de la capa conectado con la interfaz de Ethernet Gigabite a bordo G0/0 del Routers.

  • Un protocolo ligero AP (LWAPP) AP conectado con el Switch.

  • C1 de los clientes de red inalámbrica y C2 asociados al AP, a uno en la red inalámbrica (WLAN) 15 y al otro en la red inalámbrica (WLAN) 16.

Este ejemplo muestra cómo dos VLAN inalámbricos o WLAN (wl15 y wl16) se crean en el regulador, asociado al VLAN15 y al VLA N correspondientes 16 de la cara tela, y cómo el rutear entre el VLAN15 y el VLA N 16 es hecho por el router a través de los subinterfaces del dot1q.

En el router, cree una sub-interfaz bajo interfaz del WLC (en el modo de configuración de la interfaz) para cada VLA N, asígnela al VLAN correspondiente, y configure la dirección IP de las subredes correspondientes.

Vea la sección de configuración de controlador de este documento para las configuraciones requeridas en los dispositivos para esta configuración.

/image/gif/paws/70530/nm-wlc-config-guide-3.gif

Configuración de controlador

Complete estos pasos en el módulo del regulador para esta configuración.

  1. En el regulador, para cada VLA N, cree una interfaz dinámica en el VLAN correspondiente y asigne una dirección IP, el netmask, y los default gatewayes de las subredes correspondientes.

    (Cisco Controller)#configure interface create vl15 15
    (Cisco Controller)#configure interface create vl16 16
    
    (Cisco Controller)#configure interface address 
                      Vl15 192.168.15.254 255.255.255.0 192.168.15.1
    (Cisco Controller)#configure interface address 
                      Vl16 192.168.16.254 255.255.255.0 192.168.16.1
    
  2. Cree dos WLAN 15 y 16 con SSID correspondientes wl15 y wl16.

    (Cisco Controller)#configure wlan create 15 wl15
    (Cisco Controller)#configure wlan create 16 wl16
    
  3. Ate estos WLAN con las interfaces VLAN correspondientes que usted creó (en la cara tela).

    (Cisco Controller)#configure wlan interface 15 Vl15
    (Cisco Controller)#configure wlan interface 16 Vl16
    
  4. Configure la información del servidor DHCP sobre las interfaces de los reguladores (para los clientes de red inalámbrica) esa punta a los IP Addresses respectivos de la sub-interfaz en el router.

    (Cisco Controller)#configure interface dhcp vl15 192.168.15.1
    (Cisco Controller)#configure interface dhcp Vl16 192.168.16.1
    

Con estas configuraciones, los dos clientes de red inalámbrica en dos WLAN deben ser en servicio, con la suposición que la Configuración de seguridad apropiada también está hecha. El tráfico del cliente en la red inalámbrica (WLAN) 15 destinado al cliente en la red inalámbrica (WLAN) 16 se rutea entre los subinterfaces w1/0.15 y w1/0.16 en el router. Las mismas configuraciones pueden ser extendidas para cualquier número de VLA N hasta el número máximo de VLA N soportados para el regulador (16).

Configuración del switch

Con la suposición que todos los clientes atados con alambre están conectados con el Switch (por ejemplo, cat3750) que es trunked al router a través del carruaje 1/0/1 de la interfaz para la encaminamiento inter-LAN, conecte el LWAPP AP en la interfaz F1/0/1 en el Switch y configurelo para el VLAN 100.

Interface Fastethernet 1/0/1
Description: Connected to LWAPP AP
Switchport access vlan 100
Switchport mode access
!
Interface Gigabitethernet 1/0/1
Description: Connected to Router
Switchport trunk encapsulation dot1Q
Switchport mode trunk

Configuración del router

Complete estos pasos en el router.

  1. Configure la interfaz G0/0 que está conectada con el Switch y también los subinterfaces requeridos para el Routing entre VLAN para el LAN cableado.

  2. Configure el WLAN-regulador 1/0 de la interfaz con una dirección IP de las 192.168.99.0/24 redes y los subinterfaces w1/0.15 en el VLAN15 y w1/0.16 en el VLA N 16 con los IP Addresses de las redes 192.168.15.0/24 y 192.168.16.0/24.

  3. Configure a un servidor DHCP en el router con varios pools definidos.

    • El pool lwapp-ap asigna una dirección IP al AP de la red 192.168.100.0/24 que también incluye la opción DHCP 43 que informa al AP la dirección IP del regulador para entrar en contacto.

    • El pool client-15 asigna una dirección IP a los clientes (atados con alambre/Tecnología inalámbrica) en el VLAN15 de la red 192.168.15.0/24.

    • El pool client-16 asigna una dirección IP a los clientes (atados con alambre/Tecnología inalámbrica) en el VLA N 16 de la red 192.168.16.0/24.

    Nota: Las agrupaciones distintas son necesarias para los AP y los clientes.

Router
ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
								
ip dhcp pool client-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 

ip dhcp pool client-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!
interface GigabitEthernet0/0
Description: Connected to AP
No ip address							
 load-interval 30									
 duplex auto									
 speed auto
!
interface GigabitEthernet0/0.100
encapsulation dot1Q 100
ip address 192.168.100.1 255.255.255.0	
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
ip address 192.168.15.1 255.255.255.0							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
ip address 192.168.16.1 255.255.255.0

Nota: Usted puede también dirigir los servicios del DHCP para los clientes en el regulador. Pero se recomienda para ejecutarse en el router pues el regulador no es servidor DHCP hecho y derecho y no puede pasar encendido las opciones como el servidor TFTP requerido para las aplicaciones como el Cisco CallManager expreso.

Con esta configuración, el AP puede conseguir la dirección IP, encontrar, y registrarse con el regulador. Dos c1 de los clientes de red inalámbrica y C2 deben poder asociarse al AP y conseguir la dirección IP de las subredes correspondientes.

Ejemplo 3 - Configuraciones con los AP conectados con un EtherSwitch en el router y los VLAN correspondientes de la combinación de atado con alambre y Tecnología inalámbrica LAN

En este escenario, hay un EtherSwitch HWIC conectado en el slot0 ISR HWIC y un NM-WLC conectado en el c3 atado con alambre del cliente del slot 1. NM está conectado para interconectar F0/0/1 en el VLAN15 con una dirección IP de 192.168.15.102 y el cliente atado con alambre C4 está conectado con F0/0/2 en el VLA N 16 con una dirección IP de 192.168.16.102.

El LWAPP AP está conectado para interconectar F0/0/0 en el VLAN 100 con una dirección IP de 192.168.100.1. Configuran al router como servidor DHCP para servir una dirección IP al AP. Por ejemplo, un AP recibe una dirección IP de 192.168.100.101, un default gateway de 192.168.100.1 y una dirección IP del regulador de 192.168.99.24 vía la opción 43.

Nota: La configuración requerida en el regulador es similar a la configuración explicada en el ejemplo anterior y no se discute aquí. Las secciones restantes proporcionan la configuración requerida en el router.

/image/gif/paws/70530/nm-wlc-config-guide-4.gif

El c1 de los clientes de red inalámbrica y el C2 se asocian al REVESTIMIENTO en wl15 y wl16 respectivamente. El c1 de los clientes de red inalámbrica y el C2 también consiguen una dirección IP de 192.168.15.101 y de 192.168.16.101 asignados por el servidor DHCP configurado en el router o un servidor DHCP externo con las agrupaciones IP para esas subredes. Si el servidor DHCP es externo, el IP Helper Address se debe configurar en el VLAN correspondiente y los subinterfaces. Desde la perspectiva del router, hace dos VLA N atados con alambre representar por el VLAN15 de la interfaz y los VLAN inalámbricos del VLA N 16 y dos de la interfaz representados por los subinterfaces w1/0.15 y w1/0.16 del dot1q bajo el WLC interconectan en el router.

Para derrumbarse el VLAN15 atado con alambre y la red inalámbrica (WLAN) inalámbrica 15 junto, configure el VLAN15 de la interfaz e interconecte w1/0.15 bajo Grupo de Bridge común, por ejemplo, el bridge-group 15. Semejantemente, para derrumbarse VLA N atado con alambre 16 y red inalámbrica (WLAN) inalámbrica 16, VLA N 16 de la interfaz de la configuración y interfaz w1/0.16 bajo Grupo de Bridge común, por ejemplo, bridge-group 16. Con esta configuración, la correspondencia atada con alambre y los VLAN inalámbricos pertenecen a las mismas subredes IP 192.168.15.0/24 y 192.168.16.0/24 y pueden hablar el uno al otro dentro del Grupo de Bridge. Pero para que los clientes en dos diversos Grupos de Bridge a comunicar el uno al otro, Integrated Routing and Bridging (IRB) del permiso en el router de modo que comuniquen vía las interfaces BVI en los Grupos de Bridge respectivos.

Nota: Esta configuración se basa en la suposición que usted tiene EtherSwitch HWIC o NM-ESW en el router para el LAN cableado. Si usted tiene el módulo de servicio del EtherSwitch (NME-ESW) en vez del NM/HWIC, las interfaces VLAN son substituidas por los subinterfaces correspondientes del dot1q bajo interfaz de Ethernet Gigabite en el router y el resto de la configuración sigue siendo lo mismo.

Configuración del router
!

ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp excluded-address 192.168.15.1 192.168.15.100
ip dhcp excluded-address 192.168.16.1 192.168.16.100
!
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 


interface FastEthernet0/0/0								
Description: Connected to AP
Switchport mode access
Switchport access vlan 100
!
interface FastEthernet0/0/1								
Description: Connected to C3
Switchport mode access
Switchport access vlan 15
!
interface FastEthernet0/0/2								
Description: Connected to C4
Switchport mode access
Switchport access vlan 16
!
Interface vlan 15
Bridge-group 15
!
Interface vlan 16
Bridge-group 16

Interface vlan 100							
 ip address 192.168.100.1 255.255.255.0						
 load-interval 30									
 !
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
bridge-group 15							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
bridge-group 16									
!										
Bridge irb
Bridge 15 route ip
Bridge 15 protocol ieee
Bridge 16 route ip
Bridge 16 protocol ieee

Interface bvi 15
Ip address 192.168.15.1 255.255.255.0
!
Interface bvi 16
Ip address 192.168.16.1 255.255.255.0

Ejemplo 4 - Las configuraciones con los VLA N atados con alambre bajo NME-ESW se combinaron con los VLAN inalámbricos bajo NM-WLC

Considere este escenario donde usted tiene un módulo de servicio del EtherSwitch (NME-ESW) conectado en el slot 2 y un NM-WLC ISR NM conectado en el slot1 NM. El NME-ESW se puede considerar equivalente a un switch externo conectado con el router a través de un link Gigabit Ethernet. El c3 atado con alambre del cliente está conectado para interconectar F0/0/1 en el VLAN15 con la dirección IP 192.168.15.102 y el cliente atado con alambre C4 conectados con F0/0/2 en el VLA N 16 con la dirección IP 192.168.16.102

El LWAPP AP está conectado para interconectar F0/0/3 en el VLAN 100. La interfaz interna del EtherSwitch (G1/0/2) internamente está conectada con el router del host con la interfaz Gigabit Ethernet 2/0. Puesto que hay más de un VLA N en el Switch, el link interno entre el Switch y el router se debe configurar como trunk. Configuran al router como un servidor DHCP con varios pools para servir la dirección IP al AP y a los clientes (atados con alambre y Tecnología inalámbrica).

El AP consigue una dirección IP de 192.168.100.101, un default gateway de 192.168.100.1 y una dirección IP del regulador de 192.168.99.24 vía la opción 43, y los descubre y se registra con el regulador. El c1 de los clientes de red inalámbrica y el C2 se asocian al REVESTIMIENTO en la red inalámbrica (WLAN) 15 y 16 y consiguen la dirección IP 192.168.15.101 y 192.168.16.101 respectivamente. El c3 de los clientes y los C4 en el VLAN15 y los 16 atados con alambre también consiguen una dirección IP de 192.168.15.102 y de 192.168.16.102 del servidor DHCP.

Para combinarse ató con alambre el VLAN15 con la red inalámbrica (WLAN) inalámbrica 15, configuran las interfaces G2/0.15 e interconectan w1/0.15 bajo Grupo de Bridge común 15. Semejantemente, interfaces inferiores G2/0.16 del Grupo de Bridge 16 y W1/0.16. Los dos Grupos de Bridge comunican el uno al otro a través de sus interfaces BVI BVI15 y BVI16.

La configuración de controlador sigue siendo lo mismo que en los escenarios anteriores.

/image/gif/paws/70530/nm-wlc-config-guide-5.gif

Configuración del router

Configuración del router
!

ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp excluded-address 192.168.15.1 192.168.15.100
ip dhcp excluded-address 192.168.16.1 192.168.16.100
!
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!
interface GigabitEthernet2/0								
Description: Internally connected to Etherswitch
IP address 20.0.0.1 255.255.255.0
load-interval 30
!
Interface GigabitEthernet2/0.100
Encapsulation dot1Q 100							
 ip address 192.168.100.1 255.255.255.0						

Interface GigabitEthernet2/0.15
Encapsulation dot1Q 15							
 Bridge-group 15
!
Interface GigabitEthernet2/0.16
Encapsulation dot1Q 16							
Bridge-group 16									
 !
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
bridge-group 15							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
bridge-group 16									
!										
Bridge irb
Bridge 15 route ip
Bridge 15 protocol ieee
Bridge 16 route ip
Bridge 16 protocol ieee

Interface bvi 15
Ip address 192.168.15.1 255.255.255.0
!
Interface bvi 16
Ip address 192.168.16.1 255.255.255.0

Configuración del switch

Abra una sesión del router en el módulo de servicio del EtherSwitch con el comando session del módulo de servicio. Una vez en el Switch, configure el Switch como esta salida muestra:

!
Interface GigabitEthernet 1/0/2
Description: Internally connected to router G2/0 interface.
Switchport trunk encapsulation dot1Q
Switchport mode trunk

!
Interface Fastethernet 0/0/1
Description: Connected to Client C3 in vlan 15
Switchport access vlan 15
Switchport mode access
!
Interface Fastethernet 0/0/2
Description: Connected to Client C4 in vlan 16
Switchport access vlan 16
Switchport mode access
!
Interface Fastethernet 0/0/3
Description: Connected to Client LWAPP AP in vlan 100
Switchport access vlan 100
Switchport mode access

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 70530