Tecnología inalámbrica / Movilidad : VLAN inalámbrica

Ejemplo de Configuración de VLANs en Controladores de LAN Inalámbrica

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe cómo configurar las VLAN en controladores de LAN inalámbricos (WLC).

prerrequisitos

Requisitos

No hay requisitos específicos para este documento. Sin embargo, este documento asume que hay servidor DHCP de trabajo para proporcionar los IP Addresses al (APS) de los Puntos de acceso que se registra al regulador.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Configuración A:

    • Switch de Catalyst que funciona con el software del½ del¿Â del Cisco IOSï y un controlador de WLAN

    • Controlador de WLAN de Cisco 4404 que funciona con la versión de software 7.0

  • Configuración B:

    • Switch de Catalyst que funciona con el software del Catalyst OS (CatOS) y un controlador de WLAN

    • Controlador de WLAN de Cisco 4404 que funciona con la versión de software 7.0

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Interfaces dinámicas en el WLCs

Las interfaces dinámicas, también conocidas como interfaces VLAN, son creadas por los usuarios y diseñadas para ser análogas a los VLA N para los clientes del Wireless LAN. Un regulador puede soportar hasta 512 interfaces dinámicas (VLA N). Cada interfaz dinámica se configura y permite individualmente que las secuencias separadas de la comunicación existan en el cualquiera o todo el de los puertos del sistema de distribución del regulador. Cada VLA N de los controles de interfaz dinámica y otras comunicaciones entre los reguladores y los dispositivos de la cualquier otra red, y cada uno actúa como relé DHCP para los clientes de red inalámbrica asociados a los WLAN asociados a la interfaz. Usted puede asignar las interfaces dinámicas a los puertos del sistema de distribución, los WLAN, la interfaz de administración de la capa 2, y la interfaz del AP manager de la capa 3. Usted puede también asociar la interfaz dinámica a un puerto de backup.

Usted puede configurar cero, uno, o las interfaces dinámicas múltiples en un sistema de distribución viran hacia el lado de babor. Sin embargo, todas las interfaces dinámicas deben estar en un diverso VLA N o subred IP del resto de las interfaces configuradas en el puerto. Si el puerto es untagged, todas las interfaces dinámicas deben estar en una diversa subred IP de cualquier otra interfaz configurada en el puerto.

Configurar una interfaz dinámica con una subred secundaria no se soporta.

Cisco recomienda el usar de los VLA N marcados con etiqueta para las interfaces dinámicas.

Los VLA N con los controladores de WLAN utilizan este modelo:

/image/gif/paws/68100/wlan_controllers_vlans1.gif

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Configuraciones del switch Catalyst

Esta sección usa estas configuraciones:

Switch de Catalyst que funciona con el Cisco IOS Software
lab1sup720ip1#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
lab1sup720ip1(config)#interface gigabitethernet 1/6
lab1sup720ip1(config-if)#
lab1sup720ip1(config-if)#switchport
lab1sup720ip1(config-if)#switchport trunk encapsulation dot1q
lab1sup720ip1(config-if)#switchport trunk allowed vlan 1,5,15,20,25,30,35,40,45,50,55,100
lab1sup720ip1(config-if)#switchport mode trunk
lab1sup720ip1(config-if)#end
lab1sup720ip1#

Switch de Catalyst que funciona con el software CatOS
controller-catos> (enable) set trunk 2/1 on dot1q
Port(s)  2/1 trunk mode set to on.
Port(s)  2/1 trunk type set to dot1q.
!
!clearing out/pruning unwanted vlans
!
controller-catos> (enable) clear trunk 2/1 21-24,26-30,31-34,36-39,41-44,46-49,51-54,
56-99,101-999

!--- This command should be on one line.

Removing Vlan(s) 21-24,26-34,36-39,41-44,46-49,51-54,56-99,101-999 from allowed list.
Port  2/1 allowed vlans modified to 1,5,15,20,25,35,40,45,50,55,100,1000-1005,1025-4094.

Configuración de VLAN del controlador de WLAN

Configuración de la interfaz gráfica para el usuario

Complete estos pasos en el controlador de WLAN.

  1. Del WLC GUI, elija el regulador > las interfaces. Las interfaces paginan las listas todas las interfaces que se configuran en el WLC. Para crear una nueva interfaz dinámica, haga clic nuevo.

    wlan_controllers_vlans2.gif

  2. Ingrese el nombre de la interfaz y el identificador de VLAN y el tecleo se aplican.

    wlan_controllers_vlans3.gif

  3. Ingrese los parámetros específicos a este VLA N. Algunos de los parámetros incluyen la dirección IP, el netmask, el gateway, y el IP Address del servidor DHCP, y el tecleo se aplica.

    Aquí está un ejemplo.

    wlan_controllers_vlans4.gif

    Nota: La dirección IP asignada a esta interfaz actúa como el relé DHCP para que un cliente obtenga una dirección IP del servidor DHCP. Por ejemplo, cuando un cliente intenta asociarse a un WLAN/SSID (véase el paso 5 en esta configuración) asociado a esta interfaz dinámica, realiza un broadcast de la subred local para identificar al servidor DHCP. El regulador envía una solicitud al servidor DHCP (o a sí mismo si es el servidor DHCP para el segmento) con la dirección IP de esta interfaz dinámica como IP de la retransmisión al servidor DHCP configurado para esta interfaz. El servidor DHCP asigna una dirección IP al cliente del alcance de DHCP configurado.

  4. Verifique la configuración de la interfaz.

    Haga clic la lengueta del regulador en el menú en la cima de la ventana, y elija las interfaces del menú a la izquierda.

    wlan_controllers_vlans5.gif

  5. Haga clic la lengueta WLAN en el menú en la cima de la ventana, y el tecleo crea nuevo.

    wlan_controllers_vlans6.gif

  6. Ingrese el Service Set Identifier (SSID) y el nombre del perfil y el tecleo se aplican.

    Este ejemplo utiliza el vlan15 para la facilidad de la comprensión.

    wlan_controllers_vlans7.gif

  7. Seleccione el vlan15 del menú desplegable del nombre de la interfaz en la parte inferior de la ventana, y el tecleo se aplica.

    En este caso, el vlan15 SSID se ata para interconectar el vlan15 del nombre.

    wlan_controllers_vlans8.gif

Configuración de CLI

Utilice esta sección para configurar su VLA N vía el comando line interface(cli).

  1. Cree la interfaz y la etiqueta asociada del VLA N.

    El comando es interfaz de los config crea el vlan_id del interface_name.

    (lab5wlc4404ip15) >config interface create "vlan 15" 15
    

    Nota: Si hay un espacio en el nombre VLAN/WLAN al igual que el caso en este ejemplo, aseegurese el nombre está en las citas.

  2. Defina la dirección IP y el default gateway.

    El comando es gateway de máscara de red de IP_address del interface_name de la interfaz de los config.

    (lab5wlc4404ip15) >config interface address "vlan 15" 192.168.15.10  
    255.255.255.0 192.168.15.1
    
    !--- This command should be on one line.
    
    
  3. Defina al servidor DHCP.

    El comando es <secondary-server> <interface name> primario del [secondary] del <primary-server> de la interfaz dinámica DHCP de la interfaz de los config.

    (lab5wlc4404ip15) >config interface dhcp dynamic-interface "vlan 15" primary 1
    2.168.15.15
    
  4. Publique este comando para asociar la interfaz a un puerto físico:

    los config interconectan el physical_ds_port_number del operator_defined_interface_name del puerto. Aquí tiene un ejemplo:

    (Cisco Controller) >config interface port "vlan 15" 2
    
  5. Verifique la configuración de la interfaz.

    El comando es resumen de la interfaz de la demostración.

    (Cisco Controller) >show interface summary
    
    Interface Name                   Port Vlan Id  IP Address      Type    Ap Mgr Guest
    -------------------------------- ---- -------- --------------- ------- ------ ----
    ap-manager                       2    untagged 10.77.244.207   Static  Yes    N
    
    management                       2    untagged 10.77.244.206   Static  No     N
    
    service-port                     N/A  N/A      50.0.0.1        Static  No     N
    
    virtual                          N/A  N/A      1.1.1.1         Static  No     N
    
    vlan 15                          2    15       192.168.15.10   Dynamic No     N
  6. Defina la red inalámbrica (WLAN).

    El comando es config wlan crea el nombre del wlan_id.

    (lab5wlc4404ip15) >config wlan create 2 "vlan 15"
    
  7. Defina la interfaz para la red inalámbrica (WLAN).

    El comando es interface_name wlan del wlan_id de la interfaz de los config.

    (lab5wlc4404ip15) >config wlan interface 2 "vlan 15"
    
  8. Verifique la red inalámbrica (WLAN) y la interfaz asociada.

    El comando es resumen wlan de la demostración.

    (lab5wlc4404ip15) >show wlan summary 
    
    Number of WLANs.................................. 2
    
    WLAN ID�  WLAN Name�������������� Status���� �� Interface Name����������������� 
    -------� �--------------------�   ---------� ���--------------------------------
    1������� �lab5wlc4404ip15������   Enabled����   management��������������������� 
    2������� �vlan 15����������������� Disabled���   vlan 15������������������������� 
    
    (lab5wlc4404ip15) >

Haga clic este link para ver un vídeo de la comunidad del soporte de Cisco que describa cómo configurar los VLA N en los reguladores del Wireless LAN:

VLA N en los reguladores del Wireless LAN leavingcisco.com

wlan_controllers_vlans9.gif

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Verificación de los switches de Catalyst

  • Switch de Catalyst que funciona con el Cisco IOS Software interface_number del interface_type del show running-config interface

    controller-ios#show running-config interface gigabitethernet 2/1
    
     Building configuration...
     
    Current configuration : 190 bytes
    !
    interface GigabitEthernet2/1
     no ip address
     switchport
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 1,5,15,20,25,30,35,40,45,50,55,100
     switchport mode trunk
    end
  • El switch de Catalyst que funciona con el software CatOS — muestre la Mod de los config

    controller-catos> (enable) show config 2
    
    !--- This command shows non-default configurations only.
    !--- Issue the show config mod all command in order to  
    !--- show both default and non-default configurations.
    
    ............................
    begin
    !
    # ***** NON-DEFAULT CONFIGURATION *****
    !
    !
    #time: Sat Jan 7 2006, 08:03:04 
    !
    # default port status is enable
    !
    !
    #module 2 : 2-port 1000BaseX Supervisor
    clear trunk 2/1  2-4,6-14,16-19,21-24,26-34,36-39,41-44,46-49,51-54,56-99,101-999
    set trunk 2/1  on dot1q 1,5,15,20,25,35,40,45,50,55,100,1000-1005,1025-4094
    end
    Console> (enable)

Verificación del VLAN del controlador WLAN

Vea la sección de configuración de VLAN del controlador de WLAN de este documento, que incluye los pasos de verificación.

Troubleshooting

Use esta sección para resolver problemas de configuración.

Procedimiento de Troubleshooting

Complete estas instrucciones para resolver problemas su configuración.

  1. Haga ping del controlador de WLAN al default gateway que se configura en la interfaz ruteada del VLA N, y después haga ping en la dirección opuesta.

    • Controlador de WLAN:

      (lab5wlc4404ip15) >ping 192.168.15.1
      
      Send count=3, Receive count=3 from 192.168.15.1
    • Interfaz ruteada del VLA N:

      lab1sup720ip1#ping 192.168.15.10
      
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 192.168.15.10, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = �/4 ms
      lab1sup720ip1#
  2. Si los ping son fracasados, despliegue una captura de paquetes/el sniffer en el Switch y marque para verificar marcar con etiqueta apropiado del VLA N.

    Nota: Cuando usted inicia el ping de su regulador a un gateway de la capa 3, que está en la misma subred como su interfaz dinámica, el regulador aparece a la fuente el ping de la interfaz dinámica.


Información Relacionada


Document ID: 68100