Voz y Comunicaciones unificadas : Cisco Unity Express

Ejemplo de la distribución automática de llamadas del básico CME de Cisco y de las configuraciones de interoperabilidad del Auto Attendant del Cisco Unity Express

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (20 Junio 2008) | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona ejemplos de configuración para usar las funciones de básicas de Distribución automática de llamadas (ACD) y Cisco Unity Express Auto Attendant (AA) de Cisco CallManager (CME).

prerrequisitos

Requisitos

La Familiaridad general con las configuraciones de Cisco CME y del Cisco Unity Express se requiere. Este documento se centra específicamente en las configuraciones de interoperabilidad del básico CME de Cisco ACD y del Cisco Unity Express AA.

Los siguientes son las versiones mínimas para las funciones descritas en este ejemplo de configuración:

  • Cisco CME 3.3

  • Software Release 12.4.3 del ½ del ¿Â de Cisco IOSïÂ

  • Cisco Unity Express 2.1.3

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Un Cisco 2821 Router que ejecuta Cisco CME y Cisco Unity Express

  • Cisco IOS Software Release 12.4.3

  • Cisco CME 3.3

  • Versión del guión básica 2.1.0.0 ACD

  • Cisco Unity Express 2.1.3

  • Conjunto de funciones de voz IP de Cisco IOS

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Productos Relacionados

Esta configuración se puede también utilizar con el Cisco 2600XM, el Cisco 3700, el Cisco 2800, o los Cisco 3800 Series Router con el Cisco IOS Software Release 12.4.1 o Posterior.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

Antecedentes

Estos tres escenarios se dirigen en este documento:

  • Escenario 1--Using Cisco CME AA y grupos ACD con el Cisco Unity Express solamente como destino del correo de voz

  • Escenario 2--Using el Cisco Unity Express como el punto de entrada principal AA y Cisco CME AA como “submenú” dentro de ese AA

  • Escenario 3--Using Cisco CME AA como el punto de entrada principal y el Cisco Unity Express AA AA para proporcionar los “avisos flexibles” como parte del AA

El escenario 1 es el más aplicable cuando su Cisco CME AA se limita a proporcionar a un menú a las llamadas directas en los grupos ACD. En este escenario, Cisco CME se utiliza como el destino AA para las llamadas entrantes, y el Cisco Unity Express se utiliza exclusivamente como servidor de correo de voz cuando los agentes ACD no están disponibles ni contestan a las llamadas en una determinada cantidad de hora. El Cisco Unity Express AA no se utiliza en este escenario.

El escenario 2 es la configuración general más flexible para el básico CME de Cisco de integración ACD y el Cisco Unity Express AA. El diseño utilizó en el Cisco Unity Express AA de las características del escenario 2 para la automatización general del manejo de llamadas y para dar de las llamadas a los agentes ACD. En este escenario, el Cisco Unity Express se utiliza como el destino AA para las llamadas entrantes; El Cisco Unity Express también proporciona una variedad de elecciones de menú al llamador (tal como discado por nombre, discado por extensión, y segmentos de la información registrada). Una de estas opciones dirige algunas llamadas a los grupos de Cisco CME ACD. El correo de voz del Cisco Unity Express se utiliza de la misma manera como escenario 1.

El escenario 3 es una variación del escenario 1 en la cual Cisco CME AA se utiliza como el destino AA para las llamadas entrantes y el ACD es la función principal requerida del AA. Sin embargo, el Cisco Unity Express AA se utiliza como “servidor de notificación” con Cisco CME AA. Esto proporciona la capacidad de agregar algunos avisos (tales como horas de oficina o ubicación) que no estén disponibles con solamente Cisco CME AA.

Nota: Los Procedimientos de configuración GUI basados proporcionados en esta publicación se utilizan para ilustrar los procesos de instrumentación asociados a este ejemplo de configuración y para resumir los pasos necesarios para implementar las características descritas en el documento. Sin embargo, los procedimientos paso a paso completos no se proporcionan. Esta publicación asume que usted tiene una familiaridad de trabajo con Cisco CME y Cisco Unity Express GUI, así como un conocimiento sobre el funcionamiento del Cisco IOS CLI. Refiera por favor la guía al administrador apropiado de Cisco CME y del Cisco Unity Express, guía de configuración, y referencia de comandos para los detalles explícitos para los procedimientos y el comando usage.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Utilice la herramienta Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos utilizados en esta sección.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

Cuadro 1 diagrama de la red para el básico CME de Cisco ACD y el Cisco Unity Express AA

/image/gif/paws/67907/135345.jpg

Configuraciones

Los tres escenarios de configuración tienen estas características generales:

  • sistema CME de Cisco del Solo-sitio

  • Troncos PSTN integrados en el router de CME de Cisco

  • La configuración define un plan de marcación de 4 dígitos con las Extensiones del teléfono del IP en los 2000 a 2010 rangos, las Extensiones del NON-teléfono (tales como grupos Hunt) en el rango 2020 a 2099, y los puntos de entrada del Cisco Unity Express en el rango 21 xx.

  • Se definen nueve Teléfonos IP, las Extensiones 2000 a 2009.

  • La configuración ACD utiliza a tres grupos Hunt con tres Teléfonos IP en cada grupo.

  • Definen a dos recepcionistas, que son también parte de que los nueve Teléfonos IP en el ACD agrupan.

La configuración de red utiliza a un Cisco 2821 Router con estas características:

  • Acceso de red del IP vía la dirección IP b .168.1.1

  • Configuración de CME de Cisco con nueve Teléfonos IP--cada uno con una extensión de 4 dígitos (2001 a 2010)

  • NM-CUE

  • Dirección IP del Cisco Unity Express un .1.11.2

En este documento, se utilizan estas configuraciones:

Notas de configuración de la implementación general

La conectividad PSTN usada en esta configuración está vía un trunk del Oficina de intercambio remoto (FXO). Si usted tiene un tronco PRI, las configuraciones miran exactamente lo mismo que ésos dados en los ejemplos de configuración presentados en esta publicación, con la adición de estas entradas de configuración:

controller T1 2/1
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
interface Serial2/1:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
voice-port 2/1:23
!
dial-peer voice 777 pots
 incoming called-number .
 direct-inward-dial
 port 2/1:23

Los scripts del Cisco Unity Express AA que se utilizan en los ejemplos presentados en esta publicación son muy simples y para mayor clareza contienen el número mínimo de características para alcanzar las funciones ilustradas por este documento. Los scripts del Cisco Unity Express AA desplegados en una red en funcionamiento deben tener significantly more capacidad de la dirección de llamada entrante comparada a las redes de prueba del laboratorio. El manejo de llamadas adicional “pasos” puede incluir el siguiente:

  • Manejo de error mejorado (por ejemplo cuando el llamador presiona los dígitos que no están en el menú)

  • Dirección del descanso (tal como relanzar los menús al número fijo de épocas)

  • Capacidad de bloquear la transferencia externa de las llamadas a los destinos PSTN externos (evitar el fraude de cargos de llamada).

Escenario 1 - Usando el básico CME de Cisco ACD con el correo de voz del Cisco Unity Express

En el escenario 1, las llamadas entrantes se dirigen a Cisco CME AA (extensión 2040), que proporciona un saludo agradable y un menú con tres opciones al llamador. De acuerdo con la opción del llamador, la llamada se dirige a uno de tres grupos Hunt ACD. Si las llamadas no se contestan en el grupo ACD, las llamadas se remiten a una casilla de correo de entrega general (GDM) para dejar un mensaje.

Nota: Usted no puede configurar un GDM que se copiará al buzón de cada usuario (similar a una lista de distribución).

En este escenario descrito en esta sección, se utiliza un solo GDM de modo que los nueve agentes ACD en los grupos ACD puedan iniciar sesión a y extraer los mensajes. En otras variaciones descritas como parte del escenario 2, se explora la capacidad de tener un GDM individual por el grupo ACD.

Flujo de llamada

El flujo de llamada de la configuración en esta sección se ilustra en el cuadro 2.

Cuadro 2 Cisco Unity Express AA con el flujo de llamada del escenario 1 del básico CME de Cisco ACD

/image/gif/paws/67907/135346.jpg

Notas de configuración del escenario 1

Las llamadas PSTN del puerto FXO (0/3/0) autoterminated (vía el comando connection plar-opx 2040) al número piloto de Cisco CME AA (2040). Cisco CME AA presenta un saludo agradable y un menú agradable con tres opciones--el contenido hablado de los prompts se da en la imagen del flujo de llamada en el cuadro 2. La frase agradable registrada reside en el archivo Flash en_bacd_welcome.au, mientras que las frases registradas del menú residen en el archivo en_bacd_options_menu.au.

El saludo GDM para extensión 2070 es como sigue: “Gracias por llamar el servicio al cliente; nadie está disponible ahora. Deje por favor un mensaje y volveremos su llamada tan pronto como poder.”

Una indicación de mensaje en espera (MWI) para los mensajes en el GDM es alcanzada remitiendo Cisco CME AA (el comando param voice-mail 2070) a una extensión intermedia (2070) que sean CFA (call forward all) al correo de voz piloto (2105). Esta expedición se hace en vez de señalar Cisco CME AA directamente al correo de voz piloto--cuál sería hecho con el comando param voice-mail 2105. La extensión 2070 es el botón 2 en los teléfonos del agente, y este botón indica el MWI para el GDM, que se asocia a la extensión 2070--rather que con los números de grupo Hunt ACD (2020, 2021 o 2022). Los números “finales” no se configuran en los grupos Hunt porque la lógica ACD desvía los números finales a favor del número de la expedición AA (comando param voice-mail).

Nota: Cualquier momento eso usted realiza cualquier cambio al script, usted necesita cargar la aplicación.

El script de Cisco CME AA se asocia a un Loopback IP Address (un .1.1.1) para asegurar el script del Tool Command Language (TCL) está siempre para arriba--sin importar el estado de las interfaces LAN (comando dial-peer voice 2040 voip). Utilizan a un dial peer continuo a las llamadas directas al punto de entrada de Cisco CME AA (2040) para asegurarse de que los llamadores PSTN (así como los teléfonos del IP local) pueden llamar el AA (comando dial-peer voice 2041 voip).

Configuración Cisco CME para el escenario 1

Estos pasos resumen la configuración para Cisco CME para el escenario 1:

  1. Elija la configuración > los parámetros del sistema para configurar tres grupos Hunt 2020, 2021, y 2022 ACD que se asocien a tres opciones de menú de Cisco CME AA. Véase el cuadro 3.

    El cuadro 3 especifica los grupos Hunt del Cisco Unity Express ACD

    /image/gif/paws/67907/135352.jpg

  2. Elija la configuración > los parámetros del sistema para configurar los detalles para el grupo Hunt 2020 con los agentes 2001, 2002, y 2003. Véase el cuadro 4.

    Cuadro 4 detalles de la configuración para el grupo Hunt 2020

    /image/gif/paws/67907/135353.jpg

  3. Elija la configuración > los teléfonos y haga clic la dirección MAC del teléfono que usted quiere cambiar. La ventana del teléfono del cambio aparece (véase el cuadro 5).

  4. Ingrese la extensión 2070 en el teléfono del agente ACD para conseguir el MWI para los mensajes en el GDM.

    Cuadro 5 extensión del socio al botón específico

    /image/gif/paws/67907/135354.jpg

Lo que sigue es (y anotado) la configuración CLI completa del router de CME de Cisco para el escenario 1 ese los resultados de los cambios del específico a la configuración baja.

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!

!--- Define the parameters for the Cisco CME ACD TCL script. 
!--- The hunt groups for the
!--- ACD are 2020, 2021, and 2022.

!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2022
  param queue-len 30
 !

!--- Define the parameters for the Cisco CME AA TCL script. 
!--- The pilot number is 2040.
!--- The voice-mail destination is extension 2070, which is call forward all
!--- (CFA) routed to voice mail (2105).

!
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!

!--- Define the loopback address to which the TCL script is attached.

!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!

!--- PSTN calls are auto-terminated on the Cisco CME AA pilot number 2040.

!
voice-port 0/3/0
 connection plar opx 2040
!
voice-port 0/3/1
 connection plar opx 2040
!
voice-port 0/3/2
!
voice-port 0/3/3
!

!--- Calls to Cisco CME AA pilot number 2040 are associated with a loopback address
!--- a.1.11.1 to ensure that the TCL script is always up.

!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!

!--- The back-to-back dial-peer for Cisco CME AA 
!--- pilot number 2040 points to the
!--- AA TCL script and ensures that all PSTN and 
!--- internal callers can reach the AA.

!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!

!--- All calls in the 21xx range are directed to Cisco Unity Express.

!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!

!--- The following section shows nine ACD agents' extensions.

!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  7  dual-line
 number 2007
 name User27
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  8  dual-line
 number 2008
 name User28
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  9  dual-line
 number 2009
 name User29
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!

!--- Extension 2070 is associated with the GDM. 
!--- This extension is used to get MWI
!--- on the ACD agents' phone.

!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!

!--- The following section shows phone definitions for the nine ACD agents.
!--- Ephone-dn 11 (2070) is defined as button 2 on each phone, so that all
!--- agents can get MWI for the GDM.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:11
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:11
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:11
!

!--- Three hunt-groups are used by the ACD scripts. 
!--- There are three agents in each group.

!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
ephone-hunt 3 longest-idle
 pilot 2022
 list 2007, 2008, 2009
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

Cisco Unity Express de la configuración para el escenario 1

Estos pasos resumen la configuración para el Cisco Unity Express para el escenario 1:

  1. Elija la configuración > Groups. Entonces haga clic el grupo (custservice) ese usted quieren editar. La ventana del perfil del grupo aparece (véase el cuadro 6).

  2. La lengueta del perfil es la visualización predeterminada. Configure al grupo del custservice asociado a la extensión 2070.

    Cuadro 6 perfil del grupo de la configuración

    142424.jpg

  3. Haga clic la lengueta de los propietarios/de los miembros (véase el cuadro 7).

  4. Configure a los miembros (los nueve usuarios del agente ACD) del grupo del custservice.

    Cuadro 7 miembros del grupo de la configuración

    135356.jpg

Lo que sigue es (y anotado) la configuración CLI completa del Cisco Unity Express para el escenario 1 ese los resultados de los cambios del específico a la configuración baja:

cue#show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1
groupname Administrators create
groupname Broadcasters create
!

!--- The custservice group is defined as all the 
!---users that have access to the GDM.

!
groupname custservice create
!

!--- Nine ACD agents are defined as users.

!
username admin create
username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
username user27 create
username user28 create
username user29 create
!

!--- The custservice group (and therefore GDM) 
!--- is associated with extension 2070.

!
groupname custservice phonenumber "2070"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
username user27 phonenumber "2007"
username user28 phonenumber "2008"
username user29 phonenumber "2009"
groupname Administrators member admin
!

!--- Nine ACD agents users are members of the 
!--- custservice group, so they can have
!--- access to the GDM to retrieve messages.

!
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname custservice member user27
groupname custservice member user28
groupname custservice member user29
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
!

!--- The Cisco Unity Express system AA is defined 
!--- in the system by default, but
!--- is not used in this scenario.

!
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "false"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
!

!--- Define the GDM associated with 2070, 
!--- associated with the custservice group.

!
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
!

!--- Define personal mailboxes for nine ACD agents.

!
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000
description "user26 mailbox"
end mailbox
voicemail mailbox owner "user27" size 3000
description "user27 mailbox"
end mailbox
voicemail mailbox owner "user28" size 3000
description "user28 mailbox"
end mailbox
voicemail mailbox owner "user29" size 3000
description "user29 mailbox"
end mailbox
end

Escenario 2 - Utilice el Cisco Unity Express AA como el menú de la Primero-grada y el ACD básico como el segundo menú del nivel

En el escenario 2, las llamadas entrantes se dirigen a la aduana AA (número piloto 2100) del Cisco Unity Express, que proporciona un saludo agradable y un menú con cuatro opciones al llamador. De acuerdo con la opción del llamador, la llamada se dirige a Cisco CME ACD (opción 1), uno de dos avisos (opciones 2 y 3), o a una casilla de correo general de negocios (GDM para la extensión 2080) asociada a los recepcionistas (opción 4).

Si el llamador elige la opción 1, la llamada se da apagado a Cisco CME ACD donde Cisco CME AA proporciona un segundo menú del nivel, que es similar al escenario 1.

Flujo de llamada del escenario 2

El flujo de llamada de la configuración en esta sección se ilustra en el cuadro 8.

Cuadro 8 flujo de llamada para el escenario 2

135360.jpg

Notas de configuración del escenario 2

Las llamadas PSTN del puerto FXO (0/3/0) autoterminated al Cisco Unity Express AA (2100).

El menú de la primero-grada (“gracias por llamar los sistemas del aparato; presione 1 para el servicio al cliente; prensa 2 para la ubicación de las instalaciones; prensa 3 por las horas de oficina; la prensa 4 para dejar una Voz message.") es proporcionada por la aduana AA (archivo S10_Main_Menu.wav) del Cisco Unity Express.

El menú de segundo nivel (“ayudar a reorientar su llamada: Presione 1 para las preguntas relacionadas con hardware; prensa 2 para las preguntas del software relacionado; la prensa 3 para el general questions.") es proporcionada por los archivos del prompt de Cisco CME AA. La primera frase (“ayudar a reorientar su llamada ") se contiene en el archivo Flash en_bacd_welcome.au, mientras que el resto de las instrucciones es sin cambios de la configuración del escenario 1 y se contiene en el archivo Flash en_bacd_options_menu.au.

Usted puede desviar la recepción de Cisco CME que saluda en conjunto registrando un pequeño archivo vacío o borrando el archivo del flash de su router (que hace el software de Cisco CME desviar el saludo). En el ejemplo del escenario 2 representado en esta sección, las frases del menú asociadas a los archivos del prompt del Cisco Unity Express y de Cisco CME se han estructurado para fluir como solo AA al llamador. Usted puede también desviar Cisco CME AA en conjunto (las opciones agradables del saludo y de la opción) usando el comando number de la gota a través option del param de transferir una llamada directamente en Cisco CME ACD mientras que desvía Cisco CME AA.

La extensión 2080 y el GDM asociado se agregan a la configuración para proporcionar una casilla de correo general para los recepcionistas. Este buzón es ingresado eligiendo la opción 4 del menú de la primero-grada y manejado totalmente dentro del Cisco Unity Express. La extensión 2080 se ha agregado a los teléfonos 2001 y 2004--the de los Teléfonos IP asociados a dos empleados que son recepcionistas (así como agentes ACD).

Si un llamador elige 1 del menú de la primero-grada y se dirige a los grupos ACD, pero la llamada sigue siendo por contestar, la llamada se remite a la extensión 2070--which es el GDM para los agentes ACD.

Configuración Cisco CME para el escenario 2

Estos pasos resumen la configuración para Cisco CME para el escenario 2:

  1. Elija la configuración > los teléfonos. Entonces haga clic la dirección MAC del teléfono que usted quiere cambiar. La ventana del teléfono del cambio aparece (véase el cuadro 9).

  2. Ingrese la extensión 2080 para abotonar 3 del teléfono del recepcionista, mientras que el GDM ACD permanece en el botón 2. Con esta configuración, el empleado consigue el MWI para el recepcionista y las casillas de correos GDM de ACD.

    El cuadro 9 agrega el botón de la extensión al teléfono del recepcionista

    /image/gif/paws/67907/135361.jpg

Lo que sigue es la configuración CLI (y anotado) del router de CME de Cisco completo para el escenario 2 ese los resultados de los cambios del específico a la configuración baja.

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2022
  param queue-len 30
 !
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!

!--- PSTN calls are auto-terminated on the Cisco CUE AA pilot number 2100.

!
voice-port 0/3/0
 connection plar opx 2100
!
voice-port 0/3/1
 connection plar opx 2100
!
voice-port 0/3/2
!
voice-port 0/3/3
!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  7  dual-line
 number 2007
 name User27
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  8  dual-line
 number 2008
 name User28
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  9  dual-line
 number 2009
 name User29
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!

!--- Extension 2080 is associated with the receptionists' GDM. 
!--- This extension is used to get MWI on the receptionists' phones.

!
ephone-dn  10
 number 2080
 description Reception GDM
 name Reception GDM
 call-forward all 2105
!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!

!--- Ephone-dn 10 (2080) is defined as button 3 on 
!--- phones 2001 and 2004 so that all
!--- receptionists (ephones 1 and 4) get MWI for the GDM.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11 3:10
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11 3:10
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:11
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:11
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:11
!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
ephone-hunt 3 longest-idle
 pilot 2022
 list 2007, 2008, 2009
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

Cisco Unity Express de la configuración para el escenario 2

Estos pasos resumen la configuración para el Cisco Unity Express para el escenario 2:

  1. Abra la utilidad del editor de secuencia de comandos del Cisco Unity Express y cree el script de encargo del Cisco Unity Express. Véase el cuadro 10.

    Cuadro 10 configuración el script del Cisco Unity Express AA para el menú del nivel superior

    /image/gif/paws/67907/135362.jpg

  2. Elija el correo de voz > al Auto Attendant y asocie el script (S10_CUE-AA-BACD-script.aef) al número piloto 2100. Véase el cuadro 11.

    Cuadro 11 socio el script con un número piloto

    /image/gif/paws/67907/135363.jpg

  3. Registre todos los prompts para el script AA. Usted puede o registrar este offline y cargar los archivos del .wav al Cisco Unity Express con el nombre del archivo correcto, o usted puede registrarlo a través de la administración vía la telefonía (AVT).

  4. (Opcional) si usted utiliza el AVT, el Cisco Unity Express asigna un nombre del archivo genérico que usted pueda cambiar posteriormente al nombre del archivo deseado. Elija el correo de voz > los prompts y haga clic el nombre del archivo del sistema.

  5. (Opcional) edite el nombre del archivo (s) según las necesidades en el cuadro de diálogo y haga clic la autorización. La ventana del correo > de los prompts de The Voice ahora muestra el nombre del archivo corregido (s) en la lista (véase el cuadro 12).

    Cuadro 12 lista de los prompts del script AA

    /image/gif/paws/67907/135364.jpg

  6. Elija el correo de voz > al Auto Attendant y abra el AA construido en el paso 1. eligen los parámetros del script y asocian los nombres del archivo pronto al parámetro correcto en el script.

  7. Elija la configuración > Groups y haga clic al grupo (recepción) ese usted quieren editar. La ventana del perfil del grupo aparece (véase la ventana parcial en la parte superior del cuadro 13). La lengueta del perfil es la visualización predeterminada.

  8. Haga clic la lengueta de los propietarios/de los miembros para configurar a los miembros.

    El cuadro 13 define al grupo de la recepción

    142217.jpg

Lo que sigue es (y anotado) la configuración CLI completa del Cisco Unity Express para el escenario 2 ese los resultados de los cambios del específico a la configuración baja.

cue#show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1

!--- Add the reception group.

!
groupname Administrators create
groupname Broadcasters create
groupname custservice create
groupname reception create
username admin create

username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
username user27 create
username user28 create
username user29 create
!

!--- The reception group (and therefore GDM) is associated with extension 2080.

!
groupname custservice phonenumber "2070"
groupname reception phonenumber "2080"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
username user27 phonenumber "2007"
username user28 phonenumber "2008"
username user29 phonenumber "2009"
!

!--- Add membership to group "reception".

!
groupname Administrators member admin
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname custservice member user27
groupname custservice member user28
groupname custservice member user29
groupname reception member user21
groupname reception member user24
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast

!--- Define a 09:00-17:00 Monday-Friday business schedule for the AA.

!
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "true"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
!

!--- Add the custom AA script for the first-tier menu.

!
ccn application s10-cue-aa-bacd
 description "s10-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s10-cue-aa-bacd-script.aef"
 parameter "S10_StoreHours" "S10_StoreHours.wav"
 parameter "S10_CustomerService" "2040"
 parameter "S10_GDM" "2080"
 parameter "S10_StoreLocation" "S10_StoreLocation.wav"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
!

!--- Associate the custom AA script with the pilot number 2100.

!
ccn trigger sip phonenumber 2100
 application "s10-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
!

!--- Add the GDM for "reception"

!
voicemail mailbox owner "reception" size 3000
 description "Receptionists mailbox"
 end mailbox
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000
description "user26 mailbox"
end mailbox
voicemail mailbox owner "user27" size 3000
description "user27 mailbox"
end mailbox
voicemail mailbox owner "user28" size 3000
description "user28 mailbox"
end mailbox
voicemail mailbox owner "user29" size 3000
description "user29 mailbox"
end mailbox
end

Variación de la configuración 1 del escenario 2 - GDMs individual por el grupo Hunt

La configuración para el escenario principal descrito en las secciones anteriores define un solo GDM para todos los mensajes dejados por los llamadores en los tres grupos ACD (soporte del hardware, software support y Preguntas generales). Este granularity no pudo ser suficiente para algunas situaciones porque los agentes para un grupo (tal como software support) no pudieron querer vadear a través de los mensajes dejados para el hardware y los grupos de soporte generales antes de encontrar los mensajes con respecto al software support. Si el volumen de mensajes es alto, usted puede tener un buzón separado para cada grupo ACD.

Con los grupos Hunt normales de Cisco CME (cuando no usando el ACD), usted puede definir un buzón separado para cada grupo Hunt asociando el GDMs individual a los números de grupo Hunt (2020, 2021, 2022) y señalando el destino “final” del grupo Hunt al correo de voz--como se ilustra en los ejemplos de configuración siguientes.

Configuración Cisco CME para la variación 1 del escenario 2

Los siguientes son GDMs de las variaciones para el individuo de la configuración de CME de Cisco:

ephone-hunt 1 sequential
 pilot 2020
 list 2001, 2002, 2003
 final 2105
 timeout 10
!
!
ephone-hunt 2 sequential
 pilot 2021
 list 2004, 2005, 2006
 final 2105
 timeout 10
!
!
ephone-hunt 3 sequential
 pilot 2022
 list 2007, 2008, 2009
 final 2105
 timeout 10

Cisco Unity Express de la configuración para la variación 1 del escenario 2

Estos pasos resumen la configuración de los grupos y del GDMs en el Cisco Unity Express para la variación 1 del escenario 2:

  1. Definen a los grupos individuales en el Cisco Unity Express para cada uno de los tres grupos Hunt. Elija la configuración > Groups para definir a los grupos. Véase el cuadro 14.

    El cuadro 14 define a los grupos individuales

    135357.jpg

  2. De la configuración > Groups, haga clic el grupo (hardware) que usted quiere editar. La ventana de la lengueta del perfil predeterminado aparece (véase el top del cuadro 15).

    Cuadro 15 grupos del específico de la configuración

    /image/gif/paws/67907/135358.jpg

  3. Elija la lengueta de los propietarios/de los miembros (véase la parte inferior del cuadro 15) y haga clic la casilla de verificación en la izquierda para seleccionar los propietarios y a los miembros.

    Los siguientes son Variaciones de la configuración del Cisco Unity Express para el GDMs individual:

    groupname hardware create
    groupname software create
    groupname general create
    groupname hardware phonenumber "2020"
    groupname software phonenumber "2021"
    groupname general phonenumber "2022"
    groupname hardware member user21
    groupname hardware member user22
    groupname hardware member user23
    groupname software member user24
    groupname software member user25
    groupname software member user26
    groupname general member user27
    groupname general member user28
    groupname general member user29
    voicemail mailbox owner "general" size 5520
     description "general mailbox"
     end mailbox
    voicemail mailbox owner "hardware" size 5520
     description "Hardware mailbox"
     end mailbox
    voicemail mailbox owner "software" size 5520
     description "software mailbox"
     end mailbox

Variación de la configuración 2 del escenario 2 - GDMs individual por el grupo ACD

Hay dos desventajas a la configuración resumida en “GDMs de la Variación de la configuración 1--Individual del escenario 2 por la sección del grupo Hunt”.

  • Trabaja solamente si llaman los grupos Hunt directamente (Extensiones 2020, 2021 y 2022), y no trabaja cuando utilizan a los grupos Hunt como ACD cuando se llama el número piloto ACD (2040)

  • No proporciona ninguna medios de proporcionar al MWI para los agentes porque los números de grupo Hunt no se pueden poner en los teléfonos como botones.

Para proporcionar una configuración que solucione estas dos desventajas, usted puede utilizar la secuencia de comandos de sistema del xfermailbox en el Cisco Unity Express. Defina a tres grupos en el Cisco Unity Express (uno por cada uno para el soporte físico, el software, y el general), y asocie a cada grupo a una extensión provisoria (tal como 2030, 2031, y 2032) que se pueda poner como botones que aparecen en un teléfono del agente (y como consecuencia proporcionar el MWI). Esta configuración de los grupos, de las Extensiones, y de los teléfonos se resume en el cuadro 2.

Agente Extensión Número de grupo Hunt Grupo ACD Buzón del grupo
user21 2001 2020 Hardware 2030
user22 2002 2020 Hardware 2030
user23 2003 2020 Hardware 2030
user24 2004 2021 Software 2031
user25 2005 2021 Software 2031
user26 2006 2021 Software 2031
user27 2007 2022 General 2032
user28 2008 2022 General 2032
user29 2009 2022 General 2032

El flujo de llamada ajustado para esta configuración modificada se ilustra en el cuadro 16.

Cuadro 16 flujo de llamada ajustado para la variación de secuencia de comandos xfermailbox

/image/gif/paws/67907/135359.jpg

Las llamadas de dirección en el GDMs individual en el Cisco Unity Express requieren una secuencia de comandos personalizada que llame la secuencia de comandos de sistema del xfermailbox. Las llamadas a Cisco CME ACD se pueden remitir solamente al Cisco Unity Express usando el solo comando number del correo de voz del param (los destinos finales individuales en los grupos Hunt no se pueden utilizar para los flujos de llamada ACD). Este comando entrega una sola extensión al Cisco Unity Express para la entrada en un buzón (extensión 2070 en configuraciones precedentes). El Cisco Unity Express no tiene ninguna manera de distinguir qué grupo Hunt es el receptor deseado y no puede determinar que de los tres GDMs a ingresar.

En lugar, dirija el destino del correo de voz de Cisco CME ACD a un número piloto del Cisco Unity Express (2110) que ingresen una secuencia de comandos personalizada (s12-xfer-to-mbox.aef). Este número piloto proporciona un menú al usuario que ofrece una opción de los grupos para quienes un mensaje puede ser dejado (soporte físico, software, o general). El contenido de este menú se muestra en la parte inferior del flujo de llamada en el cuadro 16. De acuerdo con la respuesta del llamador, la variable mbox se fija a la extensión apropiada (2030, 2031, o 2032), y la llamada se da apagado (vía la secuencia de comandos de sistema del xfermailbox) a una de los tres GDMs.

Los pasos asociados a modificar la configuración del escenario 2 para manejar los cambios de configuración delineados en el cuadro 2 y el cuadro 16 se describen en los pasos siguientes:

  1. Abra la utilidad del editor de secuencia de comandos del Cisco Unity Express y escriba un script del Cisco Unity Express de la aduana llamado s12-xfer-to-mbox.aef. Véase el cuadro 17.

    Cuadro 17 ventana de la creación del script del Cisco Unity Express de la aduana

    /image/gif/paws/67907/135347.jpg

  2. Elija el correo de voz > al Auto Attendant. Véase el cuadro 18. Agregue a un nuevo Auto Attendant y asocíelo al script construido en el paso 1.

  3. Asocie el script de encargo del Cisco Unity Express del s12-xfer-to-mbox.aef al número piloto 2110. Véase el cuadro 18.

    Cuadro 18 socio el script de encargo del Cisco Unity Express con un número piloto

    /image/gif/paws/67907/135348.jpg

  4. Registre el prompt (en este caso nombrado S12_Main_Menu.wav) para el nuevo script AA. Usted puede o registrar este offline y cargar el archivo del .wav al Cisco Unity Express con el nombre del archivo correcto, o usted puede registrarlo a través de la administración vía la telefonía (AVT).

  5. (Opcional) si usted utiliza el AVT, el Cisco Unity Express asigna un nombre del archivo genérico que usted pueda cambiar posteriormente al nombre del archivo deseado. Elija el correo de voz > los prompts y haga clic el nombre del archivo del sistema.

  6. (Opcional) edite el nombre del archivo en el cuadro de diálogo según las necesidades y haga clic la AUTORIZACIÓN. La ventana del correo > de los prompts de The Voice ahora muestra el nombre del archivo corregido en la lista (véase el cuadro 19).

  7. Elija el correo de voz > al Auto Attendant y abra el AA construido durante el paso 2. eligen los parámetros del script y asocian el nombre del archivo pronto al parámetro correcto en el script.

    Cuadro 19 lista de los prompts registrados

    135349.jpg

  8. Elija la configuración > la extensión para definir las Extensiones 2030, 2031, y 2032 para asociar el GDMs a cada uno de estas Extensiones. Véase el cuadro 20.

    El cuadro 20 define las Extensiones para asociar el GDMs a los grupos Hunt ACD

    /image/gif/paws/67907/135350.jpg

  9. Elija la configuración > los teléfonos y haga clic la dirección MAC del teléfono que usted quiere cambiar. La ventana del teléfono del cambio aparece (véase el cuadro 21).

  10. Botones Add para 2030, 2031, o 2032 en los teléfonos del agente ACD para proporcionar el MWI.

    Cuadro 21 ventana que ilustra agregando los botones

    /image/gif/paws/67907/135351.jpg

Lo que sigue es la configuración CLI anotada del router de CME de Cisco para los cambios y las adiciones en la configuración de CME de Cisco a la configuración baja del escenario asociada a “configurar Cisco CME para el escenario 2" sección.


!--- Set the Cisco CME AA voice mail destination 
!--- to 2110, the Cisco Unity Express
!--- script entrypoint for the transfer-to-mailbox functionality.

!
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2110
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!

!--- Define the group extensions (2030, 2031 and 2032) to 
!--- be used as button appearances
!--- on the agent phones so they can get MWI for the GDMs. 
!--- Put these extension in CFA
!--- so they never ring and do not disturb the agents.

!
ephone-dn  12
 number 2030
 description HW Cust Svc Mbox
 name HW Cust Svc Mbox
 call-forward all 2110
!
ephone-dn  13
 number 2031
 description SW Cust Svc Mbox
 name SW Cust Svc Mbox
 call-forward all 2110
!
ephone-dn  14
 number 2032
 description Gen Cust Svc Mbox
 name Gen Cust Svc Mbox
 call-forward all 2110
!

!--- Add a button appearance of the appropriate 
!--- group extension to each of the
!--- ACD Agent phones.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:12 3:10
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:12
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:12
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:13 3:10
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:13
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:13
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:14
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:14
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:14

Lo que sigue es la configuración CLI anotada del Cisco Unity Express para los cambios y las adiciones en la configuración a la configuración baja del escenario asociada a “configurar el Cisco Unity Express para el escenario 2" sección y los cambios precedentes GUI:


!--- Define the three new groups, Hardware, Software and General.

!
groupname hardware create
groupname software create
groupname general create
!

!--- Define the new groups (and therefore GDMs) are associated with 
!--- extensions 2030, 2031 and 2032.

!
groupname hardware phonenumber "2030"
groupname software phonenumber "2031"
groupname general phonenumber "2032"
!

!--- Define the membership of  the Hardware, Software and General groups.

!
groupname hardware member user21
groupname hardware member user22
groupname hardware member user23
groupname software member user24
groupname software member user25
groupname software member user26
groupname general member user27
groupname general member user28
groupname general member user29
!

!--- Define the custom AA script that will branch 
!--- to the xfermailbox.aef system script
!--- when the caller selects the correct GDM from the menu.

!
ccn application s12-xfer-to-mbox
 description "s12-xfer-to-mbox"
 enabled
 maxsessions 8
 script "s12_cue-aa-bacd-script.aef"
 end application
!

!--- Define the pilot number 2110 to the custom script.

!
ccn trigger sip phonenumber 2110
 application "s12-xfer-to-mbox"
 enabled
 maxsessions 8
 end trigger
!

!--- Define the GDMs for each of the groups.

!
voicemail mailbox owner "hardware" size 3000
 description "hardware mailbox"
 end mailbox
voicemail mailbox owner "software" size 3000
 description "software mailbox"
 end mailbox
voicemail mailbox owner "general" size 3000
 description "general mailbox"
 end mailbox

Variación de la configuración 3 del escenario 2 - Utilice el descenso con las funciones CD

El descenso a través de la característica de Cisco CME ACD se puede utilizar para desviar el menú y la transferencia de Cisco CME AA una llamada directamente en el ACD. Con esta característica, el menú entero AA se puede consolidar en el script del Cisco Unity Express AA. Mientras que usar esta característica requiere la configuración adicional en el router de CME de Cisco, simplifica el mantenimiento del script AA (menús) comparado a partir los menús y las grabaciones del aviso entre el Cisco Unity Express AA (menú de la grada 1) y Cisco CME AA (menú de la grada 2).

En la configuración de la variación 3 del escenario 2, ambas gradas del menú AA se contienen en el script del Cisco Unity Express AA como sigue:

  • Gracias por llamar los sistemas del aparato

    • Presione 1 para el servicio al cliente

      • Presione 1 para las preguntas relacionadas hardware

      • Prensa 2 para las preguntas relacionadas del software

      • Prensa 3 para las Preguntas generales

    • Prensa 2 para la ubicación de las instalaciones

    • Prensa 3 por las horas de oficina

    • Prensa 4 para dejar los mensajes de voz

Las elecciones de menú de la grada 2 dan lugar a las llamadas que son dadas apagado del Cisco Unity Express a un número piloto individual de Cisco CME ACD para cada uno de estos grupos:

  • Hardware — Número piloto 2040 de Cisco CME ACD

  • Software — Número piloto 2041 de Cisco CME ACD

  • General — Número piloto 2042 de Cisco CME ACD

Las configuraciones presentadas previamente en este documento definieron un solo número piloto ACD (2040). En esta Variación de la configuración, se definen tres diversos números pilotos de Cisco CME ACD (2040, 2041, y 2042). Esta variación ilustra cómo usted puede habilitar el descenso con las funciones. Usando el descenso a través de la característica desvía el menú de Cisco CME AA y especifica una opción particular de seguir (especificado en el comando CLI correspondiente). El sistema actúa como si el llamador presionara la opción especificada estáticamente en el CLI. En este escenario, la configuración de Cisco CME AA incluye las adaptaciones siguientes:

  • La configuración para el número piloto 2040 ACD incluye el comando param drop-through-option 1

  • La configuración para el número piloto 2041 ACD incluye el comando param drop-through-option 2

  • La configuración para el número piloto 2042 ACD incluye el comando param drop-through-option 3

Configuración Cisco CME para la variación 3 del escenario 2

Estos pasos resumen la configuración para Cisco CME para la variación 3 del escenario 2:

  1. Agregue Cisco adicional CME AA y configuración de ACD TCL para los números pilotos 2040, 2041 y 2042, usando “descenso-por” el CLI.

  2. Agregue al dial-peers para habilitar la marca de los nuevos números pilotos 2040, 204,1 y 2042.

    Lo que sigue es la configuración CLI anotada del router de CME de Cisco para los cambios y las adiciones a la configuración de CME de Cisco del escenario bajo asociado a “configurar Cisco CME para el escenario 2" sección.

    application
     service acd flash:app-b-acd-2.1.0.0.tcl
      param queue-cme-debugs 1
      param aa-hunt1 2020
      param aa-hunt2 2021
      param number-of-hunt-grps 3
      param aa-hunt3 2022
      param queue-len 30
    !
    
    !--- Define the TCL configuration for the Hardware group, using pilot number 2040 
    !--- and "drop-through-option 1". Extension 2030 is associated with the GDM for
    !--- the Hardware group, so this is the voice mail destination.
    
    !
     service hardware-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param max-time-vm-retry 1
      paramspace english index 0
      param max-time-call-retry 60
      param voice-mail 2030
      param aa-pilot 2040
      param number-of-hunt-grps 1
      paramspace english language en
      param handoff-string hardware-aa
      param call-retry-timer 20
      paramspace english location flash:
      param service-name acd
      param drop-through-option 1
      param second-greeting-time 30
      paramspace english prefix en
    !
    
    !--- Define the TCL configuration for the Software group, 
    !--- using pilot number 2041 
    !--- and "drop-through-option 2". Extension 2031 is associated with the GDM for
    !--- the Software group, so this is the voice mail destination.
    
    !
     service software-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param number-of-hunt-grps 1
      paramspace english index 0
      param handoff-string software-aa
      paramspace english language en
      param call-retry-timer 20
      param service-name acd
      paramspace english location flash:
      param drop-through-option 2
      param second-greeting-time 30
      param max-time-vm-retry 1
      param voice-mail 2031
      paramspace english prefix en
      param max-time-call-retry 60
      param aa-pilot 2041
    !
    
    !--- Define the TCL configuration for the General group, using pilot number 2042 
    !--- and "drop-through-option 3". Extension 2032 is associated with the GDM for
    !--- the General group, so this is the voice mail destination.
    
    !
     service general-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param call-retry-timer 20
      paramspace english index 0
      param max-time-call-retry 60
      param voice-mail 2032
      param service-name acd
      param number-of-hunt-grps 1
      param drop-through-option 3
      paramspace english language en
      param handoff-string general-aa
      param max-time-vm-retry 1
      paramspace english location flash:
      param aa-pilot 2042
      param second-greeting-time 30
      paramspace english prefix en
    !
    
    !--- Define the dial-peers for pilot number 2040 and attach the Hardware
    !--- TCL script to this number.
    
    !
    dial-peer voice 2040 voip
     destination-pattern 2040
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20400 voip
     service hardware-aa
     incoming called-number 2040
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    
    !--- Define the dial-peers for pilot number 2041 and attach the Software
    !--- TCL script to this number.
    
    !
    dial-peer voice 2041 voip
     destination-pattern 2041
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20410 voip
     service software-aa
     incoming called-number 2041
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    �
    
    !--- Define the dial-peers for pilot number 2042 and attach the General
    !--- TCL script to this number.
    
    !
    dial-peer voice 2042 voip
     destination-pattern 2042
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20420 voip
     service general-aa
     incoming called-number 2042
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad

Cisco Unity Express de la configuración para la variación 3 del escenario 2

Estos pasos resumen la configuración para el Cisco Unity Express para la variación 3 del escenario 2:

  1. Abra la utilidad del editor de secuencia de comandos del Cisco Unity Express y ajuste el script s10-cue-aa-bacd.aef para contener ambas gradas del menú AA. Véase el cuadro 22.

    Cuadro 22 configuración el script del Cisco Unity Express AA para ambos niveles del menú

    /image/gif/paws/67907/142220.jpg

  2. Elija el correo de voz > al Auto Attendant y asocie el nuevo script (S10A_CUE-AA-BACD-script.aef) al número piloto 2100. Véase el cuadro 23.

    Cuadro 23 socio el script con un número piloto

    /image/gif/paws/67907/142221.jpg

  3. Registre todos los prompts requeridos para el script AA. Usted puede o registrar estos offline y cargar los archivos del .wav al Cisco Unity Express con los nombres del archivo correctos, o usted puede registrarlo a través de la administración vía la telefonía (AVT).

  4. (Opcional) si usted utiliza el AVT, el Cisco Unity Express asigna los nombres del archivo genéricos que usted puede cambiar posteriormente al nombre del archivo deseado. Elija el correo de voz > los prompts y haga clic el nombre del archivo del sistema.

  5. (Opcional) edite el nombre del archivo (s) en el cuadro de diálogo según las necesidades y haga clic la AUTORIZACIÓN. La ventana del correo > de los prompts de The Voice ahora muestra el nombre del archivo corregido en la lista.

Lo que sigue es la configuración CLI anotada del Cisco Unity Express para los cambios y las adiciones a la configuración del Cisco Unity Express de la configuración baja del escenario asociada al Cisco Unity Express que configura para la sección del escenario 2.


!--- Define a new AA with script s10a-cue-aa-bacd.aef.

!
ccn application s10a-cue-aa-bacd
 description "s10a-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s10a_cue-aa-bacd-script.aef"
 parameter "S10_Hardware" "2040"
 parameter "S10_StoreHours" "S10_StoreHours.wav"
 parameter "S10_Software" "2041"
 parameter "S10_General" "2042"
 parameter "S10_GDM" "2080"
 parameter "S10_StoreLocation" "S10_StoreLocation.wav"
 end application
!

!--- Associate AA pilot number 2100 with the new script.

!
ccn trigger sip phonenumber 2100
 application "s10a-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger

Escenario 3 - Utilice el ACD básico como el menú y el Cisco Unity Express AA de la Primero-grada como el segundo menú del nivel

En el tercer escenario presentado en este documento, las llamadas entrantes se dirigen a Cisco CME AA (número piloto 2040) exactamente como en el escenario 1. La única diferencia es que hay solamente dos grupos ACD (hardware y software), mientras que la tercera opción del menú principal es acceder un aviso que describa la ubicación y las horas de funcionamiento de tienda.

Nota: No es posible incluir los avisos del formato libre con Cisco CME AA. Una secuencia de comandos personalizada del Cisco Unity Express se requiere en lugar de otro.

Usted puede alcanzar este mismo resultado (desde el punto de vista de un llamador) con una variación del escenario 2. El ejemplo del escenario 3 es dado para ilustrar otra manera de estructurar la aplicación dando de una llamada de Cisco CME ACD que procesa al Cisco Unity Express AA. Usando una variación del escenario 2 está probablemente más la manera típica de construir esta aplicación.

Flujo de llamada del escenario 3

El flujo de llamada de la configuración en esta sección se ilustra en el cuadro 24.

Cuadro 24 flujo de llamada del escenario 3

135510.jpg

Notas de configuración del escenario 3

Las llamadas PSTN del puerto FXO (0/3/0) auto-se terminan a Cisco CME AA (2040).

Cisco CME ACD tiene solamente dos grupos de agentes (2020 y 2021). El option 3 del menú se utiliza para dar de la llamada al Cisco Unity Express AA para el aviso. En vez de enumerar un número de grupo Hunt, cuando los llamadores eligen el option 3 el sistema dirige a los llamadores al número piloto del Cisco Unity Express AA (2100)--resulting del uso del comando param aa-hunt3 2100.

Configuración Cisco CME para el escenario 3

La configuración CLI para el router de CME de Cisco se muestra en el siguiente ejemplo:

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!

!--- Point option 3 of the menu (aa-hunt3) to the 
!--- Cisco Unity Express AA (2100).

!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2100
  param queue-len 30
 !
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!
voice-port 0/3/0
 connection plar opx 2040
!
voice-port 0/3/1
 connection plar opx 2040
!
voice-port 0/3/2
!
voice-port 0/3/3
!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

Cisco Unity Express de la configuración para el escenario 3

Estos pasos resumen la configuración para el Cisco Unity Express para el escenario 3:

  1. Abra la utilidad del editor de secuencia de comandos del Cisco Unity Express y escriba el script de encargo del Cisco Unity Express. Véase el cuadro 25.

    Cuadro 25 horario comercial y script de la ubicación

    /image/gif/paws/67907/135367.jpg

  2. Registre el prompt (en este caso nombrado S11_Announcement.wav) para el script AA (S11_CUE-AA-BACD-script.aef). Usted puede o registrar este offline y cargar el archivo del .wav al Cisco Unity Express con el nombre del archivo correcto, o usted puede registrarlo a través de la administración vía la telefonía (AVT).

  3. (Opcional) si usted utiliza el AVT, el Cisco Unity Express asigna un nombre del archivo genérico que usted pueda cambiar posteriormente al nombre del archivo deseado. Elija el correo de voz > los prompts y haga clic el nombre del archivo del sistema.

  4. (Opcional) edite el nombre del archivo en el cuadro de diálogo y haga clic la AUTORIZACIÓN. La ventana del correo > de los prompts de The Voice ahora muestra el nombre del archivo corregido en la lista (véase el cuadro 26).

  5. Elija el correo de voz > al Auto Attendant y abra el AA construido durante el paso 2. eligen los parámetros del script y asocian el nombre del archivo pronto al parámetro correcto en el script.

    Cuadro 26 ventana que muestra las opciones de prompt

    135368.jpg

  6. Elija el correo de voz > al Auto Attendant y asocie el script al número piloto 2100 AA. Consulte la figura 27.

    Cuadro 27 ventana que muestra la asociación del script al número piloto AA

    /image/gif/paws/67907/135369.jpg

La configuración CLI para el sistema del Cisco Unity Express se muestra en el siguiente ejemplo:

cue# 
show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1
groupname Administrators create
groupname Broadcasters create
groupname custservice create
username admin create
username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
groupname custservice phonenumber "2070"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
groupname Administrators member admin
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "true"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
!

!--- Define the AA script that will provide the announcement.

!
ccn application s11-cue-aa-bacd
 description "s11-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s11_cue-aa-bacd-script.aef"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
!

!--- Associate the script with the 2100 AA pilot number.

!
ccn trigger sip phonenumber 2100
 application "s11-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000

description "user26 mailbox"
end mailbox
end

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Prompt BACD para los solos Autos Attendant que no juegan

Si el archivo BACD está en el flash: la carpeta /bacdprompt/, publica el flash inglés de la ubicación del paramspace: comando /bacdprompt/ en el servicio AA.


Información Relacionada


Document ID: 67907