Colaboración : Cisco Agent Desktop

El Cisco Agent Desktop desconecta todos los agentes simultáneamente

23 Octubre 2015 - Traducción Automática
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Contenido


Introducción

Este documento describe una razón del Cisco Agent Desktop para desconectar todos los agentes simultáneamente de sus respectivas sesiones en un entorno para empresas de Cisco IP Contact Center (IPCC). Este documento también proporciona una solución alternativa posible.

Nota: Para más información sobre la resolución de este problema, refiera al Id. de bug Cisco CSCsa79930 (clientes registrados solamente).

prerrequisitos

Requisitos

Cisco recomienda que tenga conocimiento sobre estos temas:

  • Edición para Empresas del IPCC de Cisco

  • Cisco Agent Desktop

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Versión 6.x y anterior del Edición para Empresas del IPCC de Cisco

  • Versión 6.x y anterior del Cisco Agent Desktop

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Antecedentes

Los Centros de contacto ordenan los agentes en los grupos de capacidades. Los agentes en cada grupo de capacidades se entrenan para manejar los tipos específicos de llamadas. Por ejemplo, las peticiones de la literatura se rutean a los grupos de capacidades en quienes los agentes se entrenan para proporcionar los servicios informativos de información general. Semejantemente, las llamadas que implican las transacciones complicadas se rutean a grupos de capacidades especializados.

Aquí está la Configuración general en la cual este problema ocurre:

Figura 1: Edición de IPCC Enterprise

skildelete_01.gif

Problema

Todos los agentes configurados para trabajar en el Centro de contacto pierden la Conectividad al Cisco Agent Desktop al mismo tiempo. Los agentes incluyen:

  • Agentes que funcionan con el Cisco Agent Desktop en su PC.

  • Agentes que funcionan con el Cisco Agent Desktop en un entorno del cliente liviano del Citrix.

Cuando ocurre la desconexión total, los agentes necesitan reajustar los teléfonos, y el registro nuevamente dentro del Cisco Agent Desktop.

Además de la desconexión total, el proceso de Open Peripheral Controller (OPC) en Peripheral Gateway (PG) causa un crash con un volcado del Dr.Watson.

11:12:24 PG1A-opc Trace: Agent::GetSessionTimes - SkillGroup 40424 (0x9DE8)
priority=0 unknown for agent 1428 on Peripheral 5000. 

Causa

Cuando usted revisa abre una sesión el PG, marcan si un grupo de capacidades fue quitado. Aquí está la sección pertinente del registro de la traza OPC:

11:12:20 PG1A-opc UPDATED 1 SkillGroups. 
11:12:20 PG1A-opc UPDATED 1 Routes. 
11:12:20 PG1A-opc UPDATED 5 Agents. 
11:12:20 PG1A-opc REMOVED 1 SkillGroups.

El retiro de un grupo de capacidades hace el proceso OPC causar un crash. Aquí está la sección pertinente del registro de la traza OPC:

11:12:24 PG1A-opc Trace:
Agent::GetSessionTimes - SkillGroup 40424 (0x9DE8) priority=0
unknown for agent 1428 on Peripheral 5000. 

La caída del proceso OPC a su vez causa la desconexión total del agente.

Solución

La mejor práctica que Cisco recomienda es borrar a un grupo de capacidades solamente cuando terminan una sesión a todos los agentes que pertenecen a ese grupo de capacidades.

Complete estos pasos para evitar el problema de desconexiones masivas del Cisco Agent Desktop:

  1. Programe una ventana de mantenimiento cuando usted quiere borrar a los grupos de capacidades.

  2. Notifique a todos los agentes miembros en el grupo de capacidades para terminar una sesión del Cisco Agent Desktop.

  3. Borre al grupo de capacidades.

  4. Notifique los agentes para iniciar sesión otra vez.

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