Voz : Protocolo de control de gateway de medios (MGCP)

Configuración de Trunks Q.SIG PRI entre Call Manager y Avaya S8700/G650 con Integración de Correo de Voz de Unity

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (11 Noviembre 2015) | Comentarios


Contenido


Introducción

El objetivo de este documento es proporcionar a los clientes de Cisco y los partners comerciales los pasos para configurar trunks Q.SIG PRI entre Cisco Call Manager y Avaya S8700/G650. A su vez, este documento explica los pasos necesarios para agregar Cisco Unity en la plataforma Cisco Call Manager para proporcionar soporte de correo de voz a los teléfonos IP de Cisco y Avaya. Esto es especialmente importante en situaciones en las que se requiere interoperabilidad IP-PBX e integración de correo de voz. Las capturas de pantalla de la configuración de Avaya se crearon con la herramienta de emulación estándar. De forma alternativa, también puede utilizar la herramienta Avaya Site Administration (ASA) para las tareas de configuración del Avaya S8700/G650. La visualización de salida es la misma en ambos casos. Este documento de interoperabilidad IP-PBX e integración de correo de voz está pensado para uso externo.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • El sistema del Avaya IP-PBX usado es el administrador de comunicación Avaya corriente 2.0 del Avaya S8700/G650. El conjunto de características Q.SIG viene estándar con esta versión de software.

  • Los Teléfonos IP del Avaya usados en este documento son la versión de firmware corriente 2.01 4610SW y del teléfono 4620.

  • El Cisco Call Manager 4.1.(2) fue utilizado para controlar el gateway del Media Gateway Control Protocol (MGCP) 3745 con el módulo NM-HDV, versión 12.2.15ZJ3 corriente de Cisco IOS�. Las pruebas también fueron relanzadas con la versión 12.3.8.T5 de Cisco IOS�.

  • La versión 4.0(4) corriente SR1 del Cisco Unity fue utilizada para la prueba de la integración de correo de voz.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configuración de prueba

El sistema del Avaya IP-PBX usado era el administrador de comunicación Avaya corriente 2.0 del Avaya S8700/G650. El conjunto de características Q.SIG viene estándar con esta versión de software. Los teléfonos de AvayaIP usados eran la versión de firmware corriente 2.01 4610SW y del teléfono 4620. En el lado de Cisco, el Cisco Call Manager 4.1.2 fue utilizado para controlar el gateway MGCP 3745 con el módulo NM-HDV, versión 12.2.15ZJ3 corriente de Cisco IOS�. Las pruebas también fueron relanzadas con la versión 12.3.8.T5 de Cisco IOS�. La versión 4.0(4) corriente SR1 del Cisco Unity fue utilizada para la prueba de la integración de correo de voz.

Topología de prueba

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-top.gif

Interoperabilidad entre Cisco y los sistemas del Avaya IP-PBX

Las siguientes secciones proporcionan los procedimientos y a las capturas de pantalla para ayudarle a configurar el trunk Q.SIG entre un administrador de comunicación Avaya corriente 2.0 del Avaya S8700/G650 y una versión del administrador de la llamada del funcionamiento de la plataforma del Cisco Call Manager 4.1(2) con el dispositivo MGCP del Cisco 3745 que proporciona la conexión física ISDN PRI al Avaya S8700/G650.

Procedimiento en el sistema del Avaya S8700/G650 IP-PBX

Complete estos pasos:

  1. Inicie sesión al servidor S8700. Funcione con el comando display system-parameters customer para asegurarse de que todas las características necesarias Q.SIG están habilitadas en el servidor S8700.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-proced1.gif

  2. Configure el indicador luminoso LED amarillo de la placa muestra gravedad menor DS1 para Q.SIG PRI.

    2.gif

  3. Configure a un grupo troncal. El tipo agrega al grupo troncal # donde # está el trunk deseado.

    Las tres capturas de pantalla siguientes se relacionan con la configuración del tronco. Una vez que crean al grupo troncal, agregue los 23 canales del DS0 al grupo. Éste es un ejemplo de la asignación de puertos: 01A0901 significa: Gateway# 1, cabina A, slot- 9, group1 del channel# del DS0.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-3.gif

    4.gif

    5.gif

  4. Agregue el grupo y la punta de señalización al grupo troncal creado anterior.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-6.gif

  5. Agregue al patrón de ruta y señálelo al grupo de señalización. En este ejemplo, el patrón de ruta 4 señala a señalar el group- 1 que fue creada en el paso 4.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-7.gif

  6. Agregue una entrada en la tabla AAR para utilizar al patrón de ruta que usted creó para rutear las llamadas. En este ejemplo, las llamadas a la extensión 4XXX del Cisco IP Phone utilizan la entrada de tabla AAR que comienza con 4, que a su vez señala al patrón de ruta # 4.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-8.gif

  7. Asegúrese que el Identificador de llamada esté habilitado en cada teléfono del IP para enviar el nombre de la parte llamadora.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-9.gif

Procedimiento en el Cisco Call Manager

Complete estos pasos:

  1. Bajo parámetros de servicio, aseegurese que los valores del mínimo y de tiempo máximo del reemplazo de la trayectoria del comienzo están fijados apropiadamente para prevenir cualquier problema (tal como conexión mediante pines).

    Las dos capturas de pantalla siguientes se relacionan con las configuraciones de los parámetros de servicio Q.SIG:

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-10.gif

    11.gif

  2. Agregue el Cisco 3745 como gateway MGCP y configure el módulo T-1 NM-HDV para el Q.SIG PRI.

    Las cinco capturas de pantalla siguientes se relacionan con esta configuración:

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-2.gif

    13.gif

    15.gif

    16.gif

    17.gif

  3. Como último paso, cree un grupo de la recogida del Cisco Call Manager para proporcionar una extensión de propuesta del trayecto al PBX. Aseegurese que el número de la atención de llamadas también está ingresado en id de reemplazo del PINX del trayecto el parámetro de servicio (véase al step# 1). También, el sistema Avaya necesita a un patrón de ruta para rutear al grupo de la recogida.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-8.gif

    Nota: Aseegurese que estos dos parámetros clusterwides (dispositivo - PRI y gateway MGCP) bajo parámetros del servicio CallManager de Cisco (avanzados) hacen juego la configuración Q.SIG en el PBX. Todos los troncales de PBX se deben configurar exactamente como estos parámetros del Cisco CallManager.

    • Codificación ASN.1 ROSE OID: Este parámetro especifica cómo codificar el ID del objeto de la invocación (OID) para el elemento de servicio de las operaciones remotas (ROSE). Guarde este parámetro configurado al valor predeterminado a menos que un ingeniero de soporte de Cisco dé instrucciones de otra manera. Éstos son un campo obligatorio y el valor por defecto es valor del Local del uso.

      Éstos son los valores válidos para este parámetro:

      • Utilice el valor local, que es soportado por la mayoría de los sistemas de telefonía y debe ser utilizado cuando el parámetro de servicio variable Q.SIG se fija a ISO (perfil 0x9F del protocolo).

      • Utilice el valor global (ISO), se utiliza que solamente si el PBX conectado no soporta el valor del Local del uso.

      • Utilice el valor global (ECMA), que debe ser utilizado si el parámetro de servicio variable Q.SIG se fija a ECMA (perfil 0x91 del protocolo).

    • Variante Q.SIG: Este parámetro especifica el perfil del protocolo enviado en los elementos de información salientes del recurso Q.SIG cuando el trunk se configura para el Q.SIG. Guarde este parámetro configurado al valor predeterminado a menos que un ingeniero de soporte de Cisco dé instrucciones de otra manera. Esto es un campo obligatorio, y el valor por defecto es ISO (perfil 0x9F del protocolo).

      Éstos son los valores disponibles para este parámetro:

      • ECMA (perfil 0x91 del protocolo), que se utiliza típicamente con ECMA PBX y puede utilizar solamente el perfil 0x91 del protocolo. Si este parámetro de servicio se fija a ECMA (perfil 0x91 del protocolo), el parámetro de servicio de la codificación ASN.1 Rose OID se debe fijar para utilizar el valor global (ECMA).

      • ISO (perfil 0x9F del protocolo), que es la recomendación ISO actual. Si este parámetro se fija a ISO (perfil 0x9F del protocolo), después el parámetro de servicio de la codificación ASN.1 Rose OID se debe fijar para utilizar el valor local.

        Advertencia: El Cisco CallManager no soporta el ECMA al usar los troncos entre clústers con el campo definido tunneled del protocolo al Q.SIG en la ventana de la configuración del tronco en la administración del CallManager. Si usted fijó este parámetro de servicio a ECMA (perfil 0x91 del protocolo), todos los troncos entre clústers deben tener el campo definido tunneled del protocolo a ningunos.

        qsig.gif

Configuración del Cisco 3745

Éste es el comando show version y show running-configuration hecho salir en el dispositivo MGCP del Cisco 3745. El T1 1/0 del regulador en el Cisco 3745 está conectado con el indicador luminoso LED amarillo de la placa muestra gravedad menor DS1 PRI del Avaya S8700/G650. La señalización Q.SIG se configura en el link PRI entre el Cisco 3745 y el Avaya S8700/G650.

CCME_CUE_3745# sh vers
Cisco Internetwork Operating System Software 
IOS (tm) 3700 Software (C3745-IS-M), Version 12.2(15)ZJ3, EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Thu 25-Sep-03 22:25 by eaarmas
Image text-base: 0x60008954, data-base: 0x61C2C000

ROM: System Bootstrap, Version 12.2(8r)T2, RELEASE SOFTWARE (fc1)
ROM: 3700 Software (C3745-IS-M), Version 12.2(15)ZJ3, EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)

CCME_CUE_3745 uptime is 39 minutes
System returned to ROM by reload
System image file is "flash:c3745-is-mz.122-15.ZJ3.bin"

cisco 3745 (R7000) processor (revision 2.0) with 246784K/15360K bytes of memory.
Processor board ID JMX0814L3E2
R7000 CPU at 350Mhz, Implementation 39, Rev 3.3, 256KB L2, 2048KB L3 Cache
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
Primary Rate ISDN software, Version 1.1.
2 FastEthernet/IEEE 802.3 interface(s)
25 Serial network interface(s)
1 terminal line(s)
2 Channelized T1/PRI port(s)
1 ATM AIM(s)
2 Voice FXS interface(s)
2 Voice E & M interface(s)
1 cisco service engine(s)
DRAM configuration is 64 bits wide with parity disabled.
151K bytes of non-volatile configuration memory.
125184K bytes of ATA System CompactFlash (Read/Write)
Configuration register is 0x2102

CCME_CUE_3745# sh run
Building configuration...

Current configuration : 3291 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CCME_CUE_3745
!
logging queue-limit 100
!
voice-card 1
 dspfarm
!
voice-card 5
 dspfarm
!
ip subnet-zero
!
!
no ip domain lookup
!
isdn switch-type primary-qsig
!
no voice hpi capture buffer
no voice hpi capture destination 
!
!
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 172.28.221.18  
ccm-manager config
mta receive maximum-recipients 0
!
!
controller T1 1/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 1/1
 framing sf
 linecode ami
!
!
!
interface FastEthernet0/0
 description CCME-CUE-3745_to_cat3550
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 99
!
interface FastEthernet0/0.2
 description NEW_S8700_G650
 encapsulation dot1Q 300
 ip address 172.28.221.49 255.255.255.240
 ip helper-address 172.28.221.19
 h323-gateway voip bind srcaddr 172.28.221.49
!
interface FastEthernet0/0.3
 description MODULAR_MESSAGING_SOLUTION
 encapsulation dot1Q 900
 ip address 172.28.221.129 255.255.255.240
 ip helper-address 172.28.221.19
!
interface FastEthernet0/0.4
 encapsulation dot1Q 301
 ip address 10.1.3.1 255.255.255.128
 ip helper-address 172.28.221.19
!
interface FastEthernet0/0.5
 encapsulation dot1Q 302
 ip address 10.1.3.129 255.255.255.128
 ip helper-address 172.28.221.19
!
interface FastEthernet0/0.6
 encapsulation dot1Q 90
 ip address 90.1.1.254 255.255.255.0
 ip helper-address 172.28.221.19
!
interface Serial0/0
 description CCME-CUE-3745_to_3600
 ip address 25.0.0.1 255.0.0.0
 clockrate 256000
 no fair-queue
!
interface Serial1/0:23
 no ip address
 no logging event link-status
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 isdn bchan-number-order ascending
 no cdp enable
!
interface Service-Engine2/0
 no ip address
 shutdown
!
router eigrp 100
 network 10.0.0.0
 network 25.0.0.0
 network 90.0.0.0
 network 172.28.0.0
 auto-summary
!
ip http server
ip classless
!
call rsvp-sync
!
voice-port 1/0:23
!
voice-port 4/0/0
!
voice-port 4/0/1
!
voice-port 4/1/0
!
voice-port 4/1/1
!
mgcp
mgcp call-agent 172.28.221.18 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp package-capability rtp-package
no mgcp package-capability res-package
mgcp package-capability sst-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
!
mgcp profile default
!
!
!
dial-peer cor custom
!
dial-peer voice 1 pots
 application mgcpapp
 port 1/0:23
!
dial-peer voice 999410 pots
 application mgcpapp
 port 4/1/0
!
!
line con 0
 password cisco
 login
line 65
 flush-at-activation
 no activation-character
 no exec
 transport preferred none
 transport input all
line aux 0
line vty 0 4
 password cisco
 login
!
end

Características probadas para la Interoperabilidad entre Cisco y los sistemas del Avaya IP-PBX

Esta sección proporciona una lista de características probadas entre la plataforma y el administrador corriente 2.0 del Cisco Call Manager 4.1(2) de la comunicación del Avaya S8700/G650 por el tronco PRI Q.SIG:

  • Visualización del nombre y del número (bidireccional)

  • Transferencia de Llamadas

  • Llamada en conferencia entre los dos sistemas

Integración del correo de voz del Cisco Unity para soportar Cisco y los Teléfonos IP del Avaya

En este momento, uno puede utilizar el trunk Q.SIG para hacer las llamadas entre un administrador de comunicación Avaya corriente 2.0 del Avaya S8700/G650 y una versión del administrador de la llamada del funcionamiento de la plataforma del Cisco Call Manager 4.1(2) con el dispositivo MGCP del Cisco 3745 que proporciona a la conexión física ISDN PRI al Avaya S8700/G650. Un servidor del Cisco Unity se puede agregar en la plataforma del Cisco Call Manager para proporcionar el soporte del correo de voz a Cisco y a los Teléfonos IP del Avaya. Para habilitar esto, el administrador necesita configurar el Cisco Unity en la plataforma del Cisco Call Manager. Esta sección incluye los procedimientos con las capturas de pantalla para que cómo configure el Cisco Unity en la página de la Administración de la administración del Cisco Call Manager.

Nota:  La mayor parte de la configuración se realiza en el Asisitente del puerto de correo de voz de Cisco.

Agregue el Cisco Unity al Cisco Call Manager

Complete estos pasos:

  1. Bajo característica, seleccione el correo de voz > al Asisitente del puerto de correo de voz. Selecto cree a un nuevo servidor de correo de voz y agregue los puertos a él y haga clic después.

    19.gif

  2. Ingrese un nombre de servidor de correo de voz de Cisco, tal como AvayaUM3, y haga clic después.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-20.gif

  3. Seleccione el número de puertos de correo de voz deseados y haga clic después.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-21.gif

  4. Ingrese una descripción y a una agrupación de dispositivos para los puertos de correo de voz. En la configuración de muestra, el Avaya VMailPorts fue ingresado como la descripción y el valor por defecto como la agrupación de dispositivos.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-4.gif

  5. Ingrese el número de directorio que comienza, tal como 4406, y la visualización, tal como correo de voz, y haga clic después.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-2.gif

  6. La siguiente pantalla pide, “usted quiere agregar estos números de directorio a una línea grupo?” Seleccione . Agregue los números de directorio a un grupo de línea nueva y haga clic después.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-3.gif

  7. Ingrese una línea nombre del grupo que corresponda con al servidor de correo de voz que usted ingresó previamente, por ejemplo AvayaUM3.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-4.gif

  8. La siguiente pantalla muestra la configuración ingresada hasta ahora. Clic en Finalizar si no hay cambios a la configuración.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-5.gif

  9. El tecleo agrega una nueva lista de la caza en la página Web de administración de la lista de la caza.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-6.gif

  10. Ingrese un nombre de la lista y una descripción de la caza, tal como Avaya VMailHL. También, seleccione el valor por defecto para el grupo del Cisco Call Manager.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-7.gif

  11. Esta captura de pantalla es el resultado del agregado satisfactorio de la lista de la caza. El tecleo agrega la línea grupo.

    28.gif

  12. Seleccione la línea grupo configurado previamente. En este caso, es AvayaUM3.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-9.gif

  13. La captura de siguiente pantalla muestra el resultado de la inserción exitosa de la línea grupo.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-30.gif

  14. Vaya a la ruta Plan > a la ruta/a la caza > al piloto de la caza. El tecleo agrega a un nuevo piloto de la caza de la pantalla del piloto de la caza que resulta.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-31.gif

  15. Ingrese en el piloto de la caza, tal como 4408, y seleccione una lista de la caza, tal como HL de VMail del Avaya y separador de millares del tecleo.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-2.gif

  16. Vaya a la característica > al correo de voz > al correo de voz piloto y el tecleo agrega a un nuevo correo de voz piloto en la pantalla que resulta.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-3.gif

  17. Ingrese el número del correo de voz piloto que corresponde con el número piloto de la caza configurado previamente. En este caso, los números del piloto y del correo de voz piloto de la caza son 4408.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-4.gif

  18. Vaya a la característica > al correo de voz > al perfil del correo de voz y el tecleo agrega un nuevo perfil del correo de voz.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-5.gif

  19. Ingrese el nombre y la descripción del perfil del correo de voz, tal como AvayaVMailProfile, y seleccione el número del correo de voz piloto en el paso 17. En este caso, el número del correo de voz piloto es 4408.

    36.gif

  20. Haga clic las características > el correo de voz > el indicador de mensaje en espera > Add un número que espera del nuevo mensaje para agregar los números con./desc. del indicador de mensaje en espera (MWI). Aquí incluyen a dos capturas de pantalla para los números con./desc. del indicador de mensaje en espera.

    37.gif

    38.gif

Características del correo de voz del Cisco Unity probadas

Ésta es una lista de características del correo de voz del Cisco Unity probadas con los Teléfonos IP del Avaya usados para acceder el correo de voz del Cisco Unity por el tronco PRI Q.SIG entre la plataforma y el administrador corriente 2.0 del Cisco Call Manager 4.1(2) de la comunicación del Avaya S8700/G650:

  • Saludo interno

  • Saludo ocupado

  • MWI

  • Acceso fácil del mensaje

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 63790