Módulos e interfaces de Cisco : Módulo de switching de contenido de Cisco

RHI en el ejemplo de configuración del módulo content switching

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (30 Septiembre 2014) | Comentarios


Contenido


Introducción

Este documento proporciona un ejemplo de configuración para la inyección de la salud de la ruta (RHI) en un Cisco Content Switching Module (CS).

El RHI permite que el CS haga publicidad de la Disponibilidad del direccionamiento a IP virtual (VIP) en la red. Los dispositivos múltiples CSM con los direccionamientos y los servicios idénticos VIP pueden existir en la red. Un CS puede reemplazar los servicios del Equilibrio de carga de servidores (SLB) sobre los otros dispositivos si los servicios están no más disponibles en los otros dispositivos. Un CS también puede proporcionar los servicios porque está lógicamente más cercano a los sistemas del cliente que otros dispositivos SLB. El CS hace publicidad del direccionamiento VIP como una ruta del host.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información en este documento se basa en la versión ejecutable CSM 3.x o 4.x.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/60043/rhi_csm.jpg

Configuraciones

En este documento, se utilizan estas configuraciones:

  • Catalyst A

  • Catalyst B

Catalyst A
hostname Catalyst A
!
module ContentSwitchingModule 4 
!
 vlan 10 server
  ip address 10.1.10.97 255.255.254.0
!
 vlan 20 client
  ip address 10.1.20.1 255.255.255.0
  gateway 10.1.20.2
!
 probe LINUXPING icmp


!--- This probe is to verify that the servers are alive. This could be any 
!--- type of probe.

!
 serverfarm MYLINUX
  nat server
  no nat client
  real 10.1.10.3
   inservice
  real 10.1.10.4
   inservice
  probe LINUXPING
!
 vserver RHITEST
  virtual 192.168.1.1 any
  vlan 20


!--- The VLAN is important. When the VIP address is not part of the subnet
!--- of any VLAN configured on the CSM, the VLAN is used to tell the CSM on 
!--- which VLAN the traffic is coming in. This allows the CSM to set the 
!--- next-hop correctly when configuring the static route on the MSFC.

  serverfarm MYLINUX
advertise active



!--- The advertise command tells the CSM to create the static route.
!--- If you specify the active option, the static route is created only 
!--- if the vserver is operational.

  inservice
!    
interface Vlan20
 ip address 10.1.20.2 255.255.255.0
 no ip proxy-arp
!
interface Vlan30
 ip address 10.1.30.97 255.255.254.0
 no ip proxy-arp
!
router ospf 1


!--- In this example, OSPF is used to advertise the VIP through the network.
!--- You can use any IGP however.

 log-adjacency-changes
 redistribute static metric 10 subnets


!--- Since the CSM creates a static route on the MSFC, you simply need to 
!--- redistribute static routes to advertise the VIP.

 network 10.1.0.0 0.0.255.255 area 1
!

La configuración de Catalyst B es idéntica al Catalyst A. El IP Addressing es levemente diferente porque el Catalyst B está en una diversa área de la red. El direccionamiento VIP es lo mismo sin embargo. El métrico de las Static rutas redistribuidas también fue cambiado de modo que el Catalyst A sea el trayecto preferido al VIP, y el Catalyst B sea la solución de backup.

Catalyst B
hostname Catalyst B
!
module ContentSwitchingModule 4 
!
 vlan 10 server
  ip address 10.2.10.97 255.255.254.0
!
 vlan 20 client
  ip address 10.2.20.1 255.255.255.0
  gateway 10.2.20.2
!
 probe LINUXPING icmp
!
 serverfarm MYLINUX
  nat server
  no nat client
  predictor hash address source
  real 10.2.10.3
   inservice
  real 10.2.10.4
   inservice
  probe LINUXPING
!
 vserver RHITEST
  virtual 192.168.1.1 any
  vlan 20
  serverfarm MYLINUX
  advertise active
  inservice
!    
interface Vlan20
 ip address 10.2.20.2 255.255.255.0
 no ip proxy-arp
!
interface Vlan30
 ip address 10.2.30.97 255.255.254.0
 no ip redirects
 no ip proxy-arp
!
router ospf 1
 log-adjacency-changes
 redistribute static metric 20 subnets
 network 10.2.0.0 0.0.255.255 area 2
!

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • muestre los parásitos atmosféricos de la ruta de IP — Publique este comando de ver las Static rutas creadas por el CS para cada vserver configurado con el comando advertise. Si usted no ve ninguna rutas, aseegure el vserver es operativo y eso allí es un VLA N especificado bajo el vserver.

    SwitchA#show ip route static 
         192.168.1.0/32 is subnetted, 1 subnets
    S       192.168.1.1 [1/0] via 10.1.20.1, Vlan20
    SwitchA#
  • muestre el detalle del NOMBRE del nombre del vserver Mod csm X

    SwitchB#sho mod csm 4 vservers name rhitest
    
    vserver         type  prot virtual                  vlan state        conns
    ---------------------------------------------------------------------------
    RHITEST         SLB   any  192.168.1.1/32:0         20   OPERATIONAL  0       
    SwitchA#show mod csm 4 probe name linuxping detail
    probe           type    port  interval retries failed  open   receive
    ---------------------------------------------------------------------
    LINUXPING       icmp          120      3       300            10     
     real                  vserver         serverfarm      policy          status
     ------------------------------------------------------------------------------
     10.1.10.4:0        RHITEST         MYLINUX         (default)       OPERABLE
     10.1.10.3:0        RHITEST         MYLINUX         (default)       OPERABLE
  • muestre el detalle del NOMBRE del nombre de la sonda Mod csm X

  • la base de datos OSPF del IP de la demostración uno mismo-origina — Publique este comando de verificar que el OSPF está haciendo publicidad del direccionamiento VIP.

    SwitchA#sho ip ospf database self-originate 
    
                OSPF Router with ID (10.1.30.97) (Process ID 1)
    
                    Router Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum Link count
    10.1.30.97      10.1.30.97      5           0x80000001 0x00B9BE 2
    
                    Type-5 AS External Link States
    
    Link ID         ADV Router      Age         Seq#       Checksum Tag
    192.168.1.1     10.1.30.97      5           0x80000001 0x00CCC7 0
  • muestre la ruta de IP x.x.x.x

  • muestre la base de datos OSPF del IP extern x.x.x.x

    lsd#sho ip ospf database external 192.168.1.1
    
                OSPF Router with ID (200.200.200.200) (Process ID 1)
    
    
                    Type-5 AS External Link States
    
      Routing Bit Set on this LSA
      LS age: 39
      Options: (No TOS-capability, DC)
      LS Type: AS External Link
      Link State ID: 192.168.1.1 (External Network Number )
      Advertising Router: 10.1.20.97
      LS Seq Number: 80000001
      Checksum: 0x8310
      Length: 36
      Network Mask: /32
            Metric Type: 2 (Larger than any link state path)
            TOS: 0 
            Metric: 20 
            Forward Address: 10.2.20.1
            External Route Tag: 0
    
      Routing Bit Set on this LSA
      LS age: 89
      Options: (No TOS-capability, DC)
      LS Type: AS External Link
      Link State ID: 192.168.1.1 (External Network Number )
      Advertising Router: 10.1.30.97
      LS Seq Number: 80000001
      Checksum: 0xCCC7
      Length: 36
      Network Mask: /32
            Metric Type: 2 (Larger than any link state path)
            TOS: 0 
            Metric: 10 
            Forward Address: 10.1.20.1
            External Route Tag: 0

Troubleshooting

No hay actualmente información de Troubleshooting específica disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 60043