Entrega de contenido y video : Cisco Universal Broadband Routers (uBR) de la serie 7200

Servicio de LAN transparente sobre las redes de cable

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Tradicionalmente, el Sistema de finalización del cable módem de Cisco (CMTS) se ha utilizado para proporcionar los servicios de datos de alta velocidad para los usuarios caseros y para el Redes privadas virtuales (VPN) basado en IP de la capa 3.

Hay, sin embargo, algunos clientes que necesitan las conexiones de la capa 2 ejecutar sus negocios.

Algunas de las razones para alinear el despliegue de una capa 2 Virtual Private Network (L2VPN) incluyen:

  • Soporte para los protocolos del non-IPv4

  • Encripción de extremo a extremo

  • Más control de red

  • Uso de un espacio de IP Address privado

Típicamente, acode 2 servicios son proporcionados por la compañía telefónica (compañía telefónica) y emplean diversas Tecnologías, tales como líneas arrendadas, Frame Relay, ISDN, atmósfera, y otras.

Con la introducción de la característica del Servicio de LAN transparente (TLS) del 802.1Q, el Operador de servicio múltiple (MSO) puede leverage sus implementaciones de DOCSIS para proporcionar los servicios L2VPN y de tal modo para aumentar sus ofrendas comerciales.

prerrequisitos

Requisitos

Quienes lean este documento deben tener conocimiento de los siguientes temas:

  • Software Release 12.2(15)BC2 del ½ del ¿Â de Cisco IOSïÂ

  • plataforma del uBR7200VXR

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco uBR7246 VXR Universal Broadband Router

  • Cisco Catalyst 2924-XL (fin de la vida útil)

  • Cisco 7206VXR Router

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

¿Cuál es 802.1Q TLS sobre el cable?

La característica de TLS del 802.1Q proporciona los medios de crear los L2VPN entre los sitios múltiples, similares a las líneas arrendadas privadas, Frame Relay, ISDN, las atmósferas, S DS, y similares que son ofrecidas por las compañías telefónicas.

En muchos casos, TLS se puede ver como “Frame Relay - como” el servicio. Puede acomodar a muchos patrones de tráfico, tales como Punto a punto, punta a de múltiples puntos, o enredó completamente.

El cuadro 1 muestra cómo un despliegue de TLS del 802.1Q parece conceptual un VLA N.

Figura 1

/image/gif/paws/60027/tls_over_cable_01.gif

Drivers del mercado

El driver principal para la adopción de esta característica es el potencial para aumentar las secuencias de entrada.

La característica de TLS del 802.1Q permite que un MSO compita con las compañías telefónicas proporcionando un servicio L2VPN que pueda ser al final un cliente más económico.

La huella MSO toca ya muchas áreas comerciales en su despliegue. Muchos de esos negocios inscriben ya a los servicios de la televisión por cable y a los servicios existentes de la capa 2 de una compañía telefónica.

Estos servicios de la compañía telefónica L2 tienden a tener costos que se repiten, tales como acceso del local loop, acceso del puerto del switch, y así sucesivamente.

En la mayoría de los casos, el despliegue de un servicio de TLS del 802.1Q puede ser tan fácil como esto:

  1. Caiga un módem de cable en el sitio del cliente.

  2. Provision correctamente el engranaje del establecimiento de una red MSO.

Para hacer el ofrecimiento de más atractivo y comercial, el MSO puede elegir liar la televisión por cable y TLS.

¿Cómo la operación de TLS del 802.1Q trabaja?

En una configuración del 802.1Q TLS, el módem de cable de un cliente específico es aprovisionado con los métodos de aprovisionamiento estándar que son delineados por el DOCSIS.

Además del aprovisionamiento, el CMTS se configura con las definiciones que se conocen como las correspondencias del dot1q. Las correspondencias del dot1q contienen la dirección MAC del módem de cable, el VLAN ID, y la interfaz de salida. Estas definiciones (o los atascamientos) se propagan en la base de datos del ID del servicio (SID).

Trafique que está viniendo de un módem de cable específico se marca con etiqueta con un VLAN ID y después se envía en la red, donde puede ser interligada con otros VLA N del mismo cliente. Hay vario manera de lograr el VLAN Bridging.

El cuadro 2 representa una topología Point-to-Point L2VPN, para ilustrar cómo TLS trabaja.

Figura 2

/image/gif/paws/60027/tls_over_cable_02.gif

En cada CMTS hay una definición de la correspondencia del dot1q que ata la dirección MAC del módem de cable con un VLAN ID y una interfaz de salida.

Suponga que usted localiza un paquete del sitio A para localizar B; los eventos siguientes explican cómo el CMTS A procesa el tráfico del sitio A:

  1. El módem de cable toma la trama Ethernet y agrega un encabezamiento DOCSIS, que incluye el módem de cable SID (o SFID).

  2. Cuando se recibe el tráfico, el CMTS realiza una búsqueda SID.

  3. El CMTS determina si el tráfico es TLS, sobre la base del SID.

  4. Si el tráfico es TLS, el CMTS mira en el paquete y marca para saber si hay el MAC Address de origen.

    1. Si la dirección MAC hace juego la dirección MAC del módem de cable, después el tráfico se envía al Layer 3 Switching Code.

    2. Si la dirección MAC no hace juego la dirección MAC del módem de cable, después el tráfico se marca con etiqueta con la etiqueta apropiada del VLA N y se envía en la interfaz de salida apropiada.

En el CMTS B, el paquete que está viniendo del sitio A se procesa de esta manera:

  1. Cuando el CMTS recibe una trama VLA N-marcada con etiqueta, realiza una búsqueda de base de datos para determinar si el VLA N está asociado a un módem de cable.

  2. Si se encuentra una coincidencia, después el CMTS quita la etiqueta del VLA N y agrega un encabezamiento DOCSIS.

  3. El proceso CMTS el nuevo paquete de DOCSIS, ajustarse a CoS o a los parámetros de QoS apropiados.

  4. El paquete entonces se envía en la interfaz del cable.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

El cuadro 3 ilustra la topología de red usada en las configuraciones y verifica las secciones.

Figura 3

tls_over_cable_03.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

  1. CMTS A

  2. CMTS B

  3. Switch

  4. Router de agrupamiento

CMTS A
UBR-1:
!
cable l2-vpn-service dot1q
cable dot1q-vc-map 0000.3973.be53 FastEthernet0/1 12 
!

CMTS B
UBR-2:
!
cable l2-vpn-service dot1q
cable dot1q-vc-map 0000.39a7.8a67FastEthernet0/0 21 
!

Switch
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!         
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!         
interface FastEthernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!         

SW# show vlan id 12

00:44:03: %SYS-5-CONFIG_I: Configured from console by console
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
12   VLAN0012                         active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
12   enet  100012     1500  -      -      -        -    -        0      0   

SW# show vlan id 21

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
21   VLAN0021                         active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
21   enet  100021     1500  -      -      -        -    -        0      0

Router de agrupamiento
!         
bridge irb
!         
!         
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!         
interface FastEthernet0/1.12
 encapsulation dot1Q 12
 bridge-group 1
!         
interface FastEthernet0/1.21
 encapsulation dot1Q 21
 bridge-group 1
!         
bridge 1 protocol ieee
!

Verificación

Esta sección proporciona la información que usted puede utilizar para confirmar que su configuración está trabajando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Inicialización del módem de cable

Cuando viene el módem que ha sido aprovisionado para el 802.1Q TLS en línea, se crea una correspondencia que ata el módem a un VLAN ID y a una interfaz de salida.

Publique estos comandos debug de verificar la asignación:

Esta salida muestra cómo el CMTS asocia el VLA N y la interfaz de salida, cuando viene el módem de cable en línea. También muestra el rio abajo y el flujo de servicio ascendente ID que se asocian al VLA N.


!--- Logs from CMTS A (UBR-1):

UBR-1# show debug

CMTS:
  CMTS L2 VPN debugging is on
CMTS specific:
  Debugging is on for Address 0000.3973.be53, Mask ffff.ffff.ffff

UBR-1#

cmts_l2vpn_init_cm: cm 0000.3973.be53 on Cable3/0, sid 0xA
map to FastEthernet0/1 VLAN id 12
 Mapped DS srv flow 22 on Cable3/0 to FastEthernet0/1 VLAN 12
 Mapped US srv flow 21 sid 10 on Cable3/0 to FastEthernet0/1 VLAN 12

Aprobación del tráfico

Para ver si ese tráfico está viniendo del módem de cable o destinado al módem de cable, usted puede hacer el debug de lo o la mirada en los contadores.

Para hacerlo el debug de, gire estos debugs:

Nota: Estos debugs están solamente disponibles en la plataforma del ubr7200.

La salida de próximo ejemplo muestra el debug de un paquete del sitio A para localizar B, cuando usted activa el MAC address del MAC address del cable del debug prolijo y hace el debug del cable l2-vpn condicional.

La primera línea del debug es el paquete originado del sitio A. Porque el paquete es un paquete ping, la línea siguiente del debug es la respuesta al ping. Muestra cómo un paquete se envía al módem de cable.

UBR-1#

Pkt (size 114) from CM 0000.3973.be53 sid 10 src 0008.a3b6.d371
dst 0008.a3b6.d74b fwd to FastEthernet0/1 vlan 12

Send pkt size 118 from 0008.a3b6.d74b on FastEthernet0/1:vlan 12
to 0008.a3b6.d371 on Cable3/0:0xA CM 0000.3973.be53

Para ver los bytes o los contadores de los paquetes, publique el comando show cable l2-vpn dot1q-vc-map mac-address verbose:

UBR-1# show cable l2-vpn dot1q-vc-map 0000.3973.be53 verbose

MAC Address                         : 0000.3973.be53
Customer Name                       :
Prim Sid                            : 5
Cable Interface                     : Cable3/0
Ethernet Interface                  : FastEthernet0/1
DOT1Q VLAN ID                       : 12
Total US pkts                       : 0
Total US bytes                      : 0
Total DS pkts                       : 12
Total DS bytes                      : 816

Troubleshooting

No hay actualmente información disponible específica para resolver problemas esta configuración.

Aspectos del diseño

Hay varios factores de diseño a considerar cuando usted despliega los servicios sobre una red DOCSIS. Algunos son específicos al Lado del cable y los otros son problemas más generales.

Lado del cable (DOCSIS)

Tamaño o producción del tubo

Típicamente, la limitación principal está en el ancho de banda ascendente. El cuadro 1 muestra las figuras aproximadas para los diversos valores de la producción.

Tabla 1

Versión de DOCSIS Ancho del canal (MHz) Modulación Producción aproximada (Mbps)
1.x 1.6 QPSK 2.2
1.x 1.6 16-QAM 4.4
1.x 3.2 16-QAM 8.9
2.0 3.2 64-QAM 13
2.0 6.4 64-QAM 26

La versión de DOCSIS 1.1 ha incorporado muchas características que proporcionan la optimización del canal ascendente. Algunas de esas características incluyen:

  • Concatenación

  • Fragmentación

  • Supresión del encabezado de la carga útil

DOCSIS QoS

Confiado contra mejor esfuerzo — La versión de DOCSIS 1.0 permite una tarifa garantizada en la conexión en sentido ascendente solamente. La versión 1.1 y 2.0 permite una tarifa garantizada en las ambas direcciones. Para garantizar una Velocidad de información comprometida (CIR), el programador CMTS realiza el control de admisión en la conexión en sentido ascendente, para prevenir la suscripción excesiva.

Tiempo de espera y jitter controlados — Las otorgadas no solicitadas de la versión de DOCSIS 1.1's (UGS) proporcionan a Velocidad de bits constante (CBR) - como el servicio. El tiempo de espera y el jitter se pueden controlar con eficacia, para proporcionar una velocidad de datos mínima garantizada para el tráfico que requiere las concesiones en los intervalos fijos.

Seguridad

Trafique que está atravesando a la planta de cable se puede asegurar con el Baseline Privacy Interface (BPI) del DOCSIS, en la versión de DOCSIS 1.0, o el BPI+, en las versiones más recientes del DOCSIS. Entonces, alguien no puede fisgón o escuchar detras de las puertas en los datos sobre el Lado del cable.

Para los clientes que requieren más Seguridad — por ejemplo, las instituciones financieras y similares — se recomienda una estrategia del IPSEC de extremo a extremo. Refiera a la Seguridad en Cisco.

Problemas generales

QoS

En un entorno del 802.1Q, hay tres áreas importantes de QoS:

  • Lado CPE — Cómo el CPE limpia y marca el tráfico. Esto es controlada por el cliente y es relevante a sus Internal QoS policyes (política de QoS interna).

  • Lado del cable — Esto se ajusta al protocolo DOCSIS y al aprovisionamiento del módem de cable.

  • Estructura básica — El MSO puede aplicar las directivas de QoS basadas en el Service Level Agreements.

Funcionamiento y scalability

En el CMTS, hay solamente un leve incremento de la memoria para sostener las estructuras de datos y las correspondencias del dot1q (base de datos). La transferencia para los paquetes de TLS es lo mismo que para cualquier otro paquete.

El número de VLA N soportados varía basado en la plataforma.

Interligando a los grupos varíe basado en la plataforma.

Cómo ampliar el 802.1Q TLS mas allá los límites de Ethernet

Habrá las épocas en que los clientes necesitan la Conectividad a los sitios que están más allá de los límites de la comprobación de los Ethernetes; por ejemplo, sitios en los diversos pueblos, ciudades, o estados.

En esos casos, los MSO pueden utilizar una de las varias soluciones del servicio de la retransmisión de los Metros Ethernet.

Dos de esas soluciones que han sido laboratorio probado son:

  • TLS sobre una red de núcleo IP vía la versión 3 del Tunnel Protocol de la capa 2 (L2TP)

  • TLS sobre una base del Multiprotocol Label Switching (MPLS) vía el Ethernet por MPLS (EoMPLS)

Apéndice A - Traza del paquete entre el Switch L2 y el router de agrupamiento

Esta sección muestra una traza del paquete de un paquete ping entre el Switch y el router de agrupamiento. Note que hay dos paquetes de pedido de ping: uno del sitio A al router de agrupamiento, y uno del router de agrupamiento para localizar el B. Lo mismo se aplica a la contestación del ping.

Frame 1 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d3:71, Dst: 00:08:a3:b6:d7:4b
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0000 1100 = ID: 12
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.1 (192.168.50.1),
Dst Addr: 192.168.50.2 (192.168.50.2)
Internet Control Message Protocol
    Type: 8 (Echo (ping) request)
    Code: 0 
    Checksum: 0x3fb9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

Frame 2 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d3:71, Dst: 00:08:a3:b6:d7:4b
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0001 0101 = ID: 21
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.1 (192.168.50.1),
Dst Addr: 192.168.50.2 (192.168.50.2)
Internet Control Message Protocol
    Type: 8 (Echo (ping) request)
    Code: 0 
    Checksum: 0x3fb9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

Frame 3 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d7:4b, Dst: 00:08:a3:b6:d3:71
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0001 0101 = ID: 21
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.2 (192.168.50.2),
Dst Addr: 192.168.50.1 (192.168.50.1)
Internet Control Message Protocol
    Type: 0 (Echo (ping) reply)
    Code: 0 
    Checksum: 0x47b9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

Frame 4 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d7:4b, Dst: 00:08:a3:b6:d3:71
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0000 1100 = ID: 12
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.2 (192.168.50.2),
Dst Addr: 192.168.50.1 (192.168.50.1)
Internet Control Message Protocol
    Type: 0 (Echo (ping) reply)
    Code: 0 
    Checksum: 0x47b9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

Información Relacionada


Document ID: 60027