Servicios de redes de aplicaciones : Switches de servicios de contenido Cisco CSS de la serie 11500

Redundancia de casilla a casilla en el ejemplo de configuración CSS 11xxx

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra para la Redundancia de casilla a casilla 11xxx del Content Services Switch (CSS). La Redundancia de casilla a casilla proporciona la Redundancia del chasis-nivel entre dos CSS idénticamente configurados.

prerrequisitos

Requisitos

Antes de utilizar esta configuración, asegúrese de que cumple con estos requisitos:

  • Ambos CSS que usted está utilizando para esta configuración redundante deben funcionar con la misma versión del código. Diversas versiones del código corrientes no se soportan para la Redundancia.

  • Espere que el comportamiento de los CSS sea /standby (principal) activo (respaldo); solamente los flujos de procesos del master CSS.

  • Usted debe configurar un link dedicado del Fast Ethernet (FE) entre los CSS para el latido del corazón del Virtual Router Redundancy Protocol (VRRP).

  • No utilice el cuadro-a-cuadro si usted requiere la conexión de un dispositivo de la capa 2 entre los pares redundantes CSS. Utilice la redundancia VIP en lugar de otro. Refiera a configurar el VIP y la Redundancia de la interfaz virtual para más información.

Componentes Utilizados

La información en este documento se basa en la versión de SW del CSS 11150: 6.10 Estructura 107.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Productos Relacionados

Esta configuración también se puede utilizar con las siguientes versiones de hardware y software:

  • todo el Cisco CSS 11000 - Productos de las 11500 Series CSS

  • Software Release 5.0 y Posterior de Cisco WebNS

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Antecedentes

Los CSS participan en una configuración redundante cuando un link de redundancia se ha definido entre dos CSS. El protocolo usado para este link de redundancia es VRRP, usando la dirección Multicast 224.0.0.18. Los CSS utilizan este link para mantener el contacto y el Estado de actividad el uno con el otro. Solamente un link de la cruce entre los CSS se soporta. Usted debe utilizar un cable de par cruzado para conectar directamente con los puertos FE en los CSS redundantes. No utilice los dispositivos de la capa 2 entre los dos CSS en el link redundante. No instale el cable de par cruzado en los puertos del Gigabit Ethernet (GE); no hay soporte para esta configuración.

Nota: El protocolo de la Redundancia de casilla a casilla CSS ahora se soporta en los puertos CSS11501, CSS 11503, y CSS11506 GE en la versión de software 7.10.1.02 y 7.20.0.01 y posterior.

Hay dos condiciones principales detectadas en este link de redundancia que los estados del master y del respaldo de la unidad en los dos CSS:

  • La primera condición está manteniendo el latido del corazón, que es un anuncio cada segundo. El master CSS proporciona este latido del corazón en el link de redundancia, y el respaldo CSS no pierde de vista el latido del corazón cada tres segundos (valor por defecto). Si los tiempos del latido del corazón hacia fuera (por ejemplo, los latidos del corazón no se detectan en este período), después el respaldo asume el control como master.

    El nuevo master CSS comienza a enviar los mensajes del Redundancy Protocol así como los mensajes del (ARP) del Address Resolution Protocol gratuito para poner al día las tablas ARP en los nodos vecinos y las tablas de reenvío de los dispositivos de Bridging asociados (por ejemplo, los 2 Switch de la capa) con la nueva dirección MAC del master CSS. El CSS transmite un paquete de pedido de ARP y un paquete de la respuesta ARP para cada llamada del ARP gratuito.

  • La segunda condición es la de un cambio de la prioridad del Switch VRRP. El CSS que hace publicidad de la prioridad más alta se negocia para llegar a ser principal. Éste es el mecanismo usado por los servicios de link ascendente, y algo de los comandos especiales (descritos más abajo) para iniciar un evento de falla.

Observe que en caso que se configuren mal los CSS (por ejemplo, dos o más CSS se configuran como el master de la redundancia IP), el CSS con la dirección IP más alta VRRP asume el control como el master.

El software de Cisco WebNS le permite a:

  • servicios de link ascendente múltiple de la configuración

  • utilice la Conmutación por falla basada en un link que va abajo

  • utilice la sincronización de la configuración; refiera a sincronizar una configuración redundante para más información

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Publique el comando redundancy del IP de habilitar la Redundancia CSS-a-CSS en dos CSS interconectados con un cable de par cruzado. Por abandono, la Redundancia se inhabilita en los CSS hasta que usted publique este comando en ambos CSS.

Cuando usted incluye la opción principal con este comando, usted puede señalar qué CSS es el master CSS. Inicialmente, iniciar dos CSS interconectados con un cable de par cruzado determina que sea el master y que sea el respaldo. El CSS que inicia primero es el master CSS. Si los CSS inician al mismo tiempo, el CSS con la dirección IP numéricamente más alta siente bien al master.

Cuando usted publica el comando ip redundancy master en el CSS, el CSS siente bien al master CSS. Usted puede publicar este comando en cualquiera el master o el respaldo actual. Si usted publica la opción principal en el respaldo CSS, el CSS siente bien al master y el otro CSS se convierte en automáticamente el respaldo.

Si usted señala a un master CSS, el CSS recupera el estado maestro después de ir abajo y después sube otra vez. Por ejemplo, cuando va el master CSS abajo, el respaldo CSS llega a ser principal. Cuando sube el master señalado anterior CSS otra vez, sin embargo, el CSS siente bien al master otra vez.

Si usted no tiene ningún requisito de señalar un CSS como el master cuando ambos CSS están para arriba, no incluya la opción principal al habilitar la Redundancia en el master CSS.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/50405/box_to_box_config.jpg

Configuraciones

En este documento, se utilizan estas configuraciones:

  • CSS11150 FL

  • nws-4-5

CSS11150 FL
CSS-11150-FL# sh running-config
!Generated on 03/22/2004 18:32:17
!Active version: ap0610107a

configure


!*************************** GLOBAL ***************************
  ip redundancy 		


!--- Redundancy is enabled.


  app     			


!--- This is optional if you want to synchronize the configurations.

  app session 172.17.6.2   

  ip route 0.0.0.0 0.0.0.0 10.66.86.33 1 

!************************* INTERFACE *************************
interface e1
  bridge vlan 2 

interface e3
  bridge vlan 42 

!************************** CIRCUIT **************************
circuit VLAN1
  redundancy 
         
  ip address 10.1.1.3 255.255.255.0 

circuit VLAN2

  ip address 172.17.6.1 255.255.255.0 
    redundancy-protocol 

circuit VLAN42
  redundancy 

  ip address 10.66.86.45 255.255.255.240 

!************************** SERVICE **************************
service test 
  protocol tcp 
  ip address 10.1.1.2 
  port 80 
  active 

!*************************** OWNER ***************************
owner Cisco 

  content WebServer 
    vip address 10.66.86.44 
    add service test 
    active 

CSS-11150-FL# 

nws-4-5
nws-4-5# sh running-config 
!Generated on 03/22/2004 18:53:37
!Active version: ap0610107a

configure


!*************************** GLOBAL ***************************
  ip redundancy 	


!--- Redundancy is enabled.



  app 


!--- This is optional if you want to syncronize the configurations.

  app session 172.17.6.1 

  ip route 0.0.0.0 0.0.0.0 10.66.86.33 1 

!************************* INTERFACE *************************
interface e1
  bridge vlan 2 

interface e3
  bridge vlan 42 

!************************** CIRCUIT **************************
circuit VLAN1
  redundancy 
         
  ip address 10.1.1.3 255.255.255.0 

circuit VLAN2

  ip address 172.17.6.2 255.255.255.0 
    redundancy-protocol 

circuit VLAN42
  redundancy 

  ip address 10.66.86.45 255.255.255.240 

!************************** SERVICE **************************
service test 
  protocol tcp 
  ip address 10.1.1.1 
  port 80 
  active 

!*************************** OWNER ***************************
owner Cisco 

  content WebServer 
    vip address 10.66.86.44 
    add service test 
    active 

nws-4-5# 


Soporte para servicios múltiples de link ascendente

Usted puede crear un servicio que se asocie a la dirección IP de un router. Este servicio permite al master CSS para monitorear al router con un keepalive (ICMP). Si el keepalive falla, el master abandona el control y el respaldo CSS toma el control. Usted puede configurar más de un servicio publicando el comando type redundancy-up; los CSS utilizan todo el uplinks de la Redundancia al tomar la decisión de recuperación tras falla.

Si un CSS es activo, y pierde todo el uplinks señalado como redundancia para arriba, el CSS abandona el estado activo y se convierte en el respaldo. El CSS utiliza el Redundancy Protocol para informar al otro CSS para llegar a ser activo. Si ambos CSS han perdido su uplinks, las estancias CSS en el estado activo por 45 segundos, esperando el uplink para venir vivo. Después de 45 segundos, si todavía no hay uplink viable, el CSS entra el modo de backup, dando al otro Switch un intento. Esto permite que ambos CSS consigan una ocasión de probar su uplinks sin golpear hacia adelante y hacia atrás muchas veces cada minuto.

Nota: Un CSS entra la Conmutación por falla cuando hay no más servicios de link ascendente vivos.

Consideraciones

Se inhabilita esta característica cuando publican el comando ip redundancy master. Cuando publican el comando ip redundancy master, el comando type redundancy-up no puede ser configurado. Cuando un servicio es configurado publicando el comando type redundancy-up, el comando ip redundancy master no puede ser publicado.

Configuración

CSS11150# configure terminal
CSS11150(config)# service uplink1
CSS11150(config-service[uplink1])# type redundancy-up           

!--- If this upstream router goes down, then fail the switch over.

CSS11150(config-service[uplink1])# ip address 10.66.86.33
CSS11150(config-service[uplink1])# active

Soporte para Failover por Falla de Interfaz Física

Si va de las interfaces físicas configuradas para la Redundancia abajo, el CSS abandona el control, y el respaldo CSS asume el control inmediatamente como master. Esta característica se basa en el estado del link en comparación con el servicio de la redundancia para arriba, que se basa en la conectividad del IP. El CSS puede determinar el estado del link cuando en el modo de backup. Usted debe aseegurarse que la conexión en sentido ascendente o el trayecto descendente del respaldo CSS también no se ejecuta a través de esta misma interfaz; esto hará los cuadros CSS agitar la propiedad del estado maestro.

Consideraciones

Esta característica es inhabilitada publicando el comando ip redundancy master. Cuando publican el comando ip redundancy master, el comando interface del Redundancia-phy falla. Cuando publican el comando interface del Redundancia-phy, el comando ip redundancy master falla.

Configuración

CSS-11150-FL# configure terminal
CSS-11150-FL(config)# interface e1
CSS-11150-FL(config-if[e1])# redundancy-phy

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • Redundancia sh — Este comando verifica que los CSS se estén ejecutando en una configuración redundante; este comando también visualiza qué CSS es master y cuál es de reserva, así como la razón de la Conmutación por falla más reciente.

    nws-4-5# sh redundancy
    Redundancy:               Enabled    Redundancy Protocol:      Running   
    Redundancy State:         Master     MasterMode:               No        
    Number of times redundancy state changed to Master:            2         
                                             to Backup:            2         
    Redundancy interface:     172.17.6.2
    Current State Duration:   1 day 02:54:04
    Last Fail Reason:         No Fail    
    VRID:                     128        Priority:                 100 
  • muestre el registro sys.log — Este comando visualiza los mensajes con la información para dominio entre los dispositivos CSS.

    CSS-11150-FL# sh log sys.log
    
    APR 15 18:05:49 5/1 85 REDUNDANCY-4: Redundancy force master temporarily
    APR 15 18:05:52 5/1 86 REDUNDANCY-4: Transition to redundancy master
    APR 15 18:05:52 5/1 87 VRRP-4: Virtual router 128: master on interface 172.17.6.1
  • muestre el app y muestre a la sesión de APP — Este comando visualiza el estado de la sesión de APP.

    nws-4-5# sh app
    APP CONFIGURATION:
    Enabled PortNumber: 5001 MaxFrameSize: 10240
    
    nws-4-5# sh app session
    App Session Information 'no hostname':
    Session ID: 87df3710 IP Address: 172.17.6.1 State: APP_SESSION_UP

Usted puede forzar el respaldo para dominar para los propósitos del mantenimiento. Publique el Comando Force Master de la Redundancia de configurar un respaldo CSS como master temporal. Esto es una configuración temporal porque el comando no se copia a la ejecutar-configuración. Este comando es útil en una configuración redundante cuando usted necesita tomar al master CSS off-liné para el mantenimiento o una actualización.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Información Relacionada


Document ID: 50405