IP : Integrated Intermediate System-to-Intermediate System (IS-IS)

Descripción de LSP de Pseudonodo IS-IS

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe el seudonodo de Link-State Packet (LSP). Un seudonodo es una representación lógica de la LAN que es generada por un Sistema intermedio designado (DIS) en un segmento de LAN. El documento también describe la propagación de información a los routers.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información en este documento se basa en las versiones de software y hardware asociadas a:

  • Software Release 12.1(5)T9 del � del Cisco IOS.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

DIS y el pseudonode

Esta sección describe el DIS y el pseudonode.

¿Qué es el DIS?

En las redes de acceso múltiple del broadcast, un único router se elige como el DIS. No hay respaldo DIS elegido. El DIS es el router que crea el pseudonode y actúa en nombre del pseudonode.

Dos tareas principales son realizadas por el DIS:

  • Creando y poniendo al día el pseudo nodo LSP para señalar los links a todos los sistemas en el red secundario del broadcast. Vea la sección de Pseudenode LSP para más información.

  • Inundar los LSP sobre el LAN.

El inundar sobre el LAN significa que el DIS envía las unidades de datos de protocolo periódicas del número de secuencia completo (CSNP) (configuración predeterminada de 10 segundos) resumiendo la siguiente información:

  • ID DE LSP

  • Número de secuencia

  • Checksum

  • Tiempo de vida restante

El DIS es responsable de inundar. Crea e inunda un nuevo pseudo nodo LSP para cada encaminamiento llana en cuál está participando (el nivel 1 o el nivel 2) y para cada LAN con el cual está conectado. Un router puede ser el DIS para todos los LAN conectados o un subconjunto de LAN conectados, dependiendo de la prioridad IS-IS o del direccionamiento de la capa 2. El DIS también creará e inundar un nuevo pseudo nodo LSP cuando se establece una adyacencia de vecino, derribado, o el temporizador de intervalos de actualización expira. El mecanismo DIS reduce la cantidad de inundación en los LAN.

Elección de DIS

En un LAN, uno del Routers se elige el DIS, sobre la base de la prioridad de interfaz (el valor por defecto es 64). Si todas las prioridades de interfaz son lo mismo, seleccionan al router con el Punto de acoplamiento de la subred más alto (SNPA). El SNPA es la dirección MAC en un LAN, y el Identificador de conexión del link de datos local (DLCI) en una red Frame Relay. Si el SNPA es un DLCI y es lo mismo en los ambos lados de un link, el router con el ID del sistema más alto hace el DIS. Cada interfaz del router IS-IS se asigna una prioridad L1 y una prioridad L2 en el rango a partir de la 0 a 127.

La elección del DIS es con derecho preferente (OSPF desemejante). Si un nuevo router inicia en el LAN con una prioridad de interfaz más alta, el nuevo router hace el DIS. Purga el pseudo nodo LSP viejo e inunda un nuevo conjunto de los LSP.

¿Cuál es el pseudo nodo (PSN)?

Para reducir el número de adyacencias de la interconexión total entre los Nodos en los links multiaccesos, el link multiacceso sí mismo se modela como pseudonode. Esto es un nodo virtual, pues el nombre implica. El DIS crea el pseudonode. Todo el Routers en el broadcast conecta, incluyendo el DIS, las adyacencias de la forma al pseudonode.

Representación de un pseudonode:

pseodonode.gif

En el IS-IS, un DIS no sincroniza con sus vecinos. Después de que el DIS cree el pseudonode para el LAN, envía los paquetes de saludo para cada nivel (1 y 2) cada tres segundos y CSNP cada diez segundos. Los paquetes de saludo indican que es el DIS en el LAN para ese nivel, y los CSNP describen el resumen de todos los LSP, incluyendo el ID DE LSP, el número de secuencia, la suma de comprobación, y el tiempo de vida restante. Los LSP se inundan siempre a la dirección Multicast y el mecanismo CSNP corrige solamente para cualquier unidad de datos de protocolo perdida (PDU). Por ejemplo, un router puede pedir el DIS un LSP que falta usando un paquete parcial del número de secuencia (PSNP) o, a su vez, para dar al DIS un nuevo LSP.

Los CSNP se utilizan para decir al otro Routers sobre todos los LSP en la una base de datos del router. Similar a un paquete descriptor de las bases de datos OSPF, los PSNP se utilizan para pedir un LSP y para reconocer el recibo de un LSP.

Pseudo nodo LSP

El pseudo nodo LSP es generado por el DIS. El DIS señala a todos los vecinos de LAN (DIS incluyendo) en el pseudo nodo LSP con un métrico de cero. Todos los routeres de LAN, incluyendo el DIS, señalan la Conectividad al pseudonode en sus LSP. Esto es similar en el concepto a la red LSA en el OSPF.

Ejemplo:

Utilizaremos el siguiente diagram de red para demostrar cómo el pseudo nodo LSP, generado por el DIS, se utiliza para señalar a todos los vecinos de LAN.

Nota: En el ejemplo abajo, la característica dinámica del nombre de host es permiso. Por lo tanto, los ID del sistema se asocian automáticamente a los nombres del host del router mostrados en la salida resultante de los comandos show abajo.

Diagrama de la red

isis-pnode.jpg

Configuraciones

Estas configuraciones fueron utilizadas para el Routers mostrado en el diagrama de la red:

Router ISIS
Router 6
  
       interface e0
       ip address 172.16.126.6 255.255.255.0 
       ip router isis
       Isis priority 127
	   
       router isis
       net 49.0001.0000.0c4a.4598.00
       is-type level-1
  
  Router 2

       interface e0
       ip address 172.16.126.2 255.255.255.0
       ip router isis
	
       router isis
       net 49.0001.0000.0c8d.e6b4.00
       is-type level-1
	   
  Router 1

       interface e0
       ip address 172.16.126.1 255.255.255.0
       ip router isis


       interface s1
       ip address 172.16.1.1 255.255.255.0
       ip router isis

       router isis
       net 49.0001.0000.5c75.d0e9.00
       is-type level-1
	   
  Router 8
 
       interface s1
       ip address 172.16.1.8 255.255.255.0
       ip router isis
	  
       router isis
       net 49.0001.0000.0c31.c2fd.00
       is-type level-1c

La tabla siguiente analiza el área, la dirección MAC, y la red para cada uno del Routers configurado arriba. Note que todo el Routers está en la misma área.

Router Área Dirección MAC RED (título de entidad de la red)
6 49.0001 0000.0c4a.4598 49.0001.0000.0c4a.4598.00
2 0000.0c8d.e6b4 49.0001.0000.0c8d.e6b4.00
1 0000.5c75.d0e9 49.0001.0000.5c75.d0e9.00
8 0000.0c31.c2fd 49.0001.0000.0c31.c2fd.00

Con el Routers configurado según lo descrito en esta sección, usted puede utilizar el comando show clns is-neighbor de ver a los vecinos IS-IS:

router-6# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
router-2       Et0         Up     L1   64        router-6.01        Phase V
router-1       Et0         Up     L1   64        router-6.01        Phase V
router-6#

router-2# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
router-6       Et0         Up     L1   127       router-6.01        Phase V
router-1       Et0         Up     L1   64        router-6.01        Phase V
router-2#

router-1# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
router-6       Et0         Up     L1   127       router-6.01        Phase V
router-2       Et0         Up     L1   64        router-6.01        Phase V
router-8       Se1         Up     L1   0         00                 Phase V
router-1#

router-8# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
Router-1       Se1         Up     L1   0         00                 Phase V
router-8#

En las listas vecinas precedentes, note que el Routers conectado con la red de acceso múltiple (Ethernet) todo tiene el mismo circuit id. El circuit id es un número del octeto que las aplicaciones del router de identificar únicamente la interfaz IS-IS. Si la interfaz se asocia a una red de acceso múltiple, el circuit id se concatena con el ID del sistema del DIS. Esto se conoce como el pseudonode ID. Note también, eso que el DIS es el router 6 debido a la prioridad IS-IS configurada bajo su interfaz de Ethernet.

Base de datos IS-IS

Esta salida visualiza las bases de datos IS-IS de cada uno del Routers descrito en la sección anterior:

Router-6# show isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
router-8.00-00        0x0000006E   0xFF1A        960               0/0/0
router-6.00-00      * 0x0000006D   0xDD58        648               0/0/0
router-6.01-00      * 0x00000069   0x6DCB        1188              0/0/0
router-2.00-00        0x0000006D   0x59DE        589               0/0/0
router-1.00-00        0x00000074   0xC4B0        759               0/0/0
router-6#

router-2# show isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
router-8.00-00        0x0000006E   0xFF1A        947               0/0/0
router-6.00-00        0x0000006D   0xDD58        633               0/0/0
router-6.01-00        0x00000069   0x6DCB        1172              0/0/0
router-2.00-00      * 0x0000006D   0x59DE        577               0/0/0
router-1.00-00        0x00000074   0xC4B0        746               0/0/0
router-2#

router-1# show isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
router-8.00-00        0x0000006E   0xFF1A        934               0/0/0
router-6.00-00        0x0000006D   0xDD58        619               0/0/0
router-6.01-00        0x00000069   0x6DCB        1158              0/0/0
router-2.00-00        0x0000006D   0x59DE        561               0/0/0
router-1.00-00      * 0x00000074   0xC4B0        734               0/0/0
router-1#

router-8# show isis database
IS-IS Level-1 Link State Database
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
router-8.00-00*       0x0000006E   0xFF1A        927           0/0/0
router-6.00-00        0x0000006D   0xDD58        607           0/0/0
router-6.01-00        0x00000069   0x6DCB        1147          0/0/0
router-2.00-00        0x0000006D   0x59DE        550           0/0/0
router-1.00-00        0x00000074   0xC4B0        723           0/0/0
router-8#

Mientras que la salida precedente indica, el comando show isis database visualiza una lista de LSP en la base de datos. En este caso, todo el Routers es 1 Router llanos en la misma área, así que él todo tiene los mismos LSP en sus bases de datos IS-IS. Note que cada uno del Routers genera un LSP. El DIS genera un LSP para sí mismo, y también genera un LSP en nombre del pseudonode. El pseudo nodo LSP en este ejemplo es 0000.0C4A.4598.01-00.

Mencionamos que el Routers en el LAN envía solamente los anuncios al pseudonode del LAN. El pseudonode señala a todos los vecinos de LAN, en el pseudo nodo LSP, con un métrico de cero — tal y como se muestra en de estos ejemplos de resultado del comando show isis database lsp detail:

  • Router 6 LSP (según lo visto del router 8)

    Note que el router 6 hace publicidad que puede alcanzar solamente su red con conexión directa y el pseudonode. En este caso, el pseudonode tiene un métrico de 10. Como mencionamos, el Routers en el LAN hará publicidad que él puede ser alcanzado al pseudonode del LAN solamente.

    router-8# show isis database router-6.00-00 detail
    IS-IS Level-1 LSP router-6.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-6.00-00        0x00000071   0xD55C        456           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      Code:   137 Length: 8
      IP Address:  172.16.126.6
      Metric: 10 IP 172.16.126.0 255.255.255.0
      Metric: 10 IS router-6.01
    router-8#
  • Pseudo nodo LSP (según lo visto del router 8)

    El pseudo nodo LSP hace publicidad de todos los vecinos de LAN con un métrico de cero. El pseudo nodo LSP es generado por el DIS, el router 6 en este caso, en nombre del pseudonode.

    Router-8# show isis database router-6.01-00 detail
    IS-IS Level-1 LSP router-6.01-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-6.01-00        0x0000006D   0x65CF        759           0/0/0
      Metric: 0  IS router-6.00
      Metric: 0  IS router-2.00
      Metric: 0  IS router-1.00
    router-8#
  • Router2 LSP (según lo visto del router 8)

    Una vez más el router2 LSP contiene la información si puede alcanzar su red con conexión directa y el pseudonode solamente.

    Router-8# show isis database router-2.00-00 detail
    IS-IS Level-1 LSP router-2.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-2.00-00        0x00000072   0x4FE3        791           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      Code:   137 Length: 8
      IP Address:  172.16.126.2
      Metric: 10 IP 172.16.126.0 255.255.255.0
      Metric: 10 IS router-6.01
    router-8#
  • Router1 LSP (según lo visto del router 8)

    La única información que el router1 LSP contiene para la red LAN es la red sí mismo y si puede alcanzar el pseudonode. Puesto que el router1 también está conectado con otra red, la red serie, esta red con conexión directa también se hace publicidad.

    Router-8# show isis database router-1.00-00 detail
    IS-IS Level-1 LSP router-1.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-1.00-00        0x00000079   0xBAB5        822           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      Code:   137 Length: 8
      IP Address:  172.16.1.1
      Metric: 10 IP 172.16.126.0 255.255.255.0
      Metric: 10 IP 172.16.1.0 255.255.255.0
      Metric: 10 IS router-6.01
      Metric: 10 IS router-8.00
    router-8#
  • Router 8 LSP

    En este caso, el router 8 no está conectado con el LAN, así que no hace publicidad al pseudonode que puede ser alcanzado. , Sin embargo, hace publicidad (ese puede ser alcanzado) a sí mismo, al router1, y a la red con conexión directa.

    Router-8# show isis database router-8.00-00 detail
    IS-IS Level-1 LSP router-8.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-8.00-00*       0x00000072   0xF71E        554           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      IP Address:  172.16.1.8
      Metric: 10 IP 172.16.1.0 255.255.255.0
      Metric: 10 IS router-1.00
      Metric: 0  ES router-8
    router-8#

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 49627