IP : Protocolos de routing de IP

Ruteo basado en la política con el ejemplo de configuración de la función de opciones de seguimiento múltiple

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de ejemplo para la política basada en ruteo con la función Opciones de seguimiento múltiple. Esta característica fue introducida en el Software Release 12.3(4)T del � del Cisco IOS. Si desea obtener más información, consulte Soporte para opciones de seguimiento múltiple.

Esta función amplía las capacidades del seguimiento objetivo a fin de verificar la dirección IP del próximo salto antes de reenviar el tráfico al salto siguiente. El método de verificación puede ser un ping del protocolo de mensajes de control de Internet (ICMP), un ping del protocolo de datagrama del usuario (UDP) o una solicitud de obtención del protocolo de transferencia de hipertexto (HTTP). El ICMP es la mayoría del método de verificación común usado en Internet. La característica Multiple Tracking Options (Opciones de seguimiento múltiple) es más adecuada para los routers que tienen múltiples conexiones a Ethernet como salto siguiente. Normalmente, las interfaces de Ethernet conectan con el Digital Subscriber Line (DSL) o el Cable módems. Actualmente, no hay método para detectar una conexión en sentido ascendente del error en la red de banda ancha ISP — los restos de la interfaz de Ethernet ascendentes y ninguna forma de puntas del Static Routing a esa interfaz. La fuerza de esta característica no le prohibe el respaldo dos interfaces de Ethernet, elige la interfaz que está disponible enviando los ping de ICMP para verificar el reachablity, y después rutea el tráfico hacia fuera a esa interfaz.

prerrequisitos

Requisitos

Antes de que usted intente esta configuración, asegúrese de que usted cumpla este requisito:

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

Esta sección presenta los datos para configurar las características descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza esta configuración de red: En este escenario, el r1 está conectado con dos diversos ISP (ISP-1 y ISP-2). R1 rastrea el alcance a ambos routers ISP.

/image/gif/paws/48003/pbrtracking_01.gif

Configuración

Este documento usa esta configuración:

R1
R1# show running-config 
Building configuration...

Current configuration : 1203 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
clock timezone EST 0
no aaa new-model
ip subnet-zero
no ip domain lookup
!
!
!
!
track 123 rtr 1 reachability

!--- Track Router 1's reachability.

!         
track 124 rtr 2 reachability

!--- Track Router 2's reachability.

!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.0.1 255.255.255.0
!
interface Ethernet1/0
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet2/0
 ip address 10.10.10.1 255.255.255.0
 ip policy route-map alpha

!--- Enable policy routing on the outgoing interface.

!
ip classless
no ip http server
!
!
!
!
route-map alpha permit 10

!--- Define a route-map to set the next hop depending on 
!--- the state of the tracked routers.

 set ip next-hop verify-availability 192.168.0.10 10 track 123
 set ip next-hop verify-availability 192.168.1.20 20 track 124
!
!
control-plane
!
rtr 1

!--- Define and start Router 1.

 type echo protocol ipIcmpEcho 192.168.0.10
rtr schedule 1 life forever start-time now
rtr 2

!--- Define and start Router 2.


 type echo protocol ipIcmpEcho 192.168.1.20
rtr schedule 2 life forever start-time now
!
line con 0
 transport preferred all
 transport output all
line aux 0
 transport preferred all
 transport output all
line vty 0 4
 login
 transport preferred all
 transport input all
 transport output all
!
!
end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • pista de la demostración — Visualiza la información de seguimiento.

  • muestre la descripción de la pista — Información de seguimiento limitada de las visualizaciones.

R1# show track           
Track 123
  Response Time Reporter 1 reachability
  Reachability is Up
    3 changes, last change 00:06:43
  Latest operation return code: OK
  Latest RTT (millisecs) 8
  Tracked by:
    ROUTE-MAP  0
Track 124
  Response Time Reporter 2 reachability
  Reachability is Up
    3 changes, last change 00:06:43
  Latest operation return code: OK
  Latest RTT (millisecs) 12
  Tracked by:
    ROUTE-MAP  0

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Up
124     rtr       2                    reachability     Up

De la salida del comando show track brief, usted puede ver que ambos ISP son accesibles. Si usted apaga la interfaz que está conectada con el ISP-1, se muestra como abajo cuando está seguido.

R1# conf t
R1(config)# int ethernet 0/0
R1(config-if)# shutdown
R1(config-if)# end
R1#

*Jan 21 06:06:50.167: %SYS-5-CONFIG_I: Configured from console by console
*Jan 21 06:06:50.807: %LINK-5-CHANGED: Interface Ethernet0/0, changed state to administratively down
*Jan 21 06:06:51.827: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to down

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Up
124     rtr       2                    reachability     Up

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Down
124     rtr       2                    reachability     Up
R1# 

Nota: El PBR requiere el seguimiento para determinar si la interfaz o la ruta es activa. Para ver el estatus de la ruta que sigue, usted puede también utilizar el comando show route-map.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 48003