IP : Protocolos de routing de IP

Política de ruteo con el ejemplo de configuración del switch Catalyst de la serie 3550.

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (6 Octubre 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de ejemplo del ruteo de política en los switches Catalyst 3550 Series. Los Catalyst 3550 Series Switch tienen expedición basada hardware, así la información de reenvío se programa en el Ternary Content Addressable Memory (TCAM). Para que el TCAM a la política de soporte basada ruteando el (PBR), debe ser formatada cambiando la plantilla del (SDM) de la administración de base de datos del Switch. Usted debe modificar la plantilla de SDM, tales que soporta la capa 3 TCAM del 144-bit. Refiérase entienden y configuran el Switching Database Manager en los Catalyst 3550 Series Switch para más información sobre el SDM.

Nota: El Catalyst 3550 tiene limitaciones en los comandos route-maps que usted puede utilizar.

prerrequisitos

Requisitos

Asegúrese de que usted esté bien informado de estas áreas antes de que usted intente esta configuración:

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Software Release 12.1.19-EA1a de Cisco IOS�

  • Cisco Catalyst 3550

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Antes de que pueda habilitar el ruteo de política, debe configurar uno de los siguientes comandos en el modo de configuración global y, luego, debe escribirse la configuración y recargarse el switch.

  • sdm prefer extended-match

  • sdm prefer access extended-match

  • sdm prefer routing extended-match

CAT3550(config)# access-list 10 permit 20.20.20.0 0.0.0.255
CAT3550(config)# route-map pbr permit 10
CAT3550(config-route-map)# match ip address 10
CAT3550(config-route-map)# set ip next-hop 12.12.12.12

CAT3550(config)# int vlan 3
CAT3550(config-if)# ip policy route-map pbr
CAT3550(config-if)#
06:12:31: %L3TCAM-3-SIZE_CONFLICT: PBR requires enabling extended routing

CAT3550# show run int vlan 3
Building configuration...

Current configuration : 60 bytes
!
interface Vlan3
ip address 55.55.55.1 255.255.255.0

!--- Command not taken - you need to enable SDM.

end

CAT3550# conf t
Enter configuration commands, one per line. End with CNTL/Z.
CAT3550(config)# sdm prefer extended-match
Changes to the running SDM preferences have been stored, but cannot take effect 
until the next reload.
Use 'show sdm prefer' to see what SDM preference is currently active.
CAT3550(config)# end

CAT3550# write
06:14:11: %SYS-5-CONFIG_I: Configured from console by console
Building configuration...
[OK] 

ltd-1-2# reload
Proceed with reload? [confirm]

Debería tener en cuenta que los comandos no compatibles—se refieren a Comandos de mapeo de ruta no compatibles si existe esta configuración:

!
access-list 10 permit 20.20.20.0 0.0.0.255
route-map pbr permit 10
match ip address 10
set ip default next-hop 12.12.12.12
!

Se genera un mensaje de error si intenta configurar el mapa de rutas de política en la interfaz:

CAT3550(config)# int vlan 3
CAT3550(config-if)# ip policy route-map pbr
CAT3550(config-if)# end
CAT3550#
00:02:29: %PBR-3-UNSUPPORTED_RMAP: Route-map pbr not supported for Policy-Based Routing

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/47900/cat3550pbr-1.gif

Configuraciones

Este documento usa esta configuración:

La configuración toma el origen del tráfico de 20.20.20.X (lista de acceso 10) y lo envía a 30.30.30.2—la configuración sobrescribe el gateway predeterminada establecida en 10.10.10.2.

CAT3550 (Cisco Catalyst 3550)
CAT3550# show running-config 
Building configuration...
.
.
!
interface Vlan1
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan2
 ip address 20.20.20.1 255.255.255.0
 ip policy route-map pbr
!
interface Vlan3
 ip address 30.30.30.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.10.10.2
ip classless
ip http server
!
!
access-list 10 permit 20.20.20.0 0.0.0.255
route-map pbr permit 10
 match ip address 10
 set ip next-hop 30.30.30.2
!
.
!
end

Cuando ponen al comando set ip next-hop el tráfico coincidente no puede ser considerado en la salida y es una conducta esperada en un Switch. Esto es porque un Switch funciona en el hardware solamente, y los comandos show presentan solamente la información que se maneja en el software. El Next-Hop del IP del conjunto está trabajando todo el tiempo en hardware, porque la tabla de ruteo y el proceso nunca consiguen marcados por el Switch. Recibe un paquete y si ese las caídas en las declaraciones del route-map entonces se envía directamente al salto siguiente que usted especificó, sin marcar la tabla de ruteo.

Las en primer lugar controles del comando set ip default next-hop la tabla de ruteo entera para ver si hay otra ruta al destino. Si no se encuentra ninguna ruta, después se utiliza el Next-Hop predeterminado.

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Nota: Consulte Información Importante sobre Comandos de Debug antes de usar un comando debug.

  • debug ip policy—Muestra los paquetes que son enrutados o rechazados según la política. Un ejemplo de la salida del comando debug ip policy es:

  *Dec 5 13:33:23.607: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
  *Dec 5 13:33:23.607: IP: route map pbr, item 10, permit
  *Dec 5 13:33:23.607: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4 (Vlan3),len 100, policy routed
  *Dec 5 13:33:23.607: IP: Vlan2 to Vlan3 30.30.30.1
  *Dec 5 13:33:23.707: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
  *Dec 5 13:33:23.707: IP: route map pbr, item 10, permit
  *Dec 5 13:33:23.707: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4 (Vlan3),len 100, policy routed
  *Dec 5 13:33:23.707: IP: Vlan2 to Vlan3 30.30.30.1
  *Dec 5 13:33:23.847: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
  *Dec 5 13:33:23.847: IP: route map pbr, item 10, permit

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 47900