IP : Open Shortest Path First (OSPF)

Cómo OSPF inyecta una ruta predeterminada en un área normal

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

Este documento muestra cómo Open Shortest Path First (OSPF) inserta una ruta predeterminada en un área normal. Las rutas predeterminadas introducidas en un área normal pueden ser originadas por cualquier router OSPF. Como opción predeterminada, el router de OSPF no genera una ruta predeterminada en el dominio de OSPF. Para que OSPF genere una ruta predeterminada, debe utilizar el comando default-information originate.

Hay dos maneras de anunciar una ruta predeterminada en un área normal. Lo primero es anunciar 0.0.0.0 en el dominio OSPF, siempre y cuando el router anunciante tenga una ruta predeterminada. La segunda es anunciar 0.0.0.0 independientemente de si el router anunciante ya tiene una ruta predeterminada. El segundo método puede ser logrado agregando la palabra clave siempre al comando default-information originate.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la configuración de red que se muestra en el siguiente diagrama.

/image/gif/paws/47868/ospfdb9a.gif

Configuraciones

Este documento usa las configuraciones detalladas aquí.

Router 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1

end

Router 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0
 default-information originate
 
ip route 0.0.0.0 0.0.0.0 6.0.0.3

end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Examine las bases de datos OSPF

Visualizaciones de esta salida cómo las miradas de las bases de datos OSPF dadas este entorno de red, usando el comando show ip ospf database.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age     Seq#          Checksum   Link count 
2.2.2.2    2.2.2.2     600     0x80000001    0x9583          1 

                Summary Net Link States (Area 0) 

Link ID    ADV Router   Age     Seq#          Checksum 
5.0.0.0     2.2.2.2     600     0x80000001    0x8E61 

                Router Link States (Area 1) 

Link ID   ADV Router   Age     Seq#           Checksum   Link count 
1.1.1.1    1.1.1.1     864     0x8000005E     0xD350         2 
2.2.2.2    2.2.2.2     584     0x8000001E     0xF667         2 

                Summary Net Link States (Area 1) 

Link ID   ADV Router   Age     Seq#          Checksum 
6.0.0.0    2.2.2.2     585     0x80000004    0xA87C 

                Type-5 AS External Link States 

Link ID   ADV Router   Age     Seq#          Checksum    Tag 
0.0.0.0    2.2.2.2     601     0x80000001    0xD0D8       0 

Porque tiene una ruta predeterminado, el router 2.2.2.2 origina un tipo 5 LSA con un link ID de 0.0.0.0. Este es el resultado del comando default-information originate en su configuración de OSPF.

r2.2.2.2#show ip ospf database external 0.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Type-5 AS External Link States  

  LS age: 650 
  Options: (No TOS-capability, DC) 
  LS Type: AS External Link 
  Link State ID: 0.0.0.0 (External Network Number ) 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0xD0D8 
  Length: 36 
  Network Mask: /0 
        Metric Type: 2 (Larger than any link state path) 
        TOS: 0 
        Metric: 1 
        Forward Address: 0.0.0.0 
        External Route Tag: 0 


r2.2.2.2#show ip route 0.0.0.0 
S* 0.0.0.0/0 [1/0] via 6.0.0.3, 00:28:00, ATM1/0.20  


r1.1.1.1#show ip route ospf 
O IA 6.0.0.0/8 [110/65] via 5.0.0.2, 00:00:18, Serial2/1/0 
O*E2 0.0.0.0/0 [110/1] via 5.0.0.2, 00:00:18, Serial2/1/0 

Usted puede también agregar siempre la palabra clave al comando default-information originate de hacer que un router origina un tipo 5 LSA de 0.0.0.0 incluso si el router no tiene una ruta predeterminado en su tabla de ruteo.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 47868