IP : Open Shortest Path First (OSPF)

Conversión de anuncios del estado del link estilo Not So Stubby Area (área no exclusiva de rutas internas) del tipo 7 al tipo 5 en OSPF

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

Este documento muestra cómo Open Shortest Path First (OSPF) convierte un anuncio de estado de vínculo (LSA) de tipo 7 de Not So Stubby Area (NSSA) en un LSA de tipo 5.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la configuración de red que se muestra en el siguiente diagrama.

/image/gif/paws/47867/ospfdb8a.gif

Configuraciones

Este documento usa las configuraciones detalladas aquí.

Router 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
  
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
router ospf 4
 redistribute static metric 5 metric-type 1
 network 5.0.0.0 0.255.255.255 area 1
 network 4.0.0.0 0.255.255.255 area 1
 area 1 nssa
 
ip route 9.0.0.0 255.0.0.0 4.0.0.2

end

Router 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0
 area 1 nssa

end

Router 3.3.3.3
Current configuration:

hostname r3.3.3.3

interface Loopback0
 ip address 3.3.3.3 255.0.0.0

interface ATM2/0.20 point-to-point
 ip address 6.0.0.3 255.0.0.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0

end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • muestre la base de datos OSPF del IP — Visualiza una lista de los LSA y los teclea en una base de datos del estado del link. Esta lista muestra solamente la información en el encabezado LSA.

  • muestre la base de datos OSPF del IP nssa externa — Visualiza la información solamente sobre el LSA externo NSSA.

  • muestre el externo de la base de datos OSPF del IP — Visualiza la información solamente sobre el LSA externo.

  • show ip ospf database [router] [link-state-id] — Visualiza una lista de todos los LSA de un router en la base de datos. Los LSA son producidos por cada router, y estos LSA fundamentales enumeran los links de todo el Routers, o las interfaces, junto con los estados y los costos de salida del link. Se inundan solamente dentro del área en la cual originan.

  • muestre el id> del <link-estado del Resumen de la base de datos OSPF del IP — Visualiza el Summary Links del router del borde del área (ABR).

  • ruta de IP de la demostración — Visualiza el estado actual de la tabla de ruteo.

Examine las bases de datos OSPF

Para ver cómo las miradas de las bases de datos OSPF dadas este entorno de red, utilizan el comando show ip ospf database.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router    Age    Seq#           Checksum     Link count 
2.2.2.2    2.2.2.2      1235   0x8000001D     0xD9FF           2 
3.3.3.3    3.3.3.3      1100   0x8000000B     0x9455           2 

                Summary Net Link States (Area 0) 

Link ID   ADV Router   Age    Seq#          Checksum 
4.0.0.0    2.2.2.2     1979   0x80000002    0xFDE7 
5.0.0.0    2.2.2.2     1483   0x80000004    0x8864 

                Router Link States (Area 1) 

Link ID   ADV Router   Age    Seq#          Checksum     Link count 
1.1.1.1    1.1.1.1     319    0x8000000C    0xAFA8           3 
2.2.2.2    2.2.2.2     220    0x8000002F    0xD478           2 

                Summary Net Link States (Area 1) 

Link ID   ADV Router   Age    Seq#           Checksum 
6.0.0.0    2.2.2.2     1483   0x8000001C     0x7894 

                Type-7 AS External Link States (Area 1) 

Link ID   ADV Router   Age    Seq#          Checksum     Tag 
9.0.0.0    1.1.1.1     334    0x80000005    0xD738        0 

                Type-5 AS External Link States 

Link ID   ADV Router   Age    Seq#          Checksum     Tag 
9.0.0.0    2.2.2.2     1725   0x80000004    0x50C6        0 

Para anunciar las rutas externas en un NSSA, el router del límite del sistema autónomo (ASBR) crea LSA externas al nssa (tipo 7).

r2.2.2.2#show ip ospf database nssa-external 9.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Type-7 AS External Link States (Area 1) 

  Routing Bit Set on this LSA 
  LS age: 381 
  Options: (No TOS-capability, Type 7/5 translation, DC)

!--- This can be translated into a type 5 LSA by 
!--- an ABR. 

  LS Type: AS External Link 
  Link State ID: 9.0.0.0 (External Network Number ) 

!--- The ASBR (Router 1.1.1.1) advertises 
!--- 9.0.0.0/8. 

  Advertising Router: 1.1.1.1

!--- Router ID of the ASBR.
 
  LS Seq Number: 80000005 
  Checksum: 0xD738 
  Length: 36 
  Network Mask: /8 
        Metric Type: 1 (Comparable directly to link state metric) 
        TOS: 0 
        Metric: 5 
        Forward Address: 4.0.0.1

!--- Forwarding address is incorrectly specified
!--- as an interface on the ASBR.
 

El ABR convierte el tipo 7 LSA en el tipo 5 LSA, y propaga el tipo 5 LSA en las Áreas normales.

r2.2.2.2#show ip ospf database external 9.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Type-5 AS External Link States 

  LS age: 1782 
  Options: (No TOS-capability, DC) 
  LS Type: AS External Link 
  Link State ID: 9.0.0.0 (External Network Number )

!--- Router 2.2.2.2 advertises 9.0.0.0/8.
 
  Advertising Router: 2.2.2.2 

!--- When the conversion is complete, the advertising 
!--- router ID becomes the ABR router ID 
!--- because the ABR originates this type 5 LSA. 

  LS Seq Number: 80000004 
  Checksum: 0x50C6 
  Length: 36 
  Network Mask: /8 
        Metric Type: 1 (Comparable directly to link state metric) 
        TOS: 0 
        Metric: 5 
        Forward Address: 4.0.0.1 
        External Route Tag: 0 
  

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 1) 

  Routing Bit Set on this LSA 
  LS age: 426 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1

!--- For router links, Link State ID is always the same 
!--- as the advertising router (next line). 

  Advertising Router: 1.1.1.1
  LS Seq Number: 8000000C 
  Checksum: 0xAFA8 
  Length: 60 
  AS Boundary Router

!--- Bit E in the router LSA indicates that this router
!--- originates from external LSAs.
 
   Number of Links: 3

!--- There are three links in area 1. 


    Link connected to: a Stub Network

!--- This represents the Ethernet segment 4.0.0.0/8.
 
     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10

!--- The OSPF cost of the Ethernet segment.
 

    Link connected to: another Router (point-to-point) 

!--- Shows that Router 1.1.1.1 is a neighbor with 
	!--- Router 2.2.2.2. 

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 5.0.0.1

!--- The interface address that connects to Router
!--- 2.2.2.2 is 5.0.0.1.
 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64

!--- The OSPF cost of the link that connects 
!--- the two routers.

    Link connected to: a Stub Network 

!--- This represents the serial link 5.0.0.0/8.
 
     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64

!--- The OSPF cost of the serial link.

Usted puede ver de la salida intrépida aquí que aunque el router 2.2.2.2 no haga que ningunos redistribuyan las declaraciones en su configuración, sigue siendo un ASBR porque convierte el tipo 7 LSA en el tipo 5 LSA.

r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 1361 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000001D 
  Checksum: 0xD9FF 
  Length: 48 
  Area Border Router 
  
!--- Bit B is set in the router LSA to indicate
!--- that this router is an ABR.
 
  AS Boundary Router
  
!--- Bit E in the router LSA indicates that this router 
!--- originates from external LSAs.

   Number of Links: 2 
  
!--- There are two links in area 0. 


    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 3.3.3.3 
     (Link Data) Router Interface address: 6.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1

                Router Link States (Area 1) 

  LS age: 346 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000002F 
  Checksum: 0xD478 
  Length: 48 
  Area Border Router 
  AS Boundary Router 
   Number of Links: 2 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 5.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 
  

r2.2.2.2#show ip ospf database router 3.3.3.3 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 1245 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 3.3.3.3 
  Advertising Router: 3.3.3.3 
  LS Seq Number: 8000000B 
  Checksum: 0x9455 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 6.0.0.3 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

Para hacer publicidad de las rutas a partir de una área en otra, el ABR crea los LSA de resúmenes (tipo 3).

r2.2.2.2#show ip ospf database summary 4.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 0) 

  LS age: 172 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 4.0.0.0 (summary Network Number)
  
!--- The ABR (Router 2.2.2.2) advertises 
!--- 4.0.0.0/8 into area 0.

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000003 
  Checksum: 0xFBE8 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 74 

r2.2.2.2#show ip ospf database summary 5.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 0) 

  LS age: 1687 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 5.0.0.0 (summary Network Number)
  
!--- The ABR (Router 2.2.2.2) advertises 
!--- 5.0.0.0/8 into area 0. 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000004 
  Checksum: 0x8864 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 64 

r2.2.2.2#show ip ospf database summary 6.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 1) 

  LS age: 1697 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 6.0.0.0 (summary Network Number)
  
!--- The ABR (Router 2.2.2.2) advertises 
!--- 6.0.0.0/8 into area 1.

  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000001C 
  Checksum: 0x7894 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 1 

El resumen ASBR LSA no se necesita en este caso porque el ABR origina el externo LSA, y el ABR es accesible dentro del área 0. compara este ejemplo con un escenario donde estaba una Área normal el NSSA mirando el ejemplo de base de datos cómo el OSPF propaga las rutas externo en las áreas múltiples.

Este resultado de la tabla de ruteo muestra los diversos tipos de OSPF rutas que 9.0.0.0 sea conocido como por cada router.

r1.1.1.1#show ip route 9.0.0.0 
Routing entry for 9.0.0.0/8 
  Known via "static", distance 1, metric 0 
  Redistributing via ospf 4 
  Advertised by ospf 4 metric 5 metric-type 1 
  Routing Descriptor Blocks: 
  * 4.0.0.2 
      Route metric is 0, traffic share count is 1

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 5.0.0.1, 01:10:13, Serial0/1/0 
O N1 9.0.0.0/8 [110/79] via 5.0.0.1, 01:07:20, Serial0/1/0 

R3.3.3.3#show ip route ospf
O IA 4.0.0.0/8 [110/75] via 6.0.0.2, 02:11:14, ATM2/0.20 
O IA 5.0.0.0/8 [110/65] via 6.0.0.2, 03:10:41, ATM2/0.20 
O E1 9.0.0.0/8 [110/80] via 6.0.0.2, 02:08:11, ATM2/0.20 

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 47867