IP : Open Shortest Path First (OSPF)

Link virtual OSPF

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Todas las áreas de un sistema autónomo OSPF (Open Shortest Path First) se deben conectar físicamente al área de estructura básica (Área 0). En algunos casos, en los que esto no es posible, puede usar un link virtual para conectar la estructura básica a través de un área sin estructura básica. También puede utilizar links virtuales para conectar dos partes de una estructura básica particionada con una zona que no sea de estructura básica. El área, conocida como área de tránsito, a través de la cual se configura el link virtual debe contar con la información completa de ruteo. La zona de tránsito no puede ser una zona fragmentada. Este documento examina la base de datos OSPF en un entorno de link virtual. Puede leer más sobre los links virtuales en la Guía de Diseño de OSPF.

prerrequisitos

Requisitos

Cisco recomienda que tenga conocimiento sobre estos temas:

Componentes Utilizados

Este documento no se limita a una versión específica de software o de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/47866/ospfdb7.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Router1.1.1.1
Current configuration:

hostname Router1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0

router ospf 2
 network 4.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 1
 area 1 virtual-link 3.3.3.3

!--- Area 1 is the transit area.
!--- IP address 3.3.3.3 is the router
!--- ID of the router between Area 1
!--- and Area 2 (Router3.3.3.3). See
!--- the next Note.

end

Nota: El router para OSPF ID es generalmente la dirección IP más alta en el cuadro o la dirección de loopback más alta, si existe una. El Router ID se calcula solamente en el tiempo del inicio o en cualquier momento que el proceso OSPF está recomenzado. Publique el comando show ip ospf interface de encontrar el Router ID.

Router2.2.2.2
Current configuration:

hostname Router2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0

interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20 point-to-point
 ip address 6.0.0.2 255.0.0.0

router ospf 2
 network 6.0.0.0 0.255.255.255 area 1
 network 5.0.0.0 0.255.255.255 area 1

end

Router3.3.3.3
Current configuration:

hostname Router3.3.3.3

interface Loopback0
 ip address 3.3.3.3 255.0.0.0

interface Ethernet0/0
 ip address 12.0.0.3 255.0.0.0

interface ATM2/0.20 point-to-point
 ip address 6.0.0.3 255.0.0.0

router ospf 2
 network 12.0.0.0 0.255.255.255 area 2
 network 6.0.0.0 0.255.255.255 area 1
 area 1 virtual-link 1.1.1.1

!--- Area 1 is the transit area.
!--- IP address 1.1.1.1 is the router
!--- ID of the router between Area 1
!--- and Area 0 (Router1.1.1.1).

end

Cómo el link virtual actúa

Inicialmente, el link virtual está abajo porque Router1.1.1.1 no sabe alcanzar Router3.3.3.3 (el otro extremo del link virtual). Todos los anuncios del estado del vínculo (LSA) en la necesidad del área 1 de ser inundado, y algoritmo del trayecto más corto el primer (SPF) se deben funcionar con dentro del área 1 por el tres Routers, para que Router1.1.1.1 sepa alcanzar Router3.3.3.3 con el área 1.

Después de que el Routers sepa alcanzarse con la área de tránsito, él intenta formar la adyacencia a través del link virtual. Los paquetes OSPF entre los dos extremos del link virtual no son paquetes de multidifusión. Son paquetes tunneled de la fuente 5.0.0.1 al destino 6.0.0.3, porque son tunneled al otro extremo del link virtual. Es importante observar que si hay un Firewall entre el Routers del link virtual, usted necesita habilitar el puerto OSPF (protocolo IP 89) entre la interfaz saliente IP del túnel del link virtual que está entre 5.0.0.1 y 6.0.0.3.

Una vez que el Routers hace adyacente en el link virtual, Router3.3.3.3 se considera un router del borde del área (ABR), porque ahora tiene un link en el área 0. como consecuencia, Router3.3.3.3 crea un LSA de resumen para 12.0.0.0/8 en el área 0 y en el área 1.

Si el link virtual se configura mal por alguna razón, después Router3.3.3.3 no se considera un ABR porque no tiene ninguna interfaces en el área 0. Si éste es el caso, no crea los LSA de resúmenes ni hace publicidad de 12.0.0.0/8 en el área 1.

Nota: El OSPF se ejecuta encima del IP y utiliza el número de protocolo 89. El OSPF no confía en ninguna otra protocolos de transporte, tales como TCP y UDP.

Calcule el trayecto más corto

Esta sección calcula el trayecto más corto desde la perspectiva de Router2.2.2.2.

Router2.2.2.2 mira en su propio LSA y ve que Router3.3.3.3 es un vecino. Entonces mira el LSA de Router3.3.3.3 para verificar que Router3.3.3.3 ve Router2.2.2.2 como vecino. Si ambo Routers se ve como vecinos, después lo consideran accesible.

Cada router también marca su tabla de vecino local (que usted pueda ver con el comando show ip ospf neighbor) para verificar que su interfaz y la interfaz del vecino están en una subred IP común.

Nota: Este control no se realiza en una interfaz sin numerar.

Si están en una subred común, el Routers instala las rutas para cualquier red Stub enumerada en el LSA de router de su vecino. En este ejemplo, 6.0.0.0/8 es la única red Stub enumerada en el LSA de Router3.3.3.3 en el área 1, con la cual Router2.2.2.2 ya está conectado directamente.

Router3.3.3.3 hace el mismo examen para el LSA de Router1.1.1.1, pero no hay ninguna redes Stub útil en el LSA de Router1.1.1.1.

Después de que todos los LSA de routeres alcanzables en el área 1 se examinen, Router2.2.2.2 mira los LSA de resúmenes en la base de datos. Encuentra dos LSA de resúmenes para 12.0.0.0/8 en el área 1 y elige el que está con el costo total más bajo, que es el métrico para alcanzar al router de anuncio más el métrico del LSA de resumen.

  • Router2.2.2.2 puede alcanzar 12.0.0.0 con Router1.1.1.1 con un coste de 64 + 75 = 139.

  • Router2.2.2.2 puede alcanzar 12.0.0.0 con Router3.3.3.3 con un coste de 1 + 10 = 11.

Router2.2.2.2 instala una ruta en su tabla de ruteo con Router3.3.3.3 con un métrico de 11.

Esta salida muestra las OSPF rutas en la tabla de ruteo de cada router descrito previamente:

Router1.1.1.1#show ip route ospf

!--- Output suppressed.

O    6.0.0.0/8 [110/65] via 5.0.0.2, 00:38:12, Serial2/1/0
O IA 12.0.0.0/8 [110/75] via 5.0.0.2, 00:38:02, Serial2/1/0

Router2.2.2.2#show ip route ospf

!--- Output suppressed.

O IA 4.0.0.0/8 [110/74] via 5.0.0.1, 00:38:08, Serial0/1/0
O IA 12.0.0.0/8 [110/11] via 6.0.0.3, 00:38:12, ATM1/0.20

!--- This is the route in this example.

Router3.3.3.3#show ip route ospf

!--- Output suppressed.

O    4.0.0.0/8 [110/75] via 6.0.0.2, 00:38:18, ATM2/0.20
O    5.0.0.0/8 [110/65] via 6.0.0.2, 00:38:28, ATM2/0.20

Usando un túnel GRE en vez de un link virtual

Usted puede también construir un túnel del Generic Routing Encapsulation (GRE) entre Router1.1.1.1 y Router3.3.3.3 y poner el túnel en el área 0. Las diferencias principales entre un túnel GRE y un link virtual se describen en esta tabla:

Túnel GRE link virtual
Todo el tráfico en el túnel es encapsulado y decapsulated por los puntos finales del túnel. Las actualizaciones de ruteo son tunneled, pero el tráfico de datos se envía nativo.
Encabezados de túnel en cada paquetes causan sobrecarga. El tráfico de datos no está conforme a ningún túnel de arriba.
El túnel puede pasar con una zona fragmentada. La área de tránsito no puede ser una zona fragmentada, porque el Routers en la zona fragmentada no tiene rutas para los destinos externos. Porque los datos se envían nativo, si un paquete destinado para un destino externo se envía en una zona fragmentada que sea también una área de tránsito, después el paquete no se rutea correctamente. El Routers en la zona fragmentada no tiene rutas para los destinos externos específicos.

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Examine la base de datos OSPF

Éste es cómo la base de datos OSPF mira, dado este entorno de red, cuando usted publica el comando show ip ospf database.

Router1.1.1.1#show ip ospf database

       OSPF Router with ID (1.1.1.1) (Process ID 2)

                Router Link States (Area 0)

Link ID   ADV Router    Age             Seq#          Checksum   Link count
1.1.1.1   1.1.1.1       919             0x80000003    0xD5DF         2
3.3.3.3   3.3.3.3       5     (DNA)     0x80000002    0x3990         1

                Summary Net Link States (Area 0)

Link ID   ADV Router    Age                 Seq#         Checksum
5.0.0.0   1.1.1.1       1945                0x80000002   0xAA48
5.0.0.0   3.3.3.3       9     (DNA)         0x80000001   0x7A70
6.0.0.0   1.1.1.1       1946                0x80000002   0xA749
6.0.0.0   3.3.3.3       9     (DNA)         0x80000001   0xEA3F
12.0.0.0  3.3.3.3       9     (DNA)         0x80000001   0xF624

                Router Link States (Area 1)

Link ID   ADV Router    Age             Seq#          Checksum   Link count
1.1.1.1   1.1.1.1       1946            0x80000005    0xDDA6         2
2.2.2.2   2.2.2.2       10              0x80000009    0x64DD         4
3.3.3.3   3.3.3.3       930             0x80000006    0xA14C         2

                Summary Net Link States (Area 1)

Link ID   ADV Router    Age             Seq#           Checksum
4.0.0.0   1.1.1.1       1947            0x80000002     0x9990
4.0.0.0   3.3.3.3       911             0x80000001     0xEBF5
12.0.0.0  1.1.1.1       913             0x80000001     0xBF22
12.0.0.0  3.3.3.3       931             0x80000001     0xF624

Router2.2.2.2#show ip ospf database

       OSPF Router with ID (2.2.2.2) (Process ID 2)

                Router Link States (Area 1)

Link ID   ADV Router    Age     Seq#          Checksum   Link count
1.1.1.1   1.1.1.1       1988    0x80000005    0xDDA6        2
2.2.2.2   2.2.2.2       50      0x80000009    0x64DD        4
3.3.3.3   3.3.3.3       969     0x80000006    0xA14C        2

                Summary Net Link States (Area 1)

Link ID   ADV Router    Age      Seq#          Checksum
4.0.0.0   1.1.1.1       1988     0x80000002    0x9990
4.0.0.0   3.3.3.3       950      0x80000001    0xEBF5
12.0.0.0  1.1.1.1       955      0x80000001    0xBF22
12.0.0.0  3.3.3.3       970      0x80000001    0xF624

Router3.3.3.3#show ip ospf database

       OSPF Router with ID (3.3.3.3) (Process ID 2)

                Router Link States (Area 0)

Link ID   ADV Router    Age          Seq#          Checksum   Link count
1.1.1.1   1.1.1.1       6   (DNA)    0x80000003    0xD5DF         2
3.3.3.3   3.3.3.3       977          0x80000002    0x3990         1

                Summary Net Link States (Area 0)

Link ID   ADV Router    Age            Seq#          Checksum
5.0.0.0   1.1.1.1       1027  (DNA)    0x80000002    0xAA48
5.0.0.0   3.3.3.3       986            0x80000001    0x7A70
6.0.0.0   1.1.1.1       1027  (DNA)    0x80000002    0xA749
6.0.0.0   3.3.3.3       987            0x80000001    0xEA3F
12.0.0.0  3.3.3.3       987            0x80000001    0xF624

                Router Link States (Area 1)

Link ID   ADV Router    Age    Seq#          Checksum   Link count
1.1.1.1   1.1.1.1       2007   0x80000005    0xDDA6         2
2.2.2.2   2.2.2.2       68     0x80000009    0x64DD         4
3.3.3.3   3.3.3.3       987    0x80000006    0xA14C         2

                Summary Net Link States (Area 1)

Link ID   ADV Router    Age      Seq#         Checksum
4.0.0.0   1.1.1.1       2007    0x80000002    0x9990
4.0.0.0   3.3.3.3       967     0x80000001    0xEBF5
12.0.0.0  1.1.1.1       973     0x80000001    0xBF22
12.0.0.0  3.3.3.3       987     0x80000001    0xF624

                Router Link States (Area 2)

Link ID   ADV Router    Age    Seq#          Checksum   Link count
3.3.3.3   3.3.3.3       987    0x80000003    0xCF5          1

                Summary Net Link States (Area 2)

Link ID   ADV Router    Age    Seq#        Checksum
4.0.0.0   3.3.3.3       968    0x80000001  0xEBF5
5.0.0.0   3.3.3.3       988    0x80000001  0x7A70
6.0.0.0   3.3.3.3       988    0x80000001  0xEA3F

Note que los LSA aprendidos a través del link virtual tienen la opción DoNotAge. El link virtual se trata como un circuito de la demanda.

Router1.1.1.1#show ip ospf database router 1.1.1.1

       OSPF Router with ID (1.1.1.1) (Process ID 2)

                Router Link States (Area 0)

  LS age: 1100
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 1.1.1.1

!--- For router links, Link State ID is always the same as the Advertising Router.

  Advertising Router: 1.1.1.1

!--- This is the router ID of the router that created this LSA.

  LS Seq Number: 80000003
  Checksum: 0xD5DF
  Length: 48
  Area Border Router

!--- Bit B in the router LSA indicates that this router is an ABR.

   Number of Links: 2

!--- There are two links in Area 0.

    Link connected to: a Virtual Link
     (Link ID) Neighboring Router ID: 3.3.3.3

!--- Router ID of the neighbor on the other end of the virtual link.

     (Link Data) Router Interface address: 5.0.0.1

!--- The interface that this router uses to send packets to the neighbor.

      Number of TOS metrics: 0
       TOS 0 Metrics: 65

!--- The metric comes from the cost for this router to reach the neighboring router:
!--- the ATM link has a cost of 1 and the serial link has a cost of 64.

    Link connected to: a Stub Network

!--- This represents the Ethernet segment 4.0.0.0/8.

     (Link ID) Network/subnet number: 4.0.0.0
     (Link Data) Network Mask: 255.0.0.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 10

                Router Link States (Area 1)

  LS age: 122
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 1.1.1.1
  Advertising Router: 1.1.1.1
  LS Seq Number: 80000006
  Checksum: 0xDBA7
  Length: 48
  Area Border Router
   Number of Links: 2

!--- There are two links in Area 1.

    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 2.2.2.2
     (Link Data) Router Interface address: 5.0.0.1
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 5.0.0.0
     (Link Data) Network Mask: 255.0.0.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

Router1.1.1.1#show ip ospf database router 2.2.2.2

       OSPF Router with ID (1.1.1.1) (Process ID 2)

                Router Link States (Area 1)

  LS age: 245
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 2.2.2.2
  Advertising Router: 2.2.2.2
  LS Seq Number: 80000009
  Checksum: 0x64DD
  Length: 72
   Number of Links: 4

!--- There are four links in Area 1.


    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 3.3.3.3
     (Link Data) Router Interface address: 6.0.0.2
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 6.0.0.0
     (Link Data) Network Mask: 255.0.0.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 1.1.1.1
     (Link Data) Router Interface address: 5.0.0.2
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 5.0.0.0
     (Link Data) Network Mask: 255.0.0.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

Router1.1.1.1#show ip ospf database router 3.3.3.3

       OSPF Router with ID (1.1.1.1) (Process ID 2)

                Router Link States (Area 0)

  Routing Bit Set on this LSA
  LS age: 5 (DoNotAge)
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 3.3.3.3
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0x3990
  Length: 36
  Area Border Router
   Number of Links: 1

!--- There is one link in Area 0.


    Link connected to: a Virtual Link
     (Link ID) Neighboring Router ID: 1.1.1.1
     (Link Data) Router Interface address: 6.0.0.3
      Number of TOS metrics: 0
       TOS 0 Metrics: 65

                Router Link States (Area 1)

  Routing Bit Set on this LSA
  LS age: 1137
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 3.3.3.3
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000006
  Checksum: 0xA14C
  Length: 48
  Area Border Router
   Number of Links: 2

!--- There are two links in Area 1.


    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 2.2.2.2
     (Link Data) Router Interface address: 6.0.0.3
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 6.0.0.0
     (Link Data) Network Mask: 255.0.0.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

Router3.3.3.3 se considera un ABR porque tiene un link al área 0 (el link virtual). Como consecuencia, genera un LSA de resumen para 12.0.0.0 en el área 1 y el área 0, que usted puede ver cuando usted publica el comando show ip ospf database summary.

Router3.3.3.3#show ip ospf database summary 12.0.0.0

       OSPF Router with ID (3.3.3.3) (Process ID 2)

                Summary Net Link States (Area 0)

  LS age: 1779
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 12.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000001
  Checksum: 0xF624
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 10

                Summary Net Link States (Area 1)

  LS age: 1766
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 12.0.0.0 (summary Network Number)
  Advertising Router: 1.1.1.1
  LS Seq Number: 80000001
  Checksum: 0xBF22
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 75

  LS age: 1781
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 12.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000001
  Checksum: 0xF624
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 10

También, note que Router3.3.3.3 crea los LSA de resúmenes en el área 2 para toda la información que aprendió del área 0 y del área 1.

Router3.3.3.3#show ip ospf database summary self-originate

       OSPF Router with ID (3.3.3.3) (Process ID 2)

                Summary Net Link States (Area 0)

  LS age: 155
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 5.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0x7871
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 65

  LS age: 155
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 6.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0xE840
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 1

  LS age: 156
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 12.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0xF425
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 10

                Summary Net Link States (Area 1)

  LS age: 157
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 4.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0xE9F6
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 75

  LS age: 165
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 12.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0xF425
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 10

                Summary Net Link States (Area 2)

  LS age: 167
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 4.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0xE9F6
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 75

  LS age: 168
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 5.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0x7871
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 65

  LS age: 168
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 6.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0xE840
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 1

Troubleshooting

Use esta sección para resolver problemas de configuración.

Comandos para Troubleshooting

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Nota: Consulte Información Importante sobre Comandos de Debug antes de usar un comando debug.

  • haga el debug del ajuste OSPF del IP — Visualiza los eventos implicados para construir o para romper la adyacencia OSPF.

El Routers hace adyacente e intercambia los LSA vía el link virtual, similar a un vículo físico. Usted puede ver la adyacencia si usted examina el LSA de router o la salida del comando debug ip ospf adj:

Router3.3.3.3#
May 26 17:25:03.089: OSPF: Rcv hello from 1.1.1.1 area 0 from OSPF_VL3 5.0.0.1
May 26 17:25:03.091: OSPF: 2 Way Communication to 1.1.1.1 on OSPF_VL3, state 2WAY
May 26 17:25:03.091: OSPF: Send DBD to 1.1.1.1 on OSPF_VL3
                           seq 0xD1C opt 0x62 flag 0x7 len 32
May 26 17:25:03.135: OSPF: End of hello processing
May 26 17:25:03.139: OSPF: Rcv DBD from 1.1.1.1 on OSPF_VL3
                           seq 0x1617 opt 0x22 flag 0x7 len 32
                           mtu 0 state EXSTART
May 26 17:25:03.175: OSPF: First DBD and we are not SLAVE
May 26 17:25:03.179: OSPF: Rcv DBD from 1.1.1.1 on OSPF_VL3
                           seq 0xD1C opt 0x22 flag 0x2 len 172
                           mtu 0 state EXSTART
May 26 17:25:03.183: OSPF: NBR Negotiation Done. We are the MASTER
May 26 17:25:03.189: OSPF: Send DBD to 1.1.1.1 on OSPF_VL3
                           seq 0xD1D opt 0x62 flag 0x3 len 172
May 26 17:25:03.191: OSPF: Database request to 1.1.1.1
May 26 17:25:03.191: OSPF: sent LS REQ packet to 5.0.0.1, length 36
May 26 17:25:03.263: OSPF: Rcv DBD from 1.1.1.1 on OSPF_VL3
                           seq 0xD1D opt 0x22 flag 0x0 len 32
                           mtu 0 state EXCHANGE
May 26 17:25:03.267: OSPF: Send DBD to 1.1.1.1 on OSPF_VL3
                           seq 0xD1E opt 0x62 flag 0x1 len 32
May 26 17:25:03.311: OSPF: Rcv DBD from 1.1.1.1 on OSPF_VL3
                           seq 0xD1E opt 0x22 flag 0x0 len 32
                           mtu 0 state EXCHANGE
May 26 17:25:03.311: OSPF: Exchange Done with 1.1.1.1 on OSPF_VL3
May 26 17:25:03.315: OSPF: Synchronized with 1.1.1.1 on OSPF_VL3, state FULL
May 26 17:25:03.823: OSPF: Build router LSA for area 0,
                           router ID 3.3.3.3, seq 0x80000029
May 26 17:25:03.854: OSPF: Dead event ignored for 1.1.1.1 on demand circuit OSPF_VL3

Router3.3.3.3#show ip ospf neighbor

Neighbor ID       Pri       State        Dead Time       Address         Interface
2.2.2.2           1         FULL/  -     00:00:38        6.0.0.2         ATM2/0.20

Router3.3.3.3#show ip ospf virtual-links

Virtual Link OSPF_VL3 to router 1.1.1.1 is up
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 1, via interface ATM2/0.20, Cost of using 65
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:01
    Adjacency State FULL (Hello suppressed)
    Index 1/2, retransmission queue length 0, number of retransmission 0
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 0, maximum is 0
    Last retransmission scan time is 0 msec, maximum is 0 msec

Note que las adyacencias sobre los links virtuales no están visualizadas en la salida del comando show ip ospf neighbor. La única forma de considerarlas es mirar el LSA de router y observar los comandos debug como sube la adyacencia, o publica el comando show ip ospf virtual-links.


Información Relacionada


Document ID: 47866