IP : Open Shortest Path First (OSPF)

Cómo propaga OSPF rutas externas en varias áreas

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento muestra cómo Open Shortest Path First (OSPF) propaga rutas externas en varias áreas de la red.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la configuración de red que se muestra en el siguiente diagrama.

/image/gif/paws/47865/ospfdb6a.gif

Configuraciones

Este documento usa las configuraciones detalladas aquí.

Router 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0

interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
router ospf 4
 redistribute static metric 5 metric-type 1
 network 5.0.0.0 0.255.255.255 area 1
 network 4.0.0.0 0.255.255.255 area 1

ip route 9.0.0.0 255.0.0.0 4.0.0.2

end

Router 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0

end

Router 3.3.3.3
Current configuration:

hostname r3.3.3.3

interface Loopback0
 ip address 3.3.3.3 255.0.0.0

interface ATM2/0.20 point-to-point
 ip address 6.0.0.3 255.0.0.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0

end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • muestre la base de datos OSPF del IP — Visualiza una lista de los anuncios del estado del link (LSA) y los teclea en una base de datos del estado del link. Esta lista muestra solamente la información en el encabezado LSA.

  • show ip ospf database [router] [link-state-id] — Visualiza una lista de todos los LSA de un router en la base de datos. Los LSA son producidos por cada router. Estos LSA fundamentales enumeran los links de todo el Routers, o las interfaces, junto con los estados y los costos de salida del link. Se inundan solamente dentro del área en la cual originan.

  • muestre el id> del <link-estado del Resumen de la base de datos OSPF del IP — Visualiza el Summary Links del router del borde del área (ABR).

  • muestre el externo de la base de datos OSPF del IP — Visualiza la información solamente sobre el LSA externo.

  • muestre el resumen ASBR de la base de datos OSPF del IP — Visualiza la información solamente sobre los LSA de resúmenes del Autonomous System Boundary Router.

Examine la base de datos OSPF

Esta salida muestra cómo las miradas de la base de datos OSPF dadas este entorno de red, usando el comando show ip ospf database.

r2.2.2.2#show ip ospf database
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Router Link States (Area 0) 
  
Link ID    ADV Router    Age    Seq#          Checksum   Link count 
2.2.2.2    2.2.2.2       93     0x80000020    0xCD0B         2 
3.3.3.3    3.3.3.3       1225   0x8000000D    0x9057         2 
  
                Summary Net Link States (Area 0) 
  
Link ID    ADV Router    Age   Seq#           Checksum 
4.0.0.0     2.2.2.2      73    0x80000001     0xFFE6 
5.0.0.0     2.2.2.2      1651  0x80000006     0x8466 
  
                Summary ASB Link States (Area 0) 
  
Link ID   ADV Router    Age   Seq#           Checksum 
1.1.1.1    2.2.2.2      74    0x80000001     0x935C 
  
                Router Link States (Area 1) 
  
Link ID   ADV Router   Age   Seq#         Checksum    Link count 
1.1.1.1   1.1.1.1      89    0x80000011   0xFF59          3 
2.2.2.2   2.2.2.2      88    0x80000033   0x2130          2 
  
                Summary Net Link States (Area 1) 
  
Link ID   ADV Router  Age    Seq#         Checksum 
6.0.0.0   2.2.2.2     94     0x8000001F   0xCC43 
  
                Type-5 AS External Link States 
  
Link ID   ADV Router   Age   Seq#         Checksum   Tag 
9.0.0.0   1.1.1.1      135   0x80000001   0x3AE8      0 

Para anunciar las rutas externas en OSPF, el Router de límite del sistema autónomo (ASBR) crea LSA externos (tipo 5).

r2.2.2.2#show ip ospf database external 9.0.0.0
          OSPF Router with ID (2.2.2.2) (Process ID 2)
                   Type-5 AS External Link States
     Routing Bit Set on this LSA
     LS age: 286
     Options: (No TOS-capability, DC)
     LS Type: AS External Link
     Link State ID: 9.0.0.0 (External Network Number )
  
!--- 9.0.0.0/8 is advertised by the
   !--- ASBR (Router 1.1.1.1).

   Advertising Router: 1.1.1.1
   LS Seq Number: 80000001
   Checksum: 0x3AE8
   Length: 36
   Network Mask: /8
         Metric Type: 1 (Comparable directly to link state metric)
         TOS: 0
         Metric: 5
         Forward Address: 0.0.0.0
		  
!--- Forwarding address is not specified since there
  		!--- are no OSPF neighbors on Router 1.1.1.1's Ethernet.
    !--- When the forward address is 0.0.0.0, this means that 
    !--- the traffic for this network is to be sent to the 
    !--- advertising router (1.1.1.1).
 
External Route Tag: 0  

Para hacer publicidad del accesibilidad de un ASBR en otras áreas, el ABR crea (el resumen ASBR LSA del tipo 4).

r2.2.2.2#show ip ospf database asbr-summary 1.1.1.1 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Summary ASB Link States (Area 0) 
  
  LS age: 266 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(AS Boundary Router) 
  Link State ID: 1.1.1.1 (AS Boundary Router address)
  
!--- ABR (Router 2.2.2.2) is advertising that it knows how
  !--- to reach the ASBR (Router 1.1.1.1). 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0x935C 
  Length: 28 
  Network Mask: /0 
        TOS: 0  Metric: 64
		
!--- The ABR's cost to reach the ASBR.
 

El ABR (router 2.2.2.2) ha instalado una ruta externo aprendida del ASBR (router 1.1.1.1) e inundada el externo LSA del área 1 en el área 0. (el LSA externo se inunda inalterado en todas las áreas.) Sin embargo, el ASBR no está en el Routers del área 0. en el área 0 no sabe alcanzar el ASBR. Esta es la razón por la cual el ABR crea un resumen ASBR LSA y hace publicidad del accesibilidad para el router 1.1.1.1 en el área 0.

Nota: Este conjunto siguiente de salida se presenta para dar solamente más detalles sobre la base de datos OSPF en esta configuración del ejemplo. Si usted es familiar con esta información, salte al cálculo la sección del trayecto más corto.


r2.2.2.2#show ip ospf database router 1.1.1.1 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Router Link States (Area 1) 
  
  Routing Bit Set on this LSA 
  LS age: 109 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, Link State Id is always the 
  !--- same as the Advertising Router. 

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that created
  !--- this LSA. 

  LS Seq Number: 80000011 
  Checksum: 0xFF59 
  Length: 60 
  AS Boundary Router
  
!--- Bit E in the router LSA indicates that this 
  !--- router originates external LSAs. 

   Number of Links: 3
   
!--- There are three links in area 1. 

  
    Link connected to: a Stub Network
	
!--- This line represents the Ethernet segment 
    !--- 4.0.0.0/8.
 
     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
	   
!--- OSPF cost of the Ethernet segment. 

  
    Link connected to: another Router (point-to-point)
	
!--- This line shows that Router 1.1.1.1 is a 
	!--- neighbor with Router 2.2.2.2. 

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 5.0.0.1
	 
!--- The interface address that connects to 
	 !--- Router 2.2.2.2 is 5.0.0.1.
 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64
	   
!--- OSPF cost of the link connecting the two routers. 

  
    Link connected to: a Stub Network
	
!--- This line represents the serial link 5.0.0.0/8. 

     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64
	   
!--- OSPF cost of the serial link. 

  
r2.2.2.2#show ip ospf database router 2.2.2.2 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Router Link States (Area 0) 
  
  LS age: 135 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000020 
  Checksum: 0xCD0B 
  Length: 48 
  Area Border Router
   Number of Links: 2
  
    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 3.3.3.3 
     (Link Data) Router Interface address: 6.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 
  
    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 
  
  
                Router Link States (Area 1) 
  
  LS age: 130 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000033 
  Checksum: 0x2130 
  Length: 48 
  Area Border Router
   Number of Links: 2
  
    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 5.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 
  
    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 
  

r2.2.2.2#show ip ospf database router 3.3.3.3 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Router Link States (Area 0) 
  
  LS age: 1280 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 3.3.3.3 
  Advertising Router: 3.3.3.3 
  LS Seq Number: 8000000D 
  Checksum: 0x9057 
  Length: 48 
   Number of Links: 2 
  
    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 6.0.0.3 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 
  
    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

Para anunciar las rutas de un área a otra, la ABR crea resúmenes LSA (tipo 3).

r2.2.2.2#show ip ospf database summary 4.0.0.0 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Summary Net Link States (Area 0) 
  
  LS age: 184 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 4.0.0.0 (summary Network Number)
  
!--- 4.0.0.0/8 is advertised into area 0 by 
  !--- the ABR (Router 2.2.2.2).
 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0xFFE6 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 74 



r2.2.2.2#show ip ospf database summary 5.0.0.0 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Summary Net Link States (Area 0) 
  
  LS age: 1768 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 5.0.0.0 (summary Network Number)
 
 !--- 5.0.0.0/8 is advertised into area 0 by 
  !--- the ABR (Router 2.2.2.2). 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000006 
  Checksum: 0x8466 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 64 



r2.2.2.2#show ip ospf database summary 6.0.0.0 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Summary Net Link States (Area 1) 
  
  LS age: 216 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 6.0.0.0
  
!--- 6.0.0.0/8 is advertised into area 1 by the ABR(2.2.2.2).
 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000001F 
  Checksum: 0xCC43 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 1 

Calcule el trayecto más corto

Esta sección calcula el trayecto más corto desde la perspectiva del router 3.3.3.3.

El router 3.3.3.3 aparece en su propio LSA y detecta que el router 2.2.2.2 es un vecino. Luego mira el LSA del Router 2.2.2.2 para verificar que el Router 2.2.2.2 vea al Router 3.3.3.3 como un vecino. Si ambo Routers se ve como vecinos, después lo consideran accesible.

Cada router también comprueba su tabla de vecino local (que puede ver usando el comando show ip ospf neighbor) para verificar que ésta y la interfaz del vecino estén en una subred IP común.

Nota: Este control no se realiza en una interfaz sin numerar.

Si las interfaces están en una subred común, los routers instalan rutas para todas las redes stub listadas en el LSA del router de su vecino. En este ejemplo, 60.0.0.0/8 es la única red Stub enumerada en el router 2.2.2.2's LSA en el área 0, con la cual el router 3.3.3.3 ya está conectado directamente.

Después de examinar todos los LSA de routeres alcanzables en el área 0, el router 3.3.3.3 mira los LSA de resúmenes en la base de datos. Encuentra los LSA de resúmenes para 4.0.0.0/8 y 5.0.0.0/8. Si el Router 3.3.3.3 sabe cómo alcanzar el router anunciante que creó el resumen LSA, instala la ruta en su tabla de ruteo. En nuestro ejemplo, el router de anuncio es el router 2.2.2.2, que el router 3.3.3.3 sabe alcanzar. Instala las rutas para 4.0.0.0/8 y 5.0.0.0/8 en su tabla de ruteo. La métrica para estas rutas es la métrica para alcanzar el router de anuncio más la métrica del LSA de resumen. La métrica del LSA de resumen se calcula desde el costo para alcanzar la ruta intra e interzonal para la cual se generó el LSA de resumen.

Luego de calcular todas las rutas OSPF internas (área interna y externa), el router 3.3.3.3 examina los LSA externos. Primero examina el LSA 9.0.0.0/8 externo creado por el ASBR 1.1.1.1, y luego calcula cómo alcanzar el ASBR. El router 3.3.3.3 examina el resumen ASBR LSA para el router 1.1.1.1, creado por el ABR (router 2.2.2.2). Después de hacer esto, el Router 3.3.3.3 sabe que el ASBR puede alcanzarse a través del ABR. Por lo tanto, el Router 3.3.3.3 instala una ruta para 9.0.0.0/8 en su tabla de ruteo. En nuestro ejemplo, es una ruta E1, por lo tanto la métrica para ésta es la métrica del Router 3.3.3.3 para alcanzar la ABR, más la métrica de la ABR para alcanzar la ASBR, más la métrica del LSA externo.

Esta salida muestra las OSPF rutas en la tabla de ruteo de cada router descrito.

r3.3.3.3#
show ip route ospf
 
O IA 4.0.0.0/8 [110/75] via 6.0.0.2, 00:07:59, ATM2/0.20 
O IA 5.0.0.0/8 [110/65] via 6.0.0.2, 00:07:59, ATM2/0.20 
O E1 9.0.0.0/8 [110/70] via 6.0.0.2, 00:07:59, ATM2/0.20 
  

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 5.0.0.1, 00:06:55, Serial0/1/0 
O E1 9.0.0.0/8 [110/69] via 5.0.0.1, 00:06:55, Serial0/1/0 
  

r1.1.1.1#show ip route 9.0.0.0 
Routing entry for 9.0.0.0/8 
  Known via "static", distance 1, metric 0 
  Redistributing via ospf 4 
  Advertised by ospf 4 metric 5 metric-type 1 
  Routing Descriptor Blocks: 
  * 4.0.0.2 
      Route metric is 0, traffic share count is 1

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Información Relacionada


Document ID: 47865