IP : Open Shortest Path First (OSPF)

Ruteo Interzonal OSPF

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento analiza la base de datos OSPF (Open Shortest Path First) y la tabla de ruteo cuando OSPF se ejecuta en dos áreas.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/47864/ospfdb5a.gif

Configuraciones

Este documento usa estas configuraciones.

Router 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Serial2/1/0
 ip unnumbered Ethernet2/0/0
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0

end

Router 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Serial0/1/0
 ip unnumbered Ethernet0/0/4

interface ATM1/0.20 point-to-point
 ip address 200.0.0.2 255.255.255.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0
 network 200.0.0.0 0.255.255.255 area 1

end

Router 3.3.3.3
Current configuration:

hostname r3.3.3.3

interface Loopback0
 ip address 3.3.3.3 255.0.0.0

interface ATM2/0.20 point-to-point
 ip address 200.0.0.3 255.255.255.0
 
router ospf 2
 network 200.0.0.0 0.255.255.255 area 1

end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • muestre la base de datos OSPF del IP — Visualiza una lista de los anuncios del estado del link (LSA) en la base de datos del estado del link. Esta lista muestra solamente la información en el encabezado LSA.

  • show ip ospf database [router] [link-state-id] — Visualiza el contenido del LSA de router (tipo 1 LSA) en la base de datos. Los LSA de routeres son producidos por cada router, y estos LSA fundamentales enumeran todo el de los links del router, o de las interfaces, junto con los estados y los costos de salida del link. Se inundan solamente dentro del área en la cual originan.

  • muestre el id> del <link-estado del Resumen de la base de datos OSPF del IP — Visualiza el Summary Links del router del borde del área (ABR).

Examine la base de datos OSPF

Puesto que el router 2.2.2.2 es el ABR, tiene la base de datos para ambas áreas que está conectado con. Esto lo convierte en el mejor lugar para ver la base de datos OSPF, con el comando show ip ospf database.

r2.2.2.2#show ip ospf database

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age    Seq#          Checksum   Link count 
1.1.1.1   1.1.1.1      697    0x80000040    0x5A21         2 
2.2.2.2   2.2.2.2      696    0x80000045    0xEE82         2 

                Summary Net Link States (Area 0) 

Link ID     ADV Router   Age  Seq#          Checksum 
200.0.0.0   2.2.2.2      352  0x80000001    0x2546 

                Router Link States (Area 1) 

Link ID   ADV Router Age    Seq#          Checksum   Link count 
2.2.2.2   2.2.2.2    351    0x8000000B    0xCA9D         2 
3.3.3.3   3.3.3.3    354    0x80000006    0x71F7         2 

                Summary Net Link States (Area 1) 

Link ID    ADV Router   Age   Seq#         Checksum 
4.0.0.0    2.2.2.2      689   0x80000001   0xFFE6 
6.0.0.0    2.2.2.2      700   0x80000001   0x63C1 

 r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 773 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, Link State Id is always the same as the 
  !--- Advertising Router (next line).

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that created this LSA.

  LS Seq Number: 80000040 
  Checksum: 0x5A21 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point)
	
!--- This line shows that Router 1.1.1.1 is a neighbor 
    !--- with Router 2.2.2.2. 

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 0.0.0.12
    
 !--- The link is unnumbered, so the address starts with 
	 !--- zero. In the case of unnumbered links, the interface address 
     !--- displays the MIB II IfIndex value that usually starts with 0.
 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64
	   
!--- This is the OSPF cost of the link that connects 
       !--- the two routers.
 

    Link connected to: a Stub Network

	!--- This line represents the Ethernet segment 4.0.0.0/8.
 
     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

        Router Link States (Area 0) 

!--- This is the router LSA for 2.2.2.2 in area 0. 


  LS age: 789 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000045 
  Checksum: 0xEE82 
  Length: 48 
  Area Border Router
  
!--- Bit B is set in the router LSA. 
  !--- It indicates that this router is an ABR.
 
   Number of Links: 2
   
!--- There are two links in area 0. 


    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 0.0.0.10 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

                Router Link States (Area 1)    
				
!--- This is the router LSA for 
    			!--- Router 2.2.2.2 in area 1. 


  LS age: 445 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000000B 
  Checksum: 0xCA9D 
  Length: 48 
  Area Border Router
   Number of Links: 2

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 3.3.3.3 
     (Link Data) Router Interface address: 200.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 200.0.0.0 
     (Link Data) Network Mask: 255.255.255.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

r2.2.2.2#show ip ospf database router 3.3.3.3 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 1) 

  LS age: 465 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 3.3.3.3 
  Advertising Router: 3.3.3.3 
  LS Seq Number: 80000006 
  Checksum: 0x71F7 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 200.0.0.3 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 200.0.0.0 
     (Link Data) Network Mask: 255.255.255.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

Para hacer publicidad de las rutas a partir de una área en otra, el ABR crea el Summary Links, que usted puede ver usando el comando show ip ospf database summary <link-state id>.

r2.2.2.2#show ip ospf database summary 200.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 0) 

  LS age: 487 
  Options: (No TOS-capability, DC, Upward) 

  !--- The Upward keyword indicates that this is not an LSA imported 
  !--- from a VPN backbone (from a PE to a CE).

  LS Type: Summary Links(Network) 
  Link State ID: 200.0.0.0 (summary Network Number)
  
!--- 200.0.0.0/24 is advertised into area 0 by the 
  !--- ABR (Router 2.2.2.2). 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0x2546 
  Length: 28 
  Network Mask: /24 
        TOS: 0  Metric: 1 

r2.2.2.2#show ip ospf database summary 4.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 1) 

  LS age: 840 
  Options: (No TOS-capability, DC, Upward) 
  LS Type: Summary Links(Network) 
  Link State ID: 4.0.0.0 (summary Network Number)
  
!--- 4.0.0.0/8 is advertised into area 1 by 
  !--- the ABR (Router 2.2.2.2).
 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0xFFE6 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 74 

r2.2.2.2#show ip ospf database summary 6.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 1) 

  LS age: 861 
  Options: (No TOS-capability, DC, Upward) 
  LS Type: Summary Links(Network) 
  Link State ID: 6.0.0.0 (summary Network Number)
  
!--- 6.0.0.0/8 is advertised into area 1 by the 
  !--- ABR (Router 2.2.2.2). 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0x63C1 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 10 

Calcule el trayecto más corto

Esta sección calcula el trayecto más corto desde la perspectiva del router 3.3.3.3.

El router 3.3.3.3 aparece en su propio LSA y detecta que el router 2.2.2.2 es un vecino. El router 3.3.3.3 entonces mira al router 2.2.2.2's LSA para verificar que el router 2.2.2.2 ve al router 3.3.3.3 como vecino. Si ambo Routers se ve como vecinos, lo consideran accesible.

Cada router también comprueba su tabla de vecino local (que puede ver usando el comando show ip ospf neighbor) para verificar que ésta y la interfaz del vecino estén en una subred IP común.

Nota: Este control no se realiza en una interfaz sin numerar.

Si las interfaces están en una subred común, el Routers instala las rutas para cualquier red Stub enumerada en el LSA de su vecino. En este ejemplo, 200.0.0.0/24 es la única red Stub enumerada en el router 2.2.2.2's LSA, con quien el router 3.3.3.3 ya está conectado directamente.

Después de todo los LSA de routeres alcanzables en el área 1 se examinan, las miradas de 3.3.3.3 del router en los LSA de resúmenes en la base de datos. Encuentra los LSA de resúmenes para 4.0.0.0/8 y 6.0.0.0/8. Si el Router 3.3.3.3 sabe cómo alcanzar el router anunciante que creó el resumen LSA, instala la ruta en su tabla de ruteo. En este ejemplo, el router de anuncio es router 2.2.2.2. Puesto que el router 3.3.3.3 sabe alcanzar al router 2.2.2.2, instala las rutas para 4.0.0.0/8 y 6.0.0.0/8 en su tabla de ruteo. La métrica para estas rutas es la métrica para alcanzar el router de anuncio más la métrica del LSA de resumen. La métrica del LSA de resumen se calcula desde el costo para alcanzar la ruta intra e interzonal para la cual se generó el LSA de resumen.

Nota: El Routers utiliza el tipo 1 LSA para hacer publicidad de las redes y del otro Routers con los cuales él está conectado directamente en un área, que se inunda dentro de la misma área. Así pues, todo el Routers dentro de la misma área tiene la información de topología completa para su propia área. Como consecuencia, los ABR mantienen la información de topología completa sobre todas las áreas a las cuales se asocien directamente. Sin embargo, cuando los ABR hacen publicidad de una red que pertenezca a una área en una segunda área, hacen publicidad solamente del prefijo y de la máscara de la red usando el Type-3 LSA. El Routers en la segunda área no sabe sobre la información de topología de otras áreas, sino que él tiene información de alcance para las redes en otras áreas.

Esta salida muestra las OSPF rutas en la tabla de ruteo de cada router descrito arriba.

r1.1.1.1# show ip route ospf 
O IA 200.0.0.0/24 [110/65] via 6.0.0.2, 00:09:00, Serial2/1/0 
O    6.0.0.0/8 [110/74] via 6.0.0.2, 00:14:41, Serial2/1/0 

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 4.0.0.1, 00:09:16, Serial0/1/0 

r3.3.3.3#show ip route ospf
O IA 4.0.0.0/8 [110/75] via 200.0.0.2, 00:09:27, ATM2/0.20 
O IA 6.0.0.0/8 [110/11] via 200.0.0.2, 00:09:27, ATM2/0.20 

Troubleshooting

¿Para la información sobre resolver problemas el OSPF cuando la información en la base de datos falta de la tabla de ruteo, refiérase a porqué son algunas OSPF rutas en la base de datos pero no en la tabla de ruteo? Para la información general del Troubleshooting de OSPF, refiera a resolver problemas el OSPF.


Información Relacionada


Document ID: 47864