IP : Open Shortest Path First (OSPF)

Routers OSPF conectados por una red multiacceso

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento muestra dos routers Open Shortest Path First (OSPF) conectados en una red de acceso múltiple.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la configuración de red que se muestra en el siguiente diagrama.

/image/gif/paws/47863/ospfdb4a.gif

Configuraciones

Este documento usa las configuraciones detalladas aquí.

Router 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Ethernet2/0/2
 ip address 5.0.0.1 255.0.0.0
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

Router 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Ethernet0/0/2
 ip address 5.0.0.2 255.0.0.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • muestre la base de datos OSPF del IP — Visualiza una lista de los anuncios del estado del link (LSA) y los teclea en una base de datos del estado del link. Esta lista muestra solamente la información en el encabezado LSA.

  • show ip ospf database [router] [link-state-id] — Visualiza una lista de todos los LSA de un router en la base de datos. Los LSA son producidos por cada router, y estos LSA fundamentales enumeran los links de todo el Routers, o las interfaces, junto con los estados y los costos de salida del link. Se inundan solamente dentro del área en la cual originan.

Examine las bases de datos OSPF

Para ver cómo las miradas de las bases de datos OSPF dadas este entorno de red, miran la salida del comando show ip ospf database.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router  Age   Seq#         Checksum  Link count 
1.1.1.1   1.1.1.1     107   0x80000018   0x7966        2 
2.2.2.2   2.2.2.2     106   0x80000015   0x6770        2 

                Net Link States (Area 0) 

Link ID   ADV Router  Age   Seq#         Checksum 
5.0.0.2   2.2.2.2     102   0x80000004   0x7E9D 
  

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 147 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, the Link State Id is always the 
  !--- same as the Advertising Router. 

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that created 
  !--- this LSA.
 
  LS Seq Number: 80000018 
  Checksum: 0x7966 
  Length: 48 
   Number of Links: 2 

    Link connected to: a Transit Network
    
!--- This router (1.1.1.1) has a link connected to 
    !--- a transit network that has a designated router (DR)
    !--- and backup designated router (BDR) listed here.  

     (Link ID) Designated Router address: 5.0.0.2
	 
!--- The DR's interface IP address is 5.0.0.2.
 
     (Link Data) Router Interface address: 5.0.0.1
	 
!--- This router's (1.1.1.1) interface address 
     !--- connected to the DR is 5.0.0.1. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
       
!--- The OSPF cost of the link is 10.
 

    Link connected to: a Stub Network 
    
!--- This represents the subnet of the Ethernet segment
    !--- 4.0.0.0/8. 

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
       
!--- The cost of the link is 10. 


r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 162 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000015 
  Checksum: 0x6770 
  Length: 48 
   Number of Links: 2 

    Link connected to: a Transit Network 
     (Link ID) Designated Router address: 5.0.0.2
     
!--- The DR's interface IP address is 5.0.0.2.
 
     (Link Data) Router Interface address: 5.0.0.2
     
!--- Since these values are equal, router
     !--- (2.2.2.2) is the DR. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 
  

r2.2.2.2#show ip ospf database network 5.0.0.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Net Link States (Area 0) 

  Routing Bit Set on this LSA 
  LS age: 182 
  Options: (No TOS-capability, DC) 
  LS Type: Network Links 
  Link State ID: 5.0.0.2 (address of Designated Router)
  
!--- This is the IP address of the DR 
  !--- (not the router ID). 

  Advertising Router: 2.2.2.2
  
!--- This is the router ID of the router that 
  !--- created this LSA.

  LS Seq Number: 80000004 
  Checksum: 0x7E9D 
  Length: 32 
  Network Mask: /8
  
!--- Binary and the DR's interface address with the 
  !--- mask to get to network 5.0.0.0/8. 

        Attached Router: 2.2.2.2
	
!--- The DR's router ID, along with a list of routers 
    !--- adjacent on the transit network. 

        Attached Router: 1.1.1.1 

Calcule el trayecto más corto

Esta sección calcula el árbol de trayecto más corto desde la perspectiva del router 1.1.1.1.

El router 1.1.1.1 mira en su propio LSA y ve que tiene un link a un transit network para el cual 5.0.0.2 sea el direccionamiento de la interfaz DR. Entonces busca la red LSA con un estado ID del link de 5.0.0.2. Encuentra una lista de routers asociados (Routers 1.1.1.1 y 2.2.2.2) en la LSA de la red. Esto significa que todos estos routers se pueden alcanzar a través de esta red de tránsito. El router 1.1.1.1 puede verificar que su propio ID esté en la lista. Entonces puede calcular las rutas a través de ninguno de estos routeres conectados.

El router 1.1.1.1 busca el LSA del router 2.2.2.2 para verificar que contiene un link conectado a la misma red de tránsito, 5.0.0.2. El router 1.1.1.1 ahora puede instalar rutas para cualquier red Stub en el LSA del router 2.2.2.2.

El router 1.1.1.1 instala una ruta para la red 6.0.0.0/8 en tabla de ruteo porque 6.0.0.0/8 estaba enumerada como una red Stub en su LSA.

r1.1.1.1#show ip route ospf 
O    6.0.0.0/8 [110/20] via 5.0.0.2, 00:03:35, Ethernet2/0/2 

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/20] via 5.0.0.1, 00:03:18, Ethernet0/0/2 

La base de datos de estado de links OSPF parece idéntica si es una red de broadcast o una red sin broadcast. La diferencia principal es el mecanismo de detección del vecino. En una red de broadcast, descubren a los vecinos a través de los paquetes de saludo de multidifusión. En un red de no difusión, los vecinos están configurados estadísticamente y los paquetes de saludo de unidifusión son enviados para formar adyacencia entre vecinos.

El salto siguiente en las redes de acceso múltiple de no difusión

Para explorar la aplicación el salto siguiente en una red del acceso múltiple sin broadcast (NBMA), mire este ejemplo. Hay tres routers en una red de tránsito (Routers non_DR_a, non_DR_b y DR). Es un topologia Hub y Spoke en medio NBMA tal como Frame Relay, Asynchronous Transfer Mode (ATM), o X.25.

/image/gif/paws/47863/ospfdb4b.gif

Cuando el router non_DR_a calcula rutas a través del router non_DR_b, convierte al router non_DR_b en el salto siguiente. Sin embargo, el non_DR_a del router no tiene un virtual circuit (VC) al non_DR_b del router, que significa que este Routers no puede hacerse ping. El OSPF instala las rutas en la tabla de ruteo con un Next-Hop que no pueda ser alcanzado.

La solución a este problema consiste en agregar una segunda sentencia de mapa frame-relay para poder llegar a todos los vecinos a través del VC que va al Router DR. Por ejemplo:

interface Serial0 
 frame-relay map ip 1.1.1.1 700 broadcast
 
!--- This is a map for the DR. 

 frame-relay map ip 1.1.1.2 700 broadcast
 
!--- This is a map on the same VC data-link connection 
 !--- identifier (DLCI) for a non-DR router. 

Cuando usted compara este comportamiento con el del protocolo del Intermediate System-to-Intermediate System (ISIS), un router no instala un ISIS Route a través de un salto siguiente, a menos que el salto siguiente sea un vecino. Esto significa que el ISIS no trabaja en una interfaz de múltiples puntos a menos que enreden al Routers completamente.

El OSPF instala las rutas aunque el salto siguiente no es un vecino, y no es la capa directa accesible 2. Sin embargo, usted puede reparar este problema configurando las sentencias de correspondencia múltiples.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 47863