IP : Open Shortest Path First (OSPF)

Routers OSPF conectados mediante un link punto a multipunto

24 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

Este documento muestra a dos Routers del Open Shortest Path First (OSPF) conectado por un link de la punta a de múltiples puntos.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/47862/ospfdb3a.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Router 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 ip ospf network point-to-multipoint
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

Router 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Serial2/1/0
 ip address 5.0.0.2 255.0.0.0
 ip ospf network point-to-multipoint
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

  • muestre la base de datos OSPF del IP — Visualiza una lista de los anuncios del estado del link (LSA) y los teclea en una base de datos del estado del link. Esta lista muestra solamente la información en el encabezado LSA.

  • show ip ospf database [router] [link-state-id] — Visualiza una lista de todos los LSA de un router en la base de datos. Los LSA son producidos por cada router. Estos LSA fundamentales enumeran los links o las interfaces de todo el Routers, junto con los estados y los costos de salida del link. Se inundan solamente dentro del área en la cual originan.

Examine las bases de datos OSPF

Para ver cómo las miradas de las bases de datos OSPF dadas este entorno de red, miran la salida del comando show ip ospf database.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age    Seq#           Checksum   Link count 
1.1.1.1  1.1.1.1       206    0x8000000A     0x158C       3 
2.2.2.2  2.2.2.2       206    0x8000000B     0x791        3 

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 224 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, Link State Id is always the same 
  !--- as the Advertising Router (next line).

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that created 
  !--- this LSA.

  LS Seq Number: 8000000A 
  Checksum: 0x158C 
  Length: 60 
   Number of Links: 3 

    Link connected to: another Router (point-to-point) 
   
 !--- This line shows that this router(1.1.1.1) is a 
	   !--- neighbor with 2.2.2.2.

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 5.0.0.1 
     
!--- This line shows the interface on this router 
	    !--- (1.1.1.1) that connects the neighbor (2.2.2.2).

      Number of TOS metrics: 0 
       TOS 0 Metrics: 64  
       
!--- The OSPF cost of the link is 64.


    Link connected to: a Stub Network 
    
!--- This router's (1.1.1.1) interface on the 
    !--- point-to-multipoint network. 

     (Link ID) Network/subnet number: 5.0.0.1 
     (Link Data) Network Mask: 255.255.255.255
     
!--- Notice the mask. Only the interface is advertised,
     !--- not the whole subnet. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 0
      
 !--- The OSPF cost for this router to reach its 
       !--- own interface is zero. 


    Link connected to: a Stub Network
	
!--- Represents the subnet of the Ethernet segment 4.0.0.0/8. 

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
	   
!--- The cost of the link is 10.


r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 253 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000000B 
  Checksum: 0x791 
  Length: 60 
   Number of Links: 3 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 5.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 5.0.0.2 
     (Link Data) Network Mask: 255.255.255.255 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 0 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10

Calcule el trayecto más corto

Esta sección calcula el árbol de trayecto más corto desde la perspectiva del router 2.2.2.2.

El router 2.2.2.2 aparece en su propio LSA y detecta que el router 1.1.1.1 es un vecino. El router 2.2.2.2 mira al LSA de router de 1.1.1.1 para verificar que 1.1.1.1 vea a 2.2.2.2 como un vecino. Si ambo Routers se ve como vecinos, después lo consideran accesible.

Cada router también verifica su tabla de vecino local (puede verificarla usando el comando show ip ospf neighbor) para comprobar que su interfaz y la interfaz del vecino estén en una subred IP común. Si así es, los routers instalan rutas para todas las redes Stub enumeradas en el LSA de rutas de su vecino.

En este ejemplo, el router 2.2.2.2 instala una ruta para 4.0.0.0/8 en su tabla de ruteo porque el router 1.1.1.1 descrito como 4.0.0.0/8 como una red Stub en su propio LSA de router. El router 1.1.1.1 también aparece como stub 5.0.0.1/32, que es su interfaz en la red punto a multipunto. Por lo tanto, el router 2.2.2.2 instala una OSPF ruta para 5.0.0.1/32 en su tabla de ruteo.

Router 2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 5.0.0.1, 00:09:26, Serial0/1/0 
O    5.0.0.1/32 [110/64] via 5.0.0.1, 00:09:26, Serial0/1/0
  
Router 1.1.1.1#show ip route ospf 
O    6.0.0.0/8 [110/74] via 5.0.0.2, 00:00:49, Serial2/1/0 
O    5.0.0.2/32 [110/64] via 5.0.0.2, 00:00:49, Serial2/1/0

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 47862