IP : Open Shortest Path First (OSPF)

Los routers OSPF conectados por un link serial sin número

24 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios



Contenido


Introducción

El comando ip unnumbered configuration le permite activar el procesamiento de IP en una interfaz serial sin asignarle una dirección de IP explícita. La interfaz sin numerar de IP puede “tomar prestada” la dirección IP de otra interfaz que ya esté configurada en el router. De esta forma se conserva el espacio de la red y de la dirección. Para obtener más información sobre el comando ip unnumbered, remítase a Cómo funciona y se Configura el Comando ip unnumbered. En este documento se describen dos routers Open Shortest Path First (OSPF) que están conectados a través de un link serial sin número.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la configuración de red que se muestra en este diagrama:

/image/gif/paws/47860/ospfdb1.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Router 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Serial2/1/0
 ip unnumbered Ethernet2/0/0
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0

end

Router 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Serial2/1/0
 ip unnumbered Ethernet0/0/4
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0

end

Verificación

Esta sección proporciona la información para confirmar que la configuración trabaja correctamente.

La herramienta Output Interpreter Tool (solo para clientes registrados) soporta ciertos comandos show. Esto le permitirá ver un análisis del resultado del comando show.

  • muestre la base de datos OSPF del IP — Visualiza una lista de los anuncios del estado del link (LSA) en la base de datos del estado del link. Esta lista muestra solamente la información en el encabezado LSA.

  • show ip ospf database [router] [link-state-id] — Visualiza el contenido del LSA de router (tipo 1 LSA) en la base de datos. Los LSA de routeres son producidos por cada router. Estos LSA fundamentales enumeran los links de todo el Routers, o las interfaces, junto con los estados y los costos de salida del link. Se inundan solamente dentro del área en la cual originan.

Examine las bases de datos OSPF

Para ver cómo las bases de datos OSPF miran cuando se dan este entorno de red, mire la salida del comando show ip ospf database.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router  Age   Seq#           Checksum     Link count 
1.1.1.1   1.1.1.1     254   0x8000001A     0xA6FA           2 
2.2.2.2   2.2.2.2     253   0x80000017     0x4858           2 

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  

                Router Link States (Area 0) 

  LS age: 279 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1   
  
!--- For router links, Link State Id is always the same as the 
  !--- Advertising Router (next line). 

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router which created 
  !--- this LSA.

  LS Seq Number: 8000001A 
  Checksum: 0xA6FA 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point)
	
!--- This line shows that this router (1.1.1.1) is a neighbor 
 !--- with 2.2.2.2.

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 0.0.0.12
		
!--- In the case of unnumbered link, use the MIB II IfIndex  
  !--- value. This value usually starts with 0. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 
	   
!--- This is the OSPF cost of the link that connects 
!--- the two routers.


    Link connected to: a Stub Network 
	
!--- This entry represents the Ethernet segment 4.0.0.0/8.

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10  
	   
!--- This is the OSPF cost of the Ethernet segment. 



r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  

                Router Link States (Area 0) 

  LS age: 295 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000017 
  Checksum: 0x4858 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 0.0.0.10 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

Calcule el trayecto más corto

Esta sección calcula el árbol de trayecto más corto desde la perspectiva del router 2.2.2.2.

El router 2.2.2.2 aparece en su propio LSA y detecta que el router 1.1.1.1 es un vecino. Entonces mira al router 1.1.1.1's LSA para verificar que 1.1.1.1 ve 2.2.2.2 como vecino. Si ambo Routers se ve como vecinos, lo consideran accesible. El Routers entonces instala las rutas para cualquier red Stub enumerada en el LSA de su vecino.

En este ejemplo, el router 2.2.2.2 instala una ruta para 4.0.0.0/8 en su tabla de ruteo porque el router 1.1.1.1 enumera 4.0.0.0/8 como red Stub en su LSA. Esto se ve con la ayuda del comando show ip route ospf.

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 4.0.0.1, 00:06:01, Serial0/1/0 

r1.1.1.1#show ip route ospf 
O    6.0.0.0/8 [110/74] via 6.0.0.2, 00:06:16, Serial2/1/0 

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 47860