Redes de almacenamiento : Canal de fibra

MDS a la configuración elaborada MDS con el FCIP

18 Junio 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (25 Abril 2016) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra para el Fibre Channel elaborado sobre el Switch del Director de capas múltiples TCP/IP (FCIP) (MDS) al MDS.

El FCIP describe los mecanismos que permiten que la interconexión de islas de las Redes de área de almacenamiento del Fibre Channel (FC) (sin) sobre las redes basadas en IP forme un SAN unificado en una sola tela FC. El FCIP confía en red basada en IP los servicios para proporcionar la Conectividad entre las islas SAN sobre las redes de área local, las redes de la área metropolitana, o las redes de área extensa.

Cuadro 1 – Fibre Channel sin conectado por el FCIP

/image/gif/paws/47120/ips8_elaborate_1.gif

El FCIP utiliza el Transmission Control Protocol (TCP) en el puerto 3225 como transporte de la capa de red.

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • La estructura básica IP debe ser operativa y entregar el ancho de banda necesario para soportar las aplicaciones que se ejecutan a través de los links FCIP — ésta podría ser una capa 2 (L2) o acodar 3 la topología (L3).

  • Si es una topología L3, los routeres intermedios o los switches multicapas deben ser configurados y ser configurados para remitir apropiadamente el tráfico IP entre los IP Address de origen y de destino de los túneles FCIP. Si el Calidad de Servicio (QoS) o el modelado de tráfico se aplica en cualquier dispositivo de red en la trayectoria entre los pares FCIP, el administrador de la red que administra la infraestructura IP debe ser consultado para conseguir los detalles necesarios antes de configurar cualesquiera parámetros TCP-relacionados y las características en el Director de capas múltiples conmutan (MDS) los perfiles FCIP.

  • Los switches Ethernet adyacentes a las MDS deben ser compatibles y estar configurados para el enlace troncal 802.1Q si las subinterfaces están configuradas en el módulo de servicios MDS IP Storage (IPS).

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • El MDS9509 con el módulo de servicio IPS (DS-X9308-SMIP) ese funciona con la versión 1.2.(2a)

  • El MDS9216 con el módulo de servicio IPS (DS-X9308-SMIP) ese funciona con la versión 1.2.(2a)

  • Catalyst 6509 que funciona con el Catalyst OS (CatOS) 7.4(3)

  • Win2003 Server (HPQ Pro-Liant-P4) con Emulex LP9K HBA

  • Conjunto de almacenamiento de IBM (ESS-2105-F20)

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Antecedentes

El FCIP consiste en estas especificaciones:

ANSI T11

  1. El FC-SW-2 describe la operación y la interacción del Switches FC incluyendo E_Port y el funcionamiento de la estructura.

  2. El FC-BB-2 es una asignación que pertenece a la extensión de las redes de switch FC a través de una estructura básica de red TCP, y define los modelos de referencia que soportan E_Port y B_Port.

Grupo de trabajo del IPS IETF

  1. El FC sobre el TCP cubre los requisitos TCP/IP para transportar las tramas FC sobre una red del IP.

  2. La encapsulación de la trama FC define el formato de encapsulado de la fibra típica.

Una interconexión entre dos Switches SAN o telas a través del FCIP se llama un link FCIP y puede contener una o más conexiones TCP. Cada extremo de un link FCIP se asocia a un puerto virtual E (VE_port) o a un B_port, dependiendo de la implementación. El FC-BB y el FC-BB-2 están describiendo las diferencias entre ambos acercamientos. El módulo de servicios IPS (DS-X9308-SMIP) está soportando los modos Both pero los valores por defecto a VE_Port, que es también el modo recomendado a ejecutarse si todos los pares relevantes son módulos DS-X9308-SMIP. En esta topología de ejemplo, el FCIP sobre PortChannels, los parámetros TCP a configurar, y los parámetros de la configuración FSF (trama especial) se discute.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

En las MDS, es necesario que se familiarice con las guías para la configuración de IPS para ambas plataformas. Usted puede encontrar la mayoría de la versión actual de los manuales en configurar el almacenamiento IP en el cisco.com.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

Cuadro 2 – Topología 3

ips8_elaborate_2.gif

La topología 3 representa un Canal de puerto FCIP formado por dos túneles individuales FCIP; las interfaces de peer están a través de una nube IP. La nube IP se derrumba en un switch multicapa (Catalyst 6500) que rutee el tráfico de la subred A al C de la subred y y del C de la subred a la subred A (y la subred B a la subred D y de la subred D a la subred A). Se definen las subredes como sigue:

  • Subred A: 100.100.100.0/30 - Bison int Gig4/1

  • Subred B: 100.100.100.4/30 - Bison int Gig4/2

  • C de la subred: 200.200.200.0/30- Cantorbery Gig2/1

  • Subred D: 200.200.200.4/30 - Cantorbery Gig2/2

La topología proporciona un ancho de banda máximo sabido del 100 Mbps y un ancho de banda mínima del 100 Mbps, que es el perfil que se ejecuta para nuestro tráfico IP relevante a través de esta nube IP. La configuración inicial muestra los aspectos del puerto FCIP-basado que canaliza y tráfico TCP que condiciona. En las secciones posteriores FSF, las interfaces pasivas TCP, y el sello de fecha y hora FCIP serán explicados más lejos.

Configuraciones

En este documento, se utilizan estas configuraciones:

MDS9509 (bisonte) con el módulo IPS-8
bison# sh ver
Cisco Storage Area Networking Operating System (SAN-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2003 by Cisco Systems, Inc. All rights reserved.
The copyright for certain works contained herein are owned by
Andiamo Systems, Inc. and/or other third parties and are used and
distributed under license.

Software
BIOS: version 1.0.8
loader: version 1.2(2)
kickstart: version 1.2(2a)
system: version 1.2(2a)

BIOS compile time: 08/07/03
kickstart image file is: bootflash:/k122a
kickstart compile time: 9/23/2003 11:00:00
system image file is: bootflash:/s122a
system compile time: 10/8/2003 18:00:00

Hardware
RAM 1024584 kB

bootflash: 500736 blocks (block size 512b)
slot0: 0 blocks (block size 512b)

bison uptime is 1 days 15 hours 45 minute(s) 44 second(s)

Last reset 
Reason: Unknown
System version: 1.2(2a)
Service: 

bison# sh run

Building Configuration ...
fcip profile 1
ip address 100.100.100.1
tcp max-bandwidth-mbps 100 min-available-bandwidth-mbps 100 round-trip-time-ms 10

!--- TCP bandwidth parameters defined specifically for this FCIP tunnel.
!--- Restricted to 100 Mbps max and min. See the Note on TCP Parameters 
!--- comment section in this table below for more details.

fcip profile 2
ip address 100.100.100.5
tcp max-bandwidth-mbps 100 min-available-bandwidth-mbps 100 round-trip-time-ms 10

!--- TCP max and min bandwidth parameter are configured here exactly the
!--- same as for FCIP 1 because both tunnels are combined in one PortChannel
!--- interface and are subject to the same bandwidth restrictions in the IP core.

vsan database
vsan 600 
vsan 601 

fcdomain domain 1 preferred vsan 600
fcdomain domain 1 preferred vsan 601

interface port-channel 1

switchport trunk allowed vsan 600-601

interface fcip1
channel-group 1 force
no shutdown
use-profile 1
peer-info ipaddr 200.200.200.1

!--- Interface FCIP 1 is a member of channel-group 1. The force keyword makes it 
!--- adopt the specific settings configured on interface port-channel 1.

interface fcip2
channel-group 1 force
no shutdown
use-profile 2
peer-info ipaddr 200.200.200.5 

!--- Interface FCIP 2 is also member of channel-group 1.

boot system bootflash:/s122a sup-1
boot kickstart bootflash:/k122a sup-1
boot system bootflash:/s122a sup-2
boot kickstart bootflash:/k122a sup-2

ip domain-name cisco.com
ip name-server 144.254.10.123
ip route 200.200.200.0 255.255.255.252 100.100.100.2 distance 2
ip route 200.200.200.4 255.255.255.252 100.100.100.6 distance 2

!--- FCIP interfaces are on separate IP subnets, so in order to reach the FCIP 
!--- peer IP address, you need adequate static routes to an L3 device that 
!--- knows how to forward the packets to the final destination. Multiple routes 
!--- to the same destination IP subnet are allowed, and the distance parameter 
!--- can be used to specify a preferred next hop. Multiple next hops would 
!--- require a subnet mask providing for a larger number of host; for example, 
!--- a 28-bit subnet mask.

ssh key dsa 768 force
ssh server enable
switchname bison
zone default-zone permit vsan 600-601 

interface GigabitEthernet4/1
ip address 100.100.100.1 255.255.255.252
switchport mtu 3000
no shutdown

!--- MTU size is defined as 3000 bytes. Make sure that all intermediate network 
!--- devices between this interface and the peer IP address are capable of 
!--- switching and routing Jumbo frames. In order to avoid FC Frame split, 
!--- an MTU value of 2300 is required; 3000 is used in the configuration example
!--- for simplicity. FCIP TCP segments will normally never exceed 2264 bytes for 
!--- TE ports or 2256 bytes for E ports, regardless of the configured MTU size.

interface GigabitEthernet4/2
ip address 100.100.100.5 255.255.255.252
switchport mtu 3000
no shutdown

interface fc3/1

interface fc3/2

interface fc3/3

interface fc3/4

interface fc3/5

interface fc3/6

interface fc3/7

interface fc3/8

interface fc3/9

interface fc3/10

interface fc3/11

interface fc3/12

interface fc3/13

interface fc3/14

interface fc3/15

interface fc3/16

interface mgmt0
ip address 10.48.69.151 255.255.255.128


!--- Note on TCP Parameters
!--- The following TCP parameters can be individually configured per FCIP profile:

bison(config-profile)# tcp ?

cwm Enable congestion window monitoring
keepalive-timeout Set keep alive timeout in sec
max-bandwidth-kbps Configure maximum available path bandwidth in Kbps
max-bandwidth-mbps Configure maximum available path bandwidth in Mbps
max-retransmissions Maximum number of retransmissions
min-retransmit-time Set minimum retransmit time in millisecond
pmtu-enable Enable PMTU Discovery
sack-enable Enable SACK option for TCP
send-buffer-size Send buffer size in KBytes

!--- The CWM parameter default value is 10K and should be left untouched under 
!--- normal conditions.  Congestion window monitoring (CWM) is a way of 
!--- controlling burstiness after long idle times or loss of Acks.


!--- The keepalive-timeout is the TCP keepalive timeout value and is 
!--- set to 60 seconds by default, though it can range between 1 and 7200 seconds.


!--- The max- and min-bandwidth parameters program the TCP Maximum Window Size 
!--- (scaling factor) and engages an internal “shaper” functionality.
!--- These values should be carefully chosen and requires understanding of the 
!--- intermediate network’s end-to-end topology. The default values are to be 
!--- changed according to the aforementioned requirements.
!--- The Round-trip-time can be derived once you have your FCIP tunnel up and 
!--- running by issuing the following command:

bison# ips measure 200.200.200.1 interface gigabitethernet 4/1

Round trip time is 53 micro seconds (0.05 milliseconds )

!--- Always add an additional margin of at least a few microseconds to this value.
!--- The max-retransmissions counter is set to 4 by default. In a healthy network 
!--- environment, this value should be left unchanged.


!--- The max-retransmission timer is set to 200 milliseconds. If you experience 
!--- extremely high retransmission counters, this value can be increased; but,
!--- in general, changing this parameter is not required unless the RTT is
!--- above 200 milliseconds.


!--- The PMTU (Path MTU discovery) is enabled by default. Best practice is to know 
!--- what is the maximum MTU size supported by all interfaces along the logical 
!--- path between both peers.


!--- The SACK feature (Selective Acknowledgment) is not enabled by default.
!--- Consider enabling it when you have a lot of retransmissions occurring between 
!--- the two peers. SACK allows selective retransmissions of your window, which is 
!--- beneficial if larger maximum window sizes are configured and retransmissions 
!--- occur frequently. It is enabled in this sample configuration; when you do so,
!--- make sure that it is enabled at both sides of the link.


!--- The send-buffer-size is the amount of buffers in addition to the TCP window 
!--- that are allowed to be transmitted out before starting to flow control the FC 
!--- sources. The default value is set to 0.

MDS9216 (Cantorbery) con el módulo IPS-8
canterbury# sh run

Building Configuration ...
fcip profile 200
ip address 200.200.200.1
tcp max-bandwidth-mbps 100 min-available-bandwidth-mbps 100 round-trip-time-ms 10

fcip profile 201
ip address 200.200.200.5
tcp max-bandwidth-mbps 100 min-available-bandwidth-mbps 100 round-trip-time-ms 10

!--- The TCP parameters are identical to what is configured on the peering 
!--- FCIP interfaces. Only in very specific cases should different values be 
!--- considered, for example, if the return-path(s) are running across a different 
!--- part of the network or if the application dictates asymmetrical values.

vsan database
vsan 600 
vsan 601 

fcdomain domain 2 preferred vsan 600
fcdomain domain 2 preferred vsan 601

interface port-channel 2

switchport trunk mode auto
switchport trunk allowed vsan 600-601

interface fcip1
channel-group 2 force
no shutdown
use-profile 200
peer-info ipaddr 100.100.100.1

interface fcip2
channel-group 2 force
no shutdown
use-profile 201
peer-info ipaddr 100.100.100.5

!--- Both FCIP 1 and FCIP 2 are bound to the same channel-group 2. Also note that 
!--- there is no strict relationship between profile-id and FCIP interface 
!--- numbering here, as this is not a requirement. From a management and 
!--- troubleshooting perspective, however, a “strict” relationship of both values 
!--- is recommended.

vsan database
vsan 600 interface fc1/1
vsan 601 interface fc1/8

boot system bootflash:/s122a 
boot kickstart bootflash:/k122a 

ip domain-name cisco.com
ip name-server 144.254.10.123
ip default-gateway 10.48.69.129
ip route 100.100.100.0 255.255.255.252 200.200.200.2 distance 2
ip route 100.100.100.4 255.255.255.252 200.200.200.6 distance 2

!--- IP routes are defined for both FCIP peer IP addresses. The next hop must be 
!--- aware of the best route to the peer’s addresses or to the relevant IP subnets.

ssh key dsa 768 force
ssh server enable
switchname canterbury
system default switchport trunk mode auto
username admin password 5 $1$KcCrqxlu$mtU03/60PRUIfjl.aeEEc0 role network-admin
zone default-zone permit vsan 600-601
zoneset distribute full vsan 1-4093

interface GigabitEthernet2/1
ip address 200.200.200.1 255.255.255.252
switchport mtu 3000
no shutdown

interface GigabitEthernet2/2
ip address 200.200.200.5 255.255.255.252
switchport mtu 3000
no shutdown

interface GigabitEthernet2/3

interface GigabitEthernet2/4

interface GigabitEthernet2/5

interface GigabitEthernet2/6

interface GigabitEthernet2/7

interface GigabitEthernet2/8

interface fc1/1

interface fc1/2

interface fc1/3

interface fc1/4

interface fc1/5

interface fc1/6

interface fc1/7

interface fc1/8

interface fc1/9

interface fc1/10

interface fc1/11

interface fc1/12

interface fc1/13

interface fc1/14

interface fc1/15

interface fc1/16

interface mgmt0
ip address 10.48.69.156 255.255.255.128

interface iscsi2/1

interface iscsi2/2

interface iscsi2/3

interface iscsi2/4

interface iscsi2/5

interface iscsi2/6

interface iscsi2/7

interface iscsi2/8

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

  • x/y del show interface gig — Visualiza el estatus de la interfaz Gigabit relevante limitada al perfil FCIP.

  • muestre el x/y tcp de las estadísticas de ips int gig — Estadísticas y conexiones activas de las visualizaciones TCP para la interfaz Gigabit relevante.

  • x/y de la demostración ips arp int gig — Visualiza todas las entradas del Address Resolution Protocol (ARP) para la interfaz Gigabit relevante; el salto siguiente o el par debe estar presente en esta lista.

  • muestre el x/y de la ruta de IP IPS int gig — Visualiza las rutas específicas que van a través de la interfaz Gigabit relevante.

  • muestre el fcip x de la interfaz — Visualiza el estado de la interfaz FCIP y todo detalla relacionado a este túnel FCIP.

  • muestre el fcip x del perfil — Visualiza la dirección IP a la cual el perfil es parámetros TCP encuadernados y todos los configurados.

  • muestre los contadores del fcip x internacional — Utilizado para marcar si hay algunas tramas que pasan a través del túnel FCIP.

  • muestre el vsan x del fcdomain — Enumera todos los detalles relacionados al dominio; utilizado para verificar que la tela está formada a través de los túneles FCIP.

  • muestre el vsan x DA del fcns — Visualiza todo el pwwn, FC4-Types, y FCID del VSAN relevante; utilizado para verificar que todas las entradas previstas están distribuidas a través de los túneles FCIP.

Troubleshooting

Use esta sección para resolver problemas de configuración.

Esté seguro de publicar los tiempos múltiples de los comandos show para construir un historial contrario. Los contadores que no se relacionan con una punta a tiempo y apenas se recogen solamente son una vez sobre todo inútiles.

Utilice las configuraciones mostradas abajo para el troubleshooting adicional.

MDS9509 (bisonte)
bison# sh int gig 4/1

GigabitEthernet4/1 is up
    Hardware is GigabitEthernet, address is 0005.3000.a85a
    Internet address is 100.100.100.1/30
    MTU 3000 bytes
    Port mode is IPS
    Speed is 1 Gbps
    Beacon is turned off
    Auto-Negotiation is turned on
    5 minutes input rate 312 bits/sec, 39 bytes/sec, 0 frames/sec
    5 minutes output rate 312 bits/sec, 39 bytes/sec, 0 frames/sec
    8685 packets input, 976566 bytes
      0 multicast frames, 0 compressed
      0 input errors, 0 frame, 0 overrun 0 fifo
    8679 packets output, 972382 bytes, 0 underruns
      0 output errors, 0 collisions, 0 fifo
      0 carrier errors

bison# sh int gig 4/2

GigabitEthernet4/2 is up
    Hardware is GigabitEthernet, address is 0005.3000.a85b
    Internet address is 100.100.100.5/30
    MTU 3000 bytes
    Port mode is IPS
    Speed is 1 Gbps
    Beacon is turned off
    Auto-Negotiation is turned on
    5 minutes input rate 16 bits/sec, 2 bytes/sec, 0 frames/sec
    5 minutes output rate 16 bits/sec, 2 bytes/sec, 0 frames/sec
    590 packets input, 46496 bytes
      0 multicast frames, 0 compressed
      0 input errors, 0 frame, 0 overrun 0 fifo
    547 packets output, 30898 bytes, 0 underruns
      0 output errors, 0 collisions, 0 fifo
      0 carrier errors

bison# sh ips stats tcp int gig 4/1

TCP Statistics for port GigabitEthernet4/1
    Connection Stats
      14 active openings, 4 accepts
      4 failed attempts, 0 reset received, 14 established
    Segment stats
      8897 received, 8505 sent, 0 retransmitted
      0 bad segments received, 0 reset sent

TCP Active Connections 
    Local Address        Remote Address      State      Send-Q  Recv-Q
    100.100.100.1:65480  200.200.200.1:3225  ESTABLISH  0       0
    100.100.100.1:65482  200.200.200.1:3225  ESTABLISH  0       0
    100.100.100.1:3225   0.0.0.0:0           LISTEN     0       0

bison# sh ips stats tcp int gig 4/2

TCP Statistics for port GigabitEthernet4/2
    Connection Stats
      2 active openings, 0 accepts
      0 failed attempts, 0 reset received, 2 established
    Segment stats
      598 received, 43 sent, 0 retransmitted
      0 bad segments received, 0 reset sent

TCP Active Connections 
    Local Address        Remote Address      State      Send-Q  Recv-Q
    100.100.100.5:65531  200.200.200.5:3225  ESTABLISH  0       0
    100.100.100.5:65533  200.200.200.5:3225  ESTABLISH  0       0
    100.100.100.5:3225   0.0.0.0:0           LISTEN     0       0

bison# sh int fcip1-2

fcip1 is trunking
    Hardware is GigabitEthernet
    Port WWN is 20:c2:00:05:30:00:7a:de
    Peer port WWN is 20:42:00:0c:30:6c:24:40
    Admin port mode is auto, trunk mode is on
    Port mode is TE
    vsan is 1
    Belongs to port-channel 1
    Trunk vsans (allowed active) (600-601)
    Trunk vsans (operational) (600-601)
    Trunk vsans (up) (600-601)
    Trunk vsans (isolated) ()
    Trunk vsans (initializing) ()
    Using Profile id 1 (interface GigabitEthernet4/1)
    Peer Information
      Peer Internet address is 200.200.200.1 and port is 3225
      Special Frame is disabled
      Maximum number of TCP connections is 2
      Time Stamp is disabled
      QOS control code point is 0
      QOS data code point is 0
      B-port mode disabled
    TCP Connection Information
      2 Active TCP connections
      Control connection: Local 100.100.100.1:65480, Remote 200.200.200.1:3225
      Data connection: Local 100.100.100.1:65482, Remote 200.200.200.1:3225
      28 Attempts for active connections, 7 close of connections
    TCP Parameters
      Path MTU 3000 bytes
      Current retransmission timeout is 200 ms
      Round trip time: Smoothed 5 ms, Variance: 6
      Advertized window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Peer receive window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Congestion window: Current: 10 KB, Slow start threshold: 118 KB
      5 minutes input rate 120 bits/sec, 15 bytes/sec, 0 frames/sec
      5 minutes output rate 120 bits/sec, 15 bytes/sec, 0 frames/sec
        4077 frames input, 379836 bytes
          4071 Class F frames input, 379100 bytes
          6 Class 2/3 frames input, 736 bytes
          0 Error frames timestamp error 0
        4077 frames output, 381064 bytes
          4071 Class F frames output, 380364 bytes
          6 Class 2/3 frames output, 700 bytes
          0 Error frames 0 reass frames

fcip2 is trunking
    Hardware is GigabitEthernet
    Port WWN is 20:c6:00:05:30:00:7a:de
    Peer port WWN is 20:46:00:0c:30:6c:24:40
    Admin port mode is auto, trunk mode is on
    Port mode is TE
    vsan is 1
    Belongs to port-channel 1
    Trunk vsans (allowed active) (600-601)
    Trunk vsans (operational) (600-601)
    Trunk vsans (up) (600-601)
    Trunk vsans (isolated) ()
    Trunk vsans (initializing) ()
    Using Profile id 2 (interface GigabitEthernet4/2)
    Peer Information
      Peer Internet address is 200.200.200.5 and port is 3225
      Special Frame is disabled
      Maximum number of TCP connections is 2
      Time Stamp is disabled
      QOS control code point is 0
      QOS data code point is 0
      B-port mode disabled
    TCP Connection Information
      2 Active TCP connections
      Control connection: Local 100.100.100.5:65531, Remote 200.200.200.5:3225
      Data connection: Local 100.100.100.5:65533, Remote 200.200.200.5:3225
      2 Attempts for active connections, 0 close of connections
    TCP Parameters
      Path MTU 3000 bytes
      Current retransmission timeout is 200 ms
      Round trip time: Smoothed 0 ms, Variance: 0
      Advertized window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Peer receive window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Congestion window: Current: 8 KB, Slow start threshold: 118 KB
      5 minutes input rate 32 bits/sec, 4 bytes/sec, 0 frames/sec
      5 minutes output rate 32 bits/sec, 4 bytes/sec, 0 frames/sec
        8 frames input, 1232 bytes
          8 Class F frames input, 1232 bytes
          0 Class 2/3 frames input, 0 bytes
          0 Error frames timestamp error 0
        8 frames output, 1228 bytes
          8 Class F frames output, 1228 bytes
          0 Class 2/3 frames output, 0 bytes
          0 Error frames 0 reass frames

bison# sh fcip pro 1

FCIP Profile 1
    Internet Address is 100.100.100.1 (interface GigabitEthernet4/1)
    Listen Port is 3225
TCP parameters
    SACK is enabled
    PMTU discovery is enabled, reset timeout is 3600 sec
    Keep alive is 60 sec
    Minimum retransmission timeout is 200 ms
    Maximum number of re-transmissions is 4
    Send buffer size is 0 KB
    Maximum allowed bandwidth is 100000 kbps
    Minimum available bandwidth is 100000 kbps
    Estimated round trip time is 10000 usec
    Congestion window monitoring is enabled, burst size is 10 KB

bison# sh fcip pro 2

FCIP Profile 2
    Internet Address is 100.100.100.5 (interface GigabitEthernet4/2)
    Listen Port is 3225
TCP parameters
    SACK is enabled
    PMTU discovery is enabled, reset timeout is 3600 sec
    Keep alive is 60 sec
    Minimum retransmission timeout is 200 ms
    Maximum number of re-transmissions is 4
    Send buffer size is 0 KB
    Maximum allowed bandwidth is 100000 kbps
    Minimum available bandwidth is 100000 kbps
    Estimated round trip time is 10000 usec
    Congestion window monitoring is enabled, burst size is 10 KB

bison# sh int port-channel 1

port-channel 1 is trunking
    Hardware is Fibre Channel
    Port WWN is 24:01:00:05:30:00:7a:de
    Admin port mode is auto, trunk mode is on
    Port mode is TE
    Port vsan is 1
    Speed is 2 Gbps
    Trunk vsans (admin allowed and active) (600-601)
    Trunk vsans (up)                       (600-601)
    Trunk vsans (isolated)                 ()
    Trunk vsans (initializing)             ()
    5 minutes input rate 120 bits/sec, 15 bytes/sec, 0 frames/sec
    5 minutes output rate 120 bits/sec, 15 bytes/sec, 0 frames/sec
      3969 frames input, 369812 bytes
        3963 Class F frames input, 369076 bytes
        6 Class 2/3 frames input, 736 bytes
        0 Error frames timestamp error 0
      3969 frames output, 371040 bytes
        3963 Class F frames output, 370340 bytes
        6 Class 2/3 frames output, 700 bytes
        0 Error frames 0 reass frames
    Member[1] : fcip1
    Member[2] : fcip2

bison# sh ips ip route interface gigabitethernet 4/1

Codes: C - connected, S - static
No default gateway

S 200.200.200.0/30 via 100.100.100.2, GigabitEthernet4/1
C 100.100.100.0/30 is directly connected, GigabitEthernet4/1

bison# sh ips ip route interface gigabitethernet 4/2

Codes: C - connected, S - static
No default gateway

S 200.200.200.4/30 via 100.100.100.6, GigabitEthernet4/2
C 100.100.100.4/30 is directly connected, GigabitEthernet4/2

bison# sh ips arp int gig 4/1

Protocol         Address   Age (min)   Hardware Addr  Type   Interface
Internet   100.100.100.2        8     0008.e21e.c7bc  ARPA  GigabitEthernet4/1

!--- Verify that the hardware address listed belongs to the 
!--- next hop networking device.


bison# sh ips arp int gig 4/2

Protocol         Address   Age (min)   Hardware Addr  Type   Interface
Internet   100.100.100.6        5     0008.e21e.c7bc  ARPA  GigabitEthernet4/2      

bison# sh int port-channel 1 trunk vsan 600-601

port-channel 1 is trunking
    Vsan 600 is up, FCID is 0x010000
    Vsan 601 is up, FCID is 0x010000

bison# sh fcdomain vsan 600

The local switch is the Principal Switch.

Local switch run time information:
    State: Stable
    Local switch WWN: 22:58:00:05:30:00:7a:df
    Running fabric name: 22:58:00:05:30:00:7a:df
    Running priority: 2
    Current domain ID: 0x01(1) 

Local switch configuration information:
    State: Enabled
    FCID persistence: Disabled
    Auto-reconfiguration: Disabled
    Contiguous-allocation: Disabled
    Configured fabric name: 20:01:00:05:30:00:28:df
    Configured priority: 128
    Configured domain ID: 0x01(1) (preferred)

Principal switch run time information:
    Running priority: 2

    Interface        Role          RCF-reject
    ---------------- ------------- ------------
    port-channel 1   Downstream    Disabled
    ---------------- ------------- ------------

bison# sh fcdomain vsan 601

The local switch is the Principal Switch.

Local switch run time information:
    State: Stable
    Local switch WWN: 22:59:00:05:30:00:7a:df
    Running fabric name: 22:59:00:05:30:00:7a:df
    Running priority: 2
    Current domain ID: 0x01(1) 

Local switch configuration information:
    State: Enabled
    FCID persistence: Disabled
    Auto-reconfiguration: Disabled
    Contiguous-allocation: Disabled
    Configured fabric name: 20:01:00:05:30:00:28:df
    Configured priority: 128
    Configured domain ID: 0x01(1) (preferred)

Principal switch run time information:
    Running priority: 2

    Interface        Role          RCF-reject
    ---------------- ------------- ------------
    port-channel 1   Downstream    Disabled
    ---------------- ------------- ------------

MDS9216 (Cantorbery)
canterbury# sh int gig 2/1-2

GigabitEthernet2/1 is up
    Hardware is GigabitEthernet, address is 0005.3000.ade6
    Internet address is 200.200.200.1/30
    MTU 3000 bytes
    Port mode is IPS
    Speed is 1 Gbps
    Beacon is turned off
    Auto-Negotiation is turned on
    5 minutes input rate 320 bits/sec, 40 bytes/sec, 0 frames/sec
    5 minutes output rate 320 bits/sec, 40 bytes/sec, 0 frames/sec
    8844 packets input, 993118 bytes
      0 multicast frames, 0 compressed
      0 input errors, 0 frame, 0 overrun 0 fifo
    8855 packets output, 994686 bytes, 0 underruns
      0 output errors, 0 collisions, 0 fifo
      0 carrier errors

GigabitEthernet2/2 is up
    Hardware is GigabitEthernet, address is 0005.3000.ade7
    Internet address is 200.200.200.5/30
    MTU 3000 bytes
    Port mode is IPS
    Speed is 1 Gbps
    Beacon is turned off
    Auto-Negotiation is turned on
    5 minutes input rate 16 bits/sec, 2 bytes/sec, 0 frames/sec
    5 minutes output rate 8 bits/sec, 1 bytes/sec, 0 frames/sec
    634 packets input, 39538 bytes
      0 multicast frames, 0 compressed
      0 input errors, 0 frame, 0 overrun 0 fifo
    610 packets output, 47264 bytes, 0 underruns
      0 output errors, 0 collisions, 0 fifo
      0 carrier errors

canterbury# sh ips stats tcp int gig 2/1

TCP Statistics for port GigabitEthernet2/1
    Connection Stats
      18 active openings, 10 accepts
      14 failed attempts, 0 reset received, 8 established
    Segment stats
      8919 received, 8923 sent, 0 retransmitted
      0 bad segments received, 0 reset sent

TCP Active Connections
    Local Address       Remote Address       State      Send-Q  Recv-Q
    200.200.200.1:3225  100.100.100.1:65480  ESTABLISH  0       0
    200.200.200.1:3225  100.100.100.1:65482  ESTABLISH  0       0
    200.200.200.1:3225  0.0.0.0:0            LISTEN     0       0

canterbury# sh ips stats tcp int gig 2/2

TCP Statistics for port GigabitEthernet2/2
    Connection Stats
      498 active openings, 2 accepts
      498 failed attempts, 0 reset received, 2 established
    Segment stats
      556 received, 579 sent, 0 retransmitted
      0 bad segments received, 0 reset sent

TCP Active Connections
    Local Address       Remote Address       State      Send-Q  Recv-Q
    200.200.200.5:3225  100.100.100.5:65531  ESTABLISH  0       0
    200.200.200.5:3225  100.100.100.5:65533  ESTABLISH  0       0
    200.200.200.5:3225  0.0.0.0:0            LISTEN     0       0

canterbury# sh int fcip 1-2

fcip1 is trunking
    Hardware is GigabitEthernet
    Port WWN is 20:42:00:0c:30:6c:24:40
    Peer port WWN is 20:c2:00:05:30:00:7a:de
    Admin port mode is auto, trunk mode is auto
    Port mode is TE
    vsan is 1
    Belongs to port-channel 2
    Trunk vsans (allowed active) (600-601)
    Trunk vsans (operational) (600-601)
    Trunk vsans (up) (600-601)
    Trunk vsans (isolated) ()
    Trunk vsans (initializing) ()
    Using Profile id 200 (interface GigabitEthernet2/1)
    Peer Information
      Peer Internet address is 100.100.100.1 and port is 3225
      Special Frame is disabled
      Maximum number of TCP connections is 2
      Time Stamp is disabled
      QOS control code point is 0
      QOS data code point is 0
      B-port mode disabled
    TCP Connection Information
      2 Active TCP connections
      Control connection: Local 200.200.200.1:3225, Remote 100.100.100.1:65480
      Data connection: Local 200.200.200.1:3225, Remote 100.100.100.1:65482
      18 Attempts for active connections, 2 close of connections
    TCP Parameters
      Path MTU 3000 bytes
      Current retransmission timeout is 200 ms
      Round trip time: Smoothed 5 ms, Variance: 6
      Advertized window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Peer receive window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Congestion window: Current: 10 KB, Slow start threshold: 112 KB
      5 minutes input rate 136 bits/sec, 17 bytes/sec, 0 frames/sec
      5 minutes output rate 136 bits/sec, 17 bytes/sec, 0 frames/sec
      4189 frames input, 391368 bytes
        4183 Class F frames input, 390668 bytes
        6 Class 2/3 frames input, 700 bytes
        0 Error frames timestamp error 0
      4189 frames output, 390140 bytes
        4183 Class F frames output, 389404 bytes
        6 Class 2/3 frames output, 736 bytes
        0 Error frames 0 reass frames

fcip2 is trunking
    Hardware is GigabitEthernet
    Port WWN is 20:46:00:0c:30:6c:24:40
    Peer port WWN is 20:c6:00:05:30:00:7a:de
    Admin port mode is auto, trunk mode is auto
    Port mode is TE
    vsan is 1
    Belongs to port-channel 2
    Trunk vsans (allowed active) (600-601)
    Trunk vsans (operational) (600-601)
    Trunk vsans (up) (600-601)
    Trunk vsans (isolated) ()
    Trunk vsans (initializing) ()
    Using Profile id 201 (interface GigabitEthernet2/2)
    Peer Information
      Peer Internet address is 100.100.100.5 and port is 3225
      Special Frame is disabled
      Maximum number of TCP connections is 2
      Time Stamp is disabled
      QOS control code point is 0
      QOS data code point is 0
      B-port mode disabled
    TCP Connection Information
      2 Active TCP connections
      Control connection: Local 200.200.200.5:3225, Remote 100.100.100.5:65531
      Data connection: Local 200.200.200.5:3225, Remote 100.100.100.5:65533
      498 Attempts for active connections, 0 close of connections
    TCP Parameters
      Path MTU 3000 bytes
      Current retransmission timeout is 200 ms
      Round trip time: Smoothed 10 ms, Variance: 5
      Advertized window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Peer receive window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Congestion window: Current: 8 KB, Slow start threshold: 112 KB
      5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
      5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
      8 frames input, 1228 bytes
        8 Class F frames input, 1228 bytes
        0 Class 2/3 frames input, 0 bytes
        0 Error frames timestamp error 0
      8 frames output, 1232 bytes
        8 Class F frames output, 1232 bytes
        0 Class 2/3 frames output, 0 bytes
        0 Error frames 0 reass frames

canterbury# sh int port 2

port-channel 2 is trunking
    Hardware is Fibre Channel
    Port WWN is 24:02:00:0c:30:6c:24:40
    Admin port mode is auto, trunk mode is auto
    Port mode is TE
    Port vsan is 1
    Speed is 2 Gbps
    Trunk vsans (admin allowed and active) (600-601)
    Trunk vsans (up) (600-601)
    Trunk vsans (isolated) ()
    Trunk vsans (initializing) ()
    5 minutes input rate 120 bits/sec, 15 bytes/sec, 0 frames/sec
    5 minutes output rate 120 bits/sec, 15 bytes/sec, 0 frames/sec
    4213 frames input, 394068 bytes
      4207 Class F frames input, 393368 bytes
      6 Class 2/3 frames input, 700 bytes
      0 Error frames timestamp error 0
    4213 frames output, 392844 bytes
      4207 Class F frames output, 392108 bytes
      6 Class 2/3 frames output, 736 bytes
      0 Error frames 0 reass frames
    Member[1] : fcip1
    Member[2] : fcip2

canterbury# sh ips ip route interface gig 2/1

Codes: C - connected, S - static
No default gateway

S 100.100.100.0/30 via 200.200.200.2, GigabitEthernet2/1
C 200.200.200.0/30 is directly connected, GigabitEthernet2/1

canterbury# sh ips ip route interface gig 2/2

Codes: C - connected, S - static
No default gateway

S 100.100.100.4/30 via 200.200.200.6, GigabitEthernet2/2
C 200.200.200.4/30 is directly connected, GigabitEthernet2/2

canterbury# sh fcns da

VSAN 600:
--------------------------------------------------------------------------
FCID      TYPE  PWWN                     (VENDOR)  FC4-TYPE:FEATURE
--------------------------------------------------------------------------
0x010001  N     10:00:00:00:c9:32:a6:e3  (Emulex)  scsi-fcp:init 
0x020001  N     50:05:07:63:00:d0:94:4c  (IBM)     scsi-fcp:target fc.. 

Total number of entries = 2

VSAN 601:
--------------------------------------------------------------------------
FCID      TYPE  PWWN                     (VENDOR)  FC4-TYPE:FEATURE
--------------------------------------------------------------------------
0x010100  N     10:00:00:00:00:05:00:00
0x020100  N     10:00:00:00:00:01:00:00

!--- Always verify that the fabric has formed with the expected neighbor(s)         
!--- through FCIP E or TE port when the configuration is completed.

Configuración especial de tramas (bisonte)

!--- Special frames are used to improve security.
!--- Before user-data is transmitted across an FCIP tunnel, FSF verifies that 
!--- the peer is defined on the configured wwn.


interface fcip1
channel-group 1 force
no shutdown
use-profile 1
peer-info ipaddr 200.200.200.1
special-frame peer-wwn 20:00:00:0c:30:6c:24:40 profile-id 200

interface fcip2
channel-group 1 force
no shutdown
use-profile 2
peer-info ipaddr 200.200.200.5
special-frame peer-wwn 20:00:00:0c:30:6c:24:40 profile-id 201


!--- The peer-wwn is derived from the peer MDS by issuing the following command:

canterbury# sh wwn switch

Switch WWN is 20:00:00:0c:30:6c:24:40

!--- This value is significant per peer switch, so it is used for all tunnels 
!--- towards this switch. This configuration shows the following:

bison# sh int fcip 1-2

fcip1 is trunking
    Hardware is GigabitEthernet
    Port WWN is 20:c2:00:05:30:00:7a:de
    Peer port WWN is 20:42:00:0c:30:6c:24:40
    Admin port mode is auto, trunk mode is on
    Port mode is TE
    vsan is 1
    Belongs to port-channel 1
    Trunk vsans (allowed active) (600-601)
    Trunk vsans (operational) (600-601)
    Trunk vsans (up) (600-601)
    Trunk vsans (isolated) ()
    Trunk vsans (initializing) ()
    Using Profile id 1 (interface GigabitEthernet4/1)
    Peer Information
      Peer Internet address is 200.200.200.1 and port is 3225
      Special Frame is enabled
      Peer switch WWN is 20:00:00:0c:30:6c:24:40
      Peer profile id is 200
      Maximum number of TCP connections is 2
      Time Stamp is disabled
      QOS control code point is 0
      QOS data code point is 0
      B-port mode disabled
    TCP Connection Information
      2 Active TCP connections
      Control connection: Local 100.100.100.1:65372, Remote 200.200.200.1:3225
      Data connection: Local 100.100.100.1:65374, Remote 200.200.200.1:3225
      82 Attempts for active connections, 9 close of connections
    TCP Parameters
      Path MTU 3000 bytes
      Current retransmission timeout is 200 ms
      Round trip time: Smoothed 2 ms, Variance: 1
      Advertized window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Peer receive window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Congestion window: Current: 106 KB, Slow start threshold: 118 KB
      5 minutes input rate 46128 bits/sec, 5766 bytes/sec, 19 frames/sec
      5 minutes output rate 194867736 bits/sec, 24358467 bytes/sec, 20732 frames/sec
      5841 frames input, 1729836 bytes
        4575 Class F frames input, 429444 bytes
        1266 Class 2/3 frames input, 1300392 bytes
        0 Error frames timestamp error 0
      6339146 frames output, 7447938520 bytes
        4576 Class F frames output, 431800 bytes
        6334570 Class 2/3 frames output, 7447506720 bytes
        0 Error frames 0 reass frames

fcip2 is trunking
    Hardware is GigabitEthernet
    Port WWN is 20:c6:00:05:30:00:7a:de
    Peer port WWN is 20:46:00:0c:30:6c:24:40
    Admin port mode is auto, trunk mode is on
    Port mode is TE
    vsan is 1
    Belongs to port-channel 1
    Trunk vsans (allowed active) (600-601)
    Trunk vsans (operational) (600-601)
    Trunk vsans (up) (600-601)
    Trunk vsans (isolated) ()
    Trunk vsans (initializing) ()
    Using Profile id 2 (interface GigabitEthernet4/2)
    Peer Information
      Peer Internet address is 200.200.200.5 and port is 3225
      Special Frame is enabled
      Peer switch WWN is 20:00:00:0c:30:6c:24:40
      Peer profile id is 201
      Maximum number of TCP connections is 2
      Time Stamp is disabled
      QOS control code point is 0
      QOS data code point is 0
      B-port mode disabled
    TCP Connection Information
      2 Active TCP connections
      Control connection: Local 100.100.100.5:3225, Remote 200.200.200.5:64535
      Data connection: Local 100.100.100.5:3225, Remote 200.200.200.5:64537
      58 Attempts for active connections, 1 close of connections
    TCP Parameters
      Path MTU 3000 bytes
      Current retransmission timeout is 200 ms
      Round trip time: Smoothed 2 ms, Variance: 1
      Advertized window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Peer receive window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Congestion window: Current: 106 KB, Slow start threshold: 112 KB
      5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
      5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
      415 frames input, 398160 bytes
        16 Class F frames input, 2460 bytes
        399 Class 2/3 frames input, 395700 bytes
        0 Error frames timestamp error 0
      6078322 frames output, 7147327176 bytes
        16 Class F frames output, 2460 bytes
        6078306 Class 2/3 frames output, 7147324716 bytes
        0 Error frames 0 reass frames

Configuración especial de tramas (Cantorbery)
interface fcip1
channel-group 2 force
no shutdown
use-profile 200
peer-info ipaddr 100.100.100.1
special-frame peer-wwn 20:00:00:05:30:00:7a:de profile-id 1

interface fcip2
channel-group 2 force
no shutdown
use-profile 201
peer-info ipaddr 100.100.100.5
special-frame peer-wwn 20:00:00:05:30:00:7a:de profile-id 2

canterbury# sh int fcip 1

fcip1 is trunking
    Hardware is GigabitEthernet
    Port WWN is 20:42:00:0c:30:6c:24:40
    Peer port WWN is 20:c2:00:05:30:00:7a:de
    Admin port mode is auto, trunk mode is auto
    Port mode is TE
    vsan is 1
    Belongs to port-channel 2
    Trunk vsans (allowed active) (600-601)
    Trunk vsans (operational) (600-601)
    Trunk vsans (up) (600-601)
    Trunk vsans (isolated) ()
    Trunk vsans (initializing) ()
    Using Profile id 200 (interface GigabitEthernet2/1)
    Peer Information
      Peer Internet address is 100.100.100.1 and port is 3225
      Special Frame is enabled
      Peer switch WWN is 20:00:00:05:30:00:7a:de
      Peer profile id is 1
      Maximum number of TCP connections is 2
      Time Stamp is disabled
      QOS control code point is 0
      QOS data code point is 0
      B-port mode disabled
    TCP Connection Information
      2 Active TCP connections
      Control connection: Local 200.200.200.1:3225, Remote 100.100.100.1:65372
      Data connection: Local 200.200.200.1:3225, Remote 100.100.100.1:65374
      2 Attempts for active connections, 0 close of connections
    TCP Parameters
      Path MTU 3000 bytes
      Current retransmission timeout is 200 ms
      Round trip time: Smoothed 2 ms, Variance: 1
      Advertized window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Peer receive window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Congestion window: Current: 10 KB, Slow start threshold: 112 KB
      5 minutes input rate 94347400 bits/sec, 11793425 bytes/sec, 10031 frames/sec  
      5 minutes output rate 144 bits/sec, 18 bytes/sec, 0 frames/sec
      3985861 frames input, 4685834196 bytes
        219 Class F frames input, 25228 bytes
        3985642 Class 2/3 frames input, 4685808968 bytes
        0 Error frames timestamp error 0
      1043 frames output, 866780 bytes
        218 Class F frames output, 23448 bytes
        825 Class 2/3 frames output, 843332 bytes
        0 Error frames 0 reass frames

canterbury# sh int fcip 2

fcip2 is trunking
    Hardware is GigabitEthernet
    Port WWN is 20:46:00:0c:30:6c:24:40
    Peer port WWN is 20:c6:00:05:30:00:7a:de
    Admin port mode is auto, trunk mode is auto
    Port mode is TE
    vsan is 1
    Belongs to port-channel 2
    Trunk vsans (allowed active) (600-601)
    Trunk vsans (operational) (600-601)
    Trunk vsans (up) (600-601)
    Trunk vsans (isolated) ()
    Trunk vsans (initializing) ()
    Using Profile id 201 (interface GigabitEthernet2/2)
    Peer Information
      Peer Internet address is 100.100.100.5 and port is 3225
      Special Frame is enabled
      Peer switch WWN is 20:00:00:05:30:00:7a:de
      Peer profile id is 2
      Maximum number of TCP connections is 2
      Time Stamp is disabled
      QOS control code point is 0
      QOS data code point is 0
      B-port mode disabled
    TCP Connection Information
      2 Active TCP connections
      Control connection: Local 200.200.200.5:64535, Remote 100.100.100.5:3225
      Data connection: Local 200.200.200.5:64537, Remote 100.100.100.5:3225
      500 Attempts for active connections, 0 close of connections
    TCP Parameters
      Path MTU 3000 bytes
      Current retransmission timeout is 300 ms
      Round trip time: Smoothed 10 ms, Variance: 5
      Advertized window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Peer receive window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Congestion window: Current: 8 KB, Slow start threshold: 118 KB
      5 minutes input rate 94399712 bits/sec, 11799964 bytes/sec, 10034 frames/sec
      5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
      9769115 frames input, 11486944196 bytes
        16 Class F frames input, 2460 bytes
        9769099 Class 2/3 frames input, 11486941736 bytes
        0 Error frames timestamp error 0
      415 frames output, 398160 bytes
        16 Class F frames output, 2460 bytes
        399 Class 2/3 frames output, 395700 bytes
        0 Error frames 0 reass frames

Visualización del bisonte y de Cantorbery - Pasivo Canterbury
interface fcip1
channel-group 2 force
no shutdown
use-profile 200
passive-mode
peer-info ipaddr 100.100.100.1
special-frame peer-wwn 20:00:00:05:30:00:7a:de profile-id 1

interface fcip2
channel-group 2 force
no shutdown
use-profile 201
passive-mode
peer-info ipaddr 100.100.100.5
special-frame peer-wwn 20:00:00:05:30:00:7a:de profile-id 2

canterbury# sh ips stats tcp int gig 2/1

TCP Statistics for port GigabitEthernet2/1
    Connection Stats
      20 active openings, 14 accepts
      14 failed attempts, 0 reset received, 14 established
    Segment stats
      12042719 received, 3181301 sent, 0 retransmitted
      0 bad segments received, 0 reset sent

TCP Active Connections 
    Local Address       Remote Address       State      Send-Q  Recv-Q
    200.200.200.1:3225  100.100.100.1:65368  ESTABLISH  0       0
    200.200.200.1:3225  100.100.100.1:65370  ESTABLISH  0       0
    200.200.200.1:3225  100.100.100.1:65372  TIME_WAIT  0       0
    200.200.200.1:3225  0.0.0.0:0            LISTEN     0       0

!--- Both FCIP interfaces for Canterbury are configured to be passive; this         
!--- results in the above TCP statistics where Canterbury, despite being 
!--- configured with the highest IP addresses for both tunnels, did not 
!--- initiate the TCP connections. Its peer, Bison, initiates.


canterbury# sh ips stats tcp int gig 2/2

TCP Statistics for port GigabitEthernet2/2
    Connection Stats
      500 active openings, 4 accepts
      498 failed attempts, 0 reset received, 6 established
    Segment stats
      11933351 received, 3144627 sent, 0 retransmitted
      0 bad segments received, 0 reset sent

TCP Active Connections
    Local Address       Remote Address       State      Send-Q  Recv-Q
    200.200.200.5:3225  100.100.100.5:65415  ESTABLISH  0       0
    200.200.200.5:3225  100.100.100.5:65417  ESTABLISH  0       0
    200.200.200.5:64535 100.100.100.5:3225   TIME_WAIT  0       0
    200.200.200.5:3225  0.0.0.0:0            LISTEN     0       0

Visualización del bisonte y de Cantorbery - Conjunto del grupo fecha/hora

!--- FCIP Time Stamp is enabled to allow the peer to drop FCIP userdata if it 
!--- exceeds the specified time-difference. The time difference is the maximum 
!--- value in transit of user data frames between two peer FCIP entities.


bison(config-if)# time-stamp acceptable-diff 1000

Please enable NTP with a common time source on both MDS Switches that are on 
either side of the FCIP link

!--- Note that the value specified is in milliseconds and, because a 
!--- time difference is specified, both ends of the FCIP tunnel must have access    
!--- to the same clock source through NTP.

interface fcip1
channel-group 1 force
no shutdown
use-profile 1
peer-info ipaddr 200.200.200.1
time-stamp acceptable-diff 1000
special-frame peer-wwn 20:00:00:0c:30:6c:24:40 profile-id 200

interface fcip2
channel-group 1 force
no shutdown
use-profile 2
peer-info ipaddr 200.200.200.5
time-stamp acceptable-diff 1000
special-frame peer-wwn 20:00:00:0c:30:6c:24:40 profile-id 201

bison# sh int fcip 1

fcip1 is trunking
    Hardware is GigabitEthernet
    Port WWN is 20:c2:00:05:30:00:7a:de
    Peer port WWN is 20:42:00:0c:30:6c:24:40
    Admin port mode is auto, trunk mode is on
    Port mode is TE
    vsan is 1
    Belongs to port-channel 1
    Trunk vsans (allowed active) (600-601)
    Trunk vsans (operational) (600-601)
    Trunk vsans (up) (600-601)
    Trunk vsans (isolated) ()
    Trunk vsans (initializing) ()
    Using Profile id 1 (interface GigabitEthernet4/1)
    Peer Information
      Peer Internet address is 200.200.200.1 and port is 3225
      Special Frame is enabled
      Peer switch WWN is 20:00:00:0c:30:6c:24:40
      Peer profile id is 200
      Maximum number of TCP connections is 2
      Time Stamp is enabled, acceptable time difference 1000 ms
      QOS control code point is 0
      QOS data code point is 0
      B-port mode disabled
    TCP Connection Information
      2 Active TCP connections
      Control connection: Local 100.100.100.1:65368, Remote 200.200.200.1:3225
      Data connection: Local 100.100.100.1:65370, Remote 200.200.200.1:3225
      84 Attempts for active connections, 10 close of connections
    TCP Parameters
      Path MTU 3000 bytes
      Current retransmission timeout is 200 ms
      Round trip time: Smoothed 2 ms, Variance: 3
      Advertized window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Peer receive window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Congestion window: Current: 10 KB, Slow start threshold: 118 KB
      5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
      5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
      5988 frames input, 1743840 bytes
        4719 Class F frames input, 443184 bytes
        1269 Class 2/3 frames input, 1300656 bytes
        0 Error frames timestamp error 0
      15337275 frames output, 18028320932 bytes
        4720 Class F frames output, 445544 bytes
        15332555 Class 2/3 frames output, 18027875388 bytes
        0 Error frames 0 reass frames

canterbury(config-if)# time-stamp acceptable-diff 1000

Please enable NTP with a common time source on both MDS Switches that are on 
either side of the FCIP link

interface fcip1
channel-group 2 force
no shutdown
use-profile 200
passive-mode
peer-info ipaddr 100.100.100.1
time-stamp acceptable-diff 1000
special-frame peer-wwn 20:00:00:05:30:00:7a:de profile-id 1

interface fcip2
channel-group 2 force
no shutdown
use-profile 201
passive-mode
peer-info ipaddr 100.100.100.5
time-stamp acceptable-diff 1000
special-frame peer-wwn 20:00:00:05:30:00:7a:de profile-id 2

canterbury# sh int fcip 1

fcip1 is trunking
    Hardware is GigabitEthernet
    Port WWN is 20:42:00:0c:30:6c:24:40
    Peer port WWN is 20:c2:00:05:30:00:7a:de
    Admin port mode is auto, trunk mode is auto
    Port mode is TE
    vsan is 1
    Belongs to port-channel 2
    Trunk vsans (allowed active) (600-601)
    Trunk vsans (operational) (600-601)
    Trunk vsans (up) (600-601)
    Trunk vsans (isolated) ()
    Trunk vsans (initializing) ()
    Using Profile id 200 (interface GigabitEthernet2/1)
    Peer Information
      Peer Internet address is 100.100.100.1 and port is 3225
      Passive mode is enabled
      Special Frame is enabled
      Peer switch WWN is 20:00:00:05:30:00:7a:de
      Peer profile id is 1
      Maximum number of TCP connections is 2
      Time Stamp is enabled, acceptable time difference 1000 ms
      QOS control code point is 0
      QOS data code point is 0
      B-port mode disabled
    TCP Connection Information
      2 Active TCP connections
      Control connection: Local 200.200.200.1:3225, Remote 100.100.100.1:65368
      Data connection: Local 200.200.200.1:3225, Remote 100.100.100.1:65370
      2 Attempts for active connections, 0 close of connections
    TCP Parameters
      Path MTU 3000 bytes
      Current retransmission timeout is 200 ms
      Round trip time: Smoothed 6 ms, Variance: 6
      Advertized window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Peer receive window: Current: 118 KB, Maximum: 118 KB, Scale: 1
      Congestion window: Current: 10 KB, Slow start threshold: 112 KB
      5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
      5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
      9427366 frames input, 11084654892 bytes
        295 Class F frames input, 32716 bytes
        9427071 Class 2/3 frames input, 11084622176 bytes
        145359 Error frames timestamp error 145359
      1122 frames output, 874528 bytes
        294 Class F frames output, 30932 bytes
        828 Class 2/3 frames output, 843596 bytes
        0 Error frames 0 reass frames

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 47120