Redes de almacenamiento : Canal de fibra

MDS a la configuración del 802.1Q MDS con el FCIP

18 Junio 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (25 Abril 2016) | Comentarios


Contenido


Introducción

Este documento proporciona un ejemplo de configuración para Canal de fibra por TCP/IP (FCIP) con switch del director multicapa 802.1Q a la MDS.

El FCIP describe los mecanismos que permiten que la interconexión de islas de las Redes de área de almacenamiento del Fibre Channel (FC) (sin) sobre las redes basadas en IP forme un SAN unificado en una sola tela FC. El FCIP confía en red basada en IP los servicios para proporcionar la Conectividad entre las islas SAN sobre las redes de área local, las redes de la área metropolitana, o las redes de área extensa.

Fibre Channel sin conectado por el FCIP

ips8_dot1q_1.gif

El FCIP utiliza el Transmission Control Protocol (TCP) en el puerto 3225 como transporte de la capa de red.

prerrequisitos

Requisitos

La estructura básica IP debe ser operativa y de entrega del ancho de banda necesario para soportar las aplicaciones que se ejecutan a través de los links FCIP — ésta podría ser una capa 2 (L2) o acodar 3 la topología (L3). Si es una topología L3, los routeres intermedios o los switches multicapas deben ser configurados y ser configurados para remitir apropiadamente el tráfico IP entre los IP Address de origen y de destino de los túneles FCIP. Si el Calidad de Servicio (QoS) o el modelado de tráfico se aplica en cualquier dispositivo de red en la trayectoria entre los pares FCIP, el administrador de la red que administra la infraestructura IP debe ser consultado para conseguir los detalles necesarios antes de configurar cualesquiera parámetros TCP-relacionados y las características en el Director de capas múltiples conmutan (MDS) los perfiles FCIP. Los switches Ethernet adyacentes a las MDS deben ser compatibles y estar configurados para el enlace troncal 802.1Q si las subinterfaces están configuradas en el módulo de servicios MDS IP Storage (IPS).

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • MDS9509 con la versión corriente del módulo de servicio IPS (DS-X9308-SMIP) 1.2.(2a)

  • MDS9216 con la versión corriente del módulo de servicio IPS (DS-X9308-SMIP) 1.2.(2a)

  • Catalyst 6509 que funciona con el Catalyst OS (CatOS) 7.4(3)

  • Win2003 Server (HPQ Pro-Liant-P4) con Emulex LP9K HBA

  • Conjunto de almacenamiento de IBM (ESS-2105-F20)

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Antecedentes

El FCIP consiste en estas especificaciones:

ANSI T11

  1. El FC-SW-2 describe la operación y la interacción del Switches FC incluyendo E_Port y el funcionamiento de la estructura.

  2. El FC-BB-2 es una asignación que pertenece a la extensión de las redes de switch FC a través de una estructura básica de red TCP, y define los modelos de referencia que soportan E_Port y B_Port.

Grupo de trabajo del IPS IETF

  1. El FC sobre el TCP cubre los requisitos TCP/IP para transportar las tramas FC sobre una red del IP.

  2. La encapsulación de la trama FC define el formato de encapsulado de la fibra típica.

Estándares del IEEE 802

El IEEE 802 LAN de todos los tipos se puede conectar así como los Bridges MAC, como se especifica en ISO/IEC 15802-3. Este estándar define la operación de los VLAN Bridge que permiten la definición, la operación, y la administración de las topologías de VLAN dentro de una infraestructura del LAN Bridged.

Una interconexión entre dos Switches SAN o telas a través del FCIP se llama un link FCIP y puede contener una o más conexiones TCP. Cada extremo de un link FCIP se asocia a un puerto virtual E (VE_port) o a un B_port, dependiendo de la implementación. El FC-BB y el FC-BB-2 están describiendo las diferencias entre ambos acercamientos. El módulo de servicios IP (DS-X9308-SMIP) soporta ambos modos pero predetermina el valor a VE_Port, que también es el modo recomendado para ejecutar si todos los pares relevantes son módulos DS-X9308-SMIP. Las funciones de VE_Port en las plataformas MDS también están soportando la funcionalidad de puerto TE, sin la cual hace capaz del tráfico del enlace de virtual múltiple (los VSAN) a través de un caso FCIP. Las interfaces Gigabit Ethernet (GE) que residen en los módulos X9308-SMIP de Cisco admiten 802.1Q, para aprovechar el ancho de banda de 1 Gbps entre dos o más túneles FCIP en aquellas situaciones en las que existen requerimientos de ancho de banda bajos por cada túnel FCIP. Uno debe comprender que compartir el ancho de banda utilizando dot1q no proporciona un ancho de banda determinante por túnel FCIP cuando los parámetros TCP del perfil FCIP quedan en estado predeterminado.

Configurar

En las MDS, es necesario que se familiarice con las guías para la configuración de IPS para ambas plataformas. La mayoría de la versión actual de los manuales se puede encontrar en configurar el almacenamiento IP en el cisco.com. En el lado del switch de Ethernet, uno necesita ser familiar con los específicos de la configuración de conexión de troncal del dot1q. En este ejemplo en particular, se despliega un Catalyst CatOS híbrido corriente; diversa configuración puede aplicarse a otros switches Cisco o al Switches de los otros vendedores.

Para las Catalyst 6000 Series que funcionan con al modo híbrido, refiera a configurar los links troncales de las redes Ethernet VLAN. Para el Native IOS, refiera a configurar los VLA N. Para el Switches del tipo del Catalyst XL que ejecuta el Native IOS, refiera a configurar los VLA N.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

Topología 2

/image/gif/paws/47101/ips8_dot1q_2.gif

La topología 2 representa un túnel FCIP que se ejecuta a través de un tronco 802.1q a cada lado de la nube IP. La nube IP se derrumba en un switch multicapa (Catalyst 6500) que rutee el tráfico del VLA N 1000 al VLA N 500 y el VLA N 500 al VLA N 1000. El VLA N 1000 asocia conceptual a la subred IP 100.100.100.0/30, y el VLA N 500 asocia a la subred IP 100.100.100.4/30. La manera que el MDS asocia y que extrae las tramas del dot1q se pondrá de manifiesto en la sección de configuración abajo. Para la simplicidad, solamente un túnel FCIP a través de una interfaz física en ambo MDSes se define; en la realidad, una utilizaría solamente el enlace del dot1q para compartir el ancho de banda de una interfaz Gigabit entre los túneles múltiples FCIP.

Configuraciones

MDS9509 (bisonte) con el módulo IPS-8
bison# sh ver

Cisco Storage Area Networking Operating System (SAN-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2003 by Cisco Systems, Inc. All rights reserved.
The copyright for certain works contained herein are owned by
Andiamo Systems, Inc. and/or other third parties and are used and
distributed under license.

Software
BIOS: version 1.0.8
loader: version 1.2(2)
kickstart: version 1.2(2a)
system: version 1.2(2a)

BIOS compile time: 08/07/03
kickstart image file is: bootflash:/k122a
kickstart compile time: 9/23/2003 11:00:00
system image file is: bootflash:/s122a
system compile time: 10/8/2003 18:00:00

Hardware
RAM 1024584 kB

bootflash: 500736 blocks (block size 512b)
slot0: 0 blocks (block size 512b)

bison uptime is 1 days 15 hours 45 minute(s) 44 second(s)

Last reset 
Reason: Unknown
System version: 1.2(2a)
Service: 

bison# sh run

Building Configuration ...
fcip profile 1
ip address 100.100.100.1

!--- FCIP profile 1 is bound to the local relevant IPS interface. 
!--- In this example, it is the IP address of interface Gig4/1.

vsan database
vsan 200 name test 
vsan 600 
vsan 601 

fcdomain priority 1 vsan 1
fcdomain domain 1 preferred vsan 1
fcdomain domain 1 preferred vsan 600
fcdomain domain 1 preferred vsan 601

interface fcip1
no shutdown
switchport trunk allowed vsan 600-601
use-profile 1
peer-info ipaddr 100.100.100.6


<!--- peer IP address is the address on remote MDS Canterbury
<!--- configured on interface Gig4/1.500.

vsan database
vsan 600 interface fc3/1
vsan 601 interface fc3/8

boot system bootflash:/s122a sup-1
boot kickstart bootflash:/k122a sup-1
boot system bootflash:/s122a sup-2
boot kickstart bootflash:/k122a sup-2
boot asm-sfn bootflash:/ilc1.bin module 4

ip domain-name cisco.com
ip name-server 144.254.10.123
ip default-gateway 10.48.69.129
ip route 100.100.100.4 255.255.255.252 100.100.100.2 distance 2

!--- The next hop IP address is 100.100.100.2 
!--- and is owned by the intermediate 
!--- Ethernet multilayer switch Aspendos.

zone name z-fcip2 vsan 600
member pwwn 50:05:07:63:00:d0:94:4c
member pwwn 10:00:00:00:c9:32:a6:e3

zone name Zone_a1 vsan 601
member pwwn 10:00:00:00:00:01:00:00
member pwwn 10:00:00:00:00:05:00:00

zone default-zone permit vsan 1
zone default-zone permit vsan 603

zoneset distribute full vsan 600

zoneset name zs-fcip2 vsan 600
member z-fcip2

zoneset name Agilent_1 vsan 601
member Zone_a1

zoneset activate name zs-fcip2 vsan 600

zoneset activate name Agilent_1 vsan 601

interface fc3/1
no shutdown

!--- Output supressed.

interface fc3/8
no shutdown

interface mgmt0
ip address 10.48.69.151 255.255.255.192

interface GigabitEthernet4/1
no shutdown

interface GigabitEthernet4/1.1000
ip address 100.100.100.1 255.255.255.252

switchport mtu 3000
no shutdown

!--- Here the subinterface 1000 is configured, 
!--- which ties into dot1q VLAN 1000 on the Ethernet switch.
!--- The MTU size is changed from the default 1500 bytes to 3000, 
!--- because the intermediate switch supports jumbo frames 
!--- on both L2 and L3.

MDS9216 (Cantorbery) con el módulo IPS-8
canterbury# sh run

Building Configuration ...
fcip profile 1
ip address 100.100.100.6

vsan database
vsan 600 
vsan 601 

fcdomain domain 2 preferred vsan 600
fcdomain domain 2 preferred vsan 601

interface fcip1
use-profile 1
peer-info ipaddr 100.100.100.1

vsan database
vsan 600 interface fc1/1
vsan 601 interface fc1/8

boot system bootflash:/s122a 
boot kickstart bootflash:/k122a 
fcalias name test vsan 1

ip domain-name cisco.com
ip name-server 144.254.10.123
ip default-gateway 10.48.69.129
ip route 10.61.0.0 255.255.0.0
ip route 10.61.0.0 255.255.0.0 10.48.69.200
ip route 100.100.100.0 255.255.255.252 100.100.100.5 distance 2

!--- Static IPS route required to reach the FCIP peer address.
 
line vty
exec-timeout 0

switchname canterbury
system default switchport trunk mode auto

zone name z-fcip2 vsan 600
member pwwn 50:05:07:63:00:d0:94:4c
member pwwn 10:00:00:00:c9:32:a6:e3

zone default-zone permit vsan 777
zoneset distribute full vsan 600

zoneset name zs-fcip2 vsan 600
member z-fcip2

zoneset activate name zs-fcip2 vsan 600
zoneset activate name Agilent_1 vsan 601

interface GigabitEthernet2/1
no shutdown

interface GigabitEthernet2/1.500
ip address 100.100.100.6 255.255.255.252

switchport mtu 3000
no shutdown

interface fc1/1
no shutdown

interface fc1/8
no shutdown

interface mgmt0
ip address 10.48.69.156 255.255.255.128

Catalyst 6000 (Aspendos) con el módulo IPS-8
Aspendos> (enable) sh vlan 500

VLAN Name                             Status    IfIndex Mod/Ports, Vlans
---- -------------------------------- --------- ------- -------------------
500  VLAN0500                         active    191     1/1
                                                        3/3
                                                        15/1

VLAN Type SAID MTU  Parent RingNo BrdgNo Stp    Brdg   Mode   Trans1 Trans2
---- ---- ---- ---- ------ ------ ------ ------ ------ ------ ------ ------
500  enet 100  500  1500   -      -      -      -      -      0      0


VLAN MISTP-Inst DynCreated RSPAN
---- ---------- ---------- --------
500  -          static     disabled

Aspendos> (enable) sh vlan 1000

VLAN Name                             Status    IfIndex Mod/Ports, Vlans
---- -------------------------------- --------- ------- -------------------
1000 fcip-extra-hop                   active    131     3/7
                                                        15/1

VLAN Type SAID MTU  Parent RingNo BrdgNo Stp    Brdg   Mode   Trans1 Trans2
---- ---- ---- ---- ------ ------ ------ ------ ------ ------ ------ ------
1000 enet 101  000  1500   -      -      -      -      -      0      0

VLAN MISTP-Inst DynCreated RSPAN
---- ---------- ---------- --------
1000 -          static     disabled

Aspendos> (enable) sh trunk 3/3

* - indicates vtp domain mismatch
Port Mode Encapsulation Status        Native vlan
---- ---- ------------- ------------- -----------
3/3  on   dot1q         trunking      1

Port Vlans allowed on trunk
---- ----------------------------------------------------------------------
3/3  1,500

Port Vlans allowed and active in management domain 
---- ----------------------------------------------------------------------
3/3  1,500

Port Vlans in spanning tree forwarding state and not pruned
---- ----------------------------------------------------------------------
3/3  1,500

Aspendos> (enable) sh trunk 3/7

* - indicates vtp domain mismatch
Port Mode Encapsulation Status       Native vlan
---- ---- ------------- ------------ -----------
3/7  on   dot1q         trunking     1

Port Vlans allowed on trunk
---- ----------------------------------------------------------------------
3/7  1,1000

Port Vlans allowed and active in management domain 
---- ----------------------------------------------------------------------
3/7  1,1000

Port Vlans in spanning tree forwarding state and not pruned
---- ----------------------------------------------------------------------
3/7  1,1000

!--- Note that VLAN 500 is trunked on port 3/3, which is physically connected 
!--- to MDS Canterbury while port 3/7 trunks for VLAN 1000 and is connected 
!--- to MDS Bison. The port 15/1 is an internal port and directs to the 
!--- multilayer entitity in the switch.


Aspendos> (enable) sh port jumbo 

Jumbo frames MTU size is 9216 bytes.
Jumbo frames enabled on port(s) 1/2,3/1-16.

!--- L2 Jumbo support must be enabled for all relevant ports.
 

Aspendos> (enable) sh spantree 3/3 

Port Vlan Port-State Cost Prio Portfast Channel_id
---- ---- ---------- ---- ---- -------- ----------
3/3  1    forwarding 4    32   disabled 0 
3/3  500  forwarding 4    32   disabled 0 

Aspendos> (enable) sh spantree 3/7

Port Vlan Port-State Cost Prio Portfast Channel_id
---- ---- ---------- ---- ---- -------- ----------
3/7  1    forwarding 4    32   disabled 0 
3/7  1000 forwarding 4    32   disabled 0 

Aspendos> (enable) sh spantree 15/1

Port Vlan Port-State Cost Prio Portfast Channel_id
---- ---- ---------- ---- ---- -------- ----------
15/1 192  forwarding 4    32   enabled  0 
15/1 500  forwarding 4    32   enabled  0 
15/1 691  forwarding 4    32   enabled  0 
15/1 1000 forwarding 4    32   enabled  0

!--- All relevant ports on the Catalyst are forwarding 
!--- for their respective VLANs.


Aspendos> (enable) ses 15

Trying Router-15...
Connected to Router-15.
Escape character is '^]'.

User Access Verification

Password: 
Aspendos_MSFC2> en
Password: 
Aspendos_MSFC2#

!
interface Vlan500
mtu 3000
ip address 100.100.100.5 255.255.255.252
end

Aspendos_MSFC2# sh run int vlan 1000
Building configuration...

Current configuration : 113 bytes
!
interface Vlan1000
description "test-vlan-fcip-1000"
mtu 3000
ip address 100.100.100.2 255.255.255.252
end

!--- The VLANs 500 and 1000 are configured properly on the MSFC 
!--- of the Catalyst 6000.
!--- Both subnets are directly connected to the same Ethernet 
!--- switch, so no additional routes are needed here. Also note 
!--- that the MTU size is changed accordingly on the MDS Gigabit 
!--- interfaces to 3000 bytes. This change is required to support 
!--- jumbo multilayer switching.

Verificación

En esta sección encontrará información que puede utilizar para corroborar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • x/y del show interface gig — Visualiza el estatus de la interfaz Gigabit relevante limitada al perfil FCIP.

  • muestre el x/y tcp de las estadísticas de ips int gig — Estadísticas y conexiones activas de las visualizaciones TCP para la interfaz Gigabit relevante.

  • x/y de la demostración ips arp int gig — Visualiza todas las entradas del Address Resolution Protocol (ARP) para la interfaz Gigabit relevante; el salto siguiente o el par debe estar presente en esta lista.

  • muestre el x/y de la ruta de IP IPS int gig — Visualiza las rutas específicas que van a través de la interfaz Gigabit relevante.

  • muestre el fcip x de la interfaz — Visualiza el estado de la interfaz FCIP y todo detalla relacionado a este túnel FCIP.

  • muestre el fcip x del perfil — Visualiza la dirección IP a la cual el perfil es parámetros TCP encuadernados y todos los configurados.

  • muestre los contadores del fcip x internacional — Utilizado para marcar si hay algunas tramas que pasan a través del túnel FCIP.

  • muestre el vsan x del fcdomain — Enumera todos los detalles relacionados al dominio; utilizado para verificar que la tela está formada a través de los túneles FCIP.

  • muestre el vsan x DA del fcns — Visualiza todo el pwwn, FC4-Types, y FCID del VSAN relevante; utilizado para verificar que todas las entradas previstas están distribuidas a través de los túneles FCIP.

Nota: La interfaz dot1q actúa como una interfaz física normal para FCIP. No existe ningún requisito específico para verificar el funcionamiento correcto además del comando show interface gig x/y.z, donde z representa la subinterfaz. Dependiendo del dispositivo conectado con las interfaces Gigabit locales MDS, usted debe consultar la documentación relacionada para verificar que las interfaces y los puertos están configurados correctamente.

Troubleshooting

Esté seguro de publicar los tiempos múltiples de los comandos show para construir un historial contrario. Los contadores que no se relacionan con una punta a tiempo y apenas se recogen solamente son una vez sobre todo inútiles.

Utilice las configuraciones que se ilustran a continuación para la resolución de otros problemas.

MDS9509 (bisonte)
bison# sh int gig 4/1.1000

GigabitEthernet4/1.1000 is up
    Hardware is GigabitEthernet, address is 0005.3000.a85a
    Internet address is 100.100.100.1/30
    MTU 3000 bytes

!--- Configured to 3000 bytes.

    5 minutes input rate 488 bits/sec, 61 bytes/sec, 0 frames/sec
    5 minutes output rate 488 bits/sec, 61 bytes/sec, 0 frames/sec
    1785 packets input, 996030 bytes
      0 multicast frames, 0 compressed
      0 input errors, 0 frame, 0 overrun 0 fifo
    1812 packets output, 354152 bytes, 0 underruns
      0 output errors, 0 collisions, 0 fifo
      0 carrier errors

!--- MTU is configured to 3000 bytes to avoid unnecessary 
!--- TCP segmentation and limit overhead.


bison# sh ips stats tcp int gig 4/1 de

TCP Statistics for port GigabitEthernet4/1
    TCP send stats
      337202017 segments, 222637392068 bytes
      130562402 data, 205533417 ack only packets
      503 control (SYN/FIN/RST), 0 probes, 1105737 window updates
      7 segments retransmitted, 2208 bytes
      4 retransmitted while on ethernet send queue, 40061909 packets split
      250922624 delayed acks sent
    TCP receive stats
      932985742 segments, 921498012 data packets in sequence, 
        936715052100 bytes in sequence
      770241 predicted ack, 856752348 predicted data
      0 bad checksum, 0 multi/broadcast, 0 bad offset
      0 no memory drops, 0 short segments
      0 duplicate bytes, 16 duplicate packets
      0 partial duplicate bytes, 0 partial duplicate packets
      53128 out-of-order bytes, 165 out-of-order packets
      0 packet after window, 0 bytes after window
      5 packets after close
      76225562 acks, 192030009160 ack bytes, 0 ack toomuch,
        5851 duplicate acks
      0 ack packets left of snd_una, 0 non-4 byte aligned packets
      9124012 window updates, 0 window probe
      1381 pcb hash miss, 984 no port, 103 bad SYN, 0 paws drops
    TCP Connection Stats
      272 attempts, 107 accepts, 163 established
      511 closed, 3 drops, 206 conn drops
      3 drop in retransmit timeout, 20 drop in keepalive timeout
      0 drop in persist drops, 0 connections drained
    TCP Miscellaneous Stats
      61792500 segments timed, 76225541 rtt updated
      124 retransmit timeout, 0 persist timeout
      5760 keepalive timeout, 5740 keepalive probes
    TCP SACK Stats
      0 recovery episodes, 0 data packets, 0 data bytes
      0 data packets retransmitted, 0 data bytes retransmitted
      0 connections closed, 0 retransmit timeouts
    TCP SYN Cache Stats
      107 entries, 107 connections completed, 0 entries timed out
      0 dropped due to overflow, 0 dropped due to RST
      0 dropped due to ICMP unreach, 0 dropped due to bucket overflow
      0 abort due to no memory, 0 duplicate SYN, 0 no-route SYN drop
      0 hash collisions, 0 retransmitted

100.100.100.1:64860 100.100.100.6:3225 ESTABLISH 0 0
100.100.100.1:64862 100.100.100.6:3225 ESTABLISH 0 0
100.100.100.1:3225 0.0.0.0:0 LISTEN 0 0

!--- No specific counters are maintained per subinterface.
!--- All stats for all subinterfaces on Gig 4/1 are seen here.


bison# sh ips arp interface gig 4/1

Protocol Address Age (min) Hardware Addr Type Interface
Internet 100.100.100.2 13 0008.e21e.c7bc ARPA GigabitEthernet4/1.1000 

!--- No specific ARP table is maintained per subinterface.
!--- All entries for all subinterface on Gig4/1 are seen here.


bison# sh ips ip route int gig 4/1

Codes: C - connected, S - static

No default gateway

S 100.100.100.4/30 via 100.100.100.2, GigabitEthernet4/1.1000
C 100.100.100.0/30 is directly connected, GigabitEthernet4/1.1000

!--- IPS routes are derived from the main-interface, 
!--- not specifically per subinterface. The next hop is verified here.


bison# sh cdp ne int gig 4/1

Capability Codes: R - Router, T - Trans-Bridge, B - Source-Route-Bridge
S - Switch, H - Host, I - IGMP, r - Repeater

Device ID   Local Intrfce Hldtme Capability Platform Port ID
----------- ----- ------- ------ ---------- -------- -------
TBM06033144 (Aspe Gig4/1  136    T S        WS-C6506 3/7 

!--- Use this command if the neighbor supports it to verify 
!--- physical connectivity.


bison# sh fcip profile 1

FCIP Profile 1
Internet Address is 100.100.100.1 (interface GigabitEthernet4/1.1000)
Listen Port is 3225
TCP parameters
SACK is enabled
PMTU discovery is enabled, reset timeout is 3600 sec
Keep alive is 60 sec
Minimum retransmission timeout is 200 ms
Maximum number of re-transmissions is 4
Send buffer size is 0 KB
Maximum allowed bandwidth is 1000000 kbps
Minimum available bandwidth is 15000 kbps
Estimated round trip time is 1000 usec
Congestion window monitoring is enabled, burst size is 10 KB 

!--- The profile parameters are an easy way to directly verify 
!--- the configured TCP/IP parameters per FCIP instance.
 

bison# sh int fcip 1

fcip1 is trunking
Hardware is GigabitEthernet
Port WWN is 20:c2:00:05:30:00:7a:de
Peer port WWN is 20:42:00:0c:30:6c:24:40
Admin port mode is auto, trunk mode is on
Port mode is TE
vsan is 1
Trunk vsans (allowed active) (1,600-601)
Trunk vsans (operational) (1,600-601)
Trunk vsans (up) (1,600-601)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()
Using Profile id 1 (interface GigabitEthernet4/1.1000)
Peer Information
Peer Internet address is 100.100.100.6 and port is 3225
Special Frame is disabled
Maximum number of TCP connections is 2
Time Stamp is disabled
QOS control code point is 0
QOS data code point is 0
B-port mode disabled
TCP Connection Information
2 Active TCP connections
Control connection: Local 100.100.100.1:64860, Remote 100.100.100.6:3225
Data connection: Local 100.100.100.1:64862, Remote 100.100.100.6:3225
2 Attempts for active connections, 0 close of connections
TCP Parameters
Path MTU 3000 bytes
Current retransmission timeout is 200 ms
Round trip time: Smoothed 2 ms, Variance: 1
Advertized window: Current: 118 KB, Maximum: 118 KB, Scale: 1
Peer receive window: Current: 118 KB, Maximum: 118 KB, Scale: 1
Congestion window: Current: 10 KB, Slow start threshold: 112 KB
5 minutes input rate 200 bits/sec, 25 bytes/sec, 0 frames/sec
5 minutes output rate 200 bits/sec, 25 bytes/sec, 0 frames/sec
1306 frames input, 891212 bytes
472 Class F frames input, 46972 bytes
834 Class 2/3 frames input, 844240 bytes
0 Error frames timestamp error 0
867 frames output, 252424 bytes
470 Class F frames output, 48860 bytes
397 Class 2/3 frames output, 203564 bytes
0 Error frames 0 reass frames

!--- Here, the specific details per FCIP interface are shown 
!--- by a running FCIP instance. You can also derive the 
!--- TCP parameters of the peer with this output.


bison# sh fcdomain vsan 600

The local switch is the Principal Switch.

Local switch run time information:
State: Stable
Local switch WWN: 22:58:00:05:30:00:7a:df
Running fabric name: 22:58:00:05:30:00:7a:df
Running priority: 2
Current domain ID: 0x01(1) 

Local switch configuration information:
State: Enabled
FCID persistence: Disabled
Auto-reconfiguration: Disabled
Contiguous-allocation: Disabled
Configured fabric name: 20:01:00:05:30:00:28:df
Configured priority: 128
Configured domain ID: 0x01(1) (preferred)

Principal switch run time information:
Running priority: 2

Interface        Role          RCF-reject
---------------- ------------- ------------
fcip1            Downstream    Disabled
---------------- ------------- ------------

bison# sh fcdomain vsan 601

The local switch is the Principal Switch.

Local switch run time information:
State: Stable
Local switch WWN: 22:59:00:05:30:00:7a:df
Running fabric name: 22:59:00:05:30:00:7a:df
Running priority: 2
Current domain ID: 0x01(1) 

Local switch configuration information:
State: Enabled
FCID persistence: Disabled
Auto-reconfiguration: Disabled
Contiguous-allocation: Disabled
Configured fabric name: 20:01:00:05:30:00:28:df
Configured priority: 128
Configured domain ID: 0x01(1) (preferred)

Principal switch run time information:
Running priority: 2

Interface        Role          RCF-reject
---------------- ------------- ------------
fcip1            Downstream    Disabled
---------------- ------------- ------------

!--- Similar to normal (E)ISL troubleshooting, verify 
!--- that the fabric is formed as expected.


bison# sh fcns da vsan 600-601

VSAN 600:
-------- ---- ----------------------- -------- ---------------------------
FCID     TYPE PWWN                    (VENDOR) FC4-TYPE:FEATURE
-------- ---- ----------------------- -------- ---------------------------
0x010001 N    10:00:00:00:c9:32:a6:e3 (Emulex) scsi-fcp:init 
0x020001 N    50:05:07:63:00:d0:94:4c (IBM)    scsi-fcp:target fc..

Total number of entries = 2

VSAN 601:
-------- ---- ----------------------- -------- ---------------------------
FCID     TYPE PWWN                    (VENDOR) FC4-TYPE:FEATURE
-------- ---- ----------------------- -------- ---------------------------
0x010001 N    10:00:00:00:c9:32:a6:e2 (Emulex) scsi-fcp:init 
0x010100 N    10:00:00:00:00:05:00:00 
0x020100 N    10:00:00:00:00:01:00:00 

Total number of entries = 3

MDS9216 (Cantorbery)
canterbury# sh int gig 2/1.500

GigabitEthernet2/1.500 is up
    Hardware is GigabitEthernet, address is 0005.3000.ade6
    Internet address is 100.100.100.6/30
    MTU 3000 bytes
    5 minutes input rate 2248 bits/sec, 281 bytes/sec, 0 frames/sec
    5 minutes output rate 696 bits/sec, 87 bytes/sec, 0 frames/sec
    2263 packets input, 482038 bytes
      0 multicast frames, 0 compressed
      0 input errors, 0 frame, 0 overrun 0 fifo
    2479 packets output, 1077822 bytes, 0 underruns
      0 output errors, 0 collisions, 0 fifo
      0 carrier errors

canterbury# sh cdp ne int gig 2/1

Capability Codes: R - Router, T - Trans-Bridge, B - Source-Route-Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID   Local Intrfce Hldtme Capability Platform Port ID
----------- ----- ------- ------ ---------- -------- -------
TBM06033144 (Aspe Gig2/1  165    T S        WS-C6506 3/3

!--- If the neighbor supports CDP, use this command
!--- to verify physical connectivity.


canterbury# sh fcip profile 1
FCIP Profile 1
Internet Address is 100.100.100.6 (interface GigabitEthernet2/1.500)
Listen Port is 3225
TCP parameters
SACK is enabled
PMTU discovery is enabled, reset timeout is 3600 sec
Keep alive is 60 sec
Minimum retransmission timeout is 200 ms
Maximum number of re-transmissions is 4
Send buffer size is 0 KB
Maximum allowed bandwidth is 1000000 kbps
Minimum available bandwidth is 15000 kbps
Estimated round trip time is 1000 usec
Congestion window monitoring is enabled, burst size is 10 KB

canterbury# sh int fcip 1
fcip1 is trunking
Hardware is GigabitEthernet
Port WWN is 20:42:00:0c:30:6c:24:40
Peer port WWN is 20:c2:00:05:30:00:7a:de
Admin port mode is auto, trunk mode is auto
Port mode is TE
vsan is 1
Trunk vsans (allowed active) (1,600-601)
Trunk vsans (operational) (1,600-601)
Trunk vsans (up) (1,600-601)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()
Using Profile id 1 (interface GigabitEthernet2/1.500)
Peer Information
Peer Internet address is 100.100.100.1 and port is 3225
Special Frame is disabled
Maximum number of TCP connections is 2
Time Stamp is disabled
QOS control code point is 0
QOS data code point is 0
B-port mode disabled
TCP Connection Information
2 Active TCP connections
Control connection: Local 100.100.100.6:3225, Remote 100.100.100.1:64860
Data connection: Local 100.100.100.6:3225, Remote 100.100.100.1:64862
0 Attempts for active connections, 0 close of connections
TCP Parameters
Path MTU 3000 bytes
Current retransmission timeout is 200 ms
Round trip time: Smoothed 2 ms, Variance: 1
Advertized window: Current: 118 KB, Maximum: 118 KB, Scale: 1
Peer receive window: Current: 118 KB, Maximum: 118 KB, Scale: 1
Congestion window: Current: 10 KB, Slow start threshold: 112 KB
5 minutes input rate 184 bits/sec, 23 bytes/sec, 0 frames/sec
5 minutes output rate 184 bits/sec, 23 bytes/sec, 0 frames/sec
1163 frames input, 336700 bytes
722 Class F frames input, 72176 bytes
441 Class 2/3 frames input, 264524 bytes
0 Error frames timestamp error 0
1588 frames output, 917216 bytes
724 Class F frames output, 70288 bytes
864 Class 2/3 frames output, 846928 bytes
0 Error frames 0 reass frames

Observe en la discrepancia de VLAN nativa

Bajo ciertas condiciones, es posible que el cliente vea el mensaje de error de incompatibilidad de vlan nativa en el registro del sistema del switch Ethernet (Catalyst) adyacente. Esto indica una configuración incorrecta en el puerto troncal de esos switches. Si una subinterfaz de .1000 se configura en una de las interfaces principales en el módulo de los Servicios IP MDS, el puerto del switch adyacente en el switch de Catalyst necesita ser enlace para ese mismo VLAN ID de 1000. Si, por alguna razón, el Catalyst es el VLA N corriente 1000 como el puerto VLAN o VLAN nativo, después se generan los mensajes de error y la Conectividad está quebrada, porque las tramas encapsuladas del dot1q del lado MDS no son entendidas por el Switch y serán desechadas. Un ejemplo de los errores de la discordancía del VLAN nativo se muestra abajo.

2003 Nov 13 02:36:39 %CDP-4-NVLANMISMATCH:Native vlan mismatch detected on port 3/7
2003 Nov 13 02:37:26 %CDP-4-NVLANMISMATCH:Native vlan mismatch detected on port 3/3

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 47101