Servicios de redes de aplicaciones : Cisco LocalDirector de la serie 400

Configuración de la redirección de http en LocalDirector mientras se controla la disponibilidad del servidor.

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Cisco ha anunciado la fin-de-venta para el Cisco LocalDirector. Para más información, refiera al fin de vida de las 400 Series de LocalDirector y los avisos y los boletines de productos del Fin de la Venta.


Contenido


Introducción

Este documento describe cómo configurar la redirección del Protocolo de transferencia de hipertexto (HTTP) que permite verificar la disponibilidad del servidor en Cisco LocalDirector. La redirección HTTP también requiere direcciones IP adicionales para que las direcciones IP directas (DIP) permitan las llamadas/navegación directa.

Esta configuración fue desarrollada y probada utilizando las versiones de software y hardware indicadas a continuación.

  • LocalDirector 416 en un entorno del laboratorio con configuraciones despejadas.
  • Versión 4.2.1 de LocalDirector
  • Microsoft Internet Explorer 5.5
  • Netscape Communicator 4.7

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Diagrama de la red

Cómo configurar la redirección de HTTP para verificar la disponibilidad del servidor

Utilice los siguientes pasos para configurar su LocalDirector:

  1. Cree un expediente “A” para el siguiente:
    test.testdomain.com <-> 172.18.124.209 VIP
    ns-ms1-dip.testdomain.com <-> 172.18.124.212 DIP 
    ns-ms2-dip.testdomain.com <-> 172.18.124.211 DIP
    ns-ms1.cisco.com <-> 172.18.124.207 REAL 
    ns-ms2.cisco.com <-> 172.18.124.206 REAL
    172.18.124.211 DIP virtual for 172.18.124.206 REAL (aka s2)
    172.18.124.212 DIP virtual for 172.18.124.207 REAL (aka s1)
    

    Nota: Necesita una IP virtual (VIP) orientada a puertos, un DIP y direcciones reales, pero también necesita dos direcciones IP para cada dirección real para conexiones salientes al servidor real para seguir siendo admitido. Esto permite los VIP seguros con una restauración enviada para los malos puertos. También permite que otras llamadas a los DIP pasen directamente a través de la dirección verdadera, mientras que utilizan direcciones IP alternativas para la dirección virtual de DIP.

  2. Cree una dirección VIP (límite del puerto). Debe haber una entrada de registro “A” en el Domain Name System (DNS).
    virtual 172.18.124.209:80:0:tcp is 
    
  3. Cree una INMERSIÓN para cada “servidor real” que esté validando las llamadas para este direccionamiento VIP. Utilice un "número de IP extra" en la primera parte de la sentencia.
    direct-ip 172.18.124.211:80:0:tcp 172.18.124.206:80:0:tcp is
    direct-ip 172.18.124.212:80:0:tcp 172.18.124.207:80:0:tcp is
    
    El sistema creará lo siguiente:
    real 172.18.124.207:80:0:tcp is
    real 172.18.124.206:80:0:tcp is
    bind 172.18.124.211:80:0:tcp 172.18.124.206:80:0:tcp
    bind 172.18.124.212:80:0:tcp 172.18.124.207:80:0:tcp
    
  4. Cree un redireccionamiento de URL (Uniform Resource Locator) para cada servidor real. Aquí es donde reorientarán al cliente cuando golpean el VIP.
    url s2 http://ns-ms2-dip.testdomain.com/%p 302
    url s1 http://ns-ms1-dip.testdomain.com/%p 302
    

    Nota: El "%p" especifica la página.

  5. Cree un comando de respaldo para cada DIP en el VIP común. Esto soluciona el problema de favoritos. Si un cliente marca el URL de un DIP y si ese DIP (servidor real) no está disponible (aparece como FAILED (Fallido)), entonces utilizará el comando backup para hacer que el cliente llame a VIP nuevamente.
    backup 172.18.124.211:80:0:tcp 172.18.124.209:80:0:tcp
    backup 172.18.124.212:80:0:tcp 172.18.124.209:80:0:tcp
    

    Nota: El redireccionamiento HTTPS utilice respaldos de otra manera.

  6. Asocie el VIP con cada URL.

    bind 172.18.124.209:80:0:tcp s2
    bind 172.18.124.209:80:0:tcp s1
    
  7. Cree un comando de link para cada URL a la primera parte de la dirección DIP. Esto crea una asociación entre la DIP y la URL asociadas con ese seudónimo (por ejemplo, s1). El comando de link asegura que si falla un DIP, LocalDirector no volverá a dirigir clientes a una URL que llamara a ese DIP fallado (el cual está mapeado uno a uno con la dirección IP real).
    link s2 172.18.124.211:80:0:tcp
    link s1 172.18.124.212:80:0:tcp
    

Comandos show y salida de ejemplo

Comando show version

El comando show version muestra la versión de software en ejecución en el LocalDirector.

localdirector# show version
LocalDirector 416 Version 4.2.1

Comando show configuration

El comando show configuration muestra la versión de software que está en funcionamiento en el LocalDirector.

localdirector# show configuration
: Saved
: LocalDirector 416 Version 4.2.1
syslog output 20.7
no syslog console
enable password 000000000000000000000000000000 encrypted
hostname localdirector
no shutdown ethernet 0
no shutdown ethernet 1
no shutdown ethernet 2
interface ethernet 0 auto
interface ethernet 1 auto
interface ethernet 2 auto
mtu 0 1500
mtu 1 1500
mtu 2 1500
multiring all
no secure  0
no secure  1
no secure  2
ping-allow 0
ping-allow 1
no ping-allow 2
ip address 172.18.124.210 255.255.255.0
route 0.0.0.0 0.0.0.0 172.18.124.1 1
arp timeout 30
no rip passive
rip version 1
failover ip address 0.0.0.0
no failover
failover hellotime 30
password dfeaf10390e560aea745ccba53e044ed encrypted
telnet 172.18.124.0 255.255.255.0
telnet 64.105.0.0 255.255.0.0
snmp-server enable traps
snmp-server community public
no snmp-server contact
no snmp-server location
virtual 172.18.124.209:80:0:tcp is
predictor 172.18.124.209:80:0:tcp roundrobin
real 172.18.124.207:80:0:tcp is
real 172.18.124.206:80:0:tcp is
direct-ip 172.18.124.211:80:0:tcp   172.18.124.206:80:0:tcp is
direct-ip 172.18.124.212:80:0:tcp   172.18.124.207:80:0:tcp is
url s2 http://ns-ms2-dip.testdomain.com/%p 302
url s1 http://ns-ms1-dip.testdomain.com/%p 302
backup 172.18.124.211:80:0:tcp 172.18.124.209:80:0:tcp
backup 172.18.124.212:80:0:tcp 172.18.124.209:80:0:tcp
bind 172.18.124.211:80:0:tcp 172.18.124.206:80:0:tcp
bind 172.18.124.212:80:0:tcp 172.18.124.207:80:0:tcp
bind 172.18.124.209:80:0:tcp s2
bind 172.18.124.209:80:0:tcp s1
link s2 172.18.124.211:80:0:tcp
link s1 172.18.124.212:80:0:tcp

Comando show statistics

El comando show statistics muestra las estadísticas reales y virtuales del servidor.

localdirector(config)# show statistics
          Real Machine(s)              Bytes      Packets   Connections
(DIP) 172.18.124.207:80:0:tcp           1092            8             2
(DIP) 172.18.124.206:80:0:tcp            960            7             1


       Virtual Machine(s)              Bytes      Packets   Connections
(DIP) 172.18.124.211:80:0:tcp            960            7             1
(DIP) 172.18.124.212:80:0:tcp           1092            8             1
  172.18.124.209:80:0:tcp               3296           26             2
localdirector(config)#

Comando show url

El comando show url muestra la información de conexión hacia las URL.

localdirector(config)# show url
Urls:

             Id  Connect    Rcode   State                     Url
             s2        1      302     IS http://ns-ms2-dip.testdomain.com/%p
             s1        0      302     IS http://ns-ms1-dip.testdomain.com/%p
localdirector(config)#

Comando show syslog

El comando show syslog muestra la información de ingreso al sistema (como la fecha, la hora, el nivel y la salida):

<165> May 30 11:35:14 LD-NOTICE Virtual machine '172.18.124.209:80:0:tcp': 
Edited from In Service to Out Of Service.
<165> May 30 11:35:24 LD-NOTICE Real machine '172.18.124.207:80:0:tcp': 
Edited from In Service to Out Of Service.
<165> May 30 11:35:24 LD-NOTICE Real machine '172.18.124.206:80:0:tcp': 
Edited from In Service to Out Of Service.
<165> May 30 11:35:28 LD-NOTICE Real machine '172.18.124.207:80:0:tcp': 
Edited from Out Of Service to In Service.
<162> May 30 11:35:28 LD-CRIT Switching '172.18.124.212:80:0:tcp' 
from 'leastconns' to 'slowstart'
<165> May 30 11:35:28 LD-NOTICE Real machine '172.18.124.206:80:0:tcp': 
Edited from Out Of Service to In Service.
<162> May 30 11:35:28 LD-CRIT Switching '172.18.124.211:80:0:tcp' 
from 'leastconns' to 'slowstart'
<165> May 30 11:35:34 LD-NOTICE Virtual machine '172.18.124.209:80:0:tcp': 
Edited from Out Of Service to In Service.
<162> May 30 11:36:23 LD-CRIT Switching '172.18.124.212:80:0:tcp' 
from 'slowstart' to 'leastconns'
<162> May 30 11:41:24 LD-CRIT Switching '172.18.124.211:80:0:tcp' 
from 'slowstart' to 'leastconns'
  

Verifique la Configuración

Utilice los siguientes comandos de verificar la configuración:

  • show real - Muestra las estadísticas y estados de los servidores reales.

  • show virtual - Muestra una lista de servidores virtuales, sus estados, cantidad de conexiones y algoritmos de balanceo de carga.

  • show statistics - Consulte más arriba.

Resolver problemas con la configuración

Comando syslog

El Syslog [IP del host | consola | el comando de la salida facility.level] se puede utilizar para hacer el debug de o resolver problemas.

En este ejemplo, http://test.testdomain.com se reorienta a http://ns-ms2-dip.testdomain.com/.

El siguiente es un ejemplo del resultado de syslog console y syslog output 20.7:

localdirector(config)# syslog console
localdirector(config)# <162> May 30 11:36:23 LD-CRIT Switching '172.18.124.212:80:0:tcp'
 from 'slowstart' to 'leastconns'
localdirector(config)# <162> May 30 11:41:24 LD-CRIT Switching '172.18.124.211:80:0:tcp'
 from 'slowstart' to 'leastconns'



Información Relacionada



Document ID: 46222