IP : IP versión 6 (IPv6)

conexión 6bone usando los túneles del 6to4 para el IPv6

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (29 Agosto 2008) | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe cómo un cliente de la oficina central de la empresa (por ejemplo, una institución educativa, una pequeña empresa de software o una pequeña compañía fabricante) puede conectar con el 6bone usando túneles 6to4. 6bone es una red de prueba IP version 6 (IPv6) configurada para ayudar a la evolución y al despliegue de IPv6 en Internet.

Este documento es uno de un conjunto de los documentos que el soporte y complementa la publicación de las Estrategias de implementación del IPv6, que está disponible en las guías de diseño del IPv6.

Deberá leer este documento junto con las Estrategias de instrumentación IPv6 para comprender mejor las actividades de instrumentación preliminar de IPv6.

prerrequisitos

Requisitos

Antes de que implemente un túnel 6to4 al 6bone, debe realizar las siguientes tareas:

  • Identifique el router marginal en su sitio que configurará para que ejecute la pila doble. Este Router del borde debe tener los parásitos atmosféricos, global direccionamiento del IPv4 del routable.

  • Una licencia de los datos se requiere para habilitar todas las características del IPv6. Para verificar qué licencia se habilita en el router, utilice el comando license de la demostración.

  • Del ISP 6bone, obtenga la dirección IPv4 del router de retransmisión 6to4 que utilizará para el acceso a 6bone.

    Nota: Cuando usted configura los túneles para sus routeres de borde empresariales, usted debe utilizar global los direccionamientos del IPv4 del routable. Las direcciones de IPv4 usadas en las configuraciones de ejemplo de este documento no son enrutables totalmente y se proporcionan sólo con fines ilustrativos.

  • Asegúrese de que su DNS esté funcionando con (o tiene las capacidades equivalentes de) la versión 9 del Berkeley Internet Name Domain (LAZO), que proporciona una implementación de los componentes importantes del DNS para el IPv6. La Configuración de DNS está fuera del alcance de este documento.

  • Reconozca que la implementación actual de la doble pila en Cisco IOS Software permite una solución de administración de red interina, que permite las aplicaciones tales como TFTP, ping, Telnet, y traceroute que se ejecutará sobre un IPv4 o un transporte del IPv6.

  • Seleccione un protocolo de ruteo interior IPv6, tal como RIPng, que sea apropiado para la configuración de su red. A los fines de simplificar este punto, la solución que se detalla en este documento utiliza una ruta estática. El protocolo de ruteo exterior de IPv4 correspondiente maneja el ruteo exterior.

  • Configure a todo su Routers de la doble pila para utilizar el RIP.

Consulte la Biblioteca de Configuración del IOS de Cisco IPv6 para más información sobre la configuración de su red para IPv6.

Componentes Utilizados

La información en este documento se basa en las imágenes del Cisco IOS con el soporte del IPv6.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

La siguiente figura muestra la topología de red inicial IPv4 para el cliente de oficina central corporativa. Esta red utiliza varios routers para brindar conectividad de IP entre los usuarios locales. Una conexión IPv4 permanente a un Proveedor de servicios de Internet (ISP) proporciona conectividad externa

/image/gif/paws/45741/6bone_tc_1-01.gif

La siguiente tabla detalla los dispositivos utilizados en esta solución.

Dispositivo Router de borde empresarial Router ISP 6bone
Nombre de host 6bone-gw ipv6-router
Tipo de Chasis Router Cisco 3660 Cisco 7206 Router
Interfaces físicas 2 serial de los fast ethernet 4 de los Ethernetes 2 4 serial de los fast ethernet 4 de los Ethernetes 2
Software cargado Versión de Cisco IOS 12.2(4)T Versión de Cisco IOS 12.2(4)T
Memoria RAM 64MV; Flash del 16 MB RAM DEL 128 MB; Flash del 20 MB
Direcciones de IP Ethernet0: IPv4 192.168.99.1 Tunnel2002: IPv6 2002:C0A8::1/128 Ethernet0/0: IPv4 192.168.33.1 Tunnel2002: IPv6 2002:C0A8:2102::1/128

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Cómo funcionan los túneles 6to4

Un túnel 6to4 se configura en un router de borde dual-stack de la empresa. Todo el tráfico empresarial IPv6 destinado al 6bone es enrutado por IPv4 a través del túnel al router de entramado 6bone ISP 6to4. El tráfico desde un 6bone hacia un host de empresa se realiza mediante IPv4 a través del túnel que deriva en el router de borde de pila doble y luego al host de destino IPv6.

Los beneficios para la empresa por el uso de los túneles 6 a 4 son las siguientes:

  • El software del IOS de Cisco admite con los túneles 6to4.

  • La configuración de host del usuario final es sencilla—necesita tareas generales de administración mínimas.

  • El túnel es automático; no se requiere ninguna configuración específica de la empresa en el sitio de la retransmisión del 6to4. Túneles 6to4 gradúan bien.

  • Esta solución adapta las direcciones IP dinámicas en la empresa.

  • El túnel permanece activo sólo durante el tiempo de la sesión.

  • Un túnel del 6to4 requiere solamente una configuración de una sola vez en el ISP, que hace que la retransmisión del 6to4 mantiene disponible simultáneamente a muchas empresas.

Limitaciones de los túneles 6to4

El uso del túnel 6a4 tiene las siguientes limitaciones:

  • El NAT independientemente manejado no se permite a lo largo de la trayectoria del túnel.

  • Usted no puede implementar fácilmente el multihoming.

  • El mecanismo del túnel del 6to4 proporciona un bloqueo de dirección de /48; no más de direccionamientos están disponibles.

  • Debido a que los túneles 6a4 están configurados muchos-a-uno y el tráfico del túnel puede originarse en puntos finales múltiples, los túneles 6a4 pueden proporcionar únicamente información de trafico integral al ISP.

  • El direccionamiento subyacente del IPv4 determina el prefijo de dirección del IPv6 de la empresa 6to4, así que la migración al IPv6 nativo requiere renumerar la red.

  • Esta solución sólo se aplica al ruteo estático o BGP4+.

Escenario de tunelización

Una compañía de software pequeña (a la que se considera un entorno empresarial típico) que tiene una red IPv4 está en tratativas para fusionarse con otra compañía que ejecuta IPv6 en su red. Para evaluar el impacto sobre la conectividad que la fusión de dos compañías tendría sobre éstas, el cliente desea expandir sus conocimientos de IPv6 a través de la conexión al 6bone. Los objetivos comerciales del cliente del entorno empresarial descritos en este documento son:

  • Experiencia del IPv6 del aumento en una estructura básica establecida del IPv6 usando su topología existente del IPv4, con una inversión mínima.

  • Procedimientos de prueba transitorios y operacionales en un entorno IPv6 de mundo real antes de implementar IPv6.

    Los procesos de transición son aquellos necesarios para realizar la migración desde IPv4 a IPv6. Estos procedimientos incluyen la configuración de sistemas finales y de routers de pila dual , mecanismos de tunelización, servidores DNS (Sistema de nombres de dominio) y, en el futuro, la prueba de Traducción de dirección de red-Traducción de protocolo (NAT-PT).

    Los procedimientos operativos se relacionan con la Administración de redes, administración de elementos de los hosts de la doble pila y los sistemas extremos, y otras funciones similares.

  • Pruebe las aplicaciones y las implementaciones del IPv6 en las estaciones de trabajo local.

  • Minimice la tara de administración asociada con una conexión 6bone.

    Nota: Si bien el 6bone comprende muchos tipos de organizaciones (por ejemplo, organizaciones académicas y gubernamentales, proveedores de hardware y de software y proveedores de servicios), este documento utiliza el término ISP 6bone al hacer referencia a la organización que se encuentra en el extremo 6bone del túnel.

Configurar

El direccionamiento del IPv4 de su Router del borde es 192.168.99.1. Obtenga su prefijo 6a4 de su dirección IPv4 mediante la conversión a hexadecimal de los componentes decimales de la dirección IPv4 y luego prefije “2002” a los números hexadecimales resultantes. Entonces el prefijo 6a4 para los nodos Ipv6 en su red es 2002:C0A8:6301::/128.

La parte de C0A8:6301 el direccionamiento precedente del IPv6 es formada del direccionamiento del IPv4 convirtiendo a cada octeto del dotted decimal notation a su equivalente hexadecimal, tal y como se muestra en del cuadro 6.

Decimal Hexadecimal
192 C0
168 A8
99 63
1 01

Esta sección presenta los datos para configurar las características descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

Esta figura muestra la topología de un típico túnel 6a4 conectado a 6bone.

/image/gif/paws/45741/6bone_tc_1-02.gif

Configuraciones

Su 6bone ISP ha proveído le el direccionamiento del IPv4 de su Router del borde 6bone: 192.168.33.1. Utilice la información de la dirección anterior para configurar un túnel 6a4 en su router extremo de doble pila ingresando los siguientes comandos:

Router Enterprise
ipv6 unicast-routing

interface Ethernet0
 description connection to 6bone ISP
 ip address 192.168.99.1 255.255.255.0

interface Tunnel2002
 description 6to4 tunnel to 6bone ISP
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:6301::1/128
 tunnel source ethernet0
 tunnel mode ipv6ip 6to4


!--- In some cases, a user will require a data license 
!-- in order to issue the tunnel mode ipv6ip command.

 ipv6 route 2002::/16 Tunnel2002
 ipv6 route ::/0 2002:C0A8:2101::1

El 2002:C0A8:2101::1 en el segundo comando ipv6 route es la dirección IPv6 del router de entramado 6a4 de ISP que otorga el acceso a 6bone. Se deriva la parte C0A8:2101 de la dirección desde la dirección IPv4 (192.168.33.1) del router relé 6 a 4 de una manera similar a la de la tabla 6.

Al otro extremo del túnel, el router del borde en el ISP 6bone tendría una configuración similar al siguiente ejemplo de ruteo de unidifusión IPv6:

Router de retransmisión 6a4 ISP
ipv6 unicast-routing

interface ethernet0/0
 description connection to enterprise
 ip address 192.168.33.1 255.255.255.0

interface Tunnel2002
 description 6to4 relay service
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:2101::1/128
 tunnel source ethernet0/0
 tunnel mode ipv6ip 6to4

ipv6 route 2002::/16 tunnel2002

Router 6bon2-gw para empresas
maui-soho-01# show running-config 
 Building configuration...
 .
 .
 .
 username maui-nas-05 password cisco

 ! Identify the version of Cisco IOS software running on the router
!
version 12.2
!
! Include timestamps on log and debug entries that are useful for
! troubleshooting and optimizing the network.
!
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
!
! Specify that passwords will be encrypted in configuration output.
!
service password-encryption
!
! Configure the router name
!
hostname 6bone-gw
!
! Configure boot options
!
boot system flash slot0:
boot system flash bootflash:
!
! Configure logging
!logging buffered 10000 debugging
!
! Configure secret password
!
enable secret 5 [removed]
!
! Configure clock timezone and summertime rule
!
clock timezone PST -8
clock summer-time PDT recurring
!
!
ip subnet-zero
no ip source-route
no ip rcmd domain-lookup
!
! Configure router domain name
!
ip domain-name EnterpriseDomain.com
!
! Configure DNS name servers
!
ip name-server 192.168.1.10
ip name-server 192.168.2.21
ip name-server 2002:C0A8:6301:1::21
!
! Enable IPv6 routing
!
ipv6 unicast-routing
!
! Configure Tunnel interface
!
interface Tunnel2002
 description 6to4 tunnel to 6bone ISP
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:6301::1/128
 tunnel source ethernet0
 tunnel mode ipv6ip 6to4
!
! Configure physical interface
!
interface Ethernet0
 description connection to 6bone ISP
 ip address 192.168.99.1 255.255.255.0
!
interface Ethernet1
 description connection to Lab interface router
 ip address 192.168.99.40 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:100::1/64
 ipv6 rip v6rip enable
!
interface FastEthernet2/0
 description connection to core router
 ip address 192.168.99.41 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:200::1/64
 ipv6 rip v6rip enable
!
interface FastEthernet3/0
 description connection to IPv4-only core router
 ip address 192.168.99.42 255.255.255.0
!
! Other interfaces are all unused
!

interface Serial4/0
 no ip address
 shutdown
!
interface Serial4/1
 no ip address
 shutdown
!
interface Serial4/2
 no ip address
 shutdown
!
interface Serial4/3
 no ip address
 shutdown
!
! Configure basic IP routing
!
ip default-gateway 192.168.33.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.33.1
!
! Configure IPv6 static route
!
ipv6 route 2002::/16 tunnel2002
ipv6 route ::/0 2002:C0A8:2101::1
ipv6 router rip v6rip
!
end
 end

Router ISP IPv6 6bone
maui-soho-01# show running-config 
 Building configuration...
 .
 .
 .
 username maui-nas-05 password cisco

 ! Identify the version of Cisco IOS software running on the router
!
version 12.2
!
! Include timestamps on log and debug entries that are useful for
! troubleshooting and optimizing the network.
!
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
!
! Specify that passwords will be encrypted in configuration output.
!
service password-encryption
!
! Configure the router name
!
hostname ipv6-router
!
! Configure boot options
!
boot system flash slot0:
boot system flash bootflash:
!
! Configure logging
!
logging buffered 10000 debugging
!
! Configure secret password
!
enable secret 5 [removed]
!
! Configure clock timezone and summertime rule
!
clock timezone PST -8
clock summer-time PDT recurring
!
!
ip subnet-zero
no ip source-route
no ip rcmd domain-lookup
!
! Configure router's domain name
!
ip domain-name 6boneISP.com
!
! Configure DNS name servers
!
ip name-server 192.168.33.4
ip name-server 192.168.33.5
ip name-server 3FFE:FFFF:8001::4
!
! Enable IPv6 routing
!
ipv6 unicast-routing
!
! Configure Tunnel interface
!
interface Tunnel2002
 description 6to4 relay service
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:2101::1/128
 tunnel source ethernet0/0
 tunnel mode ipv6ip 6to4
!
! Configure physical interface
!
interface Ethernet0/0
 description connection to enterprise
 ip address 192.168.33.1 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface FastEthernet1/0
 description connection to ISP-core-A
 ip address 192.168.34.10 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:2::6/64
 duplex auto
 speed auto
!
interface FastEthernet2/0
 description connection to ISP-core-B
 ip address 192.168.35.22 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:2::8/64
 duplex auto
 speed auto
!
! Other interfaces are all unused
!

interface Serial4/0
 no ip address
 shutdown
!
interface Serial4/1
 no ip address
 shutdown
!
interface Serial4/2
 no ip address
 shutdown
!
interface Serial4/3
 no ip address
 shutdown
!
! Configure basic IP routing
!
ip default-gateway 192.168.30.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.30.1
!
! Configure IPv6 static route
!
ipv6 route 2002::/16 tunnel2002
!
end

Verificación

Esta tarea optativa explica cómo confirmar que el túnel está configurado y funcionando correctamente. Los comandos contenidos en los pasos de la tarea se pueden utilizar en cualquier secuencia y podrían repetirse

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

  • permiso

  • show interfaces tunnel number [contabilidad]

  • destino del [protocol] del ping

  • show ip route [address [mask

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 45741