Switches : Switches Cisco Catalyst de la serie 3750

Configurar el Routing entre VLAN con los Catalyst 3750 Series Switch

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona un ejemplo de configuración para el ruteo VLAN utilizando dos switches Catalyst de la serie 3750 apilados ejecutando el software EMI en un escenario de red típico. El documento utiliza un switch Catalyst de la serie 2950 y un switch Catalyst de la serie 2948G como switches de armario de Capa 2 (L2) que se conectan a la pila de Catalyst 3750. El stack de los Catalyst 3750 también se configura para un trayecto predeterminado para todo el tráfico que va a Internet con el salto siguiente señalando a un router Cisco 7200VXR, que puede ser sustituido por un firewall u otros routers. Configurar el ruteo inter VLAN en un único 3750 es lo mismo que configurar esta función en un switch Catalyst 3550 Series. Para obtener información sobre cómo configurar el ruteo inter VLAN en un único switch Catalyst 3750 Series, consulte Configuración del ruteo inter VLAN con switches Catalyst 3550 Series.

Antes de comenzar

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

prerrequisitos

Antes de utilizar esta configuración, asegúrese de que cumple con los siguientes requisitos previos:

Componentes Utilizados

La información que contiene este documento se basa en las versiones de software y hardware indicadas a continuación.

  • Dos switches Catalyst 3750G-24T con la versión 12.1(14)EA1 EMI apilados.

  • Catalyst 2950G-48 que ejecuta la versión de software 12.1(12c)EA1 EI

  • Catalyst 2948G que ejecuta la versión de software 6.3(10)

Nota: La configuración desde el router Cisco 7200VXR no es relevante y por lo tanto, no se muestra en este documento.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Teoría Precedente

En una red conmutada, las VLAN separan a los dispositivos en diferentes dominios de colisión y subredes de Capa 3 (L3). Los dispositivos dentro de una VLAN pueden comunicarse entre sí sin necesidad de ruteo. Por el contrario, los dispositivos en las VLAN separadas requieren un dispositivo de ruteo para que se comuniquen entre ellos.

Los switches de L2 solamente requieren un dispositivo de ruteo L3 (ya sea uno externo al switch o en otro módulo en el mismo chasis). Una nueva raza del Switches, sin embargo, (por ejemplo, 3550 y 3750) capacidad de ruteo incorporada dentro del Switch. El switch recibe un paquete, determina si pertenece a otra VLAN y envía el paquete al puerto que corresponde en la otra VLAN.

Un diseño de red típico segmenta la red según el grupo o la función a la que corresponde el dispositivo. Por ejemplo, la VLAN del departamento de ingeniería sólo tendrá dispositivos asociados con el departamento de ingeniería, mientras que el de finanzas la VLAN sólo tendrá dispositivos relacionados con finanzas. Si el ruteo está habilitado, los dispositivos de cada VLAN pueden comunicarse entre ellos sin necesidad de que estén todos en el mismo dominio de transmisión. Este diseño de VLAN además cuenta con el beneficio adicional de permitir al administrador restringir la comunicación entre las VLAN utilizando listas de acceso. En el ejemplo, se podría limitar la ingeniería VLAN (usando access-lists) a los dispositivos de acceso del financiamiento de VLAN.

Routing IP en una pila de 3750

En una pila de switches Catalyst 3750, el software que se ejecuta en la unidad principal determina las capacidades de toda la pila. Si el switch maestro está funcionando con una imagen EMI, el stack del conjunto soportará al Conjunto completo de Routing Protocol soportados (tales como Open Shortest Path First (OSPF), Enhanced Interior Gateway Routing Protocol (EIGRP), y tal) incluso si los otros miembros de pila apenas están funcionando con una imagen SMI. Sin embargo, se recomienda ejecutar el mismo software en los diferentes miembros de la pila. En caso de que el maestro de pila falle, podría perder las capacidades de ruteo extendidas si los otros miembros ejecutan una imagen SMI, a diferencia de la imagen EMI del maestro anterior.

Una pila de switches Catalyst 3750 se le muestra a la red como un solo router, independientemente de a cuál de los stack switches esté conectado el par de ruteo. Un router creará una sola adyacencia con un stack de los 3750 Router.

El maestro de pila lleva a cabo las siguientes tareas:

  • Inicialización y configuración de los Routing Protocol

  • Generación de mensajes del Routing Protocol

  • Procesamiento de los mensajes de protocolo de ruteo recibidos.

  • Generación y distribución de la base de datos de Distributed Cisco Express Forwarding (dCEF) para los distintos miembros de pila.

  • La dirección MAC del maestro se usa como MAC de origen de los paquetes enrutados.

  • Los paquetes que necesitan conmutación de procesos son administrados por la CPU del maestro.

Los miembros de la pila realizan las siguientes tareas:

  • Estos actúan como switches de ruteo en espera que pueden tomar el control cuando la pila primaria falla.

  • Programación de las rutas en la base de datos dCEF en hardware

Cuando el switch maestro falla, los switches miembros de pila continuarán (luego de una interrupción momentánea) reenviando los paquetes en hardware mientras no hay protocolos activos.

Después de que hayan seleccionado a un nuevo master después de un error principal, el master nuevamente elegido comenzará a enviar los ARP gratuitos con su propia dirección MAC para poner al día los dispositivos en la red con la nueva dirección MAC que será utilizada para reescribir los paquetes ruteados.

Para más información acerca de la configuración y el comportamiento de la pila del switch 3750, consulte la documentación sobre Administración de pilas de switches.

Productos Relacionados

Esta configuración también puede ser usada con las siguientes versiones de hardware y software.

  • Cualquier switch Catalyst 3750 que ejecute la versión 12.1(14) EA1 y posteriores de el software EMI o SMI.

  • Switches Catalyst 2900XL/3500XL/2950/3550 o Catalyst OS para switch de capa de acceso

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/45002/intervlan3750_45002a.gif

El diagrama antedicho muestra una pequeña red de muestra con el stack del Catalyst 3750s que proporciona al Routing entre VLAN entre los diversos segmentos.

A continuación se encuentran las tres VLAN definidas por el usuario:

  • VLAN 2 – VLAN de usuario

  • VLAN 3 - VLAN servidor

  • VLAN 10 - VLAN de administración

El default gateway configurado en cada servidor y dispositivo host debe ser la dirección IP de la interfaz VLAN correspondiente en el stack de 3750s. Por ejemplo, en el caso de los servidores, el gateway predeterminado es 10.1.3.1. Catalyst 2950 tiene conexión de troncal con el switch Catalyst 3750 superior (maestro de pila) y Catalyst 2848G conexión de troncal con el switch Catalyst 3750 inferior (miembro de pila).

La ruta predeterminada para la pila apunta hacia el router Cisco 7200VXR. La pila de los 3550 utiliza este router predeterminado para rutear el tráfico destinado para Internet. Por lo tanto, el tráfico para las cuales el 3750s no tiene una entrada de la tabla de ruteo se envía al 7200VXR para procesar.

Consejos Prácticos

  • En este diagrama, la VLAN de administración está separada de la VLAN del usuario o del servidor. Esta VLAN es distinta a la VLAN del usuario o del servidor. Esto se realiza para evitar que la administración de switches se vea afectada por tormentas de difusión/paquetes potenciales en la VLAN del usuario o del servidor.

  • VLAN 1 no se utiliza para administración. Todos los puertos en los switches de Catalyst omiten el VLAN1, y cualquier dispositivo conectado con los puertos NON-configurados estará en el VLAN1. Esto puede causar los problemas potenciales para la Administración del Switches, según lo explicado arriba.

  • Un puerto de capa 3 se utiliza para conectarse al puerto predeterminado del gateway. En este diagrama, un router Cisco 7200VXR podría reemplazarse con facilidad por un firewall que se conecte al router de gateway de Internet.

  • Un protocolo de ruteo no se ejecuta entre la pila de los Catalyst 3750 y el router de gateway de Internet. En lugar, una Static Default ruta se configura en los 3750. Se prefiere esta configuración si hay solamente una ruta a Internet. Asegúrese de configurar las rutas estáticas (preferentemente resumidas) en el router gateway (7200VXR) para subredes que pueden ser alcanzadas por los Catalyst 3750. Este paso es muy importante ya que los protocolos de ruteo no se están usando.

  • Si necesita ancho de banda adicional para los puertos de enlace ascendente, puede configurar EtherChannel. La configuración de EtherChannel también proporciona redundancia de link en el caso de falla del link.

Configuraciones

Este documento usa las configuraciones detalladas a continuación.

Como puede observarse a continuación, a pesar de que hay dos switches Catalyst 3750 agrupados juntos, estos se encuentran configurados como si tuvieran un solo switch. Ambos switches tienen veinticuatro interfaces 10/100/1000 y en la configuración se muestran como Ethernet gigabit 1/0/1 a 1/0/24 para el primer switch y gigabit 2/0/1 a 2/0/24 para el segundo. Por lo tanto, al observar la configuración, parece que existe un solo switch con dos módulos de 24 puertos cada uno.

Ampliando este ejercicio a 3, 4, 5, y así sucesivamente, Switches en un stack aparecerían similares, pero para cada Switch que se agregue al stack, aparece en la configuración como si un módulo se agregue al Switch.

Cat3750 (Cisco Catalyst 3750G-24T)
C3750G-24T#show run 
Building configuration... 
Current configuration : 2744 bytes 
! 
version 12.1 
no service pad 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname C3750G-24T 
! 
! 
ip subnet-zero 
ip routing 
! 
no ip domain-lookup 
! 
spanning-tree mode pvst 
no spanning-tree optimize bpdu transmission 
spanning-tree extend system-id 
! 
! 
! 
interface GigabitEthernet1/0/1 
 description To 2950 
 switchport trunk encapsulation dot1q 
! 

!--- Dot1q trunking (with negotiation) is configured on the L2 switch. 
!--- If DTP is not supported on the far switch, issue the  
!--- switchport mode trunk command  
!--- to force the switch port to trunk mode.


!--- Note: The default trunking mode is dynamic auto. If a trunk link 
!--- is established using default trunking mode, it does not appear
!--- in the configuration even though a trunk has been established on 
!--- the interface. Use the show interfaces trunk command to verify the 
!--- trunk has been established.

! 
interface GigabitEthernet1/0/2 
!

!--- Output suppressed.

! 
interface GigabitEthernet1/0/5 
 description to SERVER_1 

!--- Configure the server port to be in the server VLAN (VLAN 3).
 
 switchport access vlan 3 

!--- Configure the port to be an access port to  
!--- prevent trunk negotiation delays.

 switchport mode access 

!--- Configure port-fast for initial STP delay.  
!--- Refer to Using PortFast and Other Commands to Fix Workstation
!--- Startup Connectivity Delays for more information.
 
spanning-tree portfast 
! 
interface GigabitEthernet1/0/6 
! 

!--- Output suppressed.
 
!  
interface GigabitEthernet1/0/10 
 description To Internet_Router 

!--- Port connected to router is converted into a routed (L3) port.
 
 no switchport 

!--- IP address is configured on this port.
  
 ip address 200.1.1.1 255.255.255.252 
! 
interface GigabitEthernet1/0/21 
! 

!--- Output suppressed.
 
! 
interface GigabitEthernet1/0/22 
! 
interface GigabitEthernet1/0/23 
! 
interface GigabitEthernet1/0/24 
! 
interface GigabitEthernet2/0/1 
 description To 2948G 
 switchport trunk encapsulation dot1q 
! 

!--- Output suppressed.

! 
interface GigabitEthernet2/0/23 
! 
interface GigabitEthernet2/0/24 
! 
interface Vlan1 
 no ip address 
 shutdown 
! 
interface Vlan2 
 description USER_VLAN 

!--- This IP address would be the default gateway for users.
 
 ip address 10.1.2.1 255.255.255.0 
! 
interface Vlan3 
 description SERVER_VLAN 

!--- This IP address would be the default gateway for servers.

 ip address 10.1.3.1 255.255.255.0 
!  
interface Vlan10 
 description MANAGEMENT_VLAN 

!--- This IP address would be the default gateway for other L2 switches
 
 ip address 10.1.10.1 255.255.255.0 
!  
ip classless 

!--- This route statement will allow the 3550 to send Internet traffic to  
!--- its default router (in this case, 7200VXR Fe 0/0 interface).
   

ip route 0.0.0.0 0.0.0.0 200.1.1.2 
ip http server 
!  
!  
line con 0 
 exec-timeout 0 0 
line vty 0 4 
 exec-timeout 0 0 
 login  
line vty 5 15 
 login  
!  
end  

C3750G-24T# 

Nota: Puesto que los 3750 se configura como servidor del VLAN Trunk Protocol (VTP), la configuración VTP no es visualizada por el Switch. Esto es normal. Los siguientes comandos se utilizan en este switch para crear un servidor VTP con tres VLAN definidas por el usuario desde el modo de configuración global.

C3750G-24T(config)#vtp domain cisco
C3750G-24T(config)#vtp mode server
C3750G-24T(config)#vlan 2
C3750G-24T(config-vlan)#name USER_VLAN
C3750G-24T(config-vlan)#exit
C3750G-24T(config)#vlan 3
C3750G-24T(config-vlan)#name SERVER_VLAN
C3750G-24T(config-vlan)#exit
C3750G-24T(config)#vlan 10
C3750G-24T(config-vlan)#name MANAGEMENT
Cat2950 (Cisco Catalyst 2950G-48 Switch)
Cat2950#show running-config 
Building configuration...

Current configuration : 2883 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat2950
!
!
ip subnet-zero
!
spanning-tree extend system-id
!
!
interface FastEthernet0/1
 no ip address
!

!--- Output suppressed.

interface FastEthernet0/16
 no ip address
!
interface FastEthernet0/17
 description SERVER_2
 switchport access vlan 3
 switchport mode access
 no ip address
 spanning-tree portfast
!

!--- Output suppressed.

!
interface FastEthernet0/33
 description HOST_1

!--- Host_1 is configured to be the user VLAN (VLAN 2).

 switchport access vlan 2
 switchport mode access
 no ip address
 spanning-tree portfast
!

!--- Output suppressed.

interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 no ip address
!
interface GigabitEthernet0/2
 no ip address
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan10
 description MANAGEMENT

!--- IP address used to manage this switch.
 
ip address 10.1.10.2 255.255.255.0
 no ip route-cache
!

!--- Default gateway is configured so that the switch is reachable
!--- from other VLANs/sub-nets. Gateway points to VLAN 10 interface 
!--- on the 3750.

ip default-gateway 10.1.10.1
ip http server
!
!
line con 0
line vty 5 15
!
end

Nota: Dado que Catalyst 2950 está configurado como cliente VTP, la configuración VTP no se muestra en el switch. Esto es normal. La 2950 adquiere la información de VLAN del servidor VTP (3750). Los comandos que aparecen a continuación se utilizan en este switch para transformarlo en un cliente VTP en el cisco de dominio VTP desde el modo de configuración global.

Cat2950(config)#vtp domain cisco
Cat2950(config)#vtp mode client
Cat2948G (Cisco Catalyst 2948G Switch)
Cat2948G> (enable) show config 

!--- This command shows non-default configurations only.
!--- Use the show config all command to show both 
!--- default and non-default configurations.


...........

..................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Fri Jun 30 1995, 05:04:47 
!
#version 6.3(10)
!
!
#system web interface version(s)
!
#test
!
#system
set system name  Cat2948G
!       
#frame distribution method
set port channel all distribution mac both
!
#vtp

!--- VTP domain is configured to be that same as the 3550 (VTP server).

set vtp domain cisco

!--- VTP mode is chosen as client for this switch.

set vtp mode client
!
#ip

!--- The management IP address is configured in VLAN 10.

set interface sc0 10 10.1.10.3/255.255.255.0 10.1.10.255

set interface sl0 down
set interface me1 down

!--- The default route is defined so that the switch is reachable.

set ip route 0.0.0.0/0.0.0.0         10.1.10.1      
!
#set boot command
set boot config-register 0x2
set boot system flash bootflash:cat4000.6-3-10.bin
!
#module 1 : 0-port Switching Supervisor
!
#module 2 : 50-port 10/100/1000 Ethernet

!--- Host_2 and SERVER_3 ports are configured in respective VLANs.

set vlan 2    2/2
set vlan 3    2/23
set port name       2/2  To HOST_2
set port name       2/23 to SERVER_3

!--- Trunk is configured to 3750 with dot1q encapsulation.

set trunk 2/49 desirable dot1q 1-1005
end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Catalyst 3750

  • Switch de la demostración - El comando show switch dice lo que consiste en el stack y cuál de los miembros de pila es el master.

    C3750G-24T#show switch
                                                   Current
            Switch#  Role      Mac Address     Priority     State 
            --------------------------------------------------------
            *1       Master    000c.30ae.6280     15        Ready               
             2       Slave     000c.30ae.2a80     1         Ready
  • show vtp status

    C3750G-24T#show vtp status 
    VTP Version                     : 2
    Configuration Revision          : 3
    Maximum VLANs supported locally : 1005
    Number of existing VLANs        : 8
    VTP Operating Mode              : Server
    VTP Domain Name                 : cisco
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0xA2 0xF4 0x9D 0xE9 0xE9 0x1A 0xE3 0x77 
    Configuration last modified by 200.1.1.1 at 3-1-93 03:15:42
    Local updater ID is 10.1.2.1 on interface Vl2 (lowest numbered VLAN interface found)
    C3750G-24T#
  • show interfaces trunk

    C3750G-24T#show interfaces trunk 
    
    Port      Mode         Encapsulation  Status        Native vlan
    Gi1/0/1     desirable    802.1q         trunking      1
    Gi2/0/1     desirable    802.1q         trunking      1
    
    Port      Vlans allowed on trunk
    Gi1/0/1     1-4094
    Gi2/0/1     1-4094
    
    Port      Vlans allowed and active in management domain
    Gi1/0/1     1-3,10
    Gi2/0/1     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    
    Gi1/0/1     1-3,10
    Gi2/0/1     1-3,10
    
  • show ip route

    C3750G-24T#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is 200.1.1.2 to network 0.0.0.0
    
         200.1.1.0/30 is subnetted, 1 subnets
    C       200.1.1.0 is directly connected, GigabitEthernet1/0/10
         10.0.0.0/24 is subnetted, 3 subnets
    C       10.1.10.0 is directly connected, Vlan10
    C       10.1.3.0 is directly connected, Vlan3
    C       10.1.2.0 is directly connected, Vlan2
    S*   0.0.0.0/0 [1/0] via 200.1.1.2
    

Catalyst 2950

  • show vtp status

    Cat2950#show vtp status 
    VTP Version                     : 2
    Configuration Revision          : 3
    Maximum VLANs supported locally : 250
    Number of existing VLANs        : 8
    VTP Operating Mode              : Client
    VTP Domain Name                 : cisco
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x54 0xC0 0x4A 0xCE 0x47 0x25 0x0B 0x49 
    Configuration last modified by 200.1.1.1 at 3-1-93 01:06:24
    
  • show interfaces trunk

    Cat2950#show interfaces trunk 
    
    Port      Mode         Encapsulation  Status        Native vlan
    Gi0/1     desirable    802.1q         trunking      1
    
    Port      Vlans allowed on trunk
    Gi0/1     1-4094
    
    Port      Vlans allowed and active in management domain
    Gi0/1     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    Gi0/1     1-3,10
    

Catalyst 2948G

  • show vtp domain

    Cat2948G> (enable) show vtp domain 
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
    cisco                            1            2           client      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    8          1023             3               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    200.1.1.1       disabled disabled 2-1000
  • show trunk

    Cat2948G> (enable) show trunk 
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     2/49     desirable    dot1q          trunking      1
    
    Port      Vlans allowed on trunk
    --------  ---------------------------------------------------------------------
     2/49     1-1005
    
    Port      Vlans allowed and active in management domain 
    --------  ---------------------------------------------------------------------
     2/49     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     2/49     1-3,10
    

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Procedimiento de Troubleshooting

Siga estas instrucciones para resolver problemas de su configuración.

  1. Si usted no puede hacer ping los dispositivos dentro del mismo VLA N, usted debe marcar la asignación VLAN de los puertos de origen y de destino publicando el comando show port mod/port para CatOS y el comando show interface status para el software del ½ del ¿Â de Cisco IOSïÂ, de aseegurarse los están en el mismo VLA N. Si no se encuentran en el mismo router, asegúrese de que el enlace troncal esté configurado correctamente mediante el comando show trunk para CatOS y el comando show interfaces trunk para el software IOS de Cisco y que la VLAN nativa coincida en ambos lados. Asegúrese de que la máscara de subred concuerde entre los dispositivos de origen y de destino.

  2. Si no puede hacer ping a los dispositivos en diferentes redes VLAN, asegúrese de que puede hacer ping a la respectiva gateway predeterminada (consulte el paso 1 anterior). También, asegúrese de que la gateway predeterminada del dispositivo esté apuntando a la dirección de IP de la interfaz VLAN correcta y de que la máscara de subred concuerde.

  3. Si puede alcanzar Internet, asegúrese de que la ruta predeterminada en los puntos 3750 a la dirección IP correcta y que la dirección de subred coincidan con el router gateway de Internet. Para ello, ejecute los comandos show ip interface interface-id y show ip route. Asegúrese de que el router de gateway de Internet tenga rutas a Internet y a las redes internas.


Información Relacionada


Document ID: 45002