IP : Open Shortest Path First (OSPF)

Diseño de las redes de marcado del proveedor de servicio del gran escala con el OSPF

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Para diseñar una red de marcado es una tarea difícil para los Proveedores de servicios de Internet (ISP). Cada ISP utiliza un método único para diseñar las redes de marcado. Sin embargo, todos los ISP comparten las mismas áreas de importancia cuando diseñan las redes de marcado, según lo enumerado aquí:

  • ¿Cómo se deben las rutas del pool propagar en la base ISP?

  • ¿Qué Routing Protocol se debe utilizar para llevar esas rutas en la base?

  • ¿Deben esas rutas de marcado manual ser resumidas antes de enviar en la base?

  • ¿Qué debe ser tenida en cuenta cuando distribuyen los pools?

  • ¿Qué sucede si los agrupamientos son estáticos?

Este documento trata la mayoría de las preguntas anteriores y explica las prácticas de diseño del uso del Primer trayecto más corto abierto (OSPF) del Protocolo de gateway interior (IGP) en un entorno de marcado ISP. OSPF se utiliza con frecuencia en la red central de ISP. En este documento, evitamos introducir un protocolo separado para llevar las rutas del pool del dial — utilizamos el OSPF para propagar las rutas del pool del dial en la base.

Topología de red

La topología mostrada aquí es una topología de red de marcado típica ISP. Los ISP que brindan servicio de acceso telefónico suelen tener una serie de Servidores de acceso de red (NAS) que por lo común son AS5300 o AS5800. Los servidores son responsables de la disposición de la dirección IP a todos los usuarios que marquen en el ISP y quieran utilizar los servicios de Internet. Los servidores NAS entonces están conectados con un dispositivo de agrupamiento, que es típicamente un Cisco 6500 Router. El router 6500 distribuye las rutas de marcado manual en el núcleo y esto le permite a los routers del núcleo otorgar servicios de Internet a los usuarios finales. El cuadro 1 muestra un escenario típico del Point of Presence (POP).

Cuadro 1 – Un escenario POP típico

ispdial.jpg

Conjuntos de marcación manual de ISP

Un ISP se ocupa típicamente de dos tipos de IP Addresses del pool:

  • Estática

  • Central

Agrupación estática

Con los pools estáticos, los ISP tienen un conjunto específico de los IP Addresses dedicado a cada servidor NAS. Un usuario que encuentra un NAS recibe uno de los IP Addresses dedicados del pool. Por ejemplo, si el rango de dirección del agrupamiento estático NAS1 es 192.168.0.0/22, hay aproximadamente 1023 IP Addresses. Un usuario que encuentra el NAS1 recibe uno de los direccionamientos en el rango de 192.168.0.0 a 192.168.3.254.

Agrupación central

Con agrupaciones centrales, los ISP poseen un mayor alcance de direcciones IP distribuidas a través de todos los NAS en un solo POP. Un usuario que encuentra un NAS recibe una dirección IP del pool central, que es rango muy grande. Por ejemplo, si el rango de direcciones de agrupamiento central es 192.168.0.0/18 y están distribuidas entre servidores 14 NAS, hay aproximadamente 14000 direcciones IP.

Diseño de marcado manual con un pool estático

Es más fácil administrar los agrupamientos estáticos desde el punto de vista del ruteo. Cuando un pool estático se define en un NAS, el pool necesita ser propagado a la base para los propósitos de ruteo.

Utilice estos métodos para propagar las rutas de marcado manual de un NAS:

  • Cree una Static ruta al alcance del IP Address del pool, señalando al null0, con la dirección del agrupamiento redistribuida en el NAS.

  • Asigne la dirección IP del pool en un loopback, en el NAS con el tipo de red punto a punto OSPF, incluyendo el loopback en una área OSPF.

  • Configure una Static ruta en un router del borde del área (ABR) para la dirección IP del pool que apunta en la dirección del Autonomous System Boundary Router NAS (ASBR) — esto es un método preferido porque el resumen se puede realizar en el ABR.

Cree una Static ruta al rango de dirección del agrupamiento que señala al null0

Si usted utiliza este método, una Static ruta se debe crear para cada NAS. Esa Static ruta debe cubrir el direccionamiento estático exacto del rango del pool que señala al null0. por ejemplo, si la dirección del agrupamiento estática es 192.168.0.0/22, la configuración de la Static ruta en el NAS es:

NAS1(config)# ip route 192.168.0.0 255.255.252.0 null0
NAS1(config)# router ospf 1
NAS1(config-router)# redistribute static subnets
NAS1(config-router)# end

Redistribuyen a la dirección del agrupamiento en el OSPF, que propaga esta información en la base en la forma del tipo 5 aviso del estado de los links externo (LSA).

Asigne a la dirección del agrupamiento en un loopback en un NAS con el tipo de red punto a punto OSPF

Si utiliza este método, no se necesitan rutas estáticas. En una interfaz de loopback, se asigna la dirección de agrupamiento como una subred. El tipo de red predeterminada en el Loopback Interface es el LOOPBACK, que, según el RFC 2328leavingcisco.com se debe hacer publicidad en el OSPF como /32 — esta es la razón por la cual usted debe cambiar el tipo de red en el loopback al Punto a punto. El tipo de red punto a punto fuerza el OSPF para hacer publicidad de la dirección de subred del loopback, que en este caso es 192.168.0.0/22. Esta es la configuración:

NAS1(config)# interface loopback 1
NAS1(config-if)# ip addreess 192.168.0.1 255.255.252.0
NAS1(config-if)# ip ospf network-type point-to-point
NAS1(config-if)# router ospf 1
NAS1(config-router)# network 192.168.0.0 0.0.3.255 area 1
NAS1(config-router)# end

Esta configuración establece las relaciones del stub del router en el LSA de router y se propaga como ruta OSPF interna bastante que una OSPF ruta externa.

Configure la Static ruta en el ABR para la dirección del agrupamiento, señalando al NAS (el ASBR)

Si utiliza este método, no necesita ejecutar ninguna configuración en el NAS. Toda la configuración ocurre en el ABR o dispositivo de agrupamiento. Las agrupaciones de direcciones son estáticas. Por lo tanto, la Static ruta se genera fácilmente y el router puede señalar el salto siguiente hacia el NAS respectivo, el Autonomous System Boundary Router (ASBR). Las rutas estáticas deben ser redistribuidas en OSPF a través de las subredes estáticas de redistribución de OSPF. Por ejemplo:

ABR(config)# ip route 192.168.0.0 255.255.252.0 <next-hop ip address (NAS1)>
ABR(config)# ip route 192.168.4.0 255.255.252.0 <next-hop ip address (NAS2)>

! --- and so on for the remaining 12 NAS boxes.

ABR(config)# router ospf 1
ABR(config-router)# redistribute static subnets
ABR(config-router)# end

Éste es el método preferido porque el resumen puede ser llevado cabo en la ARB. El resumen puede también ocurrir en los primeros dos métodos, pero las configuraciones de resumen son necesarias en cada NAS con respecto a este método, donde está necesaria una configuración de resumen solamente en este router.

Si los pools estáticos están en el bloque contiguo, el resumen se puede realizar en el ABR porque todas las Static rutas están en el ABR. Por ejemplo:

ABR(config)# router ospf 1
ABR(config-router)# summary-address 192.168.0.0 255.255.192.0
ABR(config-router)# end

Diseño de marcado manual con IP dinámica la asignación de una agrupación de direcciones central

Para este diseño de marcado manual, asuma que el pool central de la dirección IP está configurado en el servidor del Remote Authentication Dial-In User Service (RADIUS). Cada POP tiene un número de Servicio de información del número marcado (DNIS) y el servidor RADIUS tiene agrupaciones de direcciones IP separadas para cada DNIS. Además, todos los NAS que terminan las llamadas para un DNIS están en la misma área y hablan con el mismo router de agrupamiento.

Los pools centrales de la dirección IP traen una cierta complejidad en el diseño del Routing Protocol. Cuando usted marca un número DNIS para un POP, no hay garantía sobre el NAS con el cual usted conecta y la dirección IP que le será asignada del pool central de la dirección IP para ese DNIS. Como consecuencia, el resumen en cada NAS es imposible para los direccionamientos asignados el pool de los DNIS. La subred conectada redistribuida es necesaria en cada NAS así que puede propagar toda la información al ABR o al dispositivo de agrupamiento. ¿Allí está un problema con este diseño — porque el LSA externo se puede resumir solamente en el ASBR y en este diseño, los ASBR son los servidores NAS, cómo el ABR realizarán el resumen para las rutas externo que vienen de los NAS?

Para resolver esta problema de diseño, Cisco recomienda que el área a la cual los servidores NAS pertenecen esté configurada en un Not So Stubby Area (NSSA) (véase el cuadro 2):

Cuadro 2 – Configuración en un Not So Stubby Area

/image/gif/paws/44944/ispdial2.jpg

Para obtener más información acerca de OSPF NSSA, consulte Área Not-So-Stubby de OSPF (NSSA).

Aquí están las ventajas si usted define un área como NSSA:

  • Todas las rutas NAS se sintetizan en la ABR porque ABR regenera/traduce LSA tipo 7 en LSA tipo 5.

  • Cada POP no transportará rutas que pertenezcan a otro POP debido a que NSSA no permite los LSA externos.

La configuración de redistribuido, las subredes conectadas es necesaria en todos los NAS porque los pools de la dirección IP a través de todos los NAS no son estáticos — cualquier NAS puede llevar cualquier dirección IP dentro de ese alcance del IP Address central.

NAS1(config)# router ospf 1
NAS1(config-router)# redistribute connected subnets
NAS1(config-router)# end

Si usted realiza esta configuración en todos los NAS, una configuración de resumen se realiza en el ABR porque regeneran en el ABR y se traducen a todo el tipo 7s LSA al tipo 5s LSA. Porque el ABR genera totalmente un nuevo tipo 5 LSA y el router de anuncio ID es el ID del router ABR, el ABR actúa como el ASBR y permite el resumen de las rutas que eran previamente el tipo 7s LSA (originado por los NAS).

ABR(config)# router ospf 1
ABR(config-router)# summary-address 192.168.0.0 255.255.192.0
ABR(config-router)# end

Note que el área entre el ABR y el NAS es el NSSA, que puede ser configurado como sigue:

ABR(config)# router ospf 1
ABR(config-router)# network 10.10.10.0 0.0.0.255 area 1 nssa
ABR(config-router)# end

Problema de ampliación de área

¿Si usted tiene muchos servidores NAS en una área, y cada NAS redistribuye 1000 o más rutas en el área, la pregunta se presenta — cuántos servidores NAS debe la cada área comprender? Si todos los servidores NAS están en la misma área, el área puede llegar a ser inestable porque el área necesita llevar 1000 o más rutas de todos los servidores NAS. En este ejemplo de 14 servidores NAS, puede potencialmente redistribuir 14000 rutas, que es una gran cantidad. Para traer más scalability al área, Cisco recomienda que usted divide el área en varias subáreas, para asegurarse de que la cada área no afecta a otras áreas si una cierta inestabilidad ocurre en una área (véase el cuadro 3):

Cuadro 3 – Divida el área

ispdial3.jpg

Para determinar el número de servidores NAS para mantener una área, usted debe comprobar el número de rutas que cada NAS inyecta. Tres servidores NAS en una área pueden ser bastantes si cada NAS inyecta 3000 o más las rutas. No ponga a demasiado pocos servidores NAS en la cada área porque, si usted tiene demasiadas áreas, el ABR puede vencer sobrecargado a la creación de las recapitulaciones en la cada área. Sin embargo, usted puede resolver este problema si usted hace todas las áreas NSSA totalmente rechoncho, que no permite la redistribución de ninguna rutas de resumen en el área. Esta acción reduce la cantidad de información que cada NAS lleva además de sus propios 1000 o más rutas, y reduce la cantidad de carga el ABR lleva con la redistribución de los LSA de resúmenes en la cada área. Agregue la palabra clave del ninguno-resumen en el ABR para realizar la configuración, como se muestra aquí:

ABR#(config)# router ospf 1
ABR#(config-router)# network 10.10.10.0 0.0.0.255 area 1 nssa no-summary
ABR#(config-router)# end

El link entre los servidores ABR y NAS no necesita emigrar a cada área por lo que el servidor ABR tampoco necesita crear resúmenes dentro de cada área para estas rutas conectadas. La ventaja principal de NSSA es que todos las 3000 o más rutas en un área no se fugan hacia otras áreas ya que NSSA no transporta LSA externas. Cuando ABR traslada todos los tipos 7 de NSSA LSA al área 0, no envía ningún tipo 5 de LSA a otras áreas debido a las características de NSSA.

Conclusión

El diseño de la red de marcado ISP puede ser una tarea difícil, pero con algunas consideraciones puede ser mejorado y proporcionar una más solución escalable. La incorporación de NSSA puede resultar eficaz para la administración de escalabilidad ya que permite una reducción significativa de la cantidad de rutas que cada NAS debe transportar cuando se compara con una situación en la que no se utiliza NSSA. El resumen también ayuda a reducir el tamaño de la tabla de ruteo, especialmente en el caso del agrupamiento de dirección IP central, ya que se requiere el comando de configuración redistribute connected en los servidores NAS. La asignación de bloques de direcciones IP contiguas en cada NAS también es de ayuda en el resumen porque cada POP puede resumirse en un solo bloque grande y el núcleo no tiene que llevar exceso de rutas.


Información Relacionada


Document ID: 44944