IP : Multidifusión IP

Multicast sobre un túnel GRE

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de ejemplo del multicasting sobre un túnel GRE (Generic Routing Encapsulation).

En muchos escenarios de red usted quiere configurar su red para utilizar los túneles GRE para enviar la multidifusión independiente de protocolo (PIM) y el tráfico Multicast entre el Routers. Típicamente, esto ocurre cuando el origen de multidifusión y el receptor son separados por una nube IP que no se configure para el IP Multicast Routing. En tales escenarios de red, configurar un túnel a través de una nube IP con el PIM habilitado transporta los paquetes de multidifusión hacia el receptor. Este documento describe la configuración, la verificación, y los asuntos relacionados referente a la multidistribución sobre un túnel GRE.

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Mientras que el diagrama de la red muestra, el origen de multidifusión (10.1.1.1) está conectado con el R102 y configurado para el grupo de multidifusión 239.1.1.20. El receptor de multidifusión (10.2.2.3) está conectado con el R104 y configurado para recibir los paquetes de multidifusión para el grupo 239.1.1.20. La separación del R102 y del R104 es una nube IP, que no se configura para el ruteo multicast.

Un túnel se configura entre el R102 al R104 originado con sus interfaces del loopback. Configuran al comando ip pim sparse-dense mode en las interfaces del túnel y el ruteo multicast se habilita en el R102 y el R104. la configuración de modo Escaso-densa en las interfaces del túnel permite los paquetes del modo disperso o del modo denso que se remitirán sobre el túnel dependiendo de la configuración del (RP) del punto de encuentro para el grupo.

Nota:  Para el modo denso — Con el modo denso de PIM configurado sobre el túnel, un comando del tunnel0 de 10.1.1.0 255.255.255.0 de la ruta multicast del IP se configura en el R104 de asegurar un RPF acertado para la dirección de origen multicast 10.1.1.1. (10.1.1.1, 239.1.1.20) los paquetes de multidifusión entrantes sobre el tunnel0 (Tu0) se marcan para saber si hay reenvío de trayecto inverso (RPF) usando este enunciado mroute. Después de que un control acertado, los paquetes de multidifusión se remita a las interfaces de la lista de interfaz de salida (ACEITE).

Nota:  Para el modo disperso — Con el modo disperso de PIM configurado sobre el túnel, asegúrese de que estas puntas están dirigidas:

  • Para una verificación RPF exitosa de fluir de tráfico Multicast sobre el árbol compartido (*, G) del RP, un comando nexthop del RP-direccionamiento de la ruta multicast del IP necesita ser configurado para el direccionamiento RP, ese señala a la interfaz del túnel.

    Con la suposición que el R102 es el RP (direccionamiento 2.2.2.2 RP) en este caso, después la ruta multicast es el comando del tunnel0 de 2.2.2.2 255.255.255.255 de la ruta multicast del IP, que asegura un acertado revisión de "RPF" para el tráfico que fluye sobre el árbol compartido.

  • Para una verificación RPF exitosa del Multicast (S, G) flujo de tráfico sobre el Árbol de ruta más corto (SPT), un comando nexthop del fuente-direccionamiento de la ruta multicast del IP necesita ser configurado para el origen de multidifusión, señalando a la interfaz del túnel.

    En este caso, cuando el tráfico SPT está fluyendo sobre la interfaz del túnel un comando del tunnel0 de 10.1.1.0 255.255.255.0 de la ruta multicast del IP se configura en el R104 de asegurar los paquetes de multidifusión de una Verificación RPF satisfactoria para entrantes (10.1.1.1, 239.1.1.20) sobre la interfaz Tu0.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/43584/mcast-gre2.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Router 102 de la configuración según este archivo de configuración corriente:

R102
version 12.2
!hostname r102
!
!ip subnet-zero
no ip domain-lookup

!--- It stops IP domain lookup, which improves 
!--- the show command response time.

!
ip multicast-routing

!--- Enables IP multicast routing.

!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 
!--- Tunnel Source interface.

!
interface Tunnel0

!--- Tunnel interface configured for PIM and carrying 
!--- multicast packets to R104.

 ip address 192.168.24.1 255.255.255.252
 ip pim sparse-dense-mode
 tunnel source Loopback0
 tunnel destination 4.4.4.4
!
interface Ethernet0/0

!--- Interface connected to Source.

 ip address 10.1.1.2 255.255.255.0
 ip pim sparse-dense-mode
!
!
interface Serial8/0
 ip address 192.168.23.1 255.255.255.252

!--- Note IP PIM sparse-dense mode is 
!--- not configured on Serial interface.

!router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 10.1.1.0 0.0.0.255 area 0
 network 192.168.23.0 0.0.0.255 area 0
!
ip classless
ip pim bidir-enable
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Router 104 de la configuración según este archivo de configuración corriente:

R104
r104#
version 12.2
!
hostname r104
!
!
ip subnet-zero
no ip domain-lookup

!--- It stops IP domain lookup, which improves 
!--- the show command response time.

!
ip multicast-routing

!--- Enables IP multicast routing.

!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255

!--- Tunnel Source interface.

!
interface Tunnel0
 ip address 192.168.24.2 255.255.255.252

!--- Tunnel interface configured for PIM 
!--- and carrying multicast packets.

 ip pim sparse-dense-mode
 tunnel source Loopback0
 tunnel destination 2.2.2.2
!
interface Ethernet0/0
 ip address 10.2.2.2 255.255.255.0
 ip pim sparse-dense-mode
!
interface Serial9/0
 ip address 192.168.34.1 255.255.255.252

!--- Note IP PIM sparse-dense mode is not 
!--- configured on Serial interface.

!
!
router ospf 1
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 10.2.2.0 0.0.0.255 area 0
 network 192.168.34.0 0.0.0.255 area 0
!
ip classless
no ip http server
ip pim bidir-enable
ip mroute 10.1.1.0 255.255.255.0 Tunnel0


!--- This mroute ensures a successful RPF check 
!--- for packets flowing from the source.
!--- 10.1.1.1 over Shared tree in case of Dense 
!--- more and SPT in case of Sparse mode.

!
ip mroute 2.2.2.2 255.255.255.255 tunnel 0


!--- This mroute is required for RPF check when 
!--- Sparse mode multicast traffic is 
!--- flowing from RP (assuming R102 with 2.2.2.2 as RP)
!--- towards receiver via tunnel  
!--- before the SPT switchover.

line con 0
line aux 0
line vty 0 4
 login
!
end

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

  • muestre al grupo IGMP del IP — Verifica que el receptor haya enviado su IGMP se una al pedido de la calidad de miembro el grupo 239.1.1.20 al R104.

    r104#show ip igmp groups 
    IGMP Connected Group Membership
    Group Address    Interface          Uptime    Expires   Last Reporter
    239.1.1.20       Ethernet0/0        00:00:04  00:02:55  10.2.2.3
  • muestre el grupo de dirección de la ruta multicast del IP — Verifica que cuando la fuente 10.1.1.1 comienza a multicasting los paquetes para el grupo 239.1.1.20, el R102 instale (*,239.1.1.20) y (10.1.1.1, 239.1.1.20) las entradas en la tabla mroute R102.

    Nota: En (10.1.1.1, 239.1.1.20) la entrada, el ACEITE es tunnel0.

    r102#show ip mroute 239.1.1.20
    IP Multicast Routing Table
    Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
           L - Local, P - Pruned, R - RP-bit set, F - Register flag,
           T - SPT-bit set, J - Join SPT, M - MSDP created entry,
           X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
           U - URD, I - Received Source Specific Host Report
    Outgoing interface flags: H - Hardware switched
    Timers: Uptime/Expires
    Interface state: Interface, Next-Hop or VCD, State/Mode
    
    (*, 239.1.1.20), 00:00:09/00:02:59, RP 0.0.0.0, flags: D
      Incoming interface: Null, RPF nbr 0.0.0.0
      Outgoing interface list:
        Tunnel0, Forward/Sparse-Dense, 00:00:09/00:00:00
        Ethernet0/0, Forward/Sparse-Dense, 00:00:09/00:00:00
    
    (10.1.1.1, 239.1.1.20), 00:00:09/00:02:58, flags: T
      Incoming interface: Ethernet0/0, RPF nbr 0.0.0.0
      Outgoing interface list:
        Tunnel0, Forward/Sparse-Dense, 00:00:09/00:00:00
  • muestre el grupo de dirección de la ruta multicast del IP — Verifica que el R104 tenga (*,239.1.1.20) y (10.1.1.1, 239.1.1.20) entradas mientras que es reenvíos de paquetes de multidifusión para el grupo 239.1.1.20 originado de 10.1.1.1.

    Nota: En (10.1.1.1, 239.1.1.20), la interfaz entrante es tunnel0 y el vecino RPF es 192.168.24.1 — el centro distribuidor del túnel en el R102. La verificación de RPF se hace sobre la base de la ruta multicast configurada en el R104, y los paquetes de multidifusión se eliminan al ACEITE al receptor conectado en la interfaz del Ethernet0/0.

    r104#show ip mroute 239.1.1.20
    IP Multicast Routing Table
    Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
           L - Local, P - Pruned, R - RP-bit set, F - Register flag,
           T - SPT-bit set, J - Join SPT, M - MSDP created entry,
           X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
           U - URD, I - Received Source Specific Host Report
    Outgoing interface flags: H - Hardware switched
    Timers: Uptime/Expires
    Interface state: Interface, Next-Hop or VCD, State/Mode
    
    (*, 239.1.1.20), 00:07:10/00:00:00, RP 0.0.0.0, flags: DCL
      Incoming interface: Null, RPF nbr 0.0.0.0
      Outgoing interface list:
        Tunnel0, Forward/Sparse-Dense, 00:07:10/00:00:00
        Ethernet0/0, Forward/Sparse-Dense, 00:07:10/00:00:00
    
    (10.1.1.1, 239.1.1.20), 00:01:13/00:02:24, flags: CLT
      Incoming interface: Tunnel0, RPF nbr 192.168.24.1, Mroute
      Outgoing interface list:
        Ethernet0/0, Forward/Sparse-Dense, 00:01:13/00:00:00
  • muestre el IP address rpf del IP — Realice verificación RPF para paquetes originados de 10.1.1.1. El siguiente ejemplo confirma que el RPF para 10.1.1.1 está vía el tunnel0, en las cuales estamos recibiendo el Multicast (S, G) los paquetes.

    r104>show ip rpf 10.1.1.1
    RPF information for ? (10.1.1.1)
      RPF interface: Tunnel0
      RPF neighbor: ? (192.168.24.1)
      RPF route/mask: 10.1.1.1/24
      RPF type: static
      RPF recursion count: 0
      Doing distance-preferred lookups across tables

Troubleshooting

Use esta sección para resolver problemas de configuración.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Nota: Consulte Información Importante sobre Comandos de Debug antes de usar un comando debug.

Si su Multicast sobre el túnel GRE no está trabajando, uno de éstos puede ser la causa:

  • Túnel no UP/UP — El origen y destino del túnel no hace juego en cada extremo del túnel. Por ejemplo, si el destino del túnel en el R102 fuera cambiado a la dirección IP 10.2.2.2 en vez de 2.2.2.2 mientras que la configuración en el R104 seguía siendo lo mismo, el túnel no subiría.

    Publique el comando show interface tunnel 0 para verificar el estatus del túnel.

  • Los paquetes de multidifusión se caen debido a la falla de RPF.

    Publique el comando show ip mroute count. Una salida de muestra de este comando y de sus contadores cada vez mayores para la falla de RPF se muestra en esta salida:

    r104#show ip mroute count
    IP Multicast Statistics
    3 routes using 1642 bytes of memory
    2 groups, 0.50 average sources per group
    Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
    Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)
    
    Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0
    
    Group: 239.1.1.20, Source count: 1, Packets forwarded: 11, Packets received: 45
      Source: 10.1.1.1/32, Forwarding: 11/0/100/0, Other: 25/14/0
    
    
    !--- After some time, the show ip mroute count command 
    !--- is issued again. You can see the RPF failed counter increasing:
    
    r104#show ip mroute count
    IP Multicast Statistics
    3 routes using 1642 bytes of memory
    2 groups, 0.50 average sources per group
    Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
    Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)
    
    Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0
    
    Group: 239.1.1.20, Source count: 1, Packets forwarded: 11, Packets received: 50
      Source: 10.1.1.1/32, Forwarding: 11/0/100/0, Other: 30/19/0
    r104#

    Usted puede también publicar el comando source rpf del IP de la demostración. Asegúrese de que la interfaz RPF sea lo mismo que la en las cuales se reciban los paquetes de multidifusión de la fuente — tunnel0 en este ejemplo. Refiera a la guía de Troubleshooting de IP Multicast para más información sobre los errores RPF.

  • Vecinos del PIM — El router R102 no está remitiendo sobre la interfaz del tunnel0 porque no está considerando a un vecino R104 PM.

    Ejecute estos comandos:

    • muestre al vecino del pim del IP — Usted puede utilizar el comando show ip pim neighbor en el R102 de mostrar al vecino R104 sobre el túnel.

    • muestre el pim internacional del IP — Usted puede también utilizar el comando show ip pim int de mostrar que hay un vecino.

    • sparse-dense-mode del pim del IP — Verifique que configuren al comando ip pim sparse-dense-mode del nivel de la interfaz en los ambos extremos del túnel y que el ruteo multicast IP está habilitado.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 43584