Switching de LAN : Routing entre VLAN

Configuración del Ruteo de InterVLAN y Trunking de ISL/802.1Q en un Switch Catalyst 2900xl/3500xl/2950 mediante un Router Externo

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (20 Mayo 2008) | Inglés (20 Octubre 2015) | Comentarios


Contenido


Introducción

Este documento proporciona ejemplos de configuraciones en InterSwitch Link (ISL) y en 802.1Q trunking entre un switch Catalyst 3512-XL y un router Cisco 2600; los resultados de cada comando se muestran a medida que se ejecutan. Los Cisco 3600 y 4500/4700 Series Routers, u otros miembros de los Cisco 2600 Series Routers, con las interfaces FastEthernet, y cualquier Catalyst 2900XL, 3500XL, 2940, 2950 o 2970 se pueden utilizar en los escenarios presentados en este documento para obtener los mismos resultados.

Trunking es una forma de llevar el tráfico de varias VLAN a través de un link punto a punto entre dos dispositivos. Estas son dos formas en las que se puede implementar Ethernet trunking:

  • ISL (protocolo propiedad de Cisco y no compatible con los 2940 o 2950 Series Switches)

  • 802.1Q (Norma del Instituto de Ingenieros Eléctricos y Electrónicos (IEEE) )

Crearemos un trunk que transporte tráfico desde dos VLAN (VLAN1 y VLAN2) a través de un link único entre un Catalyst 3500 y un router serie 2600 de Cisco.

Para establecer el ruteo entre VLAN1 y VLAN2, utilizamos el router Cisco 2600. Catalyst 2900XL/3500XL/2940/2950/2970 Series Switches son switches de la capa 2 (L2) y no tienen capacidad de ruteo ni de comunicación entre VLAN. Para otros detalles en el Routing entre VLAN, refiera a la encaminamiento entre el capítulo de descripción general de los LAN virtuales de la guía de configuración de los servicios de transferencia de Cisco IOS�, Release12.1.

Para crear los ejemplos usados en este documento, utilizamos los siguientes switches en un entorno de laboratorio sin configuraciones.

  • Switch Catalyst 3512XL que ejecuta el IOS de Cisco 12.0(5.x)XU.

  • Router Cisco 2621 que ejecuta Cisco IOS 12.1(3)T

  • Router Cisco 2621 que ejecuta el IOS de Cisco 12.1(1)T.

Las configuraciones de este documento fueron implementadas en un entorno aislado de laboratorio. Asegúrese de comprender el posible efecto que tendrá cualquier configuración o comando sobre la red antes de usarlo. Se eliminaron las configuraciones de todos los dispositivos con el comando write erase para asegurarse de que tuvieran una configuración predeterminada.

Antes de comenzar

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

prerrequisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Notas importantes

Para Catalyst 2900XL/3500XL/2940/2950/2970 Series Switches:

Catalyst 2940 y 2950 Series Switches no admiten ISL trunking, solamente admiten 802.1q trunking.

En un switch Catalyst 2900XL de 4 MB de DRAM, trunking es admitido únicamente con los siguientes módulos con capacidad de trunking:

  • WS-X2914-XL-V: Módulo de switch de 4 puertos 10/100 ISL/802.1Q

  • WS-X2922-XL-V: módulo de switch de 2 puertos 100BaseFX ISL/802.1Q

  • WS-X2924-XL-V: módulo de switch de 4 puertos 100BaseFX ISL/802.1Q

  • WS-C2924-XL: link ascendente 1000BaseX para Catalyst 2900 XL

  • WS-X2932-XL: link ascendente 1000BaseT para Catalyst 2900 XL

Consulte la Tabla 1 a continuación que contiene una lista de modelos de switches que admiten trunking:

Tabla 1

Modelos de Switches Versión Mínima Requerida para enlace ISL Trunking Versión Mínima Requerida para IEEE 802.1Q Trunking Versión Actual Necesaria para Trunking (ISL/802.1Q)
WS-C2916M-XL (switch de 4 meg) 11.2(8)SA4 (Edición para Empresas) 11.2(8)SA5 (Edición para Empresas) 11.2(8.6)SA6 (Edición Original)
C2912-XL 11.2(8)SA4 (Edición para Empresas) 11.2(8)SA5 (Edición para Empresas) 12.0(5)WC(1) o posterior
C2924-XL 11.2(8)SA4 (Edición para Empresas) 11.2(8)SA5 (Edición para Empresas) 12.0(5)WC(1) o posterior
WS-C2924M-XL 11.2(8)SA4 (Edición para Empresas) 11.2(8)SA5 (Edición para Empresas) 12.0(5)WC(1) o posterior
WS-C2924M-XL 11.2(8)SA4 (Edición para Empresas) 11.2(8)SA5 (Edición para Empresas) 12.0(5)WC(1) o posterior
WS-C2912MF-XL 11.2(8)SA4 (Edición para Empresas) 11.2(8)SA5 (Edición para Empresas) 12.0(5)WC(1) o posterior
WS-C2924M-XL-DC 12.0(5)XU 12.0(5)XU 12.0(5)WC(1) o posterior
WS-C3508G-XL 11.2(8)SA4 (Edición para Empresas) 11.2(8)SA5 (Edición para Empresas) 12.0(5)WC(1) o posterior
WS-C3512-XL 11.2(8)SA4 (Edición para Empresas) 11.2(8)SA5 (Edición Original) 12.0(5)WC(1) o posterior
WS-C3524-XL 11.2(8)SA4 (Edición para Empresas) 11.2(8)SA5 (Edición para Empresas) 12.0(5)WC(1) o posterior
WS-C3548-XL 12.0(5)XP (Enterprise Edition) 12.0(5)XP (Enterprise Edition) 12.0(5)WC(1) o posterior
WS-C3524-PWR-XL 12.0(5)XU 12.0(5)XU 12.0(5)WC(1) o posterior
WS-C2940-8TF No hay Soporte para ISL 12.1(13)AY 12.1(13)WC(1) o posterior para 802.1Q. ISL no tiene soporte.
WS-C2940-8TT No hay Soporte para ISL 12.1(13)AY 12.1(13)WC(1) o posterior para 802.1Q. ISL no tiene soporte.
WS-C2950-12 No hay Soporte para ISL 12.0(5)WC(1) 12.0(5)WC(1) o superior para 802.1Q. ISL no tiene soporte.
WS-C2950-24 No hay Soporte para ISL 12.0(5)WC(1) 12.0(5)WC(1) o superior para 802.1Q. ISL no tiene soporte.
WS-C2950C-24 No hay Soporte para ISL 12.0(5)WC(1) 12.0(5)WC(1) o superior para 802.1Q. ISL no tiene soporte.
WS-C2950T-24 No hay Soporte para ISL 12.0(5)WC(1) 12.0(5)WC(1) o superior para 802.1Q. ISL no tiene soporte.
WS-C2950G-12-EI No hay Soporte para ISL 12.0(5)WC(1) 12.0(5)WC(1) o superior para 802.1Q. ISL no tiene soporte.
WS-C2950G-24-EI No hay Soporte para ISL 12.0(5)WC(1) 12.0(5)WC(1) o superior para 802.1Q. ISL no tiene soporte.
WS-C2950G-48-EI No hay Soporte para ISL 12.0(5)WC(1) 12.0(5)WC(1) o superior para 802.1Q. ISL no tiene soporte.
WS-C2950SX-24 No hay Soporte para ISL 12.0(5)WC(1) 12.0(5)WC(1) o superior para 802.1Q. ISL no tiene soporte.
WS-C2950-24-EI-DC No hay Soporte para ISL 12.0(5)WC(1) 12.0(5)WC(1) o superior para 802.1Q. ISL no tiene soporte.
WS-C2955T-12 No hay Soporte para ISL 12.1(13)EA1 12.1(13)EA1 o posterior para 802.1Q. ISL no tiene soporte.
WS-C2955S-12 No hay Soporte para ISL 12.1(13)EA1 12.1(13)EA1 o posterior para 802.1Q. ISL no tiene soporte.
WS-C2955C-12 No hay Soporte para ISL 12.1(13)EA1 12.1(13)EA1 o posterior para 802.1Q. ISL no tiene soporte.
WS-C2970G-24T 12.1(11)AX 12.1(11)AX 12.1(11)AX o posterior
WS-C2970G-24TS 12.1(14)EA1 12.1(14)EA1 12.1(14)EA1 o posterior

Nota: En la tabla anterior, solamente el switch WS-C2916M-XL es un switch de 4 MB de DRAM. El resto de los switches que aparecen tienen 8 MB de DRAM. Para determinar si el switch tiene 4 MB u 8 MB de DRAM, introduzca el comando show version del nivel del usuario. Para obtener más información, consulte la sección Cómo Determinar la Cantidad de Memoria del Switch con la Interfaz de Línea de Comandos de Actualización de Software en Catalyst 2900-XL/3500-XL Series Switches con la Interfaz de Línea de Comandos.

Nota: En los switches Catalyst 2900XL/3500XL/2940/2950/2970, una interfaz VLAN (por ejemplo, int vlan 1, int vlan 2, int vlan x) se puede crear para cada VLAN que se configure en el switch. Sin embargo, solo se puede utilizar una VLAN a la vez como VLAN de administración. La dirección IP se asigna a la interfaz VLAN de la VLAN de administración solamente. Esa interfaz no se activará si la dirección IP se asigna a otra interfaz VLAN cuya VLAN no se utiliza como VLAN de administración. Es preferible crear la interfaz VLAN solo para la VLAN de administración.

Para los routers Cisco 2600:

Para 802.1Q trunking, no se etiqueta una VLAN. Esta VLAN se denomina VLAN nativa. La VLAN nativa se usa para tráfico sin etiquetas cuando el puerto está en modo 802.1Q trunking. Mientras se configura 802.1Q trunking, es muy importante tener presente que la VLAN nativa se debe configurar de la misma manera en cada lado del trunk link. Un error muy común es que no se haga coincidir las VLAN de origen al configurar el enlace troncal 802.1Q entre el router y el switch. Para obtener información sobre las VLAN nativas, consulte la sección IEEE 802.1Q de Bridging entre VLAN IEEE 802.1Q en Nuevas Funciones en la Versión 12.1(3)T.

En esta configuración de ejemplo, de forma predeterminada, la VLAN nativa es VLAN1 en el router Cisco 2621 y en el switch Catalyst 3512XL. Según las necesidades de su red, deberá usar una VLAN nativa que no sea la VLAN1 predeterminada. Los comandos para cambiar la VLAN nativa en el router 2600 de Cisco y en el switch Catalyst 3500XL han sido mencionados en la sección Configuraciones de este documento.

Las configuraciones de ejemplo presentadas en este documento se pueden utilizar en los Cisco 2600/3600/4500/4700 Series Routers con las interfaces Fast Ethernet o con los módulos de red Fast Ethernet. Además, asegúrese de estar usando la versión del Cisco IOS que admite ISL/802.1Q VLAN trunking. Para obtener una lista completa de routers Cisco 2600/3600/4500/4700 que admiten ISL/802.1Q VLAN trunking y las versiones del IOS de Cisco compatibles, consulte la Tabla 2 a continuación.

Tabla 2

Modelos de Routers Versión Mínima Requerida para enlace ISL Trunking Versión Mínima Requerida para IEEE 802.1Q Trunking Conjunto de Características Mínimas Requeridas (ISL/802.1Q)
Cisco 2620 11.3(3a)T 12.0(1)T IP PLUS/IP PLUS
Cisco 2621 11.3(3a)T 12.0(1)T IP PLUS/IP PLUS
Cisco 2620 12.1(3a)T 12.1(3a)T IP PLUS/IP PLUS
Cisco 2650 12.1(3a)T 12.1(3a)T IP PLUS/IP PLUS
Cisco 3620 11.3(1)T 12.0(1)T IP PLUS/IP PLUS
Cisco 3640 11.3(1)T 12.0(1)T IP PLUS/IP PLUS
Cisco 3661 12.0(5)T 12.0(5)T IP PLUS/IP PLUS
Cisco 3662 12.0(5)T 12.0(5)T IP PLUS/IP PLUS
Cisco 4500-M 11.3(1)T 12.0(1)T IP PLUS/IP PLUS
Cisco 4700-M 11.3(1)T 12.0(1)T IP PLUS/IP PLUS

Nota: En la Tabla 2, se enumeran solamente las versiones principales/de mantenimiento actuales o mínimas que admiten esta configuración de ejemplo. Los modelos de routers con ciertos módulos de red pueden tener distintas versiones mínimas de IOS de Cisco. Para obtener una lista completa de software admitido mínimo para cualquier familia de routers, utilice la herramienta Software Advisor (para clientes registrados solamente).

Nota: La versión admitida mínima puede no ser necesariamente la versión recomendada. Para determinar cuál es la mejor versión de mantenimiento para su producto de Cisco, busque bugs enumerados por componente de producto en la herramienta Bug Toolkit (para clientes registrados solamente).

Nota: En la Tabla 2, se incluye el conjunto de características mínimas requeridas para ruteo y trunking entre VLAN IP a fin de admitir esta configuración de ejemplo. Para obtener una lista completa de los conjuntos de características admitidos en diversas versiones del IOS de Cisco y en diversas plataformas, utilice el área Descargar Software.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/14976/50a.jpg

Configuraciones

Este documento usa las configuraciones detalladas a continuación.

Nota: Los modelos de routers con ciertos módulos de red pueden tener distintas versiones mínimas del IOS de Cisco compatibles con ISL trunking.

  • Catalyst 3512-XL

  • Router 2600 de Cisco

  • Configuración 802.1Q en el Router para las Versiones Anteriores a 12.1(3)T del IOS de Cisco

Catalyst 3512-XL

Nota: Las siguientes capturas de pantalla muestran los comandos que se ingresaron en el switch 3512XL. Los comentarios entre los comandos están agregados en azul y en cursiva para explicar determinados pasos y comandos.


!-- Set the privileged mode


!-- and Telnet password on the switch.

switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
switch(config)#hostname 3512xl
3512xl(config)#enable password mysecret
3512xl(config)#line vty 0 4
3512xl(config-line)#login
3512xl(config-line)#password mysecret
3512xl(config-line)#exit
3512xl(config)#no logging console
3512xl(config)#^Z


!-- Set the IP address and default gateway for VLAN1 for management purposes.

3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int vlan 1
3512xl(config-if)#ip address 10.10.10.2 255.255.255.0
3512xl(config-if)#exit
3512xl(config)#ip default-gateway 10.10.10.1
3512xl(config)#end

!-- Set the VTP Mode.
!-- In our example, we have set the mode to be transparent.
!-- Depending on your network, set the VTP Mode accordingly.
!-- For details on VTP,
!-- refer to
!-- Creating and Maintaining VLANs on Catalyst 2900XL and 3500XL Switches.

3512xl#vlan database
3512xl(vlan)#vtp transparent
Setting device to VTP TRANSPARENT mode.


!-- Adding VLAN2. VLAN1 already exists by default.

3512xl(vlan)#vlan 2
VLAN 2 added:
Name: VLAN0002
3512xl(vlan)#exit
APPLY completed.
Exiting....


!-- Enable trunking on the interface fastEthernet 0/1.

3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int fastEthernet 0/1
3512xl(config-if)#switchport mode trunk


!-- Enter the trunking encapsulation as either isl

3512xl(config-if)#switchport trunk encapsulation isl

!-- or as dot1q:


3512xl(config-if)#switchport trunk encapsulation dot1q

!-- In case of 2940/2950 series switches, none of the above two commands are used,
!-- 2940/2950 series switches only support 802.1q encapsulation which is configured automatically,
!-- when trunking is enabled on the interface by using switchport mode trunk command.

!-- In case of dot1q, you need to make sure that
!-- the native VLAN matches across the link.
!-- On 3512XL, by default, the native VLAN is 1.
!-- Depending on your network needs, you may change
!-- the native VLAN to be other than VLAN1,
!-- but it is very important that you change the native VLAN
!-- on the router accordingly.
!-- You may change the native VLAN, if needed, by using the following command:
!-- 3512xl(config-if)#switchport trunk native vlan <vlan ID>

!-- Allow all VLANs on the trunk.

3512xl(config-if)#switchport trunk allowed vlan all
3512xl(config-if)#exit


!-- The following set of commands will place FastEthernet 0/2
!-- into VLAN2 and enable portfast on the interface.

3512xl(config)#int fastEthernet 0/2
3512xl(config-if)#switchport access vlan 2
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#exit


!-- FastEthernet 0/3 is already in VLAN1 by default.
!-- Enable portfast on the interface.

3512xl(config)#int fastEthernet 0/3
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#^Z

!-- For details on why to enable portfast,
!-- refer to:
!-- Using PortFast and Other Commands to Fix Workstation Startup Connectivity Delays.
!-- Remember to save the configuration.

3512xl#write memory
Building configuration...

3512xl#

--------------------------------------------------------------------------------

3512xl#show running-config
Building configuration...

Current configuration:

!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3512xl
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
  switchport mode trunk
!

!-- If 802.1Q is configured,
!-- you will instead see the following output
!-- under interface FastEthernet0/1:
!-- interface FastEthernet0/1
!-- switchport trunk encapsulation dot1q
!-- switchport mode trunk

!
interface FastEthernet0/2
 switchport access vlan 2
 spanning-tree portfast
!
interface FastEthernet0/3
 spanning-tree portfast
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
 ip address 10.10.10.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 10.10.10.1
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 password mysecret
 login
line vty 5 15
 login
!
end

Router 2600

Nota: Las siguientes capturas de pantalla muestran los comandos que fueron ingresados en el router 2600 de Cisco. Los comentarios entre los comandos están agregados en azul y en cursiva para explicar determinados pasos y comandos.


!-- Set the privileged mode
!-- and Telnet password on the router.

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname c2600

c2600(config)#enable password mysecret
c2600(config)#line vty 0 4
c2600(config-line)#login
c2600(config-line)#password mysecret
c2600(config-line)#exit
c2600(config)#no logging console
c2600(config)#^Z

c2600#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.


!-- Select FastEthernet 0/0 for the trunk configuration.
!-- No L2 or Layer 3 (L3) configuration is done here.

c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut
c2600(config-if)#exit


!-- Enable trunking on the sub-interface FastEthernet 0/0.1.
!-- Note that actual trunks are configured on the sub-interfaces.

c2600(config)#int fastEthernet 0/0.1


!-- Enter the trunking encapsulation as either isl

c2600(config-subif)#encapsulation isl 1


!-- or as dot1q:
!-- In case of dot1q, you need to make sure that
!-- the native VLAN matches across the link.
!-- On 3512XL, by default, the native VLAN is 1.
!-- On the router, configure VLAN1 as the native VLAN.

c2600(config-subif)#encapsulation dot1Q 1 ?
  native  Make this is native vlan
  <cr>
c2600(config-subif)#encapsulation dot1Q 1 native

!-- On the switch, if you have a native VLAN other than VLAN1,
!-- on the router, configure the same VLAN to be the native VLAN,
!-- by using the above command.

Nota: El comando encapsulation dot1Q 1 native ha sido agregado a la versión 12.1(3)T del IOS de Cisco Si usted está utilizando una versión anterior del IOS de Cisco, consulte la sección Configuración 802.1Q para las Versiones del IOS de Cisco Anteriores a 12.1(3)T de este documento para configurar 802.1Q trunking en el router.


!-- Configure L3 information on the sub-interface 0/0.1.

c2600(config-subif)#ip address 10.10.10.1 255.255.255.0
c2600(config-subif)#exit


!-- Enable trunking on the sub-interface FastEthernet 0/0.2.
!-- Note that actual trunks are configured on the sub-interfaces.

c2600(config)#int fastEthernet 0/0.2


!-- Enter the trunking encapsulation as either isl

c2600(config-subif)#encapsulation isl 2


!-- or as dot1q:

c2600(config-subif)#encapsulation dot1Q 2


!-- Configure L3 information on the sub-interface 0/0.2.

c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z


!-- Remember to save the configuration.

c2600#write memory
Building configuration...
[OK]
c2600#

Nota: Para que esta configuración funcione y para hacer ping entre la estación de trabajo 1 y la estación de trabajo 2 sin inconvenientes, usted necesita asegurarse de que los gateways predeterminados en las estaciones de trabajo estén correctamente configurados. Para la estación de trabajo 1, el gateway predeterminado debe ser 10.10.11.1 y, para la estación de trabajo 2, 10.10.10.1. Para obtener detalles sobre cómo configurar los gateways predeterminados en las estaciones de trabajo, consulte las secciones respectivas en este documento.

Nota: El siguiente párrafo se aplica únicamente si se ha configurado 802.1Q trunking entre el router y el switch.

Nota: Si usted ha seguido los pasos de configuración enumerados en las secciones anteriores y todavía no puede hacer ping a través de las VLAN (entre la estación de trabajo 1 y la estación de trabajo 2), existe la posibilidad de que haya aparecido la advertencia CSCds42715, en la cual la palabra clave de VLAN nativa 802.1Q no funciona correctamente si fast switching está habilitado. La solución de bugs fue integrada en las siguientes versiones de código: 12.2(0.5), 12.2(0.5)T, 12.1(5)DC, 12.1(5)YB, 12.2(0.18)S, 12.1(5)YD02, 12.2(2)B, 12.2(15)ZN. Usted puede verificar el estado y obtener una breve descripción del bug usando la herramienta Bug Toolkit (para clientes registrados solamente) e ingresando el ID de bug CSCds42715.


--------------------------------------------------------------------------------

c2600#show running-config
Building configuration...
 
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2600
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation isl 1
 ip address 10.10.10.1 255.255.255.0
 no ip redirects
!

!-- If 802.1Q is configured,
!-- you will instead see the following output
!-- under interface FastEthernet0/0.1:
!-- interface FastEthernet0/0.1
!-- encapsulation dot1Q 1 native
!-- ip address 10.10.10.1 255.255.255.0

!
!
interface FastEthernet0/0.2
 encapsulation isl 2
 ip address 10.10.11.1 255.255.255.0
 no ip redirects
!

!-- If 802.1Q is configured,
!-- you will instead see the following output
!-- under interface FastEthernet0/0.2:
!-- interface FastEthernet0/0.2
!-- encapsulation dot1Q 2
!-- ip address 10.10.11.1 255.255.255.0

!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password mysecret
 login
!
no scheduler allocate
end

Configuración 802.1Q en el Router para las Versiones Anteriores a 12.1(3)T del IOS de Cisco
Como se describió anteriormente en este documento, mientras se configura 802.1Q trunking, es importante que coincida la VLAN nativa a través del link. En las versiones del Cisco IOS Software anteriores a 12.1(3)T, usted no puede definir la VLAN nativa explícitamente, pues el comando encapsulation dot1Q 1 native de la subinterfaz no está disponible. En las versiones del IOS de Cisco anteriores, es importante no configurar la interfaz de VLAN nativa como subinterfaz, que está en nuestra VLAN1 de ejemplo. Si se realiza una configuración incorrecta, el router esperaría que una trama con etiqueta dot1q en VLAN1 y el switch no espera una etiqueta en VLAN1. Como consecuencia, ningún tráfico pasará entre VLAN1 en el switch y el router. En situaciones como estas, siempre realice la configuración para la VLAN nativa en la interfaz principal y cree la subinterfaz para el resto de las VLAN en el trunk. En la configuración actual del laboratorio, utilice los siguientes pasos para configurar el router 2600 de Cisco:
 

!-- Set the privileged mode
!-- and Telnet password on the router.

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname c2600
c2600(config)#enable password mysecret
c2600(config)#line vty 0 4
c2600(config-line)#login;
c2600(config-line)#password mysecret
c2600(config-line)#exit
c2600(config)#no logging console
c2600(config)#^Z

c2600#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.


!-- Select FastEthernet 0/0 for the trunk configuration.

c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut


!-- Note that the IP address for VLAN1 is configured on the main interface,
!-- and no encapsulation for VLAN1 will be done under the sub-interface.

c2600(config-if)#ip address 10.10.10.1 255.255.255.0
c2600(config-if)#exit


!-- Configure dot1q encapsulation for VLAN 2
!-- on sub-interface fastEthernet 0/0.2.

c2600(config)#int fastEthernet 0/0.2
c2600(config-subif)#encapsulation dot1Q 2
c2600(config-subif)#


!-- Configuring L3 information on the sub-interface 0/0.2.

c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z


!-- Remember to save the configuration.

c2600#write memory
Building configuration...
[OK]
c2600#

Nota: Para que esta configuración funcione y sea posible hacer ping satisfactoriamente entre la estación de trabajo1 y la estación de trabajo2, necesita asegurarse que las gateways predeterminadas en las estaciones de trabajo estén configuradas correctamente. Para la estación de trabajo 1, el gateway predeterminada debe ser 10.10.11.1 y para la estación de trabajo 2, 10.10.10.1. Para obtener detalles sobre cómo configurar los gateways predeterminados en las estaciones de trabajo, consulte sus respectivas secciones en este documento.

c2600#show running-config
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2600
!
no logging console
enable password mysecret
!
!
!
!
!
memory-size iomem 7
ip subnet-zero
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 10.10.11.1 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password mysecret
 login
!
no scheduler allocate
end

c2600#

Comandos debug y show

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

En los switches Catalyst 2900XL/3500XL/2940/2950/2970, utilice los siguientes comandos:

  • show int {FastEthernet | GigabitEthernet} <module/port> switchport}

  • show vlan

  • show vtp status

En el router Cisco 2600, utilice los siguientes comandos:

  • show vlan

  • show interface

Ejemplo de Resultado del Comando show

Catalyst 3500XL Switch

show int {FastEthernet | GigabitEthernet} <module/port> switchport}

Este comando se utiliza para verificar el estado administrativo y operacional del puerto. También se usa para garantizar que la VLAN nativa concuerde en ambos lados del trunk. La VLAN nativa se usa para tráfico sin etiquetas cuando el puerto está en modo 802.1Q trunking. Consulte Creación y Mantenimiento de VLAN en Switches Catalyst 2900XL y 3500XL para obtener información detallada sobre VLAN nativas.

3512xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none

Nota: Para 802.1Q trunking, el resultado del comando anterior cambia de la siguiente manera:

3512xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none

show vlan

Este comando se utiliza para verificar que las interfaces (puertos) pertenezcan a la VLAN correcta. En nuestro ejemplo, solamente la interfaz Fa0/2 pertenece a VLAN2. El resto son miembros de VLAN1.

3512xl#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6,
                                                Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                Fa0/11, Fa0/12, Gi0/1, Gi0/2
2    VLAN0002                         active    Fa0/2
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

...(output suppressed)

show vtp status

Se utiliza este comando para verificar la configuración del VLAN Trunking Protocol (VTP) en el switch. En nuestro ejemplo, usamos el modo transparente. El modo VTP correcto depende de la topología de su red. Para obtener información detallada sobre el VTP, consulte Creación y Mantenimiento de VLAN en Switches Catalyst 2900XL y 3500XL.

3512xl#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 254
Number of existing VLANs        : 6
VTP Operating Mode              : Transparent
VTP Domain Name                 : 
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xC3 0x71 0xF9 0x77 0x2B 0xAC 0x5C 0x97
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

Router 2600 de Cisco

show vlan

Este comando indica qué información de L2 o L3 está configurada para cada VLAN.

c2600#show vlan
 
Virtual LAN ID:  1 (Inter Switch Link Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.1
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.10.1                  40                  38
 
Virtual LAN ID:  2 (Inter Switch Link Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.2
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                   9                   9

Nota: Para 802.1Q trunking, el resultado del comando anterior cambia de la siguiente manera:

c2600#show vlan
 
Virtual LAN ID:  1 (IEEE 802.1Q Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.1
 
 This is configured as native Vlan for the following interface(s): FastEthernet0/0
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.10.1                   0                   2
 
Virtual LAN ID:  2 (IEEE 802.1Q Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.2
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                  42                  19

Nota: Para 802.1Q trunking, con las versiones del IOS de Cisco anteriores a 12.1(3)T, el resultado del comando cambia de la siguiente manera:

c2600#show vlan

Virtual LAN ID:  2 (IEEE 802.1Q Encapsulation)

   vLAN Trunk Interface:   FastEthernet0/0.2

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                   6                   4

Nota: No se muestra ninguna encapsulación IEEE 802.1Q para VLAN1 en ninguna de las subinterfaces.

show interface

Este comando se utiliza para verificar el estado administrativo y operacional del puerto.

c2600#show interfaces fastEthernet 0/0
FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:07, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     217 packets input, 12884 bytes
     Received 217 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     45 packets output, 6211 bytes, 0 underruns(0/0/0)
     0 output errors, 0 collisions, 4 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

c2600#show interfaces fastEthernet 0/0.1
FastEthernet0/0.1 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ISL Virtual LAN, Color 1.
  ARP type: ARPA, ARP Timeout 04:00:00

c2600#show interfaces fastEthernet 0/0.2
FastEthernet0/0.2 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.11.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ISL Virtual LAN, Color 2.
  ARP type: ARPA, ARP Timeout 04:00:00

Nota: Para 802.1Q trunking, el resultado del comando anterior cambia de la siguiente manera:

c2600#show interfaces fastEthernet 0/0.1
FastEthernet0/0.1 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1.
  ARP type: ARPA, ARP Timeout 04:00:00

c2600#show interfaces fastEthernet 0/0.2
FastEthernet0/0.2 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.11.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  2.
  ARP type: ARPA, ARP Timeout 04:00:00

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 14976