Marcado y acceso remotos : "Red digital de servicios integrados (ISDN), Señalización por canal asociado (CAS)"

Configurar el Data Over Voice (DoV) usando los datos de voz entrante isdn y la llamada de voz del marcador

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra para configurar el Data Over Voice (DoV) usando los comandos isdn incoming-voice data y dialer voice-call.

Antes de comenzar

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

prerrequisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las versiones de software y hardware indicadas a continuación.

  • Software Release 11.3 o Posterior del ½ del ¿Â de Cisco IOSïÂ.

  • Usted puede utilizar a cualquier router con una interfaz de ISDN. Sin embargo usted debe asegurarse de que la compañía telefónica soporte el DOV, y de que ninguna corrupción de datos

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Teoría Precedente

Datos sobre voz (DOV) le permite enviar datos sobre una llamada de voz mediante una línea ISDN. Una línea ISDN admite llamadas de datos y de voz. Los dos routers que se interconectan con las líneas ISDN por lo general usan llamadas de datos (64 kbps ó 56 kbps). Se espera que las llamadas de voz sean generadas por un teléfono o fax. Las llamadas de voz también pueden ser generadas por un dispositivo conectado a un módem analógico (por ejemplo, una PC que marque con una línea de servicio telefónico analógico convencional [POTS]).

En algunas circunstancias, un usuario puede estar interesado en conectar dos routers con llamada de voz usando líneas ISDN, especialmente si se considera la diferencia de precio entre una llamada de datos y una de voz. Las líneas ISDN normalmente poseen cargos por llamada para todas las llamadas (locales, larga distancia e internacionales).

A veces la tasación de las llamadas de voz es más baja que la tasación de las llamadas de datos. Para que los routers puedan comunicarse utilizando llamadas de voz entre dos líneas ISDN, se requiere una correcta configuración que permita que los routers sepan que las llamadas deben iniciarse como llamadas de voz y que las llamadas de voz entrantes deben ser administradas como llamadas de datos. Del lado saliente (de llamada) utilice la opción map-class para definir las llamadas como llamadas de voz:

nombre del marcador map-class

llamada de voz del marcador

Esta clase de asociador define un comportamiento y se debe aplicar a las interfaces ISDN cuando se necesite este comportamiento. Aquí está un ejemplo del comportamiento del map-class en los comandos dialer map o dialer string.

del dialer map protocol del direccionamiento de la clase del map class del nombre del nombre del host número de teléfono [broadcast]

map class de la clase del número de teléfono de la cadena del dialer

Consulte la documentación del software del IOS de Cisco si desea conocer la sintaxis completa de estos dos comandos.

En el lado entrante (llamado) agregue el comando isdn incoming-voice data debajo de la interfaz física. Recuerde que todas las llamadas de voz entrantes serán tratadas como llamadas de datos. Si está utilizando una plataforma que soporta llamadas de módem en las BRI, no puede configurar una interfaz en particular para soportar cualquiera de las funciones. Una interfaz particular podía dirigir las llamadas de voz como llamadas del módem o las llamadas de voz como llamadas del DOV, pero no ambas.

Nota: Es posible configurar una interfaz particular para manejar las llamadas de voz pues las llamadas del módem o las llamadas de voz como llamadas del DOV. Sin embargo, es necesario que configure Resource Pool Management (RPM). Si desea obtener más información sobre RPM, consulte el siguiente documento: Administración de Grupos de recursos.

Es importante comprender que DOV posee una confiabilidad limitada. Una llamada entre dos líneas ISDN debería brindar un trayecto digital de principio a fin. El equipo, las líneas, y otros recursos que la compañía telefónica utiliza para configurar las llamadas de datos y voces son generalmente lo mismo. Sin embargo, pueden ser diferentes. El transporte de voz digital es más flexible que el transporte de datos. La red telefónica garantiza el transporte de bits a lo largo de un trayecto digital de 64 ó 56 kbps para llamadas de datos ISDN. Para las llamadas de voz, la red telefónica puede rutear y manipular la secuencia de bits de diferentes maneras sin afectar la calidad de la voz, aunque todos los datos se dañan cuando se envían de esta manera. Por lo tanto, DOV no funciona con algunas líneas ISDN. Verifique que su compañía telefónica pueda manejar las llamadas del DOV antes de que usted configure esta característica, la configuración de la llamada pueda succeeed pero datos tht sea corrompida.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/14964/briipun.gif

Configuraciones

Este documento usa las configuraciones detalladas a continuación.

Router 1
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router2 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.10.186.133 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer string 5556700 class DOV

! --- The router will use the map-class DOV when dialing this number
! --- The map-class named DOV is defined below

 dialer load-threshold 5 outbound
 dialer-group 1
 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 BRI0
no ip http server
!
map-class dialer DOV

! --- map class named DOV is applied to the dialer string under 
! --- the physical interface

 dialer voice-call

! --- Outgoing call is treated as a voice call

!
dialer-list 1 protocol ip permit
!
line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

Router 2
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router2
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router1 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.8.186.134 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer-group 1
 isdn switch-type basic-5ess
 isdn incoming-voice data

! --- Incoming voice calls will be treated as data calls
! --- An interface cannot accept modem calls and DOV calls without RPM

 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.8.186.129
ip route 10.10.186.128 255.255.255.240 BRI0
no ip http server

dialer-list 1 protocol ip permit

line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • isdn status de la demostración - El estatus debe ser:

    layer 1 = active 
    layer 2 = MULTIPLE_FRAMES_ESTABLISHED

    Si el Layer 1 no es activo, después el adaptador de cableado o el puerto puede ser malo o no enchufado. Si la capa 2 está en un estado de TEI_Assign, significa que el router no se está comunicando con el switch. Refiérase usando el comando show isdn status para el Troubleshooting de BRI para más información sobre los troubleshootinges de conexión ISDN

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas

Nota: Antes de ejecutar un comando debug, consulte Información Importante sobre Comandos Debug.

  • debug dialer - Al mostrar información referente a la causa de cualquier llamada. Esto primarilty sería utilizada para determinar si el router inició la llamada.

  • debug ISDN q931 - Para marcar las conexiones ISDN como usuarios marcan adentro para considerar qué está sucediendo con la llamada ISDN (por ejemplo, si se está cayendo la conexión). Usted puede también comprobar la capacidad portadora (que indica si la llamada es digital o Voz) de esta salida de los debugs.

  • debug ppp nego - Para ver si los detalles de la negociación PPP.

  • PPP chap del debug - Para marcar la autenticación.

‘Resultado de debug’

La salida siguiente del debug ISDN q931 muestra la llamada que conecta usando el DOV. el maui-soho-01 (el cliente) marca maui-nas-08 (el servidor). Note la capacidad portadora de las llamadas para indicar que son llamadas de voz, como se esperaba. maui-nas-08 se configura para tratar las llamadas de voz entrante como las llamadas de datos (en comparación con las llamadas del módem) y la llamada está conectada.

maui-soho-01#ping 10.8.186.134 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.8.186.134, timeout is 2 seconds:
Aug 17 15:48:12.523: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x03

! --- Setup message for outgoing call

Aug 17 15:48:12.531:         Bearer Capability i = 0x8090A2

! --- Bearer Cap indicates that the call is a Voice call(u-law)
! --- An ISDN digital call would be indicated with 0x8890 (for 64k) 
! --- or 0x8890218F (for 56k)

Aug 17 15:48:12.543:         Channel ID i = 0x83
Aug 17 15:48:12.550:         Keypad Facility i = '5556700'
Aug 17 15:48:12.908: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x83

Aug 17 15:48:12.916:         Channel ID i = 0x89

Aug 17 15:48:12.927:         Locking Shift to Codeset 5
Aug 17 15:48:12.931:         Codeset 5 IE 0x2A  i = 0x808001038308, 
'555-6700', 0x8001098001, '<'
Aug 17 15:48:13.130: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x83

! --- maui-nas-08 has accepted the call and responded with the 
! --- CONNECT message

Aug 17 15:48:13.142:         Locking Shift to Codeset 5
Aug 17 15:48:13.150:         Codeset 5 IE 0x2A  i = 0x808001038308, 
'555-6700', 0x8001098909, 'Connected', 0x80010B8001, '('
Aug 17 15:48:13.217: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up.
Aug 17 15:48:13.249: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x03
Aug 17 15:48:14.372: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
changed state to up
Aug 17 15:48:19.185: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5556700

El debug siguiente se obtiene del maui-nas-08 (servidor). Tenga en cuenta que la capacidad portadora indica que la llamada es una llamada de voz. El NAS ha sido configurado para considerar las llamadas de voz entrantes en esa interfaz como llamadas de datos.

maui-nas-08#
Aug 17 15:48:12.765: ISDN BR2/0: RX <-  SETUP pd = 8  callref = 0x13

! --- Setup message for incoming call

Aug 17 15:48:12.765:         Bearer Capability i = 0x8090A2

! --- Bearer Cap indicates that the call is a Voice call(u-law)
! --- An ISDN digital call would be indicated with 0x8890 (for 64k) 
! --- or 0x8890218F (for 56k)

Aug 17 15:48:12.765:         Channel ID i = 0x89
Aug 17 15:48:12.765:         Signal i = 0x40 - Alerting on - pattern 0 
Aug 17 15:48:12.765:         Called Party Number i = 0xC1, '5556700', 
Plan:ISDN, Type:Subscriber(local)
Aug 17 15:48:12.765:         Locking Shift to Codeset 5
Aug 17 15:48:12.765:         Codeset 5 IE 0x2A  i = 0x808001038001118001, '<'

Aug 17 15:48:12.769: ISDN BR2/0: Event: Received a DATA call from  
on B1 at 64 Kb/s

! --- The incoming voice call (on int bri 2/0) is treated as a data call
! --- This is configured (in interface config mode) using 
! --- isdn incoming-voice data

Aug 17 15:48:12.769: ISDN BR2/0: TX ->  CALL_PROC pd = 8  callref = 0x93
Aug 17 15:48:12.773:         Channel ID i = 0x89
Aug 17 15:48:12.773: %LINK-3-UPDOWN: Interface BRI2/0:1, changed state to up
Aug 17 15:48:12.773: BR2/0:1 PPP: Treating connection as a callin
Aug 17 15:48:12.773: BR2/0:1 PPP: Phase is ESTABLISHING, Passive Open
Aug 17 15:48:12.773: BR2/0:1 LCP: State is Listen
Aug 17 15:48:13.073: ISDN BR2/0: TX ->  CONNECT pd = 8  callref = 0x93

! --- The call is accepted and nas-08 responds with the CONNECT message

Aug 17 15:48:13.073:         Channel ID i = 0x89
Aug 17 15:48:13.121: ISDN BR2/0: RX <-  CONNECT_ACK pd = 8  callref = 0x13


! ---Output omitted

...


Información Relacionada


Document ID: 14964