Marcado y acceso remotos : "Red digital de servicios integrados (ISDN), Señalización por canal asociado (CAS)"

Conexión de BRI a PRI usando voz sobre datos

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra para TData sobre la Voz (DOV), que permite que los datos sean enviados sobre una llamada de voz con una línea ISDN.

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • Versión del Cisco IOS Software 12.0

  • Cisco 5300 con cuatro interfaces de la velocidad primaria (PRI)

  • Cisco 2503 con un Basic Rate Interface (BRI)

  • El nombre de host de cada lado

  • Una contraseña para la autenticación PPP

  • Números de teléfono de las líneas ISDN

  • Los IP Addresses de las interfaces de Ethernet en los ambos lados

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Antecedentes

El DOV permite que los datos sean enviados sobre una llamada de voz con una línea ISDN. Una línea ISDN admite llamadas de datos y de voz. Dos Routers que interconecta con las líneas ISDN típicamente utiliza las llamadas de datos (64 kpbs o 56 kbps). Se espera que las llamadas de voz sean generadas por un teléfono o fax. Las llamadas de voz se pueden también generar por un dispositivo conectado con un módem analógico, por ejemplo, un PC ese los diales para arriba con una línea de Servicio telefónico sencillo antiguo (POTS).

En algunas circunstancias, un usuario puede conectar a dos Routers con las llamadas de voz con las líneas ISDN, especialmente cuando la diferencia de precio entre una llamada de datos y una llamada de voz se considera. Las líneas ISDN tienen comúnmente los cargos por llamada para todas las llamadas: local, larga distancia, e international. A veces, el coste de las llamadas de voz es más bajo que el coste de las llamadas de datos.

Para que el Routers comunique con las llamadas de voz entre dos líneas ISDN, la configuración cuidadosa es necesaria hacer al Routers enterado que las llamadas necesitan ser iniciadas como llamadas de voz y que las llamadas de voz entrantes se deben manejar como llamadas de datos. Del lado saliente (de llamada) utilice la opción map-class para definir las llamadas como llamadas de voz:

nombre del marcador map-class

llamada de voz del marcador

Esta clase de asociador define un comportamiento y se debe aplicar a las interfaces ISDN cuando se necesite este comportamiento. Aquí está un ejemplo del comportamiento del map-class en el mapa de marcado y los comandos dialer string:

del dialer map protocol del direccionamiento de la clase del map class del nombre del nombre del host número de teléfono [broadcast]

map class de la clase del número de teléfono de la cadena del dialer

Refiera a la documentación sobre el software del½ del¿Â del Cisco IOSï para el sintaxis completo de estos dos comandos.

En el lado (llamado) entrante, agregue el comando isdn incoming-voice data bajo interfaz Serial<n>:23. Recuerde que todas las llamadas de voz entrantes están tratadas como llamadas de datos. Si usted también quiere soportar las llamadas del módem en la misma línea ISDN, utilice la característica del (RPM) del administrador de agrupamientos de recursos; si no, usted puede separar esos dos servicios en dos diversas líneas ISDN con diversos números de teléfono. Los problemas ocurren si las dos líneas tienen el mismo número; son parte de al grupo Hunt. Una interfaz particular puede dirigir las llamadas de voz como llamadas del módem o las llamadas de voz como llamadas de Data Over Voice, pero no ambas.

Es importante comprender que DOV posee una confiabilidad limitada. Una llamada entre dos líneas ISDN debería brindar un trayecto digital de principio a fin. El equipo, las líneas, y otros recursos que la compañía telefónica utiliza para configurar las llamadas de datos y voces son generalmente lo mismo, solamente ellas puede ser diferente. El transporte de voz digital es más flexible que el transporte de datos. La red telefónica garantiza el transporte de bits a lo largo de un trayecto digital de 64 ó 56 kbps para llamadas de datos ISDN. Para las llamadas de voz, la red telefónica puede rutear y manipular la secuencia de bits en las maneras diferentes con todo no la Calidad de voz de la influencia. Puesto que se corrompen todos los datos cuando están enviados esta manera, DOV no trabaja con algunas líneas ISDN.

Configurar

Esta configuración utiliza un Cisco 5300 con cuatro interfaces de la velocidad primaria (PRI) para terminar las llamadas y un Cisco 2503 con un Basic Rate Interface (BRI) para iniciar las llamadas. El Cisco 5300 proporciona el soporte para 48 llamadas del DOV, 48 llamadas del módem, y 96 llamadas de datos. Los primeros dos PRI se configuran para manejar las llamadas de voz como datos, y los dos más recientes se configuran para manejar las llamadas de voz como llamadas del módem. Un nombre de usuario y contraseña se debe configurar para cada usuario que marque adentro. Esta configuración no utiliza el Terminal Access Controller Access Control System (TACACS+) o el Remote Authentication Dial-In User Service (RADIUS).

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/14962/britopri_dov.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

  • Router 1

  • Router 2

Router 1
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
aaa new-model
AAA authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default if-needed local
enable password somethingSecret
!
username santiago password 0 letmein
username Router2 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type primary-5ess
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 clock source line secondary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 2
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 3
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
interface Ethernet0
 ip address 10.10.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 1
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice data
!
interface Serial1:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 1
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice data
!
interface Serial2:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 2
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice modem
!
interface Serial3:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 2
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice modem
!
interface FastEthernet0
 ip address 10.10.2.1 255.255.255.0
 no ip directed-broadcast
!
interface Group-Async1
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 async mode interactive
 ip tcp header-compression passive
 peer default ip address pool IPaddressPool
 no cdp enable
 ppp authentication chap
 group-range 1 48
 !
interface Dialer1
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer-group 1
 ppp authentication chap
!
interface Dialer2
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer-group 1
 peer default ip address pool IPaddressPool
 ppp authentication chap
!
ip local pool IPaddressPool 10.10.10.1 10.10.10.254
ip classless
ip route 10.8.186.128 255.255.255.240
no ip http server
!
line con 0
 login authentication CONSOLE
 transport input none
line 1 48
 autoselect during-login
 autoselect ppp
 modem Dialin
line aux 0
line vty 0 4
!
end

Router 2
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router2
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router1 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.8.186.134 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer string 5555700 class DOV
 dialer load-threshold 5 outbound
 dialer-group 1
 isdn switch-type basic-5ess
 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 BRI0
no ip http server
!
!
map-class dialer DOV
 dialer voice-call
dialer-list 1 protocol ip permit
!
line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Use esta sección para resolver problemas de configuración.

Comandos para resolución de problemas

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Nota: Consulte Información Importante sobre Comandos de Debug antes de usar un comando debug.

  • debug dialer — Visualiza la información que se refiere a la causa de cualquier llamada

  • debug ISDN q931 — Marca las conexiones ISDN mientras que los usuarios marcan adentro para ver qué sucede con la llamada ISDN, por ejemplo, si se cae la conexión

  • debug ppp nego — Ve los detalles de la negociación PPP

  • PPP chap del debug — Marca la autenticación

  • isdn status de la demostración — El estatus debe ser éste:

    layer 1 = active 
        layer 2 = MULTIPLE_FRAMES_ESTABLISHED 

    Si el Layer 1 no es activo, el adaptador de cableado o el puerto puede ser malo o no enchufado. Si la capa 2 está en un estado del TEI_Assign, el router no habla con el Switch.

  • usuario de la demostración — Visualiza el async/a los usuarios de sincronización conectados actualmente

  • mapa de marcado de la demostración — Después de que se haga una conexión ISDN, considera si un mapa de marcado dinámico fue creado. Sin un asignador de marcado no puede rutear paquetes.

Troubleshooting del módem

  • módem del debug — Ve si el router recibe las señales correctas del módem interno

  • debug modem csm — Habilita la administración del módem el modo del debug del Call Switching Module (CS)


Información Relacionada


Document ID: 14962