Switches : Sistema de switching virtual 1440 Cisco Catalyst 6500

Módulo de Supervisor del reemplace en el Sistema de switching virtual 1440 Cisco Catalyst 6500

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona un procedimiento paso a paso para substituir a un mún supervisor en un sistema de transferencia virtual del Cisco Catalyst 6500.

Un sistema de transferencia virtual (VSS) consiste en dos chasis del Catalyst 6500. Cada chasis se equipa de un solo Supervisor Engine. Si uno de los supervisores muere debido a una falla de hardware, el supervisor del reemplazo que viene con una configuración predeterminada no hace un miembro VSS automáticamente. Este nuevo supervisor inicia inicialmente para arriba en el modo autónomo, y requiere la configuración VSS para iniciar en el modo VSS.

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • Copie la imagen válida del supervisor activo VSS a un Dispositivo Flash compacto.

  • Copie la configuración activa VSS a un Dispositivo Flash compacto (pueden ser lo mismo).

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

Sistema de switching virtual 1440 Cisco Catalyst 6500 en el Software Release 12.2(33)SXH1 o Posterior del½ del¿Â del Cisco IOSïÂ

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Utilice la herramienta Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos utilizados en esta sección.

El nuevo supervisor requiere que usted inicie con una imagen válida y una configuración. La imagen se puede copiar con el TFTP o un Dispositivo Flash compacto. Si el Flash compacta no está disponible, la imagen del software y el archivo de configuración se pueden copiar con el TFTP, también.

  1. Copie la imagen válida del supervisor activo VSS a un Dispositivo Flash compacto.

    VSS#dir sup-bootdisk:
    Directory of sup-bootdisk:/
    1 -rwx 117668516 Jan 22 2008 11:53:58 +00:00 s72033-
       ipservices_wan-vz.122-33.SXH1
    2 -rwx 33554432 Aug 16 2007 12:40:22 +00:00 sea_log.dat
    3 -rwx 7366 Aug 22 2007 20:05:42 +00:00 default-config
    

    Observe que en el modo VSS, el active y los Supervisores en espera funcionan con la misma imagen de la versión de software.

    VSS#copy sup-bootdisk:s72033-ipservices_wan-vz.122-33.SXH1 disk0:
    Destination filename [s72033-ipservices_wan-vz.122-33.SXH1]?
    Copy in progress...CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
       CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    
    !--- Output suppressed.
    
    
  2. Copie la configuración actual del supervisor activo VSS a un Dispositivo Flash compacto.

    VSS#copy running-config disk0:
    Destination filename [startup-config]? <VSS.cfg>
    11196 bytes copied in 0.712 secs (15725 bytes/sec)

Diagrama de la red

En este documento, se utiliza esta configuración de red:

Error del supervisor del Switch2

replace_vss_sup_proc_v1.gif

Instale y configure al nuevo supervisor

Complete estos pasos para instalar y para configurar al nuevo supervisor:

  1. Instale al nuevo supervisor en el chasis y, en caso de que el uplinks del supervisor se utilice para VSL, conéctelo físicamente. Inicie la imagen del Flash compacta.

  2. Borre el archivo de configuración de lanzamiento del nuevo supervisor. Este paso se requiere para asegurarse de que ninguna configuración añeja exista en el nuevo supervisor.

  3. Copie la imagen del software que fue copiada previamente al Dispositivo Flash compacto al nuevo disco de arranque sup del supervisor:

    Router#copy disk0:s72033-ipservices_wan-vz.122-33.SXH1 sup-bootdisk:
    Destination filename [s72033-ipservices_wan-vz.122-33.SXH1]?
    Copy in progress ..CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    117668516 bytes copied in 332.283 secs (354121 bytes/sec)
    
    !--- Output suppressed.
    
    
    !--- If you choose to download software image from a tftp server,
         connect one of the switch interfaces to the network in order to have connectivity 
         to the tftp server. Configure IP address to the management interface; verify 
         the connectivity between the switch and the tftp server.
    
    
    !--- The management IP address should be different from what is 
         already assigned to active VSS switch.
    !--- Configure management IP address
    
    Router(config)#interface gig 1/3
    Router(config-if)#ip address 10.10.10.100 255.255.255.0
    Router(config-if)#no shutdown
    
    !--- verify Management interface status and configuration
    
    Router#show interface gig 1/3
    GigabitEthernet1/3 is up, line protocol is up (connected)
    Hardware is C6k 1000Mb 802.3, address is 0005.dce7.8180 
       (bia 0005.dce7.8180)
    Internet address is 10.10.10.100/24
    
    !--- Output omitted
    !--- If the TFTP server and switch management interface are not in the same 
         layer-3 subnet, add a (default) route.
    
    Router(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.1
    
    !--- verify IP connectivity between switch and TFTP server
    
    Router#ping 10.20.20.200
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.20.20.200, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
    
    !---Copy the new software image into supervisor bootflash:
    
    Router#copy tftp: sup-bootdisk:
    Address or name of remote host []? 10.20.20.200
    Source filename []? s72033-ipservices_wan-vz.122-33.SXH1
    Destination filename [s72033-ipservices_wan-vz.122-33.SXH1]?
    Copy in progress ..CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    
    !--- Output omitted
    
    
  4. Copie la configuración del supervisor activo, que había sido guardada previamente en el Dispositivo Flash compacto, al nuevo archivo de configuración de los lanzamiento-config del supervisor.

    Router#copy disk0:VSS.cfg startup-config
    Destination filename [startup-config]?
    11196 bytes copied in 7.460 secs (1501 bytes/sec)
    Router#

    Nota: Este paso es crítico porque la configuración VSS y cualquier variable de arranque requeridas para iniciar la imagen de software IOS correcta se agregan.

    
    !--- Highlighted VSS configuration commands are critical 
         to boot up the supervisor in VSS mode.
    !--- Verify VSS configuration in the startup-config file
    
    Router#more nvram:startup-config
    !
    hostname VSS
    boot system flash sup-bootdisk:s72033-ipservices_wan-vz.122-33.SXH1
    
    !--- Switch Virtual domain <id> is configured with respective 
         switch priorities
    
    switch virtual domain 1
    switch mode virtual 
    
    !--- this command gets populated upon converting standalone switch to VSS mode. 
         Make sure this command is part the configuration.
    
    switch 1 priority 110
    switch 2 priority 100
    
    
    !--- Verify Virtual Switch Link (VSL) configuration
    
    interface Port-channel1
    no switchport
    no ip address
    switch virtual link 1
    mls qos trust cos
    no mls qos channel-consistency
    !
    interface Port-channel2
    no switchport
    no ip address
    switch virtual link 2
    mls qos trust cos
    no mls qos channel-consistency
    
    !--- Physical interfaces that are part of VSL
    
    interface TenGigabitEthernet1/1/4
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 1 mode on
    
    interface TenGigabitEthernet1/1/5
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 1 mode on
    
    interface TenGigabitEthernet2/1/4
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 2 mode on
    
    interface TenGigabitEthernet2/1/5
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 2 mode on
    
  5. Configure el VSS Switch_ID que identifica un Catalyst 6500 Switch dentro de un dominio virtual de la transferencia. Porque el VSS puede consistir en solamente dos Switches, usted necesita elegir el dependiente 1 o 2 en qué valores se definen en el Switch activo. Usted no puede utilizar ningún valor con excepción de 1 o de 2.

    
    !--- Verify active Switch_ID on the active switch
    
    Router#switch read switch_num local
    Read switch_num from Active rommon is 1
    
    !--- Note that since Switch_ID=1 is used for active switch, 
         we would define Switch_ID=2 in the new supervisor.
    
    
    !--- Configure the Switch_ID on the supervisor.
    
    
    !--- Below command sets a Switch_ID ROMMON variable. 
         It is used during VSS boot up to identify a switch within a VSS domain.
    !--- Note that the Switch_ID doesn’t dictate the state (active vs. standby) of the supervisor.
    
    Router#switch set switch_num 2 local
    Set rommon's switch_num to 2
    
    !--- Verify the Switch_ID configuration on the new supervisor.
    
    Router#switch read switch_num local
    Read switch_num from Active rommon is 2
  6. Recargue el Switch de modo que, cuando usted recarga, el Switch inicia en el modo VSS.

    precaución Precaución: No salve sus ejecutar-config a los lanzamiento-config en este momento. Si usted lo hace, el lanzamiento-config está sobregrabado con la configuración predeterminada, y el Switch no inicia en el modo VSS.

    Ejemplo CLI hecho salir:

    Router# reload
    System configuration has been modified. Save? [yes/no]: no
    Proceed with reload? [confirm]
    00:25:07: %SYS-5-RELOAD: Reload requested by console. 
       Reload Reason: Reload Command.
    00:26:49: %SYS-SP-3-LOGGER_FLUSHING: 
       System pausing to ensure console debugging output.
    00:26:49: %OIR-SP-6-CONSOLE: 
       Changing console ownership to switch processor
    
    !--- Output omitted
    !--- SP booting up, pay attention to the name of the image being loaded by SP
    
    System Bootstrap, Version 8.5(1)
    Copyright (c) 1994-2006 by cisco Systems, Inc.
    Cat6k-Sup720/SP processor with 1048576 Kbytes of main memory
    Autoboot executing command: “ boot system flash 
       sup-bootflash:s72033-ipservices_wan-vz.122-33.SXH1”
    Loading image, please wait ...
    Initializing ATA monitor library...
    Self decompressing the image : 
       ######################################
       #####################################
    Restricted Rights Legend
    Use, duplication, or disclosure by the Government is
    subject to restrictions as set forth in subparagraph
    (c) of the Commercial Computer Software - Restricted
    Rights clause at FAR sec. 52.227-19 and subparagraph
    (c) (1) (ii) of the Rights in Technical Data and Computer
    Software clause at DFARS sec. 252.227-7013.
    cisco Systems, Inc.
    170 West Tasman Drive
    San Jose, California 95134-1706
    Cisco IOS Software, s72033_sp Software 
       (s72033_sp-IPSERVICES_WAN-VM), 
       Version 12.2(33)SXH1, RELEASE SOFTWARE (fc3)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2008 by Cisco Systems, Inc.
    Compiled Thu 17-Jan-08 04:38 by prod_rel_team
    Image text-base: 0x01020150, data-base: 0x01021000
    
    !--- VSS configuration pre-parsed during bootup
    
    System detected Virtual Switch configuration...
    Interface TenGigabitEthernet 2/8/4 is member of Portchannel 2
    
    
    !--- output omitted
    
    Initializing as Virtual Switch STANDBY processor
    
    !--- VSL module ( supervisor in this scenario) 
         brought up and role is resolved as standby 
         since there is already a active VSS switch.
    
    
    00:00:30: %VSL_BRINGUP-6-MODULE_UP: 
       VSL module in slot 8 switch 2 brought up
    00:00:57: %VSLP-5-VSL_UP: 
       Ready for Role Resolution with Switch=1, 
       MAC=0014.1bc6.1c00 over 8/4
    00:01:01: %VSLP-5-RRP_ROLE_RESOLVED: 
       Role resolved as STANDBY by VSLP
    00:01:01: %VSL-5-VSL_CNTRL_LINK: New VSL Control Link 8/4
    
    !--- RP is booting up
    
    System Bootstrap, Version 12.2(17r)SX5, RELEASE SOFTWARE (fc1)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 2006 by cisco Systems, Inc.
    Cat6k-Sup720/RP platform with 1048576 Kbytes of main memory
    Download Start
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    Restricted Rights Legend
    Use, duplication, or disclosure by the Government is
    subject to restrictions as set forth in subparagraph
    (c) of the Commercial Computer Software - Restricted
    Rights clause at FAR sec. 52.227-19 and subparagraph
    (c) (1) (ii) of the Rights in Technical Data and Computer
    Software clause at DFARS sec. 252.227-7013.
    cisco Systems, Inc.
    170 West Tasman Drive
    San Jose, California 95134-1706
    Cisco IOS Software, s72033_rp Software (s72033_rp-IPSERVICES_WAN-VM), 
       Version 12.2(33)SXH1, RELEASE SOFTWARE (fc3)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2008 by Cisco Systems, Inc.
    Compiled Thu 17-Jan-08 04:04 by prod_rel_team
    Image text-base: 0x01020150, data-base: 0x01021000
    
    !--- output omitted
    
    Press RETURN to get started!
    
    !--- Look out for –- 
         “%PFREDUN-SW2_SPSTBY-6-STANDBY: Initializing for SSO mode”
         in the active console to make sure stadby is running in SSO mode.
    !--- After standby boots up it’s console is locked
    
    VSS-sdby>
    Standby console disabled
    VSS-sdby>
    Standby console disabled

    Nota: Para configurar el VSS en las subredes múltiples, la configuración espera no se necesita en el VSS. Los routeres de gateway deben ser configurados como el VLA N SVI.

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Discordancía del software entre los motores del supervisor

Si hay una discordancía del software entre los motores del supervisor, el supervisor standy sube en el modo de redundancia RPR (no en el modo de redundancia SSO), y el VSS no se inicializa completamente.

Para resolver el problema, aseegurese que el software requerido está presente en el flash del supervisor standy y las sentencias de arranque señalan al software correcto. Recargue al supervisor standy de modo que inicie con el software correcto y se una al VSS.


Información Relacionada


Document ID: 109334