Switches : Switches Cisco Catalyst de la serie 6500

Ejemplo de Configuración de Switches Catalyst para Balanceo de Carga de Red de Microsoft

31 Julio 2013 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (6 Junio 2013) | Comentarios

Introducción

Este documento describe cómo configurar los switches Cisco Catalyst para interactuar con Microsoft Network Load Balancing (NLB).

Contribuido por Shashank Singh, ingeniero de Cisco TAC.

Prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Catalyst 6500 Switch que funciona con el software de Cisco IOS®

  • Cisco IOS Software corriente del Catalyst 4500 Switch

  • Cisco IOS Software corriente del Catalyst 3550 Switch

  • Cisco IOS Software corriente del Catalyst 3560 Switch

  • Cisco IOS Software corriente del Catalyst 3750 Switch

  • Microsoft Windows 2000/2003 servidor

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando. 

Antecedentes

La tecnología de equilibrio de la carga de la red (NLB) se puede utilizar para distribuir los pedidos de cliente a través de un conjunto de los servidores. Para aseegurar a los clientes experimente siempre los niveles de rendimiento aceptable, Windows NLB es de uso frecuente asegurarse de que usted puede agregar los servidores adicionales para escalar hacia fuera las aplicaciones apátridas, tales como servidores Web IIS-basados, pues la carga del cliente aumenta. Además, reduce el tiempo muerto causado por los servidores que funcionan incorrectamente. Los usuarios finales nunca sabrán que un servidor miembro determinado en Windows NLB está o ha estado abajo.

El equilibrio de la carga de la red es una tecnología de clúster ofrecida por Microsoft como parte de todos los sistemas operativos 2003 de la familia Windows 2000 Server y del Servidor Windows. NLB utiliza un algoritmo distribuido para cargar el tráfico de la red de la balanza a través de varios servidores.

NLB lía los servidores en un grupo de multidifusión e intenta utilizar el IP de multidifusión y la dirección MAC estándar. Al mismo tiempo, proporciona un solo IP virtual para todos los clientes como el IP de destino, que significa que los servidores se unen a al mismo grupo de multidifusión, y los clientes no sabrán cualquier cosa sobre él. Utilizan el acceso normal del unicast al VIP.

Usted puede configurar NLB para trabajar en uno de estos modos:

Modo unidifusión

La configuración predeterminada NLB es modo unidifusión. En el modo unidifusión, NLB substituye la dirección MAC real de cada servidor en el cluster a una dirección MAC común NLB. Cuando todo el servidor en el cluster tiene la misma dirección MAC, todos los paquetes remitidos a ese direccionamiento se envían a todos los miembros del cluster. Sin embargo, un problema con esta configuración es cuando el cluster de los servidores NLB está conectado con el mismo Switch, usted no puede hacer que dos puertos en el Switch registren la misma dirección MAC. NLB soluciona este problema enmascarando la dirección MAC del cluster. El Switch mira el MAC Address de origen en la encabezado de la trama Ethernet para aprender qué direcciones MAC se asocian a sus puertos. NLB crea una dirección MAC falsa y la asigna que dirección MAC falsa a cada servidor en el cluster NLB. NLB asigna a cada servidor NLB una diversa dirección MAC falsa basada en el ID del host del miembro. Este direccionamiento aparece en la encabezado de la trama Ethernet.

Por ejemplo, la dirección MAC del cluster NLB es 00-bf-ac-10-00-01. ¿NLB en el modo unidifusión toma la dirección MAC del cluster y, para cada miembro de clúster, NLB cambia al segundo octeto de modo que consista en el miembro NLB? la identificación del host s por ejemplo, el servidor número 1 como la dirección MAC falsa 00-01-ac-10-00-01, ID del host número 2 tiene la dirección MAC falsa 00-02-ac-10-00-01, tan encendido. Si una dirección MAC única se registra en cada puerto del switch, los paquetes no se entregan a todos los miembros del arsenal; los paquetes se deben todavía enviar bastante a los puertos del switch individuales basados en la dirección MAC asignada a ese puerto. Para se utiliza hacer las tramas entregadas a todos los miembros del NLB para agruparla cuando cada puerto del switch conectado con un miembro de clúster NLB registra una diversa dirección MAC utiliza un broadcast ARP. Cuando el router envía un pedido ARP para la dirección MAC de la dirección IP virtual, la contestación contiene un encabezado ARP con la dirección MAC real 00-bf-ac-10-00-01 del cluster NLB, según el ejemplo dado arriba y no la dirección MAC falsa.

Los clientes utilizan la dirección MAC en el encabezado ARP, no el encabezado Ethernet. El Switch utiliza la dirección MAC en el encabezado Ethernet, no el encabezado ARP. El problema es cuando un cliente envía un paquete al cluster NLB con la dirección MAC del destino como dirección MAC 00-bf-ac-10-00-01 del cluster, el Switch mira la tabla CAM para la dirección MAC 00-bf-ac-10-00-01. Puesto que no hay puerto registrado con la dirección MAC 00-bf-ac-10-00-01 del cluster NLB, la trama se entrega a todos los puertos del switch. Esto introduce la inundación del Switch. La inundación del Switch causa los problemas cuando está fluyendo la cantidad significativa de tráfico y también al tener otros servidores en lo mismo conmute. Una solución para conmutar la inundación es poner a Hub simple delante de los miembros y entonces del uplink del cluster NLB el concentrador a un puerto del switch. Esta solución ni siquiera necesita enmascarar la dirección MAC del cluster NLB porque el puerto del un solo switch conectado con el concentrador aprende la dirección MAC del cluster NLB. Esto evita el problema de dos puertos del switch que registran la misma dirección MAC. Cuando el cliente envía los paquetes al NLB agrupan la dirección MAC, los paquetes van directamente al puerto del switch conectado con el concentrador y entonces con los miembros del cluster NLB.

Modo de multidifusión

Otra solución es utilizar el modo del Multicast en configuración GUI MS NLB en vez del modo unidifusión. En el modo de multidifusión, el System Admin hace clic el botón del Multicast IGMP en la configuración GUI MS NLB. Esta opción da instrucciones a los miembros del cluster para responder a los ARP para su dirección virtual que usa un Multicast MAC Address por ejemplo 0300.5e11.1111 y para enviar los paquetes del informe de afiliación IGMP. Si el IGMP Snooping se habilita en el switch local, snoops los paquetes IGMP que pasan a través de él. ¿De esta manera, cuando un cliente ARP para el cluster? la dirección IP virtual s, el cluster responde con el Multicast MAC por ejemplo 0300.5e11.1111. Cuando el cliente envía el paquete a 0300.5e11.1111, el switch local adelante que el paquete hacia fuera cada uno de los puertos conectó con los miembros del cluster. En este caso, no hay ocasión de inundar el paquete ARP fuera de todos los puertos. El problema con el modo del Multicast es dirección IP virtual llega a ser inalcanzable cuando está accedido desde fuera de la subred local porque los dispositivos de Cisco no validan una contestación arp para un Unicast IP Address que contenga un Multicast MAC Address. La porción MAC de la entrada ARP muestra tan como incompleto. (Publique el comando show arp de ver la salida.) Pues no hay porción MAC en la contestación arp, la entrada ARP nunca apareció en la tabla ARP. Salió ARPing y volvió eventual un ICMP imposible acceder al host a los clientes. Para reemplazar esto, utilice la entrada ARP estática para poblar la tabla ARP según lo dado abajo. En la teoría, esto permite que el dispositivo de Cisco pueble su mac-address-table. Por ejemplo, si la dirección IP virtual es 172.16.63.241 y el Multicast MAC Address es 0300.5e11.1111, utilice este comando para poblar la tabla ARP estáticamente:

arp 172.16.63.241 0300.5e11.1111

Sin embargo, puesto que los paquetes entrantes tienen un IP Address de destino y un destino multidifusión MAC del unicast el dispositivo de Cisco ignora esta entrada y proceso-Switches los paquetes de cada cluster-límite. Para evitar este process switching, inserte una entrada a Tabla de MAC Addresses estática según lo dado abajo para conmutar los paquetes del cluster-límite en hardware.

mac-address-table static 0300.5e11.1111 vlan 200 interface
fa2/3 fa2/4

Nota: Estáticamente asociar el MAC a los puertos múltiples se soporta solamente en el software en el Catalyst 4500 Switch. Usando esta configuración en el Catalyst 4500 Switch puede causar CPU elevada.

 

Nota: Para el Switches de las 6000/6500 Series del Cisco Catalyst, usted debe agregar el parámetro de la neutralización-snopping. Por ejemplo:

mac-address-table static 0300.5e11.1111 vlan 200
interface fa2/3 fa2/4 disable-snooping

El parámetro del neutralización-snooping es esencial y aplicable solamente para el Switches de las 6000/6500 Series del Cisco Catalyst. Sin esta declaración, el comportamiento no es afectado.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Utilice la herramienta Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos utilizados en esta sección.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

Configuraciones

Este documento utiliza la configuración del Catalyst 6509 descrita en esta sección.

Cat6K#show running-config
Building configuration...
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6K
!
boot buffersize 126968
boot system flash slot0:c6sup11-jsv-mz.121-8a.E.bin
!
redundancy
main-cpu
auto-sync standard
ip subnet-zero
!
!
interface GigabitEthernet1/1
no ip address
shutdown
!
interface GigabitEthernet1/2
no ip address
shutdown
!
interface FastEthernet2/1
description "Uplink to the Default Gateway"
no ip address
switchport
switchport access vlan 100
!
interface FastEthernet2/2
no ip address
shutdown
!
interface FastEthernet2/3
description "Connection to Microsoft server"
no ip address
switchport
switchport access vlan 200
!
interface FastEthernet2/4
description "Connection to Microsoft server"
no ip address
switchport
switchport access vlan 200
!
interface FastEthernet2/5
no ip address
shutdown
!
interface FastEthernet2/48
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
mac-address-table static 0300.5e11.1111 vlan 200 interface fa2/3 fa2/4 disable-snooping

! --- Creating a static entry in the switch for the multicast virtual mac.

! --- fa2/3 & fa2/4 are the ports connected to server.

!--- The disable-snooping is applicable only for Cisco Catalyst 6000/6500 series switches

arp 172.16.63.241 0300.5e11.1111

! --- 172.16.63.241 is the Virtual IP of 2 servers

interface Vlan100
ip address 172.17.63.240 255.255.255.192

!--- Client Side Vlan
!
interface Vlan200
ip address 10.1.1.250 255.255.255.0

!--- Server Vlan

!--- Important: Configure the default gateway

!--- of the Microsoft Server to this address.

!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.63.193
no ip http server
!
line con 0
line vty 0 4
login
!
end

Nota: Asegúrese de que usted utilice el modo del Multicast en el cluster NLB. Cisco recomienda que usted no utiliza los Multicast MAC Address que comienzan con 01 porque se saben para tener un conflicto con la configuración IGMP.

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

  • mac-address-table de la demostración - Visualiza los parásitos atmosféricos de la tabla de la dirección MAC y una entrada dinámica específica o los parásitos atmosféricos y las entradas dinámicas de la tabla de la dirección MAC en una interfaz o un VLA N específica.

    Cat6K#show mac-address-table 0300.5e11.1111

              Mac Address Table
    -------------------------------------------

    Vlan    Mac Address      vType        Ports
    ---- -----------      --------     -----
    200    0300.5e11.1111     STATIC    Fa2/3 Fa2/4
  • muestre el IP arp - Visualiza el caché del Address Resolution Protocol (ARP).

    Cat6K#show ip arp
    Protocol  Address          Age (min)  Hardware Addr   Type   Interface
    Internet  172.16.1.1            -     0300.5e11.1111  ARPA   Vlan200

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Información Relacionada


Comunidad de Soporte de Cisco - Conversaciones Destacadas

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas. Aquí están algunas de las charlas más importantes presentadas en nuestro foro.


Document ID: 107995