Switches : Switches Cisco Catalyst de la serie 6500

Ejemplo de Configuración de Switches Catalyst para Balanceo de Carga de Red de Microsoft

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (6 Octubre 2015) | Comentarios

Introducción

Este documento describe cómo configurar el Switches del Cisco Catalyst para obrar recíprocamente con el Equilibrio de carga de la red de Microsoft (NLB).

Contribuido por Ambrose Taylor, Dale Miller, y Shashank Singh, ingenieros de Cisco TAC.

Prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco Catalyst 6500 Series Switch con el Supervisor Engine 2T (Sup2T) esa versión 15.1(1)SY1 del Cisco IOS ® Software del funcionamiento

  • Cisco Catalyst 4948 Series Switch que funcionan con la versión del Cisco IOS Software 15.0(2)SG7

  • Servidores de Microsoft Windows

Nota: Consulte la guía de configuración apropiada para los comandos que se utilizan para habilitar estas características en otras Plataformas de Cisco.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Antecedentes

La tecnología NLB se puede utilizar para distribuir los pedidos de cliente a través de un conjunto de los servidores. Para asegurarse de que los clientes experimenten siempre los niveles de rendimiento aceptable, Microsoft Windows NLB proporciona la capacidad de agregar los servidores adicionales de modo que usted pueda escalar hacia fuera las aplicaciones apátridas, tales como servidores Web IIS-basados, pues la carga del cliente aumenta. Además, reduce el tiempo muerto que es causado por los servidores que funcionan incorrectamente.

Microsoft Windows NLB es una tecnología de clúster que se ofrece como una parte de toda Windows 2000 Server y Windows 2003 sistemas operativos de la familia del servidor. Proporciona a una sola dirección IP virtual para todos los clientes como el IP Address de destino para el cluster entero.

Usted puede configurar NLB para trabajar en uno de estos tres modos:

  • Modo unidifusión
  • Modo de multidifusión
  • Modo del Internet Group Management Protocol (IGMP)

Modo unidifusión

Aquí están algunas notas sobre el uso de NLB en el modo unidifusión:

  • En el modo unidifusión, NLB substituye el Media Access Control (MAC) Address real de cada servidor en el cluster por una dirección MAC común NLB. Cuando todos los servidores en el cluster tienen la misma dirección MAC, todos los paquetes que se remiten a ese direccionamiento se envían a todos los miembros en el cluster. El NLB crea una dirección MAC ficticia y la asigna a cada servidor en el cluster NLB. El NLB asigna a cada servidor NLB una diversa dirección MAC ficticia, sobre la base del ID del host del miembro. Este direccionamiento aparece en la encabezado de la trama Ethernet.

  • La dirección MAC se utiliza en la encabezado del Address Resolution Protocol (ARP), no el encabezado Ethernet. El Switch utiliza la dirección MAC en el encabezado Ethernet, no el encabezado ARP. Esto causa un problema cuando un paquete se envía al cluster NLB con la dirección MAC del destino como la dirección MAC 00-bf-ac-10-00-01 del cluster. El Switch ve la tabla del Content Addressable Memory (CAM) para la dirección MAC 00-bf-ac-10-00-01, y puesto que no hay puerto registrado con la dirección MAC 00-bf-ac-10-00-01 del cluster NLB, la trama se entrega a todos los puertos del switch. Esto introduce la Inundación de unidifusión. Para evitar inundar, Cisco recomienda que usted utiliza un vlan dedicada para NLB para obligar la inundación.

Modo de multidifusión

Aquí están algunas notas sobre el uso de NLB en el modo de multidifusión:

  • En el modo de multidifusión, el administrador de sistema hace clic el botón del Multicast en la configuración GUI de Microsoft NLB. Esta opción da instrucciones a los miembros del cluster para responder a los ARP para su dirección virtual con el uso de un Multicast MAC Address, tal como 0300.5e01.0101.

  • El proceso ARP no completa para los Multicast MAC Address (éste rompe el RFC 1812). Un Static MAC Address se requiere para alcanzar el cluster fuera de la subred local.

  • La dirección IP virtual es 10.100.1.99 y el Multicast MAC Address es 0300.5e01.0101. Ingrese este comando para poblar la tabla ARP estáticamente:
    arp 10.100.1.99 0300.5e01.0101
  • Puesto que los paquetes de entrada tienen un IP Address de destino del unicast y una dirección MAC del destino multidifusión, el dispositivo de Cisco ignora esta entrada y el unicast inunda cada paquete del cluster-límite. Para evitar esta inundación, inserte una entrada a Tabla de MAC Addresses estática para conmutar los paquetes del cluster-límite en el hardware:
    mac address-table static 0300.5e01.0101 vlan 200 interface TenGigabitEthernet1/4
    TenGigabitEthernet1/5

Nota: Cuando usted asocia estáticamente una dirección MAC a los puertos múltiples, es soportada solamente por el software en el Cisco Catalyst 4500 Series Switch. También, el uso de esta configuración en el Catalyst 4500 Series Switch pudo causar CPU elevada. Para evitar este problema, usted puede aislar el NLB a un VLA N específico, agrega solamente las entradas ARP estáticas, y permite el inundar en ese VLA N.

Modo IGMP

Aquí están algunas notas sobre el uso de NLB en el modo IGMP:

  • El uso de NLB en el modo IGMP requiere la menos cantidad de configuración manual. La dirección MAC virtual cae dentro del rango y del comienzo del Internet Assigned Numbers Authority (IANA) con 0100.5exx.xxxx. Puesto que el MAC address ahora se ajusta a las especificaciones IANA, los switches Cisco pueden programar dinámicamente el MAC address con el uso del IGMP Snooping. Esto quita la necesidad de programar manualmente la dirección MAC a los mapas del puerto que se requieren en el modo de multidifusión para evitar el inundar al VLA N.

  • El IGMP Snooping programa el MAC address virtual para usted una vez que el Switch recibe un informe de afiliación de un miembro en el cluster. Un puerto del mrouter se debe también programar para el VLA N NLB con el uso de la multidifusión independiente de protocolo (PIM) o de la característica del interrogador IGMP.

  • Puesto que la dirección IP virtual utiliza un Multicast MAC Address, es exterior inalcanzable de la subred local. Para dirigir esto, usted debe configurar una entrada ARP estática en cada dispositivo con una interfaz de la capa 3 (L3) en el VLA N del cluster. Complete esto en la misma moda que con el modo de multidifusión. Por ejemplo, si la dirección IP virtual es 10.100.1.99 y el Multicast MAC Address es 0100.5e01.0101, utilice este comando para poblar la tabla ARP estáticamente:
    arp 10.100.1.99 0100.5e01.0101

Advertencias

Aquí están las NOTAS IMPORTANTES a tener presente cuando usted utiliza NLB en el modo IGMP:

  • Según lo seguido en el Id. de bug Cisco CSCsw72680, usted no puede utilizar el PIM en la interfaz virtual del Switch del VLA N NLB (SVI) con ciertas versiones del código. Vea los detalles del bug para las versiones de código que abordan este problema o utilizan la función interrogador del IGMP Snooping.

  • Según lo seguido en el Id. de bug Cisco CSCsy62709, los paquetes se duplican para todo el tráfico que se rutee a los servidores NLB en el modo IGMP. Vea los detalles del bug para las versiones del código afectadas.

  • Debido a una limitación del hardware que sea seguida por el Id. de bug Cisco CSCug49149, el tráfico NLB no se puede enviar a través de un EtherChannel distribuido en los mismo 6708 linecard cuando el Switch se ejecuta en el modo del PFC3B o PFC3C. El canal del puerto debe ser telegrafiado de modo que todos los links de miembro estén en el mismo motor de reenvío.

Configurar

Esta sección describe cómo configurar NLB para las Plataformas de las Cisco Catalyst 6500 y 4948 Series que se ejecutan en el Multicast o el modo IGMP.

Diagrama de la red

Configuración para el modo de multidifusión

Esta sección describe cómo configurar NLB para las Plataformas de las Cisco Catalyst 6500 y 4948 Series que se ejecutan en el modo de multidifusión:

6500-1#show running-config
Building configuration...
!
hostname 6500-1
!
boot system flash disk0:s2t54-adventerprisek9-mz.SPA.151-1.SY1
!
interface TenGigabitEthernet1/4
switchport
switchport trunk allowed vlan 1,100,200
switchport mode trunk
!
interface TenGigabitEthernet1/5
switchport
switchport trunk allowed vlan 1,100,200
switchport mode trunk
!
interface Vlan100
ip address 10.100.1.1 255.255.255.0

!
!        
interface Vlan200
ip address 10.200.1.1 255.255.255.0

!
!
arp 10.100.1.88 0300.5e01.0101 ARPA
!
!
mac address-table static 0300.5e01.0101 vlan 200 interface TenGigabitEthernet1/4
TenGigabitEthernet1/5 TenGigabitEthernet5/5

!
end

Aquí están algunas NOTAS IMPORTANTES sobre esta configuración:

  • El valor del IP Address de la interfaz Vlan100 configura el VLAN de usuario.

  • El valor del IP Address de la interfaz Vlan200 configura el VLA N del cluster NLB. Es importante que usted configura el default gateway del servidor de Microsoft a este direccionamiento.

  • El arp 10.100.1.88 0300.5e01.0101 ARPA incluye todas las interfaces L3 en el VLA N y es la dirección IP virtual de los servidores del cluster NLB.

  • La interfaz vlan estática 0300.5e01.0101 200 de la tabla de direcciones del mac crea una entrada MAC estática a la correlación de puertos en el Switch para la dirección MAC virtual del Multicast.

Nota: Asegúrese de que usted utilice al modo de multidifusión en el cluster NLB. Cisco recomienda que usted no utiliza los Multicast MAC Address que comienzan con 01 porque se saben para tener un conflicto con la configuración IGMP.

4948-1#show running-config
Building configuration...
!
hostname 4948-1
!
boot system bootflash:cat4500-entservices-mz.150-2.SG7
!
interface GigabitEthernet1/1
 switchport access vlan 200
!
interface TenGigabitEthernet1/49
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
interface TenGigabitEthernet1/50
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
mac address-table static 0300.5e01.0101 vlan 200 interface Gi1/1 Te1/49 Te1/50
!
!
end

Nota: La interfaz vlan estática 0300.5e01.0101 200 de la tabla de direcciones del mac crea una Entrada estática en el Switch para la dirección MAC virtual del Multicast. Es importante recordar que todas las interfaces de tronco que llevan el tráfico NLB entre el Switches deben ser agregadas. Una vez que se define un Static MAC Address, se obliga el inundar. Si usted olvida incluir una interfaz, el cluster NLB se rompe. 

Configuración para el modo IGMP

Esta sección describe cómo configurar NLB para las Plataformas de las Cisco Catalyst 6500 y 4948 Series que se ejecutan en el modo IGMP:

6500-1#show running-config
Building configuration...
!
hostname 6500-1
!
boot system flash disk0:s2t54-adventerprisek9-mz.SPA.151-1.SY1
!
ip igmp snooping querier
!
!
vlan configuration 1,100
 no ip igmp snooping querier
!        
vlan configuration 200
ip igmp snooping querier address 10.200.1.1
!
!
interface TenGigabitEthernet1/4
 switchport
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
interface TenGigabitEthernet1/5
 switchport
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
!
interface Vlan100
 ip address 10.100.1.1 255.255.255.0

!
!        
interface Vlan200
 ip address 10.200.1.1 255.255.255.0

!
!
arp 10.100.1.99 0100.5e01.0101 ARPA
!
!
end

Aquí están algunas NOTAS IMPORTANTES sobre esta configuración:

  • El querier del IGMP Snooping del IP habilita la característica del consultor indagador.

  • El direccionamiento 10.200.1.1 del querier del IGMP Snooping del IP configura el consultor indagador para el VLA N NLB.

  • El VLAN de usuario es la interfaz Vlan100.

  • El VLA N del cluster NLB es la interfaz Vlan200. Es importante que usted configura el default gateway del servidor de Microsoft a este direccionamiento (dirección IP 10.200.1.1 255.255.255.0).

  • El arp 10.100.1.99 0100.5e01.0101 ARPA es la dirección IP virtual de los servidores del cluster NLB. El ARP estático debe estar en todas las interfaces L3 en el VLA N.

4948-1#show running-config
Building configuration...
!
hostname 4948-1
!
boot system bootflash:cat4500-entservices-mz.150-2.SG7
!
interface GigabitEthernet1/1
 switchport access vlan 200
!
interface TenGigabitEthernet1/49
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
interface TenGigabitEthernet1/50
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
end

Nota: No hay necesidad de configurar las Entradas estáticas, pues el IGMP Snooping hace esto dinámicamente en este modo. También, no se requiere ninguna configuración especial para este modo en el Switches rio abajo de la capa 2 (L2).

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

Nota: La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Verificación del modo de multidifusión

Ingrese el comando show ip arp para ver la memoria caché ARP:

6500-1#show ip arp
Protocol Address         Age (min) Hardware Addr   Type   Interface
Internet 10.100.1.99            -   0300.5e01.0101  ARPA

Ingrese el comando static de la tabla de direcciones del mac de la demostración para ver los parásitos atmosféricos de la tabla del MAC address y una entrada dinámica específica o los parásitos atmosféricos y las entradas dinámicas de la tabla del MAC address en una interfaz o un VLA N específica:

6500-1#show mac address-table static add 0300.5e01.0101

vlan   mac address    type   learn    age      ports
----+---------------+-------+-----+------+-----------------
200 0300.5e01.0101   static   No       -  Te1/4 Te1/5 Te5/5
4948-1#show mac address-table static add 0300.5e01.0101

Multicast Entries
vlan    mac address     type   ports
------+---------------+-------+--------------------
200    0300.5e01.0101   static Gi1/1,Te1/49,Te1/50

Verificación del modo IGMP

Ingrese el comando show ip arp para ver la memoria caché ARP:

6500-1#show ip arp

Protocol Address       Age (min) Hardware Addr   Type   Interface
Internet 10.100.1.99         -   0100.5e01.0101  ARPA

Ingrese el mrouter del IGMP Snooping del IP de la demostración para ver el puerto del mrouter que es programado por las interrogaciones recibidas del consultor indagador por aguas arriba:

4948-1#show ip igmp snooping mrouter

Vlan    ports
----    -----
 200   Te1/49(dynamic)

Ingrese el IGMP Snooping del Multicast de la tabla de direcciones del mac de la demostración para ver el MAC address dinámico-agregado que es docto del IGMP Snooping y de los puertos de miembro:

4948-1#show mac address-table multicast igmp-snooping

Multicast Entries
 vlan   mac address     type    ports
------+---------------+------+-------------
 200   0100.5e01.0101  igmp Gi1/1,Te1/49

Ingrese a los grupos del IGMP Snooping del IP de la demostración para ver la lista de puertos de miembros del cluster que se unieron a al grupo de multidifusión:

4948-1#show ip igmp snooping groups

Vlan      Group      Version    Port List
-----------------------------------------
200       239.1.1.1   v2         Gi1/1

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 107995