Voz y Comunicaciones unificadas : Cisco Unified Border Element

Ejemplo de configuración de transcodificación unificado del elemento de la frontera

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

El Cisco Unified Border Element (CUBO) soporta la transcodificación para las llamadas que pasan a través y que requieren diverso codecs en los dos tramos de llamada. La transcodificación entre el diverso codecs se soporta, y el CUBO inserta un transcoder basado en la configuración así como una discordancía entre el codecs negociada en los dos tramos de llamada de las llamadas.

La transcodificación requiere DSPs terminar la secuencia RTP y decodificar y codificar la carga útil de voz con el codificador-decodificador apropiado. El DSPs usado por el CUBO para transcodificar puede ser coresidente en el mismo router como CUBO o se puede situar en una plataforma del router separado.

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

Componentes Utilizados

La información en este documento se basa encendido:

  • Cisco Unified Border Element que se ejecuta en un Cisco 3745 Router y utiliza el Cisco IOS Release 12.3.11T o Posterior

  • Recursos DSP de transcodificación en un servidor de acceso de Cisco AS5400XM con una placa de función AS5X-FC poblados con los indicadores luminosos LED amarillo de la placa muestra gravedad menor del DSP AS5X-PVDM2-64

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Utilice la herramienta Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos utilizados en esta sección.

Diagrama de la red

Esta figura muestra un ejemplo del CUBO con DSPs externo para transcodificar:

/image/gif/paws/100480/cube_transcode.gif

Los recursos DSP pueden también ser internos (o coresidente de) a la plataforma del mismo router que los host CUBICAN. Si éste es el caso, el control de los recursos DSP es local al router, y el flujo de control del SCCP en la figura no está presente.

Los recursos DSP que el CUBO utiliza para transcodificar deben ser configurados sin importar independientemente de si el DSPs es coresidente con el CUBO. La única diferencia en las configuraciones es el IP Addressing entre el CUBO y los recursos DSP. Para una configuración del coresidente, la dirección IP es lo mismo para ambos.

Pasos de configuración

Esta sección describe cómo configurar el DSP externo que transcodifica. Utilizan a un Cisco 3745 Router como CUBO, y un AS5400XM se utiliza para recibir a los recursos DSP para transcodificar.

La configuración se aplica a este flujo de llamada:

  1. La llamada empieza con el OGW hacia el CUBO vía H.323 con G.711.

  2. CUBIQUE adelante la llamada vía H.323 al OGW (que se configura para G.729).

  3. Para la configuración de la llamada al TGW a ser acertado, una conversión codec se requiere de G.711 a G.729. Si los recursos de transcodificación están no configurados o disponibles, la configuración de la llamada falla.

Configuración del CUBO para el control de transcodificación del externo

Configuran a un router del CUBO para controlar a los recursos DSP para transcodificar. Esta configuración utiliza el comando telephony-service, que es similar a la configuración de transcodificación para Cisco unificó al administrador de la comunicación expreso. Los recursos DSP se registran con la entidad que controla (que en este ejemplo es CUBO, pero podría también ser CUCME o CUCM).

CUBO 3745
vdouut3#show running-config | begin telephony
!
telephony-service
sdspfarm units 1 -- Specifies the maximum number of DSP farms that can
                    be registered to CUBE. A maximum of 5 DSP resource units
                    (farms) can be configured.
sdspfarm transcode sessions 128 -- Specifies the maximum transcoding
                    sessions supported across all DSP farms registered
                    with CUBE.
sdspfarm tag 1 vdouut1 -- Specifies the device name of the DSP farm. For
                    uniqueness the device name can be the MAC address of the 
                    DSP source interface. In this example the hostname of
                    the DSP farm router is used.
ip source-address 1.2.61.73 port 2000 – The IP address and port-no: (TCP)
                    of the interface through which SCCP messages are
                    transmitted/received from CUBE.

Configuración del dsp farm para recibir a los recursos DSP de transcodificación del externo

Configuran a un router para recibir a los recursos DSP para transcodificar usado por una entidad que controla, que en este ejemplo es CUBO en un diverso router. Registran a los recursos DSP con la entidad que controla para ponerlos a disposición los flujos de llamada.

Dsp farm
vdouut1#show running-config | begin voice-card
voice-card 1
  dsp services dspfarm –- This makes the DSPs available for “DSP farming”
                    which includes transcoding services.

vdouut1#show running-config | begin sccp
sccp local GigabitEthernet0/0 -- Defines the source interface of the DSP
                    farm through which SCCP messages are exchanged with
                    controlling CUBE.               
sccp ccm 1.2.61.73 identifier 1 -- Specifies the IP address of the CUBE
                    system that the DSP farm registers to. This should
                    match the CUBE IP address on the “ip source-address”
                    configuration on CUBE.
sccp
sccp ccm group 1 -- Group configuration for linking “sccp ccm global”
                    configurations as well as the dspfarm profile(s)
  bind interface GigabitEthernet0/0
associate ccm 1 priority 1 -- Associate the sccp identifier “ccm” with
                  the “sccp ccm group”.
associate profile 1 register vdouut1 -- Associate the dspfarm profile 
                  with the DSP farm device name. In this example the 
                  hostname of the DSP farm hosted router is used
                  (vdouut1). The same name must be used on CUBE where
                  “sdspfarm tag 1” is configured.
!
dspfarm profile 1 transcode -- Configure the dspfarm profile to define
                     the codecs supported, the maximum sessions, and
                     enable SCCP.
  codec g711ulaw
  codec g711alaw
  codec g729ar8
  codec g729abr8
  codec g729r8
  codec g729br8
  maximum sessions 128
  associate application SCCP

Configuraciones de muestra completas para la transcodificación interna

Esta sección proporciona un ejemplo de la configuración total para una configuración donde configuran al mismo router (un AS5400XM) para recibir el CUBO y a los recursos DSP para transcodificar. Partes de salientes la configuración aredisplayed en el texto en negrita.

Las diferencias entre esta configuración de la configuración y configuración del dsp farm para recibir a los recursos DSP de transcodificación del externo son como sigue:

  • Los recursos DSP reales (el “Voz-indicador luminoso LED amarillo de la placa muestra gravedad menor x” > “dsp mantiene el dspfarm ") y la entidad que controla (“telefonía-servicio ") aparecen en el mismo router.

  • La dirección IP de los recursos DSP (“identificador 1" de 9.13.29.30 del ccm del sccp) y la dirección IP de la entidad que controla (“telefonía-servicio” > “puerto de 9.13.29.30 del fuente-direccionamiento del IP ") son lo mismo.

5400XM
5400XM#show run
Building configuration...

Current configuration : 3149 bytes
!
version 12.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 5400XM
!
boot-start-marker
no boot startup-test
boot-end-marker
!
logging buffered 100000000 debugging
no logging console
enable secret 5 $1$g301$4BVklIIq97tihABYS6Guy/
enable password xxx
!
resource-pool disable
no aaa new-model
!
resource policy
!
voice-card 1
 dsp services dspfarm
!
voice-card 5
!
ip cef
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 h323
 modem passthrough none codec g729r8 pre-ietf
!
controller T1 5/0
 framing sf
 linecode ami
!
controller T1 5/1
 framing sf
 linecode ami
!
controller T1 5/2
 framing sf
 linecode ami
!
controller T1 5/3
 framing sf
 linecode ami
!
controller T1 5/4
 framing sf
 linecode ami
!
controller T1 5/5
 framing sf
 linecode ami
!
controller T1 5/6
 framing sf
 linecode ami
!
controller T1 5/7
 framing sf
 linecode ami
!
interface GigabitEthernet0/0
 ip address 9.13.29.30 255.255.255.0
 duplex auto
 speed auto
 negotiation auto
 no cdp enable
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 negotiation auto
 no cdp enable
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
 no fair-queue
!
interface Serial5/0
 no ip address
 shutdown
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
 no cdp enable
!
ip route 0.0.0.0 0.0.0.0 9.13.29.1
!
no ip http server
!
dialer-list 1 protocol ip permit
!
sccp local GigabitEthernet0/0
sccp ccm 9.13.29.30 identifier 1 version 4.0 -- Use its own IP address
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate profile 1 register XCODE123456
 keepalive retries 1
 keepalive timeout 10
 switchover method immediate
 switchback method immediate
!
dspfarm profile 1 transcode
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec gsmfr
 codec g729r8
 codec g729br8
 maximum sessions 10
 associate application SCCP
!
dial-peer voice 1 voip
 destination-pattern 630222100.
 session protocol sipv2
 session target ipv4:9.13.29.22
 dtmf-relay rtp-nte digit-drop
 codec g711ulaw
!
dial-peer voice 2 voip
 session protocol sipv2
 incoming called-number 630222100.
 codec g729br8 bytes 10
!
dial-peer voice 3 voip
 destination-pattern 2000
 session protocol sipv2
 session target ipv4:9.13.29.22
 dtmf-relay rtp-nte digit-drop
!
dial-peer voice 4 voip
 session protocol sipv2
 incoming called-number 2000
 codec g711ulaw
!
gatekeeper
 shutdown
!
telephony-service
 max-ephones 1
 max-dn 1
 ip source-address 9.13.29.30 port 2000 --> Use its own IP address
 sdspfarm units 1
 sdspfarm transcode sessions 10
 sdspfarm tag 1 XCODE123456
 ss7 mtp2-variant Bellcore 0
 ss7 mtp2-variant Bellcore 1
 ss7 mtp2-variant Bellcore 2
 ss7 mtp2-variant Bellcore 3
 !
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 password cisco
 login
!
scheduler allocate 10000 400
no process cpu extended
no process cpu autoprofile hog
end

Verificación

La salida en esta sección pertenece a la configuración puesta para la transcodificación externa.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

CUBO

El Nombre del dispositivo con el cual el dsp farm se registra con el CUBO y la dirección IP del router del host del dsp farm se visualiza en el texto en negrita.

vdouut3#show sdspfarm units
Load for five secs: 0%/0%; one minute: 0%; five minutes: 3%
Time source is NTP, 23:46:40.649 PST Tue Nov 21 2006


mtp-1 Device:vdouut1 TCP socket:[1] REGISTERED
actual_stream:256 max_stream 256 IP:1.2.61.71  27519  MTP YOKO keepalive 45  
Supported codec:
                 G711Ulaw
                 G711Alaw
                 G729
                 G729a
                 G729b
                 G729ab
 max-mtps:1, max-streams:256, alloc-streams:256, act-streams:0

Esta salida muestra la configuración de la configuración del CUBO.

vdouut3#show telephony-service
ip source-address 1.2.61.73 port 2000
max-ephones 128
max-dn 1
max-conferences 8 gain -6
dspfarm units 1
dspfarm transcode sessions 128
dspfarm 1 vdouut1

Esta salida muestra que después de que una llamada se haga el codecs (visualizado en el texto en negrita) que se utiliza para los tramos de llamada a través del CUBO.

vdouut3#show sdspfarm sessions active 
Load for five secs: 1%/0%; one minute: 1%; five minutes: 1%
Time source is NTP, 23:52:43.922 PST Tue Nov 21 2006

Stream-ID:37 mtp:1 1.2.61.71  20190  Local:2000 START  
 usage: Ip-Ip                        
 codec:G729  duration:20 vad:0 peer Stream-ID:38 

Stream-ID:38 mtp:1 1.2.61.71  21326  Local:2000 START  
 usage: Ip-Ip                        
 codec:G711Ulaw64k  duration:20 vad:0 peer Stream-ID:37

Esta salida muestra el active de las sesiones entre el OGW y el TGW a través del CUBO.

vdouut3#show voip rtp connections     
Load for five secs: 1%/0%; one minute: 1%; five minutes: 1%
Time source is NTP, 23:54:22.722 PST Tue Nov 21 2006
VoIP RTP active connections :
No. CallId     dstCallId  LocalRTP RmtRTP LocalIP         RemoteIP       
1   3991       3992       18496    17430  1.2.61.73       1.2.61.48      
2   3992       3991       17382    19706  1.2.61.73       1.2.61.68      
Found 2 active RTP connections

Esta salida muestra un resumen compacto de las sesiones activas y del codecs (visualizados en el texto en negrita) usado por los tramos de llamada.

vdouut3#show call active voice compact 
Load for five secs: 1%/0%; one minute: 1%; five minutes: 1%
Time source is NTP, 02:31:58.156 PST Wed Nov 22 2006
 <callID>  A/O FAX T<sec> Codec     type  Peer Address  IP R<ip>:<udp>
Total call-legs: 2
      4023 ANS     T25    g711ulaw  VOIP  P5200         1.2.61.48:16934
      4024 ORG     T25    g729r8    VOIP  P6200         1.2.61.68:17040

Host del dsp farm

Esta salida muestra el estatus del estado de registro de los recursos DSP. La información saliente aparece en el texto en negrita.

vdouut1#show sccp
SCCP Admin State: UP
Gateway IP Address: 1.2.61.71, Port Number: 2000
IP Precedence: 5
User Masked Codec list: None
Call Manager: 1.2.61.73, Port Number: 2000
                Priority: N/A, Version: 3.1, Identifier: 1

Transcoding Oper State: ACTIVE - Cause Code: NONE
Active Call Manager: 1.2.61.73, Port Number: 2000
TCP Link Status: CONNECTED, Profile Identifier: 1
Reported Max Streams: 256, Reported Max OOS Streams: 0
Supported Codec: g711ulaw, Maximum Packetization Period: 30
Supported Codec: g711alaw, Maximum Packetization Period: 30
Supported Codec: g729ar8, Maximum Packetization Period: 60
Supported Codec: g729abr8, Maximum Packetization Period: 60
Supported Codec: g729r8, Maximum Packetization Period: 60
Supported Codec: g729br8, Maximum Packetization Period: 60
Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30
Supported Codec: rfc2833 pass-thru, Maximum Packetization Period: 30
Supported Codec: inband-dtmf to rfc2833 conversion, Maximum Packetization Period: 30

Esta salida muestra la configuración de los recursos DSP (mientras que marcha lenta).

vdouut1#show dspfarm all
Dspfarm Profile Configuration

 Profile ID = 1, Service = TRANSCODING, Resource ID = 1  
 Profile Description :  
 Profile Admin State : UP 
 Profile Operation State : ACTIVE 
 Application : SCCP   Status : ASSOCIATED 
 Resource Provider : FLEX_DSPRM   Status : UP 
 Number of Resource Configured : 128 
 Number of Resource Available : 128
 Codec Configuration 
 Codec : g711ulaw, Maximum Packetization Period : 30 
Codec : g711alaw, Maximum Packetization Period : 30 
 Codec : g729ar8, Maximum Packetization Period : 60 
 Codec : g729abr8, Maximum Packetization Period : 60 
 Codec : g729r8, Maximum Packetization Period : 60 
 Codec : g729br8, Maximum Packetization Period : 60


SLOT DSP VERSION  STATUS CHNL USE   TYPE   RSC_ID BRIDGE_ID PKTS_TXED PKTS_RXED

1    1   9.2.1    UP     N/A  FREE  xcode  1      -         -         -        
1    1   9.2.1    UP     N/A  FREE  xcode  1      -         -         -        
1    1   9.2.1    UP     N/A  FREE  xcode  1      -         -         -  

Esta salida muestra el estatus de los recursos DSP (después de que se hace una llamada).

vdouut1#show sccp connections summary 
  SCCP Application Service(s) Statistics Summary:
  Total Conferencing Sessions: 0, Connections: 0
  Total Transcoding Sessions: 1, Connections: 2
  Total MTP Sessions: 0, Connections: 0
  Total ALG-Phone Sessions: 0, Connections: 0
  Total BRI-Phone Sessions: 0, Connections: 0
  Total SCCP Sessions: 1, Connections: 2

vdouut1#show dspfarm dsp active 
SLOT DSP VERSION  STATUS CHNL USE   TYPE   RSC_ID BRIDGE_ID PKTS_TXED PKTS_RXED

1    1   9.2.1    UP     1    USED  xcode  1      15        9400      9405     
1    1   9.2.1    UP     1    USED  xcode  1      16        9400      9394     

Total number of DSPFARM DSP channel(s) 1

Esta salida muestra las sesiones RTP entre los recursos DSP (este router) y la entidad que controla (CUBO). Dos piernas de la llamada VoIP con diverso codecs se muestran. Las piernas ambas se establecen con el CUBO (1.2.61.73).

vdouut1#show voip rtp connections 
VoIP RTP active connections :
No. CallId     dstCallId  LocalRTP RmtRTP LocalIP         RemoteIP       
1   46         47         17668    2000   1.2.61.71       1.2.61.73      
2   48         47         21530    2000   1.2.61.71       1.2.61.73      
Found 2 active RTP connections

vdouut1#show call active voice compact 
 <callID>  A/O FAX T<sec> Codec     type   Peer Address  IP R<ip>:<udp>
Total call-legs: 2
        46 ORG     T150   g711ulaw  VOIP   P             1.2.61.73:2000 
        48 ORG     T150   g729r8    VOIP   P             1.2.61.73:2000

Troubleshooting

Aquí están algunos comandos de Troubleshooting útiles para transcodificar:

  • mensajes del sccp del debug

  • mtp del ephone del debug

  • estado del ephone del debug

Nota: Consulte Información Importante sobre Comandos de Debug antes de usar un comando debug.


Información Relacionada


Document ID: 100480