Voz y Comunicaciones unificadas : Cisco Unified Communications Manager Express

Cisco Unified Communications Manager Express: Guía de instrumentación del SORBO

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona las instrucciones paso a paso para configurar un Cisco Unified Communications Manager Express independiente (CME) los teléfonos de ese SORBO de las aplicaciones. El documento delinea un sistema del Cisco Unified Communications Manager Express con cuatro teléfonos SIP, con las configuraciones para configurar el sistema del Cisco Unified Communications Manager Express y los teléfonos SIP.

Nota: Aunque los pasos para la configuración de los documentos abarca para permitir que el Cisco Unified Communications Manager Express interopere con el Cisco Unity Express, la configuración del Cisco Unity Express están fuera del alcance de este papel. Refiera al Cisco CallManager expreso/al ejemplo de configuración del Cisco Unity Express para más información sobre las configuraciones del Cisco Unified Communications Manager Express y del Cisco Unity Express.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de hardware:

  • Cisco 2801 que funciona con el Cisco Unified Communications Manager Express 4.2 con el Software Release 12.4(11)XW2 del½ del¿Â del Cisco IOSïÂ

  • switch de Ethernet ancho doble 9-port 10/100BASE-T HWIC

  • Cisco teléfonos de 7970 SORBOS

  • Cisco teléfono de 3911 SORBOS

La información en este documento se basa en estas versiones de firmware:

  • Teléfono del IP 7970 (SORBO) — SIP70.8-2-1S

  • Teléfono del IP 3911 (SORBO) — SIP3951.8-0-2-9

Refiera a la matriz de compatibilidad unificada Cisco CME y de la versión del Cisco IOS Software para determinar el firmware apropiado SIP para utilizar para cada versión del Cisco Unified Communications Manager Express. Puesto que se utiliza el Cisco Unified Communications Manager Express 4.2, refiera al link de las especificaciones del Cisco Unified Communications Manager Express 4.2.

Los phoneloads del SORBO se pueden descargar de estas ubicaciones:

Después de que usted haya desabrochado ambos los archivos ZIP en su carpeta TFTP, copie todos los archivos de firmware sobre el flash del Cisco Unified Communications Manager Express con su servidor TFTP. Aseegurese le copiar todos estos archivos sobre el flash.

SIP3951.8-0-2-9.loads
SIP3951.8-0-2-9.zz
DSP3951.0-0-0-1.zz
BOOT3951.0-0-0-9.zz
SIP70.8-2-1S.loads
term70.default.loads
term71.default.loads
apps70.8-0-2-55.sbn
cnu70.8-2-0-55.sbn 
cvm70.sip.8-2-0-55.sbn
dsp70.8-2-0-55.sbn
jar70.sip.8-0-2-25.sbn

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Estas tablas delinean los esquemas de direccionamiento que se utilizan en esta configuración.

Propósito VLAN Red Interfaz Dirección de la interfaz
Voice 192 192.168.10.0/24 VLA N 192 192.168.10.1/24
Datos 100 10.10.10.0/24 VLAN 100 10.10.10.1/24

Protocolo Tipo de teléfono Número de interno Máscara del externo del número de teléfono
SORBO 7970 101 4085251001
SORBO 7970 102 4085251002
SORBO 3911 103 4085251003
SORBO 3911 104 4085251004

Número piloto del voicemail 100 Piloto AA 110
MWI encendido 800 MWI desactivado 801

Nota: Utilice para obtener más información sobre los comandos usados en esta sección.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/99946/cme-sip-guide01.gif

Configuraciones del sistema

En este documento, se utilizan estas configuraciones:

DHCP de la configuración

Es necesario configurar a dos agrupamientos DHCP separados; El uso de los Teléfonos IP el agrupamiento DHCP de la Voz y los PC utiliza al agrupamiento DHCP de los datos. Necesidad de los Teléfonos IP de utilizar la opción DHCP 150 para proporcionar la dirección IP del servidor TFTP.

Si hay algunos dispositivos en cualquier pool con los IP Address estáticos, aseegurese estos direccionamientos se excluyen del agrupamiento DHCP para evitar dirigir los conflictos. Usted puede utilizar el comando show ip dhcp binding para verificar que dirige los Teléfonos IP y los PC reciben del router.

Configuración DHCP
ip dhcp excluded-address 10.10.10.1 10.10.10.10
ip dhcp excluded-address 192.168.10.1 192.168.10.10
!
ip dhcp pool data
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1 
!
ip dhcp pool voice
   network 192.168.10.0 255.255.255.0
   option 150 ip 192.168.10.1
   default-router 192.168.10.1

Interfaz FastEthernet y Switchports de la configuración

En esta sección, usted configura las interfaces VLAN para ambos los datos y expresa el VLA N y asigna los switchports en sus VLAN respectivos.

Nota: Antes de la configuración de los VLA N, esté seguro de agregar los VLA N anteriores a la base de datos de VLAN con estos comandos:

Interfaz FastEthernet y configuración de puerto de switch
CME-SIP#vlan database
% Warning: It is recommended to configure VLAN from config mode,
 as VLAN database mode is being deprecated. Please consult user
  documentation for configuring VTP/VLAN in config mode.

CME-SIP(vlan)#vlan 100
VLAN 100 modified:
CME-SIP(vlan)#vlan 192
VLAN 192 modified:
CME-SIP(vlan)#exit
APPLY completed.
Exiting....
CME-SIP#

Configure los switchports que se conectarán con la Voz y los VLAN de datos. Los Teléfonos IP se asignan automáticamente en el VLA N de la Voz y los PC conectados con el switchport directamente o conectados con el switchport en el teléfono del IP que se asigna al VLAN de dato.

Configuración DHCP
interface FastEthernet0/3/0
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/1
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
! 
 interface FastEthernet0/3/2
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/3
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
! !
interface Vlan100
description Data VLAN
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan192
description Voice VLAN
 ip address 192.168.10.1 255.255.255.0

Configuración TFTP

Esta configuración permite que el Cisco Unified Communications Manager Express sirva a Teléfonos IP su firmware.

Nota: Esta configuración es obligatoria.

Configuración de TFTP
tftp-server flash:SIP3951.8-0-2-9.loads
tftp-server flash:SIP3951.8-0-2-9.zz
tftp-server flash:DSP3951.0-0-0-1.zz
tftp-server flash:BOOT3951.0-0-0-9.zz
tftp-server flash:SIP70.8-2-1S.loads
tftp-server flash:term70.default.loads
tftp-server flash:term71.default.loads
tftp-server flash:apps70.8-0-2-55.sbn
tftp-server flash:cnu70.8-2-0-55.sbn 
tftp-server flash:cvm70.sip.8-2-0-55.sbn
tftp-server flash:dsp70.8-2-0-55.sbn
tftp-server flash:jar70.sip.8-0-2-25.sbn

Funciones de telefonía básicas de la configuración

Parámetros del servicio de voz de la configuración

El sistema de la configuración para permitir que las llamadas del SORBO SORBAN los puntos finales y el permiso SORBEN al secretario.

Nota: Esta configuración es obligatoria.

Configuración de parámetros del servicio de voz
voice service voip
allow-connections sip to sip 

!--- Enable SIP to SIP calls.

sip
registrar server expires max 1200 min 300 

!--- Enable Cisco IOS SIP registrar.

Parámetros globales del registro de la Voz de la configuración

En esta sección, usted configura los Parámetros globales del registro de la Voz.

Nota: Las configuraciones globales del registro de la Voz para el SORBO son parámetros de la configuración similares del telefonía-servicio para los teléfonos del SCCP.

Nota: Esta configuración es obligatoria.

Configuración de los Parámetros globales del registro de la Voz
voice register global                     
 mode cme  

!--- Set Cisco IOS SIP registrar to CME mode.

 source-address 192.168.10.1 port 5060 

!--- Set the source address for phone registration.

 max-dn 20 

!--- Set max extensions.

 max-pool 10 

!--- Set max phones.

 load 7970 SIP7 SIP70.8-2-1S 

!--- Specify phone loads for each phone type.

 load 3911 SIP3951.8-0-2-9 

!--- Specify phone loads for each phone type.

 authenticate register 

!--- Set authentication for phone registration.

 authenticate realm cisco.com 
 tftp-path flash:  

!--- Specify path for tftp files.

 create profile 

!--- Create configuration files for all phones.

 dialplan-pattern 1 4085251... extension-length 3  

!--- Configure dial-plan pattern for the system.

Aquí está un link a un vídeo en la comunidad del soporte de Ciscoleavingcisco.com que explica el procedimiento para registrar un teléfono del IP con el Cisco Unified Communications Manager Express (CME) usando el protocolo del SORBO:

Registro de un teléfono del IP de las 79xx Series usando el protocolo del SORBO en CUCME leavingcisco.com

/image/gif/paws/99946/cme-sip-guide02.gif

Conexión de la configuración al Cisco Unity Express

Dial-peers necesario de la configuración y ephones abajo del MWI a interoperar con el Cisco Unity Express. Para que el Cisco Unified Communications Manager Express interopere con el Cisco Unity Express, es necesario configurar el Cisco Unified Communications Manager Express SIP como a de nuevo al agente de usuario posterior (B2BUA), así que significa que toda la señalización y la secuencia RTP pasa a través del Cisco Unified Communications Manager Express. Esta configuración se requiere para habilitar la Conectividad al Cisco Unity Express.

Configuración de la conexión del Cisco Unity Express
dial-peer voice 2 voip
    destination-pattern 1.0  

!--- Specify destination-pattern to reach CUE VM and AA.

    session target ipv4:10.1.10.1  

!--- Configure IP address to reach Cisco Unity Express.

    session protocol sipv2
    dtmf-relay sip-notify  

!--- Configure DTMF method to communicate with Cisco Unity Express.

    b2bua  

!--- Enable B2BUA for Cisco Unified Communications Manager Express
!--- for calls to Cisco Unity Express.

    codec g711ulaw 
    no vad

El soporte del MWI del Cisco Unity Express de la configuración para el outcall para habilitar el MWI para el SORBO llama por teléfono.

Configuración MWI del Cisco Unity Express
ephone-dn 11
number 800
mwi on
!
ephone-dn 12
number 801
mwi off

Extensión y parámetros de la configuración

Registro dn de la Voz de la configuración para crear los números de interno para el ephones. En la topología de red anterior, hay cuatro Extensiones, que necesitan ser creadas según lo dado aquí.

Nota: Esta configuración es obligatoria.

Configuración de la extensión
voice register dn 1 
name Phone1 

!--- Set display name.

label 4085251001  

!--- Set display label.

number 101 

!--- Set extension number.

call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch  

!--- Allow this number to be watched (presence).

! 
voice register dn 2 
name Phone2
label 4085251002
number 102 
call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch
!
voice register dn 3 
name Phone3
label 4085251003
number 103 
call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch 
! 
voice register dn 4 
name Phone4
label 4085251004
number 104 
call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch

Teléfono del SORBO de la configuración

Los parámetros del pool del registro de la Voz de la configuración para cada SORBO llaman por teléfono.

Nota: El pool del registro de la Voz para los teléfonos del SORBO es idéntico al ephones para los teléfonos del SCCP.

Nota: Esta configuración es obligatoria.

Configuración de parámetros del pool del registro de la Voz
voice register pool  3
 id mac 001A.A11B.500E  

!--- Specify phone mac-address.

 type 3911  

!--- Specify phone type.

 number 1 dn 3  

!--- Assign button 1 dn tag 3.

 dtmf-relay sip-notify  

!--- Configure dtmf-relay sip-notify to work 
!--- with Cisco Unity Express.

 codec g711ulaw  

!--- Specify codec.

 username user1 password cisco  

!--- Configure username and password for SIP registrar.

Nota: Los métodos múltiples para el DTMF se pueden configurar bajo el pool del registro de la Voz, pero para cada teléfono del SORBO que tenga un cuadro del voicemail en el Cisco Unity Express, la DTMF-retransmisión de la configuración sorbo-notifica.

Parámetros avanzados de la configuración

En esta sección, usted configura los parámetros avanzados para los teléfonos del SORBO tales como presencia con el estatus ocupado del campo de la lámpara (BLF). La presencia con BLF permite que un teléfono del SCCP o el teléfono del SORBO monitoree el estatus de otras Extensiones del SORBO, que habilita la información de la presencia entre los teléfonos.

Nota: Esto es una configuración optativa.

Servicio de la presencia del SORBO del soporte de estos teléfonos en el Cisco Unified Communications Manager Express.

Restricciones

BLF Call-List
Supported only on Cisco Unified IP Phone 7941G, 7941GE, 7961G, 7961GE, 7970G, and 7971GE.
BLF Speed-Dial
Supported only on Cisco Unified IP Phone 7941G, 7941GE, 7961G, 7961GE, 7970G, and 7971GE.

Presencia del permiso para las líneas internas

Complete estos pasos para permitir al router para validar las peticiones entrantes de la presencia de los vigilantes internos y PARA SORBER los trunks.

1.  enable 
2.  configure terminal 
3.  sip-ua 
4.  presence enable 
5.  exit 
6.  presence 
7.  max-subscription number 
8.  presence call-list 
9.  end
Habilite la presencia para las líneas internas
Presence  

!--- Enable presence service.

 presence call-list  

!--- Enable BLF monitoring of directory numbers.

 max-subscription 120  

!--- Configure max number watched sessions.

!
sip-ua
 presence enable  

!--- Enable router to accept incoming presence request.

Habilite un número de directorio que se mirará

Complete estos pasos para habilitar una línea asociada a un número de directorio que se monitoreará por un teléfono registrado a un router expreso de las Comunicaciones unificadas de Cisco. Se habilita la línea mientras que un presentity y los teléfonos pueden inscribir a su línea estatus a través de las características de la llamada-lista BLF y del velocidad-dial BLG. No hay restricción en el tipo de teléfono que puede hacer sus líneas monitorear; cualquier línea en cualquier teléfono del IP o en un teléfono analógico en el Gateways de voz soportado puede ser un presentity.

1.  enable 
2.  configure terminal 
3.  voice register dn dn-tag 
4.  number number 
5.  allow watch 
6.  end
Habilite un número de directorio que se mirará
voice register dn  1
 number 101
 allow watch  

!--- Allow this number to be watched.

 name Phone1
 label 4085251001

Nota: Relance esta configuración para cada número de interno que necesite ser mirado. Este paso fue hecho ya cuando usted el primer registro dns de la voz configurada.

Permita al teléfono del SORBO para monitorear el estatus BLF para los marcados rápidos y las listas de la llamada

Un vigilante puede monitorear el estatus de las líneas asociadas a los números de directorio internos y externos (presentities) a través de las características de la presencia del velocidad-dial BLF y de la llamada-lista BLF. Complete estos pasos para habilitar las características de la notificación BLF en un teléfono del SORBO:

1.  enable 
2.  configure terminal 
3.  voice register pool pool-tag 
4.  number tag dn dn-tag 
5.  blf-speed-dial tag number label string 
6.  presence call-list 
7.  exit 
8.  voice register global 
9.  mode cme 
10.  create profile 
11.  restart 
12.  end
Permita al teléfono del SORBO para monitorear el estatus BLF para los marcados rápidos y las listas de la llamada
voice register pool  1
 id mac 0016.47CD.9BD7
 type 7970
 number 1 dn 1
 presence call-list  

!--- Enable this phone to have presence call list.

 dtmf-relay sip-notify  
 username user1 password cisco
 codec g711ulaw
 blf-speed-dial 2 102 label "Phone2"  

!--- Enable this line to monitor extension 1002.

 blf-speed-dial 3 103 label "3911-1"  

!--- Enable this line to monitor extension 1003.

 blf-speed-dial 4 104 label "3911-2"  

!--- Enable this line to monitor extension 1004.

Nota:  Esté seguro de realizar el reinicio cada vez que usted cambia una Configuración del teléfono del SORBO.

Nota: Refiérase a cómo configurar el servicio de la presencia para más información sobre las configuraciones del servicio de la presencia del SORBO.

Configure al grupo Hunt paralelo

En esta sección, las Extensiones 102, 103, y 104 se asignan en un grupo Hunt paralelo. Un grupo Hunt paralelo es un grupo Hunt que llama a todos los miembros en el grupo simultáneamente.

Configuración paralela del grupo Hunt
voice hunt-group 1
pilot 180  

!--- Configure Hunt group pilot number.

list 102, 103, 104  

!--- Specify members in hunt-group.

final 100  

!--- Specify final number as Voicemail Pilot.

Implementación del SORBO CME: Configuración de muestra:

Esta sección proporciona la configuración de muestra completa para configurar un Cisco Unified Communications Manager Express independiente que utilice los teléfonos del SORBO.

Implementación del SORBO CME: Configuración de muestra:
CME-SIP#show version
Cisco IOS Software, 2801 Software (C2801-IPVOICE-M), Version 12.4(11)XW2, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Mon 02-Jul-07 19:10 by prod_rel_team

ROM: System Bootstrap, Version 12.3(8r)T6, RELEASE SOFTWARE (fc1)

CME-SIP uptime is 18 hours, 55 minutes
System returned to ROM by reload at 17:01:34 UTC Wed Oct 3 2007
System image file is "flash:c2801-ipvoice-mz.124-11.XW2.bin"

Cisco 2801 (revision 4.1) with 235520K/26624K bytes of memory.
Processor board ID FHK084510HS
11 FastEthernet interfaces
1 terminal line
2 Voice FXO interfaces
3 DSPs, 48 Voice resources
1 cisco service engine(s)
DRAM configuration is 64 bits wide with parity disabled.
191K bytes of NVRAM.
62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

CME-SIP#show running-config
Building configuration...

Current configuration : 6227 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-SIP
!
boot-start-marker
boot-end-marker
!
logging buffered 999999
no logging console
enable password cisco
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1 10.10.10.10
ip dhcp excluded-address 192.168.10.1 192.168.10.10
!
ip dhcp pool data
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1 
!
ip dhcp pool voice
   network 192.168.10.0 255.255.255.0
   option 150 ip 192.168.10.1 
   default-router 192.168.10.1 
!
!
no ip domain lookup
multilink bundle-name authenticated
!
!
!
voice service voip 
 allow-connections sip to sip
 sip
  registrar server expires max 1200 min 300
!
!
!
!
!
voice register global
 mode cme
 source-address 192.168.10.1 port 5060
 max-dn 20
 max-pool 10
 load 7970 SIP70.8-2-1S
 load 3911 SIP3951.8-0-2-9
 authenticate register
 authenticate realm cisco.com
 voicemail 100
 tftp-path flash:
 create profile sync 0000589556325309
!
voice register dn  1
 number 101
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone1
 label 4085251001
!
voice register dn  2
 number 102
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone2
 label 4085251002
!
voice register dn  3
 number 103
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone3
 label 4085251003
!
voice register dn  4
 number 104
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone4
 label 4085251004
!
voice register pool  1
 id mac 0016.47CD.9BD7
 type 7970
 number 1 dn 1
 presence call-list
 dtmf-relay sip-notify
 username user1 password cisco
 codec g711ulaw
 blf-speed-dial 2 102 label "Phone2"
 blf-speed-dial 3 103 label "3911-1"
 blf-speed-dial 4 104 label "3911-2"
!
voice register pool  2
 id mac 0014.6948.1D52
 type 7970
 number 1 dn 2
 dtmf-relay sip-notify
 username user2 password cisco
 codec g711ulaw
!
voice register pool  3
 id mac 001A.A11B.4FCE
 type 3911
 number 1 dn 3
 dtmf-relay sip-notify
 username user3 password cisco
 codec g711ulaw
!
voice register pool  4
 id mac 001A.A11B.500E
 type 3911
 number 1 dn 4
 dtmf-relay sip-notify
 username user4 password cisco
 codec g711ulaw
!
voice hunt-group 1 parallel
 final 100
 list 102,103,104
 pilot 180 
!
!
!
!
voice-card 0
!
!
!
archive
 log config
 hidekeys
!
!
!
interface Loopback0
 ip address 10.1.10.2 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Service-Engine0/0
 ip unnumbered Loopback0
 service-module ip address 10.1.10.1 255.255.255.0
 service-module ip default-gateway 10.1.10.2
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/3/0
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/1
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/2
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/3
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/4
 description Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/5
 description Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/6
 description Phone
 switchport access vlan 192
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/7
 description Phone
 switchport access vlan 192
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/8
 switchport access vlan 192
!
interface Vlan1
 no ip address
!
interface Vlan100
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan192
 ip address 192.168.10.1 255.255.255.0
!
ip route 10.1.10.1 255.255.255.255 Service-Engine0/0
!
!
ip http server
!
!
!
tftp-server flash:BOOT3951.0-0-0-9.zz
tftp-server flash:SIP3951.8-0-2-9.zz
tftp-server flash:DSP3951.0-0-0-1.zz
tftp-server flash:SIP3951.8-0-2-9.loads
tftp-server flash:SIP70.8-2-1S.loads
tftp-server flash:term70.default.loads
tftp-server flash:term71.default.loads
tftp-server flash:apps70.8-0-2-55.sbn
tftp-server flash:cnu70.8-2-0-55.sbn 
tftp-server flash:cvm70.sip.8-2-0-55.sbn
tftp-server flash:dsp70.8-2-0-55.sbn
tftp-server flash:jar70.sip.8-0-2-25.sbn
!
control-plane
!
!
!
voice-port 0/1/0
!
voice-port 0/1/1
!
!
!
!
!
dial-peer voice 2 voip
 description ** cue voicemail pilot number **
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 100
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 3 voip
 description ** cue auto attendant number **
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 110
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
!
presence
 presence call-list
 max-subscription 120
!
sip-ua 
 presence enable
!
!
telephony-service
 max-ephones 24
 max-dn 72
 ip source-address 10.100.100.10 port 2000
 system message CME1
 time-zone 5
 voicemail 100
 max-conferences 8 gain -6
 call-forward pattern .T
 web admin system name cisco secret 5 $1$4FC/$CMer08o/KELFlVrhL5QRO0
 dn-webedit 
 time-webedit 
 transfer-system full-blind
 transfer-pattern 9.T
!
!
ephone-dn  11
 number 800
 mwi on
!
!
ephone-dn  12
 number 801
 mwi off
!
!
line con 0
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end

CME-SIP#

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

El teléfono SIP IP no consigue el tono de discado

Una causa común para los teléfonos SIP IP que no pueden conseguir un tono de discado es que hay otro teléfono con la misma extensión. A partir del Cisco Unified Communications Manager Express 4.2, la línea compartida no se soporta en los teléfonos del SORBO. Así, los teléfonos del SORBO no pueden compartir la misma extensión entre los teléfonos múltiples. Además, aseegurese que el teléfono del SORBO es aprovisionado con una extensión apropiada.

Para resolver este problema, aseegurese que ocurren éstos:

  • El teléfono del SORBO tiene la extensión configurada y las demostraciones de la extensión en el SORBO llaman por teléfono.

  • No hay otro teléfono del SORBO o del SCCP configurado con la misma extensión.

El teléfono del IP no puede actualizar a la última versión de firmware

Las causas más probable para que el error pueda actualizar un teléfono están faltando los archivos de firmware puestos en el flash del Cisco Unified Communications Manager Express o los comandos tftp-server que falta.

Intente estos pasos para resolver este problema:

  • Marque que los archivos del firmware necesario están salvados en el flash. Realice el dir flash: ordene para marcar el flash para los archivos.

  • Marque para ver si usted ha puesto al día el archivo OS79XX.TXT para reflejar el firmware correcto. Los teléfonos 79XX marcan este archivo para cargar el firmware apropiado y cambiar del SCCP PARA SORBER.

  • Marque para aseegurarse que las declaraciones correctas del tftp-servidor están agregadas para cada archivo de firmware. Vea la sección de la configuración TFTP.

  • Aseegurese el comando load bajo registro de la Voz global se agrega para cada tipo de teléfono del SORBO. Vea la sección de los Parámetros globales del registro de la Voz de la configuración.

Para resolver problemas más lejos, recoja estos debugs para ver si el teléfono puede conseguir las cargas apropiadas del teléfono del flash del Cisco Unified Communications Manager Express.

Debug tftp events

Incapaz de provision el teléfono

Las causas más probable para no poder provision son teléfono son que el teléfono no tiene la dirección IP apropiada con la opción del servidor TFTP.

  • Marque para ver que el teléfono recibe una dirección IP y el TFTP Server IP Address apropiado.

  • Aseegurese que agregan a todos los comandos global apropiados del registro de la Voz. Vea la sección de los Parámetros globales del registro de la Voz de la configuración.

  • Marque que usted utiliza la dirección MAC correcta por debajo cada configuración de agrupación del registro de la Voz.


Información Relacionada


Document ID: 99946