Voz y Comunicaciones unificadas : Cisco Unified Border Element

Elemento unificado de la frontera (CUBO) con el ejemplo de configuración del administrador de las Comunicaciones unificadas de Cisco (CUCM)

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (28 Enero 2009) | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

El Cisco Unified Border Element facilita la Conectividad simple y rentable entre los trunks del Session Initiation Protocol (SIP) de las Comunicaciones unificadas de la empresa a la red de telefonía pública conmutada (PSTN). Diseñó resolver la empresa y el regulador de la frontera de la sesión del proveedor de servicio que (SBC) el dispositivo necesita, el Cisco Unified Border Element (CUBO) es una aplicación de software integrada del � del Cisco IOS que se ejecuta encendido:

  • Cisco 2800 Series Integrated Services Routers

  • Cisco 3800 Series Integrated Services Routers

  • Plataformas multiservicios de las Cisco 2600XM Series

  • Cisco 3700 Series Routers

  • Cisco 7200VXR Router

  • Routers Cisco 7301

  • Cisco AS5400XM y gatewayes de acceso AS5350XM

Las interconexiones directas IP entre las redes de las Comunicaciones unificadas ofrecen la mayor flexibilidad para soportar los servicios emergentes en comparación con las interconexiones tradicionales de la multiplexión por división de tiempo de la red de telefonía pública conmutada (PSTN) (TDM).

El Cisco Unified Border Element proporciona una punta de la interfaz de red-a-red para:

  • Señalando intertrabajar — H.323, SORBO

  • Media que intertrabajan — [DTMF], fax, módem, y transcodificación de múltiples frecuencias bitonales del codificador-decodificador

  • Direccionamiento y traducciones de puerto — ocultación de la aislamiento y de la topología

  • Factura y normalización del registro de detalles de la llamada (CDR)

  • Calidad de Servicio (QoS) y administración del ancho de banda — Marca de QoS usando el [DSCP] o el Tipo de servicio (ToS) del Differentiated Services Code Point, aplicación del ancho de banda usando el Resource Reservation Protocol [RSVP] y filtración del codificador-decodificador

Un Cisco Unified Border Element interopera con muchos diversos elementos de redes incluyendo el Gateways de voz, los Teléfonos IP, y los servidores del Control de llamadas en muchos diversos entornos de la aplicación, de la Voz de la empresa y/o los servicios de video avanzados con las Comunicaciones unificadas administrador o Cisco Unified Communications Manager Express, así como un Toll Bypass y aplicaciones más simples de Cisco del transporte de la voz sobre IP (voip).

El Cisco Unified Border Element proporciona las organizaciones con todas las funciones del controlador de la frontera integradas en la capa de red para interconectar las arquitecturas del empresa-a-servicio-proveedor de la Voz y del vídeo de las Comunicaciones unificadas. El Cisco Unified Border Element es utilizado por la empresa y las pequeñas y medianas organizaciones para interconectar el acceso del SORBO PSTN con el SORBO y las redes de las Comunicaciones unificadas de la empresa de H.323.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información en este documento se basa en el Cisco Unified Border Element (CUBO).

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Utilice la herramienta Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos utilizados en esta sección.

Configuraciones

Esta configuración habilita las funciones básicas del Cisco Unified Border Element en una plataforma. Estas funciones terminan una llamada VoIP entrante y re-la originan con el uso de un VoIP dial-peer de salida. Las llamadas pueden ser H.323 A SORBER o A SORBER PARA SORBER.

voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
allow-connections h323 to h323

Configure el entrante y a las dial peer salientes con el protocolo relevante, el tipo DTMF, y la información de códec.

dial-peer voice 1 voip
session target ipv4:10.13.8.150
incoming called-number 8...
dtmf-relay h245-alphanumeric
codec g711ulaw
!
dial-peer voice 2 voip
destination-pattern 8...
session protocol sipv2
session target ipv4:10.13.8.16
dtmf-relay rtp-nte
codec g711ulaw

SORBA la configuración de agente de usuario

Configure al agente de usuario del SORBO (UA) para el registro y la autenticación.

SORBA al agente de usuario (el UA)
sip-ua
registrar ipv4:10.1.1.10
or
registrar dns:csps.cisco.com
authentication username xyz password xyz realm cisco.com

Interconexión con el administrador de las Comunicaciones unificadas de Cisco

El administrador de las Comunicaciones unificadas de Cisco puede ser interconectado con el Cisco Unified Border Element con el uso de H.323 o de un trunk de las Comunicaciones unificadas del SORBO.

Trunk de H.323 al Cisco Unified Border Element

Hay dos métodos de definir un trunk de H.323 al Cisco Unified Border Element en el administrador de las Comunicaciones unificadas de Cisco:

  • Con un portero — Configure un trunk H.225 (GK controlado) hacia el Cisco Unified Border Element

  • Sin un portero — Configure el Cisco Unified Border Element como gateway de H.323

Requisitos del Media Termination Point (MTP):

  • Si el Cisco Unified Border Element hace H.323 a las llamadas de H.323, un MTP no es obligatorio mientras la versión del Cisco Unified Border Element sea 12.4(6)T o más adelante y el administrador de las Comunicaciones unificadas de Cisco es versión 4.1 o posterior.

  • Un soporte físico o un software MTP puede ser coresidente en el mismo router como el Cisco Unified Border Element (en las Plataformas del Routers que soportan CUCM MTP, que incluyen las Cisco y Series ISR).

Requisitos rápidos del comienzo de H.323:

  • Si el Cisco Unified Border Element hace H.323 PARA SORBER intertrabajar para el administrador de las Comunicaciones unificadas de Cisco, la mayoría de los servidores alternativos SIP requieren la llamada del SORBO ser oferta temprana. Esto implica el lado de H.323 debe ser H.323 rápidamente comienza. Por lo tanto, el administrador de las Comunicaciones unificadas de Cisco debe ser configurado para entrante y H.323 saliente rápidamente comienza, que también requiere un MTP.

El cuadro 1 muestra la configuración para un Cisco Unified Border Element definido como gateway de H.323 en el administrador de las Comunicaciones unificadas de Cisco.

Figura 1. La configuración del Cisco Unified Border Element como gateway de H.323 en el administrador de las Comunicaciones unificadas de Cisco

/image/gif/paws/99863/cube-config01.gif

cube-config02.gif

El cuadro 2 muestra la configuración del Cisco Unified Border Element para hacer juego la configuración de administrador precedente de las Comunicaciones unificadas de Cisco.

Cuadro 2. configuración en el Cisco Unified Border Element para un trunk de H.323

cube-config03.gif

Trunk del SORBO al Cisco Unified Border Element

La versión del administrador se requiere 5.x de las Comunicaciones unificadas de Cisco o más adelante definir un trunk del SORBO de las Comunicaciones unificadas al Cisco Unified Border Element.

Requisitos MTP:

  • Trunk del SORBO sin un MTP — Configure un trunk del SORBO de las Comunicaciones unificadas sin el MTP si los media retrasados o invítelo sin el SDP es aceptable.

  • SORBA el trunk con el MTP — Configure un trunk unificado del SORBO de la comunicación (con el MTP) si los media tempranos o invítelo con el SDP es un requisito (llamadas de G.711 solamente).

Los cuadros 3 muestran la configuración para un Cisco Unified Border Element definido con un trunk del SORBO de las Comunicaciones unificadas al administrador de las Comunicaciones unificadas de Cisco.

Figura 3. La configuración del Cisco Unified Border Element con un trunk del SORBO al administrador de las Comunicaciones unificadas de Cisco

/image/gif/paws/99863/cube-config04.gif

El cuadro 4 muestra a configuración la configuración del Cisco Unified Border Element para hacer juego la configuración de administrador precedente de las Comunicaciones unificadas de Cisco.

Cuadro 4. configuración en el Cisco Unified Border Element para un trunk del SORBO

/image/gif/paws/99863/cube-config05.gif

Coresidente MTP con el Cisco Unified Border Element

Si un software MTP es requerido por la configuración de administrador de las Comunicaciones unificadas de Cisco, esto se puede configurar en el mismo router usado para el Cisco Unified Border Element.

Ésta es la configuración en el Cisco Unified Border Element para un MTP:

sccp local FastEthernet0/1

sccp ccm 15.5.34.1 identifier 1 version 4.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP

!

dspfarm profile 1 mtp

codec g711ulaw

maximum sessions software 100

associate application SCCP

Transcodificación en el Cisco Unified Border Element

El Cisco Unified Border Element puede hacer la transcodificación entre G.711�-law/a-law y los diversos sabores de G.729. La transcodificación se puede invocar para cualquier llamada si origina del administrador de las Comunicaciones unificadas de Cisco hacia el PSTN, o del PSTN hacia el administrador de las Comunicaciones unificadas de Cisco. El criterio principal es si los dos tramos de llamada en el Cisco Unified Border Element tienen diverso codecs - G.711 y G.729. La configuración de la transcodificación en el Cisco Unified Border Element requiere DSPs estar disponible en la plataforma.

Ésta es la configuración en el Cisco Unified Border Element para transcodificar:

voice-card 2

dspfarm

dsp services dspfarm

sccp local FastEthernet 0/0

sccp ccm 200.1.1.100 identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP123456782012

keepalive retries 5

switchover method immediate

switchback method immediate

switchback interval 15

!

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec gsmfr

codec g729r8

maximum sessions 5

associate application SCCP

telephony-service

load 7960-7940 P00303020214

max-ephones 48

max-dn 48

ip source-address 200.1.1.100 port 2000

sdspfarm units 1

sdspfarm transcode sessions 50

sdspfarm tag 1 MTP123456782012

create cnf-files version-stamp 7960 Jul 29 2002 13:50:03

Usando Tcl IVR en el Cisco Unified Border Element

El Cisco Unified Border Element soporta el Scripts TCL, y usted puede configurarlos bajo los VoIP dial-peer. No hay necesidad de un DSP para utilizar las funciones Tcl. Hay varias aplicaciones Tcl incorporadas ya al Cisco IOS Software que se puede utilizar para las implementaciones del Cisco Unified Border Element. Las funciones del Authentication, Authorization, and Accounting (AAA) del Cisco IOS se pueden también utilizar conjuntamente con la secuencia de comandos de TCL y el Cisco Unified Border Element para proporcionar la autenticación y autorización de las llamadas.

aaa new-model

!

aaa authentication login h323 group radius

aaa authorization exec h323 local group radius

aaa accounting exec h323 start-stop group radius

!

application

service debitcard tftp://15.5.27.11/app_debitcard.2.0.2.8.tcl

paramspace english index 1

paramspace english language en

paramspace english location tftp://15.5.27.11/prompts/en/

param pid-len 4

paramspace english prefix en

param uid-len 6

!

gw-accounting aaa

!

radius-server host 15.5.27.11 auth-port 1645 acct-port 1646

radius-server timeout 10

radius-server key lab

radius-server vsa send accounting

radius-server vsa send authentication

Configuración de muestra completa

router#show run
Building configuration...
Current configuration : 1122 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IPIPGW-1
!
boot-start-marker
boot-end-marker
!
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
ip cef
!
! aaa new-model
!
aaa authentication login h323 group radius
aaa authorization exec h323 local group radius
aaa accounting exec h323 start-stop group radius
!
application
service debitcard tftp://15.5.27.11/app_debitcard.2.0.2.8.tcl
paramspace english index 1
paramspace english language en
paramspace english location tftp://15.5.27.11/prompts/en/
param pid-len 4
paramspace english prefix en
param uid-len 6
!
gw-accounting aaa
!
radius-server host 15.5.27.11 auth-port 1645 acct-port 1646
radius-server timeout 10
radius-server key lab
radius-server vsa send accounting
radius-server vsa send authentication
!
no ip domain lookup
no ftp-server write-enable
!
voice service voip
allow-connections h323 to sip 

!--- key command

allow-connections sip to h323 

!--- key command

allow-connections sip to sip 

!--- key command

allow-connections h323 to h323 

!--- key command

!
interface FastEthernet0/0
ip address 200.1.1.100 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 200.1.1.1
ip http server
!
control-plane
!
dial-peer voice 1 voip
application debitcard 

!--- TCL Application

session target ipv4:9.13.8.150
incoming called-number 8...
dtmf-relay h245-alphanumeric 

!--- DTMF config for h.245 alphanumeric

codec g711ulaw
!
dial-peer voice 2 voip
destination-pattern 8...
session protocol sipv2
session target ipv4:9.13.8.16
dtmf-relay rtp-nte 

!--- DTMF config for RFC2833

codec g711ulaw
!
gatekeeper
shutdown
sip-ua
registrar ipv4:200.1.1.10 or registrar dns:csps.cisco.com
authentication username xyz password xyz realm cisco.com
!
line con 0
line aux 0
line vty 0 4
login
!
end

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Nota: Consulte Información Importante sobre Comandos de Debug antes de usar un comando debug.

  • registración — Es importante asegurarse que el Cisco Unified Border Element está configurado para registrar como en este ejemplo y también realizar el debugging durante las horas del NON-pico lo más lejos posible puesto que los comandos debug son prolijos.

    logging console informational
    logging buffer 200000 debug
    service sequence-number
    service timestamp debug date msec
  • demostración — Ésta es salida relevante:

    show version
    show run
    show voip rtp connection (once the call is up)
    show call active voice brief (once the call is up)
  • debug — Aseegurese para borrar el registro antes de que una llamada para el debugging se haga, y conseguir la salida del comando show logging después de la llamada ha ejecutado.

    H.323 a los escenarios de H.323

    debug h225 asn1
    debug h225 q931
    debug h225 events
    debug h245 asn1
    debug h245 events
    debug h225 q931
    debug cch323 all
    debug voip ipipgw
    debug voip ccapi inout

    H.323 PARA SORBER los escenarios

    debug h225 asn1
    debug h225 q931
    debug h225 events
    debug h245 asn1
    debug h245 events
    debug cch323 all
    debug voip ipipgw
    debug voip ccapi inout
    debug ccsip all

    SORBO PARA SORBER los escenarios

    debug ccsip all
    debug voip ccapi inout
  • debug — Además de los comandos de debugging basados en el escenario descrito anterior, estos comandos de debugging del transcoder deben ser habilitados:

    debug dspfarm all
    debug sccp messages
  • Nombrado-eventos de la sesión del rtp del voip del debug — Si se utiliza el RFC2833 (DTMF-retransmisión RTP-NTE), usted debe también girar este comando debug.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 99863