IP : Traducción de direcciones de red (NAT)

Balanceo de carga IOS NAT con el Edge Routing optimizado para dos conexiones de Internet

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (25 Agosto 2008) | Inglés (29 Septiembre 2014) | Comentarios


Contenido


Introducción

Este documento describe una configuración para que un router del � del Cisco IOS conecte una red con Internet con la traducción de dirección de red a través de dos Conexiones ISP. El Network Address Translation (NAT) del Cisco IOS Software puede distribuir las conexiones TCP y a las Sesiones UDP subsiguientes sobre las conexiones de Red múltiple si las rutas de igual costo a un destino determinado están disponibles. En caso que una de las conexiones llegue a estar inutilizable, el Rastreo de objetos, un componente del Edge Routing optimizado (OER), se puede utilizar para desactivar la ruta hasta que la conexión esté disponible otra vez, que asegura la disponibilidad de la red a pesar de la inestabilidad o la falta de fiabilidad de una conexión de Internet.

/image/gif/paws/99427/ios-nat-2isp-1.gif

prerrequisitos

Requisitos

Este documento asume que usted tiene el LAN funcional y conexiones WAN; no proporciona el fondo de la configuración o del troubleshooting para establecer la conectividad inicial.

  1. Este documento no describe una manera de distinguir entre las rutas, tan allí no es ninguna manera de preferir una conexión más-deseable sobre una conexión menos-deseable.

  2. Este documento describe la configuración de OER para habilitar o para inhabilitar cualquier ruta de Internet basada en el accesibilidad de los servidores DNS del ISP. Usted necesita identificar los hosts específicos que pueden ser accesibles con solamente uno de las Conexiones ISP y no pueden estar disponibles si esa Conexión ISP no está disponible.

Componentes Utilizados

Esta configuración fue desarrollada con un Cisco 1811 Router con el software avanzado 12.4(15)T de los Servicios IP. Si se utiliza una diversa versión de software, algunas características no están potencialmente disponibles, o los comandos configuration pueden diferenciar de ésos mostrados en este documento. La configuración similar está disponible en todas las plataformas del router del Cisco IOS aunque la configuración de la interfaz varíe probablemente entre diversas Plataformas.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

Usted potencialmente necesita agregar el Policy-Based Routing para que el tráfico específico se asegure de que utiliza siempre una Conexión ISP. Los ejemplos del tráfico que requieren este comportamiento incluyen los clientes del IPSec VPN, los microteléfonos VoIP, y cualquier otro tráfico que utilicen solamente uno de las opciones de Conexión ISP para preferir la misma dirección IP, una velocidad más alta, o para bajar el tiempo de espera en la conexión.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/99427/ios-nat-2isp-2.gif

Configuraciones

Este ejemplo de configuración, como se ilustra en el diagrama de la red, describe un router de acceso que utilice una conexión IP DHCP-configurada a un ISP (como se muestra por el FastEthernet 0), y una conexión PPPoE sobre la otra Conexión ISP. Los Tipos de conexión no tienen ningún impacto determinado en la configuración a menos que se vaya el Rastreo de objetos y OER y/o el Policy-Based Routing a ser utilizado con una conexión de Internet DHCP-asignada. En estos casos, puede ser muy difícil definir a un Next Hop Router para el Policy Routing u OER.

Ejemplo de la configuración del router
track timer interface 5
!
! Configure timers on route tracking
!
track 123 rtr 1 reachability
 delay down 15 up 10
!
track 345 rtr 2 reachability
 delay down 15 up 10
!
! Use “ip dhcp client route track [number]” 
   ! to monitor route on DHCP interfaces
! Define ISP-facing interfaces with “ip nat outside”
!
interface FastEthernet0
 ip address dhcp
 ip dhcp client route track 345
 ip nat outside
 ip virtual-reassembly
!
interface FastEthernet1
 no ip address
 pppoe enable
 no cdp enable
!
interface FastEthernet2
 no cdp enable
!
interface FastEthernet3
 no cdp enable
!
interface FastEthernet4
 no cdp enable
!
interface FastEthernet5
 no cdp enable
!
interface FastEthernet6
 no cdp enable
!
interface FastEthernet7
 no cdp enable
!
interface FastEthernet8
 no cdp enable
!
interface FastEthernet9
 no cdp enable
!
! Define LAN-facing interfaces with “ip nat inside”
!
interface Vlan1
 description LAN Interface
 ip address 192.168.108.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
! Define ISP-facing interfaces with “ip nat outside”
!
Interface Dialer 0
 description PPPoX dialer
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 ip tcp adjust-mss
!
ip route 0.0.0.0 0.0.0.0 dialer 0 track 123
!
! Configure NAT overload (PAT) to use route-maps
!
ip nat inside source route-map fixed-nat
   interface Dialer0 overload
ip nat inside source route-map dhcp-nat 
   interface FastEthernet0 overload
!
! Configure an OER tracking entry 
   ! to monitor the first ISP connection
!
ip sla 1
 icmp-echo 172.16.108.1 source-interface Dialer0
 timeout 1000
 threshold 40
 frequency 3
!
! Configure a second OER tracking entry 
   ! to monitor the second ISP connection
!
ip sla 2
 icmp-echo 172.16.106.1 source-interface FastEthernet0
 timeout 1000
 threshold 40
 frequency 3
!
! Set the SLA schedule and duration
!
ip sla schedule 1 life forever start-time now
ip sla schedule 2 life forever start-time now
!
! Define ACLs for traffic that 
   ! will be NATed to the ISP connections
!
access-list 110 permit ip 192.168.108.0 0.0.0.255 any
!
! Route-maps associate NAT ACLs with NAT 
   ! outside on the ISP-facing interfaces
!
route-map fixed-nat permit 10
 match ip address 110
 match interface Dialer0
!
route-map dhcp-nat permit 10
 match ip address 110
 match interface FastEthernet0 

Con el seguimiento DHCP-asignado de la ruta:

Ejemplo de configuración de seguimiento DHCP-asignado de la ruta (opcional)
interface FastEthernet0
 description Internet Intf
 ip dhcp client route track 123
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 speed 100
 full-duplex
 no cdp enable

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

  • muestre a IP la traducción nacional — Actividad de las visualizaciones NAT entre los host interiores NAT y los host exteriores NAT. Este comando proporciona la verificación que los host interiores están traducidos a ambas direcciones externas NAT.

    Router# sh ip nat tra
    Pro Inside global      Inside local       Outside local      Outside global
    tcp 172.16.108.44:54486 192.168.108.3:54486 172.16.104.10:22 172.16.104.10:22
    tcp 172.16.106.42:49620 192.168.108.3:49620 172.16.102.11:80 172.16.102.11:80
    tcp 172.16.108.44:1623 192.168.108.4:1623 172.16.102.11:445  172.16.102.11:445
    Router#
    
  • ruta de IP de la demostración — Verifica que las rutas múltiples a Internet estén disponibles.

    Router# sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, 
           L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, 
           U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is 172.16.108.1 to network 0.0.0.0
    
    C    192.168.108.0/24 is directly connected, Vlan1
         172.16.0.0/24 is subnetted, 2 subnets
    C       172.16.108.0 is directly connected, 
            FastEthernet4
    C       172.16.106.0 is directly connected, Vlan106
    S*   0.0.0.0/0 [1/0] via 172.16.108.1
                   [1/0] via 172.16.106.1
    Router#
    

Troubleshooting

Después de que usted configure al router del Cisco IOS con el NAT, si las conexiones no trabajan, esté seguro de éstos:

  • El NAT se aplica apropiadamente en el exterior y las interfaces interiores.

  • La configuración del NAT es completa, y los ACL reflejan el tráfico que debe ser NATed.

  • Las rutas múltiples al Internet/WAN están disponibles.

  • Si usted utiliza la ruta que sigue para estar seguro que las conexiones de Internet están disponibles, marque el estado del seguimiento de la ruta.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 99427