Switches : Switches Cisco Catalyst de la serie 3750

Ruteo de stub PIM en el Catalyst 3750, y 3560 Series Switch

24 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (25 Agosto 2008) | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

El tráfico del plano del control de multidifusión es considerado siempre por cada router en un entorno LAN. El Multicast IP del stub se utiliza para reducir y para minimizar el tráfico Multicast innecesario que se considera en el LAN en la capa de acceso y para salvar el ancho de banda en los media para remitir el tráfico Multicast a la distribución/a la capa del núcleo por aguas arriba.

En el Switches de las Catalyst 3750 y 3560 Series, el ruteo multicast de los soportes de característica del Multicast del stub PIM entre la capa de distribución y la capa de acceso. Apoya dos tipos de interfaces PIM: interfaces del uplink PIM y interfaces pasivas PIM. Particularmente, una interfaz ruteada configurada con el modo pasivo PIM no pasa/tráfico del plano delantero del control PIM; pasa solamente/adelante tráfico IGMP.

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • El router Stub PIM no rutea el tráfico de tránsito entre los routeres de distribución. Este comportamiento es aplicado por el ruteo de stub del (EIGRP) del unicast. La configuración apropiada del ruteo de stub del unicast se requiere para ayudar a este comportamiento del router Stub PIM. La característica del stub PIM no previene al administrador de router que configura el RIP, las Static rutas, o PIM RP para desviar esta restricción.

  • Solamente los receptores directo-conectados y las fuentes del (IGMP) del Multicast se permiten en los dominios del acceso de la capa 2. El protocolo PIM no se soporta en los dominios del acceso.

  • La topología redundante del router Stub PIM no se soporta.

Componentes Utilizados

La información en este documento se basa en la salida del Catalyst 3750 Switch.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Productos Relacionados

Esta configuración se puede también utilizar con estos tipos de switch:

  • Switches de las Catalyst 3750 y 3560 Series

Versión del código 12.2(37)SE del Stub Multicast Routing del soporte PIM de los Cisco Catalyst 3750 y 3560 Switch y posterior.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

El PIM SS se utiliza en el uplinks para comunicar con el router ascendente. Los usuarios pueden utilizar a cualquier otro modo PIM (por ejemplo, denso o escaso).

Para más información sobre la configuración del ruteo multicast en los 3750 Series Switch, refiera a configurar el IP Multicast Routing.

Nota: Utilice la herramienta Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos utilizados en esta sección.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/98289/pim_stub-1.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Complete estos pasos para configurar el ruteo de stub PIM:

  1. Publique este comando de habilitar el ruteo multicast global en el Switch o el stack del Switch:

    mix_stack(config)#ip multicast-routing distributed
    
  2. Publique este comando de definir el rango SS del IP Multicast Address con el rango del grupo predeterminado:

    mix_stack(config)#ip pim ssm default
    
  3. Publique este comando de habilitar PIM SS en el uplink:

    mix_stack(config)#interface GigabitEthernet3/0/25
    
    
    !--- By default switch configures the Layer 2 parameters.
    So in order to configure the Layer 3 parameter, use the next command.
    
    mix_stack(config-if)#no switchport
    
    mix_stack(config-if)#ip pim sparse-dense-mode
    
  4. Publique este comando de habilitar el ruteo de stub PIM en la interfaz VLAN:

    mix_stack(config)#interface vlan100
    mix_stack(config-if)#ip pim passive
    

Conmute la configuración (del mix_stack)

mix_stack#show run
Building configuration...
 
Current configuration : 7810 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname mix_stack
!
!
switch 2 provision ws-c3750e-24pd
switch 3 provision ws-c3750g-24ts
switch 5 provision ws-c3750-24fs
switch 9 provision ws-c3750e-24pd
!
ip routing
!
!
ip multicast-routing distributed
!
!--- Output suppressed.
!
!
vlan 100
!
!
interface GigabitEthernet2/0/1
switchport access vlan 100
no keepalive
spanning-tree portfast
!
interface GigabitEthernet2/0/2
switchport access vlan 100
no keepalive
spanning-tree portfast
!
!
!--- Output suppressed.
!
!
interface GigabitEthernet3/0/25
no switchport
ip address 3.1.1.2 255.255.255.248
ip pim sparse-dense-mode
!
!
!--- Output suppressed.
!
!
interface GigabitEthernet9/0/24
no switchport
ip address 10.1.1.1 255.255.255.0
ip pim passive
no keepalive
!
!
!--- Output suppressed.
!
!
interface Vlan1
no ip address
!
interface Vlan100
ip address 100.1.1.1 255.255.255.0
ip pim passive
!
!
!--- Output suppressed.
!
! 
ip pim ssm default
!
!
!--- Output suppressed.
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
speed 115200
line vty 0 4
login
line vty 5 15
login
!
end

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Publique el comando show ip pim interface para visualizar el stub PIM que es permiso para cada interfaz.

mix_stack#show ip pim interface 

Address    Interface               Ver/    Nbr     Query   DR     DR
                                   Mode    Count   Intvl   Prior

3.1.1.2    GigabitEthernet3/0/25   v2/SD   1       30      1      3.1.1.2
100.1.1.1  Vlan100                 v2/P    0       30      1      100.1.1.1
10.1.1.1   GigabitEthernet9/0/24   v2/P    0       30      1      10.1.1.1

Publique al detalle de los grupos IGMP del IP de la demostración para visualizar al cliente interesado que se ha unido al origen de multidifusión/al grupo específicos.

mix_stack#show ip igmp groups 232.0.0.9 det

Flags: L - Local, U - User, SG - Static Group, VG - Virtual Group,
SS - Static Source, VS - Virtual Source,
Ac - Group accounted towards access control limit

Interface: GigabitEthernet9/0/24
Group: 232.0.0.9
Flags: SSM 
Uptime: 00:00:10
Group mode: INCLUDE
Last reporter: 10.1.1.2
CSR Grp Exp: 00:02:57
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, M - SSM Mapping, L - Local,
Ac - Channel accounted towards access control limit)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
200.1.1.3 00:00:10 stopped 00:02:57 Yes CM

Interface: Vlan100
Group: 232.0.0.9
Flags: SSM 
Uptime: 01:42:08
Group mode: INCLUDE
Last reporter: 100.1.1.3
CSR Grp Exp: 00:02:00
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, M - SSM Mapping, L - Local,
Ac - Channel accounted towards access control limit)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
200.1.1.3 01:42:12 stopped 00:02:00 Yes CM
mix_stack#

Publique la ruta multicast del IP de la demostración para verificar que la secuencia de multidifusión adelante de la fuente a los clientes interesados.

mix_stack#show ip mroute 232.0.0.9
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report, 
Z - Multicast Tunnel, z - MDT-data group sender, 
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(200.1.1.3, 232.0.0.9), 01:44:23/00:02:52, flags: sTI
Incoming interface: GigabitEthernet3/0/25, RPF nbr 3.1.1.1
Outgoing interface list:
GigabitEthernet9/0/24, Forward/Sparse-Dense, 00:02:24/00:02:50
Vlan100, Forward/Sparse-Dense, 01:44:23/00:02:52

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 98289