Switches : Switches Cisco Catalyst de la serie 3750

Cisco Catalyst 3750 ejemplos de la configuración de QoS

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

Cisco Catalyst 3750 Switches soportan varias características de QoS tales como clasificación, marcado, control de tráfico, colocación en cola y programación. Este documento explica estas características de QoS con los ejemplos de configuración.

prerrequisitos

Requisitos

Cisco recomienda que tenga conocimiento sobre la Configuración de QoS.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco Catalyst 3750 Switch - WS-C3750-24TS

  • Software Release 12.2(35)SE2 de Cisco IOS�

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Descripción de QoS

Con el QoS, puede proporcionar tratamiento preferencial a tipos determinados de tráfico a expensas de otros. Puede diferenciar el tráfico con las etiquetas de QoS. Las dos etiquetas que se usan con más frecuencia en el encabezado IP de la Capa 3 son el campo de precedencia IP y el campo DSCP. La etiqueta de QoS en el encabezado de trama de la Capa 2 se denomina Clase de Servicio (CoS). Las herramientas de QoS del Catalyst switch pueden proporcionar tratamiento preferencial en función de las etiquetas de QoS de la Capa 2 o de las etiquetas de QoS de la Capa 3. Este documento proporciona diversos ejemplos que pueden darle una idea del uso de las etiquetas de QoS de la Capa 2 y de la Capa 3 en los switches de Cisco Catalyst.

/image/gif/paws/91862/cat3750-qos-config1.gif

Cisco Catalyst 3750 Switch sin QoS

QoS se inhabilita de forma predeterminada en los Catalyst 3750 Switches. Mientras que el QoS se inhabilita, todas las tramas/paquetes se pasan por el switch inalterado. Por ejemplo, si una trama con CoS 5 y el paquete dentro de la trama con DSCP EF ingresa al switch, las etiquetas CoS y DSCP no se modifican. El tráfico se va con el mismo CoS y los valores DSCP con los que ingresa. Todo el tráfico, que incluye la voz, se administra con el mejor esfuerzo.

Switch#show mls qos
QoS is disabled
QoS ip packet dscp rewrite is enabled

!--- Even though it says QoS ip packet dscp rewrite is enabled,
!--- the switch does not alter the DSCP label on the packets when 
!--- the QoS is disabled.

Características de QoS del Cisco Catalyst 3750 Switch

Una vez habilitado el QoS en el 3750 Switch, hay pocas características de QoS de ingreso y egreso habilitadas de forma predeterminada. Este diagrama muestra la vista de alto nivel de la arquitectura de QoS del switch:

/image/gif/paws/91862/cat3750-qos-config2.gif

Éste es un resumen de los puntos basados en el diagrama:

  • Las características de QoS de ingreso tales como clasificación, marcado y control de tráfico pueden configurarse por puerto.

  • Las tablas del mapa de entrada y la colocación en colas de ingreso se pueden configurar de forma global. Éstas no pueden configurarse por puerto.

  • El SRR para la cola de ingreso se puede configurar de forma global.

  • El ancho de banda del anillo stack depende del cableado del stack. Si el stack está conectado en el ancho de banda completo, recibe el ancho de banda de 32 Gbps. Este ancho de banda es compartido por todos los switches en el stack.

  • Las tablas del mapa de resultado y las colas de egreso se configuran de forma global. Puede tener dos conjuntos de configuraciones de cola y aplicar cualquiera de las configuraciones de conjunto de cola a un puerto.

  • El SRR para la cola de salida se puede configurar en función de cada puerto.

Características de QoS de Ingreso

Esta sección explica los conceptos de las diferentes configuraciones de QoS posibles de ingreso. Esta sección incluye los siguientes temas:

Configuración de QoS Predeterminada de Ingreso

De esta manera el switch trata a las tramas de forma predeterminada después de que se habilita el QoS:

  • Una trama ingresa al puerto del switch y no etiqueta a la trama (significa que el puerto es un puerto de acceso y la trama que ingresa al switch no tiene encapsulación ISL o dot1q).

  • El switch encapsula la trama con dot1q (ignore ISL porque el dot1q es el valor predeterminados en todos los switches nuevos).

  • Dentro de la etiqueta de la trama dot1q, hay tres bits llamados bits de prioridad 802.1p disponibles que también se llaman CoS. Estos bits se configuran en 0.

  • Entonces, el switch calcula el valor DSCP basado en la tabla del mapa CoS-DSCP. Según la tabla, el switch establece el valor DSCP en 0. El valor DSCP está situado en el encabezado IP del paquete.

En resumen, los valores CoS y DSCP de la trama ingresan al switch configurados en 0 de forma predeterminada si el QoS se habilita en el switch.

Clasificación y marcado

A diferencia de los routers, la clasificación de QoS y de marcado se comportan de forma diferente en los switches de Cisco Catalyst. En los routers Cisco, puede clasificar los paquetes con el MQC en función del valor del paquete entrante DSCP o en función de la lista de control de acceso (ACL). Esto depende de si confía en la etiqueta de QoS del paquete entrante o no. En el Cisco Catalyst 3750 Switch, puede clasificar las tramas basadas en los valores entrantes del CoS/DSCP o basadas en el ACL.

La configuración basada en el valor entrante del CoS/DSCP se alcanza de tres formas diferentes:

Puede utilizar cualquiera de estos tres métodos. No puede utilizar más de un método en un puerto. Por ejemplo, ha configurado el comando mls qos trust cos en un puerto. Cuando configura el puerto con el comando service-policy input, <policy-map-name> , quita al comando mls qos trust cos automáticamente.

La sección Clasificación y Marcado Basados en el Puerto explica la configuración basada en el puerto.

La sección Clasificación y Marcado Basadosen MQC explica la clasificación basada en MQC.

Clasificación y Marcado Basados en el Puerto

Esta sección explica la clasificación basada en la configuración específica de la interfaz. Puede surgir una pregunta con la sección de clasificación y marcado. Esto se debe a que Cisco Catalyst 3750 Switch, CoS o los valores DSCP de las tramas (paquete dentro de la trama) se remarcan con las tablas del mapa. Las tablas del mapa no están disponibles en los routers de Cisco. Estas están disponibles solamente en los switches de Cisco Catalyst. Esta sección explica las funciones de estas tablas.

Esta sección trata sobre estas dos configuraciones:

/image/gif/paws/91862/cat3750-qos-config3.gif

Clasificación: Configuración de Confiabilidad del Puerto

Un paquete entrante o una trama puede tener una etiqueta de QoS asignada. Pueden surgir las siguientes preguntas:

  • ¿Confía en la etiqueta de QoS del paquete entrante/trama en un puerto?

  • Si un teléfono IP y un equipo están conectados con un puerto, ¿confía en las etiquetas de QoS del teléfono, del equipo o de ambos?

Si no confía en las etiquetas de QoS del paquete entrante/trama, debe clasificar el paquete basado en una etiqueta de QoS de la lista de acceso y de la marca. Si confía en las etiquetas de QoS del paquete entrante/trama, otra pregunta es: ¿debe confiar en el valor de CoS o el valor DSCP del paquete entrante/trama en un puerto? Esto depende del escenario. Puede ver los diversos escenarios con ejemplos en esta sección.

La opción de configuración de confiabilidad del puerto es:

Switch(config-if)#mls qos trust ?
  cos            cos keyword
  device         trusted device class
  dscp           dscp keyword
  ip-precedence  ip-precedence keyword
  <cr>
  • Ejemplo 1: Si el puerto es un puerto de acceso o un puerto de la Capa 3, debe configurar el comando mls qos trust dscp. No puede utilizar el comando mls qos trust cos porque la trama del puerto de acceso o del puerto de la Capa 3 no contiene el dot1q o la etiqueta ISL. Los bits del CoS están presentes en dot1q o ISL frame solamente.

    interface GigabitEthernet1/0/1
     description **** Layer 3 Port ****
     no switchport
     ip address 192.168.10.1 255.255.255.0
     mls qos trust dscp
    end
    interface GigabitEthernet1/0/2
     description **** Access Port ****
     switchport access vlan 10
     switchport mode access
     mls qos trust dscp
    end
  • Ejemplo 2: Si el puerto es un puerto de trunk, puede configurar el comando mls qos trust cos o el comando mls qos trust dscp. La tabla del mapa dscp-cos se utiliza para calcular el valor del CoS si el puerto se configura para que confíe en el DSCP. De forma similar, la tabla del mapacos-dscp se utiliza para calcular el valor DSCP si el puerto se configura para confiar en el CoS.

    interface GigabitEthernet1/0/3
    description **** Trunk Port ****
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport trunk native vlan 5
    switchport trunk allowed vlan 5,10,20,30,40,50
    mls qos trust cos
    end
    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     spanning-tree portfast
    end
    
    !--- The Cisco IP Phone uses IEEE 802.1Q frames for Voice 
    !--- VLAN traffic.
    
    
  • Ejemplo 3: Si el puerto es un puerto trunk dot1q y el puerto se configura con el comando mls qos trust cos, las tramas de VLAN nativa tendrán los valores CoS y DSCP en 0. Debido a que las tramas de la VLAN nativa no son etiquetadas y la trama se etiqueta después de que ingrese al switch, el switch fijará el valor predeterminado del CoS en 0 y la tabla del CoS-to-DSCP establece el valor DSCP en 0.

    Nota: El valor DSCP del paquete que proviene de la VLAN nativa será restablecido a 0.

    También puede configurar el puerto del switch para cambiar el valor predeterminado de CoS de las tramas sin etiqueta de 0 a cualquier otro valor entre 0-7 con el comando mls qos cos<0-7> . Este comando no modifica los valores CoS de las tramas etiquetadas.

    Por ejemplo, el puerto GigabitEthernet1/0/12 se configura con el acceso VLAN10 y la voz VLAN20.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     spanning-tree portfast
    
    !--- The Cisco IP Phone uses IEEE 802.1Q frames for Voice 
    !--- VLAN traffic. Voice VLAN is only supported on access ports and not  
    !--- on trunk ports, even though the configuration is allowed.
    
    end

    De forma predeterminada, el equipo envía los datos sin etiqueta. El tráfico sin etiqueta del dispositivo conectado a Cisco IP Phone pasa a través del teléfono sin etiqueta, independientemente del estado confiable del puerto de acceso en el teléfono. El teléfono envía las tramas etiquetadas dot1q con la ID de VLAN de voz 20. Por lo tanto, si configura el puerto con el comando mls qos trust cos, confía en los valores de CoS de las tramas del teléfono (tramas etiquetadas) y establece el valor de CoS de las tramas (sin etiqueta) del equipo en 0. Luego, la tabla de mapa de CoS-DSCP establece el valor DSCP del paquete dentro de la trama en 0 porque la tabla de mapa de CoS-DSCP tiene valor DSCP 0 para el valor 0 de CoS. Si los paquetes del equipo tienen algún valor específico DSCP, ese valor será restablecido a 0. Si configura el comando mls qos cos 3 en el puerto, establece el valor CoS de todas las tramas del equipo a 3 y no configura el valor CoS de las tramas desde el teléfono.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     mls qos cos 3
     spanning-tree portfast
    end

    Si configura el puerto con el comando mls qos cos 3 override , configura los valores CoS de todas las tramas (tanto etiquetadas como sin etiqueta) en 3. Invalida los valores seguros previamente configurados.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     mls qos cos 3 override
    
    !--- Overrides the mls qos trust cos.
    
    
    !--- Applies CoS value 3 on all the incoming packets on both 
    !--- the vlan 10 and 20.
    
     spanning-tree portfast
    end
  • Ejemplo 4: Por ejemplo, consulte la configuración del puerto gi 1/0/12:

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     spanning-tree portfast
    end

    Si el equipo etiqueta su trama con la VLAN20, también establece un valor CoS de 5. El switch procesa el tráfico de datos etiquetado (tráfico en tipos de tramasIEEE 802.1Q o IEEE 802.1P) del dispositivo conectando al puerto de acceso en el Cisco IP Phone. Como la interfaz está configurada para que confíe en el valor CoS, todo el tráfico recibido a través del puerto de acceso en el Cisco IP Phone pasa a través del teléfono sin modificarse. El switch también confía en y permite el tráfico del equipo, y otorga la misma prioridad que el tráfico del teléfono IP. Este no es el resultado que desearía ver. Puede evitarse con el comando switchport priority extend cos <cos-value>.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     switchport priority extend cos 0
    
    !--- Overrides the CoS value of PC traffic to 0.
    
     spanning-tree portfast
    end

    El comando switchport priority extend cos <cos-value> configura el teléfono de tal manera que el teléfono IP cambia el valor CoS del tráfico del equipo a 0.

  • Ejemplo 5: Por ejemplo, en la misma interfaz, alguien conecta el equipo directamente con el switch y etiqueta los datos del equipo con la trama dot1q con un valor más alto de CoS. Esto puede evitarse con el comando mls qos trust device cisco-phone.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     switchport priority extend cos 0
     mls qos trust device cisco-phone 
    
    !--- Specify that the Cisco IP Phone is a trusted device.
    
     spanning-tree portfast
    end
  • Ejemplo 6: Por ejemplo, en la interfaz GigabitEthernet1/0/12, tiene que confiar en las etiquetas QoS del equipo. Además, el equipo está conectado con la VLAN nativa 10. En este caso, el comando mls qos trust cos no ayuda porque el paquete del equipo no etiqueta el valor de CoS etiquetado. Solamente etiquetará el valor DSCP. Por lo tanto, el switch agrega la trama dot1q y configura el valor predeterminado de CoS en 0. Entonces, la tabla CoS-DSCP calcula y restablece el valor DSCP a 0.

    Para solucionar este problema, tiene dos opciones. Uno es configurar la clasificación y el marcado con el MQC. Puede crear un ACL para que coincida con el tráfico de su equipo basado en la fuente, las direcciones IP de destino, y los números de puerto de origen o destino. Entonces, puede hacer coincidir este ACL en class-map. Puede crear un policy-map para confiar en este tráfico. Esta solución se trata en la siguiente sección. Esta sección trata sobre el segundo método. El segundo método es confiar en la etiqueta DSCP en lugar de la etiqueta CoS. Luego, la etiqueta DSCP-CoS calcula y establece el valor de CoS que se corresponde con el valor DSCP.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust dscp
     spanning-tree portfast
    end

    Se prefiere el primer método porque no se recomienda confiar en las etiquetas QoS de todo el tráfico del equipo.

Marcado: Configuración de las Tablas de Mapa de QoS

Una vez habilitado el QoS, las tablas de mapa se crean con los valores predeterminados y se habilitan.

Distribution1#show mls qos maps cos-dscp
   Cos-dscp map:
        cos:   0  1  2  3  4  5  6  7
     --------------------------------
       dscp:   0  8 16 24 32 40 48 56

Distribution1#show mls qos maps dscp-cos
   Dscp-cos map:
     d1 :  d2 0  1  2  3  4  5  6  7  8  9
     ---------------------------------------
      0 :    00 00 00 00 00 00 00 00 01 01
      1 :    01 01 01 01 01 01 02 02 02 02
      2 :    02 02 02 02 03 03 03 03 03 03
      3 :    03 03 04 04 04 04 04 04 04 04
      4 :    05 05 05 05 05 05 05 05 06 06
      5 :    06 06 06 06 06 06 07 07 07 07
      6 :    07 07 07 07
  • Ejemplo 1: Si el puerto se configura para confiar en el CoS, todos los valores entrantes del CoS son de confianza y se remarcan los valores DSCP en función de la tabla de CoS-DSCP. Según la configuración predeterminada de CoS-DSCP, los valores se mapean como se muestra aquí:

    CoS DSCP (decimal) DSCP
    0 0 Predeterminado
    1 8 CS1
    2 16 CS2
    3 24 CS3
    4 32 CS4
    5 40 CS5
    6 48 CS6
    7 56 CS7

    Un dato importante que debe observar aquí es que el valor DSCP corresponde al valor CoS 5. Es CS5. El ejemplo 2 hace referencia a este valor.

  • Ejemplo 2: Por ejemplo, la interfaz GigabitEthernet1/0/12 se configura para confiar en el CoS.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     spanning-tree portfast
    end

    El Cisco IP Phone marca la carga útil de voz con el CoS 5 y el DSCP EF cuando envía el tráfico al switch. Cuando el tráfico ingresa al puerto Gi 1/0/12, el switch confía en el valor de CoS. Entonces, el switch deriva el valor DSCP CS5 (40) para el valor 5 del CoS de la tabla CoS-DSCP. Todas las cargas útiles de voz con el CoS 5 son marcadas con el valor CS5 DSCP. Éste no es el valor deseable. El valor requerido DSCP para la carga útil de voz es DSCP EF. De forma predeterminada, los otros valores de CoS a los valores DSCP se mapean de forma correcta según los RFCs.

    Esta configuración lo ayuda a configurar la tabla de mapa de CoS-DSCP para cambiar el valor EF DSCP que corresponde al CoS 5.

    Distribution1(config)# mls qos map cos-dscp 0  8 16 
    24 32 46 48 56
    
    !--- DSCP 46 is EF
    
    

    Después de esta configuración, los valores se mapean como se muestra aquí:

    CoS DSCP (decimal) DSCP
    0 0 Predeterminado
    1 8 CS1
    2 16 CS2
    3 24 CS3
    4 32 CS4
    5 46 EF
    6 48 CS6
    7 56 CS7

  • Ejemplo 3: Si el puerto se configura para confiar en el DSCP, todos los valores entrantes DSCP son de confianza y los valores de CoS están remarcados en la tabla DSCP-CoS. Según la configuración predeterminada de DSCP-CoS, los valores se mapean como se muestra aquí:

    DSCP DSCP (decimal) CoS
    Predeterminado 0-7 0
    CS1 AF11 AF12 AF13 8-15 1
    CS2 AF21 AF22 AF23 16-23 2
    CS3 AF31 AF32 AF33 24-31 3
    CS4 AF41 AF42 AF43 32-39 4
    CS5 EF 40-47 5
    CS6 48-55 6
    CS7 56-63 7

    No necesita cambiar estos valores predeterminados.

Esta tabla resume los valores DSCP y los valores CoS sólo para referencia:

DSCP (decimal) DSCP CoS
0 Predeterminado 0
     
8 CS1 1
10 AF11 1
12 AF12 1
14 AF13 1
     
16 CS2 2
18 AF21 2
20 AF22 2
22 AF23 2
     
24 CS3 3
26 AF31 3
28 AF32 3
30 AF33 3
     
32 CS4 4
34 AF41 4
36 AF42 4
38 AF43 4
     
40 CS5 5
42   5
44   5
46 EF 5
     
48 CS6 6
     
56 CS7 7

Nota: En una red, todos los switches de Cisco Catalyst deben tener tablas de mapa idénticas. Diversos valores de la tabla de mapa en diversos switches provocan el comportamiento indeseable de QoS.

Clasificación y Marcado Basados en MQC

Como se explica en la sección de la Clasificación y Marcado, puede utilizar el MQC para clasificar y para marcar el paquete. Puede utilizar el MQC en vez de la configuración específica del puerto. También puede marcar los paquetes entrantes con policy-map.

Los requisitos de este ejemplo son:

  • Confíe en los valores de CoS del tráfico del teléfono IP.

  • Marque el valor DSCP de los paquetes de la aplicación softphone del equipo que está conectado con el teléfono IP.

  • Retire la confianza del resto del tráfico del equipo.

cat3750-qos-config4.gif

Este diagrama muestra que policy-map está conectado a la entrada de una interfaz. No puede aplicar un policy-map a la salida de ninguna interfaz en el Catalyst 3750 Switch. La siguiente configuración representa el diagrama. Esta sección no se centra en la colocación en cola de la función QoS. La sección sólo se centra en el MQC aplicado en la interfaz.

Se asume que la VLAN de datos es 10 y su dirección de subred es 172.16.10.0/24. La voz VLAN es 100 y su dirección de subred es 192.168.100.0/24.


!--- Section A

Distribution1(config)#ip access-list extended voice-traffic
Distribution1(config-std-nacl)#permit ip 192.168.100.0 0.0.0.255 any

Distribution1(config-std-nacl)#ip access-list extended
 database-application
Distribution1(config-ext-nacl)#permit tcp any any eq 1521
Distribution1(config-ext-nacl)#permit tcp any any eq 1810
Distribution1(config-ext-nacl)#permit tcp any any eq 2481
Distribution1(config-ext-nacl)#permit tcp any any eq 7778
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map  Class-A
Distribution1(config-cmap)#match access-group name voice-traffic
Distribution1(config-cmap)#exit
Distribution1(config)#class-map  Class-B
Distribution1(config-cmap)#match access-group name
 database-application
Distribution1(config-cmap)#exit


!--- Section B

Distribution1(config)#policy-map sample-policy1
Distribution1(config-pmap)#class Class-A
Distribution1(config-pmap-c)#trust cos
Distribution1(config-pmap-c)#exit
Distribution1(config-pmap)#class Class-B
Distribution1(config-pmap-c)#set dscp af21
Distribution1(config-pmap-c)#exit
Distribution1(config-pmap)#exit


!--- Section C

Distribution1(config)#interface gigabitEthernet 1/0/13
Distribution1(config-if)#switchport access vlan 10
Distribution1(config-if)#switchport mode access
Distribution1(config-if)#switchport voice vlan 100
Distribution1(config-if)#spanning-tree portfast
Distribution1(config-if)#service-policy input sample-policy1
Distribution1(config-if)#exit

Sección A:

  • Clasifica el tráfico del teléfono IP a la Clase A. El teléfono IP pertenece a la VLAN de voz y tiene una dirección IP en la subred de 192.168.100.0.

  • Clasifica el tráfico de la aplicación de base de datos a la Clase B. El tráfico del equipo (realmente cualquier tráfico según la configuración) destinado a cualquier destino con los números de puerto 1521, 1810, 2481, 7778 se clasifica en el mapa de clase Clase B.

Sección B:

  • Las coincidencias de tráfico Clase A están configuradas para que confíen en la etiqueta CoS. Esto significa que los valores de CoS de todo el tráfico del teléfono IP son de confianza. Como se muestra en el diagrama, el valor DSCP deriva de la tabla de mapaCoS-DSCP para el tráfico de Clase A.

  • Las coincidencias de tráfico Clase B están configuradas para establecer el valor DSCP en AF21. Como se muestra en el diagrama, el valor de DCoS deriva de la tabla de mapaDSCP-CoS para el tráfico de Clase B.

  • Las configuraciones en cada clase de policy-map se llaman acciones PHB. El marcado, la colocación en cola, el control de tráfico, el modelado, y la prevención de congestión son las acciones soportadas PHB en los routers Cisco. El marcado y el control de tráfico son las únicas acciones soportadas por PHB en Cisco Catalyst 3750 Switch.

    Distribution1(config)#policy-map test
    Distribution1(config-pmap)#class test
    Distribution1(config-pmap-c)#?
    QoS policy-map class configuration commands:
      exit            Exit from QoS class action configuration mode
      no              Negate or set default values of a command
      police          Police
      service-policy  Configure QoS Service Policy
      set             Set QoS values
      trust           Set trust value for the class
      <cr>

    Los comandos set y trust son acciones PHB de marcado Puede configurar la acción PHB set o trust. No puede configurar ambas acciones en una clase de policy-map. Sin embargo, puede configurar set en una clase y trust en otra clase en el mismo policy-map.

    El comando police es la acción de Regulación de PHB. Esto se trata detalladamente en la siguiente sección.

    El Modelado no se soporta en Cisco Catalyst 3750 Switch. La colocación en cola y la prevención de congestión se soportan en Cisco Catalyst 3750 Switch, pero no son configurables con MQC. Las configuraciones colocación en cola y prevención de la congestión se discuten en detalle más adelante en este documento.

Sección C:

  • El policy-map se puede aplicar solamente a la entrada en la interfaz. Cuando aplica a la interfaz de salida, recibe este mensaje de error:

    Distribution1(config)#int gi 1/0/3
    Distribution1(config-if)#service-policy output test
    Warning: Assigning a policy map to the output side of an
             interface not supported
    
    Service Policy attachment failed
    Warning: Assigning a policy map to the output side of an
             interface not supported
  • Si otros métodos de la Clasificación de QoS, tales como basado en puerto o basado en VLAN, se configuran en el puerto gi 1/0/3, dichas configuraciones se quitan cuando aplica el policy-map. Por ejemplo, el puerto Gi 1/0/13 se configura para confiar en el CoS como se muestra aquí:

    interface GigabitEthernet1/0/13
     description **** Access Port ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
     mls qos cos 3
     mls qos trust cos
     spanning-tree portfast
  • Cuando aplica el policy-map a la interfaz, elimina el comando trust.

    Distribution1(config)#int gi 1/0/13
    Distribution1(config-if)#service-policy input sample-policy1
    Distribution1(config-if)#do show run int gi 1/0/13
    Building configuration...
    
    Current configuration : 228 bytes
    !
    interface GigabitEthernet1/0/13
     description **** Access Port ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
     service-policy input sample-policy1  
     
    !--- It replaces the mls qos trust or mls qos 
    !--- vlan-based command.
    
     mls qos cos 3    
     
    !--- This command is not removed.
    
     spanning-tree portfast
    end

    Puede ver que el service-policy input substituye solamente al comando mls qos trust o al comando mls qos vlan-based. No modifica los otros comandos, como los comandos mls qos cos o mls qos dscp-mutation. En resumen, substituye el comando de la clasificación de QoS y no substituye los comandos de marcado de QoS.

  • En el policy-map, ve solamente dos class-maps. La Clase A se corresponde con el tráfico del teléfono del IP y la Clase B se corresponde con el tráfico de la aplicación de base de datos del equipo. El resto del tráfico del equipo (excepto la aplicación de base de datos definida en la lista de acceso) se clasifica en class-default class del policy-map. Éste es un tráfico catch-all que captura el tráfico que no corresponde con el class-maps definido conectado al policy-map. Por lo tanto, este tráfico que pertenece al class-default no es de confianza para el puerto, y dichos paquetes se configuran con el CoS predeterminado y las etiquetas DSCP como 0. Puede configurar cualquier CoS predeterminado o valor DSCP a este tráfico de class-default.

    Puede determinar el valor predeterminado DSCP con el MQC. El valor del CoS deriva de la tabla de mapa del DSCP-CoS.

    Distribution1(config)#policy-map sample-policy1
    Distribution1(config-pmap)#class class-default
    Distribution1(config-pmap-c)#set dscp af13
    Distribution1(config-pmap-c)#exit
    

    Puede establecer el valor predeterminado del CoS como se muestra aquí. El valor DSCP deriva de la tabla de mapa del CoS-DSCP.

    Distribution1(config)#int gi 1/0/13
    Distribution1(config-if)#mls qos cos 3
    Distribution1(config-if)#do show run int gi 1/0/13
    Building configuration...
    
    Current configuration : 228 bytes
    !
    interface GigabitEthernet1/0/13
     description **** Access Port ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
     service-policy input sample-policy1  
     mls qos cos 3    
     spanning-tree portfast

Fije la prioridad más alta al tráfico

En este ejemplo, la configuración se utiliza para fijar la prioridad más alta al tráfico del puerto TCP 1494.

  1. Tráfico de VoIP necesita ser asignado un valor DSCP del EF:

    
    !--- Classifying all traffic coming with dscp value of EF 
    !--- under this class-map.
    
    Switch(config)# class-map match-all AutoQoS-VoIP-RTP-Trust
    Switch(config-cmap)# match ip dscp ef 
    
    Switch(config)# policy-map AutoQoS-Police-CiscoPhone
    Switch(config-pmap)# class AutoQoS-VoIP-RTP-Trust
    
    !--- Again setting the dscp value back to EF.
    
    Switch(config-pmap-c)# set dscp ef
    Switch(config-pmap-c)# police 320000 8000 exceed-action 
    policed-dscp-transmit
    
  2. Tráfico de TCP 1494 necesita ser asignado un valor DSCP de CS4:

    Switch(config)# access-list 100 permit tcp <source source-wildcard>
                 <destination destination-wildcard> eq 1494
    
    Switch(config)# class-map tcp 
    Switch(config-cmap)# match access-group 100
    
    Switch(config)# policy-map AutoQoS-Police-CiscoPhone
    Switch(config-pmap)# class tcp
    Switch(config-pmap-c)# set dscp cs4
    
  3. El resto del tráfico necesita ser asignado CS3:

    Switch(config)# access-list 200 permit ip any any
    
    Switch(config)# class-map default
    Switch(config-cmap)# match access-group 200
    
    Switch(config)# policy-map AutoQoS-Police-CiscoPhone
    Switch(config-pmap)# class default
    Switch(config-pmap-c)# set dscp cs3
    
  4. Apliqúelo bajo interfaces pertinentes:

    Switch(config)# interface <interface-type><interface number>
    
    Switch(config-if)# service-policy <policy-map-name>
    
    

Control de tráfico

En el Cisco Catalyst 3750 Switch, el control de tráfico se puede configurar solamente en el puerto de ingreso. El control de tráfico se puede configurar solamente con el MQC. Esto significa que no hay un comando específico de la interfaz para controlar el tráfico. Puede configurar el control de tráfico en policy-map y aplicar el policy-map usando solamente el comando service-policy input <policy-name>. No puede aplicar ningún policy-map en el lado de salida de una interfaz.

Distribution1(config-if)#service-policy output test
police command is not supported for this interface
Configuration failed!
Warning: Assigning a policy map to the output side of an 
         interface not supported.

Esta sección trata estos temas:

Clasificación, Marcado y Control de Tráfico (acción de exceso - eliminar)

Esta sección explica la configuración de control de tráfico que elimina el tráfico excesivo. El control de tráfico mide el tráfico entrante y mantiene la velocidad entrante a los bits por segundo configurados. El Cisco Catalyst 3750 Switch soporta solamente control de tráfico de velocidad única y una sola cubeta. Esto significa que el switch mide solamente a una velocidad y puede perfilar el tráfico en dos colores acciones de conformidad y excedente. El diagrama muestra un policy-map ample-policy2 con tres class-maps.

Los requisitos de este ejemplo son:

  • Controle ftp, pop3, imap traffic a 10 Mbps.

  • Confíe en el valor DSCP de los paquetes de la aplicación del comunicador IP del equipo que está conectado con el teléfono IP. También, el requisito es controlar este tráfico a 1 Mbps.

  • Marque y controle la aplicación filnet.

cat3750-qos-config5.gif

Esta configuración representa el policy-map mencionado en el diagrama:


!--- Create Access-list and Class map Class-A

Distribution1(config)#ip access-list extended BULK-DATA
Distribution1(config-ext-nacl)#permit tcp any any eq ftp
Distribution1(config-ext-nacl)#permit tcp any any eq ftp-data
Distribution1(config-ext-nacl)#permit tcp any any eq pop3
Distribution1(config-ext-nacl)#permit tcp any any eq 143
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-A
Distribution1(config-cmap)#match access-group name BULK-DATA
Distribution1(config-cmap)#exit


!--- Create Access-list and Class map Class-B

Distribution1(config)#ip access-list extended IP-Communicator
Distribution1(config-ext-nacl)#remark *** Voice Payload ***
Distribution1(config-ext-nacl)#permit udp any any range 16384 32767
Distribution1(config-ext-nacl)#remark *** Voice Signalling ***
Distribution1(config-ext-nacl)#permit tcp any any range 2000 2002
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-B
Distribution1(config-cmap)#match access-group name IP-Communicator
Distribution1(config-cmap)#exit


!--- Create Access-list and Class map Class-C

Distribution1(config)#ip access-list extended application
Distribution1(config-ext-nacl)#remark *** Application for example ***
Distribution1(config-ext-nacl)#permit tcp any any eq 32768
Distribution1(config-ext-nacl)#permit udp any any eq 32768
Distribution1(config-ext-nacl)#permit tcp any any eq 32769
Distribution1(config-ext-nacl)#permit udp any any eq 32769
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-C
Distribution1(config-cmap)#match access-group name application
Distribution1(config-cmap)#exit


!--- Create Policy map

Distribution1(config-cmap)#policy-map sample-policy2
Distribution1(config-pmap)#class Class-A
Distribution1(config-pmap-c)#police 10000000 8000 exceed-action drop
Distribution1(config-pmap-c)#class Class-B
Distribution1(config-pmap-c)#trust dscp
Distribution1(config-pmap-c)#police 256000 8000 exceed-action drop
Distribution1(config-pmap-c)#class Class-C
Distribution1(config-pmap-c)#set dscp CS2
Distribution1(config-pmap-c)#police 25000000 8000 exceed-action drop
Distribution1(config-pmap-c)#exit
Distribution1(config-pmap)#exit


!--- Apply Policy map to the interface

Distribution1(config)#interface GigabitEthernet1/0/20
Distribution1(config-if)#service-policy input sample-policy2

La configuración en el policy-map se explica a continuación:

  • Clase-UNo: El tráfico que concuerda con la Clase A se controla a una velocidad de 10 Mbps. Las etiquetas QoS en el tráfico de Clase A no son seguras. Los valores CoS y DSCP son marcados como 0. Los paquetes excesivos son descartados por el regulador de tráfico.

  • Clase-B: Hay dos acciones PHB que se realizan en el tráfico que concuerdan con la Clase B. Una es la confianza y la segunda, el control de tráfico. El valor DSCP para el tráfico de Clase B es de confianza. El valor del CoS será derivado de la tabla DSCP-CoS. Luego, el tráfico de Clase B se controla a una velocidad de 256 Kbps. Los paquetes excesivos son descartados por el regulador de tráfico.

  • Clase-C: Hay dos acciones PHB que se realizan en el tráfico que concuerdan con la Clase B. Una es el marcando y la segunda, el control de tráfico. Los paquetes entrantes que concuerdan con Clase C se marcan con el valor CS2 DSCP, y el valor del CoS deriva de la tabla DSCP-CoS que es 2. Entonces, el tráfico de la Clase C se controla a una velocidad de 25 Mbps. Los paquetes excesivos son descartados por el regulador de tráfico.

Clasificación, Marcado y Control de Tráfico (acción excedente - policed-dscp-transmit)

Esta sección explica la configuración de control de tráfico que marca y transmite el tráfico excesivo. Este diagrama muestra un policy-map sample-policy3 con dos class-maps:

/image/gif/paws/91862/cat3750-qos-config6.gif

El switch marca el tráfico que excede la velocidad de control de tráfico configurada basada en los valores de la tabla de mapa con control DSCP. Se utiliza el mapa controlado por DSCP cuando se configura en la configuración del control de tráfico. La tabla de mapa predeterminadacontrolada por DSCP se menciona aquí:

Distribution1(config)#do show mls qos map policed-dscp
   Policed-dscp map:
     d1 :  d2 0  1  2  3  4  5  6  7  8  9
     ---------------------------------------
      0 :    00 01 02 03 04 05 06 07 08 09
      1 :    10 11 12 13 14 15 16 17 18 19
      2 :    20 21 22 23 24 25 26 27 28 29
      3 :    30 31 32 33 34 35 36 37 38 39
      4 :    40 41 42 43 44 45 46 47 48 49
      5 :    50 51 52 53 54 55 56 57 58 59
      6 :    60 61 62 63

Desde esta tabla, puede ver que coinciden los mismos valores DSCP. Por ejemplo, el DSCP 34 se mapea con el DSCP 34. El tráfico que se ajusta a la velocidad del regulador de tráfico se transmite sin la alteración del valor DSCP. El tráfico que excede la velocidad del regulador de tráfico se puede transmitir con un valor DSCP diferente. Por ejemplo, puede ser marcado con el valor DSCP con más posibilidades de descarte.

Si utiliza los valores predeterminados controlados por DSCP, no tiene sentido utilizar el control de tráfico. Por ejemplo, ha configurado para controlar el tráfico a una velocidad de 10 Mbps. El paquete entrante tiene el valor DSCP de CS4. Si guarda el valor predeterminado DSCP, el tráfico que cumple con los 10 Mbps se transmite con el valor DSCP de CS2. Además, el tráfico que excede los 10 Mbps se transmite con el valor DSCP de CS2. Esto es porque los valores predeterminados del mapa controlados por DSCP se mapean con los mismos valores. Por lo tanto, se recomienda configurar la tabla de mapacontrolada por DSCP de forma adecuada para distinguir los valores DSCP.

Los requisitos de este ejemplo son:

  • Configure la tabla de mapa controlada por DSCP para mapear:

    • EF a AF31

    • CS3 a AF13

    • CS2 a AF11

  • Confíe en los valores DSCP de los paquetes del comunicador IP y contrólelo a 256 Kbps. Si el tráfico excede los 256 Kbps, remarque los valores DSCP con la tabla de mapa controlada por DSCP.

  • Marque y controle la aplicación filnet. Si el tráfico excede los 25 Mbps, remarque los valores DSCP con la tabla de mapa controlada por DSCP.

Esta configuración representa el policy-map mencionado en el diagrama:


!--- Policed DSCP table Configuration

Distribution1(config)#mls qos map policed-dscp 46 to 26
Distribution1(config)#mls qos map policed-dscp 24 to 14
Distribution1(config)#mls qos map policed-dscp 16 to 10


!--- Create Access-list and Class map Class-A

Distribution1(config)#ip access-list extended IP-Communicator
Distribution1(config-ext-nacl)#remark *** Voice Payload ***
Distribution1(config-ext-nacl)#permit udp any any range 16384 32767
Distribution1(config-ext-nacl)#remark *** Voice Signalling ***
Distribution1(config-ext-nacl)#permit tcp any any range 2000 2002
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-A
Distribution1(config-cmap)#match access-group name IP-Communicator
Distribution1(config-cmap)#exit


!--- Create Access-list and Class map Class-C

Distribution1(config)#ip access-list extended application
Distribution1(config-ext-nacl)#remark *** Application for example ***
Distribution1(config-ext-nacl)#permit tcp any any eq 32768
Distribution1(config-ext-nacl)#permit udp any any eq 32768
Distribution1(config-ext-nacl)#permit tcp any any eq 32769
Distribution1(config-ext-nacl)#permit udp any any eq 32769
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-B
Distribution1(config-cmap)#match access-group name application
Distribution1(config-cmap)#exit


!--- Create Policy map

Distribution1(config-cmap)#policy-map sample-policy3
Distribution1(config-pmap-c)#class Class-A
Distribution1(config-pmap-c)#trust dscp
Distribution1(config-pmap-c)#police 256000 8000 exceed-action 
policed-dscp-transmit
Distribution1(config-pmap-c)#class Class-B
Distribution1(config-pmap-c)#set dscp CS2
Distribution1(config-pmap-c)#police 25000000 8000 exceed-action 
policed-dscp-transmit
Distribution1(config-pmap-c)#exit
Distribution1(config-pmap)#exit


!--- Apply Policy map to the interface

Distribution1(config)#interface GigabitEthernet1/0/21
Distribution1(config-if)#service-policy input sample-policy3

La configuración en el policy-map se explica a continuación:

  • LIMPIAR-DSCP: Hay tres valores modificados en la tabla de mapa controlada por DSCP.

    • EF a AF31

    • CS3 a AF13

    • CS2 a AF11

    Los primeros dos valores se modifican en función de los tipos de tráfico clasificados en los mapas de clase de la Clase A y la Clase B.

  • Clase-UNo: La carga útil de voz y el control de voz del softphone se clasifican en el mapa de clase de la Clase A. El tráfico de la carga útil de voz tiene el valor DSCP del EF y el control de voz tiene el valor DSCP de CS3. Según la configuración de policy-map, estos valores DSCP son de confianza. El tráfico se controla a una velocidad de 256 Kbps. El tráfico que cumple con esta velocidad será enviado con el valor entrante DSCP. El tráfico que excede esta velocidad será remarcado por la tabla controlada por DSCP y transmitido. La tabla DSCP controlada remarcará el EF a AF31 y el CS3 a AF13 según los valores configurados. Luego, los valores de CoS que se corresponden serán derivados de la tabla DSCP-CoS.

  • Clase-B: Los paquetes entrantes que se corresponden con la Clase B son marcados con el valor DSCP de CS2. El tráfico de la Clase B se controla a una velocidad de 25 Mbps. El tráfico que cumple con esta velocidad será enviado con el valor DSCP de 2 y el valor del CoS se deriva de la tabla DSCP-CoS que es 2. El tráfico que excede esta velocidad será remarcado por la tabla controlada por DSCP y transmitido. La tabla DSCP controlada remarcará el EF a AF31 y el CS3 a AF13 según los valores configurados. Luego, los valores de CoS que se corresponden serán derivados de la tabla DSCP-CoS.

Administración y Prevención de la Congestión

La administración y prevención de la congestión es un proceso de tres pasos. Los pasos incluyen colocación en la cola, descarte y programación. La colocación en cola consiste en poner los paquetes en diferentes colas de software según las etiquetas de QoS. El Cisco Catalyst 3750 Switch tiene dos colas del ingreso. Una vez que el tráfico es clasificado y marcado con las etiquetas de QoS, puede asignar el tráfico en dos colas diferentes basadas en las etiquetas de QoS.

El descarte de cola ponderado (WTD) se utiliza para administrar las longitudes de cola y proporcionar precedencias para clasificaciones del tráfico diferentes.

Las colas de ingreso y de salida son mantenidas por el SRR, que controla la velocidad en la que se envían los paquetes. En las colas de ingreso, el SRR envía los paquetes al anillo del stack. El SRR puede funcionar de dos modos: formado y compartido. Para las colas de ingreso, el modo compartido es el modo predeterminado, y es el único modo soportado. En el modo compartido, las colas comparten el ancho de banda según los pesos configurados. El ancho de banda se garantiza a este nivel pero no se limita a él.

Esta sección explica tres tipos de configuraciones.

Los comandos disponibles para las configuraciones son:

Distribution1(config)#mls qos srr-queue input ?

!--- Queueing

  buffers         Configure buffer allocation
  cos-map         Configure cos-map for a queue id
  dscp-map        Configure dscp-map for a queue id

!--- Scheduling

  bandwidth       Configure SRR bandwidth
  priority-queue  Configure priority scheduling

!--- Dropping

  threshold       Configure queue tail-drop thresholds

Configuración Predeterminada de Colocación en Cola, Descarte y Programación

Este resultado muestra la etiqueta predeterminada de QoS al mapeo de cola. Cada cola puede soportar tres niveles de umbral. De forma predeterminada, cada soporte de la cola tiene solamente un valor de umbral que es 100%.

cat3750-qos-config7.gif

  • Configuración del Mapa de la Cola Predeterminada:

    Los paquetes con CoS 5 (DSCP 40 a 47) se colocan en la cola 2. Los paquetes que permanecen se colocan en la cola 1

    Distribution1#show mls qos maps cos-input-q
       Cos-inputq-threshold map:
                  cos:  0   1   2   3   4   5   6   7
                  ------------------------------------
      queue-threshold: 1-1 1-1 1-1 1-1 1-1 2-1 1-1 1-1
    
    Distribution1#show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2  0    1    2    3    4    5    6    7    8    9
         ------------------------------------------------------------
          0 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          1 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          2 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          3 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          4 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 01-01 01-01
          5 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          6 :  01-01 01-01 01-01 01-01

    Esta tabla representa el CoS/DSCP predeterminado para el mapeo de cola de entrada:

    CoS DSCP Cola de Ingreso
    0 0 a 7 1
    1 8 a 15 1
    2 16 a 23 1
    3 24 a 31 1
    4 32 a 39 1
    5 40 a 47 2
    6 48 a 55 1
    7 56 a 63 1

  • Configuración de la Cola Predeterminada:

    El buffer de la Cola del ingreso es compartido en un 90% por la cola 1 y en un 10% por la cola 2. Los niveles de Umbral 1, 2 y 3 son 100%.

    Distribution1#show mls qos input-queue
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      90      10
    bandwidth :       4       4
    priority  :       0      10
    threshold1:     100     100
    threshold2:     100     100
    
  • Configuración Predeterminada del Programador:

    La cola 2 es la cola de prioridad. El SRR mantiene la cola de prioridad para su peso configurado que es 10%. Luego, el SRR comparte el ancho de banda restante (el 90%) con las colas de ingreso y las mantiene según lo especificado por los pesos configurados. En este caso, la cola 1 y la cola 2 se mantienen a una velocidad de 45% cada una.

    Distribution1#show mls qos input-queue
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      90      10
    bandwidth :       4       4
    priority  :       0      10
    threshold1:     100     100
    threshold2:     100     100

Colocación en Cola y Programación

Hay tres pasos para configurar la colocación en cola y la programación. Los pasos son:

  1. Configuración de Mapa de la Cola:

    La configuración de mapa de cola mapea los paquetes a las dos colas de ingreso en función de los valores DSCP o CoS.

  2. Configuración de la Cola:

    La configuración de la cola define la relación (asignación de una cantidad de espacio) con la cual debe dividir los buffers de ingreso entre las dos colas.

  3. Configuración del Programador:

    El SRR configura la relación de los pesos que controla la frecuencia de los paquetes que salen de las colas al anillo del stack.

Las configuraciones de la cola y el programador controlan la cantidad de datos guardados en el buffer antes de que se descarten los paquetes.

cat3750-qos-config8.gif

En esta sección, los niveles de descarte WTD no se configuran. Esto significa que los paquetes serán descartados si la cola es 100%.

  • Configuración de Mapa de la Cola:

    Primero, los valores de CoS se mapean con las colas. En esta sección, los valores de umbral no se configuran.

    
    !--- Assign the frames into the queue based on the CoS value.
    
    Distribution1(config)#mls qos srr-queue input cos-map
     queue 1 0 1 
    Distribution1(config)#mls qos srr-queue input cos-map
     queue 2 2 3 4 5 6 7
    
    
    !--- Show output.
    
    Distribution1#show mls qos maps cos-input-q
       Cos-inputq-threshold map:
                  cos:  0   1   2   3   4   5   6   7
                  ------------------------------------
      queue-threshold: 1-1 1-1 2-1 2-1 2-1 2-1 2-1 2-1
    
    Distribution1#show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2   0    1    2    3    4    5    6    7    8    9
         ------------------------------------------------------------
         0 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         1 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         2 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         3 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         4 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 01-01 01-01
         5 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         6 :  01-01 01-01 01-01 01-01

    Puede ver el conflicto en los mapas Cos-inputq-threshold y Dscp-inputq-threshold. Por ejemplo, el CoS 3 se mapea a la cola 2 en la tabla Cos-inputq-threshold. Sin embargo, el valor DSCP 24 (que se corresponde con CoS 3) se mapea a la cola 1 en el mapa Dscp-inputq-threshold. De hecho, el mapa Dscp-inputq-threshold invalida el mapa Cos-inputq-threshold. Estos mapeos deben ser lo más consistentes para asegurar el comportamiento confiable y simplificar el troubleshooting. Por lo tanto, el mapa Dscp-inputq-threshold se configura para que sincronice con el mapa Cos-inputq-threshold.

    
    !--- Assign the frames into the queue based on the DSCP value.
    
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      16 17 18 19 20 21 22 23
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      24 25 26 27 28 29 30 31
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      32 33 34 35 36 37 38 39
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      48 49 50 51 52 53 54 55
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      56 57 58 59 60 61 62 63
    
    Distribution1#show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2  0   1   2    3    4    5    6    7    8    9
         ------------------------------------------------------------
         0 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         1 :  01-01 01-01 01-01 01-01 01-01 01-01 02-01 02-01 02-01 02-01
         2 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
         3 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
         4 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
         5 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
         6 :  02-01 02-01 02-01 02-01
  • Configuración de la Cola:

    El IOS asigna el espacio predeterminado en el buffer para poner en cola los paquetes de ingreso después de habilitar el QoS. Las colas de ingreso, cola 1 y cola 2, comparten este espacio del buffer. En el Catalyst 3750 Switch, puede configurar el porcentaje de este espacio del buffer que cada cola puede utilizar. El 67% de la memoria disponible total para la cola de ingreso se asigna a la cola 1 y el 33% se asigna a la cola 2.

    Distribution1(config)#mls qos srr-queue input buffers 67 33
    
    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      67      33
    bandwidth :       4       4
    priority  :       0      10
    threshold1:     100     100
    threshold2:     100     100
  • Configuración del Programador:

    Esta configuración se realiza con el comando mls qos srr-queue input bandwidth. Aquí, este ancho de banda determina la cantidad de bits mantenidos por el SRR en las colas.

    Distribution1(config)#mls qos srr-queue input bandwidth 90 10
    Distribution1(config)#mls qos srr-queue input priority-queue 2 
    bandwidth 20
    
    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      67      33
    bandwidth :      90      10
    priority  :       0      20
    threshold1:     100     100
    threshold2:     100     100

    De forma predeterminada, la cola 2 es la cola de prioridad y el 10% del ancho de banda interno total del anillo se asigna a la cola de prioridad. También puede configurar la cola 1 como la cola de prioridad. Sin embargo, no puede configurar ambas colas como la cola de prioridad.

    Si tiene el ancho de banda del anillo en 10 Gbps, el SRR mantiene el 20% de los 10 Gbps para poner en cola los dos primeros que es 2 Gbps. El ancho de banda restante del anillo, 8 Gbps, es compartido por la cola 1 y la cola 2. Según la configuración, la cola 1 recibe el 90% de los 8 Gbps y la cola 2 recibe el 10% de los 8 Gbps. Este ancho de banda de 8 Gbps es mantenido por el SRR en el modo compartido. Esto significa que los porcentajes de ancho de banda configurados están garantizados pero no limitados a éste.

    Nota: Puede inhabilitar la cola de prioridad con el comando mls qos srr-queue input priority-queue 2 bandwidth 0.

    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      90      10
    bandwidth :      90      10
    priority  :       0       0
    threshold1:     100     100
    threshold2:     100     100
    Distribution1(config)#

Colocación en cola, Descarte y Programación

En esta sección, los niveles de umbral se configuran además del tamaño del buffer de cola. Puede asignar cada paquete que pase por el switch a una cola y a un umbral.

cat3750-qos-config9.gif

Los siguientes son ejemplos de configuración y las explicaciones:

  • Configuración de Mapa de la Cola:

    Primero, los valores de CoS se mapean con las colas.

    
    !--- Assign the frames into the queue based on the CoS value.
    
    Distribution1(config)#mls qos srr-queue input cos-map queue 1
     threshold 2  1
    Distribution1(config)#mls qos srr-queue input cos-map queue 1
     threshold 3  0
    Distribution1(config)#mls qos srr-queue input cos-map queue 2
     threshold 1  2
    Distribution1(config)#mls qos srr-queue input cos-map queue 2
     threshold 2  4 6 7
    Distribution1(config)#mls qos srr-queue input cos-map queue 2
     threshold 3  3 5
    
    
    !--- Show output.
    
    Distribution1(config)#do show mls qos maps cos-input-q
       Cos-inputq-threshold map:
                  cos:  0   1   2   3   4   5   6   7
                  ------------------------------------
      queue-threshold: 1-3 1-2 2-1 2-3 2-2 2-3 2-2 2-2
    
    Distribution1(config)#do show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2  0    1    2    3    4    5    6    7    8    9
         ------------------------------------------------------------
         0 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         1 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         2 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         3 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         4 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 01-01 01-01
         5 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         6 :  01-01 01-01 01-01 01-01

    Puede ver el conflicto en los mapas Cos-inputq-threshold y Dscp-inputq-threshold. Por ejemplo, el CoS 3 se mapea a la cola 2 en la tabla Cos-inputq-threshold, pero el DSCP de valor 24 (que se corresponde con el CoS 3) se mapea a la cola 1 en el mapa Dscp-inputq-threshold. De hecho, el mapa Dscp-inputq-threshold invalida el mapa Cos-inputq-threshold. Estos mapeos deben ser lo más consistentes para asegurar el comportamiento confiable y simplificar el troubleshooting. Por lo tanto, el mapa Dscp-inputq-threshold se configura para que sincronice con el mapa Cos-inputq-threshold.

    
    !--- Assign the frames into the queue based on the DSCP value.
    
    Distribution1(config)#mls qos srr-queue input dscp-map queue 1
     threshold 2 9 10 11 12 13 14 15
    Distribution1(config)#mls qos srr-queue input dscp-map queue 1 
     threshold 3 0 1 2 3 4 5 6 7
    Distribution1(config)#mls qos srr-queue input dscp-map queue 1 
     threshold 3 32
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 1 16 17 18 19 20 21 22 23
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 2 33 34 35 36 37 38 39 48
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 2 49 50 51 52 53 54 55 56
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 2 57 58 59 60 61 62 63
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 3 24 25 26 27 28 29 30 31
    
    Distribution1(config)#do show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2  0    1    2    3    4    5    6    7    8    9
         ------------------------------------------------------------
         0 :  01-03 01-03 01-03 01-03 01-03 01-03 01-03 01-03 01-01 01-02
         1 :  01-02 01-02 01-02 01-02 01-02 01-02 02-01 02-01 02-01 02-01
         2 :  02-01 02-01 02-01 02-01 02-03 02-03 02-03 02-03 02-03 02-03
         3 :  02-03 02-03 01-03 02-02 02-02 02-02 02-02 02-02 02-02 02-02
         4 :  02-03 02-03 02-03 02-03 02-03 02-03 02-03 02-03 02-02 02-02
         5 :  02-02 02-02 02-02 02-02 02-02 02-02 02-02 02-02 02-02 02-02
         6 :  02-02 02-02 02-02 02-02
  • Configuración de la Cola:

    De forma predeterminada, el umbral 3 es de 100% y no puede modificarse.

    Distribution1(config)#mls qos srr-queue input buffers 67 33
    Distribution1(config)#mls qos srr-queue input threshold 1 8 16
    Distribution1(config)#mls qos srr-queue input threshold 2 34 66
    
    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      67      33
    bandwidth :       4       4
    priority  :       0      10
    threshold1:       8      34
    threshold2:      16      66
  • Configuración del Programador:

    El IOS asigna un espacio predeterminado en el buffer para cada puerto de ingreso después de que se habilita el QoS. Ambas colas comparten este espacio de buffer. En el Catalyst 3560/3750 Switch, puede configurar el porcentaje de este espacio de buffer que cada cola puede utilizar.

    Distribution1(config)#mls qos srr-queue input bandwidth 90 10
    Distribution1(config)#mls qos srr-queue input priority-queue 2
     bandwidth 20
    
    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      67      33
    bandwidth :      90      10
    priority  :       0      20
    threshold1:       8      34
    threshold2:      16      66

    De forma predeterminada, la cola 2 es la cola de prioridad y el 10% del ancho de banda interno total del anillo se asigna a la cola de prioridad. También puede configurar la cola 1 como la cola de prioridad. Sin embargo, no puede configurar ambas colas como la cola de prioridad.

    Si tiene ancho de banda del anillo en 10 Gbps, el SRR mantiene el 20% de los 10 Gbps para poner en cola los 2 primeros que es 2 Gbps. El ancho de banda restante del anillo, 8 Gbps, es compartido por la cola 1 y la cola 2. Según la configuración, la cola 1 recibe el 90% de los 8 Gbps y la cola 2 recibe el 10% de los 8 Gbps. Este ancho de banda de 8 Gbps es mantenido por el SRR en el modo compartido. Esto significa que los porcentajes de ancho de banda configurados están garantizados pero no limitados a éste.

    Nota: Puede inhabilitar la cola de prioridad con el comando mls qos srr-queue input priority-queue 2 bandwidth 0.

    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      90      10
    bandwidth :      90      10
    priority  :       0       0
    threshold1:     100     100
    threshold2:     100     100
    Distribution1(config)#

Características de QoS de Salida

La administración y prevención de la congestión son características de QoS de salida soportadas por los Cisco Catalyst 3750 Switches. La administración y prevención de la congestión es un proceso de tres pasos. Los pasos incluyen colocación en la cola, descarte y programación.

La colocación en cola consiste en poner los paquetes en diferentes colas de software según las etiquetas de QoS. El Cisco Catalyst 3750 Switch tiene 4 colas de salida, umbral de 3 por cola. Después de que el tráfico sea clasificado y marcado con las etiquetas de QoS, puede asignar el tráfico a cuatro colas diferentes basadas en las etiquetas de QoS.

Cada cola se puede configurar con el tamaño de buffer, el umbral reservado, los niveles de umbral y el umbral máximo. El descarte de cola ponderado (WTD) se utiliza para administrar las longitudes de cola y proporcionar precedencias para clasificaciones del tráfico diferentes. Los parámetros de la cola de ingreso se configuran globalmente. Los parámetros de la cola de ingreso no se basan en cada puerto. Sin embargo, los parámetros de la cola de salida se basan en cada puerto configurado. Incluso entonces, la configuración es por puerto. No puede configurar cada puerto de una manera diferente. Puede configurar cada puerto en dos maneras diferentes. Esto se llama conjunto de colas. Puede configurar un máximo de dos conjuntos diferentes de la cola en configuración global. Entonces, puede aplicar cualquiera de estos dos conjuntos en la interfaz.

Las colas de ingreso y de salida son mantenidas por el SRR, que controla la velocidad en la que se envían los paquetes. En las colas de ingreso, el SRR envía los paquetes al anillo del stack. El SRR puede funcionar de dos modos: formado y compartido. Para las colas de ingreso, el modo compartido es el modo predeterminado, y es el único modo soportado. En el modo compartido, las colas comparten el ancho de banda según los pesos configurados. El ancho de banda se garantiza a este nivel pero no se limita a él. En el modo formado, las colas de salida se aseguran un porcentaje de ancho de banda, y son limitadas por velocidad a esta cantidad. El tráfico formado no utiliza más que el ancho de banda asignado, incluso si el link está inactivo. El modelado proporciona un flujo de tráfico más parejo con el tiempo y reduce los picos y los valles del tráfico congestionado. La cola 1 se puede configurar como la cola de prioridad.

Comandos QoS de Salida

Esta sección categoriza todos los comandos QoS de salida disponibles.

  • Configuración de Mapa de la Cola:

    Para mapear los valores del CoS a las colas de salida:

    Rack1SW1(config)#mls qos srr-queue output cos-map queue ?
      <1-4>  enter cos-map output queue id
    
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 1
     threshold ? <1-3>  enter cos-map threshold id
    
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 1
     threshold 1 ? <0-7>  8 cos values separated by spaces

    Para mapear los valores DSCP a las colas de salida:

    Rack1SW1(config)#mls qos srr-queue output dscp-map queue ?
      <1-4>  enter dscp-map output queue id
    
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 1
     threshold ? <1-3>  enter dscp-map threshold id
    
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 1
     threshold 1 ? <0-63>  dscp values separated by spaces
     (up to 8 values total)
  • Configuración de la Cola:

    La configuración de la cola de salida permite que configure dos conjuntos de colas. Cada conjunto de cola tiene la opción de configurar el tamaño de buffer y el valor umbral para las cuatro colas de salida. Luego, puede aplicar cualquiera de los conjuntos de la cola a cualquiera de los puertos. De forma predeterminada, la cola 1 se asigna a todos los puertos cuando habilita el QoS en el switch.

    Rack1SW1(config)#mls qos queue-set output ?
      <1-2>  queue-set id
    
    Rack1SW1(config)#mls qos queue-set output 1 ?
      buffers    assign buffers to each egress queue
      threshold  Assign threshold values to a queue
    

    Para configurar el tamaño de buffer para las cuatro colas de salida:

    Rack1SW1(config)#mls qos queue-set output 1 buffers ?
      <0-99>  enter buffer percentage for queue 1 0-99
    
    Rack1SW1(config)#mls qos queue-set output 1 buffers 10 ?
      <1-100>  enter buffer percentage for queue 2 1-100
     (includes CPU buffer)
    
    Rack1SW1(config)#mls qos queue-set output 1 buffers 10 20 ?
      <0-99>  enter buffer percentage for queue 3 0-99
    
    Rack1SW1(config)#mls qos queue-set output 1 buffers 10 20 30 ?
      <0-99>  enter buffer percentage for queue 4 0-99

    Para configurar dos valores umbrales, los valores reservados y de umbrales máximos para cada cola (el umbral 3 es el 100% de forma predeterminada y no puede modificarse):

    Rack1SW1(config)#mls qos queue-set output 1 threshold ?
      <1-4>  enter queue id in this queue set
    
    Rack1SW1(config)#mls qos queue-set output 1 threshold 1 ?
      <1-400>  enter drop threshold1 1-400
    
    Rack1SW1(config)#mls qos queue-set output 1 threshold 1 50 ?
      <1-400>  enter drop threshold2 1-400
    
    Rack1SW1(config)#mls qos queue-set output 1 threshold 1 50 60 ?
      <1-100>  enter reserved threshold 1-100
    
    Rack1SW1(config)#mls qos queue-set output 1 threshold 1 50 60
     100 ? <1-400>  enter maximum threshold 1-400

    Para aplicar el queue-set a la interfaz (deforma predeterminada, la cola fijó 1 se asigna a todos los puertos cuando habilita qos en el switch):

    Rack1SW1(config-if)#queue-set ?
      <1-2>  the qset to which this port is mapped
  • Configuración del Programador:

    Tres configuraciones diferentes están disponibles para la interfaz del switch. Las configuraciones incluyen moldear, compartir y limitar el ancho de banda. También puede configurar la cola 1 de salida como la cola de prioridad. Si se habilita la cola de prioridad, el SRR la mantiene hasta que esté vacía antes de mantener las otras tres colas. Sin embargo, en la cola de prioridad de ingreso, el SRR mantiene la cola de prioridad con el valor configurado.

    Rack1SW1(config-if)#srr-queue bandwidth ?
      limit  Configure bandwidth-limit for this interface
      shape  Configure shaping on transmit queues
      share  Configure shared bandwidth
    
    Rack1SW1(config-if)#priority-queue ?
      out  egress priority queue

    Configuración del límite de ancho de banda:

    Rack1SW1(config-if)#srr-queue bandwidth limit ?
      <10-90>  enter bandwidth limit for interface  as percentage

    Configuración del moldeado de ancho de banda:

    Rack1SW1(config-if)#srr-queue bandwidth shape ?
      <0-65535>  enter bandwidth weight for queue id 1
    
    Rack1SW1(config-if)#srr-queue bandwidth shape 10 ?
      <0-65535>  enter bandwidth weight for queue id 2
    
    Rack1SW1(config-if)#srr-queue bandwidth shape 10 20 ?
      <0-65535>  enter bandwidth weight for queue id 3
    
    Rack1SW1(config-if)#srr-queue bandwidth shape 10 20 30 ?
      <0-65535>  enter bandwidth weight for queue id 4

    Configuración de distribución del ancho de banda:

    Rack1SW1(config-if)#srr-queue bandwidth share ?
      <1-255>  enter bandwidth weight for queue id 1
    
    Rack1SW1(config-if)#srr-queue bandwidth share 10 ?
      <1-255>  enter bandwidth weight for queue id 2
    
    Rack1SW1(config-if)#srr-queue bandwidth share 10 20 ?
      <1-255>  enter bandwidth weight for queue id 3
    
    Rack1SW1(config-if)#srr-queue bandwidth share 10 20 30 ?
      <1-255>  enter bandwidth weight for queue id 4

    Las cuatro colas participan en el SRR a menos que se habilite la cola de prioridad; en este caso, el primer peso del ancho de banda se ignora y no se utiliza en el cálculo de la relación. La cola de prioridad se mantiene hasta que queda vacía antes de que las otras colas se mantengan. Habilita la cola de prioridad con el comando priority-queue out interface configuration.

Configuración predeterminada

Configuración del Mapa de la Cola Predeterminada:

/image/gif/paws/91862/cat3750-qos-config10.gif

Estos mapeos predeterminados se pueden cambiar según su requisito:


!--- Map CoS to Egress Queue

Distribution1#show mls qos maps cos-output-q
   Cos-outputq-threshold map:
              cos:  0   1   2   3   4   5   6   7
              ------------------------------------
  queue-threshold: 2-1 2-1 3-1 3-1 4-1 1-1 4-1 4-1


!--- Map DSCP to Egress Queue

Distribution1#show mls qos maps dscp-output-q
   Dscp-outputq-threshold map:
     d1 :d2  0    1    2    3    4    5    6    7    8    9
     ------------------------------------------------------------
     0 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
     1 :  02-01 02-01 02-01 02-01 02-01 02-01 03-01 03-01 03-01 03-01
     2 :  03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01
     3 :  03-01 03-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
     4 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 04-01 04-01
     5 :  04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
     6 :  04-01 04-01 04-01 04-01

Configuración de la Cola Predeterminada:

cat3750-qos-config11.gif

Las configuraciones predeterminadas de la cola de salida son convenientes para la mayoría de las situaciones. Debe cambiarlas solamente cuando comprende perfectamente cuáles son las colas de salida y si estas configuraciones no resuelven su Solución de QoS).

Los conjuntos de colas se configuran y el conjunto de cola 1 se asigna a los puertos de forma predeterminada. A cada cola se le asigna el 25 por ciento del espacio del buffer total. A cada cola se le reserva el 50 por ciento del espacio del buffer asignado que es el 12,5 por ciento del espacio del buffer total. La suma de todos los buffers reservados representa el pool reservado, y los buffers restantes son parte del conjunto común. La configuración predeterminada establece 400 por ciento como la memoria máxima que esta cola puede tener antes de que se descarten los paquetes.

Distribution1#show mls qos queue-set 1
Queueset: 1
Queue     :       1       2       3       4
----------------------------------------------
buffers   :      25      25      25      25
threshold1:     100     200     100     100
threshold2:     100     200     100     100
reserved  :      50      50      50      50
maximum   :     400     400     400     400

Distribution1#show mls qos queue-set 2
Queueset: 2
Queue     :       1       2       3       4
----------------------------------------------
buffers   :      25      25      25      25
threshold1:     100     200     100     100
threshold2:     100     200     100     100
reserved  :      50      50      50      50
maximum   :     400     400     400     400

Distribution1#show mls qos int gigabitEthernet 1/0/20 buffers
GigabitEthernet1/0/20
The port is mapped to qset : 1
The allocations between the queues are : 25 25 25 25

Configuración Predeterminada del Programador:

Se inhabilita la cola de prioridad. El modo formado y compartido se configura para el SRR. Los pesos del modo modelado invalidan el valor del modo compartido. Por lo tanto, el resultado neto en la cola 1 se mantiene en el modo moldeado y las colas 2,3 y 4 se mantienen en el modo compartido. Esto significa que la cola 1 es mantenida con un valor absoluto que es el 1/25 por ciento, o el cuatro por ciento, del ancho de banda. Las colas 2, 3 y 4 se mantienen en el 25 por ciento del ancho de banda. Si el ancho de banda está disponible, las colas 2, 3 y 4 se pueden mantener en más del 25 por ciento del ancho de banda.

Distribution1#show mls qos int gigabitEthernet 1/0/20 queueing
GigabitEthernet1/0/20
Egress Priority Queue : disabled
Shaped queue weights (absolute) :  25 0 0 0
Shared queue weights  :  25 25 25 25
The port bandwidth limit : 100  (Operational Bandwidth:100.0)
The port is mapped to qset : 1

Colocación en Cola, Descarte y Programación

Las siguientes son configuraciones de ejemplo:

  • Configuración de Mapa de la Cola:

    Rack1SW1(config)#mls qos srr-queue output cos-map queue 1
     threshold 3 5
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 1
     threshold 1 2 4
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 2 
     threshold 2 3
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 2
     threshold 3 6 7
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 3
     threshold 3 0
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 4
     threshold 3 1
    
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 1
     threshold 3  46
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  16
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  18 20 22
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  25
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  32
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  34 36 38
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 2  24 26
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 3  48 56
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 3
     threshold 3  0
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 4
     threshold 1  8
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 4
     threshold 3  10 12 14
    
  • Configuración de la Cola:

    Esta configuración muestra la configuración de los conjuntos de colas 1 y 2. De forma predeterminada, el conjunto de cola 1 se aplica en todas las interfaces.

    Rack1SW3(config)#mls qos queue-set output 1 buffers 10 10 26 54
    Rack1SW3(config)#mls qos queue-set output 2 buffers 16 6 17 61
    
    Rack1SW3(config)#mls qos queue-set output 1 threshold 2 70 80
     100 100
    Rack1SW3(config)#mls qos queue-set output 1 threshold 4 40 100
     100 100
    
    Rack1SW3(config)#mls qos queue-set output 2 threshold 1 149 149
     100 149
    Rack1SW3(config)#mls qos queue-set output 2 threshold 2 118 118
     100 235
    Rack1SW3(config)#mls qos queue-set output 2 threshold 3 41 68
     100 272
    Rack1SW3(config)#mls qos queue-set output 2 threshold 4 42 72
     100 242
    
    Rack1SW3(config)#int fa 1/0/11
    Rack1SW3(config-if)#queue-set 2
    

    La interfaz 1/0/11 se aplica con el conjunto de cola 2.

    Rack1SW3(config-if)#do show mls qos int fa 1/0/10 buffers
    FastEthernet1/0/10
    The port is mapped to qset : 1
    The allocations between the queues are : 10 10 26 54
    
    Rack1SW3(config-if)#do show mls qos int fa 1/0/11 buffers
    FastEthernet1/0/11
    The port is mapped to qset : 2
    The allocations between the queues are : 16 6 17 61
  • Configuración del Programador:

    Rack1SW3(config-if)#srr-queue bandwidth share 1 75 25 5
    Rack1SW3(config-if)#srr-queue bandwidth shape  3  0  0  0
    

    La cola de salida de Cisco Catalyst 3750 no soporta la Colocación en Cola de Baja Latencia (LLQ). Soporta la colocación en cola de prioridad. Cuando configura priority-queue out, la cola 1 siempre se mantiene cuando tiene un paquete.

    Rack1SW3(config-if)#srr-queue bandwidth share 1 75 25 5
    Rack1SW3(config-if)#srr-queue bandwidth shape  3  0  0  0
    Rack1SW3(config-if)#priority-queue out
    

    Cuando configura este comando, las razones del peso SRR y del tamaño de la cola son afectadas porque hay una cola menos que participa en el SRR Esto significa que weight1 en el comando srr-queue bandwidth shape o srr-queue bandwidth share es ignorado (no se usa en el cálculo de la relación).

Éste es el comando para ver los descensos en las colas específicas:

Paso 1:

1/ #show platform pm if-numbers

Utilice el comando de los si-números de la plataforma P.M. de la demostración y marque la información de puerto correspondiente a su interfaz (ésta es la interfaz saliente en sus 3750). Por ejemplo, 0/3 será fas el puerto 0/4. Guarde 4 como valor de puerto; si el primer valor no es un cero, después dé el número asic después del número del puerto.

interface gid gpn lpn port slot unit slun port-type lpn-idb gpn-idb
------------------------------------------------------------------------
---------
Gi0/1     1    1    25   0/1  1    1    1    local     Yes     Yes
Gi0/2     2    2    26   0/0  1    2    2    local     Yes     Yes
Fa0/1     3    3    1    0/2  1    1    3    local     Yes     Yes
Fa0/2     4    4    2    0/3  1    2    4    local     Yes     Yes
Fa0/3     5    5    3    0/4  1    3    5    local     Yes     Yes
Fa0/4     6    6    4    0/5  1    4    6    local     Yes     Yes
Fa0/5     7    7    5    0/6  1    5    7    local     Yes     Yes
Fa0/6     8    8    6    0/7  1    6    8    local     Yes     Yes

El valor de puerto correspondiente a la interfaz fa 0/3 es 0/4. Ahora usted puede ver las caídas de la cola de la interfaz fa 0/3 con el comando del puerto 4 del descenso stats de puerto-ASIC de la plataforma de la demostración.

2/ #show platform port-asic stats drop port 4 
       
Port-asic Port Drop Statistics - Summary
========================================
  RxQueue 0 Drop Stats: 0
  RxQueue 1 Drop Stats: 0
  RxQueue 2 Drop Stats: 0
  RxQueue 3 Drop Stats: 0
...
 
  Port 4 TxQueue Drop Statistics
    Queue 0
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 0
    Queue 1
      Weight 0 Frames 0
      Weight 1 Frames 2755160   <--- Here is an example of drops
      Weight 2 Frames 0
    Queue 2
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 0
    Queue 3
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 8

Paso 2:

  • Configuración del Límite del Ancho de Banda:

    Para limitar el resultado máximo en el puerto, configure el comando srr-queue bandwidth limit interface configuration. Si configura este comando al 80 por ciento, el puerto permanece inactivo el 20 por ciento del tiempo. La velocidad de la línea cae a 80 por ciento de la velocidad conectada. Estos valores no son exactos porque el hardware ajusta la velocidad de la línea en incrementos de seis. Este comando no está disponible en una interfaz de Ethernet de 10 Gigabit.

    srr-queue bandwidth limit weight1
    
    

    donde weight1 es el porcentaje de la velocidad del puerto a la que el puerto debe limitarse. El rango es 10 a 90.

    Nota: Las configuraciones predeterminadas de la cola de salida son convenientes para la mayoría de las situaciones. Debe cambiarlas solamente cuando comprende perfectamente cuáles son las colas de salida y si estas configuraciones no cumplen con la solución de la Calidad de servicio (QoS).

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 91862