Switches : Switches Cisco Catalyst de la serie 3750

3 Switch de la capa de Catalyst para el soporte Estela-En-LAN a través del ejemplo de configuración de los VLA N

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (7 Octubre 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de ejemplo del soporte de WOL (Wake-On-LAN) en las VLAN con un switch Catalyst Layer 3.

prerrequisitos

Requisitos

Cisco recomienda que usted tiene conocimiento de estos temas antes de que usted intente esta configuración:

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Catalyst 3750 Series Switch que funciona con la versión de software del sistema 12.2(25r)SEC del ½ del ¿Â de Cisco IOSïÂ

  • Catalyst 2950 Series Switch que funcionan con la versión de software del sistema 12.1(19)EA1a del Cisco IOS

  • PC que funcionan con el sistema operativo del Microsoft Windows 2000

  • Utilidad del Freeware Estela-En-LAN de SolarWinds leavingcisco.com

    Nota: Cisco no recomienda ninguna utilidad Estela-En-LAN.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Antecedentes

ESTELA-EN-LAN

El Estela-En-LAN (WOL) es una combinación de Tecnologías de hardware y software para despertar los sistemas el dormir. WOL envía los paquetes de red especialmente cifrados, llamados los paquetes mágicos, a los sistemas equipados y habilitados para responder a estos paquetes. Estas funciones adicionales permiten que los administradores realicen el mantenimiento en los sistemas incluso si el usuario los ha accionado abajo. La característica de WOL permite que el administrador accione remotamente para arriba todas las máquinas el dormir de modo que puedan recibir las actualizaciones. WOL se basa en el principio que cuando el PC apaga, el NIC todavía recibe el poder, y guarda el escuchar en la red el paquete mágico para llegar. Este paquete mágico se puede enviar sobre una variedad de protocolos sin conexión (UDP, IPX), pero el UDP es el más de uso general.

Si usted envía los paquetes de WOL de las redes remotas, el Routers debe ser configurado para permitir los broadcastes dirigidos. Esto se debe hacer por estas dos razones:

  • Porque el PC está dormido, no tendrá una dirección IP y no responderá a los protocolos Protocolo de resolución de la dirección (ARP) (ARP) del router. Por lo tanto, solamente un paquete del broadcast IP de la subred local se transmite en el segmento sin un ARP.

  • Si hay un 2 Switch de la capa entre el router y el PC, que es verdad para la mayoría de las redes hoy, el Switch no sabe a qué puerto está conectado el PC físicamente. Solamente una capa 2 transmitida o una trama de la unidifusión desconocida se envía a todos los puertos del switch. Todos los paquetes del broadcast IP se dirigen a la dirección MAC del broadcast.

Advertencia - Broadcastes dirigidos

Los broadcastes dirigidos por IP se utilizan en el establecimiento de rechazo del servicio común y popular del smurf, y se pueden también utilizar en los ataques relacionados.

Las transmisiones directas por IP son datagramas enviados a la dirección de difusión de una subred a la que el equipo de envío no está directamente conectado. La difusión directa se enruta a través de la red como un paquete de unidifusión hasta que llega a la subred de destino, donde se convierte en una difusión de capa de link. Debido a la naturaleza de la arquitectura de direccionamiento IP, sólo el último router de la cadena, el que se encuentra conectado directamente con la subred de destino, puede identificar en forma definitiva una transmisión dirigida. Algunas veces las difusiones directas se utilizan con objetivos legítimos, pero tal uso no es habitual fuera de la industria de servicios financieros.

En un ataque smurf, el atacante envía los pedidos de eco ICMP de una dirección de la fuente falsificada a una dirección de broadcast dirigido. Esto hace a todos los host en la subred de destino enviar las contestaciones a la fuente falsificada. Enviando una secuencia continua de ese pedido, el atacante puede crear una secuencia de respuesta mucho más grande. Esto puede inundar totalmente al host, cuyo se falsifica direccionamiento.

Si una interfaz de Cisco se configura con el comando no ip directed-broadcast, los broadcastes dirigidos que se estallan de otra manera en los broadcastes de link-layer en esa interfaz se caen en lugar de otro. Esto significa que el comando no ip directed-broadcast debe ser configurado en cada interfaz de cada router que esté conectado con una subred de destino. No es suficiente configurar solamente en los routeres de escudo de protección. El comando no ip directed-broadcast es el valor por defecto en el Cisco IOS Software Release 12.0 y Posterior. En las versiones anteriores, el comando se debe aplicar a cada interfaz LAN que no se sepa para remitir los broadcastes dirigidos legítimos.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos usados en esta sección.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans1.gif

Éstos son los detalles de esta configuración de la red:

  • Los PC 1, 2 y 3 son el cliente PC que necesiten ser despertados.

  • El PC 4 es el servidor de WOL así como el servidor DHCP.

  • El PC 4 se configura con un IP Address estático de 172.16.3.2/24.

  • Configuran al cliente PC para obtener la dirección IP de un servidor DHCP.

  • Servidor DHCP (el PC 4) se configura con tres alcances IP para los clientes que conectan con los VLA N 2,3 y 4.

  • Se utilizan SW-1 y SW-2 (Catalyst 2950) mientras que los 2 Switch y el L3 (Catalyst 3750) de la capa se utiliza como el switch de la capa 3.

  • Los PC 1 y 4 están conectados en el mismo VLA N (VLA N 3).

  • Los PC 2 y 3 están conectados en el VLAN2 y 4 respectivamente.

Configuraciones del switch

Este documento utiliza estas configuraciones del switch:

  • Switch de la capa 3 - L3

  • 2 Switch de la capa - SW-1 y SW-2

L3
Switch>en
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname L3
L3(config)#ip routing
L3(config)#vtp mode server
Device mode already VTP SERVER.
L3(config)#vtp domain cisco
Changing VTP domain name from NULL to cisco
L3(config)#vlan 2
L3(config-vlan)#vlan 3
L3(config-vlan)#vlan 4
L3(config)#interface gigabitEthernet 2/0/1
L3(config-if)#switchport trunk encapsulation dot1q
L3(config-if)#switchport mode trunk
L3(config-if)#interface gigabitEthernet 2/0/2
L3(config-if)#switchport trunk encapsulation dot1q
L3(config-if)#switchport mode trunk
L3(config-if)#exit
L3(config)#access-list 101 permit udp host 172.16.3.2 any eq 7

!--- This accepts directed broadcasts only from PC 4.

L3(config)#ip forward-protocol udp 7 

!--- Specifies the protocol and port to be forwarded.
!--- Capture the WOL packet with any network sniffer to determine the UDP port
!--- to use in this command. The port number varies with the WOL utility used.

L3(config-if)#interface vlan 2
L3(config-if)#ip address 172.16.2.1 255.255.255.0
L3(config-if)#ip helper-address 172.16.3.2

!--- Enables BOOTP broadcast forwarding to the DHCP server.

L3(config-if)#ip directed-broadcast 101

!--- Enables the translation of a directed broadcast to physical broadcasts.

L3(config-if)#interface vlan 3
L3(config-if)#ip address 172.16.3.1 255.255.255.0
L3(config-if)#ip helper-address 172.16.2.255
L3(config-if)#ip helper-address 172.16.4.255

!-- Enables forwarding of WoL packets to clients.
!-- Works in conjunction with the ip forward-protocol command.
L3(config-if)#interface vlan 4
L3(config-if)#ip address 172.16.4.1 255.255.255.0
L3(config-if)#ip helper-address 172.16.3.2

!--- Enables BOOTP broadcast forwarding to the DHCP server.

L3(config-if)#ip directed-broadcast 101

!--- Enables the translation of a directed broadcast to physical broadcasts.

L3(config)#^Z
L3#wr
Building configuration...
[OK]
L3#

SW-1
Switch>en
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname SW-1
SW-1(config)#vtp mode client
Setting device to VTP CLIENT mode.
SW-1(config)#vtp domain cisco
Changing VTP domain name from NULL to cisco
SW-1(config)#interface fastEthernet 0/1
SW-1(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION

%Portfast has been configured on FastEthernet0/1 but will only
 have effect when the interface is in a non-trunking mode.
SW-1(config-if)#switchport mode access
SW-1(config-if)#switchport access vlan 4
SW-1(config-if)#interface fastEthernet 0/2
SW-1(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION

%Portfast has been configured on FastEthernet0/2 but will only
 have effect when the interface is in a non-trunking mode.
SW-1(config-if)#switchport mode access
SW-1(config-if)#switchport access vlan 3
SW-1(config-if)#interface gigabitethernet 0/1
SW-1(config-if)#switchport mode trunk
SW-1(config-if)#^Z
SW-1#wr
Building configuration...
[OK]
SW-1#

SW-2
Switch>en
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname SW-2
SW-2(config)#vtp mode client
Setting device to VTP CLIENT mode.
SW-2(config)#vtp domain cisco
Changing VTP domain name from NULL to cisco
SW-2(config)#interface fastEthernet 0/1
SW-2(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION

%Portfast has been configured on FastEthernet0/1 but will only
 have effect when the interface is in a non-trunking mode.
SW-2(config-if)#switchport mode access
SW-2(config-if)#switchport access vlan 3
SW-2(config-if)#interface fastEthernet 0/2
SW-2(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION

%Portfast has been configured on FastEthernet0/2 but will only
 have effect when the interface is in a non-trunking mode.
SW-2(config-if)#switchport mode access
SW-2(config-if)#switchport access vlan 2
SW-2(config)#interface gigabitethernet 0/1
SW-2(config-if)#switchport mode trunk
SW-2(config-if)#^Z
SW-2#wr
Building configuration...
[OK]
SW-2#

PC del cliente configuración

La mayoría de las placas madres tienen construido en el NIC y soportan hoy las funciones de WOL. Algunos ordenadores tienen WOL inhabilitado por abandono. Usted tiene que entrar las opciones básicas del sistema de entrada-salida (BIOS) habilitar WOL. Éste es el procedimiento para habilitar WOL en a PC del cliente:

  1. Ingrese la pantalla de la configuración BIOS durante el autoexamen del poder del ordenador encendido (POSTE).

    Nota: Generalmente el F10 o la tecla delete se presiona para ingresar las configuraciones BIOS.

  2. Dentro de la pantalla BIOS, navegue a las configuraciones y entonces a las opciones avanzadas del dispositivo.

  3. Dentro de esta pantalla, busque las configuraciones relacionadas con el Estela-En-LAN y habilitelas.

  4. Salve y salga las configuraciones BIOS.

    Nota: El procedimiento y las opciones exactos disponibles en el BIOS para habilitar WOL son diferentes con cada fabricante de computadoras. Refiera al manual de la placa madre proporcionado cada ordenador para más información en las configuraciones BIOS.

  5. Marque las propiedades avanzadas de su placa de red para asegurarse de que las funciones de WOL están habilitadas.

    1. Elija el comienzo > las configuraciones > la red y las conexiones por línea telefónica, después haga clic con el botón derecho del ratón en su conexión de área local.

    2. Haga clic las propiedades y elija la configuración.

    3. Navegue al cuadro avanzado fijan la propiedad de las capacidades del despertar a ambos y la velocidad de WOL al auto.

      http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans2.gif

    4. Haga clic la lengueta de la administración de la energía y marque el cuadro que los estados permiten que este dispositivo traiga a ordenador del recurso seguro.

      http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans3.gif

      Nota: En las máquinas del Microsoft Windows XP, hay una más opción: Permita solamente que las estaciones de administración traigan el ordenador del recurso seguro. Esta última opción gira el ordenador solamente si se recibe un paquete mágico de WOL. Sin esta opción marcada, cualquier tráfico enviado al adaptador de red gira el PC.

Complete estos pasos para que el cliente obtenga una dirección IP del servidor DHCP:

  1. Elija el comienzo > las configuraciones > la red y las conexiones por línea telefónica, después haga clic con el botón derecho del ratón en su conexión de área local y elija las propiedades.

  2. Conforme a la ficha general, haga clic el protocolo de Internet (TCP/IP) y entonces las propiedades.

  3. Elija obtienen una dirección IP automáticamente.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans4.gif

Configuración de la PC del servidor

Complete estos pasos para configurar el servidor de WOL:

  1. Descargue y instale la utilidad Estela-En-LAN.

  2. Configure el PC con un IP Address estático de 172.16.3.2/24.

  3. Configure el PC como servidor DHCP.

  4. Cree tres alcances con estos detalles:

    Alcance Intervalo de direcciones IP El IP excluyó el rango
    VLAN2 172.16.2.1 - máscara de 172.16.2.254 - 255.255.255.0 172.16.2.1
    VLAN3 172.16.3.1 - máscara de 172.16.3.254 - 255.255.255.0 172.16.3.1 y 172.16.3.2
    VLA N 4 172.16.4.1 - máscara de 172.16.4.254 - 255.255.255.0 172.16.4.1

    Refiérase a cómo instalar y configurar a un servidor DHCP en un grupo de trabajo en el Servidor Windows 2003leavingcisco.com para más información sobre la configuración del servidor DHCP.

Verificación

Utilize esta sección para confirmar que su configuración funcione correctamente.

Complete estos pasos:

  1. El poder en los PC y los conecta con los switches respectivos tal y como se muestra en del diagrama de la red.

  2. El registro en cada PC y anota las direcciones MAC y los IP Addresses.

    Nota: Abra un comando prompt y ingrese el comando de /all del ipconfig para determinar el MAC address y el IP Address.

  3. Utilice el ping para marcar la Conectividad entre los PC.

  4. Apague a todo el cliente PC (PC1, PC2 y PC 3) después de la verificación de una Conectividad acertada.

  5. Ponga en marcha la utilidad de WOL en el servidor PC (PC 4).

  6. Ingrese el MAC address y IP Address del PC que usted quiere “despierta” como se muestra aquí:

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans5.gif

    Nota: La dirección IP puede ser cualquier direccionamiento (incluso broadcast de subred) en ese rango de subred del VLA N con el cual PC del cliente esté conectado. Solamente la dirección MAC del PC del cliente necesita hacer juego.

  7. Haga clic en el icono del despertar PC para enviar una serie de paquetes mágicos a la blanco PC en un intento por accionar encendido el dispositivo.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans6.gif

  8. Cuando el dispositivo remoto recibe el mensaje para despertar y se acciona encendido, se visualiza este mensaje:

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans7.gif

    PC del cliente ahora se acciona encendido.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Información Relacionada


Document ID: 91672