Voz y Comunicaciones unificadas : Cisco Unified Communications Manager Express

Ejemplo expreso de la configuración de conexión de troncal del SORBO del Cisco CallManager (CME)

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

En la actualidad, la industria de telecomunicaciones experimenta el cambio del establecimiento de switching y transporte de tecnologías de larga data a dispositivos de borde basados en IP. La revolución de la comunicación IP ha comenzado a generar un gran impacto comercial en la pequeña y mediana empresa. Estas pequeñas y medianas empresas reconocen que el uso de IP es muy eficiente porque el IP puede utilizar las funciones de Voz, Vídeo, y Datos sobre una red única, en vez de usar tres redes independientes para propósitos determinados. La Figura 1 muestra la implementación de telefonía IP que tiende al Trunking de IP.

Figura 1 - Sistema de Telefonía IP

cme-sip-trunking-config1.gif

Las IP PBX están comenzando a predominar en el negocio de la tecnología Voz, y el TDM PBX ya no más la fuente principal como el cruce que va entre dos redes de voz. El uso de TDM PBX ha disminuido en los últimos años, y el uso del IP PBX se está convirtiendo en una buena inversión en LAN y WAN IP. Para conectarse con la PSTN, los PBX necesita una cierta clase de trunking como TDM (T1/E1) o líneas analógicas. Las IP PBX puede acceder a la PSTN usando estos tipos de trunks, pero necesitan un gateway de medios que convierta el tráfico de voz del IP en la PSTN tradicional, lo que algunas veces puede dar como resultado una traducción sucesiva del dominio IP al dominio TDM. Estas traducciones sucesivas aumentan los costos de mantenimiento de los gateways, aumentan la latencia, y reducen la calidad de voz.

Para evitar estos problemas, la IP PBX utiliza los protocolos para el inicio de sesión y la administración, el más prominente es el Session Initiation Protocol (SIP). Este documento proporciona una descripción sobre el trunking SIP y Cisco CallManager Express (CME), y una configuración para implementar un sistema de telefonía basado en IP con el CME usando trunking SIP para las llamadas entrantes y salientes.

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • La versión CME 4.1 está instalada

  • Una imagen del Software Release 12.4(11)XJ o de IOS 12.4(6th)T de Cisco IOS� está en el router

  • Un módulo NM-CUE está instalado con la versión 2.3.4 de CUE

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco 3825 Router en Cisco IOS Software Release 12.4(11)XJ

  • Cisco Catalyst 3550 Switch en Cisco IOS Software Release 12.4

  • Teléfono IP 7960 de Cisco

  • Cisco CallManager Express 4.1

  • Cisco Unity Express 2.3.4

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

Protocolo SIP

SIP es un protocolo de control, de capa de aplicación basado en ASCII que se puede utilizar para establecer, mantener, y finalizar llamadas entre dos o más extremos. SIP se ha destacado rápidamente como el protocolo estándar usado en las comunicaciones IP, porque es un protocolo de multimedia que se puede utilizar para las sesiones de video y mensajería inmediata además de voz. Además, SIP puede administrar sesiones de conferencia y broadcasts, así como las sesiones uno a uno. El SIP tiene gran potencial en la transformación y el desarrollo en los medio de comunicación. Por esta razón, Cisco continúa desempeñando una función importante como líder en la creación detecnologías nuevas que hacen que SIP y sus aplicaciones sean el estándar de las comunicaciones IP.

Los trunks de SIP son similares a una línea telefónica, salvo que los trunks de SIP utilizan la red IP, no la PSTN. Además, los trunks de SIP permiten la convergencia de voz y de los datos en conexiones comunes IP. Para acceder a la red de IP con un trunk de SIP, es necesario que las configuraciones se realicen en el proveedor de servicio, y en el lado del cliente. Los clientes necesitan establecer y configurar el CME, que es el PBX que interpretará la señal de SIP de forma adecuada y pasará el tráfico con éxito. El proveedor de servicio necesita configurar un servidor alternativo SIP. Sin embargo, el establecimiento de los trunks de SIP es más complicado que los trunks PSTN habituales. La razón es que un cliente enfrenta desafíos al administrar las diversas interpretaciones e implementaciones del SIP de parte de los proveedores del equipo, al ofrecer seguridad, administrar calidad de Servicio (QoS), habilitar Traducción de Dirección de Red (NAT) y firewall traversal, y al garantizar confiabilidad a portadoras y continuidad del servicio.

Estos puntos describen por qué los trunks de SIP se usan cada vez más en las pequeñas y medianas empresas:

  • Implementación fácil y rápida

  • Capacidad mejorada de la Utilización de la Red

  • Potencial para Consolidar y Disminuir los Costos de Telefonía

  • Marcado de Entrada Directo (DID) Económico

  • Continuidad del negocio

Soporte de Trunk CME SIP

Cisco CME es una solución de telefonía IP que se integra directamente con el Cisco IOS Software. El CME permite que las pequeñas y medianas empresas implementen capacidades de voz, datos, y vídeo en una plataforma única. La red de telefonía IP es fácil de configurar porque el CME se ejecuta en un único router, que tiene funciones PBX para los negocios. Por lo tanto, al usar el CME, las pequeñas y medianas empresas pueden ofrecer telefonía IP y ruteo de datos con una sola solución integrada con costos mínimos.

Retransmisión DTMF para Trunk SIP

El CME comenzó a soportar trunking SIP cuando se lanzó CME 3.1 . Sin embargo, se produjeron algunos problemas cuando un teléfono SIP se comunicaba a un teléfono SCCP o intentaba acceder al correo de voz. El problema es que los teléfonos SCCP conectados con CME requieren el uso de retransmisión DTMF fuera de banda para transportar DTMF (dígitos) a través de las conexiones VoIP, y los teléfonos SIP usan transportes de banda. Una distorsión DTMF existió entre los dos dispositivos. Cuando el CME 3.2 fue lanzado, se agregó soporte a la retransmisión DTMF. Los dígitos DTMF de SCCP pudieron convertirse al mecanismo de retransmisión DTMF de banda con el RFC2833 o los métodos de Notificación.

El CME soporta actualmente esta lista de conexión entre redes DTMF para SIP a las llamadas SIP:

  • Notificación <---> Notificación desde 12.4(4)T

  • RFC2833 <---> Notificación desde 12.4(4)T

  • Notificación <---> RFC2833 desde 12.4(4)T

  • De banda G711 <---> desde 12.4(11)T [Requiere Transcodificación]

El CME soporta actualmente esta conexión entre redes DTMF para el SIP a las llamadas SCCP:

  • SCCP fuera de banda— Notificación SIP / RFC2833 desde 12.4(4)T

Soporte Códec y Transcodificación

Otro aspecto importante que debe considerar alconfigurar un trunk SIP son los el códecs soportados. Los códecs representan la muestra de modulación de código por impulso para las señales en las frecuencias de voz. Los trunks SIP soportan estos códecs: G.711 y G.729. Sin embargo, para diversas funciones tales como Cisco Unity Express (CUE) y Music on Hold (MOH), solamente se soporta el códec G.711. Esto significa que las llamadas de voz que utilizan los trunks SIP con el códec G.729 no pueden acceder a CUE, a menos que haya un transcodificador para permitir que la compresión y descompresión de las transmisiones de voz coincidan con las capacidades de la CUE. El MOH puede también utilizar el códec G.729 para guardar el ancho de banda, pero el códecno proporciona transmisiones MOH de calidad. adecuada. Esto es debido al hecho de que el G.729 está optimizado para la voz. Por lo tanto, debe forzar el MOH para utilizar el G.711.

Reenvío de Llamadas

Cuando una llamada ingresa a un trunk de SIP y es reenviada (CFNA/CFB/CFA), el comportamiento predeterminado está que el CME envíe el mensaje de SIP 302 "Movido Temporalmente” al proxy del proveedor de servicio (SP). La parte de del Encabezado de Contacto del usuario el mensaje 302 posiblemente deba ser traducida para reflejar un DID que el proxy SP puede rutear. La parte de Encabezado de Contacto del host en el mensaje 302 se debe modificarse para reflejar la Dirección de Registro (AOR) usando host-registrar CLI en sip-ua y b2bua CLI en el voip dial peer que va a la CUE.

Algunos proxies SIP no pudieron soportar esta modificación. Si es así, necesita agregar lo siguiente:

Router(config)#voice service voip
Router(conf-voi-serv)#no supplementary-service sip moved-temporarily

La Figura 2 muestra el comportamiento del sistema CME cuando el mensaje 302 está inhabilitado.

Figura 2 - Flujo de Reenvío de Llamada Ocupado (CFB) con el mensaje 302 inhabilitado

/image/gif/paws/91535/cme-sip-trunking-config2.gif

Este método permitirá la devolución de llamadas de los mensajes SIP 302 para los reenvíos de llamada en CME. También se requiere lo anterior hay ciertas extensiones que no tienen mapping de DID ya que el proxy SP posiblemente no sepa cómo rutear tales llamadas. Si inhabilita la respuesta 3xx, el iniciador de número de origen se puede utilizar para preservar el identificador de llamada de la parte que llama original.

Transferencia de Llamadas

Cuando una llamada ingresa un trunk de SIP a un teléfono SCCP CUE AutoAttendant (AA) SCCP y es transferida, el CME de forma predeterminada enviará un mensaje SIP REFER al proxy SP. La mayoría de los Servidores Proxy SP no soportan el método REFER. Este método debe ser configurado para que el CME devuelva la llamada:

Router(config)#voice service voip
Router(conf-voi-serv)#no supplementary-service sip refer

La Figura 3 muestra el comportamiento del sistema CME con el método REFER inhabilitado.

Figura 3 - Transferencia con REFER inhabilitado

cme-sip-trunking-config3.gif

Si REFER se soporta en el proxy SIP, la porción de usuario de Derivar a y Derivado por debe ser traducida a un DID que el proxy SP comprenda. La porción de host de los campos Referir a y Derivado por debe ser una dirección IP o DN que el proxy SP también pueda rutear (esto sucede de forma predeterminada en CME 4.1).

Llamadas en Espera

Si un teléfono SCCP pone una llamada de PSTN en ESPERA, el CME localmente cambia los medios. No se envían mensajes en el trunk de SIP. El usuario escuchará Música en Espera en el trunk de SIP en función de la configuración CME.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Utilice la herramienta Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos utilizados en esta sección.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/91535/cme-sip-trunking-config4.gif

Configuraciones

Estos elementos de configuración proporcionan una descripción de los pasos requeridos para configurar su CME con los trunks SIP:

  • Elementos de la infraestructura: Interfaces, TFTP y servicios DHCP, NTP, etc

  • Telefonía-servicio: Habilita el control de llamadas IOS “PBX” en la plataforma CME incluidos los elementos de la gestión del teléfono

  • Ephones y Ephones-dns: Definen los teléfonos IP y sus números de teléfono

  • Plan de marcado: Dial-peers, extensiones, reglas de traducción de voz

  • Configuración de IOS SIP: Habilita el SIP, el registro de teléfono con el proxy SIP, el ruteo de llamadas a través de trunks, el etc

  • Soporte de Correo de Voz: Cisco Unity Express

  • Configuración de Switch Catalyst: Dirección IP, Interfaces, etc

Ésta es la configuración completa necesaria para implementar un sistema CME con los trunks del SIP:

Router - Configuración CME
!
AUSNML-3825-01#show run
Building configuration...

Current configuration : 8634 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname AUSNML-3825-01
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$vBU1$MCMG1rXM5ejME8Wap6W0H1
!
no aaa new-model
clock timezone central -8
clock summer-time central recurring
ip cef
!

!--- DHCP Configuration ---

ip dhcp pool Voice
   network 172.22.100.0 255.255.255.0
   option 150 ip 172.22.1.107 
   default-router 172.22.100.1 
!
ip dhcp pool Data
   network 172.22.101.0 255.255.255.0
   option 150 ip 172.22.1.107 
   default-router 172.22.101.1 
!
!
ip domain name cisco.com
ip name-server 205.152.0.20
multilink bundle-name authenticated
!
voice-card 0
 no dspfarm
!
!
!
!

!--- Voice Class and Service VoIP Configuration ---

voice service voip 
 allow-connections sip to sip
 no supplementary-service sip moved-temporarily

!---Disable 302 sending

 no supplementary-service sip refer

!---Disable REFER sending

 sip
  registrar server expires max 3600 min 3600
  localhost dns:domain.test.com 
!
!
voice class codec 1
 codec preference 1 g711ulaw
!
!
!
!
!
!
!
!
!
!
!

!--- Voice Translation Rules ---

voice translation-rule 1
 rule 1 /5123781291/ /601/

!--- An inbound rule for AA pilot "601

 rule 2 /5123781290/ /600/

!--- An inbound rule for the voicemail pilot "600"

!
voice translation-rule 2
 rule 1 /^911$/ /911/

!--- An outbound rule to allow "911"

 rule 2 /^9\(.*\)/ /\1/


!--- An outbound rule to strip "9" from PSTN calls

!
voice translation-rule 3
 rule 1 /^.*/ /5123781291/

!--- An outbound rule to change calling-number CLID to a
!--- "main" number

!
voice translation-rule 4
 rule 1 /^9(.......)$/ /512\1/

!--- An outbound rule to add areacode for local calls

 rule 2 /600/ /5123788000/

!--- An outbound rule to present the voicemail pilot extension as DID

 rule 3 /601/ /5123788001/

!--- An outbound rule to present the AA pilot extension as DID

 rule 4 /^2(..)$/ /51237812\1/

!--- An outbound rule to support transfers and call-forwards

 rule 5 /^9(.*)/ /\1/

!--- An outbound rule to strip "9" from "9+" transfers and call-forwards

!
!
voice translation-profile CUE_Voicemail/AutoAttendant

!--- Applied to the inbound dial-peers for CUE

 translate called 1
!
voice translation-profile PSTN_CallForwarding

!--- Applied to CUE dial-peers

 translate redirect-target 4
 translate redirect-called 4
!
voice translation-profile PSTN_Outgoing

!--- Applied to all outbound dial-peers

 translate calling 3
 translate called 2
 translate redirect-target 4
 translate redirect-called 4
!
!
!
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!

!--- Internet Connection Configuration ---

interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 media-type rj45
 no keepalive
!
interface GigabitEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 172.22.1.71 255.255.255.0
!
interface GigabitEthernet0/0.20
 encapsulation dot1Q 20
 ip address 172.22.101.1 255.255.255.0
!
interface GigabitEthernet0/0.100
 encapsulation dot1Q 100
 ip address 172.22.100.1 255.255.255.0
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 media-type rj45
 no keepalive
!
interface Service-Engine1/0
 ip unnumbered GigabitEthernet0/0.1
 service-module ip address 172.22.1.253 255.255.255.0
 service-module ip default-gateway 172.22.1.71
!
ip route 0.0.0.0 0.0.0.0 172.22.1.1
ip route 172.22.1.253 255.255.255.255 Service-Engine1/0
!
!
ip http server
no ip http secure-server
!
!
!

!--- TFTP Server Configuration  ---

tftp-server flash:P0030702T023.bin
tftp-server flash:P0030702T023.loads
tftp-server flash:P0030702T023.sb2
tftp-server flash:P0030702T023.sbn
!
control-plane
!
!
!
!
!
!
!

!--- SIP Trunk Configuration ---

dial-peer voice 1 voip
 description **Incoming Call from SIP Trunk**
 translation-profile incoming CUE_Voicemail/AutoAttendant
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 incoming called-number .%
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 2 voip
 description **Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9........
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 3 voip
 description **Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9[2-9]..[2-9]......
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 4 voip
 description **Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9[0-1][2-9]..[2-9]......
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 5 voip
 description **911 Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 911
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 6 voip
 description **Emergency Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9911
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 7 voip
 description **911/411 Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9[2-9]11
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 8 voip
 description **International Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9011T
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 9 voip
 description **Star Code to SIP Trunk**
 destination-pattern *..
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!

!--- Voicemail Configuration ---

dial-peer voice 10 voip
 description **CUE Voicemail**
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 600
 b2bua

!--- Used by CME to send its IP address to SP proxy instead of CUE

 session protocol sipv2
 session target ipv4:172.22.1.155
 dtmf-relay sip-notify

!--- This can also be RFC2833 going to CUE

 codec g711ulaw

!--- CUE only supports G711ulaw as the codec

 no vad

!--- With VAD enabled, messages left on CUE could be blank or poor quality

!
!
!
dial-peer voice 11 voip
 description **CUE Auto Attendant**
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 601
 b2bua
 session protocol sipv2
 session target ipv4:172.22.1.155
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
!

!--- SIP UA Configuration ---

sip-ua 
 authentication username 5123781000 password 075A701E1D5E415447425B
 no remote-party-id
 retry invite 2
 retry register 10
 retry options 0
 timers connect 100
 registrar dns:domain.test.com expires 3600
 sip-server dns:domain.test.com
  host-registrar
!
!

!--- CME Telephony Service Configuration ---

telephony-service
 no auto-reg-ephone
 load 7960-7940 P0030702T023
 max-ephones 168
 max-dn 500
 ip source-address 172.22.1.107 port 2000
 calling-number initiator

!--- Preserves the caller-id of a call when transferred or forwarded

 dialplan-pattern 1 51237812.. extension-length 3 extension-pattern 2.. no-reg
 voicemail 600
 max-conferences 12 gain -6
 call-forward pattern .T
 call-forward system redirecting-expanded

!--- Enables translation rule features for call-forwarding

 moh music-on-hold.au
 transfer-system full-consult dss
 transfer-pattern 9.T
 secondary-dialtone 9
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!

!--- Ephone and Ephone-dn Configuration ---

ephone-dn  11  dual-line
 number 201 secondary 5123781201 no-reg both

!---"no-reg both" means do not try to register either extension with SP SIP Proxy

 name John Smith
 call-forward busy 600
 call-forward noan 600 timeout 15
!
!
ephone-dn  12  dual-line
 number 202 secondary 5123781202 no-reg both
 name Enrique Zurita
 call-forward busy 600
 call-forward noan 600 timeout 15
!
!
ephone-dn  13
 number 5123788000
 description **DID Number for Voicemail**
!
!
ephone-dn  14
 number 5123788001
 description **DID Number for Auto Attendant*
!
!
ephone-dn  15
 number 8000... no-reg primary
 mwi on
!
!
ephone-dn  16
 number 8001... no-reg primary
 mwi off
!
!
ephone  1
 mac-address 0008.A371.28E9
 type 7960
 button  1:11
!
!
!
ephone  2
 mac-address 0008.A346.5C7F
 type 7960
 button  1:12
!
!
!
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 password ut69coe
 login
!
scheduler allocate 20000 1000
ntp server 172.22.1.107
!
end

Router - Configuración de CUE
se-172-22-1-253#show run
 
Generating configuration:


clock timezone America/Chicago

hostname se-172-22-1-253

ip domain-name localdomain



groupname Administrators create
groupname Broadcasters create


!--- Users ---

username Enrique create
username John create
username Enrique phonenumberE164 "5123781202"
username John phonenumberE164 "5123781201"
username Enrique phonenumber "202"
username John phonenumber "201"


!--- AutoAttendant ---

ccn application autoattendant
 description "**AutoAttendant**"
 enabled
 maxsessions 4
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "operExtn" "601"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "disconnectAfterMenu" "false"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "false"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "businessSchedule" "systemschedule"
 parameter "MaxRetry" "3"
 end application


!--- MWI ---

ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "CallControlGroupID" "0"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 end application


!--- Voicemail ---

ccn application voicemail
 description "**Voicemail**"
 enabled
 maxsessions 4
 script "voicebrowser.aef"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 end application


!--- SIP ---

ccn subsystem sip
 gateway address "172.22.100.1"

!--- Must match the "ip source-address" in telephony-service

 dtmf-relay sip-notify
 mwi sip outcall

!--- Subscribe / Notify and Unsolicited Notify have not been tested

 transfer-mode blind bye-also

!--- Testing with REFER method on CUE has caused certain call flows to break

 end subsystem


!--- Trigger Phones ---

ccn trigger sip phonenumber 600
 application "voicemail"
 enabled
 maxsessions 4
 end trigger

ccn trigger sip phonenumber 601
 application "autoattendant"
 enabled
 maxsessions 4
 end trigger

service phone-authentication
 end phone-authentication

service voiceview
 enable
 end voiceview


!--- Voicemail Mailboxes ---

voicemail default mailboxsize 21120
voicemail broadcast recording time 300

voicemail mailbox owner "Enrique" size 300
 description "**Enrique_Mailbox**"
 expiration time 10
 messagesize 120
 end mailbox

voicemail mailbox owner "John" size 300
 description "**John'sMailbox**"
 expiration time 10
 messagesize 120
 end mailbox

end

Configuración del switch

!--- Interface Connected to CME/CUE Router ---

interface FastEthernet0/2
 description Trunk to 3825
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no ip address
 duplex full
 speed 100


!--- Interfaces Connected to the IP Phones ---

interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20

!--- Data Traffic ---

 switchport mode trunk
 switchport voice vlan 100

!--- Voice Traffic ---

 no ip address
 spanning-tree portfast


interface FastEthernet0/8
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20
 switchport mode trunk
 switchport voice vlan 100
 no ip address
 spanning-tree portfast
 

!--- IP Address ---

interface Vlan1
 ip address 172.22.1.194 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.22.1.1
ip http server

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Nota: Consulte Información Importante sobre Comandos de Debug antes de usar un comando debug.

Registro de Troubleshooting

Troubleshooting del trunk del SIP en el CME incluye los mismos comandos que utiliza para el troubleshooting del SIP GW IOS y el troubleshooting CME. Use estos comandos para verificar si se registra su DN:

  • show sip-ua register status — Use este comando para mostrar el estado de los números E.164 que un gateway de SIP ha registrado con un registro de SIP primario externo.

  • ccsip message del debug - Habilita todo el seguimiento de mensajes SIP SPI, como aquellos que se intercambian entre el cliente usuario-agente SIP (UAC) y el servidor de acceso.

Troubleshooting de la Configuración de Llamadas

Los comandos para las llamadas de troubleshooting a través de trunks son esencialmente los mismos que usa para eltroubleshooting del SIP GW y CME habitual.

Comandos show:

  • show ephone registered — Verifica registración ephone.

  • show voip rtp connection — Muestra información acerca de los paquetes RTP named-event, como el número de ID de llamada, dirección IP, y puertos para los extremos localesy remotos.

  • show sip-ua call — Muestra información sobre UAC activa y el servidor usuario agente (UAS) sobre las llamadas SIP.

  • show call active voice brief — Muestra información de llamas activas para llamadas de voz o transmisiones por fax en curso.

Comandos debug:

  • debug ccsip message — Habilita todo el seguimiento de mensajes SIP SPI, como aquellos que se intercambian entre SIP UAC y el servidor de acceso.

  • debug voip ccapi inout — Localiza la trayectoria de ejecución a través de API de control de llamadas.

  • debug voice translation — Verifica la funcionalidad de una regla de traducción.

  • debug ephone detail mac-address <mac of phone> — Establece debugging en detalle para el teléfono IP de Cisco.

  • debug voip rtp session named-events — Habilita debugging para los paquetes de eventos denominados de Real-Time Transport Protocol (RTP).

  • debug sccp message — Muestra la secuencia de los mensajes SCCP.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 91535